Sie sind auf Seite 1von 7

R3#debug eigrp packets

EIGRP Packets debugging is on


(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, S
IAREPLY)
R3#
*Aug 25 07:48:42.207: EIGRP: Sending HELLO on Serial0/2/0
*Aug 25 07:48:42.207: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:42.819: EIGRP: Sending HELLO on Loopback1
*Aug 25 07:48:42.819: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:42.819: EIGRP: Received HELLO on Loopback1 nbr 10.3.1.3
*Aug 25 07:48:42.819: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:48:42.819: EIGRP: Packet from ourselves ignored
*Aug 25 07:48:42.971: EIGRP: Received HELLO on Serial0/2/0 nbr 192.168.23.2
*Aug 25 07:48:42.971: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#
*Aug 25 07:48:43.143: EIGRP: Sending HELLO on Loopback3
*Aug 25 07:48:43.143: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:43.143: EIGRP: Received HELLO on Loopback3 nbr 10.3.3.3
*Aug 25 07:48:43.143: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:48:43.143: EIGRP: Packet from ourselves ignored
*Aug 25 07:48:43.795: EIGRP: Received HELLO on Serial0/1/1 nbr 192.168.13.1
*Aug 25 07:48:43.795: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
*Aug 25 07:48:44.063: EIGRP: Sending HELLO on Serial0/1/1
*Aug 25 07:48:44.063: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R3#
*Aug 25 07:48:44.587: EIGRP: Sending HELLO on Loopback2
*Aug 25 07:48:44.587: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:44.587: EIGRP: Received HELLO on Loopback2 nbr 10.3.2.3
*Aug 25 07:48:44.587: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:48:44.587: EIGRP: Packet from ourselves ignored
R3#
*Aug 25 07:48:47.195: EIGRP: Sending HELLO on Serial0/2/0
*Aug 25 07:48:47.195: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:47.699: EIGRP: Sending HELLO on Loopback1
*Aug 25 07:48:47.699: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:47.699: EIGRP: Received HELLO on Loopback1 nbr 10.3.1.3
*Aug 25 07:48:47.699: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:48:47.699: EIGRP: Packet from ourselves ignored
*Aug 25 07:48:47.891: EIGRP: Received HELLO on Serial0/2/0 nbr 192.168.23.2
*Aug 25 07:48:47.891: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#
*Aug 25 07:48:47.899: EIGRP: Sending HELLO on Loopback3
*Aug 25 07:48:47.899: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:47.899: EIGRP: Received HELLO on Loopback3 nbr 10.3.3.3
*Aug 25 07:48:47.899: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:48:47.899: EIGRP: Packet from ourselves ignored
*Aug 25 07:48:48.155: EIGRP: Received HELLO on Serial0/1/1 nbr 192.168.13.1
*Aug 25 07:48:48.155: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#
*Aug 25 07:48:48.939: EIGRP: Sending HELLO on Serial0/1/1
*Aug 25 07:48:48.939: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:49.295: EIGRP: Sending HELLO on Loopback2
*Aug 25 07:48:49.295: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:48:49.295: EIGRP: Received HELLO on Loopback2 nbr 10.3.2.3
*Aug 25 07:48:49.295: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:48:49.295: EIGRP: Packet from ourselves ignored

R3#
*Aug 25 07:48:51.859:
*Aug 25 07:48:51.859:
*Aug 25 07:48:52.407:
*Aug 25 07:48:52.407:
*Aug 25 07:48:52.407:
*Aug 25 07:48:52.407:
*Aug 25 07:48:52.407:
*Aug 25 07:48:52.471:
*Aug 25 07:48:52.471:
*Aug 25 07:48:52.471:
R3#
*Aug 25 07:48:52.471:
*Aug 25 07:48:52.471:
*Aug 25 07:48:52.539:
*Aug 25 07:48:52.539:
erQ un/rely 0/0
*Aug 25 07:48:52.923:
*Aug 25 07:48:52.923:
erQ un/rely 0/0
*Aug 25 07:48:53.411:
*Aug 25 07:48:53.411:
R3#
*Aug 25 07:48:54.191:
*Aug 25 07:48:54.191:
*Aug 25 07:48:54.191:
*Aug 25 07:48:54.191:
*Aug 25 07:48:54.191:
R3#
*Aug 25 07:48:56.815:
*Aug 25 07:48:56.815:
*Aug 25 07:48:57.251:
*Aug 25 07:48:57.251:
erQ un/rely 0/0
*Aug 25 07:48:57.307:
*Aug 25 07:48:57.307:
*Aug 25 07:48:57.307:
*Aug 25 07:48:57.307:
*Aug 25 07:48:57.307:
R3#
*Aug 25 07:48:57.351:
*Aug 25 07:48:57.351:
*Aug 25 07:48:57.351:
*Aug 25 07:48:57.351:
*Aug 25 07:48:57.351:
*Aug 25 07:48:57.679:
*Aug 25 07:48:57.679:
erQ un/rely 0/0
*Aug 25 07:48:57.843:
*Aug 25 07:48:57.843:
R3#
*Aug 25 07:48:58.971:
*Aug 25 07:48:58.971:
*Aug 25 07:48:58.971:
*Aug 25 07:48:58.971:
*Aug 25 07:48:58.971:
R3#
*Aug 25 07:49:01.603:
*Aug 25 07:49:01.603:
*Aug 25 07:49:01.611:

EIGRP: Sending HELLO on Serial0/2/0


AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Sending HELLO on Loopback1
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Loopback1 nbr 10.3.1.3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
EIGRP: Packet from ourselves ignored
EIGRP: Sending HELLO on Loopback3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Loopback3 nbr 10.3.3.3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
EIGRP: Packet from ourselves ignored
EIGRP: Received HELLO on Serial0/2/0 nbr 192.168.23.2
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
EIGRP: Received HELLO on Serial0/1/1 nbr 192.168.13.1
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
EIGRP: Sending HELLO on Serial0/1/1
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Sending HELLO on Loopback2
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Loopback2 nbr 10.3.2.3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
EIGRP: Packet from ourselves ignored
EIGRP: Sending HELLO on Serial0/2/0
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Serial0/2/0 nbr 192.168.23.2
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
EIGRP: Sending HELLO on Loopback1
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Loopback1 nbr 10.3.1.3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
EIGRP: Packet from ourselves ignored
EIGRP: Sending HELLO on Loopback3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Loopback3 nbr 10.3.3.3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
EIGRP: Packet from ourselves ignored
EIGRP: Received HELLO on Serial0/1/1 nbr 192.168.13.1
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
EIGRP: Sending HELLO on Serial0/1/1
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Sending HELLO on Loopback2
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Received HELLO on Loopback2 nbr 10.3.2.3
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
EIGRP: Packet from ourselves ignored
EIGRP: Sending HELLO on Serial0/2/0
AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
EIGRP: Sending HELLO on Loopback1

*Aug 25 07:49:01.611: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:01.611: EIGRP: Received HELLO on Loopback1 nbr 10.3.1.3
*Aug 25 07:49:01.611: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:49:01.611: EIGRP: Packet from ourselves ignored
*Aug 25 07:49:02.075: EIGRP: Received HELLO on Serial0/2/0 nbr 192.168.23.2
*Aug 25 07:49:02.075: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#
*Aug 25 07:49:02.147: EIGRP: Sending HELLO on Serial0/1/1
*Aug 25 07:49:02.147: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:02.235: EIGRP: Sending HELLO on Loopback3
*Aug 25 07:49:02.235: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:02.235: EIGRP: Received HELLO on Loopback3 nbr 10.3.3.3
*Aug 25 07:49:02.235: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:49:02.235: EIGRP: Packet from ourselves ignored
*Aug 25 07:49:02.383: EIGRP: Received HELLO on Serial0/1/1 nbr 192.168.13.1
*Aug 25 07:49:02.383: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#
*Aug 25 07:49:03.939: EIGRP: Sending HELLO on Loopback2
*Aug 25 07:49:03.939: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:03.939: EIGRP: Received HELLO on Loopback2 nbr 10.3.2.3
*Aug 25 07:49:03.939: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:49:03.939: EIGRP: Packet from ourselves ignored
R3#un all
*Aug 25 07:49:05.967: EIGRP: Sending HELLO on Serial0/2/0
*Aug 25 07:49:05.967: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:06.051: EIGRP: Sending HELLO on Loopback1
*Aug 25 07:49:06.051: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:06.051: EIGRP: Received HELLO on Loopback1 nbr 10.3.1.3
*Aug 25 07:49:06.051: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:49:06.051: EIGRP: Packet from ourselves ignored
*Aug 25 07:49:06.695: EIGRP: Received HELLO on Serial0/2/0 nbr 192.168.23.2
*Aug 25 07:49:06.695: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#un all
Port Statistics for unclassified packets is not turned on.
All possible debugging has been turned off
R3#
*Aug 25 07:49:06.871: EIGRP: Sending HELLO on Loopback3
*Aug 25 07:49:06.871: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:06.871: EIGRP: Received HELLO on Loopback3 nbr 10.3.3.3
*Aug 25 07:49:06.871: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Aug 25 07:49:06.871: EIGRP: Packet from ourselves ignored
*Aug 25 07:49:06.911: EIGRP: Sending HELLO on Serial0/1/1
*Aug 25 07:49:06.911: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Aug 25 07:49:07.159: EIGRP: Received HELLO on Serial0/1/1 nbr 192.168.13.1
*Aug 25 07:49:07.159: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 pe
erQ un/rely 0/0
R3#wr
Building configuration...
[OK]
R3#
R3#
R3#
R3#
R3#
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#route eig
% Ambiguous command: "route eig"
R3(config)#route eigrp
% Ambiguous command: "route eigrp"
R3(config)#router eigrp
R3(config)#router eigrp 100
R3(config-router)#no net 10.3.1.0
R3(config-router)#end
R3#sho run
Building configuration...
*Aug 25 07:51:50.491: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1420 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
no ip ips deny-action ips-interface
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

no crypto isakmp ccm


!
!
!
!
interface Loopback1
ip address 10.3.1.3 255.255.255.0
!
interface Loopback2
ip address 10.3.2.3 255.255.255.0
!
interface Loopback3
ip address 10.3.3.3 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/1/1
description "Connect to R1"
ip address 192.168.13.3 255.255.255.0
!
interface Serial0/2/0
description "Connect to R2"
ip address 192.168.23.3 255.255.255.0
clockrate 2000000
!
interface Serial0/2/1
no ip address
clockrate 2000000
!
router eigrp 100
network 192.168.13.0
network 192.168.23.0
auto-summary
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane

!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
end
R3#
R3#sho ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(192.168.23.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.2.1.0/24, 1 successors, FD is 2297856
via 192.168.23.2 (2297856/128256), Serial0/2/0
P 10.2.2.0/24, 1 successors, FD is 2297856
via 192.168.23.2 (2297856/128256), Serial0/2/0
P 10.2.3.0/24, 1 successors, FD is 2297856
via 192.168.23.2 (2297856/128256), Serial0/2/0
P 192.168.13.0/24, 1 successors, FD is 2169856
via Connected, Serial0/1/1
P 192.168.23.0/24, 1 successors, FD is 2169856
via Connected, Serial0/2/0
R3#sho ip int br
Interface
IP-Address
OK? Method Status
Prot
ocol
FastEthernet0/0
unassigned
YES unset administratively down down
FastEthernet0/1

unassigned

YES unset administratively down down

Serial0/1/0

unassigned

YES unset administratively down down

Serial0/1/1

192.168.13.3

YES manual up

up

Serial0/2/0

192.168.23.3

YES manual up

up

Serial0/2/1

unassigned

YES manual down

down

Loopback1

10.3.1.3

YES manual up

up

Loopback2

10.3.2.3

YES manual up

up

Loopback3

10.3.3.3

YES manual up

up

R3#sh ip route eigrp


D
192.168.12.0/24 [90/2681856] via 192.168.23.2, 00:08:30, Serial0/2/0
[90/2681856] via 192.168.13.1, 00:08:30, Serial0/1/1

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks


D
10.2.0.0/22 [90/2297856] via 192.168.23.2, 00:01:24, Serial0/2/0
R3#sho run int s0/2/0
Building configuration...
Current configuration : 171 bytes
!
interface Serial0/2/0
description "Connect to R2"
ip address 192.168.23.3 255.255.255.0
ip summary-address eigrp 100 10.3.0.0 255.255.252.0 5
clockrate 2000000
end
R3#ping 10.2.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
D

192.168.12.0/24 [90/2681856] via 192.168.23.2, 00:09:46, Serial0/2/0


[90/2681856] via 192.168.13.1, 00:09:46, Serial0/1/1
C
192.168.13.0/24 is directly connected, Serial0/1/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C
10.3.1.0/24 is directly connected, Loopback1
D
10.2.0.0/22 [90/2297856] via 192.168.23.2, 00:02:40, Serial0/2/0
C
10.3.3.0/24 is directly connected, Loopback3
C
10.3.2.0/24 is directly connected, Loopback2
C
192.168.23.0/24 is directly connected, Serial0/2/0
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#network 10.0.0.0
R3#sho ip route eigrp
D
192.168.12.0/24 [90/2681856] via 192.168.23.2, 00:11:23, Serial0/2/0
[90/2681856] via 192.168.13.1, 00:11:23, Serial0/1/1
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D
10.2.0.0/22 [90/2297856] via 192.168.23.2, 00:04:17, Serial0/2/0
D
10.3.0.0/22 is a summary, 00:00:19, Null0
D
10.0.0.0/8 is a summary, 00:00:19, Null0