Sie sind auf Seite 1von 61

Schnupperkurs-Handbuch „Erfassen,

Analysieren und Darstellen mit NI LabVIEW“

Übung Nr. 1: Ausführen eines LabVIEW-VIs


Überblick
Zweck
Diese Demo bietet eine Einführung in die Entwicklungsumgebung NI LabVIEW.

Voraussetzungen

Hardware Software
keine • LabVIEW
• Lissajous.vi

Anleitungen für die Übung


1. Starten Sie das VI Lissajous.vi. Es befindet sich im Ordner
C:\Schnupperkurse\LabVIEW\Demos.
2. Führen Sie das VI aus, um eine Vorschau auf die Fähigkeiten von LabVIEW zu erhalten.

© National Instruments Corporation 1 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
3. Verändern Sie die Steuergrößen, um Änderungen im Graphen anzuzeigen.
4. Es wird deutlich, wie einfach das Blockdiagramm insbesondere dank der Express-VIs ist.

5. Halten Sie das VI an, wenn Sie fertig sind, und schließen Sie es.

Ende der Demo 1

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 2 ni.com


Übung Nr. 2: Die Entwicklungsumgebung NI LabVIEW
Überblick
Zweck
Diese Demo dient zur Vorbereitung auf die Arbeit mit der Umgebung NI LabVIEW. Dabei werden das
Frontpanel, das Blockdiagramm und die Paletten erklärt. Weiterer Bestandteil der Demo ist zudem die
Erstellung der Demo 2, die simulierte Daten verwendet, diese Daten in einem Diagramm darstellt und
diesen Wert mit einem festgelegten Grenzwert vergleicht.

Voraussetzungen

Hardware Software
keine • LabVIEW
• LabVIEW Demo.vi

Anleitungen für die Übung


1. Öffnen Sie das VI LabVIEW Demo.vi, das sich im Ordner
C:\Schnupperkurse\LabVIEW\Demos befindet.
2. Starten Sie das VI.

3. Machen Sie sich mit der Entwicklungsumgebung (Frontpanel, Blockdiagramm, Paletten) vertraut.
4. Schließen Sie das VI.
© National Instruments Corporation 3 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Erstellen des LabVIEW-Demo-VIs
1. Klicken Sie auf Datei und wählen Sie Neu…, um den Application Template Browser zu öffnen. Es
wird das Fenster Neu geöffnet, auf dessen linker Seite Sie die nach Kategorien sortierten
Applikationsvorlagen sehen. Zum einen besteht hier die Möglichkeit, Leeres VI zur Erstellung eines
Tasks zu wählen. Zum anderen stehen auch Vorlagen-VIs zur Verfügung, die als Grundlage für die
Anwendungserstellung verwendet werden können. Es gibt zahlreiche weitere Optionen, bei denen es
sich um weiterentwickelte Komponenten handelt, auf die im Folgenden nicht weiter eingegangen wird.
Nähere Informationen zu allen Einträgen im Application Template Browser erhalten Sie, indem Sie
auf die Schaltfläche Hilfe in der unteren rechten Ecke des Fensters klicken.
2. Wählen Sie VI» Aus Vorlage» Tutorium (Erste Schritte) und anschließend Generieren und
anzeigen. Bestätigen Sie mit OK.

3. Führen Sie das VI aus. Es läuft so ab, wie es erstellt wurde. Später werden einige Funktionen ergänzt.
4. Betrachten Sie die Elementepalette und insbesondere die Express-Paletten sowie die weiteren
Standardpaletten. Vervollständigen Sie das Frontpanel für das VI.
• Fügen Sie folgende Elemente ein: Führen Sie einen Rechtsklick auf jedes Element aus und wählen
Sie Eigenschaften, um auf die Seiten mit den jeweiligen Eigenschaften zu gelangen. Ändern Sie
die Eigenschaften entsprechenden.
• Schieber mit Zeiger (vertikal) (unter Express» Numerische Bedienelemente) mit den
Eigenschaften:
Beschriftung: Grenze (Limit)

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 4 ni.com


Skalierung: –10 bis +10
• LED (rund) unter Express» LEDs mit den Eigenschaften:
Beschriftung: Alarm

5. Erstellen Sie das Blockdiagramm mithilfe der Tastenkombination <Strg+E>.

© National Instruments Corporation 5 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
a. Fügen Sie die folgenden VIs und Funktionen hinzu:
• Express-VI-Vergleich [In der Unterpalette: Express» Arithmetik & Vergleich» Vergleich
(Express)] mit den Eigenschaften:
Vergleichsbedingung: > Größer
Vergleichseingänge: Zweites Signal (Eingang)

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 6 ni.com


• Die Beispieldaten beim Eingangssignal und im Fenster Vorschau sind nur ein Platzhalter,
bis Sie das VI ausgeführt haben. Die Abtastwerte werden später durch die echten Daten
ersetzt, die verwendet werden. Es können aktuell erfasste oder simulierte Daten sein. Das ist
besonders hilfreich bei den leistungsstarken Analysefunktionen, auf die später noch
eingegangen wird.
• Durch einen Doppelklick auf das VI Signal simulieren öffnet sich die dazugehörige
Konfigurationsseite. Dem Express-VI können unterschiedliche Werte zugewiesen werden.
Amplitude: 10

• Verdrahten Sie den Ausgang des VIs Signal simulieren und das Bedienelement
„Grenze“ im VI Vergleich und das Ergebnis mit dem booleschen Bedienelement „Alarm“.
6. Starten Sie das VI. (Mit der Tastenkombination <Strg+E> wechseln Sie in das Frontpanel.) Nutzen
Sie die Bedienelemente, um die Funktionsweise zu prüfen.
7. Schalten Sie im Blockdiagramm (mit der Tastenkombination <Strg+E> wechseln Sie in das
Blockdiagramm) die Highlight-Funktion ein.

Hier lässt sich die Datenflussprogrammierung veranschaulichen. Die Ausführung hat sich erheblich
verlangsamt und Sie sehen, wie die einzelnen Werte von einem Block an den nächsten übergeben
werden.
8. Schalten Sie die Highlight-Funktion danach wieder aus, wechseln Sie ins Frontpanel und beenden Sie
die Anwendung über die Schaltfläche Stopp.

© National Instruments Corporation 7 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
9. Öffnen Sie nun im Blockdiagramm per Doppelklick auf das Express-VI Vergleich das
Konfigurationsmenu des Express-VIs. Sie sehen, dass die Daten keine Beispielwerte mehr sind,
sondern die wirkliche Sinuskurve, die jetzt erzeugt wurde.
10. Speichern Sie das Programm als Demo2.vi auf dem Desktop und schließen Sie es. Sie werden
dieses VI in der nächsten Übung weiterverwenden.

Ende der Demo 2

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 8 ni.com


Übung Nr. 3: MAX und der DAQ-Assistent
Überblick
Zweck
Diese Demo baut auf der bereits erstellten LabVIEW-Demo auf. Hierin werden die simulierten Daten
durch echte Messdaten ersetzt. Sie lernen den Measurement Automation Explorer (MAX) kennen und
verwenden den DAQ-Assistenten zur Datenerfassung.

Voraussetzungen

Hardware Software
• Datenerfassungskarte • LabVIEW
• Datenerfassungskabel • Ab Version NI-DAQmx 8.2
• BNC-2120 oder DAQ-Demobox • Demo2.vi

Anleitungen für die Übung


Einführung in den Measurement Automation Explorer (MAX)
1. Öffnen Sie das in der Demo Nr. 2 erstellte VI Demo2.vi oder das Demo2.vi im Ordner
C:\Schnupperkurse\LabVIEW\Lösungen. Öffnen Sie den MAX vom Desktop oder aus
LabVIEW heraus über Werkzeuge» Measurement & Automation Explorer.
2. Gehen Sie die unterschiedlichen Konfigurations- und Fehlersuchfunktionen des MAX durch:
• Datenumgebung: Hier können Kanäle konfiguriert werden. Wenn DAQmx eingesetzt wird,
können Messungen direkt in LabVIEW mithilfe des DAQ-Assistenten konfiguriert werden.
• Geräte und Schnittstellen: Betrachten Sie die Eigenschaften der Geräte und Schnittstellen, öffnen
Sie das Testpanel eines der Geräte unter NI-DAQmx - Geräte, wählen Sie einen analogen
Eingang (z. B. einen ai0) und starten Sie die Erfassung über die Taste Start.

• Wenn Sie eine Fehlermeldung erhalten, bitte den Kursleiter um Hilfe bitten. Ansonsten beenden
Sie den Test über die Schaltfläche Stopp.

© National Instruments Corporation 9 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
3. Klicken Sie mit der rechten Maustaste auf Mein System» Geräte und Schnittstellen und wählen Neu
…. Wählen Sie im Dialogfenster zuerst Neues NI-DAQmx Gerät erzeugen… und im
Unterverzeichnis NI-DAQmx - Simulierte Geräte.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 10 ni.com


Im Fenster Gewähltes Gerät werden Sie zur Auswahl eines Geräts aufgefordert. Wählen Sie ein
beliebiges Gerät aus. Mithilfe dieser Liste können Sie die zahlreichen Geräte ansehen, die von NI-
DAQmx unterstützt werden.
4. Klicken Sie nach Ihrer Auswahl im Fenster Gewähltes Gerät auf OK, um das Fenster zu schließen.
Das mit NI-DAQmx simulierte Gerät erscheint im MAX. Die Farbe des Symbols des mit NI-DAQmx
simulierten Geräts unterscheidet sich von der von echten Geräten. Echte Geräte werden grün
dargestellt und simulierte Geräte gelb.

Konfigurieren einer Messung in LabVIEW


1. Öffnen Sie das in der Demo Nr. 2 erstellte VI Demo2.vi oder das Demo2.vi im Ordner
C:\Schnupperkurse\LabVIEW\Lösungen.
2. Wechseln Sie mit der Tastenkombination <Strg+E> in das Blockdiagramm und löschen Sie das
Express-VI Signal simulieren.
3. Fügen Sie die folgenden VIs und Funktionen hinzu, indem Sie diese per Drag&Drop aus der
Funktionspalette wählen (Rechtsklick mit der Maus ins Blockdiagramm öffnet die Funktionspalette):
Express-VI DAQ-Assistent (Express» Eingabe» DAQ-Assistent). Folgende Schritte sind im
Konfigurationsfenster zu wählen:
1.) Signalart: Analoge Erfassung» Spannung
© National Instruments Corporation 11 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
2.) Gerät und Kanal: Dev1 oder Dev2
(Hier müssen Sie den Namen des simulierten Datenerfassungsgeräts, das im Schritt 4 erstellt wurde,
eingeben. Sie sehen den Namen im MAX.)
ai0, ai1 (je nach gewünschtem Kanal auswählen: per Mausklick oder bei mehreren Kanälen mithilfe
der Strg- oder Shift-Taste)
Mit Beenden bestätigen.
3.) Einstellen der Task- und Timing-Parameter:
Kontinuierlich, zu lesende Werte 1000, Rate (Hz) 10000

4. Klicken Sie auf die Schaltfläche OK und verbinden Sie das Signal mit dem Anzeigeelement und dem
Vergleichs-Express-VI.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 12 ni.com


5. Das Blockdiagramm sollte dann wie folgt aussehen:

6. Speichern Sie das VI als Demo3.vi auf dem Desktop.


7. Starten Sie das VI. Die y-Achse des Diagramms sollte sich automatisch skalieren. Verändern Sie die
Einstellungen des Schiebereglers. Dadurch wird deutlich, dass der boolesche Wert nur einen Wahr-
Zustand (True) annimmt, wenn sich der Schiebereglerwert innerhalb des Bereichs der Sinuskurve
befindet.
8. Stoppen Sie das VI und kehren Sie zum Blockdiagramm zurück. Im nächsten Schritt wird erklärt, wie
der Programmcode geändert wird, um die Kommunikation mit einem realen anstelle eines simulierten
Datenerfassungsgeräts zu ermöglichen.
9. Führen Sie einen Doppelklick auf den DAQ-Assistenten aus, um den Konfigurationsassistenten erneut
zu öffnen. Ist der DAQ-Assistent offen, klicken Sie auf die zwei Pfeile neben Details anzeigen im
Fenster der Kanalansicht.

10. In diesem Fenster werden die physikalischen Kanäle angezeigt.


11. Führen Sie einen Rechtsklick auf den in diesem Fenster aufgeführten Kanal aus und wählen Sie
Physikalischen Kanal ändern… Im sich öffnenden Dialogfenster Kanäle neu ausrichten… wählen
Sie nun einen Kanal auf dem real vorhandenen Gerät Dev1 (das physikalische Datenerfassungsgerät
der E-Serie, das im Computer installiert ist – versichern Sie sich im MAX, dass der Name richtig
gewählt ist) »ai1 und bestätigen Sie mit OK. Klicken Sie dann im DAQ-Assistenten wieder auf OK,
um zum Blockdiagramm zurückzukehren.

© National Instruments Corporation 13 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Gehen Sie zurück zum Frontpanel und starten Sie das VI. Wenn das Messgerät mit einem BNC 2120 oder
einer DAQ-Demobox verbunden ist, können sie am jeweiligen Modul die Frequenz des erfassten Signals
ändern. Beobachten Sie dabei das Signal auf dem Frontpanel. Verändern Sie die Einstellungen des
Schiebereglers. Dadurch wird deutlich, dass der boolesche Wert nur einen Wahr-Zustand (True) annimmt,
wenn sich der Schiebereglerwert innerhalb des Bereichs der Sinuskurve

befindet.

Codeerstellung
HINWEIS: Sie benötigen die Treiberversion NI-DAQmx 8.2 oder höher, um Programmcode direkt aus
dem DAQ-Assistenten heraus zu erzeugen!
1. Nachfolgend wird das Express-VI des DAQ-Assistenten in LabVIEW-Programmcode umgewandelt.
Dadurch erhalten Sie eine weiter reichende Kontrolle über die Funktionalitäten der Erfassung und
können diese frei verändern und ergänzen.
2. Führen Sie einen Rechtsklick auf das Express-VI DAQ-Assistent aus und wählen Sie NI-DAQmx-
Code erzeugen.
3. Bereinigen Sie den erstellten Code bzw. die erzeugten Drähte (rechter Mausklick auf einen Draht und
„Verdrahtung bereinigen“ wählen).
4. Speichern Sie das veränderte VI NICHT ab.
Schließen Sie das VI, wenn Sie fertig sind.
Ende der Demo 3
Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 14 ni.com
Übung Nr. 4 (optional): DAQmx-Task-Erstellung und
automatische Codeerzeugung
Überblick
Zweck
Diese Demo soll die Funktion zur Codeerstellung in DAQmx zeigen. Es wird gezeigt, wie Code nach der
Erstellung eines Tasks erzeugt wird. Dadurch erhalten Sie eine weiter reichende Kontrolle über die
Funktionalitäten der Erfassung.

Voraussetzungen

Hardware Software
• Datenerfassungskarte der E-Serie • LabVIEW
• Datenerfassungskabel • Ab Version NI-DAQmx 7.1
• BNC-2120 oder DAQ-Demobox

Anleitungen für die Übung


Neues VI erstellen
1. Öffnen Sie ein neues Leeres VI in LabVIEW.
2. Öffnen Sie das Blockdiagramm.
3. Platzieren Sie das Element DAQmx Taskname auf dem Blockdiagramm (Mess-I/O» DAQmx –
Datenerfassung).
4. Wechseln Sie nun in den MAX (falls er nicht offen ist, öffnen Sie den MAX vom Desktop aus).
5. Führen Sie einen Rechtsklick auf den Eintrag Datenumgebung aus und wählen Sie Neu…
6. Wählen Sie in dem Konfigurationsfenster DAQmx Task und bestätigen Sie mit Weiter.
7. Es wird derselbe Task wie im vorherigen Beispiel (Demo 3) erstellt, um die unterschiedlichen
Möglichkeiten zur Erstellung von Tasks mit LabVIEW aufzuzeigen. Nehmen Sie hier folgende
Einstellungen vor:
1.) Signalart: Analoge Erfassung» Spannung
2.) Gerät und Kanal: Dev1 (entsprechend dem Namen der Datenerfassungskarte der E-Serie) » ai1.
Klicken Sie auf Weiter.
Taskname: Mein Spannungstask – Klicken Sie auf Beenden.
3.) Einstellen der Task- und Timing-Parameter: N Samples, Samples 10000 , Rate (Hz) 100000
8. Bestätigen Sie mit OK.

Der soeben angelegte Task (Messaufgabe) ist im MAX hinterlegt und kann von LabVIEW aus genutzt
werden. Wechseln Sie zu Ihrem neu angelegten LabVIEW-VI und öffnen Sie das Blockdiagramm.

© National Instruments Corporation 15 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
9. Klicken Sie mit der linken Maustaste auf den Pfeil nach unten auf dem Element DAQmx-Taskname
und wählen Sie den soeben im MAX angelegten Task aus.
10. Führen Sie nun einen Rechtsklick auf die Konstante aus und wählen Sie Programmcode-Erzeugung
und im Untermenü Konfiguration und Beispiel. Nun wird der Programmcode erzeugt, der notwendig
ist, um die Messaufgabe durchzuführen, die Sie im MAX konfiguriert haben. Darüber hinaus erzeugt
LabVIEW eine Beispielanwendung, welche die Messaufgabe durchführt und die Daten anzeigt.
Dieses Programmcodegerüst ist sofort ausführbar und kann beliebig erweitert werden.

11. Öffnen Sie das unbenannte SubVI. Hier können jetzt die Konfigurations- und Erfassungsparameter
programmatisch geändert werden.

12. Speichern Sie das SubVI als Channel Config.vi und schließen Sie es.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 16 ni.com


13. Fügen Sie eine While-Schleife hinzu (Express» Ausführungssteuerung).

© National Instruments Corporation 17 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Das Frontpanel sollte dann wie folgt aussehen:

14. Starten Sie das VI und bewegen Sie den Drehknopf Frequency Adjust (sowie den Drehregler
Amplitude Adjust/Amplitude anpassen am BNC 2120). Die Sinuskurve im Graphen verändert sich
dadurch.
15. Unterbrechen Sie die Ausführung des VIs, wenn Sie fertig sind.
16. Speichern Sie das VI als Demo4.vi auf dem Desktop und schließen Sie es.
Ende der Demo 4

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 18 ni.com


Übung Nr. 5: Gerätesteuerung
Überblick
Zweck
Diese Demo bietet eine Einführung in die Suchmaschine für NI-Gerätetreiber und den Assistenten für
Instrumenten-I/O (Instrument I/O Assistant) und zeigt, wie schnell Sie mithilfe von LabVIEW mit
Geräten kommunizieren können.

Voraussetzungen
Das Instrument Driver Network zum Treiber herunterladen setzt eine Internetverbindung voraus.

Hardware Software
• GPIB-Karte • LabVIEW
• GPIB-Kabel • NI-488.2 v2.4
• NI-Gerätesimulator oder softwareseitig
simuliertes Gerät (verwenden Sie ein
traditionelles Messgerät falls vorhanden)

Einrichten der Übung

Führen Sie folgende Schritte aus, falls Sie GPIB-Hardware verwenden:


• Öffnen Sie den MAX (durch Doppelklick auf das entsprechende Symbol auf dem Desktop).
Klicken Sie unter Geräte und Schnittstellen mit der rechten Maustaste auf die GPIB-
Karte. Wählen Sie Nach Geräten suchen. Mithilfe dieser Funktion wird der GPIB nach
mit ihm verbundenen Messgeräten durchsucht und diese Geräte werden aufgelistet.
Nachdem diese Funktion ihre Aufgabe beendet hat, findet sie den Gerätesimulator (oder das von Ihnen
verwendete herkömmliche Messgerät). Der Bus erkennt dieses Gerät mit dem Namen „Instrument0“ und
Primary Address „2“. Erscheint dieses Menü nicht, wurde entweder die GPIB-Karte oder der
Gerätesimulator nicht gefunden. Bitte fragen Sie in diesem Fall den Kursleiter.

Anleitungen für die Übung


Bei dieser Übung suchen Sie zuerst nach einem Gerätetreiber. Anschließend wird ein Messgerät
programmatisch abgefragt und Sie erhalten Angaben über den Hersteller. Über die Befehle, die auf dem
Simulator abgedruckt sind, kann mit dem Gerät kommuniziert werden.

Suche nach einem Gerätetreiber


Wählen Sie im LabVIEW-Fenster Erste Schritte im Abschnitt Neu den Punkt Leeres VI aus oder
verwenden Sie die Tastenkombination <Strg+N>, um ein leeres VI zu öffnen.
1. Wählen Sie auf dem Frontpanel Hilfe» Gerätetreiber suchen…. Ein Konfigurationsfenster
„Gerätetreiber suchen“ wird geöffnet.
© National Instruments Corporation 19 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Sie sehen auf der linken Seite alle installierten Geräte und verbundene Geräte, für die noch kein Treiber
installiert wurde. Für nicht installierte Geräte können Sie nun automatisch im Instrument Driver Network
nach Treibern suchen. Dazu müssen Sie mit dem Internet verbunden sein und benötigen ein
Benutzerkonto bei MyNI, welches Sie kostenlos einrichten können.

Wir werden auf ein bereits installiertes Gerät zugreifen und beenden die Installation an dieser Stelle.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 20 ni.com


Eine Suche im Internet könnte wie auf folgendem Bild dargestellt aussehen:

Verlassen Sie die Suchmaschine über Schließen. Öffnen Sie ein leeres VI und gehen Sie auf das
Blockdiagramm. Führen Sie einen Rechtsklick auf dem Blockdiagramm aus und wählen Sie
Instrumenten-I/O» Gerätetreiber. Hier sind alle installierten Gerätetreiber mit ihren Funktionen
aufgeführt und werden bereits in Unterpaletten angezeigt. LabVIEW muss nicht neu gestartet werden, um
einen zuvor hinzugefügten Gerätetreiber nutzen zu können.

© National Instruments Corporation 21 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Direkte Kommunikation mit Messgeräten ohne Treiber
1. Es stehen nicht immer Gerätetreiber für Ihr spezielles Messgerät zur Verfügung. Außerdem ist es
möglich, dass Ihre Anwendung die Verwendung eines Gerätetreibers nicht zulässt. In diesen Fällen
erlaubt der Assistent für Instrumenten-I/O mit nur geringem Programmieraufwand eine direkte
Gerätesteuerung.
2. Wählen Sie aus der Funktionspalette des Blockdiagramms Funktionen» Instrumenten-I/O»
Assistent für Instrumenten-I/O und platzieren Sie ihn auf das Diagramm. Das Fenster für den
Assistenten für Instrumenten-I/O wird geöffnet.
3. Das Gerät, mit dem kommuniziert werden soll, wird ausgewählt.
NI-Gerätesimulator: Wählen Sie hier aus dem Dropdown-Menü mit der Beschriftung Geräteauswahl
den Eintrag GPIB0::<pa>::INSTR. (dabei ist pa die Primäradresse des Geräts). Wird dieser
Listeneintrag nicht angezeigt, klicken Sie auf die Schaltfläche Geräteliste aktualisieren.1

1
Befindet sich der NI-Gerätesimulator noch immer nicht in der Geräteliste, gehen Sie zu MAX und wählen Sie unter der
entsprechenden GPIB-Schnittstelle Nach Geräten suchen. Wurde der Simulator in MAX gefunden, steht er in der Geräteliste zur
Verfügung.
Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 22 ni.com
4. Als nächstes wird in einem Schritt die Geräteidentifikation abgefragt und die Geräteantwort gelesen.
a. Klicken Sie auf die Schaltfläche Schritt hinzufügen und wählen Sie aus der sich öffnenden Liste
die Option Abfragen und Analysieren.
b. Das Editierfeld Befehl gestattet Ihnen die Eingabe des an das Gerät zu sendenden Befehls oder die
Auswahl eines schon einmal eingegebenen Befehls aus dem Dropdown-Listenfeld. Geben Sie den
Befehl *idn? ein. Dabei handelt es sich um einen allgemein üblichen Befehl, den die meisten
Geräte verstehen. Über ihn werden vom Gerät Daten zu dessen Hersteller und Gerätetyp
angefordert. Weitere Informationen zu gültigen Gerätebefehlen können Sie der Dokumentation
des Messinstruments entnehmen.
c. Klicken Sie zum Senden des Befehls und zum Empfangen der Geräteantwort auf die Schaltfläche
Diesen Schritt ausführen.
d. Die Geräteantwort wird im Antwortfenster, wie im Folgenden abgebildet, angezeigt:

© National Instruments Corporation 23 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
e. Sie haben die Möglichkeit, den gesamten Datensatz automatisch vom Assistenten für
Instrumenten-I/O analysieren zu lassen oder die Daten manuell zu analysieren. Die empfangenen
Daten werden im Antwortfenster im Binär- oder ASCII-Format bzw. Binär- und ASCII-Format
ausgegeben. Nehmen Sie die Auswahl des Formats, in dem die Daten im Antwortfenster
ausgegeben werden sollen, über das Dropdown-Listenfeld vor. Wählen Sie in dieser Übung für
die Anzeige der Daten Nur ASCII wie unten abgebildet.
f. Klicken Sie auf die Schaltfläche Auto-Analyse, um das Parsen der Daten in lesbare Zeichen zu
starten. Ein Daten-Token wird erzeugt, der in Ihrem VI als Ausgabestring gelesen werden kann.
Tragen Sie im Feld Token Name „Hersteller und Typ“ ein. Ihr Fenster sollte nun der folgenden
Abbildung entsprechen:

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 24 ni.com


5. Nachdem das Gerät identifiziert wurde, soll nun ein Befehl für das Gerät geschrieben werden,
demzufolge es eine Sinuskurve erstellt.
a. Klicken Sie auf die Schaltfläche Schritt hinzufügen und wählen Sie die Option Schreiben und
Formatieren. Über diesen Schritt erfolgt der Versand eines Befehls an das Gerät.
b. Geben Sie in das Editierfeld Befehl folgenden Befehl ein: SOUR:FUNC<Leerzeichen>
Klicken Sie nach der Eingabe des Leerzeichens auf die Schaltfläche Parameter hinzufügen. Es
erscheint ein Standardparameter mit der Bezeichnung VOLT:DC.

c. Dieser Parameter wird ein Eingang für den Block Assistent für Instrumenten-I/O, der Ihnen
eine programmatische Kontrolle der Art des Signalverlaufs, der vom Instrument erzeugt wird,
erlaubt.
d. Geben Sie im Abschnitt Gewählte Parametereinstellungen des Konfigurationsfensters die
Signalform im Textfeld Parametername ein.
e. Wählen Sie Ring als Datentyp. Nach Auswahl von Ring wird eine Tabelle mit Parameterwerten
und Befehlsstrings geöffnet. Vervollständigen Sie die Tabelle wie im Folgenden abgebildet:
© National Instruments Corporation 25 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Parameter- Befehlsstring
wert
Sinus SIN
Rechteck SQU
Rauschen RAND

f. Zum Versand des Befehls an das Gerät klicken Sie auf die Schaltfläche Diesen Schritt ausführen.
Hinweis: Es wird zu diesem Zeitpunkt noch keine sichtbare Antwort vom Gerät kommen. Im
nächsten Schritt wird das Gerät nach der Sinuskurve abgefragt.

6. Das vom Gerät erstellte Signal wird gelesen.


a. Klicken Sie auf die Schaltfläche Schritt hinzufügen und wählen Sie aus der sich öffnenden Liste
die Option Abfragen und Analysieren. Geben Sie den Befehl SENS:DATA? ein.
b. Den Versand des Befehls und den Empfang der Geräteantwort starten Sie durch einen Mausklick
auf die Schaltfläche Diesen Schritt ausführen.
c. Klicken Sie auf die Schaltfläche Auto-Analyse. Weisen Sie diesem Token den Namen
Gerätedaten zu.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 26 ni.com


7. Bestätigen Sie nun abschließend die Konfiguration dieser Kommunikationsaufgabe mit Klick auf die
Schaltfläche OK. Nun wird der Programmcode erzeugt, der nacheinander die Kommunikation mit
dem Messgerät durchführt.

Hinzufügen von Bedien- und Anzeigeelementen des


Frontpanels
a. Führen Sie einen Rechtsklick auf den Eingang Signaltyp aus und wählen Sie Erstellen»
Bedienelement, um ein Ring-Bedienelement auf der Benutzeroberfläche zur Auswahl des
Signaltyps, den das Gerät erzeugen wird, zu erstellen.
b. Führen Sie einen Rechtsklick auf den Ausgang Hersteller aus und wählen Sie Erstellen»
Anzeigeelement, um ein String-Anzeigeelement zu erstellen, das den Gerätehersteller anzeigt.
c. Führen Sie einen Rechtsklick auf den Ausgang Gerätedaten aus und wählen Sie Erstellen»
Graph-Anzeige, um einen Graphen auf dem Frontpanel zu erstellen, der die Gerätewerte
anzeigt.

© National Instruments Corporation 27 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Folgendes Programm liegt nun vor und kann ausgeführt werden:

Variieren Sie die Signalform und führen Sie das Programm mehrfach aus. Beobachten Sie dabei auch die
LEDs des Gerätesimulators, die Ihnen die Vorgänge auf dem Gerät anzeigen.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 28 ni.com


In Programmcode umwandeln (optional)
1. Führen Sie einen Rechtsklick auf den Assistenten für Instrumenten-I/O aus und wählen Sie
Frontpanel öffnen. Es öffnet sich ein Dialogfeld, das Ihnen die Umwandlung des VIs in ein
Standard-SubVI ermöglicht. Wählen Sie Umwandeln. So können Sie die
Kommunikationskonfiguration in einem separaten VI speichern.
2. Dann öffnet sich das Frontpanel des Codes für den I/O-Assistenten. Wechseln Sie mithilfe der
Tastenkombination <Strg+E> zum Blockdiagrammfenster. Sie können den Programmcode sehen, den
der I/O-Assistent für Sie erstellt hat, um mit dem Gerät zu kommunizieren und die Daten zu
analysieren.
3. Kehren Sie zum Frontpanel zurück, indem Sie die Tastenkombination <Strg+E> verwenden. Gehen
Sie in der Leiste auf Datei» Speichern unter und speichern Sie das VI als Instrument IO.vi
auf Ihrem Desktop.
4. Schließen Sie Instrument IO.vi und kehren Sie zum Haupt-VI zurück. Der Assistent für
Instrumenten-I/O hat jetzt eine andere Farbe und trägt nun die Bezeichnung Instrument.vi.
5. Speichern Sie das Haupt VI als Demo5.vi auf Ihrem Desktop.
6. Schließen Sie das VI, wenn Sie fertig sind.

Ende der Demo 5

© National Instruments Corporation 29 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Übung Nr. 6: Messwertanalyse
Überblick
Zweck
Diese Demo zeigt, wie Sie NI LabVIEW nutzen können, um die erfassten Daten direkt zu analysieren und
online Auswertungen durchzuführen. LabVIEW beinhaltet mehr als 550 native Analysefunktionen, die
durch spezielle Toolkits noch erweiterte werden können.

Voraussetzungen
• Datenerfassungskarte der E-Serie • LabVIEW
• Datenerfassungskabel • Ab Version NI-DAQmx 7.1
• BNC-2120 oder DAQ-Demobox • Demo3.vi

Anleitungen für die Übung


In dieser Übung werden ein paar der zahlreichen Messfunktionen gezeigt, die in LabVIEW verfügbar sind.

Datenerfassungs-VI mit Signalanalyse


1. Öffnen Sie das in der Demo Nr. 3 erstellte VI Demo3.vi oder das Demo3.vi im Ordner
C:\Schnupperkurse\LabVIEW\Lösungen.
2. Löschen Sie das Express-VI Vergleich, den numerischen Schieber (Limit) und das boolesche
Bedienelement (Alarm).
3. Ändern Sie das Blockdiagramm wie folgt:

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 30 ni.com


4. Fügen Sie ein Express-VI Spektrummessungen (Express» Signalanalyse) hinzu und
konfigurieren Sie es gemäß folgender Abbildung:

© National Instruments Corporation 31 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
5. Erstellen Sie Graph-Anzeigeelemente für die Ausgänge FFT – (RMS) und Phase, indem Sie im
Blockdiagramm einen Rechtsklick auf den jeweiligen Anschluss am Express-VI durchführen und
jeweils den Eintrag Erstellen» Graphische Anzeige auswählen. Die neuen Graphen zeigen den
ermittelten Betrag und die ermittelte Phase des Leistungsspektrums des Eingangstestsignals als
Funktion der Frequenz an. Beide Elemente tauchen als Oberflächenelemente automatisch auf dem
Frontpanel auf.

6. Fügen Sie das Express-VI Messung von Frequenzkomponenten (Express» Signalanalyse)


hinzu und konfigurieren Sie es gemäß folgender Abbildung:

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 32 ni.com


7. Erstellen Sie numerische Anzeigeelemente von den Ausgaben von Amplitude und Frequenz
(Rechtsklick auf den jeweiligen Anschluss am Express-VI – Erstellen» Nummerische Anzeige).
Diese Anzeigeelemente zeigen Frequenz und Amplitude der höchsten Amplitudenspitze des
Eingangssignals an. Aufgrund der Voreinstellung sucht das Express-VI Messung von
Frequenzkomponenten nach der höchsten Amplitudenspitze im Eingangssignal.
8. Wechseln Sie zum Frontpanel, indem Sie die Tastenkombination <Strg+E> verwenden. Positionieren
Sie die Graphen und Anzeigeelemente gemäß folgender Abbildung:

© National Instruments Corporation 33 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
9. Deaktivieren Sie die Autoskalierung der X-Achse und setzen Sie den Bereich der X-Achse auf 0–1000
für die Graphen der FFT – (RMS) und der Phase.
Dies erreichen Sie durch einen Klick mit der rechten Maustaste auf den jeweiligen Graphen und den
Aufruf der Eigenschaften. Wählen Sie den Eintrag Skalierung und stellen Sie folgende Werte ein:

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 34 ni.com


Wiederholen Sie dieselben Schritte für den Graphen der Phase.
10. Starten Sie das VI.
11. Verändern Sie über den Drehknopf auf dem Anschlussblock BNC 2120 oder dem Signal Accessory
die Frequenz, um zu sehen, wie sich die Anzeigeelemente auf dem Frontpanel ändern.

© National Instruments Corporation 35 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
12. (Optional) Kehren Sie zum Blockdiagramm zurück. Führen Sie einen Doppelklick auf das Express-VI
Spektrummessungen aus. Das Konfigurationsfenster ermöglicht Ihnen eine Interaktion mit den
aktuellen Daten. Ändern Sie das Ergebnis von dB zu linear.
13. Speichern Sie das VI als Demo6.vi auf dem Desktop.
14. Schließen Sie das VI.

Ende der Demo 6

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 36 ni.com


Übung Nr. 7: Berichterstellung
Überblick
Zweck
Diese Demo zeigt eine einfache Art der Berichterstellung mithilfe von NI LabVIEW. Sie zeigt, wie
schnell und einfach sich Berichte anpassen und Daten in ansprechender Form darstellen lassen. Diese
Demo ergänzt Demo 6 um das Report Generation Express VI.

Voraussetzungen
• Datenerfassungskarte der E-Serie • LabVIEW
• Datenerfassungskabel • Ab Version NI-DAQmx 8
• BNC-2120 oder DAQ-Demobox • Demo6.vi

Anleitungen für die Übung


1. Öffnen Sie das in der Demo 6 erstellte VI Demo6.vi oder das Demo6.vi im Ordner
C:\Schnupperkurs\labview\Lösungen.
2. Ändern Sie das Blockdiagramm, so dass es aussieht wie folgt:

Ergänzen Sie das Diagramm dazu um folgende VIs:

© National Instruments Corporation 37 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Bericht-VI (Express » Ausgabe): Konfigurieren Sie das Bericht-VI entsprechend folgender
Abbildung.
3. Wählen Sie einen geeigneten Pfad (zum Beispiel den Desktop) und geben Sie Ihrem Bericht in der
rechten unteren Ecke des Konfigurationsfensters einen Dateinamen. Klicken Sie dann auf OK.

4. Verbinden Sie die Ausgänge entsprechend der vorherigen Abbildung.


5. Wechseln Sie zum Frontpanel, indem Sie die Tastenkombination <Strg+E> verwenden.
6. Starten Sie das VI.
7. Speichern Sie das VI als Demo7.vi auf dem Desktop.
8. Navigieren Sie zu Ihrem Bericht. Der Bericht wird alle Daten enthalten, die Sie im Report VI
spezifiziert haben.

Ende der Demo 7

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 38 ni.com


Übung Nr. 8 (optional): Netzwerk-Panels
Überblick
Zweck
Diese Demo zeigt eine weitere gängige Darstellungsfunktion von NI LabVIEW, nämlich die Netzwerk-
Panels. Diese Technologie ermöglicht Ihnen ohne Programmierung die Visualisierung Ihrer Anwendung
über das Netzwerk oder Internet. LabVIEW-Anwendungen können mit einem Internet-Browser ohne
zusätzlichen Programmieraufwand ferngesteuert werden.

Voraussetzungen

Hardware Software
keine • LabVIEW
• Signal Generation and
Processing.vi

Anleitungen für die Übung


Die folgende Demo beschäftigt sich mit dem Darstellen von Daten über Netzwerk mithilfe von
LabVIEW-Netzwerk-Panels.

Vorschau des Demo-VIs


1. Öffnen Sie aus LabVIEW die Suchfunktion für Beispielprogramme (über Hilfe» Beispiele suchen…)
und navigieren Sie zum Beispiel-VI Signal Generation and Processing unter Analyse und
Verarbeitung von Signalen » Erzeugung von Signalen und Rauschen. Folgendes Frontpanel wird
geöffnet:

© National Instruments Corporation 39 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
2. Starten Sie das VI und ändern Sie die Bedienelemente auf dem Frontpanel, um deren Funktionalität zu
untersuchen. Unterbrechen Sie die Ausführung des VIs, wenn Sie fertig sind.
3. Speichern Sie das VI auf Ihrem Desktop unter dem Namen Demo8.vi.

Aktivieren der Netzwerk-Panel-Funktion


Wir wollen dieses VI nun über das Ethernet veröffentlichen und verwenden dazu die Netzwerk-Panel-
Funktion.

1. Öffnen Sie das Web-Dokumentationswerkzeug aus der Menüleiste (Werkzeuge» Web-


Dokumentationswerkzeug). Mit diesem Werkzeug kann der Anwender mit ein paar wenigen
Mausklicks ein Netzwerk-Panel erstellen.
2. Wählen Sie Signal Generation and Processing.vi als VI-Name und Eingebunden als
Anzeigemodus. Klicken Sie auf Weiter.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 40 ni.com


Wählen Sie für Dokumententitel, Kopf- und Fußzeile aussagekräftige Namen wie:
Dokumententitel: Schnupperkursbeispiel 9
Kopfzeile: Signalerzeugung und -verarbeitung
Fußzeile: Dieses VI simuliert ein Sinussignal und analysiert dieses mithilfe von Filter- und
Fensterfunktionen. Zusätzlich zeigt es das Leistungsspektrum des Signals an.

© National Instruments Corporation 41 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
3. Klicken Sie zum Starten des Web-Servers auf die Schaltfläche Web-Server starten und klicken Sie
dann auf Weiter.
4. Speichern Sie die Konfiguration als HTML-Dokument. Klicken Sie dazu auf die Schaltfläche
Speichern auf Datenträger. Speichern Sie die Datei als Demo8.htm im Verzeichnis C:\Program
Files\National Instruments\LabVIEW\www.
Sie erhalten eine URL, über die Sie auf dieses Netzwerk-Panel zugreifen können. Sie ähnelt der in der
Abbildung gezeigten URL, kann jedoch einen anderen Rechnernamen verwenden. Klicken Sie auf
Verbinden.

Ein Internet-Browser wird geöffnet. Vergrößern Sie das Browser-Fenster zum Vollbild.
Zur Anforderung der VI-Steuerung via Internet-Browser klicken Sie mit der rechten Maustaste auf
das Frontpanel des Netzwerk-Panels und wählen Sie aus dem Menü VI-Steuerung anfordern.
Unter Umständen erhalten Sie zunächst die Meldung Auf Steuerung warten: Entweder ist
der Server gesperrt oder ein anderer Client hat die Steuerung. Warten Sie in
diesem Fall einige Sekunden.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 42 ni.com


Die Meldung Steuerung gewährt informiert Sie schließlich darüber, dass Ihnen die Steuerung der
Anwendung übertragen wurde.
5. Starten Sie das VI. Falls das VI in den Vordergrund tritt, minimieren Sie es. Sie sind jetzt in der Lage,
das VI über Netzwerk zu steuern. Ändern Sie die Einstellungen, um dies zu veranschaulichen. Sie
können auch das VI anhalten und wieder starten, um zu demonstrieren, dass die LabVIEW-Netzwerk-
Panels Ihnen volle Kontrolle über das VI geben.
6. Klicken Sie zum Schluss mit der rechten Maustaste auf die Benutzeroberfläche des Netzwerk- Panels
und wählen Sie aus dem Kontextmenü Steuerung von VI wieder freigeben.
7. Halten Sie das VI an, wenn Sie fertig sind. Schließen Sie VI und Internet-Browser.

Über den Computernamen bzw. die IP-Adresse könnte diese Fernsteuerung auch von jedem anderen PC
im Netzwerk durchgeführt werden. Dabei kann man den Web-Server frei konfigurieren und bestimmen,
welche Anwender bzw. PCs die Steuerung übernehmen dürfen und welche nicht. Es können auch nur
bestimmte VIs freigegeben werden. Bei detaillierteren Fragen wenden Sie sich an den Kursleiter.

Ende der Demo 8

© National Instruments Corporation 43 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Übung Nr. 9 (optional): Dokumentationswerkzeuge
Überblick
Zweck
Diese Demo ist besonders bei umfangreichen Anwendungen interessant. Sie dient der Dokumentation
Ihrer Anwendung.

Voraussetzungen

Hardware Software
keine • LabVIEW
• Demo8.vi

Anleitungen für die Übung


1. Öffnen Sie das in Demo 8 erstellte Demo8.vi oder navigieren Sie unter Analyse und Verarbeitung
von Signalen» Erzeugung von Signalen- und Rauschen zum Beispiel-VI Signal Generation
and Processing.

2. Gehen Sie auf Datei» Drucken» Weiter und wählen Sie VI-Dokumentation.

3. Klicken Sie auf Vorschau und vergrößern Sie das Bild auf eine angenehme Größe.
So kann mit LabVIEW schnell und dynamisch eine professionelle Dokumentation erzeugt werden.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 44 ni.com


4. Schließen Sie das VI.

Abschließende Bemerkung
Obwohl die Dokumentation einen der unbeliebten Aspekte der Softwareentwicklung darstellt, ist sie doch
einer der wichtigsten, v. a. für Bedienbarkeit und Wartung.
LabVIEW vereinfacht diese Aufgabe erheblich, indem eine professionelle Dokumentation erzeugt wird,
die vom Endanwender oder von Entwicklern genutzt werden kann.

Ende der Demo 9

© National Instruments Corporation 45 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Übung Nr. 10: Analyse und Berichterstellung mit NI
DIAdem
Überblick
Diese Demo zeigt neue Technologien zur Datensuche in NI DIAdem. Außerdem werden die einfache
Durchführung zusätzlicher Analysen und die Erstellung professioneller Berichte präsentiert.

Voraussetzungen

Hardware Software
keine • LabVIEW
• DIAdem 10

Anleitungen für die Übung

1. Öffnen Sie die in Übung 6 erstellte Datei Demo6.vi oder laden Sie die Datei Demo6.vi aus dem
Ordner C:\Schnupperkurse\LabVIEW\Lösungen.
2. Wechseln Sie über die Tastenkombination <Strg+E> ins Blockdiagramm. Löschen Sie dort das
Express-VI zur Berichterstellung und alle nicht benötigten Verbindungen (nutzen Sie dafür die
Tastenkombination <Strg+B>).
3. Ergänzen Sie nun außerhalb der Schleife das Express-VI Messwerte in Datei schreiben
aus der Funktionspalette Express» Ausgabe.
4. Im sich öffnenden Dialog ergänzen Sie die Eingaben wie folgt:

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 46 ni.com


5. Bestätigen Sie den Dialog mit OK.
6. Verbinden Sie den Dateneingang des Express-VIs mit den Messwerten der Datenerfassung.

7. Wechseln Sie ins Frontpanel (mit der Tastenkombination Strg+E) und starten Sie die Anwendung.
Wenn Sie die Erfassung stoppen, werden die Daten in die angegebene Datei geschrieben. Sie stehen
nun auf der Festplatte zur weiteren Verarbeitung zur Verfügung. Sie können die Daten wieder in NI

© National Instruments Corporation 47 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
LabVIEW laden oder Programme zur interaktiven Datenanalyse, Auswertung und Berichterstellung,
wie NI DIAdem, verwenden.
8. Speichern Sie das VI zur Sicherheit unter demselben Namen über Datei» Speichern.
9. Öffnen Sie nun NI DIAdem über den Desktop oder mit Start» Programme» National Instruments.
10. NI DIAdem ist ein interaktives Werkzeug, mit dem Sie nahezu jedes beliebige technische
Datenformat verarbeiten können. Es ist in mehrere Module gegliedert.
a. Der Datennavigator ermöglicht uns das Laden und Speichern von Daten aus
unterschiedlichen Datenbeständen und unterschiedlichen Datenformaten. Durch ein neues
Werkzeug, den DataFinder, ermöglicht NI DIAdem dabei datenbankähnliche Such- und
Recherchefunktionen.
b. Löschen Sie den aktuell im Arbeitsspeicher geladenen Datenbestand durch Klick auf
Interne Daten löschen.

c. Suchen Sie nun nach Dateien und nehmen Sie dabei die Funktionalität des DataFinders in
Anspruch. Geben Sie in der Suchzeile als Suchtext beispielsweise „Geschwindigkeit“ ein.
Als Ergebnis werden Sie eine Datei erhalten, in der ein Kanal mit dem Namen
„Geschwindigkeit“ existiert.

d. Sie können Dateien natürlich auch anhand ihrer Lage auf der Festplatte suchen. Wechseln
Sie durch Klick auf

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 48 ni.com


zurück in die aufgelisteten Ordner und navigieren Sie unter My Computer zu Ihrer Datei
C:\Schnupperkurse\LabVIEW\Daten.
e. Wenn Sie die Datei gefunden haben, ziehen Sie sie mit gedrückter Maustaste nach rechts
ins Datenportal. Dort werden Sie dann alle gespeicherten Kanäle sehen.

11. Wechseln Sie nun über die Tasten auf der rechten Seite ins nächste Modul „VIEW“.
12. Hier haben Sie die Möglichkeit, Daten zu sichten. Markieren Sie zum Beispiel auf der rechten Seite
im Datenportal den Zeitkanal und den Spannungskanal (mit gedrückter Maustaste) und ziehen Sie
diese nach rechts in den Anzeigebereich.
13. Markieren Sie anschließend dieselben Kanäle und ziehen Sie sie in den unteren Bereich des
Anzeigebereichs.
14. Es sollte sich je nach erfassten Daten folgendes Bild ergeben:

© National Instruments Corporation 49 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Sie sehen oben eine grafische und darunter eine tabellarische Darstellung der Daten.
15. Ergänzen Sie nun durch einen Rechtsklick in die große freie weiße Fläche einen weiteren
Anzeigebereich: Bereich neu» Rechts.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 50 ni.com


16. Markieren Sie anschließend dieselben Kanäle wie vorhin und ziehen Sie sie in den neuen
Anzeigebereich. Wählen Sie im Auswahlfenster: 2D-Achsensystem.
17. Nun aktivieren Sie oben in der Mitte den Band-Cursor durch Klick auf die Taste Band-Cursor.

18. Sie sehen nun einen Band-Cursor, den Sie in einer der Anzeigen bewegen können. Betätigen Sie im
unteren rechten Feld die dynamische Zoom-Funktion. Wenn Sie nun im oberen Fenster den Band-
Cursor bewegen, sehen Sie im unteren Fenster den vergrößerten Ausschnitt. So lassen sich Daten
komfortabel durchsuchen.

19. Jetzt wechseln Sie in das nächste Modul, um eine Berichtvorlage zu erstellen. Klicken Sie auf der
linken Seite auf das Symbol für den Report.

20. Löschen Sie die Vorlage durch Klick auf das leere weiße Blatt in der linken Ecke „Layout neu“.
21. Nun erstellen Sie ein Layout, indem Sie die Daten anzeigen und später über einen Drucker oder als
PDF ausgeben können.

© National Instruments Corporation 51 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
22. Erstellen Sie zuerst ein 2D-Achsensystem durch Auswahl aus der Palette und platzieren Sie es auf
dem weißen Blatt, indem Sie mit gedrückter linker Maustaste ein Rechteck aufziehen.

23. Fügen Sie auf dieselbe Art und Weise eine 2D-Tabelle mit horizontalen und vertikalen Trennbalken
ein.
24. Ziehen Sie nun wieder mit gedrückter linker Maustaste die Daten aus dem Datenportal nacheinander
in beide Elemente.

Verändern Sie nun noch die Schriftgröße der Tabelleneinträge, indem Sie einen Doppelklick auf die
einzelnen Spalten ausführen und dann unter Spalteneigenschaften Format und Schriftgrad Ihren
Wünschen entsprechend anpassen.
25. Markieren Sie nun im Datenportal durch Klick auf Ihre Datei test.tdm die komplette Datei.
26. Nun sehen Sie rechts unten in der Ecke zusätzliche Eigenschaften, die Sie mit Ihrer Datei
abgespeichert haben, beispielsweise die Beschreibung LabVIEW-Schnupperkurs.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 52 ni.com


27. Ziehen Sie diese mit gedrückter linker Maustaste in Ihren Report. Sie können nun auch beliebige
weitere Eigenschaften, wie beispielsweise den Autor, in den Report integrieren.
28. Dieser Report kann nun auf einem Drucker ausgegeben werden oder als PDF, HTML oder in einem
anderen Dateiformat auf der Festplatte gespeichert werden. Sie können darüber hinaus aber auch Ihr
Layout als Reportvorlage speichern. Nachträglich geladene neue Datensätze werden automatisch in
dem von Ihnen erstellten Report dargestellt. Somit lässt sich eine Vorlage für beliebig viele
Datensätze wiederverwenden. Dabei werden auch Dateieigenschaften wie z. B. der Autor oder das
Erstellungsdatum immer aktualisiert.
Wir wollen die Reportvorlage nun speichern und uns anschauen, wie dieser Prozess der
Reportgenerierung mit LabVIEW automatisiert werden kann.
29. Speichern Sie die Reportvorlage über Datei» Speichern unter auf dem Desktop mit dem Namen
Report10.tdr ab.

© National Instruments Corporation 53 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
1. Wechseln Sie nun wieder in Ihre LabVIEW-Anwendung oder öffnen Sie die Datei Demo12.vi
vom Desktop oder aus C:\Schnupperkurse\LabVIEW\Lösungen.
2. Wechseln Sie ins Blockdiagramm (Strg+E) und ergänzen Sie das Express-VI DIAdem Report
aus der Funktionspalette Express» Ausgabe.
3. Wählen Sie im Konfigurationsfenster Ihr eben erstelltes und auf dem Desktop gespeichertes
Layout. Deaktivieren Sie für diese Übung die Ausgabe an ein Gerät.

4. Bestätigen Sie die Einstellungen mit OK und verdrahten Sie das Blockdiagramm wie folgt:

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 54 ni.com


5. Wechseln Sie abschließend ins Frontpanel und starten Sie die Anwendung. Wenn Sie die
Anwendung über die Schaltfläche Stopp anhalten, werden die Daten gespeichert und es wird
automatisch ein Report erstellt.
6. Speichern Sie Ihre Beispielanwendung erneut unter dem Namen Demo10_2.vi und beenden Sie
LabVIEW und DIAdem.
Ende der Demo 10

© National Instruments Corporation 55 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
Übung Nr. 11: LabVIEW-Projekt
Überblick
Zweck
In dieser Demo wird Ihnen das LabVIEW-Projekt vorgestellt und der Einsatz von NI LabVIEW für die
Entwicklung komplexer Anwendungen erläutert.

Voraussetzungen

Hardware Software
keine • LabVIEW
• Projektdateien

Anleitungen für die Übung


1. Klicken Sie im LabVIEW-Fenster Erste Schritte auf Leeres Projekt. Speichern Sie das Projekt auf
dem Desktop (Datei» Speichern) unter dem Namen Demo11.lvproj.
Ein leeres Projekt-Explorer-Fenster wird sich öffnen, das mehrere, in einer Baumstruktur organisierte
Knoten enthält. Ganz oben steht Mein Projekt, dem untergeordnet sind Mein Computer,
Abhängigkeiten und Build-Spezifikationen.

Mit dem LabVIEW-Projekt können alle VIs, Bibliotheken und verwandte Dateien, aus denen Ihre
Anwendung besteht, organisiert und verwaltet werden. Ein LabVIEW-Projekt kann über das Fenster
Projekt-Explorer angesehen und bearbeitet werden.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 56 ni.com


2. Um dem leeren Projekt eine Datei hinzuzufügen, klicken Sie rechts auf Mein Computer und wählen
Sie Datei hinzufügen. Das Dialogfenster Wählen Sie eine Datei aus öffnet sich.

3. Navigieren Sie zum Ordner Projektdateien im Verzeichnis


C:\Schnupperkurs\labview\Demos und fügen Sie dem Projekt folgende Dateien hinzu,
indem Sie alle auswählen (Strg-Taste gedrückt halten) und Datei hinzufügen wählen:
• Main.vi
• DACSignSweep.c
• DAC Testing Timeline.ppt
• LabVIEW Upgrade Notes.pdf
• Gantt Chart.jpg
5. Sie können jede Datei direkt aus dem Projekt-Explorer-Fenster öffnen. Doppelklicken Sie auf Gantt
Chart.jpg. Diese Datei enthält das Muster einer Zeitachse für ein Entwicklungsprojekt; sie ist wichtig
für Entwickler, ist jedoch keine LabVIEW-Datei.

6. Bei umfangreichen Systemen ist es oft schwierig, alle Dateien einer Anwendung zu organisieren.
LabVIEW ermöglicht Anwendern nun die Erstellung virtueller Ordner, um Dateien komplett aus der
LabVIEW-Umgebung heraus zu organisieren.
7. Klicken Sie rechts auf Mein Computer und wählen Sie Neu» Ordner.
8. Nennen Sie den Ordner Hilfedateien und drücken Sie Enter.
9. Markieren Sie (Strg gedrückt halten) die PDF-, JPEG- und PowerPoint-Dateien im Projekt-Explorer
und ziehen Sie sie in den Ordner Hilfedateien.
10. Klicken Sie rechts auf Mein Computer und wählen Sie Neu» Ordner. Nennen Sie diesen Ordner
Externer Code und drücken Sie Enter.
11. Ziehen Sie die Datei DACSignSweep.c in den Ordner Externer Code.

© National Instruments Corporation 57 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
12. Klicken Sie rechts auf die Projektdatei Demo11.lvproj und wählen Sie Ansicht» Komplette
Pfade. In der Baumstruktur wird nun hinter jeder Datei des Projekts der komplette Pfad angezeigt.
Dabei können die Dateien auf verschiedenen Festplatten oder sogar an verschiedenen Standorten eines
Netzwerks gespeichert sein.

13. Wählen Sie wiederum Ansicht» Komplette Pfade, um diese Ansicht wieder zu deaktivieren.
14. Speichern Sie das Projekt wieder unter Datei» Alle speichern » Projekt11.proj.

Ende der Demo 11

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 58 ni.com


Übung Nr. 12: Application Builder
Überblick
Voraussetzungen

Hardware Software
keine • LabVIEW
• Projekt11.lvproj

Anleitungen für die Übung


1. Öffnen Sie die in Demo 11 erstellte Datei Projekt11.proj oder die Datei Demo11.proj im
Ordner C:\Schnupperkurs\labview\Lösungen.
2. Klicken Sie mit der rechten Maustaste auf Build-Spezifikationen und wählen Sie Neu. Sie könnten
jetzt eine .EXE-, Installer-, .DLL- oder .ZIP-Datei bzw. eine Quellcode-Distribution erstellen. Wählen
Sie Neu» Applikation(EXE), um den Application Builder zu starten.
3. Ändern Sie in der Kategorie Angaben zur Anwendung den Punkt Name der Build-Spezifikation in
Release Build, den Zieldateiname in Demo12.exe und das Zielverzeichnis für die Anwendung in
den Ordner Projektdateien im Verzeichnis C:\Schnupperkurse\LabVIEW\Demos um. Sie
können für Ihre .EXE-Datei auch Versions- und Urheberrechts-Informationen spezifizieren.

© National Instruments Corporation 59 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW
4. Klicken Sie auf die Kategorie Ausgangsdateien. Markieren Sie Main.vi im Feld Projektdateien und
klicken Sie auf den blauen Pfeil links vom Feld Start-VIs. Main.vi wird unter Start-VIs auftauchen
und unter Projektdateien ausgegraut erscheinen. Wenn die .EXE-Datei gestartet wird, dann wird
jedes Start-VI geöffnet.
5. Markieren Sie den Ordner Hilfedateien und klicken Sie auf den blauen Pfeil links vom Feld
Dynamische VIs und Hilfedateien. Der Ordner Hilfedateien wird in diesem Feld erscheinen und
unter Projektdateien ausgegraut. Alle Dateien, die sich bei Erstellung der .EXE-Datei im Ordner
Hilfedateien befinden, werden automatisch darin integriert. Dadurch kann die .EXE-Datei mit der Zeit
dynamisch wachsen, ohne dass eine neue Build-Spezifikation erstellt werden muss.

6. Klicken Sie auf die Kategorie Einstellungen der Quelldateien. In diesem Fenster können Sie die
Einstellung für jedes VI anpassen, das in die .EXE-Datei integriert wird, so z. B. ob das Fenster eine
Titelleiste enthält oder modal ist. Behalten Sie die aktuellen Standardwerte bei.
7. Klicken Sie auf die Kategorie Fortgeschritten. Beachten Sie die Option Fehlersuche aktivieren. Sie
können damit eine .EXE-Datei erstellen, die Informationen über das Blockdiagramm enthält und
somit auch im Nachhinein noch eine Fehlersuche zulässt. Von einem über ein Netzwerk
angeschlossenen PC kann so nachträglich ein Remote-Debugging realisiert werden, ohne dass auf
dem Zielsystem eine LabVIEW-Entwicklungsumgebung installiert sein muss.
8. Klicken Sie auf OK, um diese Build-Spezifikation im Projekt-Explorer zu speichern. Unterhalb von
Build-Spezifikationen erscheint ein Eintrag mit dem Namen Meine Applikation.

Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW 60 ni.com


1. Klicken Sie mit der rechten Maustaste auf Meine Applikation und betrachten Sie die Optionen für
Build oder Ausführen der Applikation, wenn sie vorher erstellt wurde. Erstellen und führen Sie
die .EXE-Datei aus.
2. Speichern Sie das Projekt unter dem Namen Projekt12.lvproj.

Ende der Demo 12

© National Instruments Corporation 61 Seminar – Erfassen, Analysieren und Darstellen mit NI LabVIEW