You are on page 1of 13

Tutorial for Modeling the Web Cutter

Mechanism in ADAMS

by Stephen C. Ilyes

Figure.1 Web Cutter Dimensions in units of cm

Links are 2cm think and made out of Al 6063. Link 2 is rotating at a rate of 60 rpm CCW.
Figure.2 Exploded image of Web Cutter Links

This tutorial will describe in depth how to use TPS Dig 32 and ADAMS to determine the

torque of the motor, bearing forces, and the angular position, velocity, and acceleration of the

links for the given problem.


Before analysis in ADAMS can take place the links must be digitized so points can be

inserted to define the shapes of the objects. To accomplish this digitization TPS Dig 32 will be

used. This program is free and can be downloaded from http://life.bio.sunysb.edu/morph/soft-

dataacq.html. To digitize the links copy Figure.2 and paste it into a simple photo editing

program. Save the image as a jpeg. Open TPS then Click File>Input Source>File, change the

file type to JPEG and open the file you just saved. Click the cross hair button to select points.

Select points one link at a time. The first two points selected on each link should be the pin

locations. Then proceed clockwise around the outside of the link. You will only need two points

at each end of a straight line. More points will be necessary in the corners. Once you are

finished selecting points on a link Click File>Save Data and chose a file name corresponding to

the link. Once the data is saved Click File>Clear Data and begin a new link and repeat the above

steps. Make sure to use the zoom feature to improve accuracy.

To utilize this data we must now convert the points into units of meters and also reorient

the links to make modeling easier in ADAMS. Open Excel and then Open the first tps file

containing the data. This will require you to go through the import wizard. The data is space

delimitated. X values will be in the first column and the Y values will be in the second column.

Since the pin locations were digitized and we know the distance between the pins from Figure.1

we can use the distance formula to calculate a conversion factor between points and meters.

d= ( x2 − x1 ) 2 + ( y 2 − y1 ) 2

Using this conversion factor create two new columns, with the X and Y values in meters. Now

we will normalize the points about O2, A3, and O4 for Links 2, 3, and 4 respectively. The points

will also be rotated so that both pin locations lie on the x-axis. In column 5 determine the
distance between each point and its respective ground point. In column 6 calculate the angle

between the points and their respective ground point using the ATAN2 function as shown.

θ = ATAN2((x-xG), (y-yG)) In column 7 subtract the angle between the pins locations from the

values in column 6. To calculate the x values in column 8 multiply the distance from column 5

by the cosine of column 7. To calculate the y values in column 9 multiply the distance from

column 5 by the sine of column 7.

In sheet 2 label columns X, Y, and Z. Paste the X and Y values of only the boundary

points (not the pin locations) from Columns 8 and 9 into the respective columns. For links 2 and

4 assign Z values of 0.00. For link 3 assign a Z value of -0.02. Save the file and then with the

second sheet selected click File>Save As, change the Save as type to Text (Tab delimitated) and

save the file. Repeat these steps for the other two links. Once this is done we are ready to begin

analysis in ADAMS.
To open Adams navigate to Start>….>MSC.Adams2003>AView>Adams-View

Choose a Working Directory, a Name for your Model, and Select MKS for the units and Press
OK.

Select Build>Materials>New

Change the Name as shown above and Enter the properties of Al 6063 and Press OK.
Right Click on , the Rigid Body: Link Icon in the Main Toolbox

The menu shown on the right will the appear

Left Click on the Rigid Body Extrusion Icon

This can also be accomplished by selecting Build>Bodies\Geometry

The menu to the left will appear.

Enter 0.02 for the length since the parts are 2cm thick.

Select Backward for the Path.

Create a simple triangle by left clicking on the origin, a point in the


first quadrant, and on the x-axis. Right Click to complete the shape

Note: When using a command the bar on the bottom will tell you what to do
and you can always exit a command by pressing the Esc key

Right Click in the workspace and Select Iso <I> or Press Shift+I
to view an isometric view.

Various other options and their shortcut keys are available in this menu.
Spend some time experimenting with them and then return to the front
view (Shift+F)
Now we will utilize files the files of the link geometry created previously.

Right Click inside the triangle and Select Extrusion: Extrusion_1>Modify. Click on the (…)
icon on the profile points line.

Click Read and select link2.txt and Press Open and then OK 2 times. The link should look like
the one below.

By starting our Triangle at the origin and normalizing the points about O2 for link 2 the origin
and O2 coincide.

The second coordinate system is located at the center of mass of the link. This is automatically
added for all Parts

Now we will add a coordinate system on link two at A2.

In the main toolbox right click on then left click on

At the bottom of the main toolbox select Add to Part and GlobalXY, then click anywhere on
Link 2 and then on the coordinate system at the origin.

Right Click on the coordinate system you just added and Select Marker_Marker2>Modify. In
the Location box enter 0.04,0.0,0.0 since point A2 is 4cm from O2 and Press OK.

Note: This is why the links were rotated to make OA horizontal for the input files.
Now that all of the keypoints on link2 are defined we will pin it to the ground.

From the main toolbox click on the Joint: Revolute button.

Using the default options click anywhere on Link two, then anywhere on the Ground, and finally
at the origin (Point O2). The results should look like the following.

Note: Whenever Joints are added a coordinate frame is added at that location.

The next step is to add a motor. In the main toolbox Click the Rot Joint Motion Button.

Select a speed of 360 which represents 360o/s CCW or 60 rmp CCW and click the blue arrow
just created which represents the joint. A larger blue arrow will appear outside the previous one
if you have done it correctly.

Save your database by Click File>Save Database, and select no for a backup copy

Now we will run a simulation to test are model.

Click Simulate>Interactive Controls set the end time to 1s. Change Steps to Step Size and set it
equal to .01. Check Reset before running and Press the run button. As shown on the next page.

If everything has been done correctly the bar should complete one revolution.
Now we will add the next link. Select the Extrude Command Enter 0.02 for the length
and Select Backward for the Path. This time place the first point on A2 and draw a triangle.

Repeat the steps above to import the values for link 3.

Repeat the steps above to add a new coordinate system at point B3 Note the new Location is
0.032,0.0,0.0 After this step your model should look like this.
Pin the two parts together as done before but this time select Link 3, then Link 2 then A3. If
done correctly a blue arrow will appear around A3.

Click anywhere on Link 3. Notice that everything is highlighted and there is a green handle at
the end of the y axis on the coordinate located at A3. Click on this handle and drag left. This
causes Link 3 to rotate about that point. Let Link 3 in this position for now so it is out of the
way.

Now we will add the ground point at O4

Click but this time change the options to Add to Ground and GlobalXY click on any
location except on a part. Right Click on the ground point that you just added. Select
Marker_10>Modify. Change the location to 0.26,-0.04,0.0 which is the location of O4 and Press
OK.

Draw another triangle with the Extrusion tool this time with the first point at O4.
Repeat the previous steps and read in Link4.txt to correct the shape.

Add another coordinate system on Link 4 at O4 and then change the location of the
coordinate system to B4 (0.66, -4.0E-002, 0.0).

Add a Pin to Link 4 by clicking on Link 4, Ground, and then O4.


At this point the model should look like this.

The Next Step is to Join Link 3 and Four

Click on Link 4, grab the green handle and drag it left until the Links are close to their final
positions.

Select the Joint tool but this time change the options to 2 Bod-2 Loc and Normal to Grid.

Click on Link 4, then Link 3, and then Point B4, and finally Point B3. This will add a joint but
the locations will be separate.
To join these location click Simulate>Interactive Controls

Click on this performs initial conditions solution.

Ignore and Close the warning that comes up. The part is now joined

In the Simulation window click and save the joined model as .Webcutter_Asm. Now
press play and run the simulation.

Now that the model is running we must assign the material properties to the links. Right Click
on Link 2 and Select Part2>Modify for Material Type enter Al6063 and choose
.Webcutter_Asm.Al6063. Repeat this step for Link 3 and 4.

Note: If you choose the option of just entering density the Links will have significant
deformation during the run.

Select View>Render Mode>Smooth Shaded. This will fill in the Links giving them a more
realistic shape especially in the isometric view. Change the view to isometric view and run the
simulation.

The model is now complete and should look like this in the front view.
Now we can select the desired output.

To find the Torque of the motor left click just inside largest blue arrow to highlight it. Right
Click and select Motion_1>Measure, Enter a name, and Select Torque, Choose Z, and with
respect to Part 2.

If you make a measurement that you don’t want Click Build>Measure>Delete Select the
measurements that you want to delete and press OK. Then rerun the simulation.

To measure bearing forces Right Click on the desired Joint and Select Measure. Assign a name,
select magnitude and determine if you want F12 or F21.

To measure the angles of the Links with respect to ground Click Build>Measure>Orientation
>New. For Theta2 Select Marker_1 (Marker on Link 2) for the To Marker, and Marker_4
(Marker on the Ground) for the From Marker.

To measure the angular velocity and acceleration Right Click on a Part, Select the Part and
Measure. Choose CM Angular (Velocity or Acceleration), select Z and Press OK.

To create and view plots Click Review>Postprocessing Select a measure and Click Add curves.

To Export All data for manipulation in Excel, Highlight all Measures using the Shift key and
select Add curves. Click File>Export>Table. Enter a Name, Plot should be plot_1, and the
format is spreadsheet. Press OK and then go to your working directory. Right Click on the File
and select Open With>Excel. Click File>Save As and choose a File type of .xls.