You are on page 1of 6

3D Chess Modelling

Software: AutoDesk Maya 2014

Maya User Guide - Interface Overview


http://download.autodesk.com/global/docs/maya2014/en_us/index.html?url=files/
Fields__Set_field_attributes_with_workspace_manipulators.htm,topicNumber=d30e432954

!
!
!

Mr. Balians YouTube Channel - Video Tutorials


Intro to Maya
Tutorial: Maya 01_Setting Work Documents
https://www.youtube.com/watch?v=jIPZ_w1WuKU

Steps: Maya 01
1. Saving your Work
a. File > Project Window > Create New Current Project Name (Anything you create and save is organized and saved
here - Primary Project Locations) > click Accept
b. File > Set Project > Maya Recordings

c. File > Save Scene As > Title your scene

Tutorial: Maya 02- Intro to Maya User Interface


https://www.youtube.com/watch?v=G-81awWZF2k

Steps: Maya 02
1. When we are creating things we are modelling and using polygons.
2. Create a cylinder with the Polygon Tool.
3. Press #5 for shade view
4. Choose a Polygon icon > appears in workspace
5. Quick Keys > W , E and R
a. W = Move Tool
b. E = Rotate Tool
c. R = Scale Tool
d. Q = Selection Tool
6. Zooming In and Out
7. Three Arrows (engine or tripod) in Move > Blue = X Axis (left - right) ; Green = Y Axis (up and down); Yellow = Z Axis (in
and out)
8. The Origin = where X + Y (zero) axis meet (very important to start your work at the origin)
9. Different Perspective Views
a. Alt/Option Key = Panning workspace
b. Alt/Option Key + Left Click = Orbiting workspace
10. Zooming = Scroll button (click home icon in top right to return to default view)
11. Create a Torus/Donut > set to origin > Translate X = 0; Translate Y = 0; Translate Z = 0 (delete just for demo)
12. Figuring out Sizing > Inputs > click PolyCylinder1
> change Radius = 1
> change Height = 3
> Subdivision Heights = 5

> Subdivisions Cap = 3


13. Move cylinder to ground plane > Translate X = 0; Translate Y = 1.5; Translate Z = 0
14. Add a (ground) plane > Translate X = 0; Translate Y = 0; Translate Z = 0
> Inputs > PolyPlane1 > Change Dimensions > Width = 30 > Height = 30
15. Easiest to stay in W = Move Tool or Q = Selection Tool

!
!

Tutorial: Maya 03 - Review 3D modeling


https://www.youtube.com/watch?v=s12Aa8cILJg
Steps: Maya 03
1. Make sure your workspace is set to Channel Box/Layer Editor
2. Create a polygon cylinder
> Origin set to zero (X, Y, Z)
> Set Translate Y = 1.5
> Height = 1
> Radius = 3
> Subdivisions Axis = 20
> Subdivisions Height = 6
> Subdivisions Cap = 3
3. Modeling a Rook/Castle chess piece
4. Press #5 for shade view
5. Extrude (made up of Edges, Vertices, and Faces - just focusing on Faces)
6. Right click an hold > this will show you the elements that make up the object
7. Click once on a single face > hold Shift + double click next face beside - this will select entire face ring
8. Select Extrude Icon (under Polygon tab)
9. Use blue tab to center extrude to the origin
10. Click and drag Y Axis (yellow arrow) upwards to begin extruding entire ring
11. Click and select every other face of the ring and extrude only those faces on the Y Axis
12. Now we want to taper some faces of the rook using the Scale Tool
13. Right click and select Edges
14. Click one edge and double click the next to select the entire ring edge
15. Press R for Scale > Scale from the center only (yellow square)
16. Scale the next edge below
17. Right click and hold (the spider web) and select Vertex
18. Left click and make a Marque Selection
19. Click w for the Move Tool and drag Y Axis up and down
20. Right click and hold (the spider web) and select Faces
21. Left click one face hold shift and double click the next for the entire ring face
22. Click Extrude > and increase the Thickness > Left click on the word and drag to the left and right
23. Right click and hold (the spider web) and select Edge
24. Left click one edge on the ring above and double click the next edge to select entire edge ring
25. To add more Edges > from the Edit Mesh drop down menu choose Insert Edge Loop Tool
26. Tool will insert edge loops perpendicular to the line you click on
27. Make sure to click Q or W to exit the Insert Edge Loop Tool

28. Right click and hold (the spider web) and select Object Mode
29. Under Shading tab click Wireframe on Shaded

!
!

Tutorial: Maya 04 - Intro to Extruding Polygons


https://www.youtube.com/watch?v=JVkLCtJR7I4
Steps: Maya 04
1. We are going to practice extruding elements of our chess piece previously created in above tutorials.
2. Click the Extrude icon and right click on your chess piece to access the Spider Web.
3. Choose Faces.
4. Left click and Shift select every other face on a portion of your chess piece (all the way around.)
5. Click the Extrude icon again and left drag the mouse until the Thickness equals -0.3.
6. All of your faces should have extruding in uniformly. If not go to Edit Mesh and make sure that Keep Face Together is
checked.
7. Now you should have a dozen or so openings around your chess piece.
8. Checking that your proportions are proper choose Panels > Orthographic > Front View
9. You can switch between views from Perspective (which is default view) or Orthographic all from the Panels menu.
10. You can also see all four Orthographic views by pressing the space bar and again to return to full view.
11. Click the Extrude icon and right click on your chess piece to access the Spider Web.
12. Choose Edges.
13. Left click and Shift select every other inside edge of the inner ring at the top of the chess piece.
14. Click the W key (Move Tool) and extrude the height of those selections.
15. You now have pointed pieces at the top of your chess piece.
16. Remember to save you work every 10-20 minutes and change the scene name (ie: Elsie 3D Chess_01; Elsie 3D

!
!
!

Chess_02 etc.)

Creating a pawn chess piece


Tutorial: Maya 05 - Modelling by Combining Polygons
https://www.youtube.com/watch?v=JZU36Cb3lrg
Steps: Maya 05
1. We are going to learn how to model a chess piece by combining multiple polygons.
2. Create a polygon cylinder
> Origin set to zero (X, Y, Z)
> Set Translate Y = 0
> Height = 1
> Radius = 3
> Subdivisions Axis = 20
> Subdivisions Height = 5
> Subdivisions Cap = 2
3. Right click on your cylinder and choose Edge.
4. Double the inner ring on the top of the cylinder > Click the R key for Scale.
5. Click the center origin to drag out the inner circle closer to the outer ring.
6. Click W > Right click and choose Object Mode.
7. Change the Translate Y = 1.5

8. Now we are going to create a sphere.


9. Choose the Sphere icon and set:
> Origin set to zero (X, Y, Z)
> Set Translate X = 0
> Set Translate Y = 0
> Set Translate Z = 0
10. Click W and move the sphere up on Y axis until it connects to the edge of the inner ring.
11. Now to combine both polygons you must click the cylinder hold the shift key and select the sphere and from the Mesh
drop down menu choose Combine. (They will both highlight green)
12. We want to Extrude the thickness of the base of the chess piece.
13. Right click and select Faces.
14. Click extrude and choose to extrude from the origin. Drag the base out slightly.
15. Now lets scale the first edge ring under the sphere.
16. Right click and select Edge. Double click one edge to select the entire ring. Click R for Scale and drag the origin in to
scale in.
17. Repeat this Scale slightly less for the edge ring below.
18. Now we need to insert more edges. From Edit Mesh menu select Insert Edge Loop.
19. Remember that to insert a new edge you must click on an edge the is perpendicular to where you want a new edge to
insert.
20. Create two to three new edges below where we just scaled the previous edge.
21. We are now going to edit the top portion of the sphere.
22. Right click on the chess piece and choose Faces.
23. Select and left click to select all faces of the top inner ring of the sphere.
24. Click Extrude again and drag up from the origin to extrude the height of the selection.
25. Select the next ring around and Scale the thickness out so that you create a horizontal extrusion.
26. Always right click and choose Object Mode once you are done editing so that you see all of your model.

!
!
!

Bringing in models from external project files


Tutorial: Maya 06 - Importing Geometry
https://www.youtube.com/watch?v=fOoj7jn_T5k
Steps: Maya 06
1. Create a ground plane with the Polygon Plane icon.
2. Under Inputs > Polyplane1 > set the following:
a. Width: 30
b. Height: 45
3. You should now see a ground plane under your chess piece.
4. You can hide the grid by clicking on the Grid icon under the Lighting Drop Down Menu.
5. You should also get into the habit of properly naming each element in your scene. So rename Polyplane1 to Plane for
ground plane.
6. Now we are going to bring in other pieces created in different scenes.
7. Choose File > Import > Select the chosen file you would like to import and click Import in bottom right o window.
8. The imported element should appear at the origin of your current scene.

9. Choose the Move Tool and click and move your imported piece to a desired location.
10. Now click the Film Gate icon under the word Show to ensure that all elements will be seen within the safe frame
(highlighted area.)
11. Now we can take a picture of our current models. Click on the Render Current Frame icon (looks like a camera slate) to
produce a picture. You should notice a Render View Window appear with a photo of your pieces and ground plane in
shaded view.
12. Save your Rendered Image as Importing Models.
13. Save your Scene as Importing Models.

!
!

Tutorial: Maya 07 - Rendering with Mental Ray


https://www.youtube.com/watch?v=wt3E7v9dUek
Steps: Maya 07
1. Open the last saved scene Importing Models when we had our Film Gate safe area highlighted and took our first photo.
2. Now choose the last Camera Slate icon with two dots on the left side. This is Render Settings.
3. Ensure that it is Rendering Using Maya Software > Image Format Maya IFF > and your Image Size W= 640 x H=480.
4. Then click the Film Slate icon again for a second photo and you should notice it is a larger file now.
5. Now under Render Using change from Maya Software to Mental Ray.
6. Change Resolution from 72 to 150.
7. Change Presets to HD 1080.
8. Click Quality tab > Quality Presets > Production.
9. Click Indirect Lighting tab > click create button beside Image Based Lighting and Physical Sun and Sky.
10.Click Common tab > ensure that Renderable Cameras is set to persp.
11. Now you can click close button at bottom of the window.
12. Now click the second Film Slate icon and notice the difference in the shot.
13. Now we are going to redirect the SunDirection in our environment using the move tool.
14. Change properties as follows:
a. Translate X: 11.75
b. Translate Y: 21.5
c. Translate Z: -9.65
d. Rotate X: -172
e. Rotate Y: -58
f. Rotate Z: 48.4
15. Now we can add a new texture to each chess piece. Select a chess piece, right click and choose Assign New Material >
from Options choose Lambert.
16. From the Attributes Editor window choose the Lambert tab. From the Common Material Attributes section click Colour
and adjust the grayscale slider to a brighter grey.
17. To add new material to each chess piece to need to right click on each piece and choose Assign New Material > from
Options choose Lambert. Now add a different colour to each piece.
18. Then render this current shot with the second Film Slate icon and notice the difference in the materials and angle of the
light and shadows.

!
!
!

Tutorial: Maya 08 - Rendering and Presenting Work


https://www.youtube.com/watch?v=WixNOZfVGmE

Steps: Maya 08
1. Presenting our screen shot to our rendered shot.
2. Select the ground plane.
3. Right click and assign new material. Change the colour in the Attribute Editor.
4. Select the checkered board to the right of the colour window. Select the checkered board in the Create Render Node
window. You can change colours in the colour 1 and colour 2 windows. Change colour 2 to blue.
5. If you dont see you texture on your checkered board press the 6 key to turn texture on.
6. Command + Shift + 3 will take a screen shot on a Mac computer. Command + Shift + 4 will allow you to take a specific
screen shot (with a target cursor.) So click and hold, drag out to cover all of what you want to take a screen shot of and
release all keys. Both screen shots will be saved to the desktop.
7. Now take a render of the current scene by clicking the render icon

!
!

Tutorial: Maya 09 - Adding a checkered texture picture


https://www.youtube.com/watch?v=RFebG6OiCAA

under the main menu drop downs.