Sie sind auf Seite 1von 11

Home > Network Simulator with Designer for CCNA / Network Simulator for CCNA 

> Router Simulator Supported


Commands
Available labs  |   Supported Commands  |   D/L & Installation instructions  |   Product Help

Router Simulator Supported Commands


List of Router Commands
Sl. No. Command Comments, if any.
access-list <list-num> {permit | deny} <source-ip- Only standard access list of the format given is
1
address>  supported.
access-list <100-199> {permit/deny} protocol
    2 source-addr [source-mask] [operator operand]
Global command for extended access-lists
new destination-addr [destination-mask] [operator
operand]
    3 access-list <list-num> {permit/deny} protocol
 
new <source-addr> any operator operand
    4 access-list <list-num> {permit/deny} protocol
 
new <source-addr> any
    5 access-list <list-num> {permit/deny} protocol host
 
new <source-addr> <dest-addr><dest-mask>
    6 access-list <list-num> {permit/deny} protocol any
 
new any
    7 access-list <list-num>{permit/deny} protocol any
 
new host <dest-addr> operator operand
    8 access-list <list-num> {permit/deny} protocol host
 
new <source-addr> any operator operand
    9 access-list <list-num> {permit/deny} protocol
 
new <source-addr> <source-wmask> host <dest-addr>
10 banner motd <banner>  
11 bandwidth <kilobits> Required bandwidth, in kilobits per second.
12 cdp advertise-v2  
13 cdp enable   
14 cdp run  
15 cdp holdtime <seconds>  
16 cdp timer <seconds>  
17 clear arp-cache  
Desired clock rate in bits per second: 1200,
18 clock rate <bps> 2400, 4800, 9600, 19200, 38400, 56000, 64000
etc.
Hexadecimal or decimal value that represents
the 16-bit configuration register value. It is used
19 config-register <value> at the router start-up. The value range is from
0x0 to 0xFFFF (0 to 65535 in decimal).
Normally, the default value is 0x2102
20 configure terminal  
21 copy running-config startup-config  
22 copy startup-config running-config  
23 description <string> Character string from 1 to 80 characters.
Terminates the suspended telnet session and
24 disconnect
then logout it.
  25 Running configuration file is copied to TFTP
copy running-config tftp:
new server
  26 Copies configuration file from TFTP server to
copy tftp: running-config
new new router
  27 Copies configuration file from TFTP server to
copy tftp: startup-config
new new router
28 debug ip packet   
29 disable   
30 disconnect  
31 disconnect <TELNET_ID>  
32 enable  
33 enable password <password>  
34 enable secret <password>  
35 erase startup-config  
  36 Command for router in interface configuration
encapsulation dot1q <vlan id>
new mode
Only PPP/HDLC are supported at this time by
37 encapsulation  <encapsulation-type> the simulator.
ex: encapsulation hdlc
  38
encapsulation framerelay [cisco][ietf]  
new
39 end   
40 exec-timeout <minutes> [seconds]  seconds is optional. 
  41 LMI type is specific to the entire interface,not
frame-relay lmi-type <lmi_type>
new to a VC.
  42 frame-relay map<protocol-name> <ip-address>
It configures the manual resolution of PVC's.
new <dlci_num>
  43 frame-relay map<protocol-name> <ip-address>
 
new <dlci_num> broadcast
  44 frame-relay map<protocol-name> <ip-address>
 
new <dlci_num> broadcast cisco
  45 frame-relay map<protocol-name> <ip-address>
 
new <dlci_num> broadcast ietf
  46 frame-relay map<protocol-name> <ip-address>
 
new <dlci_num> cisco
  47 frame-relay map<protocol-name> <ip-address>
 
new <dlci_num> ietf
48 hostname <host-name>  
49 interface ethernet 0  
  50
interface fa <Port-number>  
new
  51
interface fa <Slot-number>/<Port-number>  
new
  52
interface fa <Port-number>.<Subint-number>  
new
  53 interface fa <Slot-number>/<Port-
 
new number>.<Subint-number>
  54 Loop back interface numbers 0 to 9 are
interface loopback <port-number>
new supported
55 interface serial 0   
  56 Interface sub command to enable named
ip access-group <named ACL>
new access-list
57 ip access-group <num> in  
58 ip access-group <num> out   
  59
ip access-list extended <named ACL> Global command for Named Access-List
new
60 ip address <ip-address> <sub-net mask>   
61 ip default-network <ip-address>  
62 ip domain-lookup   
63 ip name-server<ip-address>  
  64
ip nat inside source list <ANUM> pool <WORD>  
new
  65 ip nat inside source static <ip-address> <ip-
 
new address>
  66
ip nat inside  
new
  67 ip nat outside source static <ip-address> <ip-
 
new address>
  68
ip nat outside  
new
  69 ip nat pool <WORD> <ip-address> <ip-address>
 
new netmask <ip-address>
  70 ip nat inside source list <num> interface <int>
PAT command
new overload
The command supported by the simulator are:
ip route <prefix> <mask> {next-hop-ip-addr |
71 ip route <prefix> <mask> <next-hop-ip> and
interface-type}
ip route <prefix> <mask> serial 
72 ip route 0.0.0.0 0.0.0.0 <ip-address>  
73 ip route<ip-address> <ip-address> <ip-address>  
74 ip route <ip-address> <ip-address> serial 0 Not supported at this time
Complete syntax for this command: ip host
75 ip host <name> <ip-address> name [tcp-port-number] address1
[address2...address8]
76 ip routing  
77 ipx routing  
78 keepalive <seconds>  
79 line aux  
80 line console 0   
81 line vty  
82 logging synchronous  
83 login  
84 logout   
85 network <ip-address>  Used with routing rip, igrp etc.
  86 network <ip-address> < ip-address > area <Area-
(For ospf routing)
new id>
87 no cdp enable  
88 no ip address  
89 no ip routing  
90 no cdp run  
  91 no frame map <protocol name> <ip-address>
 
new <dlci_num>
  92 no frame map<protocol-name> <ip-address>
 
new <dlci_num> broadcast
  93 no frame map<protocol-name> <ip-address>
 
new <dlci_num> cisco
  94 no frame map<protocol-name> <ip-address>
 
new <dlci_num> ietf
95 no ip domain-lookup  
  96 no ip nat pool <WORD><ip-address> <ip-address>
Nat pool related command
new netmask <mask-addr>
  97 no ip nat inside source list <ANUM> pool
 
new <WORD>
  98 no ip nat inside source static <ip-address> <ip-
 
new address>
  99
no router eigrp  
new
100
no router ospf  
new
101
no router rip  
new
102 no shutdown  
103 password <password>   
104 ping <host-name>  
105 ping <ip-address>  
106 reload  
107 resume <TELNET_ID>  
108
router eigrp <aut_sys>  
new
Process_id is locally significant and is used to
109
router ospf <proc_id> differentiate different ospf processes running on
new
a router.
110 router rip  
111 shutdown  
112 show access-list   
113
show arp Displays entries in the ARP table
new
114 show cdp neighbor   
115 show flash   
116 show history  
117
show frame-relay lmi Shows the detailed statistics regarding LMI.
new
118
show frame-relay map  
new
119 Shows all the frame relay PVC's terminated and
show frame-relay pvc <dlci_num>
new their statistics at a specified router
120 show hosts  
121 show ip arp  
122 show ip eigrp neighbors detail  
123 show ip eigrp neighbors  
124 show ip eigrp topology  
125 show ip eigrp traffic  
126 show ip interface brief  
127 show ip interface  
128 show ip ospf interface  
129
show ip nat statistics  
new
130 show ip nat translations  
new
131 show ip ospf database  
132 show ip ospf neighbor detail   
133 Displays parameters and current state of the
show ip protocols
new active routing protocol process.
134 show ip route  
135 show interfaces  
136 show interfaces ethernet 0  
137 show interfaces serial 0  
138
show interfaces loopback <Loopback_num> Loopback interface number,0 to 9 are supported
new
139 show protocols  
140 show running-config  
141 show sessions  
142 show startup-config   
143
show users Displays users connected to the router
new
144 show version   
145 telnet <host-name>  
146 telnet <IP-address>  
147 Lists all routers along path to destination and
traceroute <hostname>
new finds the routing problems if any.
148
traceroute <ip-address>  
new
149 username <name> password <password>  
150
version 2 For RIPv2 routing
new
151 write erase  
152 write memory  
153 write terminal  
     
List of Switch Commands Supported
Sl.No. commands Comments, if any.
1 banner motd <phrase>  
2 copy startup-config running-config  
3 configure terminal  
4 cdp advertise-v2  
5 copy running-config startup-config  
6 cdp holdtime <seconds>  
7 cdp timer <seconds>  
8 clock set hh:mm:ss <1-31> Month <2004-2035>  
9 cdp run  
10 duplex <duplex-type>  
11 description <phrase>  
12 disable  
13 enable  
14 erase startup-config  
15 enable secret <secret>  
16 enable password <password>  
17 end  
18 hostname <name>  
Depends on the switch type. For module 0, port
19 interface fastethernet <0-0>/<0-24>
1 the command is interface fastethernet 0/1
20 ip default-gateway <ip-address>  
  21
ip host<hostname> <ip-address>  
new
  22
interface range fastethernet <0-0>/<0-12>  
new
You can enter interface config mode.
example: interface vlan 1
23 interface vlan <vlan #>
(config-if)#ip address 192.168.10.1
255.255.255.0
24 ip name-server <ip-address>  
25 ip address <ip-address> <subnet mask> A switch can have one IP address. The IP
address of the switch can be accessed only
through ports that belong to the management
VLAN. 
26 line vty 0 15  
27 line console 0  
28 login  
29 logout  
  30 mac-address-table static <mac-address> vlan
 
new <valn_num> interface fastethernet <pnum>
  31
no ip address  
new
  32 It re-enables the interface when the interface is
no shutdown
new disabled.By default interfaces are enabled.
  33
no switchport mode  
new
  34
no switchport <port_security>  
new
35 password <password>  
36 reload  
37 show interfaces  
38 show history  
  39
show mac-address-table Displays mac-address-table information
new
Display version information for the hardware 
40 show version
and firmware
  41
show vlan Displays vlan information
new
  42
show vlan-membership Displays vlan membership information
new
  43
show vtp status Displays vtp status information
new
44 show startup-config  
45 show flash  
46 show running-config  
47 show ip interface brief  
Disables a port and shuts-down management
48 shutdown
vlan. no shutdown command enables a port.
49 snmp-server enable traps vtp  
50 speed <speed> Enter switch port speed 10,100, auto. 
  51
switchport access vlan <vlan_num>
new
  52
switchport mode access Access mode of the switch is set to access
new
  53
switchport mode trunk Access mode of the switch is set to trunk
new
  54 switchport port-security mac-address
 
new sticky<mac_addr>
  55
switchport port-security maximum <max_macadd>  
new
  56
switchport port-security violation <violat_mode>  
new
  57 Command for switch in interface configuration
switchport trunk encapsulation dot1q
new mode
  58 VLAN numbers can range 1-1000,However
vlan<vlan_num>
new only 64VLANs can be active at a time.
 VLAN numbers can range 1-1000, VLAN
59 vlan <vlan_num> name <vlan_name>
name can be upto 32 characters
Place the switch in VTP client mode. But it
60 vtp client does not store VLAN information in non-
volatile memory.
61 vlan database  
SW(vlan)# vtp transparent
62 vtp transparent Sets the switch to VTP TRANSPARENT
mode.
Passwords are case sensitive. Passwords should
63 vtp password <password>
match on all switches in the same domain.
VTP domain name can be 1 to 32 characters
long and identifies the VTP administrative
64 vtp domain <name>
domain for the switch. The domain name is
case sensitive.
65 vtp pruning  
Place the switch in VTP server mode. Stores
66 vtp server VLAN information in non-volatile memory.
Generates VLAN advertisements.
 
Note: The commands supported by the simulator is given above. The syntax may not be complete for
various commands. This is done intentionally to accommodate limited command set supported by the
simulator at this point of time. Please refer to official Cisco® website for complete command syntax.

A useful URL:

http://www.cisco.com/univercd/cc/../l22index.htm

Please  Email  web master for any information Site Map Web design by AnandSoft

Das könnte Ihnen auch gefallen