Sie sind auf Seite 1von 30

Getting started.

Getting started. Module 01 Introduction. In using NCG CAM you are able to create tool paths

Module 01

Introduction.

In using NCG CAM you are able to create toolpaths for the machining complex 3D forms. The toolpaths you create are also ideally suited to High Speed Machining, having smoothing arcs fitted with lead-in and lead-out radii. Additional controls allow you to make adjustments for full width cuts to help protect the cutter, the part and the machine tool. In this module you will get a feel of the layout and general function of NCG CAM.

Objectives.

Once you have completed this module you will understand:

Locate and open NCG CAM.

Change the tolerance of a model while opening it.

Insert an additional model into an existing part being worked on.

Understand what the Project settings are.

Understand the layout of the Graphics Window.

Cloning and copying the Graphics Window.

Use the (three) mouse buttons.

Use the keyboard functions for viewing.

Use the Zoom and Pan functions.

Use dynamic rotation.

View normal to a surface.

Take some basic measurements from the model – linear, radial, angular and point.

Save the part and work you have done (dca files).

linear, radial, angular and point. • Save the part and work you have done (dca files).
linear, radial, angular and point. • Save the part and work you have done (dca files).
Blank page. NCG CAM Basic Training Page 2

Blank page.

Blank page. NCG CAM Basic Training Page 2
Blank page. NCG CAM Basic Training Page 2

Exercise 1 Starting NCG CAM. Introduction.

Exercise 1 Starting NCG CAM. Introduction. In this exercise you will open a part, see how

In this exercise you will open a part, see how you can change and control the view. You will also load a part with a different tolerance, this tolerance is important on a real job as it will affect the accuracy of the part and the surface finish that is achieved. You will also insert a part into an existing database, this is something you may want to do if you machine castings, or if some other machining has been done before you start programming the toolpaths.

Objectives.

Once you have completed this module you will understand:

Open a given model in NCG CAM.

Change views and maximise the view.

Select surfaces and de-select surfaces.

Change the tolerance of the model while loading it .

Insert an additional model into an existing database.

Task 1.

Start NCG CAM and load a part.

1. Locate the NCG CAM icon on the desktop and double click on it.

Tip:

Another method would be to pick: Start > All Programs > NCG CAM 9.1 > NCG CAM 9.1

2. As NCG CAM starts, expect the Tip of the Day dialogue appear, this will feed you little tips on

NCG CAM.

Tip:

As you are starting to learn how to use NCG CAM these tip can be useful little reminders. Once you are happy and up to speed with NCG CAM you can disable the Tip of the Day.

3. Have a read of the Tip of the day and then Click OK

4. Pick File.

5. Pick Open.

6. In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

Open . 6. In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\
Open . 6. In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

7. Locate the file called pump.igs and click on it.

7. Locate the file called pump.igs and click on it. (Do not double click). Tip: To

(Do not double click).

called pump.igs and click on it. (Do not double click). Tip: To see the file extension

Tip:

To see the file extension (.igs) the 'Hide extensions for known file type' option needs to be disabled in the Windows™ configuration. Mouse right on the Start button > Explore > Tools > Folder Options Go to the View tab and then find “Hide extensions for known file types”, this options should be un-ticked to make the file extension viable. Being able to see the file extensions is recommended. Once set, that setting will remain until it is changed again.

8. Click Open.

will remain until it is changed again. 8. Click Open . Note: The image above shows

Note:

The image above shows what you screen may look like, you may even be able to see other desktop icons around the NCG CAM window. In addition to seeing the part appear in the Graphics Window, notice the Database Window behind the Graphics Window. In the contents tree there are 3 folders, Editable boundaries, Triangulated surfaces and Triangulated curves.

there are 3 folders, Editable boundaries, Triangulated surfaces and Triangulated curves. NCG CAM Basic Training Page
there are 3 folders, Editable boundaries, Triangulated surfaces and Triangulated curves. NCG CAM Basic Training Page
The Editable boundaries folder is creat ed automatically and is empty. Triangulated surfaces are the
The Editable boundaries folder is creat ed automatically and is empty. Triangulated surfaces are the

The Editable boundaries folder is created automatically and is empty. Triangulated surfaces are the 3D model from the loaded part (pump.igs). Triangulated curves may have curves (profiles) from the loaded part, don’t expect all parts you load to have triangulated curves, though the folder will always be created. Notice that on the end of the Triangulated Surfaces, there are 2 numbers, 1 and [0.02]. The 1 is just a number to help identify the folder, a new set of triangulated surfaces folder would be 2 and so on. Like files in a Windows™ folder, you can not have 2 files for the same name. The second number [0.02] by default, is actually the tolerance the surfaces have been triangulated.

9. To maximise the windows to your screen, click on the maximise window button in the top right

corner of the window.

window button in the top right corner of the window. Highlighted green here . Do this

Highlighted green here.

Do this for the Graphics Window and the main NCG CAM window.

Task 2.

Get a feel for some of the viewing functions from the keyboard.

Note:

When you load a part, by default you are looking down the Z axis (from Z+ to Z-), you will also be looking at X0 Y0 and a viewing scale of 1:1 So in some cases the part you have loaded may not be visible on the screen or may be too small to see clearly.

1. Press M this maximise the view to fit the available graphics window for the current viewing

position.

2. Press I now you have changed the view to ISO, looking down from the front left, but some of the

part may now be outside of the graphics window.

3. Press M to maximise this view to the graphics window.

4. To look along the Z axis again (looking down on the part from Z+ to Z-);

Press Z

5. Using the menus, pick: View.

6. Pick: Isometric.

7. Pick: Back right Shift+I

Note: As you may have noticed in the menus the keyboard short cuts are also
Note:
As you may have noticed in the menus the keyboard short cuts are also show.
Although you have just used the menus, pressing Shift + I would have given the same result.
you have just used the menus, pressing Shift + I would have given the same result.
you have just used the menus, pressing Shift + I would have given the same result.

8. Now to look along the X axis;

8. Now to look along the X axis; Press X this is looking from X- towards

Press X this is looking from X- towards X+, you should be seeing a view like this:

from X- towards X+, you should be seeing a view like this: 9. Press M if

9. Press M if you need to maximise the view to the screen.

10. To look along the X axis again, but looking from X+ towards X-;

Press Shift+X

11. Press M again to maximise this view and you should have a view like this:

to maximise this view and you should have a view like this: Note: That should give

Note:

That should give you an insight into some of the viewing options and keyboard short-cuts. Later in this module you will look at some other viewing options that get used frequently. After a short time changing views will become second nature because you do it so often.

Task 3.

Selecting surfaces in the graphics area.

1. Click on Triangulated Surfaces in the contents tree. That will highlight that folder, making that the

selected folder.

2. Press I to view the part in an ISO view.

3. Press M to Maximise the view.

4. Click on one of the surfaces in the graphics area, it should change colour, showing it has been

selected.

ea, it should change colour, showing it has been selected. 5. Repeat the previous step a

5. Repeat the previous step above, but on a different surface

it has been selected. 5. Repeat the previous step a bove, but on a different surface
it has been selected. 5. Repeat the previous step a bove, but on a different surface
Tip: In the last 2 steps you selected an individual surf ace one at a

Tip:

In the last 2 steps you selected an individual surface one at a time, sometimes that is what you will want. (For creating a boundary, changing the surfaces colour or deleting an unwanted surface. But in most cases you will want to select a small group of surfaces.

6. Click in the background of the graphics window, this will clear anything you had selected.

7. Check you still have the Triangulated Surfaces selected in the contents tree, if need click on

Triangulated Surfaces so they are selected.

8. Click on a surface in the graphics window.

9. While pressing Ctrl, click on another surface.

10. Repeat the above step 2 or 3 times but on a different surface each time

Note: You should now have 3 or 4 surface selected. At some point you will
Note:
You should now have 3 or 4 surface selected.
At some point you will select a surface you did not really want, there is a simple solution to this
(and it not starting again).

11. While pressing Ctrl+Shift, click on one of the surfaces you had selected in step 10. The surface

you clicked on should no longer be highlighted in the graphics window.

on should no longer be highlighted in the graphics window. Tip: In this example surfaces have

Tip:

In this example surfaces have been selected, the same principal can be applied to selecting boundaries. You will often be selecting surfaces in this manner to create boundaries, change the colour of a surface or even delete unwanted surfaces.

to create bound aries, change the colour of a surface or even delete unwanted surfaces. NCG
to create bound aries, change the colour of a surface or even delete unwanted surfaces. NCG
Task 4. Close the NCG CAM database.

Task 4.

Close the NCG CAM database.

1.

Pick File.

2.

Pick Exit.

3.

When asked "Save changes to Casting.igs?", click No.

Tip:

The changes have not been saved as this is not a real part, it is just to get a general feel for NCG CAM. On a real job you would normally be saving the part.

 

Task 5.

Open a part and change the tolerance.

1.

Start NCG CAM by clicking on the icon on the desktop.

2.

Have a read of the Tip and then Click OK.

Note:

Some of the Tip may not mean much to you at the moment, but the more you get into this course the more useful they will be as little reminders.

3.

Pick File.

4.

Pick Open.

5.

In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

6.

Find pump.igs and click on it.

(Do not double click).

Note:

Because Ctrl was depress as the file was opened the control options dialogue will be displayed.

was opened t he control options dialogue will be displayed. Now was the file is opened

Now was the file is opened additional dialogues will be shown, one of which allows the triangulation tolerance to be changed.

7.

While pressing Ctrl (keep it pressed), pick Open.

Keep Ctrl pressed until the Control Options dialogue is displayed and then release Ctrl

8.

In the Control Options dialogue ensure:

Display dialogs (Control) is ticked.

Skip triangulation (Shift) is un-ticked.

9.

Click OK.

10.

Click OK in the Project Settings dialogue.

11.

Click OK in the Top Entities dialogue.

OK in the Project Settings dialogue. 11. Click OK in the Top Entities dialogue. NCG CAM
OK in the Project Settings dialogue. 11. Click OK in the Top Entities dialogue. NCG CAM
Note: The Triangulated Surfaces dialogue will now be displayed showing the default tolerance of 0.02
Note: The Triangulated Surfaces dialogue will now be displayed showing the default tolerance of 0.02
Note:
The Triangulated Surfaces dialogue will now be displayed showing the default tolerance of 0.02

12.

In

the Tolerance area, change the General to 0.005

13.

Click OK.

14.

The Triangulated curves dialogue will then be displayed.

15.

In

the Tolerance area, change the General to 0.005

16.

Click OK.

   

Note:

In

the contents tree you should now see 0.005 at the end of the Triangulated Surfaces and the

Triangulated Curves.

of the Triangulated Surfaces and the Triangulated Curves. You will recall it was 0.02 be fore,

You will recall it was 0.02 before, when using the defaults.

A

further exercise will look at the tolerance in more detail.

17.

Put the part in an ISO view by pressing I and then M to maximise the view.

 

Task 6.

Insert another model to this database.

1.

Pick File.

2.

Pick Insert.

3.

In

the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

if

it is not already looking at that folder.

4.

Find Pump_casting.igs and click on it.

5.

Click Open.

that folder. 4. Find Pump_casting.igs and click on it . 5. Click Open . NCG CAM
that folder. 4. Find Pump_casting.igs and click on it . 5. Click Open . NCG CAM
Note: In the contents tree you should see another Triang ulated Surface folder and Triangulated

Note:

In the contents tree you should see another Triangulated Surface folder and Triangulated Curves folder. The Triangulated Surfaces and Triangulated Curves have the default 0.02 tolerance

and Triangulat ed Curves have the default 0.02 tolerance If you were to have pressed Ctrl

If you were to have pressed Ctrl while clicking Open (step 5 above) you would have been presented with additional dialogues, allowing the triangulation tolerance to be changed. Expect the inserted surfaces not to be drawn by default.

6. Click in the check box beside Triangulated Surfaces 2, this should make those surfaces visible.

Surfaces 2, this should make those surfaces visible. Tip: This is a something you may do

Tip:

This is a something you may do if machining a casting, where one model represents the finished part and the other represents the casting. By using both any fresh air cutting can be avoided. Or it could be that you plan to machine 2 or more parts as an assembly, after opening the first part the other parts can be inserted, then they can be joined together.

Task 7.

Close the NCG CAM database (without saving).

1. Pick File.

2. Pick Exit

3. When asked "Save changes to Casting.igs?", click No.

This completes this exercise.

asked "Save change s to Casting.igs?", click No. This completes this exercise. NCG CAM Basic Training
asked "Save change s to Casting.igs?", click No. This completes this exercise. NCG CAM Basic Training
Exercise 2 The Project Settings and Graphics Windows. Introduction. In this exercise you will learn

Exercise 2 The Project Settings and Graphics Windows. Introduction.

In this exercise you will learn more about the options in the Project Settings dialogue. These can be used to your advantage if you have dedicated locations for NC tape files. You will also discover how you can clone and copy the graphics window, which can be useful to separate different stages or machining setups.

Objectives.

Once you have completed this module you will understand:

 

The project settings dialogue.

How to clone and copy graphics windows.

Task 1.

Start NCG CAM and load a part.

1. Locate the NCG CAM icon on the desktop and double click on it.

2. Have a read of the Tip of the day and then click OK.

3. Pick File.

4. Pick Open.

5. In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

6. Locate the file hsm.igs and click on it.

7. Click Open.

8. Study the Project Settings dialogue.

Note:

The options in the project settings give you as the user control as to where the NC tape file or part will be saved, any additional comment or note you want to save with the part.

Folder :

By default the Folder shows the ‘path’ to where the file was opened. This can be changed to a different folder or even another computer on the network if needed. It is where the part (the dca file) will be saved to later.

Tape Folder :

By default the Tape Folder will also show the ‘path’ to where the file was opened. This can be changed to different folder and or computer. It is where the NC Tape file will be saved.

Toolsheet Folder :

By default this will contain the 'path' to where the part was opened from. If you create a tooling sheet to go to the machine with the NC tape file, this is the folder the toolsheet and associated files will be saved and can be set to a different computer on the network or folder.

Prefix :

The Prefix is taken from the name of the file being opened and will be the name of the dca file or

is taken from the name of the file bei ng opened and will be the name
is taken from the name of the file bei ng opened and will be the name
the start of the NC Tape files, T ooling sheets. The NC Tape file and

the start of the NC Tape files, Tooling sheets. The NC Tape file and tooling sheets make use of the Next Tape Number also, in conjunction with the Prefix name.

Defaults :

Once you have started using NCG CAM and are proficient, it is possible to save your own preferred defaults for a dialogue under a profile name. A preferred profile can then be chosen here and dialogues we have your defaults not the NCG CAM defaults.

Engineer :

The default name will be the login name for the computer, but can be changed for the name of the 'real' user if different. This name will appear on the tooling sheets and can optionally appear in the NC Tape file.

Tool Database :

You can select the tool database or tool library to use, making cutter selection quicker.

Material :

The relevant material can be chosen from here, once it has been defined. This will affect the cutting speed below.

Cutting speed :

This is the cutting speed for the current material being cut and will have an effect on the default feeds and speeds that are calculated.

Next Tape Number :

The next NC Tape file number, this will increment up by 1 each time a post-processed file is created.

Comments :

This is like a note pad for any important comments about the job.

9. Click OK to continue loading the part.

Note:

You can get back to the project settings at any time by picking Edit > Project Settings.

at any time by picking Edit > Project Settings . 10. Click on the 11. Press

10. Click on the

11. Press M to maximise the view.

(ISO view) button in the toolbar.

M to maximise the view. (ISO vi ew) button in the toolbar. Task 2. Create a

Task 2.

Create a bounding box from the part.

1. Click on Triangulated Surfaces 1 in the contents tree to make that the selected or 'active' item.

2. With the cursor in the graphics area of the screen, mouse right.

3. From the menu, pick Bounding Box.

4. Click OK in the Bounding Box dialogue.

right. 3. From the menu, pick Bounding Box . 4. Click OK in the Bounding Box
right. 3. From the menu, pick Bounding Box . 4. Click OK in the Bounding Box
Tip: The menu that is displayed when you do a mouse right like you have

Tip:

The menu that is displayed when you do a mouse right like you have just done. is sensitive to what you had selected or active at the time.

Task 3.

Clone the graphics window.

1. Pick Window.

2. Pick Clone Graphics Window

Note: That makes an exact copy of your current Graphics Window. This can be useful
Note:
That makes an exact copy of your current Graphics Window.
This can be useful if you want to experiment with something without putting the work you have
done at risk.
You can save the part with more than one graphics window

Task 4.

Copy the graphics window.

1. Pick Triangulated Surfaces 1 in the contents tree.

2. While pressing Ctrl, pick Bounding Box 1

Tip:

Both items (Triangulated Surfaces 1 and Bounding Box 1) should be highlighted in the contents tree.

Tip: Both items (Triangulated Surfaces 1 and Bounding Bo x 1) should be highlighted in the

3. Click Window.

4. Click Copy Graphics Window.

be highlighted in the contents tree. 3. Click Window . 4. Click Copy Graphics Window .
be highlighted in the contents tree. 3. Click Window . 4. Click Copy Graphics Window .
Note: Because Copy Graphics Window was used, then new graphics window only contains the items
Note: Because Copy Graphics Window was used, then new graphics window only contains the items
Note:
Because Copy Graphics Window was used, then new graphics window only contains the items
that were selected (highlighted in the contents tree) before the copy Graphics window was
performed.
This can be useful if you want to have the part in a single database, but also want different
graphics window for different setups or for pre / post heat treatment machining.

Task 5.

Close the NCG CAM database (without saving).

1. Pick File.

2. Pick Exit.

3. When asked "Save changes to Casting.igs?", click No.

This completes this exercise.

asked "Save change s to Casting.igs?", click No. This completes this exercise. NCG CAM Basic Training
asked "Save change s to Casting.igs?", click No. This completes this exercise. NCG CAM Basic Training

Exercise 3 Mouse and Keyboard Functions. Introduction.

Exercise 3 Mouse and Keyboard Functions. Introduction. This exercise is to help you learn more about

This exercise is to help you learn more about the mouse and keyboard functions. You have already seen some in exercise 1 and 2. These are often referred to as Hot keys or Shortcut keys. Being able to get the part into the correct view to see what is happening is important. These are functions you will do many times on each job, some are options on the toolbar and are in the menus, but most are available as keyboard functions. You will also find yourself using the mouse and keyboard at the same time.

Objectives.

Once you have completed this module you will understand:

The use of the mouse buttons .

Keyboard viewing keys.

Dynamic rotation.

Zooming in on an area.

Panning the view.

Viewing normal to a given surface.

Task 1.

Start NCG CAM and load a part.

1. Start NCG CAM by double clicking on the desktop icon.

2. Have a quick read of the Tip of the day, before clicking OK.

3. Pick File.

4. Pick Open.

5. In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

6. Locate the file hsm.igs and click on it

7. Click Open

8. Click OK in Project Settings dialogue to continue loading the part.

9. Click on the

dialogue to continue loading the part. 9. Click on the (ISO vi ew) button in the

(ISO view) button in the toolbar.

dialogue to continue loading the part. 9. Click on the (ISO vi ew) button in the
dialogue to continue loading the part. 9. Click on the (ISO vi ew) button in the
10. Press M to maximise the view to the available screen area. Task 2. Examine

10. Press M to maximise the view to the available screen area.

Press M to maximise the view to the available screen area. Task 2. Examine the Mouse

Task 2.

Examine the Mouse help page.

1. Pick Help.

2. Pick Mouse Controls. This opens the NCG CAM Help window, on the mouse controls page.

Note: One of the first things you may notice is that many functions are really
Note:
One of the first things you may notice is that many functions are really mouse and keyboard. Do
not worry about how many there are, as you use then you do remember them. And you will be
guided throughout these training exercises.
Everyone will have their preferred methods (this again is what suits you best, not a wrong and
right way). The author of this manual used the mouse in the right hand (held between thumb and
little finger with a finger over the 3 mouse buttons). That leaves the left hand for the keyboard.
Given a bit of time you will find out what is most comfortable and quickest for yourself.

3. Review the table that explains the function of different mouse buttons.

4. Close the Help window using the button in the top right of the help window.

using the butt on in the top right of the help window. Highlighted in green here.

Highlighted in green here.

Task 3.

Examine the Keyboard help page.

1. Pick Help.

2. Pick Keyboard Controls. This opens the NCG CAM Help window, on the keyboard controls

page.

Keyboard Controls . This opens the NCG CAM Help window, on the keyboard controls page. NCG
Keyboard Controls . This opens the NCG CAM Help window, on the keyboard controls page. NCG
Note: The help for Keyboard Controls is split into different section Changing Views, Boundaries, Navigating
Note: The help for Keyboard Controls is split into different section Changing Views, Boundaries, Navigating
Note:
The help for Keyboard Controls is split into different section Changing Views, Boundaries,
Navigating and more.
You will use functions from Changing Views quite a lot, functions Boundaries will also be used,
but there are some you may never use as the toolbar or menus are more convenient.

3. Review the table that explains the function of different mouse buttons.

4. Close the Help window using the button in the top right of the help window.

window using the button in the top right of the help window. Highlighted in green here.

Highlighted in green here.

Task 4.

Using the Hot Keys to change view.

Tip:

Study the current view of the part and create a mental image of the part in your head, you should be looking at the part in an isometric view, from the front left and above. Having the mental image of the part will help you understand the following view and what is happening.

1. Press Z.

The view should now be looking down the Z axis, from Z+ to Z-.

view should now be looking down the Z axis, from Z+ to Z-. 2. Press Y

2. Press Y.

The view is now looking along the Y axis, from Y- to Y+.

Y . The view is now looking along the Y axis, from Y- to Y+. 3.

3. Press I.

The view is now ISO, looking down from the front left.

I . The view is now ISO, looking down from the front left. 4. Press M

4. Press M.

This will maximize the view of the part to the available screen area.

left. 4. Press M . This will maximize the view of the part to the available
left. 4. Press M . This will maximize the view of the part to the available
5. Press L . This changes the viewing scale to be ab out 1:1 or

5. Press L. This changes the viewing scale to be about 1:1 or Life size, but can be affected by

screen resolution.

6. Press Ctrl + I. This is an isometric view again, but looking down from the front right.

isometric view again, but looking down from the front right. 7. Press M . To maximize

7. Press M. To maximize the view.

8. Press Shift + X. The view is now looking along the X axis from X+ towards X-.

The view is now looking along the X axis from X+ towards X-. Task 5. Change

Task 5.

Change view using the menus.

1. Pick View.

2. Pick Along Axis.

3. Pick Bottom View

Shift + Z

Tip:

The Shift + Z part of that menu option is the keyboard shortcut. If an option in the menus has a shortcut, it will be shown.

4. Pick View.

5. Pick Isometric.

6. Pick Back left

Ctrl + Shift + I

Tip: Remember you have a ctrl and shift to the right of the main keys
Tip:
Remember you have a ctrl and shift to the right of the main keys as well as the left.
Typical UK Keyboard layout. Ctrl and Shift key highlighted in green.

7. Pick View.

8. Pick Along Axis.

9. Pick Top View

Z

Task 6.

Use the dynamic rotation.

1. Place the cursor near the centre of the graphics area - the exact position is not that important.

2. Hold the mouse centre button down

3. Move the mouse to dynamically rotate the view.

Note:

You are rotating the view of the part, not repositioning the part relative to the XYZ axis.

4. Release the centre mouse button and the part will stay in at view, until you change the view.

the centre mouse button and the part will stay in at view, until you change the
the centre mouse button and the part will stay in at view, until you change the
Task 7. Zoom in on an area.

Task 7.

Zoom in on an area.

1. Place the cursor near the centre of the area you want to zoom in on - in this instance it does not

matter which are is zoomed in on.

2. Hold Ctrl + Shift, then press and hold the mouse centre (at this point ctrl + shift may be

released, but not mouse centre).

3. Move the mouse to see a zoom rectangle - this is the area that will be zoomed in on.

4. Release the mouse centre button - the view will change maximising the zoom rectangle to the

screen.

Task 8.

Use the dynamic panning.

1. Place the cursor near the centre of the graphics area - the exact position is not that important.

2. Hold Shift, then press and hold the mouse centre.

3. Move the mouse across the screen, in the direction you want to pan- in this instance the direction

is not that important.

Note:

You are moving the view of the part, not repositioning the part relative to the XYZ axis.

4. Release Shift and mouse centre, the part will stay in that view.

Task 9.

Viewing normal to a surface.

1. Press I.

2. Press M.

3. Ensure that Triangulated Surfaces 1 is highlighted in the contents tree, if it is not, click on it once.

in the contents tree, if it is not, click on it once. Tip: As this view

Tip:

As this view is going to be normal to a surface, the software has to know which surfaces folder to work with. It is possible and not uncommon to have more than 1 triangulated surfaces folder.

4. Place the cursor over the surface to view normal to. The suggested surface is marked with A in

the following image.

suggested surface is marked with A in the following image. 5. While holding N down, click

5. While holding N down, click on the surface identified as A above.

following image. 5. While holding N down, click on the surface identified as A above. NCG
following image. 5. While holding N down, click on the surface identified as A above. NCG

6. Release the N key.

6. Release the N key. Tip: While the viewing normal to a surface can be usef
6. Release the N key. Tip: While the viewing normal to a surface can be usef

Tip:

While the viewing normal to a surface can be useful when looking at a part, it is mostly used when creating 3_2 toolpaths.

Task 6.

Close the NCG CAM database (without saving).

1. Pick File.

2. Pick Exit.

3. Do not save the changes to the existing file.

This completes the exercise

Pick Exit . 3. Do not save the changes to the existing file. This completes the
Pick Exit . 3. Do not save the changes to the existing file. This completes the

Exercise 4 Measuring Functions. Introduction.

Exercise 4 Measuring Functions. Introduction. Quite often you will want to check the size of the

Quite often you will want to check the size of the part or a local area of the part. How wide is this slot, or how deep is this pocket, what radius is this fillet. In this exercise you will find out how to use the measuring rod. You could liken it to measuring the part with a set of calipers. As NCG CAM is a CAM system, it should not be likened to dimensioning as you would in a CAD system.

Objectives.

Once you have completed this module you will be able to measure:

Linear distances, while locking different axis .

Radii, internal or external.

An angle.

A point in the edge of a surface.

See how the cursor tracks XYZ on the surfaces.

Task 1.

Start NCG CAM and load a part and maximise to the screen.

1. Start NCG CAM by double clicking on the desktop icon.

2. Have a quick read of the Tip of the day, before clicking OK.

3. Pick File.

4. Pick Open.

5. In the Open dialogue, use the ‘Look in’ and browse to: C:\NCG CAM\Training\

6. Locate the file pump.igs and click on it

7. Click Open

8. Click OK in Project Settings dialogue to continue loading the part.

in Project Settings dialogue to continue loading the part. 9. Click on the 10. Press M

9. Click on the

10. Press M to maximise the part to the screen.

(ISO view) button in the toolbar.

Task 2.

Rotate the view and zoom in.

1. Ensure that Triangulated Surfaces is selected in the tree on the left. Click on it if required.

Tip:

To make life easier, you need to dynamically rotate the view and then zoom in on the area of interest.

2. Place the cursor near the middle of the graphics area.

3. Press and hold mouse centre, then move the mouse to rotate the view, aim for something like

the following:

centre , then move the mouse to rotate the view, aim for something like the following:
centre , then move the mouse to rotate the view, aim for something like the following:
The red box indicates the area to zoom in on. 4. Place the cursor in
The red box indicates the area to zoom in on. 4. Place the cursor in

The red box indicates the area to zoom in on.

4.

Place the cursor in the middle of the area to zoom in on.

5.

Press and hold Ctrl + Shift, then while holding mouse centre, drag a zoom box out. Aim for the area in the red box in the previous image.

11.

The aim is to measure the distance between two points, shown as A and B in the following image:

two points, shown as A and B in the following image:   Task 3. Measure a
 

Task 3.

Measure a linear distance on the part.

1.

Place the cursor at the intersection near A, this defines the point to measure from.

2.

While holding Ctrl, press and hold mouse right, you can release Ctrl now.

2. While holding Ctrl , press and hold mouse right , you can release Ctrl now.
2. While holding Ctrl , press and hold mouse right , you can release Ctrl now.
3. Drag the mouse over to the intersection near B as the point to measure

3.

Drag the mouse over to the intersection near B as the point to measure to.

to the intersection near B as the point to measure to. You should get 94.0, but

You should get 94.0, but this is dependent on how accurate you are with the cursor positions.

4.

Release the mouse right button, the measured distance will disappear.

 

Task 4.

Pan the view.

1.

Place the cursor towards the left of the graphics window

2.

While holding Shift, press and hold mouse right.

3.

Move the mouse towards the right of the screen slightly, aim for a view like this:

the right of the screen slightly, aim for a view like this: In the image above

In the image above A and B are the levels you need to see as they are the 2 positions to measure between in the next task.

 

Task 5.

Measure a linear distance on the part, while locking axis.

1.

Ensure the Triangulated Surfaces are still selected in the contents tree.

2.

Place the cursor at the intersection near A, this defines the point to measure from.

3.

While holding Ctrl, press and hold mouse right, you can release Ctrl now.

6.

Drag the mouse over to the intersection near B as the point to measure to. Do not release mouse right.

to the intersection near B as the point to measure to. Do not release mouse right.
to the intersection near B as the point to measure to. Do not release mouse right.
Tip: You will be seeing a measured distance an a line represen ting the measuring

Tip:

You will be seeing a measured distance an a line representing the measuring rod.

distance an a line represen ting the measuring rod. In the image above that distance is

In

the image above that distance is 60.6 don't expect to have the same distance. But that is not

the height difference between the 2 levels, it is the length of the measuring rod line, so not much use at the moment.

4. While keeping mouse right pressed, press and hold X + Y, read the distance while X and Y are

pressed.

hold X + Y , read the distance while X and Y are pressed.   Note:
 

Note:

By locking the axis it is possible to measure in the direction required. In this example both X and

Y

were locked, it is possible to lock just 1 axis to 2 other axis, locking Y and Z would measure in

X

only.

Remember that 45.0 distance – it plays a part in another task in this exercise.

5. Release the locked axis, X and Y.

6. Release the mouse right button.

Task 6.

Using the cursor tracking.

1. Position the cursor somewhere on the part, the exact position is not important.

2. Look at the status bar across the bottom of the NCG CAM window, you will see the XYZ position

of the cursor.

across the bottom of the NCG CAM window, you will see the XYZ position of the
across the bottom of the NCG CAM window, you will see the XYZ position of the
across the bottom of the NCG CAM window, you will see the XYZ position of the
3. Place the cursor on the surface you measur ed from in the previous task,

3. Place the cursor on the surface you measured from in the previous task, position A.

surface you measur ed from in the previous task, position A. 4. Make a mote of

4. Make a mote of the Z value, you should have 105.00

5. Place the cursor on the surface you measured to, position B.

6. Make a mote of the Z value here, it should be 60.00

7. So a simple 105 - 60 = 45, which is the value you measured between the same levels while

locking the X and Y axis.

Tip:

While the cursor is over the part XYZ values will be displayed in the status bar. If the view is not along an axis, when the cursor is on the background no XYZ value will be displayed in the status bar. If viewing along an axis 2 of the axis will be displayed in the status bar, viewing in Z, X and Y are displayed in the status bar, viewing along Y would display X and Z in the status bar, even when the cursor is not over the part.

Task 7.

Measuring a radius.

1. Press Z.

2. Press M.

3. Place the cursor over the 'lug or flange' at the back of the part.

4. While pressing Ctrl + Shift, use mouse centre to drag a zoom box out to cover the area show in

the following image.

zoom box out to cover the area show in the following image. 5. Place the cursor

5. Place the cursor on the flange feature, near A on the image above.

6. While holding Ctrl, press and hold mouse right. Ctrl can be released, but not mouse right.

7. Move the mouse over to position B on the above image, but still keep mouse right pressed. This

is currently showing a linear distance through the part.

keep mouse right pressed. This is currently showing a linear distance through the part. NCG CAM
keep mouse right pressed. This is currently showing a linear distance through the part. NCG CAM
8. Press and hold R , this will give a radius value as shown in

8. Press and hold R, this will give a radius value as shown in the following image.

will give a radius value as shown in the following image. Tip: This radius is calculated

Tip:

This radius is calculated by fitting a circle through 3 points, A, B and C on the image shown in step 4. In the image above points A and B are the start position and the current cursor position, you can see the third point C as a dot in the middle of the measuring rod. So you need to keep the measuring line perpendicular to the radius for good results. When measuring a radius you can not lock an axis.

9. Release R and mouse right.

Task 8.

Measuring an angle.

1. Press Shift + Y.

2. Press M.

3. Place the cursor in the middle of the 'flange feature'.

4. While pressing Ctrl + Shift, use mouse centre to drag a zoom box out to cover the area show in

So you are viewing from Y+ towards Y-.

the following image.

So you are viewing from Y+ towards Y-. the following image. 5. Place the cursor close

5. Place the cursor close to the centre line of the flange feature, near the bottom of the part.

6. Press and hold Ctrl.

7. Press and hold mouse right (Ctrl can be released).

8. Move the cursor towards the top of the flange, keeping the measuring rod vertical.

9. Press and hold A to display the angle.

flange, keeping the measuring rod vertical. 9. Press and hold A to display the angle. NCG
flange, keeping the measuring rod vertical. 9. Press and hold A to display the angle. NCG
flange, keeping the measuring rod vertical. 9. Press and hold A to display the angle. NCG

10. Release the A key and mouse right.

10. Release the A key and mouse right. Note: The angle displayed (87.0° in the previous

Note:

The angle displayed (87.0° in the previous image) is measured from the horizontal plane.

Task 9.

Measuring an individual point.

1. Press I.

2. Press M.

3. Ensure that Triangulated Surface is selected in the contents tree on the left.

4. Click the 3 point circle button

in the toolbar.tree on the left. 4. Click the 3 point circle button That will force the part

That will force the part to be displayed as a wire frame.

That will force the part to be displayed as a wire frame. The red circle indicates

The red circle indicates the corner to measure.

5. Place the cursor on the position to me measured.

NCG CAM will snap to the intersection, but you need to be reasonably close.

6. Press and hold Ctrl.

7. Click mouse left. The Datum point dialogue will be displayed, showing the coordinates of the

point picked.

be displayed, showing the coordinates of the point picked . Note: The Datum point dialogue will

Note:

The Datum point dialogue will allow that point to be set as the parts datum in XY (Set as datum) or XYZ (set as datum with Z).

8. Click OK.

9. Click on the 3 point circle button to switch that function off.

Task 10.

Measuring a radius from the wire frame.

1. If needed press I and then M to get a suitable view and maximise the part to the screen.

2. Ensure that Triangulated Surface is selected in the contents tree on the left.

3. Click the 3 point circle button

in the toolbar.Surface is selected in the contents tree on the left. 3. Click the 3 point circle

in the contents tree on the left. 3. Click the 3 point circle button in the
in the contents tree on the left. 3. Click the 3 point circle button in the
4. The following image shows 3 red dots in the radius to me measured. 5.

4. The following image shows 3 red dots in the radius to me measured.

image shows 3 red dots in the radius to me measured. 5. Place the cursor over

5. Place the cursor over the wire frame in a similar position to the left hand red dot and click mouse

left.

6. Move the cursor around the wire frame to close to where the middle red dot is and click mouse

left.

7. Move the cursor around the wire frame to close to where the right hand red dot is and click

mouse left.

This last click will display the Circle centre dialogue.

. This last click will display the Circle centre dialogue. Note: The Circle centre dialogue provides

Note:

The Circle centre dialogue provides details of the circles centre, the radius and diameter. It will also allow circles centre to be set as the parts datum in XY (Set as datum) or XYZ (set as datum with Z).

8. Click OK.

9. Click on the 3 point circle button to switch that function off.

That completes this exercise, but do not close NCG CAM.

on to switch that function off. That completes this exercise, but do not close NCG CAM.
on to switch that function off. That completes this exercise, but do not close NCG CAM.

Exercise 5

Saving the project. Introduction.

Exercise 5 Saving the project. Introduction. In most cases you want to save what you have

In most cases you want to save what you have done. Then you can reopen the database and see what was done before, or append to what you had done.

Objectives.

Once you have completed this module you will be able to measure:

Save the part (dca.file).

Task 1.

Save your work.

1. Pick File.

2. Pick Save.

Note:

The system will display the Save As dialogue – the filename shown has been extracted from the Prefix setting in the Project Settings dialogue. The file is given the extension dca automatically. The dca file contains the triangulated surfaces, any boundaries and any toolpaths that may have been created. The dca file can be re opened later in the same as an iges file , though you won't

be presented with the Project settings dialogue.

3. Click the Save button.

4. Pick File.

5. Pick Exit.

This completes the exercise.

3. Click the Save button. 4. Pick File . 5. Pick Exit . This completes the
3. Click the Save button. 4. Pick File . 5. Pick Exit . This completes the
Summary Having completed this module succe ssfully you should understand how to: • Open a

Summary

Having completed this module successfully you should understand how to:

Open a given model in NCG CAM.

Change views and maximise the view.

Select surfaces and de-select surfaces.

Change the tolerance of the model while loading it .

Insert an additional model into an existing database.

The project settings dialogue.

How to clone and copy graphics windows.

The use of the mouse buttons.

Keyboard viewing keys.

The use of the mouse buttons.

Keyboard viewing keys.

Dynamically rotate the view.

Zoom in on an area.

Pan the view.

View normal to a given surface.

Measure linear distances, while locking different axis .

Measure radii, internal and external.

Measure an angle.

Measure a point in the edge of a surface.

The cursor tracks XYZ on the surfaces.

Measure a radius from the edge of a surface.

Save the part as a DCA file.

• Measure a radius from the edge of a surface. • Save the part as a
• Measure a radius from the edge of a surface. • Save the part as a