You are on page 1of 17

Con el ordenador a cuestas

http://blog.educastur.es/sofwarelibre

Cap. 2. Insertando texto e


imagen en el documento
En este capítulo iniciaremos la introducción de texto e imagen en un documento de Scribus:

1. Los marcos de texto


2. Los marcos de imagen

1.- LOS MARCOS DE TEXTO

Los marcos de texto son cuadros contenedores de texto los cuales se manejan de forma
independiente respecto a otros marcos de texto u objetos contenidos en el documento. Muchos
procesadores de texto incorporan esta herramienta, aunque no son la forma habitual de intro-
ducir texto en el caso de un procesador de texto. En un programa de autoedición como Scribus
son muy necesarios ya que ofrecen un control total sobre el texto y su independencia sobre
otros elementos del documento permiten una correcta maquetación del mismo.

Insertar y formatear un texto


Para insertar un cuadro de texto puedes acudir al menú Insert – Marco de texto, ha-
cer clic sobre el botón correspondiente de la barra de herramientas o pulsar la tecla T de tu te-
clado. Observa que el cursor del ratón adopta el icono propio del marco de texto. Ahora puedes
dibujar el marco en el lugar deseado haciendo clic en el punto elegido y arrastrando el ratón
hasta que adopte el tamaño elegido. Una vez insertado el marco de texto dispones de dos for-
mas diferentes de introducir el texto en su interior: la primera, más visual (WYSIWYG – What
You See Is What You Get, “lo que ves es lo que obtienes”) pero menos eficiente en Scribus, es
hacer doble clic en el interior del marco. Aparecerá el cursor del ratón indicándote que has pa-
sado a modo edición y que puedes comenzar a teclear el texto.

Figura 2.1. Marco de texto en el documento e inserción de texto en el mismo

1
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

La segunda, mucho más eficaz, es utilizar un pequeño editor externo que incorpora Scri-
bus llamado Story Editor (editor que no es del tipo WYSIWYG por lo cual no apreciarás los
cambios en el texto directamente). Para activar este editor haz clic con el botón derecho del ra-
tón sobre el marco de texto y selecciona en el menú contextual emergente la opción Editar
texto (el mismo resultado obtendrás si pulsas el botón correspondiente a Editar texto de la ba-
rra de herramientas de Scribus situada en la parte superior de la pantalla).

Figura 2.2. Menú contextual del botón derecho del ratón sobre el marco de texto

Aparecerá entonces la ventana Story Editor que te permitirá editar el texto que acabas
de introducir en el marco de texto. Puedes también, si lo prefieres, introducir el texto directa-
mente en el editor Story Editor utilizando el espacio en blanco situado en la parte inferior de di-
cha ventana. El formato del texto tecleado será el establecido de manera predeterminada en la
configuración inicial de Scribus en una instalación básica y que podrás apreciar en Archivo –
Preferencias – botón Herramientas – Icono Fuentes y que, si no lo has modificado, será
formato de fuente Times New Roman, tamaño 12 puntos, color de fuente negro.

2
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Figura 2.3. Editor interno de Scribus: Story Editor

Story Editor te permite editar directamente el texto seleccionando previamente el texto


a formatear y utilizando las opciones disponibles en sus barras de herramientas:

● Barra de archivo
● Barra de configuración de fuente
● Barra de configuración de estilo
● Barra de configuración de carácter
● Barra de configuración del trazo
● Barra de configuración de relleno

Figura 2.4. Barras de herramientas de Story Editor

3
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

BARRA DE ARCHIVO

Figura 2.5. Story Editor – Barra de archivo

Las funciones de la barra de Archivo del editor son, de izquierda a derecha, las siguien-
tes:

1. Borra todo el texto del editor: útil para resetear el contenido del marco del texto y vol-
ver a comenzar a teclear un nuevo texto
2. Importa un archivo de texto plano en el editor. Te permite introducir en el marco de tex-
to el contenido de un archivo de texto txt previamente tecleado y convenientemente
guardado en tu equipo.
3. Guarda en un archivo de texto plano el contenido del editor. Operación inversa a la an-
terior, guarda el contenido del marco de texto a un archivo de texto plano.
4. Actualiza el marco y sale del editor. Utilízalo cada vez que quieras validar los cambios
que has introducido en el marco de texto. El editor Story Editor se cerrará y verás cómo
ha quedado el texto en el marco.
5. Sale del editor sin actualizar los cambios.
6. Actualiza el editor con el contenido del marco: recarga el texto desde el marco, no sales
del editor y puedes seguir editando el texto y probando otras opciones.
7. Busca y reemplaza texto dentro del contenido del editor.

BARRA DE CONFIGURACIÓN DE FUENTE

Figura 2.6. Story Editor – Configuración de fuente

A través de esta barra de herramientas puedes modificar aspectos relacionados con la


fuente o tipografía:

● Listado de fuentes: permite modificar el tipo de letra del texto previamente selecciona-
do.
● Tamaño de fuente definido en puntos
● La anchura del carácter. Se mide en porcentaje y no afecta al espaciado.
● La altura del carácter. Se mide en porcentaje y no afecta al espaciado.

Es necesario comentar que en Scribus son tipos de letra diferentes, por ejemplo, Nimbus
Roman, Nimbus Roman Medium y Nimbus Roman Italic. Es decir, que no ocurre como con los
procesadores de texto en los que se selecciona un tipo de fuente como Nimbus Roman y segui-
damente se define, a través de determinados botones, el aspecto de la fuente (negrita, cursiva
o negrita-cursiva). En Scribus todos estos aspectos son fuentes diferentes. Por ejemplo, si quie-
res Nimbus Roman con aspecto negrita, en Scribus tienes que seleccionar como fuente Nimbus
Roman Regular Italic.

4
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

BARRA DE CONFIGURACIÓN DE ESTILO

Figura 2.7. Story Editor – Configuración de estilo

En esta barra se localizan los botones de justificación del texto junto con un control para
seleccionar los estilos predefinidos. La alineación izquierda es la que se encuentra predetermi-
nada por defecto, pero podrás elegir otros tipos de alineación del párrafo como centrado, dere-
cha, justificada. De los estilos te hablaremos más adelante.

BARRA DE CONFIGURACIÓN DE CARÁCTER


Esta barra permite modificar los atributos de los caracteres seleccionados previamente.
Algunos botones como los de subrayado, tienen una pequeña flecha en la esquina inferior de-
recha. Esta flecha indica que al hacer clic con el ratón sobre el botón correspondiente y mante-
nerlo pulsado cierto tiempo (medio segundo aproximadamente) aparecen más opciones rela-
cionadas. A partir de aquí, nombraremos a estas opciones como Opciones de botón.

Figura 2.8. Story Editor – Configuración de carácter

Las funciones de esta barra son las siguientes, de izquierda a derecha:

● Subrayado completo. Este botón subraya el texto seleccionado incluyendo los espa-
cios en blanco entre palabras. Esta herramienta tiene dos opciones de botón que son el
desplazamiento y la anchura de la línea. La primera contiene la distancia entre la base
del texto y la posición de la línea de subrayado. La segunda controla la anchura de la lí-
nea de subrayado.

● Subrayado de palabras. Este botón subraya sólo las palabras y no los espacios en
blanco entre palabras. Aquí también dispones de dos opciones de botón idénticas a las
de la herramienta anterior y que realizan la misma función.

● Subíndice y superíndice. Estos botones ponen el texto seleccionado como subíndice


o superíndice respectivamente.

● Mayúsculas. Este botón cambia todo el texto a mayúscula.

● Versalitas. Esta opción pone el texto con aspecto versalitas. Es decir, tiene la forma de
las versales (la palabra versal es sinónimo de mayúscula) con aspecto de letra mayúsu-
cula de un tamaño cercano a las letras minúsculas (generalmente algo mayor). Suelen
utilizarse para escribir párrafos de texto integralmente escritos en mayúscula, con obje-
to de evitar cansar al lector, también se suelen escribir en versalitas los números romas
y las siglas.

5
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

● Tachado. Con este botón se activa el tachado en todos los caracteres seleccionados
previamente. Esta herramienta tiene dos opciones de botón idénticas a las del subraya-
do.

● Línea exterior (Outline). Esta función añade una línea exterior bordeando el texto se-
leccionado. Esta función tiene una opción de botón que es el ancho de línea del borde.
El color del trazo del texto se puede modificar con la siguiente barra de herramientas
(color del trazo del texto).

● Sombra de texto (Shadowed text). Esta herramienta añade una sombra al texto se-
leccionado. Esta función tiene dos opciones de botón: X-Offset e Y-Offset, respectiva-
mente varían la profundidad de la sombra del eje X e Y.

● Separación entre los caracteres. Medido en porcentaje, indica la separación entre


los caracteres que componen cada palabra. A medida que aumenta el porcentaje, au-
menta la separación entre las letras dejando un cierto espacio en blanco.

BARRA DE CONFIGURACIÓN DE COLOR DEL TRAZO


Para utilizar esta herramienta se debe de haber activado previamente la función de lí-
nea exterior del texto (Outline) descrita en el punto anterior. Lo que hace esta herramienta es
modificar el color para la línea mencionada anteriormente. A la derecha del control que modifi-
ca el color existe un control para modificar también el porcentaje de intensidad del color aplica-
do al trazo.

Figura 2.9. Story Editor – Configuración del color del trazo

BARRA DE CONFIGURACIÓN DE COLOR DE RELLENO


Esta herramienta funciona exactamente igual que la anterior pero para la sombra y re-
lleno del texto.

Figura 2.10. Story Editor – Configuración de color de relleno

Nota. Se pueden modificar aspectos estéticos del editor como la fuente a usar y el
fondo a través del menú Preferencias.

6
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Insertar símbolos especiales


Otra de las herramientas del editor externo de Scribus es la posibilidad de insertar ca-
racteres especiales. Esto se hace a través del menú Insertar. Por ejemplo, dentro de este
menú existe la opción Insert Glyph... Esta opción inserta un carácter desde un cuadro de sím-
bolos con todos los códigos de la fuente seleccionada. Esta opción suele estar disponible en
casi todos los procesadores de textos como Insertar símbolo.

Figura 2.11. Insertar símbolos especiales

El procedimiento es muy sencillo: según la fuente que se esté utilizando se selecciona el


filtro de tipos de código en Character Class y se hace clic sobre el símbolo deseado. La venta-
na ofrecerá una previsualización en la parte inferior del carácter especial. Para incluirlo en el
marco de texto debes hacer clic sobre el botón Insertar.

Este mismo menú Insertar te permite insertar otro tipo de objetos como números de pá-
gina, el carácter especial de copyright, trademark, de marca registrada, etc.

7
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Menú contextual de un marco de texto


Cuando se hace clic con el botón derecho del ratón sobre un marco de texto, emerge un
menú contextual con diversas opciones, algunas de ellas muy interesantes (ya has visto la op-
ción Story-Editor).

Figura 2.12. Menú contextual en un marco de texto

● Información. Ofrece información de ciertos aspectos diferentes según el objeto selec-


cionado. En el caso de un marco de texto informa sobre el número de palabras, el nú-
mero de caracteres o el número de párrafos del marco.

● Cargar texto. Permite cargar un texto contenido en un archivo externo con distintos
formatos. Los formatos soportados para la importación de texto son: .csv, .htm, .hml,
.odt (Open Document, formato nativo de OpenOffice), .pdb (Palm PDB Document), .sxw
(formato de OpenOffice Writer), .txt. Esta opción es bastante útil cuando dispones de
textos escritos en otros formatos y no quieres reescribirlos en Scribus. Debes tener cui-
dado ya que con esta opción se borra el contenido actual del marco de texto y se susti-
tuye por el contenido del archivo importado.

● Añadir texto. Opción igual que la anterior pero añade el contenido del archivo importa-
do a lo ya escrito, y no borra el contenido actual del marco, como ocurre en el caso an-
terior.

8
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

● Editar texto. Abre el contenido del marco en el Story Editor, opción que ya te hemos
comentado anteriormente, y que te permite formatear el texto con diferentes opciones
de formato.

● Sample Texto. Inserta automáticamente un texto en diferentes idiomas a modo de


ejemplo. Es un texto sin sentido aparente cuyo fin es el de ayudarnos a ver el resultado
de un formateo (maquetación) y no el contenido del texto en sí.

Figura 2.13. Sample texto

● Attributes... Abre la ventana de atributos.

● Opciones de PDF. Permite asignar funciones PDF como anotación PDF o marcador PDF
al marco seleccionado.

● Is Locked. Bloquea la geometría, tamaño y posición del marco. Una vez que lo activas
no podrás moverlo hacia otro lugar del documento, ni cambiarlo de tamaño. Para desac-
tivarlo, simplemente acude a este menú contextual y haz clic, de nuevo, sobre esta en-
trada.

● Size is Locked. Bloquea únicamente el tamaño del marco, que permanecerá inaltera-
ble. Pero, en cambio, podrás moverlo a cualquier otro lugar del documento. Igual que en
el caso anterior, al hacer de nuevo clic sobre esta entrada se produce el desbloqueo del
tamaño del marco.

● Enviar al Álbum de Recortes. A través de esta opción se envía el marco seleccionado


al Álbum de Recortes. Este Álbum es una poderosa herramienta de Scribus que veremos
más adelante.

9
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

● Enviar a Capa. Se envía el marco a la capa seleccionada de la lista que aparece tras
esta opción (submenú). Esta entrada del menú contextual sólo se muestra si en el docu-
mento existen dos o más capas.

● Nivel. Esta opción permite variar de nivel el objeto seleccionado. Desde de una misma
capa, los objetos están superpuestos unos encima de otros como en una pila según su
orden de creación. Con esta opción puedes variar esa posición dentro de la “pila”. Dis-
pondrás de cuatro opciones:
● Poner encima: Raise to Top
● Subir
● Bajar
● Poner debajo: Lower to Bottom

Figura 2.14. Nivel

● Convertir a. Con esta opción es posible transformar un marco de texto en otros objetos
y tratarlos como tales. Así por ejemplo, un marco de texto se puede convertir en un
Marco de imagen, en un contorno o en un polígono.

● Cortar – Copiar – Pegar. Típicas operaciones sobre objetos, en este caso, sobre el
marco de texto.

● Contenidos. Permite eliminar – borrar el contenido del marco de texto.

● Propiedades. Informa de varios parámetros sobre el marco de texto.

Los estilos de párrafo


Es una de las mejores formas de formatear un texto y, sobre todo, resulta una manera
muy cómoda de aplicar el mismo formato a diferentes elementos de texto del documento: por
ejemplo, el mismo estilo de título para cada uno de los artículos o fragmentos de texto de un
periódico digital (fuente Arial, tamaño de 18 puntos, negrita, cursiva, con un espaciado poste-
rior de 18 puntos para separarlo del resto del artículo y alineado a la derecha).

¿Te imaginas lo que supondría tener que seleccionar todas estas características para cada uno
de los títulos de los diferentes artículos que aparecen en el periódico?

Manejar estilos no es difícil: su proceso consiste en aplicar una serie de características


(formato) del texto a un párrafo determinado y teclear el nombre que deseas aplicar a dicho
estilo. Cada vez que quieras aplicar un formato como el creado bajo el nombre anterior única-
mente tendrás que seleccionar el texto a formatear y aplicarle el estilo deseado.

10
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Nota. Es posible tener tantos estilos diferentes como se necesiten.

Para visualizar los estilos de texto creados selecciona la opción Estilos de párrafo...
del menú Editar y aparecerá una ventana en la que se listarán todos los estilos creados hasta
el momento. De momento, lógicamente, al no haber ningún estilo creado está ventana está va-
cía y sólo aparecerá la entrada Sin estilo.

Para crear un nuevo estilo haz clic sobre la columna izquierda de la pantalla en la que
aparece la entrada Sin estilo y observa el menú emergente que aparece. Haz clic sobre la en-
trada Edit Styles (editar estilos) para crear o editar los estilos configurados.

Figura 2.15. Editar Estilos

La ventana Editar Estilos aparece a continuación. Selecciona el botón Nuevo para crear un
nuevo estilo.

Figura 2.16. Ventana Editar estilos de párrafo

En la siguiente ventana que aparece en pantalla podrás seleccionar las diferentes pro-
piedades que tendrá el texto al que se le aplicará el nuevo estilo: la fuente, el tamaño, los atri-
butos, la alineación, las distancias y alturas de la fuente, colores, etc..

11
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

En primer lugar, asígnale un nombre que introducirás en la parte superior de la pantalla en el


campo Nombre. A continuación, elige los diferentes valores que desees para el carácter, las
distancias entre caracteres, tabuladores y sangrías, etc.

Figura 2.17 Ventana de edición de estilos de párrafo

En la parte inferior de la ventana verás una muestra de cómo quedará el estilo una vez
definido. Luego, durante la edición de un texto (ya en el Story Editor), cuando quieras aplicar el
estilo creado, haz clic con el botón izquierdo del ratón al comienzo del párrafo a formatear o
simplemente selecciona el párrafo y haz clic sobre el estilo deseado de la lista de estilos mos-
trada en la barra Configuración de estilos del Story Editor.

12
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Fíjate por ejemplo, en el estilo que hemos definido en la siguiente captura de pantalla, con la
intención de crear un título para nuestros marcos de texto:

Figura 2.18. Ventana Editar estilo de párrafo – Nuevo estilo creado

2.- LOS MARCOS DE IMAGEN

Los marcos de imagen son objetos que pueden albergar además de imágenes otro tipo
de objetos como documentos PDF y EPS.

Insertar y formatear una imagen


Para insertar una imagen selecciona la opción Marco de imagen del menú Insert, haz
clic sobre el botón de la barra de herramientas correspondiente o pulsa la tecla I de tu teclado.

A continuación dibuja el marco de imagen sobre la zona del documento deseada utili-
zando el mismo procedimiento con el que dibujar marcos de texto. No te preocupes en exceso
de su tamaño y de su posición, pues al igual que ocurre con los marcos de texto, podrás variar
ambos parámetros mas tarde según tus necesidades. Cuando se inserta un marco de imagen
se inserta “en blanco”, es decir, vacío. La apariencia del marco incluirá unas líneas que lo atra-
viesan de vértice a vértice, en forma de aspa. Para que el marco contenga una imagen tendrás
que insertarla a continuación. Para ello, haz clic con el botón derecho del ratón sobre el marco
de imagen y selecciona la entrada Get Image... del menú contextual emergente.

13
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Figura 2.19. Menú contextual en el Marco de Imagen

Aparecerá entonces el cuadro de diálogo Abrir del sistema en el que tendrás que locali-
zar la imagen que deseas insertar navegando por el árbol de directorios de tu equipo. para se-
leccionar el archivo de imagen deseado. Una vez que hagas doble clic sobre ella o la seleccio-
nes y hagas clic sobre el botón Abrir, la imagen aparecerá incluida en el marco.

Figura 2.20. Seleccionar una imagen para incluir en Marco de Imagen

Observa en la captura de pantalla anterior que Scribus soporta una gran variedad de
formatos de imagen, entre ellos los más populares como gif, jpg, jpeg, png, xpm, tiff, psd y PDF.

La forma en que está imagen aparecerá en el marco de imagen dependerá de los pará-
metros configurados anteriormente en las Preferencias de Scribus, concretamente en el apar-
tado Herramientas – Propiedades del Marco de imagen.

14
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Figura 2.21. Imagen añadida al marco de imagen

Pero no te preocupes si no has configurado estos parámetros al principio porque los po-
drás configurar en este momento. Para ello, en el menú contextual del botón derecho del ratón
sobre la imagen activa la ventana Propiedades o pulsa la tecla F2. En esta ventana podrás
modificar ciertos parámetros como la resolución de la imagen, su proporcionalidad y sobre
todo, una opción muy útil, la posibilidad de ajustar la imagen (aunque su tamaño sea grande)
al tamaño del marco de imagen dibujado, Para ello selecciona la pestaña Imagen de la venta-
na Propiedades.

Figura 2.22. Propiedades del Marco de Imagen

15
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

Menú contextual del marco de imagen


Al seleccionar el marco de imagen y hacer clic con el botón derecho del ratón aparece
un menú contextual con diferentes opciones que te será muy útil para editar la imagen selec-
cionada y para realizar algunas operaciones con ella:

● Información. Proporciona información acerca de la imagen contenida en el Marco de


Imagen: el nombre del archivo y su formato, resolución original y actual, etc.

● Get Image... Ya hemos visto esta opción. Sirve para localizar el archivo de imagen que
estará contenido en el marco.

Figura 2.23. Marco de imagen – Menú contextual del botón derecho del ratón

● Imagen visible. Sirve para mostrar la imagen en el documento u ocultarla. Esta opción
es útil cuando se tienen bastantes imágenes en el documento y sólo interesa ver su dis-
tribución en el documento y no su contenido, acelerando de este modo la renderización
en pantalla. Aunque la imagen no se visualice al desactivar esta opción, sí que lo hace
el marco.

16
Con el ordenador a cuestas
http://blog.educastur.es/sofwarelibre

● Preview Settings. Con esta opción se indica a Scribus con qué resolución se muestra
en pantalla la imagen: Low Resolution (Baja), Normal Resolution (Normal) y Full Resolu-
tion (Completa). Hay que tener en cuenta que a mayor resolución más trabajo para el
ordenador y, por tanto, más lento mostrará los cambios en pantalla. Sin embargo, en or-
denadores potentes esto no supondrá un problema.

● Image Effects. Muestra en pantalla una ventana con diversas opciones para realizar
efectos sobre la imagen seleccionada. Podrás previsualizar los efectos aplicados inme-
diatamente. Ahora bien, se trata de una lista de efectos muy básica y, por tanto, si se
quiere algo más elaborado se tendrá que recurrir a un programa de edición digital de
imágenes como El Gimp, por ejemplo. Deshacer los efectos es tan simple como volver
de nuevo a la pantalla de edición de Image Effects y eliminar los efectos utilizados.

● Edit Image. Abre el programa predeterminado de edición digital de imágenes. Esto se


configura en el apartado Herramientas Externas de la ventana de configuración de Scri-
bus Preferencias que ya has visto en el Capítulo 1. Por defecto, el programa predetermi-
nado es el editor de retoque fotográfico El Gimp.

● Update Image. Actualiza la imagen contenida en el marco con el archivo del disco.
Esta opción es útil cuando modifiques la imagen fuera de Scribus y luego quieras actua-
lizarla en el documento.

● Adjust Frame to Image. Normalmente, sobre todo, si guardas la proporción de la ima-


gen, el marco dibujado al principio no coincide con el tamaño de la imagen. Es muy difí-
cil ajustar el tamaño del marco a la imagen de forma manual así que tendrás que usar
esta opción para realizar esta tarea de forma automática.

● Attributes. Abre la ventana de atributos. Esta opción se verá más adelante.

El resto de opciones son exactamente las mismas que las referidas a marcos de texto y cum-
plen sus mismas funcionalidades.

17