You are on page 1of 7

DXF Import in STAAD.

Pro 2007

By

Structural Engineering Group


Bentley Systems Inc.

December 27, 2007

1
There are many ways to construct a structural geometry in STAAD.Pro. The structural
engineer can create a particular model using the STAAD.Pro interface, use structure
wizard, OpenSTAAD, command input file, or Bentley Structural. In some instances,
he/she may already have the drawings or geometry ready in a dgn, dwg, or dxf format
and may not want to go through the process of redrawing that structure using
STAAD.Pro. The purpose of this document is to help out engineers in making this
conversion process easier. This document also highlights some of the common mistakes
that users make while converting a dxf file format file to a STAAD.Pro analysis model.

AutoCAD DXF (Drawing Interchange Format, or Drawing Exchange Format) is a CAD


data file format, developed by Autodesk as their solution for enabling data
interoperability between AutoCAD and other programs. As AutoCAD has become more
powerful, supporting more complex object types, DXF has become less useful. Certain
object types, including ACIS solids and regions, are not documented. Other object types,
including AutoCAD 2006's dynamic blocks, and all of the objects specific to the vertical-
market versions of AutoCAD, are partially documented, but not at a sufficient level to
allow other developers to support them. Hence, one has to keep in mind that having a dxf
file does not mean that it should be read by STAAD.Pro without any problems.

There is no product in the market that can convert any dxf file model to a STAAD.Pro
analytical model without any clean-up. The dxf file has to be cleaned up using the
following steps.

There are many stages that you can start off with. The following figure illustrates some
starting points.

Stage 1: Existing CAD drawing with sections drawn.


(e.g. a simple HSS section is shown with two lines (i.e.
top and bottom flanges in an elevation view) on a 2D
drawing

Stage 2: Simple stick model where every section is


represented by a simple line element.

Stage 3: Simple dxf containing a stick model with


polylines, cells (MicroStation), blocks (AutoCAD).

Stage 4: A 2D dxf obtained from a 3D structural frame


model created using Autodesk Inventor.

Figure 1: Possible stages of a RAW dxf file

2
The following write-up will help you import dxf files into STAAD.Pro. Always make a
backup copy of your dxf file before proceeding with the following steps.

For Stage 1:

1. Remove all the text, dimension lines, and unwanted views.


2. Need to draw a stick line diagram using simple line elements in the CAD package. If
you are drawing a stick model on top of an existing model make sure you use a different
layer on top of the existing view in the dxf file. For example, you will need to draw a
line representing the centerline of the HSS section.
3. Remove the original elevation not the newly created centerline diagram. Use the layer
on/off feature to delete the elements under the unwanted layer.
4. As a result of steps 1-3, you will be left with a simple stick model of the structure
5. Scale the model to match the import unit system (may or may not be necessary)
6. Save the file as a dxf file and close it. Close the CAD package.
7. Open STAAD.Pro and create a new project.
8. Click on File->Import command menu and select the 3D-DXF option in the Import
dialog box.
9. Click on the Import button.
10. Select the dxf file and click on the Open button.
11. The DXF Import dialog box will appear. The axis system in your CAD package will
be different from the axis system used in the STAAD.Pro model. The Y-Axis usually is
the axis of gravity in STAAD.Pro the Z-Axis is usually the axis of gravity in the CAD
products. Hence you need to specify which axis is the axis of gravity in your
STAAD.Pro model. If the axis system is the same in the STAAD.Pro model and the dxf
file, then select the No Change option. If the Y-Axis is the axis of gravity in the
STAAD.Pro model and Z-Axis is the axis of gravity for the CAD model, select the Y Up
option button.

3
For Stage 2:

1. Remove all the text, dimension lines, and unwanted views. You will be left with a
simple stick model of the structure
2. Scale the model to match the import unit system (may or may not be necessary)
3. Save the dxf file and close it. Close the CAD package.
4. Open STAAD.Pro and create a new project.
5. Click on File->Import command menu and select the 3D-DXF option in the Import
dialog box.
6. Click on the Import button.
7. Select the dxf file and click on the Open button.
8. The DXF Import dialog box will appear. The axis system in your CAD package will
be different from the axis system used in the STAAD.Pro model. The Y-Axis usually is
the axis of gravity in STAAD.Pro the Z-Axis is usually the axis of gravity in the CAD
products. Hence you need to specify which axis is the axis of gravity in your
STAAD.Pro model. If the axis system is the same in the STAAD.Pro model and the dxf
file, then select the No Change option. If the Y-Axis is the axis of gravity in the
STAAD.Pro model and Z-Axis is the axis of gravity for the CAD model, select the Y Up
option button.

4
For Stage 3:

1. Remove all the text, dimension lines, and unwanted views


2. Need to draw a stick line diagram using simple line elements in the CAD package.
Make sure you use a different layer on top of the existing view in the dxf file. Explode
all blocks or cells and draw the centerline diagram for the exploded blocks or cells. All
polylines and arcs have to be converted to simple line elements. Remove any title blocks.
3. Remove the original elevation
4. As a result of steps 1-3, you will be left with a simple stick model of the structure
5. Scale the model to match the import unit system (may or may not be necessary)
6. Save the file as a dxf file and close it. Close the CAD package.
7. Open STAAD.Pro and create a new project.
8. Click on File->Import command menu and select the 3D-DXF option in the Import
dialog box.
9. Click on the Import button.
10. Select the dxf file and click on the Open button.
11. The DXF Import dialog box will appear. The axis system in your CAD package will
be different from the axis system used in the STAAD.Pro model. The Y-Axis usually is
the axis of gravity in STAAD.Pro the Z-Axis is usually the axis of gravity in the CAD
products. Hence you need to specify which axis is the axis of gravity in your
STAAD.Pro model. If the axis system is the same in the STAAD.Pro model and the dxf
file, then select the No Change option. If the Y-Axis is the axis of gravity in the
STAAD.Pro model and Z-Axis is the axis of gravity for the CAD model, select the Y Up
option button.

5
For Stage 4:

1. Remove all the text, dimension lines, and unwanted views


2. Need to draw a stick line diagram using simple line elements in the CAD package. If
you are drawing a stick model on top of an existing model make sure you use a different
layer on top of the existing view in the dxf file.
3. Remove the original elevation
4. As a result of steps 1-3, you will be left with a simple stick model of the structure
5. Scale the model to match the import unit system (may or may not be necessary)
6. Save the file as a dxf file and close it. Close the CAD package.
7. Open STAAD.Pro and create a new project.
8. Click on File->Import command menu and select the 3D-DXF option in the Import
dialog box.
9. Click on the Import button.
10. Select the dxf file and click on the Open button.
11. The DXF Import dialog box will appear. The axis system in your CAD package will
be different from the axis system used in the STAAD.Pro model. The Y-Axis usually is
the axis of gravity in STAAD.Pro the Z-Axis is usually the axis of gravity in the CAD
products. Hence you need to specify which axis is the axis of gravity in your
STAAD.Pro model. If the axis system is the same in the STAAD.Pro model and the dxf
file, then select the No Change option. If the Y-Axis is the axis of gravity in the
STAAD.Pro model and Z-Axis is the axis of gravity for the CAD model, select the Y Up
option button.

6
After you import the dxf file into STAAD.Pro, you will need to do some clean-up on the
std file. For example;

1. Remove unnecessary lines or objects


2. Click on Geometry->Intersect Selected Members->Highlight menu command.
Hint: Try a 1in search radius.
3. Click on the Tools menu command and go through all the checks. (e.g. check for
structural integrity, check for duplicate nodes and beams etc.)

Using the above steps make sure the model is ok from an analysis point of view.

Plate elements have to be drawn as 3D Faces in the dxf file. Before importing a model
into STAAD.Pro pay attention to the node coordinates in your dxf file.

Solid objects cannot be created in STAAD.Pro using the dxf format. One could create the
outline of a solid object using simple line elements. Once the lines are imported into
STAAD.Pro, he/she can draw the solid object using the line elements as grid lines.

Engineers in the bridge industry place bridge decks in real world GPS coordinates in the
dxf file. These deck coordinates will be imported as they are in the STAAD.Pro model.
GPS coordinates are very big numbers in the order of 100,000’s. If these node
coordinates are used as they are in the STAAD.Pro analysis, the accuracy of the results
are affected due to round off errors. It is a good idea to move these models to the origin
using the move command in the CAD package that is being used.