Sie sind auf Seite 1von 12

Memisahkan gateway hotspot dengan VLAN

Dimisalkan kita berlangganan dua ISP, ISP1 untuk kepentingan user yang bersifat stationery dan ISP2
untuk kepentingan user yang menggunakan hotspot

TOPOLOGI

SKEMA PENGALAMATAN

ISP IP Public Gateway DNS


1 222.124.194.23/27 222.124.194.1/27 222.124.194.11/27
2 202.134.248.6/28 202.134.248.1/28 202.134.248.9/28

LOCAL AREA NETWORK

Vlan Name Network First Host Last Host Broadcast


1 Management 192.168.1.0/28 192.168.1.1/28 192.168.1.14/28 192.168.1.15/28
2 Lecture 192.168.1.16/28 192.168.1.17/28 192.168.1.30/28 192.168.1.31/28
3 Staff 192.168.1.32/28 192.168.1.33/28 192.168.1.46/28 192.168.1.47/28
4 Guest 192.168.1.48/28 192.168.1.49/28 192.168.1.62/28 192.168.1.63/28
5 Student 192.168.1.64/28 192.168.1.65/28 192.168.1.78/28 192.168.1.79/28
6 Hotspot 192.168.1.80/28 192.168.1.81/28 192.168.1.94/28 192.168.1.95/28

PERALATAN

- Switch Cisco
- Router Cisco
- Access Point

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

KONFIGURASI

SWITCH 1

Switch>enable
Switch#conf t
Switch(config)#hostname vtp-server

vtp-server(config)#interface vlan 1
vtp-server(config-if)#ip address 192.168.1.3 255.255.255.240
vtp-server(config-if)#no shutdown
vtp-server(config-if)#exit

vtp-server(config)#ip default-gateway 192.168.1.1

vtp-server(config)#vtp mode server


vtp-server(config)#vtp domain unsri
vtp-server(config)#vtp password unsri

vtp-server(config)#vlan 2
vtp-server(config-vlan)#name lecture
vtp-server(config-vlan)#exit

vtp-server(config)#vlan 3
vtp-server(config-vlan)#name staff
vtp-server(config-vlan)#exit

vtp-server(config)#vlan 4
vtp-server(config-vlan)#name guest
vtp-server(config-vlan)#exit

vtp-server(config)#vlan 5
vtp-server(config-vlan)#name student
vtp-server(config-vlan)#exit

vtp-server(config)#vlan 6
vtp-server(config-vlan)#name hotspot
vtp-server(config-vlan)#exit

vtp-server(config)#interface fastEthernet 0/1


vtp-server(config-if)#switchport mode trunk
vtp-server(config-if)#switchport trunk native vlan 1
vtp-server(config-if)#exit

vtp-server(config)#interface fastEthernet 0/2


vtp-server(config-if)#switchport mode trunk
vtp-server(config-if)#switchport trunk native vlan 1
vtp-server(config-if)#exit

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

vtp-server(config)#interface fastEthernet 0/4


vtp-server(config-if)#switchport mode trunk
vtp-server(config-if)#switchport trunk native vlan 1
vtp-server(config-if)#exit

vtp-server(config)#interface fastEthernet 0/3


vtp-server(config-if)#switchport mode trunk
vtp-server(config-if)#switchport trunk native vlan 1
vtp-server(config-if)#exit

vtp-server(config)#line vty 0 4
vtp-server(config-line)#password candraganteng
vtp-server(config-line)#login
vtp-server(config-line)#exit
vtp-server(config)#enable secret candragantengtenan
vtp-server(config)#exit
vtp-server#copy running-config startup-config
vtp-server#

SWITCH 2
Switch>enable
Switch#conf t
Switch(config)#hostname vtp-client1
vtp-client1(config)#vtp mode client
vtp-client1(config)#interface vlan 1
vtp-client1(config-if)#ip address 192.168.1.4 255.255.255.240
vtp-client1(config-if)#no shutdown
vtp-client1(config-if)#exit
vtp-client1(config)#ip default-gateway 192.168.1.1

vtp-client1(config)#line vty 0 4
vtp-client1(config-line)#password candraganteng
vtp-client1(config-line)#login
vtp-client1(config-line)#exit
vtp-client1(config)#enable secret candragantengtenan
vtp-client1(config)#exit

vtp-client1(config)#vtp domain unsri


vtp-client1(config)#vtp password unsri

vtp-client1(config)#interface fastEthernet 0/1


vtp-client1(config-if)#switchport mode trunk
vtp-client1(config-if)#switchport trunk native vlan 1
vtp-client1(config-if)#exit
vtp-client1(config)#exit

vtp-client1#show vtp status


VTP Version :2
Configuration Revision : 11
Maximum VLANs supported locally : 255
CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA
http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

Number of existing VLANs : 10


VTP Operating Mode : Client
VTP Domain Name : unsri
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0×71 0×4B 0×63 0×34 0×6A 0xC2 0xEB 0×11
Configuration last modified by 192.168.1.2 at 3-1-93 00:21:42
vtp-client1#sh
vtp-client1#show vl
vtp-client1#show vlan

VLAN Name Status Ports


—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
2 lecture active
3 staff active
4 guest active
5 student active
6 hotspot active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs


——————————————————————————

Primary Secondary Type Ports


——- ——— —————– ——————————————

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

vtp-client1#conf t
vtp-client1(config)#interface fastEthernet 0/2
vtp-client1(config-if)#switchport mode access
vtp-client1(config-if)#switchport access vlan 6
vtp-client1(config-if)#exit
vtp-client1(config)#interface fastEthernet 0/3
vtp-client1(config-if)#switchport mode access
vtp-client1(config-if)#switchport access vlan 2
vtp-client1(config-if)#exit
vtp-client1(config)#interface fastEthernet 0/4
vtp-client1(config-if)#switchport mode access
vtp-client1(config-if)#switchport access vlan 3
vtp-client1(config-if)#exit
vtp-client1(config)#interface fastEthernet 0/5
vtp-client1(config-if)#switchport mode access
vtp-client1(config-if)#switchport access vlan 4
vtp-client1(config-if)#exit
vtp-client1(config)#interface fastEthernet 0/6
vtp-client1(config-if)#switchport mode access
vtp-client1(config-if)#switchport access vlan 5
vtp-client1(config-if)#exit
vtp-client1(config)#exit
vtp-client1#show vlan

VLAN Name Status Ports


—- ——————————– ——— ——————————-
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
2 lecture active Fa0/3
3 staff active Fa0/4
4 guest active Fa0/5
5 student active Fa0/6
6 hotspot active Fa0/2
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA
http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

1003 tr 101003 1500 - - - - - 0 0


1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs


——————————————————————————

Primary Secondary Type Ports


——- ——— —————– ——————————————

vtp-client1#copy run startup-config


Destination filename [startup-config]?
Building configuration…
[OK]
vtp-client1#
vtp-client1#

SWITCH 3
Switch>enable
Switch#conf t
Switch(config)#hostname vtp-client2
vtp-client2(config)#vtp mode client
vtp-client2(config)#vtp domain unsri
vtp-client2(config)#vtp password unsri
vtp-client2(config)#interface fastEthernet 0/1
vtp-client2(config-if)#switchport mode trunk
vtp-client2(config-if)#switchport trunk native vlan 1
vtp-client2(config)#interface vlan 1
vtp-client2(config-if)#ip address 192.168.1.5 255.255.255.240
vtp-client2(config-if)#no shutdown
vtp-client2(config-if)#exit
vtp-client2(config)#ip default-gateway 192.168.1.1
vtp-client2(config)#line vty 0 4
vtp-client2(config-line)#password candraganteng
vtp-client2(config-line)#login
vtp-client2(config-line)#exit
vtp-client2(config)#enable secret candragantengtenan
vtp-client2(config)#exit

vtp-client2#show vtp status


VTP Version :2
Configuration Revision : 11
Maximum VLANs supported locally : 255
Number of existing VLANs : 10
VTP Operating Mode : Client
VTP Domain Name : unsri
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

MD5 digest : 0×71 0×4B 0×63 0×34 0×6A 0xC2 0xEB 0×11
Configuration last modified by 192.168.1.2 at 3-1-93 00:21:42

vtp-client2#show vlan

VLAN Name Status Ports


—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
2 lecture active
3 staff active
4 guest active
5 student active
6 hotspot active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs


——————————————————————————

Primary Secondary Type Ports


——- ——— —————– ——————————————

vtp-client2#conf t
vtp-client2(config)#interface fastEthernet 0/2
vtp-client2(config-if)#switchport mode access
vtp-client2(config-if)#switchport access vlan 6
vtp-client2(config-if)#exit
vtp-client2(config)#interface fastEthernet 0/3
vtp-client2(config-if)#switchport mode access
vtp-client2(config-if)#switchport access vlan 2
CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA
http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

vtp-client2(config-if)#exit
vtp-client2(config)#interface fastEthernet 0/4
vtp-client2(config-if)#switchport mode access
vtp-client2(config-if)#switchport access vlan 3
vtp-client2(config-if)#exit
vtp-client2(config)#interface fastEthernet 0/5
vtp-client2(config-if)#switchport mode access
vtp-client2(config-if)#switchport access vlan 4
vtp-client2(config-if)#exit
vtp-client2(config)#interface fastEthernet 0/6
vtp-client2(config-if)#switchport mode access
vtp-client2(config-if)#switchport access vlan 5
vtp-client2(config-if)#exit
vtp-client2(config)#exit

vtp-client2#show vlan

VLAN Name Status Ports


—- ——————————– ——— ——————————-
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
2 lecture active Fa0/3
3 staff active Fa0/4
4 guest active Fa0/5
5 student active Fa0/6
6 hotspot active Fa0/2
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs


——————————————————————————

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

Primary Secondary Type Ports


——- ——— —————– ——————————————
vtp-client2#
vtp-client2#

ROUTER 1
Router>enable
Router#conf t
Router(config)#hostname R1

R1(config)#line vty 0 4
R1(config-line)#password candraganteng
R1(config-line)#login
R1(config-line)#exit

R1(config)#enable secret candragantengtenan


R1(config)#service password-encryption

R1(config)#interface fastEthernet 0/0


R1(config-if)#ip address 222.124.194.23 255.255.255.224
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#ip route 0.0.0.0 0.0.0.0 222.124.194.1

R1(config)#interface fastEthernet 0/1


R1(config-if)#ip address 192.168.1.1 255.255.255.240
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface fastEthernet 0/1.2


R1(config-subif)#encapsulation dot1Q 2
R1(config-subif)#ip address 192.168.1.17 255.255.255.240
R1(config-subif)#ip nat inside
R1(config-subif)#exit

R1(config)#interface fastEthernet 0/1.3


R1(config-subif)#encapsulation dot1Q 3
R1(config-subif)#ip address 192.168.1.33 255.255.255.240
R1(config-subif)#ip nat inside
R1(config-subif)#exit

R1(config)#interface fastEthernet 0/1.4


R1(config-subif)#encapsulation dot1Q 4
R1(config-subif)#ip address 192.168.1.49 255.255.255.240
R1(config-subif)#ip nat inside
R1(config-subif)#exit

R1(config)#interface fastEthernet 0/1.5


R1(config-subif)#encapsulation dot1Q 5
CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA
http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

R1(config-subif)#ip address 192.168.1.65 255.255.255.240


R1(config-subif)#ip nat inside
R1(config-subif)#exit

R1(config)#ip nat inside source list 1 interface fastEthernet 0/1 overload


R1(config)#access-list 1 permit any

R1(config-subif)#exit
R1(config)#ip dhcp pool vlan2
R1(dhcp-config)#default-router 192.168.1.17
R1(dhcp-config)#network 192.168.1.16 255.255.255.240
R1(dhcp-config)#dns-server 222.124.194.11
R1(dhcp-config)#exit

R1(config)#ip dhcp pool vlan3


R1(dhcp-config)#default-router 192.168.1.33
R1(dhcp-config)#dns-server 222.124.194.11
R1(dhcp-config)#exit

R1(config)#ip dhcp pool vlan4


R1(dhcp-config)#default-router 192.168.1.49
R1(dhcp-config)#network 192.168.1.48 255.255.255.240
R1(dhcp-config)#dns-server 222.124.194.11
R1(dhcp-config)#exit

R1(config)#ip dhcp pool vlan5


R1(dhcp-config)#default-router 192.168.1.65
R1(dhcp-config)#network 192.168.1.64 255.255.255.240
R1(dhcp-config)#dns-server 222.124.194.11
R1(dhcp-config)#exit

R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.15 area 0
R1(config-router)#network 192.168.1.16 0.0.0.15 area 0
R1(config-router)#network 192.168.1.32 0.0.0.15 area 0
R1(config-router)#network 192.168.1.48 0.0.0.15 area 0
R1(config-router)#network 192.168.1.64 0.0.0.15 area 0

R1(config)#exit

R1#copy running-config startup-config


R1#

ROUTER 2
Router>enable
Router#conf t
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 202.134.248.6 255.255.255.240

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

R2(config-if)#no shutdown
R2(config-if)#ip nat outside

R2(config)#interface fastEthernet 0/1


R2(config-if)#ip address 192.168.1.2 255.255.255.240
R2(config-if)#no shutdown

R2(config)#interface fastEthernet 0/1.6


R2(config-subif)#encapsulation dot1Q 6
R2(config-subif)#ip address 192.168.1.81 255.255.255.240
R2(config-subif)#ip nat inside
R2(config-subif)#exit

R2(config)#ip nat inside source list 1 interface fastEthernet 0/0 overload


R2(config)#access-list 1 permit any
R2(config)#ip route 0.0.0.0 0.0.0.0 202.134.248.1

R2(config)#ip dhcp pool vlan6


R2(dhcp-config)#default-router 192.168.1.81
R2(dhcp-config)#network 192.168.1.80 255.255.255.240
R2(dhcp-config)#dns-server 202.134.248.9
R2(dhcp-config)#exit

R2(config)#line vty 0 4
R2(config-line)#password candraganteng
R2(config-line)#login
R2(config-line)#exit
R2(config)#enable secret candragantengtenan
R2(config)#service password-encryption
R2(config)#

R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.15 area 0
R2(config-router)#network 192.168.1.80 0.0.0.15 area 0
R2(config-router)#^Z
R2#

ROUTER 1
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 222.124.194.1 to network 0.0.0.0

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id
Memisahkan gateway hotspot dengan VLAN

192.168.1.0/28 is subnetted, 6 subnets


C 192.168.1.0 is directly connected, FastEthernet0/1
C 192.168.1.16 is directly connected, FastEthernet0/1.2
C 192.168.1.32 is directly connected, FastEthernet0/1.3
C 192.168.1.48 is directly connected, FastEthernet0/1.4
C 192.168.1.64 is directly connected, FastEthernet0/1.5
O 192.168.1.80 [110/2] via 192.168.1.2, 00:00:27, FastEthernet0/1
222.124.194.0/27 is subnetted, 1 subnets
C 222.124.194.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 222.124.194.1
R1#

ROUTER 2
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 202.134.248.1 to network 0.0.0.0

192.168.1.0/28 is subnetted, 6 subnets


C 192.168.1.0 is directly connected, FastEthernet0/1
O 192.168.1.16 [110/2] via 192.168.1.1, 00:00:44, FastEthernet0/1
O 192.168.1.32 [110/2] via 192.168.1.1, 00:00:34, FastEthernet0/1
O 192.168.1.48 [110/2] via 192.168.1.1, 00:00:34, FastEthernet0/1
O 192.168.1.64 [110/2] via 192.168.1.1, 00:00:24, FastEthernet0/1
C 192.168.1.80 is directly connected, FastEthernet0/1.6
202.134.248.0/28 is subnetted, 1 subnets
C 202.134.248.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 202.134.248.1
R2#

CANDRA SETIAWAN – UNIVERSITAS SRIWIJAYA


http://unsri.ac.id
candra@unsri.ac.id

Das könnte Ihnen auch gefallen