Sie sind auf Seite 1von 12

Hartmann + Hartmann GmbH, Augsburg

Product description:

KUKA.Sim Viewer, for optimal presentation of your simula- tion. Free download available at www.kuka.com. KUKA.Sim Layout, the unique program for creating 3D lay- outs of systems with KUKA robots, and for simulation and workflow investigation. KUKA.Sim Pro, for the offline programming of KUKA robots. The product is connected in real time to the virtual KUKA controller, thus allowing cycle time analyses and the generation of robot programs.

KUKA.Sim Viewer, Layout and Pro run on Win2000, WinXP. Minimum configuration for Viewer/Layout:

Pentium III, 750 MHz, 128 MB, 1024 x 768 px, 16-bit color resolution. Minimum configuration for Pro:

Pentium III, 1 GHz, 256 MB, 1024 x 768 px, 16-bit color resolution. An OpenGL-capable graphics card is recommended for all KUKA.Sim products.

KUKA.Sim – powered by Visual Components

Produktbeschreibung:

KUKA.Sim Viewer, für die optimale Präsentation Ihrer Simu- lation. Kostenlos als Download über www.kuka.com. KUKA.Sim Layout, das einzigartige Programm zur Erstellung von 3-D-Layouts von Anlagen mit KUKA Robotern, für Simu- lation und Workflow-Untersuchung. KUKA.Sim Pro, für die Offline-Programmierung von KUKA Robotern. Das Produkt ermöglicht durch die Echtzeit-Kopp- lung an die virtuelle KUKA Steuerung Taktzeitanalysen und die Generierung von Roboterprogrammen.

KUKA.Sim Viewer, Layout und Pro sind auf Win2000 und WinXP lauffähig. Mindestanforderungen für Viewer/Layout:

Pentium III, 750 MHz, 128 MB, 1024 x 768 Pixel,

16-Bit-Farbauflösung.

Mindestanforderungen für Pro:

Pentium III, 1 GHz, 256 MB, 1024 x 768 Pixel,

16-Bit-Farbauflösung.

Wir empfehlen für alle KUKA.Sim Produkte eine OpenGL-fähige Grafikkarte.

KUKA.Sim – powered by Visual Components

www.kuka.com

KUKA.Sim – powered by Visual Components www.kuka.com SIMULATION PROGRAMMING DESIGN MODULATION QUICK GUIDE –
SIMULATION PROGRAMMING DESIGN MODULATION
SIMULATION
PROGRAMMING
DESIGN
MODULATION

QUICK GUIDE – KUKA.SIM

WORKING IDEAS

by Visual Components www.kuka.com SIMULATION PROGRAMMING DESIGN MODULATION QUICK GUIDE – KUKA.SIM WORKING IDEAS

KUKA.SIM

Important information about KUKA.Sim Wichtige Informationen zu KUKA.Sim Wichtige Informationen zu KUKA.Sim

Support Answers to questions about setup, getting started and other topics can be found in the installation manual on the product CD-ROM, in the on-line help and at www.kuka.com. Comments regarding the products of the KUKA.Sim family and the KUKA.Sim component library are welcome and should be directed to: simulation@kuka-roboter.de.

New components can be created using KUKA.Sim Pro or requested from us. Please contact us for further information.

Supported systems

– Windows 2000

– Windows XP

How to buy KUKA.Sim Layout and KUKA.Sim Pro are sold under license by the KUKA Robot Group. The fully licensed version is activated after installa- tion and registration. The necessary product key can be requested by e-mail, quoting your order number. You can download a test version of KUKA.Sim Layout and request a demo product key from our website at www.kukasim.com. For further information on ordering, e-mail simulation@kuka-roboter. de or contact your local KUKA sales representative.

Support Antworten auf Ihre Fragen bezüglich Setup, Starten des Produkts und zu allgemeinen Themen finden Sie im Installationshandbuch auf der Produkt-CD-Rom, in der Onlinehilfe und auf www.kuka.com. An- regungen zu den Produkten der KUKA.Sim Familie und der KUKA.Sim Komponentenbibliothek sind uns stets willkommen. Bitte senden Sie diese an: simulation@kuka-roboter.de.

Neue Komponenten können mit KUKA.Sim Pro oder von uns auf An- frage erstellt werden. Für weitere Informationen setzen Sie sich bitte mit uns in Verbindung.

Unterstützte Systeme

– Windows 2000

– Windows XP

Wie Sie unsere Produkte erwerben können KUKA.Sim Layout und KUKA.Sim Pro werden von der KUKA Robot Group mit der dazugehörigen Lizenz verkauft. Die Aktivierung einer Volllizenz erfolgt nach der Installation und Registrierung. Den Product- Key dazu erhalten Sie unter Angabe Ihrer Auftragsnummer per E-Mail. Auf unserer Homepage www.kukasim.com können Sie eine Test- version von KUKA.Sim Layout herunterladen und einen Demo-Product- Key anfordern. Informationen zur Bestellung erhalten Sie auch per E-Mail unter:

simulation@kuka-roboter.de oder kontaktieren Sie Ihren KUKA Ver- triebsmitarbeiter vor Ort.

2
2

Designed for your needs Auf Ihre Bedürfnisse zugeschnitten

Designed for your needs Auf Ihre Bedürfnisse zugeschnitten KUKA.Sim offers you major benefits in many different
Designed for your needs Auf Ihre Bedürfnisse zugeschnitten KUKA.Sim offers you major benefits in many different

KUKA.Sim offers you major benefits in many different areas:

KUKA.Sim bietet Ihnen weitreichende Vorteile in vielen Bereichen:

– Planning: Greater reliability through verification of alternative

– Planung: zuverlässig, durch Prüfung mehrerer Layoutalternativen

layouts

– Konstruktion: von Anfang an optimale Hilfe bei Layouterstellung

– Design: Optimal help with layout creation and design from the

und Konstruktion

very outset

– Programmierung: Taktzeitanalyse, -minimierung und Programm-

– Programming: Cycle time analysis and optimization, program

strukturierung

structuring

– Programmoptimierung: Offline-Änderungen bei laufender Produk-

tion möglich

– Program optimization: Offline modifications possible without

interrupting production

– Training: Safe and cost-effective employee training

– Schulung: sichere und wirtschaftliche Schulung Ihrer Mitarbeiter

– Sales: Professional presentation of cell layouts

– Vertrieb: überzeugende Präsentation der Zellenlayouts

 

3

KUKA.SIM

A quick introduction Eine schnelle Einführung

QUICK GUIDE

Installation

Start-up

Help

What’s included in the installers? The setup programs of the full version install KUKA.Sim Viewer, KUKA.Sim Layout, KUKA.Sim Pro and the components library with more than 500 components. The setup program of KUKA.OfficeLite installs the virtual KUKA controller (VRC).

Installing KUKA.Sim Viewer or KUKA.Sim Layout To install, locate on the CD-ROM or in your download directory, the files:

SetupKUKASimLayout.exe SetupKUKASimViewer.exe SetupKUKASimComponents.exe Double-click on these files or open them from the desktop using Start > Run… and follow the instructions given by the setup wizard for correct installation of the products.

Installing KUKA.Sim Pro To install, locate on the CD-ROM or in your download directory, the files:

SetupKUKASimPro.exe SetupKUKASimComponents.exe Double-click on these files or open them from the desktop using Start > Run… and follow the instructions given by the setup wizard for correct installation of the products.

Installation von KUKA.OfficeLite:

Run the following file from the KUKA.OfficeLite CD-ROM:

setup.exe. Please follow the licensing and start-up information on the accompany- ing software CD.

Was beinhaltet das Installationsprogramm? Die Setup-Programme der Vollversion installieren KUKA.Sim Viewer, KUKA.Sim Layout, KUKA.Sim Pro und die Komponentenbibliothek mit mehr als 500 Komponenten. Das Setup-Programm von KUKA.Office- Lite installiert die virtuelle KUKA Steuerung (VRC).

Installation KUKA.Sim Viewer/KUKA.Sim Layout Zur Installation starten Sie auf der CD-Rom oder in Ihrem Download- Verzeichnis die Dateien:

SetupKUKASimLayout.exe SetupKUKASimViewer.exe SetupKUKASimComponents.exe Doppelklicken Sie auf diese Dateien oder öffnen Sie diese auf Ihrem Desktop. Verwenden Sie hierfür Start > Run (Ausführen)… und folgen Sie den Anweisungen des Setup-Assistenten, um die Produkte kor- rekt zu installieren.

Installation KUKA.Sim Pro Zur Installation starten Sie auf der CD-Rom oder in Ihrem Down- load-Verzeichnis die Dateien:

SetupKUKASimPro.exe SetupKUKASimComponents.exe Doppelklicken Sie auf diese Dateien oder öffnen Sie diese auf Ihrem Desktop. Verwenden Sie hierfür Start > Run (Ausführen)… und folgen Sie den Anweisungen des Setup-Assistenten, um die Produkte kor- rekt zu installieren.

Installation KUKA.OfficeLite Starten Sie auf der CD-Rom KUKA.OfficeLite die Datei:

setup.exe. Bitte beachten Sie hierzu die Lizenzierungs- und Starthinweise auf bei- liegender Software-CD.

Starting KUKA.Sim Viewer and KUKA.Sim Layout The installation wizard creates a desktop icon for both KUKA.Sim Viewer and KUKA.Sim Layout. Start the desired application by double-clicking on the corresponding icon. When starting KUKA.Sim for the first time, please follow the registration instructions.

the first time, please follow the registration instructions. Start KUKA.Sim Viewer und KUKA.Sim Layout Der
the first time, please follow the registration instructions. Start KUKA.Sim Viewer und KUKA.Sim Layout Der

Start KUKA.Sim Viewer und KUKA.Sim Layout Der Installationsassistent erstellt sowohl für KUKA.Sim Viewer als auch für KUKA.Sim Layout ein Desktop-Icon. Starten Sie die gewünschte Anwendung, indem Sie auf das entsprechende Icon doppelklicken. Bitte folgen Sie beim ersten Start den Registrierungshinweisen.

Starting KUKA.Sim Pro The installation wizard creates a desktop icon for KUKA. Sim Pro. Start KUKA.Sim Pro by double-clicking on this icon. When starting KUKA.Sim for the first time, please follow the registration instructions.

the first time, please follow the registration instructions. Start KUKA.Sim Pro Der Installationsassistent erstellt für

Start KUKA.Sim Pro Der Installationsassistent erstellt für KUKA.Sim Pro ein Desktop-Icon. Starten Sie KUKA.Sim Pro, indem Sie auf dieses Icon doppelklicken. Bitte folgen Sie beim ersten Start den Registrierungshinweisen.

Activating KUKA.Sim Layout and KUKA.Sim Pro To be able to use or test the products, please activate them by enter- ing the product key sent to you by e-mail. You can request a free demo product key at www.kukasim.com.

Aktivierung von KUKA.Sim Layout und KUKA.Sim Pro Bitte aktivieren Sie die Produkte, um diese nutzen oder testen zu können. Dazu geben Sie bitte den per E-Mail erhaltenen Product-Key ein. Einen Demo-Key können Sie unter www.kukasim.com kostenlos anfordern.

Detailed help KUKA.Sim’s on-line help system contains all the information you need. To access, press F1 or select Help from the menu bar. Then choose a help topic from the pull-down menu. Further information, FAQs and a KUKA.Sim Knowledge Base can be found at www.kukasim.com or via the Web Resources link on the eCat tabbed panel.

Detaillierte Hilfe Das Online-Hilfe-System von KUKA.Sim enthält alle Informationen, die Sie benötigen. Drücken Sie bitte „F1“ oder wählen Sie „Hilfe“ aus der Menüleiste, um auf die Hilfe zuzugreifen. Wählen Sie nun aus dem Pull- down-Menü das gewünschte Hilfethema. Weitere Informationen, Antworten auf häufig gestellte Fragen (FAQs) so- wie eine KUKA.Sim Knowledge Base finden Sie unter www.kukasim.com oder über den Link „Web Resource“ im Auswahlregister eCat.

4 5
4
5
KUKA.SIM User interface Benutzeroberfläche  Menu bar  Menüleiste  Toolbar  Werkzeugleiste 
KUKA.SIM
User interface
Benutzeroberfläche
 Menu bar
 Menüleiste
 Toolbar
 Werkzeugleiste
 Selection bar
 Funktionsleiste
 Simulation bar
 Simulationsbedienfeld
 Tabbed panels
 Auswahlregister
 Status bar
 Statusleiste
 Message panel
 Meldungsfenster
 3D world
 3-D-Ansicht
Note: The illustration shows the graphical user interface
of KUKA.Sim Pro. The tabbed panels “Create” and “KRC”
are not available in KUKA.Sim Layout. The user interface is
available in a number of languages.
Hinweis: Die Abbildung zeigt die Bedienoberfläche von
KUKA.Sim Pro. Die Auswahlregister „Erstellen“ und „KRC“
sind in KUKA.Sim Layout nicht vorhanden. Die Benutzer-
oberfläche ist in der jeweils eingestellten Sprache ver-
fügbar.
6
7

TOOLBAR

WERKZEUGLEISTE

TOOLBAR WERKZEUGLEISTE Tip: Center your 3D model by holding down the key and clicking with the

Tip: Center your 3D model by holding down the key and clicking with the left-hand mouse button on a component. Tipp: Zentrieren Sie Ihr 3-D-Modell, indem Sie die Taste gedrückt halten und mit der linken Maustaste auf eine Komponente klicken.

Buttons in the toolbar Open a layout* and start the simulation by pressing the “Run” button. You can use the following shortcuts to move around:

Schaltflächen in der Werkzeugleiste Öffnen Sie ein Layout* und starten Sie die Simulation durch Drücken der Schaltfläche „Start“. Verwenden Sie folgende Tastaturkürzel, um sich im Programm zu bewegen:

Orbits the viewpoint around the view center. Dreht den Blickpunkt um das Bildzentrum herum.

Orbits the viewpoint around the view center.

Dreht den Blickpunkt um das Bildzentrum herum.

Shortcut**:

Shortcut**: hold down left-hand mouse button and Shortcut**: linke Maustaste gedrückt halten und ziehen

hold down left-hand mouse button and

Shortcut**:

Shortcut**: hold down left-hand mouse button and Shortcut**: linke Maustaste gedrückt halten und ziehen

linke Maustaste gedrückt halten und ziehen

drag

Pans the view parallel to the screen. Verschiebt den Blickpunkt parallel zum Bildschirm.

Pans the view parallel to the screen.

Verschiebt den Blickpunkt parallel zum Bildschirm.

Shortcut**:

Shortcut**: hold down left-hand mouse button and Shortcut**: linke Maustaste gedrückt halten und ziehen

hold down left-hand mouse button and

Shortcut**:

Shortcut**: hold down left-hand mouse button and Shortcut**: linke Maustaste gedrückt halten und ziehen

linke Maustaste gedrückt halten und ziehen

drag

Zooms closer or further away from the view center. Bewegt den Blickpunkt näher oder weiter

Zooms closer or further away from the view center.

Bewegt den Blickpunkt näher oder weiter weg vom Bildzentrum.

Shortcut**:

Shortcut**: hold down left-hand mouse button and Shortcut**: linke Maustaste gedrückt halten und ziehen

hold down left-hand mouse button and

Shortcut**:

Shortcut**: hold down left-hand mouse button and Shortcut**: linke Maustaste gedrückt halten und ziehen

linke Maustaste gedrückt halten und ziehen

drag

Fills the 3D World with all current layout items. Shortcut**: Zentriert die 3-D-Ansicht mit allen

Fills the 3D World with all current layout items. Shortcut**:

Fills the 3D World with all current layout items. Shortcut**:
Fills the 3D World with all current layout items. Shortcut**:
Fills the 3D World with all current layout items. Shortcut**:

Zentriert die 3-D-Ansicht mit allen aktuellen Layoutobjekten. Shortcut**:

Zentriert die 3-D-Ansicht mit allen aktuellen Layoutobjekten. Shortcut**:
Zentriert die 3-D-Ansicht mit allen aktuellen Layoutobjekten. Shortcut**:
Zentriert die 3-D-Ansicht mit allen aktuellen Layoutobjekten. Shortcut**:

* Layout files can easily be sent by e-mail. If you receive an e-mail with a layout attached, double-clicking on the attachment will launch KUKA.Sim Viewer (or, if installed, KUKA.Sim Layout or Pro) to view the simulation.

** Shortcuts can be defined by the user. A description can be found in the Knowledge Base at www.kukasim.com.

* Eine Layoutdatei kann via E-Mail verschickt werden. Wenn Sie eine E-Mail mit einem angehängten Layout erhalten, dann doppelklicken Sie auf den Anhang und der KUKA.Sim Viewer wird gestartet (oder, falls installiert, KUKA.Sim Layout oder Pro), um die Simulation anzu- zeigen.

** Shortcuts können benutzerspezifisch definiert werden. Eine Beschrei- bung finden Sie in der Knowledge Base auf www.kukasim.com.

A quick introduction Eine schnelle Einführung

QUICK GUIDE User Interface Functions Buttons

Extended toolbar functions in KUKA.Sim Layout and KUKA.Sim Pro

Erweiterte Funktionen der Werkzeugleiste bei KUKA.Sim Layout und KUKA.Sim Pro

Selects an object for the Attach, Plug ’n’ Play (PnP), Translate and Rotate operations. The

Selects an object for the Attach, Plug ’n’ Play (PnP), Translate and Rotate operations. The toolbar allows you to make selec- tions between different types of objects: components, se- quences, bases, tools, positions.

Wählt ein Objekt aus für die Vorgänge Verbinden, Plug ’n’ Play (PnP), Verschieben und Rotieren. Die Werkzeugleiste ermöglicht das Aus- wählen aus verschiedenen Objekttypen: Komponenten, Sequenzen, Bases, Tools, Positionen.

Komponenten, Sequenzen, Bases, Tools, Positionen. Translates a component or a position. Select a colored arrow
Translates a component or a position. Select a colored arrow to move the component in

Translates a component or a position. Select a colored arrow to move the component in the X, Y or Z direction. The direction of translation depends on the active coordinate system.

Verschiebt eine Komponente oder eine Position. Wählen Sie einen far- bigen Pfeil, um die Komponente in die x-, y- oder z-Richtung zu be- wegen. Die Richtung der Verschiebung hängt vom aktiven Koor- dinatensystem ab.

Rotates a component or a position about one of the colored arrows: red (X), green

Rotates a component or a position about one of the colored arrows: red (X), green (Y), or blue (Z). The direction of rotation depends on the selected coordinate system

Rotiert eine Komponente oder eine Position um einen der farbigen Pfeile: rot (x), grün (y), blau (z). Die Richtung der Rotation hängt vom ausgewählten Koordinaten- system ab.

Plug ’n’ Play mode links components logically and physically when they are dragged close enough

Plug ’n’ Play mode links components logically and physically when they are dragged close enough to each other.

Der Plug ’n’ Play-Modus verknüpft die Komponenten logisch und phy- sikalisch miteinander, wenn sie nahe genug aneinander herangezo- gen werden.

8 9
8
9

STATUS BAR

STATUSLEISTE

Buttons in the status bar The following toggle buttons can be found in the status bar:

Schaltflächen in der Statusleiste In der Statusleiste finden Sie folgende Umschaltflächen:

In der Statusleiste finden Sie folgende Umschaltflächen: Switches visibility of positions, tools and bases on /
Switches visibility of positions, tools and bases on / off Tip: right-click on this button

Switches visibility of positions, tools and bases on / off Tip: right-click on this button to fine-tune the selection.

Ein- und Ausschalten von Positions-, Tool- und Base-Ansichten Tipp: Klicken Sie mit der rechten Maustaste auf diese Schaltfläche um die Auswahl zu selektieren.

Switches collision detection on / off for the selected component Ein- und Ausschalten der Kollisionsüberwachung

Switches collision detection on / off for the selected component

Ein- und Ausschalten der Kollisionsüberwachung für die gewählte Komponente

Switches the visibility of the notes on / off Ein- und Ausschalten der Notizenansicht

Switches the visibility of the notes on / off

Ein- und Ausschalten der Notizenansicht

Switches working range limitation on / off Ein- und Ausschalten der Arbeitsraumbegrenzung

Switches working range limitation on / off

Ein- und Ausschalten der Arbeitsraumbegrenzung

Switches traces (motion path) on / off Trace (Bewegungspfad) ein-/ausschalten

Switches traces (motion path) on / off

Trace (Bewegungspfad) ein-/ausschalten

Hides / shows the reference plane Referenzebene ein-/ausblenden

Hides / shows the reference plane

Referenzebene ein-/ausblenden

Locks frames in the layout Frames im Layout fixieren

Locks frames in the layout

Frames im Layout fixieren

QUICK GUIDE

User Interface

Functions

Buttons

Buttons in the status bar

Schaltflächen in der Statusleiste

The grid icons with boxes for entering the step or an- gle size are used to activate incremental translations and rotations.*
and rotations.*The grid icons with boxes for entering the step or an- gle size are used to

Raster-Icons mit Schritt- bzw. Winkelangaben werden verwendet, um schrittweise Verschiebungen bzw. Rotationen zu aktivieren.*

World coordinate system activeWeltkoordinatensystem aktiv

Weltkoordinatensystem aktiv

User-specific coordinate system activeBenutzerspezifisches Koordinatensystem aktiv

Benutzerspezifisches Koordinatensystem aktiv

Object-specific coordinate system activeObjektspezifisches Koordinatensystem aktiv

Objektspezifisches Koordinatensystem aktiv

Parent-object coordinate system activeVaterobjektspezifisches Koordinatensystem aktiv

Vaterobjektspezifisches Koordinatensystem aktiv

* The units used are mm and degrees.

* Die Einheiten sind in mm und Grad angegeben.

1 0 1 1
1 0
1 1

KUKA.SIM

QUICK GUIDE Loading a Component Modifying Parameters

Loading a layout or a component A layout or a component can be loaded in several ways:

Laden eines Layouts oder einer Komponente Ein Layout oder eine Komponente kann auf verschiedene Arten gela- den werden:

1.

Drag and drop the layout or component from the eCatalog library on the tabbed panel into the 3D world.

1. Ziehen Sie das Layout oder die Komponente mit drag ’n’ drop aus

2.

Double-clicking on the layout or component in the eCatalog has the

der eCatalog-Bibliothek im Auswahlregister in die 3-D-Ansicht.

same effect, but places it at the zero point.

2. Mit einem Doppelklick auf das Layout oder die Komponente im

3.

You can use the Cut, Copy and Paste commands from the Edit menu,

You can use the Cut, Copy and Paste commands from the Edit menu,
You can use the Cut, Copy and Paste commands from the Edit menu,

eCatalog erreichen Sie denselben Effekt, jedoch wird dieses dann

or the respective keyboard shortcuts , and

im Nullpunkt platziert.

, to reinsert existing components.

3. Sie können die Befehle Ausschneiden, Kopieren und Einfügen aus

4.

Drag the layout or component from Windows Explorer into the 3D

dem Menü Bearbeiten verwenden oder die entsprechenden

world.

Tastatur-Shortcuts ,

Tastatur-Shortcuts ,

und

world. Tastatur-Shortcuts , und , um

, um

5.

Use the Import command from the File menu. The component is placed at the zero point.

vorhandene Komponenten erneut einzufügen.

4. Ziehen Sie das Layout oder die Komponente aus dem Windows

6.

Use the Open command from the File menu for opening layouts.

Explorer in die 3-D-Ansicht.

5. Verwenden Sie das Menü Datei > Importieren. Die Komponente wird im Nullpunkt platziert.

6. Verwenden Sie das Menü Datei > Öffnen, um Layouts zu öffnen.

Tip: In the DemoLayouts directory you will find several prepared layouts and simulations. The location of this directory depends on your installation but is usually located at c:/Visual Components 2.0/eCat/DemoLayouts. (Tools > Option).

Tipp: Im Verzeichnis DemoLayouts finden Sie einige vorbereitete Layouts und Simulationen. Der Speicherort dieses Verzeichnisses hängt von der Installa- tion ab und befindet sich normalerweise in c:/Visual Components 2.0/eCat/ DemoLayouts (Tools>Option).

Modifying parameters (“Param” tab) (KUKA.Sim Pro only) Most components from the eCat library are parametric in design. This parametric approach eliminates the need for CAD remodelling and saves you valuable time. Adjusting parameters can be done as follows:

Select the component whose parameters are to be modified. Go to the “Param” tab and edit the parameters as needed. Parametric components themselves can only be created or modified using KUKA.Sim Pro.

Ändern von Parametern (Auswahlregister „Param“) (nur KUKA.Sim Pro) Die meisten Komponenten in der eCat-Bibliothek sind parametrisch. Diese parametrische Lösung erspart Ihnen CAD-Neumodellierung und wertvolle Zeit. Die Einstellung von Parametern nehmen Sie wie folgt vor:

Wählen Sie die Komponente aus, deren Parameter verändert wer- den soll. Gehen Sie in das Auswahlregister „Param“ und bearbei- ten Sie die Parameter entsprechend Ihren Anforderungen. Para- metrische Komponenten selbst können nur mit KUKA.Sim Pro er- stellt oder verändert werden.

nur mit KUKA.Sim Pro er- stellt oder verändert werden. Note: To create parametric components, KUKA.Sim Pro

Note: To create parametric components, KUKA.Sim Pro is needed.

Hinweis: Um parametrische Komponenten zu erstellen, benötigen Sie KUKA.Sim.Pro.

Note: To apply changes, text fields must be confirmed using the Enter key or the 3D world must be updated with a mouse click.

Hinweis: Um Änderungen zu übernehmen, müssen Textfelder mit der Eingabetaste abgeschlossen werden oder die 3-D-Ansicht muss mit einem Mausklick aktuali- siert werden.

1 2 1 3
1 2
1 3

PROGRAMMING WITH KUKA.SIM PROGRAMMIEREN MIT KUKA.SIM

PROGRAMMING WITH KUKA.SIM PROGRAMMIEREN MIT KUKA.SIM Tip: You can modify the TOOL_DATA[1-32] by first setting the

Tip: You can modify the TOOL_DATA[1-32] by first setting the local coordinates, then se- lecting the tool, pressing the Trans or Rot button and finally typing in a value or moving the tool with one of the red, green or blue arrows. The BASE_DATA[1-32] can be positioned in the layout in the same way.

Tipp: Sie können die TOOL_DATA[1-32] verändern, indem Sie zuerst die lokalen Ko- ordinaten einstellen, dann das Tool auswählen, die Schaltfläche „Trans” oder „Rot” drücken und schließlich einen Wert eingeben oder das Tool mit einem der roten, grünen oder blauen Pfeile bewegen. Analog können die BASE_DATA[1-32] im Layout positioniert werden.

können die BASE_DATA[1-32] im Layout positioniert werden. 1 4 You can grip components by moving to
1 4
1 4

You can grip components by moving to a component with the tool TOOL_DATA[1–16] and setting the corresponding output to TRUE. At the same time, a virtual cuboid around the Tool Center Point (50 mm x 50 mm x 50 mm) must intersect with the component to be gripped. Output 1 is preset for TOOL_DATA[1] and output 2 for TOOL_DATA[2], etc. If the output is reset (FALSE), the component is released. Outputs 1–16 are preset here for gripping. A trace (robot path) can be switched on or off using outputs 17–32. The assignment of these outputs can be freely configured in KUKA.Sim Pro.

Sie können Bauteile greifen, indem Sie mit dem Werkzeug TOOL_ DATA[1–16] ein Bauteil anfahren und den entsprechenden Ausgang dazu einschalten (TRUE). Dabei muss ein virtueller Quader um den Tool Center Point (50 mm x 50 mm x 50 mm) in das zu greifende Bauteil eintauchen. Voreingestellt ist der Ausgang 1 für TOOL_DATA[1] und der Ausgang 2 für TOOL_DATA[2] usw. Wird der Ausgang wieder zurückge- setzt (FALSE), so wird auch das Bauteil wieder gelöst. Voreingestellt sind hier die Ausgänge 1–16 für das Greifen. Ein Trace (Roboterspur) kann mit den Ausgängen 17–32 ein- bzw. aus- geschaltet werden. Mit KUKA.Sim Pro kann die Funktionsweise dieser Ausgänge auch beliebig konfiguriert werden.

bzw. aus- geschaltet werden. Mit KUKA.Sim Pro kann die Funktionsweise dieser Ausgänge auch beliebig konfiguriert werden.

Moving the robot interactively (“Teach” tab)

Interaktives Verfahren des Roboters (Auswahlregister „Teachen“)

Robots can be moved interactively in different ways on the “Teach” tab.

Roboter können auf der Seite „Teachen“ auf verschiedene Weisen inter- aktiv bewegt werden.

When the cursor is moved over one of the movable axes, the cursor shape changes

When the cursor is moved over one of the movable axes, the cursor shape changes and the axis can be jogged by clicking and dragging with the left-hand mouse button.

Wenn Sie den Cursor über eine der beweglichen Achsen ziehen, ändert sich die Form des Cursors und die Achse kann durch gleich- zeitiges Drücken der linken Maustaste verfahren werden.

Translates the tool in relation to the selected coordinate system: Bewegt den Roboter entlang des

Translates the tool in relation to the selected coordinate system:

Bewegt den Roboter entlang des ausgewählten Koordinatensystems:

Red (X)

rot (x)

Green (Y)

grün (y)

 

Blue (Z)

blau (z)

Rotates the tool in relation to the selected coordinate system: Orientiert den Roboter bezüglich des

Rotates the tool in relation to the selected coordinate system:

Orientiert den Roboter bezüglich des ausgewählten Koordinaten- systems:

Red (X)

Green (Y)

rot (x)

 

Blue (Z)

grün (y)

 

blau (z)

Note : If more than one robot is used in the layout, go to program

Note: If more than one robot is used in the layout, go to program selection, select the robot and then move the robot. To move a robot, activate the icon shown in the selection bar.

move a robot, activate the icon shown in the selection bar. Note: When working range limitation

Note: When working range limitation is activated, the robot cannot be moved beyond its range limits.

Hinweis: Wenn mehrere Roboter im Layout verwendet werden, gehen Sie zur Programmauswahl, wählen den Roboter und verfahren dann den Roboter. Um einen Roboter zu bewegen, aktivieren Sie das abgebildete Icon in der Funktionsleiste.

Hinweis: Wenn die Arbeitsraumbegrenzung aktiviert ist, kann der Roboter nicht über die Achsbegrenzungen hinaus bewegt werden.

1 5
1 5

KUKA.SIM

Tip: You can change the order of taught points by selecting a statement on the “Teach” tab and moving these points forward or backward in the sequence by means of Drag ’n’ Drop. These statements can be changed, added or removed. Tipp: Sie können die Reihenfolge der geteachten Punkte ändern, indem Sie eine Anweisung im Auswahlregister „Teachen“ wählen und diese Punkte per Drag ’n’ Drop in der Sequenz vorwärts oder rückwärts bewegen. Diese Anweisungen können verändert, hinzugefügt oder entfernt werden.

der Sequenz vorwärts oder rückwärts bewegen. Diese Anweisungen können verändert, hinzugefügt oder entfernt werden.

Creating a robot sequence (“Teach” tab) A robot program can consist of different subprograms (sequences). These sequences are made up of a series of simple statements. Statements can be changed, added to or removed from a se- quence.

Erstellen einer Robotersequenz (Seite „Teachen“ im Auswahlregister) Ein Roboterprogramm kann aus verschiedenen Unterprogrammen (Sequenzen) bestehen. Diese Sequenzen sind eine Abfolge von einfachen Anweisungen. Anweisungen können in einer Sequenz verändert, hinzugefügt oder aus ihr entfernt werden.

PTP motion (point-to-point) – LIN motion (linear) PTP-Bewegung (Point to Point) – LIN-Bewegung (Linear)
PTP motion (point-to-point) – LIN motion (linear) PTP-Bewegung (Point to Point) – LIN-Bewegung (Linear)

PTP motion (point-to-point) – LIN motion (linear)

PTP-Bewegung (Point to Point) – LIN-Bewegung (Linear)

 
  Call a subprogram Unterprogramm aufrufen

Call a subprogram

Unterprogramm aufrufen

 
  Halt statement Halt-Anweisung

Halt statement

Halt-Anweisung

 
  Comment statement Kommentar-Anweisung

Comment statement

Kommentar-Anweisung

 
  Wait statement Wartezeit-Anweisung

Wait statement

Wartezeit-Anweisung

 
  Delete statement Anweisung löschen

Delete statement

Anweisung löschen

 
  Touch-up statement Touch-up-Anweisung

Touch-up statement

Touch-up-Anweisung

QUICK GUIDE

Moving Interactively

Creating Sequences

KUKA.Sim Pro only

Nur KUKA.Sim Pro

Set output – Wait for input

Set output – Wait for inputAusgang setzen – Warten auf Eingang

Ausgang setzen – Warten auf Eingang

Start remote routine – Wait until remote routine is completedRemote-Routine starten – Warten auf Abarbeitung der Remote-Routine

Start remote routine – Wait until remote routine is completed

Remote-Routine starten – Warten auf Abarbeitung der Remote-Routine

Assign tool data

Assign tool data

Werkzeug-Daten zuweisen

Assign base data

Assign base data

Base-Daten zuweisen

ProgSync / program synchronization

ProgSync / program synchronization

Prog-Syn/Programmsynchronisation

Run simulation Starten der Simulation Stop Stop Speed Geschwindigkeit

Run simulation

Starten der Simulation

Stop

Stop

Speed

Geschwindigkeit

1 6 1 7
1 6
1 7

KUKA.SIM

E-mailing a layout Layout files are small and can be sent easily as an e-mail. When a layout is complete, you can send it by e-mail using the command E-Mail Layout from the File menu.

If you receive an e-mail with an attached layout, double-click on the attachment. KUKA.Sim Viewer, Layout or Pro will then be started to display the simulation. If you do not have any of these programs installed, please follow the link to download your own copy of KUKA. Sim Viewer.

Layout als E-Mail versenden Layout-Dateien sind klein und können problemlos als E-Mail versendet werden. Wenn ein Layout fertig gestellt ist, können Sie dieses per E-Mail mit der Funktion Datei > E-Mail-Layout versenden.

Wenn Sie eine E-Mail mit einem angehängten Layout erhalten, dann doppelklicken Sie auf den Anhang. KUKA.Sim Viewer, Layout oder Pro werden gestartet, um die Simulation anzuzei- gen. Wenn Sie keines dieser Programme installiert haben, folgen Sie bitte dem Link, um Ihre eigene Kopie des KUKA.Sim Viewers herunterzuladen.

QUICK GUIDE E-mailing a Layout Credits Box in Layout Adding a Library Changing the Background Connecting External Axes

“Credits” box in Layout When saving a new layout, a credits box for entering project details is displayed. It is important to give the project a name, because this name will be displayed in the “eCat” tab and identifies your layout. You can change the Credits information anytime by selecting File > Credits.

Adding a library User-defined libraries can be added in the eCat tab by selecting Tools > Options > Local eCat.

Changing the background Background settings can be changed in View > Settings > 3D World.

Connecting external axes to robots (KUKA.Sim Pro only)

Connecting external axes to robots (KUKA.Sim Pro only) When an abstract connection is made using PnP

When an abstract connection is made using PnP be- tween a robot and an external axis, then this axis moves synchronously with the robot. Touch-up also takes into account the axis values of the external axis. The compo- nents used, e.g. a turntable, must have the appropriate properties (behavior).

Box „Projekt Info“ in Layout Wenn Sie ein neues Layout speichern, erscheint eine Box, in die Sie Projekt-Infos und andere Details eintragen können. Sie müssen dem Projekt unbedingt einen Namen geben, da dieser Name im Auswahlregister „eCat“ erscheint und Ihr Layout kennzeichnet. Sie können diese Projekt-Infos jederzeit än- dern, indem Sie Datei > Projekt-Info wählen.

Bibliothek hinzufügen Benutzerdefinierte Bibliotheken können im Auswahlregister eCat hinzugefügt werden, indem Sie Tools > Optionen > Lokaler eCat wählen.

Hintergrund ändern Hintergrundeinstellungen können über Ansicht > Einstellungen > 3-D-Ansicht geändert werden.

Zusatzachsen mit Robotern verbinden (Nur KUKA.Sim Pro) Wenn mit PnP eine abstrakte Verbindung zwischen einem Roboter und einer Zusatzachse erstellt wird, dann bewegt sich diese Achse synchron mit dem Roboter. Bei Touch-up werden auch die Achswerte der Zusatzachse berücksichtigt. Die ver- wendeten Komponenten, z. B. Drehtisch, müssen über die entsprechenden Eigenschaften (Behavior) verfügen.

1 8 1 9
1 8
1 9

KUKA.SIM PRO + KUKA.OFFICE LITE

KUKA.SIM PRO + KUKA.OFFICE LITE KUKA.Sim Pro is designed to be connected to KUKA.OfficeLite. Note: Connection

KUKA.Sim Pro is designed to be connected to KUKA.OfficeLite.

Note:

Connection will only work after correct installation of KUKA.OfficeLite (virtual robot controller VRC) and an active VRC Manager. Please follow the installation instructions on the CDs.

KUKA.Sim Pro ist für die Verbindung mit KUKA.OfficeLite vorgesehen.

Hinweis:

Das Verbinden funktioniert nur nach einer einwandfreien In- stallation von KUKA.OfficeLite (Virtual Robot Controller VRC) und einem aktiven VRC Manager. Bitte beachten Sie hierzu die Installationshinweise auf den CDs.

This is signaled by the following symbol in the task bar:

Signalisiert wird dies in der Taskleiste durch ein Symbol:

CDs. This is signaled by the following symbol in the task bar: Signalisiert wird dies in

Please select the robot that you wish to connect to the controller.

Connecting

Bitte wählen Sie den Roboter aus, den Sie mit der Steuerung ver- binden möchten.

Verbinden

to the controller. Connecting Bitte wählen Sie den Roboter aus, den Sie mit der Steuerung ver-

1. Starting the virtual robot controller VRC (KUKA.OfficeLite) All robots used in the layout are shown in the Workcell Diagram on the “KRC” tab.

1. Starten der virtuellen Robotersteuerung VRC (KUKA.OfficeLite) Alle in dem Layout verwendeten Roboter erscheinen im Workcell- Diagramm-Auswahlfenster „KRC“.

Selecting a robot

Roboterselektion

Layout verwendeten Roboter erscheinen im Workcell- Diagramm-Auswahlfenster „KRC“. Selecting a robot Roboterselektion

Connecting to robots When connecting the robot for the first time, you will be asked to enter the host name of the virtual robot controller VRC. This is generally the same as the computer name of your PC.

Verbinden mit Roboter Bei der ersten Verbindung werden Sie aufgefordert, den Hostnamen der virtuellen Robotersteuerung VRC anzugeben. In der Regel ent- spricht dieser dem Rechnernamen Ihres PCs.

den Hostnamen der virtuellen Robotersteuerung VRC anzugeben. In der Regel ent- spricht dieser dem Rechnernamen Ihres
der virtuellen Robotersteuerung VRC anzugeben. In der Regel ent- spricht dieser dem Rechnernamen Ihres PCs. 2
der virtuellen Robotersteuerung VRC anzugeben. In der Regel ent- spricht dieser dem Rechnernamen Ihres PCs. 2

2 0

2 1
2 1

KUKA.SIM PRO + KUKA.OFFICE LITE

Selecting machine data Now you must select the correct machine data from the list.

(Info: All machine data are copied during installation to C:\KRC\ ALLMADA. You can add further machine data to this directory.)

Maschinendaten auswählen Anschließend müssen Sie die richtigen Maschinendaten aus der Liste auswählen.

(Info: Alle Maschinendaten werden bei der Installation unter C:\KRC\ALLMADA kopiert. Weitere Maschinendaten können Sie in die- sem Verzeichnis ergänzen.)

bei der Installation unter C:\KRC\ALLMADA kopiert. Weitere Maschinendaten können Sie in die- sem Verzeichnis ergänzen.)

Program selection Once the controller has booted, you can select an existing KRC program.

Programmauswahl Wenn die Steuerung hochgefahren ist, können Sie ein bestehendes KRC-Programm auswählen.

KRC program. Programmauswahl Wenn die Steuerung hochgefahren ist, können Sie ein bestehendes KRC-Programm auswählen.

Once the virtual robot controller has booted, you can move the robot manually or in Automatic mode. If further motions are programmed in the simulation (e.g. conveyors or other kinematic systems), the simu- lation must be started from KUKA.Sim Pro to ensure that all the motion sequences are correctly reproduced. (see page 17)

Ist die virtuelle Robotersteuerung hochgefahren, können Sie den Roboter von Hand oder im Automatik-Modus bewegen. Wenn in der Simulation weitere Bewegungen programmiert sind (z. B. Förderbän- der oder andere Kinematiken), muss die Simulation vom KUKA.Sim Pro aus gestartet werden, damit alle Bewegungsabläufe richtig dar- gestellt werden (siehe S. 17).

2.

Actions

KRL program selection

Download RSL program

Disconnect VRC

Actions KRL program selection Download RSL program Disconnect VRC

2. Aktionen

– KRL-Programmauswahl

– Download RSL-Programm

– Verbindung trennen

3.

Operating KUKA.OfficeLite (icon overview)

3. Bedienung KUKA.OfficeLite (Icon-Kurzübersicht)

Stop Stop

Stop

Stop

Start program Programm starten

Start program

Programm starten

Run program backwards Programm rückwärts ablaufen lassen

Run program backwards

Programm rückwärts ablaufen lassen

Enabling switch Zustimmtaste

Enabling switch

Zustimmtaste

Mode selector switch Schalter zur Betriebsartenwahl

Mode selector switch

Schalter zur Betriebsartenwahl

Pin window on top Fenster immer im Vordergrund

Pin window on top

Fenster immer im Vordergrund

Mode selector switch Schalter zur Betriebsartenwahl Pin window on top Fenster immer im Vordergrund 2 2
Mode selector switch Schalter zur Betriebsartenwahl Pin window on top Fenster immer im Vordergrund 2 2

2 2

2 3
2 3