You are on page 1of 8

How do I change the Single Drawing Compatibility Mode in AutoCAD 2008+?

The Single Document Interface (SDI) system variable can be used to manage SINGLE DRAWING COMPATIBILITY MODE. Type SDI and press ENTER. 1 = On (single), 0 = Off (multiple). How do I create a PDF from an AutoCAD drawing? A Portable Document Format (PDF) file is highly portable across computer platforms, making it a popular format for viewing and printing drawings without AutoCAD. PDF documents are created with Adobe Acrobat or other programs and can be viewed with Adobe Acrobat Reader and other PDF reader programs. Prior to AutoCAD 2007, AutoCAD did not include a PDF driver or converter. However, many free and low cost solutions exist. I have personally had good success with a free product named CutePDF. This product installs and is used just like an ordinary printer. One draw back I've found is that you cannot create multi-page PDF's using AutoCAD's Publish command. However, if you are using AutoCAD 2007+, you can use the DWG to PDF.PC3 configuration that is included. No new to purchase or download anything. You can use the DWG to PDF.PC3 configuration to create multi-page PDF's too! How do I use the command line instead of dialog boxes? Beginning with AutoCAD 2000, several commands changed to utilize a dialog box for input. Prior to AutoCAD 2000 one command produced a dialog box, another prompts on the command line. For instance, typing DDINSERT displayed the Insert dialog box, while typing INSERT prompted for input on the command line. This change can wreck havoc on customized menus in later versions of AutoCAD. To use the command line version, include a hyphen (-) in front of a command: -INSERT. The following is a list of commands that support dialog box and command line input. Placing a hyphen before the command name will cause prompts to be displayed in the command window. array, attdef, attedit, attext, bhatch, block, boundary, color, dimstyle, group, hatchedit, hyperlink, image, imageadjust, insert, layer, linetype, lweight, mtext, pan, plot, plotstamp, psetupin, purge, refedit, rename, style, toolbar, units, vbarun, view, wblock, xbind and xref

How do I make the file dialog box display? The system variable FILEDIA controls the display of file dialog boxes used in command like WBLOCK and SAVEAS. Setting FILEDIA to 0 disables the display of file dialog boxes, forcing input from the command line. If your file dialog boxes have disappeared, make sure FILEDIA is set to 1. How do I make the attribute dialog box display when I insert a block? The system variable ATTDIA controls the display of the attribute dialog box when inserting a block with attributes. Setting ATTDIA to 0 disables the display of the attribute dialog box, forcing input from the command line. If your attribute dialog box has disappeared, make sure ATTDIA is set to 1. Another setting that may be having an effect on the attribute dialog box is ATTREQ. Setting ATTREQ to 0 disables the prompting for attributes when a block is inserted. How do I make the middle button display the Object Snap menu? The MBUTTONPAN system variable controls the behavior of the middle button. Set MBUTTONPAN to 0 causes the middle mouse button to perform the actions defined by the menu, typically to display the Object Snap cursor menu. How do I find and use the files created by AutoSave? By default the files created by AutoSave are stored in a temporary file folder. You can determine the folder name by selecting the Options command from the Tools menu. Next, select the Files tab. Click the '+' sign next to Automatic Save File Location. The complete path will be shown. Once you've located the folder that contains the AutoSave files you'll need to decipher the file names. Below is the format used by the AutoSave function in naming the files. drawing name_AutoCAD session number_MDE Window number_random number.sv$ drawing name is the original drawing name. AutoCAD session number is the sequentially numbered session of the program running concurrently on the system (if there is more than one session running). MDE Window number is the sequentially numbered open drawing in the program (if there is more than one drawing open). random number is a random number generated by the program.

.sv$ is the file extension AutoCAD assigns to all AutoSave files. Let's say you are looking for the AutoSave file for a drawing FloorPlan.dwg. You have determined that the AutoSave Folder is C:\Temp Your AutoSave file wil be something like C:\Temp\FloorPlan_1_2_4361.sv$. To open the AutoSave file you'll need to rename the file so that it has dwg extension.Once you've located the file, just highlight it, right-click and select Rename from the list. At the very least, change the sv$ to dwg. At this point you can move the file to a different folder or open it. Note: The BAK file can also be useful in recovering drawings. The BAK file will have the same name as the drawing file, but with a bak extension. Use the procedure described above to rename the BAK file to a DWG file before opening it. How do I make my dialog boxes reappear? A system variable named CMDDIA (command dialog) controls the display of many dialog boxes. Setting CMDDIA to 0 disables the display of these dialog boxes, forcing input from the command line. Set CMDDIA to 1 to have the dialog boxes display normally. How do I make dimensions associative? The system variable DIMASSOC controls the associativity of dimensions. Dimension associativity defines the relationship between geometric objects and the dimensions that give their distance and angles. DIMASSOC has three possible values: 2 - Fully Associative dimensions. Locations, orientations, and measurement values change when the geometric objects associated with them are modified, regardless of method (AutoCAD 2002 only). 1 - Nonassociative dimensions. Selected and modified with the geometry they measure. Use STRETCH to change geometry and dimensions. 0 Exploded dimensions. Contains a collection of separate objects rather than a single dimension object. How do I relocate a toolbar on my screen that is turned on but not visible? If you find that one of your toolbars is missing, the first thing you want to do is make sure that the toolbar is turned on. Right clicking on a standard AutoCAD toolbar and verifying that there is a check mark beside the missing toolbar accomplishes this. If the toolbar is turned on and still not visible on the screen, then you have an "out-ofbounds" toolbar. Sometimes in AutoCAD, during a drafting session, one can accidentally place a toolbar off of the viewable area of the monitor. This toolbar is still on and active, but untouchable to be manually relocated on the screen.

To reposition the toolbar so that it can be seen, enter -TOOLBAR at the command line. When prompted for the toolbar name, enter the name of the toolbar that you want to relocate. Next, you will be prompted for an option. The options are listed in [brackets]. Enter F for Float and press enter. Now, the command line will ask for a New Position (screen coordinates). Enter 500,500 (approximate center of the screen) and press enter. When the command line asks for the number of rows for the toolbar, accept the default value <default>. The missing toolbar should then appear near the center of your screen and can now be relocated and resized as needed. How do I make AutoCAD search a different folder for menus, blocks, etc.? The AutoCAD Support File Search path specifies the folders in which AutoCAD searches for support files. In addition to the files required to run AutoCAD, you can include files for fonts, menus, drawings to insert, linetypes, and hatch patterns in the support file search path. The path is set on the Files tab of the Options window. How do I make a toolbar button that allows me to select objects? Commands like move, erase, chprop, etc. allow you to select objects until you press ENTER to continue to the next step of the command. Because you can select any number of objects, using any number of picks, it can be confusing to create toolbar buttons and menu picks that use commands like this. However, there is an easy way to deal with this apparent roadblock, the SELECT command. When the SELECT command is used in a toolbar button or menu pick, AutoCAD waits until the user presses ENTER to continue with the rest of the menu macro. Let's say you want create a button to select a group of objects and change them to the HIDDEN layer, when linetype and color set ByLayer. Here's is the code [Change to Hidden]^c^cselect;\chprop;previous;;la;hidden;lt;bylayer;co;bylayer;; ^c^c - clear any active commands Select - select command ; - ENTER (spaces can also be used in most instances) \ - pause for user input Chprop - Change Properties command Previous - select the previously selected group of objects (those selected for the Select command) ;; - one to complete Previous, the other to stop selecting objects. La - layer Lt - linetype Co - color ByLayer - Change the entity settings to display the property of the layer the object. ;; - one to complete ByLayer, the other complete the Chprop command.

How can I select more than one object with commands like Move and Erase? If you find yourself unable to make more than one selection in commands like Move and Erase, it's probably because a setting has been changed that requires you to hold down the shift key to Add to the selection. To change this back to shift to Remove from the selection, select the Tools menu, then Options and left-click on the Selection tab. Remove the check mark from the Use Shift to add to the select box. This setting can also be changed with the PICKADD system variable. How do I change the AutoCAD background color? The background color can be changed by selecting Options in the Tools menu (or type OPTIONS). Left-click on the Display tab. Next, left-click on the Color... button. Now, left-click on the model or layout tab image. Use the Color drop down list to select the desired color. You can change the color of a few other Window elements also: The Model and Layout tab pointers, the Autotrack vector color, the Command line background, the Command line text and the Plot Preview background. How do I change the read-only setting on a file? You can change the read-only setting on a file by selecting the file in AutoCAD's Select File window, right-clicking and selecting Properties from the menu. The Read-only setting is located at the bottom of the window. Note: AutoCAD will display an error when saving if the BAK file is Read-only. How do I remove the proxy notice window? Custom objects created using the AutoCAD Runtime Extension programming language (ObjectARX) require the ObjectARX program to display the objects. If the program is not available, a Proxy window is displayed. Set the PROXYNOTICE setting to 0 to suppress the window's display. How do I turn off the Active Assistant in AutoCAD 2002? To turn off the Active Asstistant permanently, right-click in the Active Assistance box and choose Settings... Remove the check mark next to Show on start. Set the Activation to On demand. Close Active Assistant.

The text is the Mtext dialog is very light. How do I make the Mtext dialog darker? This is caused by a Windows XP display setting for font display. 1. Right-click on the Windows XP desktop and click Properties on the shortcut menu. 2. In the Properties dialog box, click the Appearance tab.

3. Click Effects. 4. Clear the Use the Following Method to Smooth the Edges of Screen Fonts option. 5. Click Apply and Close

How do I edit a Table object in AutoCAD 2004? Unfortunately, the Table object, which was added in AutoCAD 2005, cannot be modified in release AutoCAD 2004 and earlier. Tables can be exploded, resulting in line and text objects. 2.) When do you use cad in your production process?( i.e. preliminary design, design development, ect.) Through all phases of design. 3.) What types of standardization do you use? Our standards are based off of the US NCS 3 standards. 4.) What are some advantages or disadvantages that cad brings to your practice? Advantages: x-refs are great, especially when working with an architectural firm and client who keeps changing their design. Disadvantages: Working with people who make up their own standards, just because they're not used to using the one that's set up where you are. Those black spots that every hand drafter used to get when using paper and ink (I always wanted to do that, but by the time I got into it, they had started to embrace CAD).

What are the differences between Dtext and Mtext. What is a ctb file? Which Autocad Layer never plots whether it is turned off or on? What are the differences between associative hatching and non-associative hatching? If you wanted to select a line and there were other lines on top of it how would you select it? What is the difference between the divide command and the measure command? If you wanted to increase the length of a line by 20mm how would you do it. What does the system variable FILEDIA do? What is Orthomode. What is the difference between a crossing polygon and a window polygon. What is a mnu file? What is the difference between Attached and Overlayed Xrefs, and when would you use each?

What should you be aware of when doing hatching in a drawing that contains an xref? What do you need to be aware of when using Perpendicular as a running Osnap? Explain what happens when you Wblock items and choose a base point rather than typing 0, 0, 0. What is the difference between grid and snap? What is the difference between a window and crossing selection box? How do you deselect an object? What is a base point? How do you find the length of a line? How do you find the x, y coordinates of the center of a circle? When inserting a block with the insert command, what parameters can be specified? What are some of the advantages of using blocks? How can you insert one drawing into another? What are the differences between aligned and linear dimensions? How do you move a dimension farther away from an object? What is the difference between snap and osnap? When would you use snap? What is the difference between freezes and off? What is ortho? What is polar? What command creates parallel copies of an object?What are the definitions of the following abbreviations:

1. A 2. Ar 3. C 4. Co 5. E 6. F 7. L 8. La 9. Lt 10. M 11. Mi 12. Ms 13. O 14. Os 15. Pe 16. Pl 17. Ps 18. R 19. Re 20. Ro 21. Z 22. UCS

What is shown in the properties box when a line is selected? When a dimension is selected? What does the boundary command do? What is the main difference to consider when using a spline versus a curved polyline? What is an xref? What happens when you hold the shift key in the extend command? What does a layer filter do? What do layer states do? What does ^C^C in a toolbar macro do? When should you write (or purchase) a macro, script, or LISP routine? What is the difference between 2D and 3D in AutoCAD? When should you use 2D in civil engineering projects? When should you use 3D in civil engineering projects? What angle would AutoCAD say the hour hand is on at 1:30 on a clock? What does this tool button do? In the line command, how do you tell AutoCAD that you have finished drawing the line segment and want to exit the command? In the copy object command, when do you tell AutoCAD that you want to paste multiple copies? What is the difference between the scale and stretch commands? What is a layer? What is a block? What is the difference between redraw and regen? What do you do to get the linetype scale to look the same in model space and layout viewports? How do you make a solid filled circle? How do you use to make a line on layer 1 with a continuous line and red color have the same properties as a line on Layer 3 with a dashed line and blue color? What happens when you double click a hatch pattern? (Assumed the layer is not locked.)