You are on page 1of 13

http://www.ambienteoffice.com.

br/excel/contar_celulas_num_intervalo/

Contar Clulas num Intervalo


ltima atualizao: 05/12/2011 Introduo Exemplos de Contagem de Clulas num Intervalo Contagem Condicional de Clulas Contar Clulas com Base em Mltiplos Critrios Elemento Mais Frequente numa Lista Contar Nmero de Ocorrncias de Texto Especfico Contar Quantidade de Registros Distintos Numa Lista Referncias

Introduo
O Excel uma poderosa ferramenta para contar clulas, baseados at com uma ou mais condio. Esta pgina possui vrios exemplos de como se fazer isso atravs das funes do Excel.

Exemplos de Contagem de Clulas num Intervalo


Observe a figura abaixo. Ela contm vrios exemplos de contagem de clulas num intervalo, dependendo de sua natureza:

As frmulas usadas so: Total de clulas: =LINS(A2:B11)*COLS(A2:B11) Clulas em branco: =CONTAR.VAZIO(A2:B11) Clulas preenchidas: =CONT.VALORES(A2:B11) Valores numricos: =CONT.NM(A2:B11) No possuem texto: =SOMA(SE(.NO.TEXTO(A2:B11);1)) (frmula matricial) Clulas texto: =SOMA(SE(TEXTO(A2:B11);1)) (frmula matricial) Valores lgicos: =SOMA(SE(LGICO(A2:B11);1)) (frmula matricial) Erros: =SOMA(SE(ERROS(A2:B11);1)) (frmula matricial) Erros #N/D: =CONT.SE(A2:B11;"#N/D") Erros #NULO!: =CONT.SE(A2:B11;"#NULO!") Erros #DIV/0!: =CONT.SE(A2:B11;"#DIV/0!") Erros #VALOR!: =CONT.SE(A2:B11;"#VALOR!") Erros #REF!: =CONT.SE(A2:B11;"#REF!") Erros #NOME?: =CONT.SE(A2:B11;"#NOME?") Erros #NM!: =CONT.SE(A2:B11;"#NM!")

As frmulas matriciais devem ser entradas na Planilha com Ctrl+Shift+Enter. Para saber mais sobre frmulas matriciais, clique aqui. Vale ressaltar que as frmulas de contagem de erro no vo funcionar para a verso do Excel em ingls, por exemplo, j que o erro #NOME? #NAME?. Voc poderia corrigir esse erro forando o erro, como por exemplo: =CONT.SE(A2:B11;NomeInesistente).

Contagem Condicional de Clulas


Considere um intervalo fictcio. As frmulas abaixo so vrios exemplos de como se fazer uma contagem baseada num critrio. =CONT.SE(Intervalo;12) - Retorna o nmero de clulas que contm o valor 12. =CONT.SE(Intervalo;"<0") - Returna o nmero de clulas de valor negativo. =CONT.SE(Intervalo;"<>0") - Returna o nmero de clulas diferentes de 0. =CONT.SE(Intervalo;">5") - Returna o nmero de clulas maior que 5. =CONT.SE(Intervalo;A1) - Retorna o nmero de clulas de valor igual ao de A1. =CONT.SE(Intervalo;">"&A1) - Retorna o nmero de clulas maior que o valor de A1. =CONT.SE(Intervalo;"*") - Retorna o nmero de clulas que contm texto. =CONT.SE(Intervalo;"???") - Retorna o nmero de clulas de texto que contm exatamente trs caracteres. =CONT.SE(Intervalo;"casa") - Retorna o nmero de clulas que possui texto exatamente igual a casa (no diferencia maisculas de minsculas). =CONT.SE(Intervalo;"*casa*") - Retorna o nmero de clulas que possui o texto casa dentro de todo texto da clula (no diferencia maisculas de minsculas). =CONT.SE(Intervalo;"A*") - Retorna o nmero de clulas que comeam com a letra a (no diferencia maisculas de minsculas). =CONT.SE(Intervalo;HOJE()) - Retorna o nmero de clulas que contm a data atual. =CONT.SE(Intervalo;">"&MDIA(Intervalo)) - Retorna o nmero de clulas cujo valor maior que a mdia. =CONT.SE(Intervalo;">"&MDIA(Intervalo)+DESVPAD(Intervalo)*3) - Retorna o nmero de clulas cujo valor excede trs desvios padres acima da mdia.

=CONT.SE(Intervalo;3)+CONT.SE(Intervalo;-3)+CONT.SE(Intervalo;5) - Retorna o nmero de clulas contm o valor 3, -3 ou 5. Alternativa: =SOMA(CONT.SE(Intervalo;{3;-3;5})) (frmula matricial) =CONT.SE(Intervalo;VERDADEIRO) - Retorna o nmero de clulas que contm o valor lgico VERDADEIRO. =CONT.SE(Intervalo;VERDADEIRO)+CONT.SE(Intervalo;FALSO) - Retorna o nmero de clulas que contm o valor lgico VERDADEIRO ou FALSO. Alternativa: =SOMA(CONT.SE(Intervalo;{VERDADEIRO;FALSO})) (frmula matricial) =CONT.SE(Intervalo;"#N/D") - Retorna o nmero de clulas que possui o erro #N/D.

Contar Clulas com Base em Mltiplos Critrios


Existe uma funo que foi introduzida a partir do Excel 2007 para contar clulas que atendam mltiplos critrios (por exemplo: contar clulas com valores entre 10 e 100) chamada CONT.SES. No entanto, recomendo fortemente no us-la, mas usar uma das funes mais versteis do Excel, que a SOMARPRODUTO. Clique aqui para ver o artigo de SOMARPRODUTO.

Elemento Mais Frequente numa Lista


Observe a figura abaixo:

Para saber qual o termo mais frequente numa lista, use: =NDICE(A18:A27;CORRESP(MXIMO(CONT.SE(A18:A27;A18:A27));CONT.S E(A18:A27;A18:A27);0)) (frmula matricial) Para saber quantas vezes esse termo aparece:

=CONT.SE(A18:A27;D18)

Contar Nmero de Ocorrncias de Texto Especfico


Observe a figura abaixo:

As frmulas so: Vezes que 'alpha' aparece: No diferenciando maisculas de minsculas: =CONT.SE(A31:A41;B31) Diferenciando maisculas de minsculas: =SOMA(SE(EXATO(A31:A41;B31);1)) Clulas que consta o texto 'alpha': No diferenciando maisculas de minsculas: =CONT.SE(A31:A41;"*"&B31&"*") Diferenciando maisculas de minsculas: =SOMA(SE(NM.CARACT(A31:A41) NM.CARACT(SUBSTITUIR(A31:A41;B31;""))>0;1)) (frmula matricial) Vezes que aparece o texto 'alpha' em todas as clulas: No diferenciando maisculas de minsculas: =(SOMA(NM.CARACT(A31:A41)) SOMA(NM.CARACT(SUBSTITUIR(MAISCULA(A31:A41);MAISCULA(B3 1);"")))) / NM.CARACT(B31) (frmula matricial) Diferenciando maisculas de minsculas: =(SOMA(NM.CARACT(A31:A41)) SOMA(NM.CARACT(SUBSTITUIR(A31:A41;B31;"")))) / NM.CARACT(B31) (frmula matricial)

Contar Quantidade de Registros Distintos Numa Lista


Veja nesta pgina: Registro Distintos, Exclusivos e Duplicados Numa Lista - Contar Quantidade de Registros Distintos Numa Lista..

Referncias
John Walkenbach: Microsoft Excel 2010 Bible Frmulas Matriciais Registros Distintos, Exclusivos e Duplicados Numa Lista Somar Clulas num Intervalo SOMARPRODUTO
Para baixar um arquivo de exemplo pronto, clique aqui.

http://www.expertaccess.com.br/forumnew/forum_posts.asp?TID=16665

Excel: Frmula para contar ocorrencia de texto


Data do Evento: 01 Dez 2008 - 01 Dez 2008
Caros colegas, Preciso contar o nmero de ocorrncias em uma cadeia de texto de um intervalo de clulas, quantas vezes aparece a palavra "chave". Na verdade, o texto completo est assim descrito: "montagem incorreta de chaves e para-raios" na pgina <http://support.microsoft.com/kb/213889/pt>, a Microsoft apresenta uma possvel soluo, mas nao consegui fazer a formula funcionar. Alguem poderia explicar-me o que est errado, ou sugerir uma soluo alternativa? Agradeo antecipadamente.

=CONT.SE(A1:A14;"*chaves*")

EXCEL: encontrar palavra na frase e efetuar clculo


Criado por npontes, Mar 04 2012 09:28 AM 04 March 2012 - 09:28 AM Ol, gostaria de saber se h possibilidade de efetuar a seguinte tarefa no Excel: Tenho uma planilha onde em determinada clula contenha uma frase ou textos variados - por exemplo: VENCIMENTO: 26/02/12 - IMPOSTO DE RENDA (1,5%) = 132,95 RETENO LEI 10833/03 (4,65%) = 412,14 INSS (11%) = 974,96 (coluna I) Mas nem todas as clulas contm as mesmas informaes, algumas aplicado por exemplo IR ou INSS. Em outra coluna na mesma linha, existe o valor total que a base para os clculos dos impostos. (coluna A) Para conferir se as informaes na clula onde est o texto, est correta, tenho que efetuar o clculo em outras colunas, cada uma para um tipo de informao: por exemplo IR que ser 1,5% do valor da coluna A, INSS que ser 11% do valor da clula na coluna A, e assim por diante. Ento para cada clula a ser calculada, necessito que seja aplicada uma frmula condicional, por exemplo, se encontrado texto "IMPOSTO DE RENDA" na clula da frase, ento calcular o correspondente IR na coluna, utilizando o valor base na coluna A). o objetivo verificar se o valor encontrado no descritivo (coluna I) corresponde ao valor corretamente calculado nas colunas correspondentes, tendo como base o valor indicado na coluna A) Outra necessidade, indicar o banco (abreviatura) na coluna G, por exemplo, se no descritivo existir o texto CAIXA ECONOMICA FEDERAL, dever automaticamente mostrar na coluna G o texto CEF, caso seja SANTANDER dever trazer o texto STDER, se for BANCO DO BRASIL dever mostrar BBRAS. Obrigado pela ajuda Arquivos Anexados

PLANILHA.zip 8.76KB 149 downloads

Publicado 06 March 2012 - 10:23 PM Conforme sua dvida e pelo que entendi, Tente desta forma: B2 => =SE(ERROS(LOCALIZAR("IMPOSTO DE RENDA";I2));"";1,5%*A2) G2 => =SE(NO(ERROS(LOCALIZAR("SANTANDER";I2)));"STDER";SE(NO(ERROS(LOCA LIZAR("ECONOMICA";I2)));"CEF";SE(NO(ERROS(LOCALIZAR("BANCO DO BRASIL";I2)));"BBRAS";""))) Para as demais clulas abaixo, selecione a Clula com a frmula e utilizando ala de preenchimento - arraste para baixo . Para os demais impostos, a idia a mesma, que a do IR (mudando apenas o texto e o percentual) Publicado 08 March 2012 - 01:50 PM SHOW!!!! FUNCIONOU PERFEITAMENTE... muitssimo obrigado

Leia mais: http://www.babooforum.com.br/forum/index.php?/topic/757387-excelencontrar-palavra-na-frase-e-efetuar-calculo/#ixzz2fRNWoisJ

http://support.microsoft.com/kb/187667/pt-br

Frmula para contar o nmero de ocorrncias de uma seqncia de texto em um intervalo


Use a seguinte frmula para contar o nmero de ocorrncias de uma seqncia de texto em um intervalo: = Soma (LEN(<range>) LEN (SUBSTITUTO (< intervalo > "text","")))/LEN("text") onde < intervalo > o intervalo de clulas em questo e "texto" substitudo pela seqncia de caracteres de texto especficos que voc deseja contar. Observao A frmula acima deve ser inserida como uma frmula de matriz. Para inserir uma frmula como uma frmula de matriz, pressione COMMAND + RETURN. A frmula deve ser dividida pelo comprimento da seqncia de caracteres de texto porque a soma do comprimento do caractere do intervalo reduzida por um mltiplo de cada ocorrncia da seqncia de caracteres de texto. Essa frmula pode substituir todas as frmulas posteriores neste artigo exceto a frmula para contar o nmero de palavras em uma clula.

Exemplo 1: Contar o nmero de ocorrncias de uma seqncia de texto em um intervalo


1. Inicie o Microsoft Excel e abra uma nova pasta de trabalho. 2. Digite o seguinte em sheet1: 3. A1: Fruit 4. A2: apple,apple 5. A3: orange 6. A4: apple,orange 7. A5: grape 8. A6: orange,grape 9. A7: grape, apple 10. A8: =SUM(LEN(A2:A7)LEN(SUBSTITUTE(A2:A7,"apple","")))/LEN("apple") Observao: A frmula acima deve ser inserida como uma frmula de matriz. Para inserir uma frmula como uma frmula de matriz, pressione COMMAND + RETURN. O valor da clula A8 4, porque o texto "apple" exibida quatro vezes no intervalo.

Frmula para contar o nmero de ocorrncias de um nico caractere em uma clula


Se voc estiver preocupado sobre como procurar por um nico caractere em uma nica clula, a frmula simplificada para: = LEN(<range>)-LEN (SUBSTITUTO (< intervalo > "um","")) onde < intervalo > o intervalo de clulas em questo e "a" substituda pelo caractere que voc deseja contar. Observao: Esta frmula no precisa ser inserida como uma frmula de matriz.

Exemplo 2: Contando o nmero de ocorrncias de um caractere em uma clula


Usar os mesmos dados do exemplo anterior; Suponha que voc deseja contar a nmero de ocorrncias ou o caractere "p" em A7. Digite o seguinte frmula na clula A9: A9: =LEN(A7)-LEN(SUBSTITUTE(A7,"p","")) O valor da clula A9 3 porque o caractere "p" aparece trs vezes em A7.

Frmula para contar o nmero de ocorrncias de um nico caractere em um intervalo


Se voc estiver preocupado sobre como procurar um nico caractere em um intervalo, o frmula simplificada para: =SUM(Len(Range)-Len(SUBSTITUTE(Range,"a",""))) onde <range> o intervalo de clulas em questo e "a" substituda pelo caractere que voc deseja contar. Observao A frmula acima deve ser inserida como uma frmula de matriz. Para inserir um a frmula como uma frmula de matriz, pressione COMMAND + RETURN.</range>

Exemplo 3: Contando o nmero de ocorrncias de um caractere em um intervalo


Usar os mesmos dados do exemplo anterior; Suponha que voc deseja contar a nmero de ocorrncias ou o caractere "p" em a2: a7. Digite o seguinte frmula na clula A10: A10: =SUM(LEN(A2:A7)-LEN(SUBSTITUTE(A2:A7,"p",""))) Observao: A frmula acima deve ser inserida como uma frmula de matriz. Para inserir um a frmula como uma frmula de matriz, pressione COMMAND + RETURN. O valor da clula A10 11 porque o caractere "p" aparece onze vezes em a2: a7.

Frmula para contar o nmero de palavras separadas por um caractere em uma clula
A seguinte frmula conta o nmero de palavras em uma clula separados por um caractere especfico: = Se (LEN (TRIM (<cell_ref>)) = 0, 0, LEN (<cell_ref>)- Len(SUBSTITUTE(<cell_ref>,<char>,"")) + 1)< /char></cell_ref></cell_ref></cell_ref> onde <cell_ref> a referncia de clula e <char> o caractere separar as palavras. Observao No h nenhum espao na frmula acima; vrias linhas so usadas somente para ajustar a frmula para este documento. No inclua espaos quando Digite-o na clula. Essa frmula no precisa ser inserida como uma frmula de matriz.</char></cell_ref>

Exemplo 4: Contando o nmero de palavras separadas por um espao em uma clula


Siga estas etapas para contar o nmero de palavras em uma clula em que as palavras so separados por um caractere de espao:

1. Inicie o Microsoft Excel e abra uma nova pasta de trabalho. 2. Digite o seguinte em sheet1: 3. A1: The car drove fast A2: =IF(LEN(TRIM(A1))=0,0,LEN(TRIM(A1))-LEN(SUBSTITUTE(A1," ",""))+1) A frmula na clula A2 retorna um valor de 4 para refletir que a seqncia de caracteres contm quatro palavras separadas por espaos. Se as palavras so separadas por vrios espaos ou se palavras iniciar ou terminam em um espao no importa. O PREPARO funo remove caracteres de espao extra e inicial e final de espao caracteres no texto na clula. No Microsoft Excel, voc tambm pode usar uma macro para contar as ocorrncias de um caractere especfico em uma clula ou intervalo de clulas. Para obter informaes adicionais, clique no nmero abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft: 89794 Como usar o Visual Basic for Applications para contar as ocorrncias de um caractere em uma seleo no Excel Voltar para o incio | Submeter comentrios

Propriedades
ID do artigo: 187667 - ltima reviso: sbado, 25 de maio de 2013 - Reviso: 6.0 A informao contida neste artigo aplica-se a:
Microsoft Excel 2004 for Mac Microsoft Excel X para Macintosh Microsoft Excel 2001 para Mac Microsoft Excel 98 for Macintosh

Palavras-chave:

kbhowto kbmt KB187667 KbMtpt

Traduo automtica IMPORTANTE: Este artigo foi traduzido pelo software de traduo automtica da Microsoft e eventualmente pode ter sido editado pela Microsoft Community atravs da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que voc tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulrio, sintaxe e/ou gramtica. A Microsoft no responsvel por qualquer inexatido, erro ou dano causado por qualquer traduo imprecisa do contedo ou por seu uso pelos nossos clientes. Clique aqui para ver a verso em Ingls deste artigo: 187667