You are on page 1of 12

R1#show run

Building configuration
Current configuration : 1319 bytes
!
! Last configuration change at 11:40:24 UTC Tue Sep 1 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback120
ip address 172.16.120.1 255.255.255.0
!
interface Loopback121
ip address 172.16.121.1 255.255.255.0
!
interface Loopback122
ip address 172.16.122.1 255.255.255.0
!
interface Loopback123
ip address 172.16.123.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.12.1 255.255.255.0
serial restart-delay 0
clock rate 19200
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 172.16.12.0 0.0.0.255 area 0
network 172.16.120.0 0.0.0.255 area 0
network 172.16.121.0 0.0.0.255 area 0
network 172.16.122.0 0.0.0.255 area 0
network 172.16.123.0 0.0.0.255 area 0
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2 Configure:
R2#show run
Building configuration
Current configuration : 1498 bytes
!
! Last configuration change at 14:49:04 UTC Tue Sep 1 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.12.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
ip address 172.16.23.2 255.255.255.0
serial restart-delay 0
clock rate 19200
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 65100
redistribute ospf 1 metric 100000 10 0 1 1500
network 172.16.0.0
distribute-list 1 out
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 65100
network 172.16.12.0 0.0.0.255 area 0
default-information originate always
!
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 172.16.2.0 mask 255.255.255.0
network 172.16.23.0 mask 255.255.255.0
neighbor 172.16.3.1 remote-as 65100
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
access-list 1 deny 172.16.120.0 0.0.0.255 log
access-list 1 deny 172.16.121.0 0.0.0.255 log
access-list 1 permit any log
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R3 Configure:
R3#show run
Building configuration
Current configuration : 1662 bytes
!
! Last configuration change at 16:30:45 UTC Tue Sep 1 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
ip address 172.16.23.3 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 192.168.34.3 255.255.255.0
serial restart-delay 0
clock rate 19200
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 65100
redistribute connected
network 172.16.0.0
no auto-summary
!
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 172.16.3.0 mask 255.255.255.0
network 172.16.23.0 mask 255.255.255.0
neighbor 172.16.2.1 remote-as 65100
neighbor 192.168.34.4 remote-as 65400
neighbor 192.168.34.4 prefix-list filterout in
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
ip prefix-list filterout seq 5 deny 172.31.8.0/24
ip prefix-list filterout seq 10 deny 172.31.12.0/24
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R4 Configure:
R4#show run
Building configuration
Current configuration : 1382 bytes
!
! Last configuration change at 14:46:06 UTC Tue Sep 1 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback200
ip address 172.31.0.1 255.255.255.0
!
interface Loopback204
ip address 172.31.4.1 255.255.255.0
!
interface Loopback208
ip address 172.31.8.1 255.255.255.0
!
interface Loopback212
ip address 172.31.12.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.34.4 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 65400
no synchronization
bgp log-neighbor-changes
network 172.31.0.0 mask 255.255.255.0
network 172.31.4.0 mask 255.255.255.0
network 172.31.8.0 mask 255.255.255.0
network 172.31.12.0 mask 255.255.255.0
neighbor 192.168.34.3 remote-as 65100
no auto-summary
!
ip http server
no ip http secure-server
!
ip route 172.16.0.0 255.255.0.0 Serial0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
BGP

on R1:
R1#show ip ospf 1 database
OSPF Router with ID (172.16.123.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
172.16.2.1 172.16.2.1 1545 0x8000000C 0x0078D2 2
172.16.123.1 172.16.123.1 1738 0x8000000E 0x00139C 6
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
0.0.0.0 172.16.2.1 1282 0x8000000C 0x007E69 1
192.168.34.0 172.16.2.1 212 080000003 0x00143F 0
R1#show ip route
Gateway of last resort is 172.16.12.2 to network 0.0.0.0
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.12.0 is directly connected, Serial0/0
C 172.16.120.0 is directly connected, Loopback120
C 172.16.121.0 is directly connected, Loopback121
C 172.16.122.0 is directly connected, Loopback122
C 172.16.123.0 is directly connected, Loopback123
O E2 192.168.34.0/24 [110/20] via 172.16.12.2, 00:03:59, Serial0/0
O*E2 0.0.0.0/0 [110/1] via 172.16.12.2, 02:04:43, Serial0/0
R1#show ip ospf 1 border-routers
OSPF Process 1 internal Routing Table
Codes: i Intra-area route, I Inter-area route
i 172.16.2.1 [64] via 172.16.12.2, Serial0/0, ASBR, Area 0, SPF 9
On R2:
R2#show ip ospf 1 neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.123.1 0 FULL/ - 00:00:31 172.16.12.1 Serial0/0
R2#show ip ospf 1 database router
OSPF Router with ID (172.16.2.1) (Process ID 1)
Router Link States (Area 0)
LS age: 1699
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 172.16.2.1
Advertising Router: 172.16.2.1
LS Seq Number: 8000000C
Checksum: 0x78D2
Length: 48
AS Boundary Router
Number of Links: 2
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 172.16.123.1
(Link Data) Router Interface address: 172.16.12.2
Number of TOS metrics: 0
TOS 0 Metrics: 64
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.12.0
(Link Data) Network Mask: 255.255.255.0
Number of TOS metrics: 0
TOS 0 Metrics: 64
LS age: 1895
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 172.16.123.1
Advertising Router: 172.16.123.1
LS Seq Number: 8000000E
Checksum: 0x139C
Length: 96
Number of Links: 6
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.123.1
(Link Data) Network Mask: 255.255.255.255
Number of TOS metrics: 0
TOS 0 Metrics: 1
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.122.1
(Link Data) Network Mask: 255.255.255.255
Number of TOS metrics: 0
TOS 0 Metrics: 1
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.121.1
(Link Data) Network Mask: 255.255.255.255
Number of TOS metrics: 0
TOS 0 Metrics: 1
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.120.1
(Link Data) Network Mask: 255.255.255.255
Number of TOS metrics: 0
TOS 0 Metrics: 1
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 172.16.2.1
(Link Data) Router Interface address: 172.16.12.1
Number of TOS metrics: 0
TOS 0 Metrics: 64
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.12.0
(Link Data) Network Mask: 255.255.255.0
Number of TOS metrics: 0
TOS 0 Metrics: 64
R2# show ip ospf 1 database
OSPF Router with ID (172.16.2.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
172.16.2.1 172.16.2.1 1717 0x8000000C 0x0078D2 2
172.16.123.1 172.16.123.1 1912 0x8000000E 0x00139C 6
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
0.0.0.0 172.16.2.1 1454 0x8000000C 0x007E69 1
192.168.34.0 172.16.2.1 384 080000003 0x00143F 0
R2#show ip eigrp 65100 interfaces
IP-EIGRP interfaces for process 65100
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/0 0 0/0 0 0/1 0 0
Se0/1 1 0/0 118 0/15 531 0
Lo0 0 0/0 0 0/1 0 0
R2#show ip eigrp 65100 topology
IP-EIGRP Topology Table for AS(65100)/ID(172.16.2.1)
Codes: P Passive, A Active, U Update, Q Query, R Reply,
r reply Status, s sia Status
P 192.168.34.0/24, 1 successors, FD is 2681856
via 172.16.23.3 (2681856/2169856), Serial0/1
P 172.16.23.0/24, 1 successors, FD is 2169856
via Connected, Serial0/1
P 172.16.12.0/24, 1 successors, FD is 2169856
via Connected, Serial0/0
P 172.16.2.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 172.16.3.0/24, 1 successors, FD is 2297856
via 172.16.23.3 (2297856/128256), Serial0/1
P 172.16.123.1/32, 1 successors, FD is 28160
via Redistributed (28160/0)
P 172.16.122.1/32, 1 successors, FD is 28160
via Redistributed (28160/0)
R2#
R2#show ip bgp
BGP table version is 3, local router ID is 172.16.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i internal,
r RIB-failure, S Stale
Origin codes: i IGP, e EGP, ? incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.2.0/24 0.0.0.0 0 32768 i
*> 172.16.23.0/24 0.0.0.0 0 32768 i
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C 172.16.23.0/24 is directly connected, Serial0/1
C 172.16.12.0/24 is directly connected, Serial0/0
C 172.16.2.0/24 is directly connected, Loopback0
D 172.16.3.0/24 [90/2297856] via 172.16.23.3, 00:08:00, Serial0/1
O 172.16.121.1/32 [110/65] via 172.16.12.1, 02:08:45, Serial0/0
O 172.16.120.1/32 [110/65] via 172.16.12.1, 02:08:45, Serial0/0
O 172.16.123.1/32 [110/65] via 172.16.12.1, 02:08:45, Serial0/0
O 172.16.122.1/32 [110/65] via 172.16.12.1, 02:08:45, Serial0/0
D EX 192.168.34.0/24 [170/2681856] via 172.16.23.3, 00:08:00, Serial0/1
on R3:
R3# show ip route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 172.16.23.0/24 is directly connected, Serial0/1
D 172.16.12.0/24 [90/2681856] via 172.16.23.2, 00:08:17, Serial0/1
D 172.16.2.0/24 [90/2297856] via 172.16.23.2, 00:08:17, Serial0/1
C 172.16.3.0/24 is directly connected, Loopback0
D EX 172.16.123.1/32 [170/2172416] via 172.16.23.2, 00:08:17, Serial0/1
D EX 172.16.122.1/32 [170/2172416] via 172.16.23.2, 00:08:17, Serial0/1
C 192.168.34.0/24 is directly connected, Serial1/1
R3#
R4#sh ip route
Codes: C connected, S static, R RIP, M mobile, B BGP
D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area
N1 OSPF NSSA external type 1, N2 OSPF NSSA external type 2
E1 OSPF external type 1, E2 OSPF external type 2
i IS-IS, su IS-IS summary, L1 IS-IS level-1, L2 IS-IS level-2
ia IS-IS inter area, * candidate default, U per-user static route
o ODR, P periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
B 172.16.23.0/24 [20/0] via 192.168.34.3, 01:27:12
S 172.16.0.0/16 is directly connected, Serial0/0
B 172.16.3.0/24 [20/0] via 192.168.34.3, 01:27:12
172.31.0.0/24 is subnetted, 4 subnets
C 172.31.0.0 is directly connected, Loopback200
C 172.31.4.0 is directly connected, Loopback204
C 172.31.8.0 is directly connected, Loopback208
C 172.31.12.0 is directly connected, Loopback212
C 192.168.34.0/24 is directly connected, Serial0/0