You are on page 1of 19

ALGORITMOS.

JESUS DANIEL PACHECO ARROYO.




TUTOR:
ELEUCY FUENTES.


UNIVERSIDAD DE CORDOBA
(SEDE SAHAGUN)


SAHAGUN - CORDOBA


11 DE SEPTIEMBRE DE 2012



INTRODUCCION.

Con la realizacin del siguiente trabajo busco aprender a realizar un buen anlisis
de un algoritmo sencillo que pasan en la vida cotidiana de una persona. De igual
manera tambin busco aprender a elaborar los pseudocdigos de cualquier
algoritmo.
De la misma forma con esta prctica tambin busco formarme como un ingeniero
de sistemas capaz de generar buenos pseudocdigos de algoritmos, que sepa
programarlos y que de alguna forma den solucin a un problema,


















OBJETIVOS.

OBJETIVOS GENERALES:
Aprender a hacer un buen anlisis de un algoritmo y generar un
pseudocdigo para este.

OBJETIVOS ESPECFICOS:
Diferenciar entre una constante y una variable en el anlisis de un
algoritmo.
Implementar un algoritmo en el programa PSeInt.
Darle una solucin a un problema o algoritmo cada vez que se le presente
Saber cules son los operadores aritmticos y los operadores relacionales.
Aprender a implementar el operador indicado a la hora de realizar un
anlisis de un algoritmo.














ACTIVIDAD

ALGORITMOS PROPUESTOS.
1. Conociendo el valor de la entrada al cine, calcule el valor a pagar para una
delegacin de 10 personas, sabiendo que debe hacer un descuento del 10%
del total a pagar por la delegacin.
2. Realizar un algoritmo que dado el ao de nacimiento de una persona, calcule y
muestre su edad.
3. Desarrolle un algoritmo que permita leer dos nmeros distintos, determinar cul
de los dos nmeros es el mayor y escribirlo; tambin debe tener en cuenta que
si los valores son iguales debe mostrar el mensaje indicando que los dos son
iguales.
4. Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si
dicho nmero es positivo, negativo o nulo.
5. Elaborar un algoritmo para un supermercado, que dado el nombre de un cliente
y el valor de tres compras realizadas, calcule y muestre en pantalla el nombre
del cliente, su venta total y si esta es inferior a $50.000, muestre un mensaje
que diga No Participa en la Rifa, si est entre $50.000 y $100.000 el mensaje
debe ser Reclame 2 boletas y si su compra es de $100.000 en adelante, el
mensaje debe decir Reclame 4 boletas.
6. Dado el salario de un empleado, calcular y mostrar en pantalla el valor de una
bonificacin, el valor de un subsidio y el total a recibir, teniendo en cuenta que
si gana ms de $3.000.000, la bonificacin ser del 5% de su salario y no
recibir subsidio, en caso contrario, la bonificacin ser del 3% de su salario y
el subsidio del 5%.
7. Elabore un algoritmo para un expendio de pollo, que dados el nmero kilos
comprados y el valor de cada kilo de pollo, calcule el total a pagar, teniendo en
cuenta que si son ms de 30 kilos, el valor de cada kilo disminuye en $1.000.
Mostrar en pantalla el nmero de Kilos de pollo comprados, el valor de cada
kilo y el Total a pagar.



ALGORITMOS IDEADOS:
1. Elaborar un algoritmo que dadas la base y la altura de un tringulo, calcule y
muestre en pantalla su rea.
2. Calcular y mostrar en pantalla la nota definitiva de un estudiante, teniendo en
cuenta lo siguiente:
la primera nota vale 30%
la segunda nota vale 30%
la tercera nota vale 40%
3. En un almacn se realizan descuentos de la siguiente manera, si la compra es
inferior a $100000 no hay descuento, si la compra esta entre $100000 y $200000
el descuento ser del 20% y si la compra supera los $200000 el descuento ser
del 30%.

ENUNCIADO, ANALISIS Y PSEUDOCODIGO DE CADA ALGORITMO
ENUNCIADO: Conociendo el valor de la entrada al cine, calcule el valor a pagar
para una delegacin de 10 personas, sabiendo que debe hacer un descuento del
10% del total a pagar por la delegacin.
ANALISIS (DESCRIPCION DE VARIABLES):
ENTRADA:
vec: variable de tipo entero que representa el valor de la entrada a cine.
PROCESO:
const: variable que representa el nmero de personas de la delegacin.
tot: variable de tipo entero que almacena el total pagado por la delegacin.
des: variable de tipo entero que almacena el descuento del 10%.
SALIDA:
Mostrar en pantalla el valor total que debe pagar la delegacin.
PSEUDOCODIGO:
Inicio
Variables: vec, const, tot, des: entero
Escribir "PROGRAMA PARA CALCULAR EL VALOR TOTAL DE LA ENTRADA A
CINE"
Escribir " <DELEGACION DE 10 PERSONAS>"
Escribir "Digite el valor de la entrada a cine: ";
Leer vec;
const<-10;
des<-(const*vec)*0.1;
tot<-(vec*const)-des;
Escribir "El valor total a pagar es: ", tot, " pesos ";
Fin

ENUNCIADO: Realizar un algoritmo que dado el ao de nacimiento de una
persona, calcule y muestre su edad.
ANALISIS (DESCRIPCION DE VARIABLES)
ENTRADA:
Anac: variable de tipo entero que representa el ao de nacimiento de la
persona.
Aact: variable de tipo entero que representa el ao actual.
PROCESO:
Edad: variable de tipo entero que almacena la edad de la persona
SALIDA:
Mostrar la edad actual de la persona.
PSEUDOCODIGO:
Inicio
Variables: Anac, Aact, Edad: entero
Escribir "<PROGRAMA PARA CALCULAR LA EDAD DE UNA PERSONA>";
Escribir "Digite su ao de nacimiento";
Leer Anac;
Escribir "Digite el ao actual";
Leer Aact;
Edad<-(Aact-Anac)
Escribir "Su edad actual es: ", Edad, " Aos";
Fin
ENUNCIADO: Desarrolle un algoritmo que permita leer dos nmeros distintos,
determinar cul de los dos nmeros es el mayor y escribirlo; tambin debe tener
en cuenta que si los valores son iguales debe mostrar el mensaje indicando que
los dos son iguales.

ANALISIS (DESCRIPCION DE VARIABLES)

ENTRADA:

num1: variable de tipo real que representa el primer nmero.
num2: variable de tipo real que representa el segundo nmero.

PROCESO:
M: variable de tipo real que almacena el nmero mayor cuando num1>num2.
K: variable de tipo real que almacena el nmero mayor cuando num1<num2.
I: variable de tipo real que almacena la igualdad cuando num1=num2
SALIDA:
Mostar en pantalla cul de los dos nmeros es el mayor, si los dos son iguales
entonces mostrar un mensaje indicando que ambos nmeros son iguales.
PSEUDOCODIGO:
Inicio
Variable: num1, num2, M, K, I: real
Escribir " <PROGRAMA PARA DETERMINAR NUMERO MAYOR>";
Escribir "Digite primer nmero";
Leer num1;
Escribir "Digite segundo numero";
Leer num2;
M<- (num1>num2)
Si M Entonces
Escribir "El nmero mayor es: ", num1;
FinSi
K<- (num1<num2)
Si K Entonces
Escribir "El nmero mayor es: ", num2;
FinSi
I<- (num1=num2)
Si I Entonces
Escribir "Ambos nmeros son iguales...";
FinSi
Fin

ENUNCIADO: Desarrolle un algoritmo que permita leer un valor cualquiera N y
escriba si dicho nmero es positivo, negativo o nulo.

ANALISIS (DESCRIPCION DE VARIABLES)

ENTRADA:

v: variable de tipo real que representa un nmero cualquiera.

PROCESO:

N: variable de tipo real que almacena el nmero nulo.
P: variable de tipo real que almacena el nmero positivo.
Ne: variable de tipo real que almacena el nmero negativo.

SALIDA:
Mostrar en pantalla si el nmero es nulo, positivo o negativo.

PSEUDOCODIGO:

Inicio
Variables: v, N, P, Ne: real
Escribir " <PROGRAMA PARA DETERMINAR NUMERO>";
Escribir " <positivo-negativo-nulo>"
Escribir "Digite un nmero";
Leer v;
N<-v=0
Si N Entonces
Escribir "El nmero es nulo";
FinSi
P<-v>0
Si P Entonces
Escribir "El nmero es positivo";
FinSi
Ne<-v<0
Si Ne Entonces
Escribir "El nmero es negativo";
FinSi

Fin

ENUNCIADO: Elaborar un algoritmo para un supermercado, que dado el nombre
de un cliente y el valor de tres compras realizadas, calcule y muestre en pantalla
el nombre del cliente, su venta total y si esta es inferior a $50.000, muestre un
mensaje que diga No Participa en la Rifa, si est entre $50.000 y $100.000 el
mensaje debe ser Reclame 2 boletas y si su compra es de $100.000 en
adelante, el mensaje debe decir Reclame 4 boletas.

ANALISIS (DESCRIPCION DE VARIABLES)
ENTRADA:
Nper: variable que representa el nombre del cliente
Comp1: variable de tipo entero que representa el valor de la compra 1.
Comp2: variable de tipo entero que representa el valor de la compra 2.
Comp3: variable de tipo entero que representa el valor de la compra 3.
PROCESO:
comptot: variable de tipo entero que almacena el valor total de la venta.
SALIDA:
Mostrar en pantalla el nombre del cliente, el valor total de la venta, si ese
valor es inferior a $50000 muestra un mensaje que dice no participa en la
rifa, si ese valor esta entre $50000 y $100000 muestra un mensaje que dice
reclame 2 boletas y si ese valor es de $100000 en adelante muestra un
mensaje que dice reclame 4 boletas.
PSEUDOCODIGO:
Inicio
Variables: Nper, comp1, comp2, comp3, comptot: entero
Escribir " <PROGRAMA PARA SUPERMERCADO>";
Escribir "Nombre de la persona";
Leer Nper;
Escribir "Digite el valor de la primera compra";
Leer comp1;
Escribir "Digite el valor de la segunda compra";
Leer comp2;
Escribir "Digite el valor de la tercera compra";
Leer comp3;
Comptot <-(comp1+comp2+comp3);
Escribir "El nombre del cliente es: ", Nper;
Escribir "Compra total: ", comptot, " pesos";
Si comptot<50000 Entonces
Escribir "No participa en la rifa";
FinSi
Si (comptot>=50000 & comptot<=100000) Entonces
Escribir "Reclame 2 boletas";
FinSi
Si comptot>100000 Entonces
Escribir "Reclame 4 boletas";
FinSi
Fin

ENUNCIADO: Dado el salario de un empleado, calcular y mostrar en pantalla el
valor de una bonificacin, el valor de un subsidio y el total a recibir, teniendo en
cuenta que si gana ms de $3.000.000, la bonificacin ser del 5% de su salario y
no recibir subsidio, en caso contrario, la bonificacin ser del 3% de su salario y
el subsidio del 5%.
ANALISIS (DESCRIPCION DE VARIABLES)
ENTRADA:
Sal: variable de tipo entero que representa el salario de una persona.
PROCESO:
Bon1: variable de tipo real que almacena el 5% de la bonificacin de la persona.
Bon2: variable de tipo real que almacena el 3% de bonificacin de una persona.
Sub: variable de tipo entero que almacena el 5% del subsidio de una persona.
Sal1: variable de tipo real que almacena el total del salario ms la bonificacin del
50% de la persona.
Sal2: variable de tipo real que almacena el total del salario ms la bonificacin del
30% y ms el 50% del subsidio de esa persona.
SALIDA:
Mostrar en pantalla el total del salario, la bonificacin y el subsidio que va a recibir
la persona.
PSEUDOCODIGO:
Inicio
Variables: Sal, Bon1, Bon2, Sub, Sal1, Sal2: real
Escribir " <PROGRAMA PARA CALCULAR SALARIO>";
Escribir "Digite salario";
Leer Sal;
Bon1<-(Sal*0.05);
Bon2<-(Sal*0.03);
Sub<-(Sal*0.05);
Si Sal>3000000 Entonces
Sal1<-(Sal+bon1);
Escribir "su bonificacin es: ", Bon1, " pesos";
Escribir "su salario ms la bonificacin es: ", Sal1, " pesos";
FinSi
Si Sal<3000000 Entonces
Sal2<-(Sal+Bon2+Sub);
Escribir "su bonificacin es: ", Bon2, " pesos";
Escribir "su subsidio es: ", Sub, " pesos";
Escribir "su salario ms la bonificacin mas el subsidio es: ", Sal2, " pesos";
FinSi
Fin

ENUNCIADO: Elabore un algoritmo para un expendio de pollo, que dados el
nmero kilos comprados y el valor de cada kilo de pollo, calcule el total a pagar,
teniendo en cuenta que si son ms de 30 kilos, el valor de cada kilo disminuye en
$1.000. Mostrar en pantalla el nmero de Kilos de pollo comprados, el valor de
cada kilo y el Total a pagar.

ANALISIS (DESCRIPCION DE VARIABLES)

ENTRADA:

Ckpc: variable de tipo real que representa la cantidad de kilos de pollos
comprados.
Pkp: precio de cada kilo de pollo.

PROCESO:

Totalpag: variable de tipo entero que almacena el resultado de Ckpc*pkp.
Tot: variable de tipo entero que almacena el resultado de pkp*Ckpc.
Tot1: variable de tipo entero que almacena el resultado de pkp*Ckpc.
Tot2: variable de tipo entero que almacena el resultado de (ckpc-30)*(pkp-1000).
Total: variable de tipo entero que almacena el resultado de tot1-tot2.

SALIDA:
Mostrar en pantalla el nmero de Kilos de pollo comprados, el valor de cada kilo
y el Total a pagar.

PSEUDOCDIGO:

Inicio
Variables: Ckpc, Pkp, Totalpag, Tot, Tot1, Tot2, Total: real
Escribir " <PROGRAMA PARA EXPENDIO DE POLLO>";

Escribir "Digite la cantidad de kilos de pollo comprados";
Leer Ckpc;
Escribir "Digite el precio del kilo de pollo";
Leer Pkp;
Totalpag<-(Ckpc*Pkp);

Si Ckpc<=30 Entonces
Tot<-(Pkp*Ckpc)
Escribir "numero de kilos de pollo comprados: ", Ckpc;
Escribir "valor de cada kilo de pollo: ", Pkp;
Escribir "Cantidad de kilos de pollos menor a 30 kilos usted debe pagar: ",
Tot," pesos";
Sino
Si Ckpc>30 Entonces
Tot1<-(Ckpc*Pkp)
Tot2<-(Ckpc-30)*(Pkp-1000)
Total<-(Tot1-Tot2)
Escribir "numero de kilos de pollo comprados: ", Ckpc," kilos";
Escribir "valor de cada kilo de pollo: Pkp, " pesos";
Escribir "Total a pagar:", Total," pesos";
FinSi
FinSi

Fin


ENUNCIADO: Elaborar un algoritmo que dadas la base y la altura de un tringulo,
calcule y muestre en pantalla su rea.
ANALISIS (DESCRIPCION DE VARIABLES)
ENTRADA:
B: variable de tipo real que representa la base del tringulo.
H: variable de tipo real que representa la altura del tringulo.
PROCESO:
A: variable de tipo real que almacena el rea del tringulo.
SALIDA:
Mostrar en pantalla el rea del tringulo.
PSEUDOCODIGO:
Inicio
Variables: B, H, A: real
Escribir Digite la base del tringulo;
Leer B;
Escribir Digite la altura del tringulo;
Leer H;
A< (B*H) / 2
Escribir El rea del tringulo es:, A;
Fin

ENUNCIADO: Calcular y mostrar en pantalla la nota definitiva de un estudiante,
teniendo en cuenta lo siguiente:
la primera nota vale 30%
la segunda nota vale 30%
la tercera nota vale 40%
ANALISIS (DESCRIPCION DE VARIABLES)
ENTRADA:
N1: variable de tipo real que representa la primera nota.
N2: variable de tipo real que representa la segunda nota.
N3: variable de tipo real que representa la tercera nota.
PROCESO:
N1p: variable de tipo real que almacena el resultado de N1p.
N2p: variable de tipo real que almacena el resultado de N2p.
N3p: variable de tipo real que almacena el resultado de N3p.
Def: variable de tipo real que almacena el resultado total de N1p+N2p+N3p
SALIDA:
Mostrar en pantalla la nota definitiva del estudiante.
PSEUDOCODIGO:
Inicio
Variables: N1, N2, N3, N1p, N2p, N3p, Def: real
Escribir "digite la primera nota";
Leer N1;
Escribir "digite la segunda nota";
Leer N2;
Escribir "digite la tercera nota";
Leer N3;
N1p<- N1*0.30
N2p<- N2*0.30
N3p<- N3*0.40
Def<- N1p+N2p+N3p
Escribir "Su nota definitiva es:", Def;
Fin

ENUNCIADO: En un almacn se realizan descuentos de la siguiente manera, si la
compra es inferior a $100000 no hay descuento, si la compra esta entre $100000 y
$200000 el descuento ser del 20% y si la compra supera los $200000 el
descuento ser del 30%.
ANALISIS (DESCRIPCION DE VARIABLES)
ENTRADA:
compra: variable de tipo entero que representa el valor de la compra.
PROCESO:
C1: variable de tipo entero que almacena el valor de la compra cuando es menor a
100000 pesos.
C2: variable de tipo entero que almacena el valor de la compra cuando esta entre
100000 y 200000 pesos.
C3: variable de tipo entero que almacena el valor de la compra cuando es mayor a
200000 pesos.
SALIDA:
Mostrar en pantalla el valor total de la compra, si la compra es inferior a $100000
muestra un mensaje que dice no hay descuento, si la compra esta entre $100000
y $200000 muestra un mensaje que dice el descuento ser del 20% y si la compra
supera los $200000 muestra un mensaje que dice el descuento ser del 30%.
PSEUDOCODIGO:
Inicio
Variables: compra, C1, C2, C3: entero
Escribir " PROGRAMA PARA ALMACEN";
Escribir "por favor digite el valor de su compra";
Leer compra;
C1<- compra<100000
Si C1 Entonces
Escribir "su compra es menor a 100.000 pesos no recibir descuento";
FinSi
C2<- compra>100000 & compra<200000
Si C2 Entonces
Escribir "su compra esta entre 100.000 y 200.000 pesos recibir un descuento
del 20%";
FinSi
C3<- compra>200000
Si C3 Entonces
Escribir "su compra es mayor a 200.000 pesos recibir un descuento del 30%";
FinSi
Fin
CONCLUSION
Gracias a la realizacin del anterior trabajo aprend a analizar un algoritmo, as
como tambin a producir un pseudocdigo para este.

Tambin gracias a este trabajo aprend a implementar el programa PSeInt, el cual
ser muy til para mi carrera como estudiante de ingeniera de sistemas.