Sie sind auf Seite 1von 6

Teil 3

EXCEL
GRUNDLAGEN






GINF EXCEL: bungen 3 Seite: 1

Autor: Mag. Dieter Lehner, HTBLA Wels (c) Mai 2014
6. Die logischen Funktionen
EXCEL bietet ein Reihe von logischen Funktionen wie etwa die UND-Funktion mit der
Syntax: =UND(Wahrheitswert1; Wahrheistwert2; . . .)
Die UND-Funktion liefert, wenn alle Bedingungen erfllt sind, das Ergebnis WAHR
bzw. wenn zumindest eine Bedingung nicht erfllt ist den Wert FALSCH.
Die logische Funktion ODER mit der
Syntax: =ODER(Wahrheitswert1; Wahrheistwert2; . . .)
liefert das Ergebnis WAHR, wenn zumindest eine Bedingung erfllt ist, oder FALSCH,
wenn keine Bedingung erfllt ist.
Fr die folgenden 4 Beispiele gelten die folgenden Anforderungen:
Jedes Beispiel ist auf einem getrennten Tabellenblatt der Mappe darzustellen
Jedes Tabellenblatt erhlt einen sinnvollen Namen
Die Mappe erhlt den Namen Logik.xlsx
Fr die Zahlenformatierung ist jeweils eine sinnvolle Variante zu whlen
Formatiere die Tabelle mit Gitternetzlinien, Hintergrundfarbe fr
die berschrift und die Spaltenberschriften.
Beispiel1:
1) Erstelle zunchst die im Folgenden dargestellte Tabelle.

2) In der Spalte Gemischt? soll WAHR stehen, wenn es auf der Farm Rinder und
Schafe gibt.
Beispiel2:
1) Erstelle zunchst die im Folgenden dargestellte Tabelle.

2) In der Spalte Beihilfe soll WAHR stehen, wenn die Familie mehr als 3 Kinder
oder weniger als 15.000,-- Einkommen hat.

EXCEL bietet auch eine Reihe von Mglichkeiten Untersuchungen unter dem Gesichts-
punkt WAS WRE WENN anzustellen. Fr die meisten Berechnungen dieser Art ist in
EXCEL die LOGISCHE FUNKTION Wenn geeignet.
Syntax: =WENN(Bedingung;Dann-Wert;Sonst-Wert)

GINF EXCEL: bungen 3 Seite: 2

Autor: Mag. Dieter Lehner, HTBLA Wels (c) Mai 2014

Beispiel3:
1) Erstelle zunchst die im Folgenden dargestellte Tabelle.

2) In der Spalte Verkehrsverhalten soll Raser stehen, wenn das Tempo
hher als 70 km/h ist, sonst vorbildlich.
Beispiel4:
1) Erstelle zunchst die im Folgenden dargestellte Tabelle.

2) In der Spalte Bauvorhaben soll der Wert Schule stehen, wenn in dem jeweiligen
Ort ein Bevlkerungswachstum vorliegt und die Einwohnerzahl mehr als 100.000
betrgt. Andernfalls soll die Zelle leer bleiben.

Speichere die Mappe. schliee sie und ffne eine neue leere Mappe.

EXCEL bietet neben der WENN-Funktion eine Reihe weiterer Mglichkeiten Untersuchun-
gen unter dem Gesichtspunkt WAS WRE WENN anzustellen.
Im folgenden Beispiel soll das monatliche Gehalt eines Vertreters abgerechnet werden: als
Grundlage dient die folgende Vereinbarung:
Das Gehalt setzt sich zusammen aus einem Fixum von 2.300,- und bei berschreiten
von gewissen Umsatzgrenzen einer prozentuellen Beteiligung des Mehrumsatzes.
Umsatz ber 50.000,- 2,00% Provision
Fr solche Berechnungen ist in EXCEL die LOGISCHE FUNKTION Wenn geeignet.
Syntax: =WENN(Bedingung;Dann-Wert;Sonst-Wert)

Zunchst werden die Daten eingegeben:

GINF EXCEL: bungen 3 Seite: 3

Autor: Mag. Dieter Lehner, HTBLA Wels (c) Mai 2014

und die interessanten Zellen mit sprechenden Namen belegt:
Geben sie den angegebenen Zellen die folgenden Namen:
B8 Umsatz, B9 Grenze, B10 Prozent, D7 Fixum, E7 Prmie,
F7 Gehalt
Dann-Wert und Sonst-Wert knnen Texte sein, aber auch Berechnungen. Fr die Prob-
lemlsung ist es ntig die berlegung ordentlich zu formulieren:
Fr unsere Aufgabe: wenn die Bedingung Umsatz>50.000,- erfllt ist,
dann Prmie=(Umsatz-50000)*Prozent
sonst Prmie=0
In der obigen Abbildung ist zu erkennen, wie die Prmie mittels WENN-Funktion zu be-
rechnen ist.
Speichere das Ergebnis unter dem Namen: Provision1.xls
Das Abrechnungsmodell soll nun erweitert werden und zwar dahingehend, dass bei einem
Umsatz grer als 70.000,- ein Prozentsatz von 3,5 % (auf den Mehrumsatz ber
50.000,-) zur Anwendung kommt.
Dazu speichert man die aktuelle Mappe (mit Datei speichern unter) unter dem Namen:
Provision2.xls
Zunchst ist die Anordnung der einzelnen Zahlenwerte ungnstig und man baut die Tabel-
le um. Die Zellen erhalten wiederum geeignete Namen (Grenze1, Grenze2, Prozent1 ..)
Die Lsung unseres Problems lsst sich mit einer geschachtelten WENN-Funktion erzeu-
gen:
wenn die Bedingung Umsatz>70.000,- (Grenze2) erfllt ist,
dann Prmie=(Umsatz-50.000,- (Grenze1))*Prozent2
sonst
wenn die Bedingung Umsatz>50.000,- erfllt ist,
dann Prmie=(Umsatz-50.000,- (Grenze1))*Prozent1
sonst Prmie=0

7. Die SVERWEIS-Funktion (B7)
Nun knnte jemand auf die Idee kommen noch mehr Stufen einzufhren. Dann wird die
Verwendung der WENN-Funktion allerdings recht unhandlich. EXCEL bietet dazu die
Verweisfunktion SVERWEIS mit der Syntax:
SVERSWEIS(Suchzelle; Bereich_in_dem_gesucht_wird; Spaltennummer_Rckgabe)


GINF EXCEL: bungen 3 Seite: 4

Autor: Mag. Dieter Lehner, HTBLA Wels (c) Mai 2014

Beginnend mit 50.000,- wird eine Provision in Hhe von 2,0 % angenommen. In Stufen
von 20.000,- wird der Prozentsatz um jeweils 0,3 % angehoben. Als maximale Stufe wird
190.000,- angenommen.
Das Gehalt setzt sich zusammen aus einem Fixum von 2.300,- und - bei berschreiten
der angegebenen Umsatzgrenzen - einer prozentuellen Beteiligung des Umsatzes ber
50.000,-.
Vorgangsweise:
1) Zunchst werden die Daten
(wie nebenstehend) einge-
geben
2) Die Tabelle erhlt den Na-
men: Gehalt
3) Die entsprechenden Gren-
zen mit den jeweiligen da-
zugehrenden Prozentst-
zen werden in eine eigene
Tabelle (Name: Grenzen)
eingetragen.
Dazu verwendet man geschickter Weise das Autoausfllen
4) Der Zellbereich A2:B9 wird mit dem Namen: Grenzen belegt
und wird dadurch zu einem ABSOLUTEN BEREICH!!
5) Das Entstehen der Formel in der Zelle D8 wird nun genau beschrieben:
schreibe: =sverweis(
klicke auf die Zelle C8
schreibe: ;
wechsle auf die Tabelle Grenzen und markiere den Bereich A2:B9 (=Grenzen)
schreibe: ;
schreibe: 2)
damit wird angegeben, dass der zurckzugebende Wert in der Spalte 2 des Such-
bereiches zu finden ist
die Zellen D9 bis D12 werden dann mit Autoausfllen gefllt

Das Ergebnis sollte dann wir folgt aussehen:

6) Die Zelle C5 erhlt nun den Namen Fixum


GINF EXCEL: bungen 3 Seite: 5

Autor: Mag. Dieter Lehner, HTBLA Wels (c) Mai 2014

7) Provision, Gehalt und die jeweiligen Summen werden berechnet

Die aktuelle Mappe speichert man die unter dem Namen: Gehalt.xls