Sie sind auf Seite 1von 60

ROUTER RIP

(Project Report)

Made by: Manoj Kumar


CS-4287

CERTIFICATE

This is to certify that project that dissertation/project report entitled Router RIP done by Manoj
Kumar is an authentic work carried out by him at CMC Limited under my guidance. The matter
inputted in this project work has not been submitted earlier for the award of any degree to best
of my knowledge and belief.

Date:
H.O.D Name:

UNDER GUIUDANCE

HCL CAREER DEVELOPMENT CENTRE


PATHANKOT

CISCO CERTIFIED NETWORK ASOCIATE


SUMMER TRAINING REPORT

SUBMITTED IN PARTIAL FULFILLMENT OF


THE REQUIREMENT FOR THE AWARD OF THE DEGREE OF
BACHELOR OF TECHNOLOGY
IN COMPUTER SCIENCE ENGINEERING
OF HIMACHAL PRADESH TECHNICAL UNIVERSITY

HAMIRPUR
BY

Manoj Kumar (CS-4287)

SHAHPUR, KANGRA (H.P.)


4

Introduction to the
Trainee
Student name

College name

Manoj Kumar

HIET Shahpur

Roll no

Semester

Branch

CS-4287

5th

Training period

From: 23rd June, 2013

To: 3rd August, 2013

CSE

Preface

Vocational training plays a very important role in the engineering course of the student because
this helps him/her in gaining tremendous knowledge & experience as he /she can learn about the
bundle of things which cant be learn in campus, so these Vocational training schedules are
added in the course by various universities. The duration of our training is 6 weeks after 4th
semester.

Manoj Kumar

ACKNOWLEDGEMENT

ENTRANCE Hard work Gradual progress and second year. Thats how I have reached this
level and now I stand at the two years which I have spent in this college.
Training is agglomeration of the theoretical and practical and technical concepts, which enhances
our skills in the field of technology.
No academic endeavor can be single handedly accomplished our sincere gratitude is the staff of
HCL CDC for their kind assistance and provision of our training.
We sincerely acknowledge our thanks to the teachers for their guidance and motivation
throughout the training and project work.
We would also like to record our gratitude to Mr. Varider for giving us a chance for a successful
training here.
Last, but not the least, I would like to thanks all our companions for their help which was in
abundance

Manoj Sharma

TABLE OF CONTENTS
CONTENTS
Introduction .
1.1 History
1.2
Courses
Literature Review
2.1
Networking Essentials
2.2
Network Architecture
2.3
Networking Topology
2.4
Networking Hardware
3. CISCO Certified Network Associate..
3.1 Router
3.2 Lan card
3.3 OSI Model
3.4 Router Configuration
3.5 IP Routing
3.6 LAN Switching
3.7 Access Control List
4. Project Methodology.......
4.1 Router 1
4.2 Router 2
4.3 Router 3
5.Result and Conclusion..
Result
Project Review

Introduction to Organization

HCL Info Systems Limited

HCL Infosystems Ltd., a listed subsidiary of HCL, is an India-based hardware and systems
integrator. It has a presence in 170 locations and 300 service centres throughout India. Its
manufacturing facilities are based in Chennai, Pondicherry and Uttarakhand. It is headquartered
at Noida.
History
With its origins in 1976, HCL Infosystems Ltd is one of the pioneers in the Indian IT market.
HCL Peripherals (a unit of HCL Infosystems Ltd.), founded in the year 1983, is a manufacturer
of computer peripherals in India of Display Products, Thin Client solutions, Information and
Interactive Kiosks and a range of Networking products & Solutions. HCL Peripherals has two
Manufacturing facilities, one in Pondicherry (Electronics) and the other in Chennai
(Mechanical). The company has been given ISO: 27001 certifications.
HCL ERC (Enterprise Response Center) was started to give outstanding support to its customers,
at Pondicherry, in 2007. It has grown and team of domain experts working in it.
The company operates under three primary segments namely Computer Systems and related
products and services, Telecommunication & Office Automation and Internet and related
services.

Computer Systems and related products and services

Telecommunication & Office Automation

Internet and Related Services

HCL Infosystems is ranked #1 in IDC-Dataquest Customer Satisfaction Survey 2011, third year
in a row. DQ-IDC ranks the company #2 Domestic ICT company. It has been selected as
Business Super brands of India by the Super Brands Council. The company has been awarded

with the CMMI (Capability Maturity Model Integration) Maturity Level 5 certification for its
Jaipur Development centre in 2011.
The 35 year old enterprise, founded in 1976, is one of India's original IT garage start ups. Its
range of offerings span R&D and Technology Services, Enterprise and Applications Consulting,
Remote Infrastructure Management, BPO services, IT Hardware, Systems Integration and
Distribution of Technology and Telecom products in India. The HCL team comprises 88,000
professionals of diverse nationalities, operating across 31 countries including 500 points of
presence in India. HCL has global partnerships with several leading Fortune 1000 firms,
including several IT and Technology majors.
Courses

Fig 1.1 Courses offered at HCL

Networking courses
HCE (HCL CERTIFIED ENTERPRISE ENGINEER)
In Today is IT scenario, there is a huge requirement of IT professionals with a firm grasp of
Hardware and Networking Concepts. With the role of an IT professional not restricted to one
10

technology alone, the industry requires one to have all-round knowledge of computer hardware
& networking concepts and technologies. The average salaries of such network professionals
which have done a complete course range to more than $90,000 per annum. The course is a great
value addition to the candidates who have completed their graduation in Applied Sciences and
Engineering, and IT field.
Taking into consideration the Industry requirements HCL has come up with an Industry Ready
Course known as HCEE (known as HCE+). The various course contents areCourse Contents & Unique Features
i.

Basic Hardware and Server Technology.

ii.

Advanced Networking and Security.

iii.

System Engineering on Microsoft Technologies.

iv.

Networking Technology & Devices.

v.

Linux Administration & Security

vi.

Service Desk Institute.


Advanced Storage Technology.

vii.

HCNE (NETWORK ENGINEER)


With roles of an IT professionals not just constrained to one technology only, Industry demands
people to have al-round knowledge of Computer Hardware and Networking Concepts ranging to
various Technologies. The average salaries of such network professionals which have done a
complete

course

range

to

more

than

$90,000

per

annum.

The course creates great job prospects for the candidates who have a keen inclination towards
making their career in managing IT Infrastructure along with their graduation such that when
they complete the course with graduation they are industry ready and the most sought after
professionals.
Course Contents & Unique Features
Taking into consideration the Industry requirements HCL has come up with an Industry Ready
Course known as HCE plus. The various course contents are:
i.

Basic Hardware and Server Technology

ii.

Advanced Networking and Security

iii.

System Engineering on Microsoft Technologies

iv.

Networking Technology & Devices


11

v.

Linux Administration & Security

vi.

Notebook Technology.

vii.

Wireless Network Administration.

HCSA (SYSTEM ADMINISTRATOR)


With the role of an IT professional not restricted to one technology alone, the industry requires
one to have all-round knowledge of computer hardware & networking concepts and technologies
The average salaries of such network professionals which have done a complete course range to
more than $90,000 per annum. The course creates great job prospects for the candidates who
have a keen inclination towards making their career in managing IT Infrastructure along with
their graduation such that when they complete the course with graduation they are industry ready
and the most sought after professionals.
HCSP (SYSTEM PROFESSIONAL)
With the role of an IT professional not restricted to one technology alone, the industry requires
one to have all-round knowledge of computer hardware & networking concepts and
technologies. The average salaries of such network professionals which have done a complete
course range to more than $90,000 per annum. The course creates great job prospects for the
candidates who have a keen inclination towards making their career in managing IT
Infrastructure along with their graduation such that when they complete the course with
graduation they are industry ready and the most sought after professionals.

12

Fig 1.2 HCL- A Snapshot

13

Literature Review
Network Essentials
1. Networking
Networking is the concept of sharing resources and services. A network of computers is a
group of interconnected systems sharing resources and interacting using a shared
communications link. A network, therefore, is a set of interconnected systems with
something to share. The shared resource can be data, a printer, a fax modem, or a service
such as a database or an email system. The individual systems must be connected through
a pathway (called the transmission medium) that is used to transmit the resource or
service between the computers. All systems on the pathway must follow a set of common
communication rules for data to arrive at its intended destination and for the sending and
receiving systems to understand each other. The rules governing computer
communication are called protocols. All networks must have the following:
i.

A resource to share (resource)

ii.

A pathway to transfer data (transmission medium)

iii.

A set of rules governing how to communicate (protocols)

The two main reasons for using computer networking are to provide services and to
reduce equipment costs. The following are specific reasons for networking PCs:
i.

Sharing files

ii.

Sharing printers and other devices

iii.

Enabling centralized administration and security of the resources within the


system

iv.

Supporting network applications such as electronic mail and database services.

Networks come in all shapes and sizes. Network administrators often classify networks
according to geographical size. The following are the most common size classifications:

Local Area Networks (LANs)


A local area network (LAN) is a group of computers and network communication
devices interconnected within a geographically limited area, such as a building or
a campus. LANs are characterized by the following:

They transfer data at high speeds (higher bandwidth).


14

They exist in a limited geographical area.

Connectivity and resources, especially the transmission media, usually are


managed by the company running the LAN.

Wide Area Networks (WANs)


A wide area network (WAN) interconnects LANs. A WAN can be located entirely
within a state or a country, or it can be interconnected around the world. WANs
are characterized by the following:

They exist in an unlimited geographical area.

They usually interconnect multiple LANs.

They often transfer data at lower speeds (lower bandwidth).

Connectivity and resources, especially the transmission media, usually are


managed by a third-party carrier such as a telephone or cable company.

Fig 2.1 LAN with WAN

Intranet
An intranet is basically a network that is local to a company. In other words, users
from within this company can find all of their resources without having to go
outside of the company. An intranet can include LANs, private WANs and
MANs.

15

Extranet
An extranet is an extended intranet, where certain internal services are made
available to known external users or external business partners at remote
locations.

Internet
An internet is

used

when

unknown

external

users

need

to

access

internal resources in your network. In other words, your company might have a
web site that sells various products, and you want any external user to be able to
access this service.
2) Network Architecture
The network architecture basically consists of the way the devices are connected to each
other in a network. It is mainly of two typesi.

Peer to Peer Model


Peer-to-peer (P2P) refers to a computer network in which each computer in the
network can act as a client or server for the other computers in the network,
allowing shared access to files and peripherals without the need for a central
server. P2P networks can be set up in the home, a business or over the Internet.
Each network type requires all computers in the network to use the same or a
compatible program to connect to each other and access files and other resources
found on the other computer. P2P networks can be used for sharing content such
as audio, video, data or anything in digital format.

ii.

Client Server Model


The client/server

model is

a computing model

that

acts

as distributed

application which partitions tasks or workloads between the providers of a


resource or service, called servers, and service requesters, called clients. Often
clients and servers communicate over a computer network on separate hardware,
but both client and server may reside in the same system. A server machine is a
host that is running one or more server programs which share their resources with
clients. A client does not share any of its resources, but requests a server's content
or service function. Clients therefore initiate communication sessions with servers
which await incoming requests.
16

Functions such as email exchange, web access and database access are built on
the client/server model. Many business applications being written today use the
clientserver model, as do the Internet's main application protocols, such
as HTTP, SMTP, Telnet, and DNS.

Fig 2.2 Peer to Peer and Client Server Model

3) Network Topology
Network topology is the layout pattern of interconnections of the various elements
(links, nodes, etc.) of a computer or biological network. Network topologies may be
physical or logical. Physical topology refers to the physical design of a network
including the devices, location and cable installation. Logical topology refers to how data
is actually transferred in a network as opposed to its physical design.
A local area network (LAN) is one example of a network that exhibits both a physical
topology and a logical topology. There are two basic categories of network topologies:
a) Physical topologies- The shape of the cabling layout used to link devices is called
the physical topology of the network. This refers to the layout of cabling, the
locations of nodes, and the interconnections between the nodes and the cabling.
The physical topology of a network is determined by the capabilities of the

17

network access devices and media, the level of control or fault tolerance desired,
and the cost associated with cabling or telecommunications circuits.
The basic Physical Topologies are

Bus Topology
In local area networks where bus topology is used, each node is connected
to a single cable. Each computer or server is connected to the single bus
cable. A signal from the source travels in both directions to all machines
connected on the bus cable until it finds the intended recipient. If the
machine address does not match the intended address for the data, the
machine ignores the data. Alternatively, if the data matches the machine
address, the data is accepted. Since the bus topology consists of only one
wire, it is rather inexpensive to implement when compared to other
topologies. However, the low cost of implementing the technology is
offset by the high cost of managing the network. Additionally, since only
one cable is utilized, it can be the single point of failure. If the network
cable is terminated on both ends and when without termination data
transfer stop and when cable breaks, the entire network will be down.

Star Topology
In local area networks with a star topology, each network host is
connected to a central hub with a point-to-point connection. The network
does not necessarily have to resemble a star to be classified as a star
network, but all of the nodes on the network must be connected to one
central device. All traffic that traverses the network passes through the
central hub. The hub acts as a signal repeater. The star topology is
considered the easiest topology to design and implement. An advantage of
the star topology is the simplicity of adding additional nodes. The primary
disadvantage of the star topology is that the hub represents a single point
of failure.
Although most networks that are based upon the physical star topology are
commonly implemented using a special device such as a hub or switch as
the central node (i.e., the 'hub' of the star), it is also possible to implement
18

a network that is based upon the physical star topology using a computer
or even a simple common connection point as the 'hub' or central node.

Ring Topology
A network topology that is set up in a circular fashion in which data
travels around the ring in one direction and each device on the right acts as
a repeater to keep the signal strong as it travels. Each device incorporates a
receiver for the incoming signal and a transmitter to send the data on to the
next device in the ring. The network is dependent on the ability of the
signal to travel around the ring.

Mesh Topology
The number of connections in a full mesh = n(n - 1) / 2.
The physical fully connected mesh topology is generally too costly and
complex for practical networks, although the topology is used when there
are only a small number of nodes to be interconnected.
The Partially connected type of network topology in which some of the
nodes of the network are connected to more than one other node in the
network with a point-to-point link this makes it possible to take
advantage of some of the redundancy that is provided by a physical fully
connected mesh topology without the expense and complexity required for
a connection between every node in the network.

Tree Topology
Tree topology is a combination of Bus and Star topology.
Each node in the network having a specific fixed number, of nodes
connected to it at the next lower level in the hierarchy, the number, being
referred to as the 'branching factor' of the hierarchical tree. This tree has
individual peripheral nodes.
A network that is based upon the physical hierarchical topology must have
at least three levels in the hierarchy of the tree, since a network with a
central 'root' node and only one hierarchical level below it would exhibit
the physical topology of a star.
Such a type of network topology is very useful and highly recommended.
19

Hybrid Topology
Hybrid topology is a combination of Bus, Star and ring topology.
Hybrid networks use a combination of any two or more topologies in such
a way that the resulting network does not exhibit one of the standard
topologies (e.g., bus, star, ring, etc.). For example, a tree network
connected to a tree network is still a tree network topology. A hybrid
topology is always produced when two different basic network topologies
are connected. Two common examples for Hybrid network are: Star-Ring
network and Star-Bus network

Fig 2.3 Basic Network Topologies

b) Logical topologies-The logical topology, in contrast, is the way that the signals
act on the network media, or the way that the data passes through the network
from one device to the next without regard to the physical interconnection of the
devices. For example, the original twisted pair Ethernet using repeater, hubs was a
logical bus topology with a physical star topology layout. Token Ring is a logical
ring topology, but is wired a physical star from the Media Access Unit.
The logical classification of network topologies describes the path that
the data takes

between

nodes

being

actual physical connections between nodes.

20

used

as

opposed

to

the

4) Networking Hardware
Networking hardware or networking equipment typically refers to devices facilitating
the use of a computer network. Computer networking devices are units that
mediate data in a computer network. The various Networking devices arei.

Network interface cards


A network card, network adapter, or NIC (network interface card) is a piece
of computer hardware designed to allow computers to physically access a
networking medium. It provides a low-level addressing system through the use
of MAC addresses.
Each Ethernet network interface has a unique MAC address which is usually
stored in a small memory device on the card, allowing any device to connect to
the network without creating an address conflict. Ethernet MAC addresses are
composed of six octets. Uniqueness is maintained by the IEEE, which manages
the Ethernet address space by assigning 3-octet prefixes to equipment
manufacturers.

Fig 2.4 Network Interface Card (Network and Wireless LAN)

ii.

Repeaters and hubs


A repeater is an electronic device that receives a signal, cleans it of unnecessary
noise, regenerates it, and retransmits it at a higher power level, or to the other side
of an obstruction, so that the signal can cover longer distances without
degradation. In most twisted pair Ethernet configurations, repeaters are required
for cable that runs longer than 100 meters. A repeater with multiple ports is
known as a hub. Repeaters work on the Physical Layer of the OSI model.
Repeaters require a small amount of time to regenerate the signal. This can cause
a propagation delay which can affect network communication when there are
21

several repeaters in a row. Many network architectures limit the number of


repeaters that can be used in a row (e.g. Ethernet's 5-4-3 rule). Today, repeaters
and hubs have been made mostly obsolete by switches.

Fig 2.5 Hub- 4 Port and 8 Ports


iii.

Bridges
A bridge is used to join two network segments together; it allows computers on
either segment to access resources on the other. They can also be used to divide
large networks into smaller segments. Bridges have all the features of repeaters,
but can have more nodes, and since the network is divided, there is fewer
computers competing for resources on each segment thus improving network
performance.

Fig 2.6 Bridge


iv.

Switches
Switches are a special type of hub that offers an additional layer of intelligence to
basic, physical-layer repeater hubs. A switch must be able to read the MAC
address of each frame it receives. This information allows switches to repeat
incoming data frames only to the computer or computers to which a frame is
addressed. This speeds up the network and reduces congestion.

Fig 2.7 Switch


22

v.

Routers
A router is an internetworking device that forwards packets between networks by
processing information found in the datagram or packet (Internet protocol
information from Layer 3 of the OSI Model). In many situations, this information
is processed in conjunction with the routing table (also known as forwarding
table). Routers use routing tables to determine what interface to forward packets
(this can include the "null" also known as the "black hole" interface because data
can go into it, however, no further processing is done for said data).

Fig 2.8 Router


vi.

Firewalls
A firewall is an important aspect of a network with respect to security. It typically
rejects access requests from unsafe sources while allowing actions from
recognized ones. The vital role firewalls play in network security grows in
parallel with the constant increase in 'cyber' attacks for the purpose of
stealing/corrupting data, planting viruses, etc.

Fig 2.9 Overview of Firewall

23

Cisco Certified Network Associate or CCNA


1) Router
Router is hardware device, which is used to communicate two different networks. Router
performs routing and path determination. It does not perform broadcast information.
There are two types of routers: -

(i) Hardware Routers are developed by Cisco, HP.


(ii) Software Routers is configured with the help of routing and remote
access. This feature is offered by Microsoft. This feature is by default
installed, but you have to enable or configure it.
Hardware routers are dedicated routers. They are more efficient. But in case of software
routers, it has fewer features, slow performance. They are not very much efficient.
2) Lan Card
LAN card is media access device. LAN card provide us connectivity in the network.
There is a RJ45 (Registered Jack) connector space on the LAN card. RJ45 is used in UTP
cable. There is another led which is also called heartbeat of Lan card. When any activity
occur it may be receiving or transmitting any kind of data. This led start blinking and also
tell us the status of lan card.
LAN Topologies

BUS Topology
Cable Type

Coaxial

Connector Type

BNC (Bayonet Neill-Concelman), T type, Terminator

Coaxial Thick

Maximum length 500 meters N/w devices 100

Coaxial Thin

Maximum length 185 meters N/w devices 30

Fig 2.23 Coaxial Cable

24

Star Topology
Cable type

- UTP

Connector type - RJ45


Maximum Length 100 meters (with proper color coding)

UTP (Unshielded Twisted Pair)

Fig 2.24 UTP

STP (Shielded Twisted Pair)

Fig 2.25 STP


In case of hub media access method will be CSMA/CD.

Ethernet Family
Speed
10

Base band
Base 2

200-meter

Coaxial cable

10

Base 5

500-meter

Thick Coaxial cable

10

Base T

100 meter

Twisted Pair (UTP)

10/100(present)

Base TX

100 meter

UTP

100

Base T4

100 meter

UTP 4 Pairs used

100

Base FX

up to 4 kms

Fiber Optic

1000(Server)

Base TX

100 meter

UTP

1000

Base FX

up to 10 kms

Fiber Optic

10000

Base FX

Fiber Optic

25

Color
Green Green white
Orange Orange white
Blue

Blue white

Brown Brown white


Green cable has maximum twists.

Pin Configuration
Cross

Straight

Straight Cable
1

Orange white -

Orange white

Orange

Orange

Green white

Green white

Blue

Blue

Blue white

Blue white

Green

Green

Brown white -

Brown white

Brown

Brown

Cross Cable
1

Orange white -

Green white

Orange

Green

Green white

Orange white

Blue

Blue

Blue white

Blue white

Green

Orange

Brown white -

Brown white

Brown

Brown

26

RJ45 Connector

Fig 2.26 RJ45


3) OSI (Open Systems Interconnection) Model
OSI model is the layer approach to design, develop and implement network. OSI
provides following advantages: (i)

Designing of network will be standard base.

(ii)

Development of new technology will be faster.

(iii) Devices from multiple vendors can communicate with each other.
(iv) Implementation and troubleshooting of network will be easy.
The seven Layers of OSI model are explained asi) Application Layer: - Application layer accepts data and forward into the protocol stack.
It creates user interface between application software and protocol stack.
ii) Presentation Layer: - This layer decides presentation format of the data. It also able to
performs other function like compression/decompression and encryption/decryption.
iii) Session Layer: - This layer initiate, maintain and terminate sessions between different
applications. Due to this layer multiple application software can be executed at the same
time.
iv) Transport Layer: - Transport layer is responsible for connection oriented and
connection less communication. Transport layer also performs other functions like

Error checking, Flow Control, Buffering, Windowing

Multiplexing, Sequencing, Positive Acknowledgement, Response

v) Network Layer: - This layer performs function like logical addressing and path
determination. Each networking device has a physical address that is MAC address. But
logical addressing is easier to communicate on large size network.

27

Logical addressing defines network address and host address. This type of addressing is
used to simplify implementation of large network. Some examples of logical addressing
are: - IP addresses, IPX addresses etc.

Fig 2.27 Seven Layers of OSI Model and their Functions

vi) Data Link Layer: - The functions of Data Link layer are divided into two sub layers-

28

Logical Link Control defines the encapsulation that will be used by the NIC to
delivered data to destination. Some examples of Logical Link Control are ARPA
(Ethernet), 802.11, Wi-Fi.

Media Access Control defines methods to access the shared media and establish
the identity with the help of MAC address. Some examples of Media Access
Control are CSMA/CD, Token Passing.

vii) Physical Layer: - Physical Layer is responsible to communicate bits over the media this
layer deals with the standard defined for media and signals. This layer may also perform
modulation and demodulation as required.
4) Router Configuration
I.

Router Access Modes


When we access router command prompt the router will display different modes.
According to the modes, privileges and rights are assigned to the user.

User mode-In this mode, we can display basic parameter and status of the router
we can test connectivity and perform telnet to other devices. In this mode we are
not enable to manage & configure router.

Privileged mode-In this mode, we can display all information, configuration,


perform administration task, debugging, testing and connectivity with other
devices. We are not able to perform here configuration editing of the router.
The command to enter in this mode is enable. We have to enter enable password
or enable secret password to enter in this mode. Enable secret has more priority
than enable password. If both passwords are configured then only enable secret
will work.

Global configuration-This mode is used for the configuration of global


parameters in the router. Global parameters applied to the entire router. For eg: router hostname or access list of router.
The command Enter in this mode is configure terminal.

II.

Line configuration mode


This mode is used to configure lines like console, vty and auxiliary. There are
main types of line that are configured.
(i)

Console- Router(config)#line console 0


29

III.

(ii)

Auxiliary- Router(config)#line aux 0

(iii)

Telnet or vty- Router(config)#line vty 0 4

Interface configuration mode


This mode is used to configure router interfaces. For e.g:- Ethernet, Serial, BRI
etc.
Router (config) #interface <type> <number>
Router (config) #interface serial 1

IV.

Routing configuration mode


This mode is used to configure routing protocol like RIP, EIGRP, OSPF etc.
Router (config) #router <protocol> [<option>]
Router (config) #router rip
Router (config) #router eigrp 10

V.

Configuring Password
There are five types of password available in a router
(1) Console Password
Router#configure terminal
Router(config)#line console 0
Router(config-line)#password <word>
Router(config-line)#login
Router(config-line)#exit
To erase password do all steps with no command.
(2) Vty Password
Router>enable
Router#configure terminal
Router(config)#line vty 0 4
Router(config-line)#password <word>
Router(config-line)#login
Router(config-line)#exit
(3) Auxiliary Password
Router#configure terminal
Router(config)#line Aux 0
30

Router(config-line)#password <word>
Router(config-line)#login
Router(config-line)#exit
(4) Enable Password
Router>enable
Router#configure terminal
Router(config)#enable password <word>
Router(config)#exit
(5) Enable Secret Password
Enable Password is the clear text password.
Router>enable
Router#configure terminal
Router(config)#enable secret <word>
Router(config)#exit
(6) Encryption all passwords
All passwords other than enable secret password are clear text password. We
can encrypt all passwords using level 7 algorithms. The command to encrypt
all passwords areRouter#configure terminal
Router(config)#service password-encryption
VI.

Managing Configuration
There are two types of configuration present in a router
(1) Startup Configuration
(2) Running Configuration
Startup configuration is stored in the NVRAM. Startup configuration is used to
save settings in a router. Startup configuration is loaded at the time of booting in
to the Primary RAM.
Running Configuration is present in the Primary RAM wherever we run a
command for configuration; this command is written in the running configuration.

To save configuration
Router#copy running-configuration startup-configuration
31

Or
Router#write

To display running-configuration Router#show running-configuration

To display startup configuration


Router#show startup-configuration

To erase old configuration


Router#erase startup-configuration

Configuring Host Name


Router#configure terminal
Router#hostname <name>

VII.

<name>#exit or end or /\z

Configuration Interfaces
Interfaces configuration is one of the most important part of the router
configuration. By default, all interfaces of Cisco router are in disabled mode. We
have to use different commands as our requirement to enable and configure the
interface.

Configuring IP, Mask and Enabling the Interface


Router#configure terminal
Router(config)#interface <type> <no>
Router(config-if)#ip address <ip> <mask>
Router(config-if)#no shutdown
Router(config-if)#exit

To configure Interface description


Router#configure terminal
Router(config)#interface <type> <no.>
Router(config-if)#description <line>

To display interface status


Router#show interfaces (to show all interfaces)
Router#show interface <type> <no.>
This command will display following parameters about an interface
1)

Status
32

2)

Mac address

3)

IP address

4)

Subnet mask

5)

Hardware type / manufacturer

6)

Bandwidth

7)

Reliability

8)

Delay

9)

Load ( Tx load, Rx load)

10)

Encapsulation

11)

ARP type (if applicable)

12)

Keep alive

Configuring secondary IP
Router#config terminal
Router(config)#interface <type> <no>
Router(config-if)#IP address 192.168.10.5 255.255.255.0
Router(config-if)#IP address 192.168.10.18 255.255.255.0 secondary
Router(config-if)#no shutdown (to enable the interface because they
always shutdown)
Router(config-if)#exit
Router#show run (to display secondary IP)

33

To display commands present in history


Router#show history

To display history size


Router#show terminal

VIII.

Configuring Banners
Banners are just a message that can appear at different prompts according to the
type. Different banners are: Message of the day (motd)-This banner appear at every access method.

5) IP Routing
When we want to connect two or more networks using different n/w addresses then we
have to use IP Routing technique. The router will be used to perform routing between the
networks. A router will perform following functions for routing.
I.

Path determination
The process of obtaining path in routing table is called path determination. There
are three different methods to which router can learn path.

II.

Automatic detection of directly connected networks.

Static & Default routing

Dynamic routing

Packet forwarding
It is a process that is by default enable in router. The router will perform packet
forwarding only if route is available in the routing table.

III.

Static Routing
In this routing, we have to use IP route commands through which we can specify
routes for different networks. The administrator will analyze whole internetwork
topology and then specify the route for each n/w that is not directly connected to
the router.
Steps to perform static routing

a. Create a list of all n/w present in internetwork.


b. Remove the n/w address from list, which is directly connected to n/w.
34

c. Specify each route for each routing n/w by using IP route command.
Router(config)#ip route <destination n/w> <mask> <next hop ip>
Next hop IP it is the IP address of neighbor router that is directly
connected our router.

Static Routing Example: Router#conf ter


Router(config)#ip route 10.0.0.0 255.0.0.0 192.168.10.2

Advantages of static routing


a. Fast and efficient.
b. More control over selected path.
c. Less overhead for router.

Disadvantages of static routing


a. More overheads on administrator.
b. Load balancing is not easily possible.
c. In case of topology change routing table has to be change
manually.

IV.

Default Routing
Default routing means a route for any n/w. these routes are specify with the help
of following syntax: Router(config)#ip route 0.0.0.0 0.0.0.0 <next hop>

To display routing table


Router#show ip route

To check all the interface of a router


Router#show interface brief

V.

Dynamic Routing
In dynamic routing, we will enable a routing protocol on router. This protocol will
send its routing information to the neighbor router. The neighbors will analyze the
information and write new routes to the routing table.
The routers will pass routing information receive from one router to other router
also. If there are more than one path available then routes are compared and best
35

path is selected. Some examples of dynamic protocol are: -RIP, IGRP, EIGRP,
and OSPF

Configuring RIP
Router#conf ter
Router(config)#router rip
Router(config-router)#network <own net address>
Router(config-router)#network <own net address>
Router(config-router)#exit

Example- Router(config-router)#network 10.0.0.0


Router(config-router)#network 172.16.0.0
Router(config-router)#network 200.100.100.0
175.2.0.0 via 172.16.0.6
VI.

Configuring IGRP
Router(config)#router igrp <as no>(1 65535)
Router(config-router)#network <net address>
Router(config-router)#network <net address>
Router(config-router)#exit

VII.

Link State Routing


This type of routing is based on link state. The router will send link state
information to the all neighbors. Link state information from one neighbor is also
forwarded to other neighbor.
Each router will maintain its link state database created from link state
advertisement received from different routers.
36

The router will use best path algorithm to store the path in routing table.
Problems of Link State Routing
The main problems of link state routing are:

High bandwidth consumption.

More hardware resources required that is processor and memory (RAM)

The routing protocols, which use link state routing are: a. EIGRP (Enhanced Interior Gateway Routing Protocol)
Features:

Cisco proprietary

Hybrid protocol

Link State

Distance Vector

Multicast Updates using

Address 224.0.0.10

Support AS

Support VLSM

Automatic Route Summarization

Unequal path cost load balancing

Configuring EIGRP: Router(config)#router eigrp <as no>


Router(config-router)#network <net addr.>
Router(config-router)#network <net addr.>
Router(config-router)#exit
b. OSPF Terminology
Router ID-Router ID is the highest IP address of router interfaces. This id
is used as the identity of the router. It maintains link state databases. The
first preference for selecting router ID is given to the Logical interfaces. If
logical interface is not present then highest IP of physical interface is
selected as router id.

37

Backup Designated Router-This router will work as backup for the


designated router. In BDR mode, it will receive all information but do not
forward this information to other non-DR router.
Configuring OSPFRouter#conf ter
Router(config)#router ospf <process no>
Router(config-router)#network <net address> <wild mask> area <area id>
Router(config-router)#network <net address> <wild mask> area <area id>
Router(config-router)#exit
Wild Mask Complement of subnet mask
Example

255.255.255.255
- 255.255.192.0
0.0.63.255

subnet mask
wild mask

Example of OSPF RoutingRouter(config)#router ospf 33


Router(config-router)#network 200.100.100.32 0.0.0.3 area 0
Router(config-router)#network 200.100.100.64 0.0.0.31 area 0
Router(config-router)#exit

6) LAN Switching
Ethernet switches are used in LAN to create Ethernet n/ws. Switches forward the traffic
on the basis of MAC address. Switches maintain a Mac Addresse table in which mac
addresses and port no.s are used to perform switching decision. Working of bridge and
switch is similar to each other.
Classification of switches
Switches are classified according to the following criteria: Types of switches based on working:

Store & Forward-This switch receives entire frame then perform error checking
and start forwarding data to the destination.

38

Cut through-This switch starts forwarding frame as soon as first six bytes of the
frame are received.

Fragment-free-This switch receives 64 bytes of the frame, perform error checking


and then start forwarding data.

Adaptive cut-through-It changes its mode according the condition. If it see there
are errors in many frames then it changes to Store & Forward mode from Cut
through or Fragment-free.

Types of switches based on management:

Manageable switches

Non-Manageable switches

Semi-Manageable switches

Types of switches based on OSI layer:

Layer 2 switches (only switching)

Layer 3 switches (switching & routing)

Types of switches based on command mode (only in Cisco):

IOS based

CLI based

Type of switches based on hierarchical model:

Core layer switches

Distribution layer switches

Access layer switches

Qualities of switch
- No. of ports
- Speed of ports
- Type of media
- Switching or wire speed or throughput
Basic Switch Administration
IOS based switches are similar to the routers. We can perform following function on
switches in a similar manner as performed on router.
(1) Access switch using console
(2) Commands to enter & exit from different mode
39

(3) Commands to configure passwords


(4) Manage configuration
(5) Backup IOS and configuration
(6) Configuring and resolving hostnames
(7) Managing telnet
(8) Configuring CDP
(9) Configuring time clock
(10) Configuring Banners
(11) Command line shortcuts and editing shortcuts
(12) Managing history
(13) Configure logging
(14) Boot system commands
Following function and options are not similar in router and switch.
(1) Default hostname is Switch
(2) Auxiliary port is not present
(3) VTY ports are mostly 0 to 15
(4) By default interfaces are enabled
(5) IP address cannot be assign to interfaces
(6) Routing configuration mode is not present
(7) Interface no. starts from 1
(8) Web access is by default enabled
(9) Configuration registry is not present in similar manner
(10) Flash memory may contain multiple files and startup-configuration is also
saved in flash

Configuring IP and Gateway on switch


We can configure IP address on switch for web access or telnet IP address
is required for the administration of the switch. If we have to access switch
from remote n/w then we will configure default gateway in addition to IP
address.
IP address is assigned to the logical interface of switch with following
command:40

Switch(config)#interface vlan 1
Switch(config)#IP address <ip> <mask>
Switch(config)#no sh
Switch(config)#exit

Configuring Gateway
Switch(config)#ip default-gateway <ip>
Switch(config)#exit

Breaking Switch Password


1. Power off switch press mode button present in front of switch then
power on the switch.
2. Keep mode button press until Switch: prompt appears on console.
3. In switch monitor mode, type following commands: flash_init
load_helper
rename flash:config.text flash:<anyname>
dir flash:
boot
4. After booting switch will prompt to enter in initial configuration
dialog. Enter no here and type.
Switch>enable
Rename flash:<anyname> Flash:config.text
Configure memory
Change password and save config. Then copy run start_config.

Logical Segmentation of Network


To perform logical segmentation, we have to create VLAN in the network. With the help
of VLAN, we can logically divide the broadcast domain of the network.
VLAN (Virtual LAN)-VLAN provides Virtual Segmentation of Broadcast Domain in the
network. The devices, which are member of same Vlan, are able to communicate with
each other. The devices of different Vlan may communicate with each other with routing.
So that different Vlan devices will use different n/w addresses. Vlan provides following
advantages: 41

(1) Logical Segmentation of network


(2) Enhance network security
Creating port based Vlan
In port based Vlan, first we have to create a Vlan on manageable switch then we have to
add ports to the Vlan.

Commands to create Vlan


Switch#config ter
Switch(config)#vlan <no> [name <word>]
Switch(config)#exit

[optional]

Or
Switch#vlan database
Switch(vlan)#vlan <no> [name <word>]
Switch(vlan)#exit

Commands to configure ports for a Vlan


By default, all ports are member of single vlan that is Vlan1. we can
change vlan membership according to our requirement.
Switch#conf ter
Switch(config)#interface <type> <no>
Switch(config-if)#switchport access vlan <no>
Switch(config-if)#exit

Commands to configure multiple ports in a vlan


Switch#config ter
Switch(config)#interface range <type> <slot/port no-port no>
Switch(config-if)#switchport access vlan <no>
Switch(config-if)#exit
Example: - Suppose we want to add interface fast Ethernet 0/10 to
0/18 in vlan5
Switch#config ter
Switch(config)#interface range fastethernet 0/10 18
Switch(config-if)#switchport access vlan 5
Switch(config-if)#exit
42

To Disable web access in switch


Switch#config ter
Switch(config)#no ip http server

To display mac address table


Switch#show mac-address-table

Vlan

Mac address

type

ports

20

00-08-a16-ab-6a-7b

dynamic

fa0/7

To Display Vlan and port membership


Switch#show vlan

Trunking
When there are multiple switches then we have to use trunk links to connect one switch
with other. If we are not using trunk links then we have to connect one cable from each
vlan to the corresponding vlan of the other switch.
Switches will perform trunking with the help of frame tagging. The trunk port will send
data frames by adding a Vlan id information to the frame, at the receiving end vlan id
information is removing from the end and according to the tag data is delivered to the
corresponding vlan.

Configuring Trunking-In cisco switches all switch ports may be


configured in three modes-Trunk desirable (default), Trunk on, Trunk off.
Switch#conf ter
Switch(config)#interface <type> <no>
Switch(config-if)#switchport mode <trunk|access|auto>
Switch(config-if)#exit

on

off

desirable

To configure Vlans allowed on Trunk- By default all Vlans are allowed


on Trunk port. We can add/remove a particular Vlan from trunk port with
following command
Switch#config ter
Switch(config)#interface <type> <no.>
Switch(config-if)#switchport trunk allowed vlan all

To display trunk interfaces


Switch#show interface trunk
43

Switch#show interface <type> <no.> trunk


Inter Vlan Communication
After creating Vlans, each Vlan has own broadcast domain. If we want communication
from one Vlan to another Vlan then we need to perform routing. There are three methods
for inter vlan communication.

Inter Vlan using multi-interface router


In this case, we have to connect one interface of router in each Vlan. This
interface will act as gateway for the corresponding vlan. Each Vlan has to use
different n/w addresses. Data from one Vlan to another Vlan will travel by router.

Configuration on Router
Router#config ter
Router(config)#interface fastethernet 0/0
Router(config-if)#no ip address
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#interface fastethernet 0/0.1
Router(config-if)#encapsulation dot1q 1
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no sh

44

Router(config-if)#exit
Router(config)#interface fastethernet 0/0.2
Router(config-if)#encapsulation dot1q 3
Router(config-if)#ip address 11.0.0.1 255.0.0.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#interface fastethernet 0/0.3
Router(config-if)#encapsulation dot1q 5
Router(config-if)#ip address 12.0.0.1 255.0.0.0
Router(config-if)#no sh
Router(config-if)#exit

Configuration on Core switch


a. Configure switch as VTP server
b. Create Vlans
c. Configure interface connected to router as Trunk
d. Configure interfaces connected to other switches as trunk (if
required)

Configuration on Distribution layer switches


a. Configure switch as VTP client
b. Configure required interface as Trunk (optional)
c. Add ports to Vlan

Configuration on Pc
Configure IP and Gateway

To configure ports for forwarding mode directly


Switch#config ter
Switch(config)#interface <type> <no.>
Switch(config-if)#switchport host

7) Access Control List

45

ACL are the basic security feature that is required in any network to control the flow of
traffic. Most of time our network may have servers and clients for which traffic control is
required.
We can also use ACL to classify the traffic. ACLs are used in features like QOS (Quality
of Service), Prioritize traffic and interesting traffic for ISDN. Classification Access
Control List: Types of ACL based on Protocol: (1) IP Access Control List
(2) IPX Access Control List
(3) AppleTalk Access Control List
Types of ACL based on Feature: (1) Standard ACL
(2) Extended ACL
Types of ACL based on Access mode: (1) Numbered ACL
(2) Named ACL
Types of ACL based on Order of rules: (1) Deny, permit
(2) Permit, deny

IP Standard ACL (Numbered)


In Standard ACL, we are only able to specify source address for the
filtering of packets. The syntax to create IP standard ACL are: Router#conf ter
Router(config)#access-list <no> <permit|deny> <source>
Router(config)#exit
<source>

Single pc

host 192.168.10.5
192.168.10.5
192.168.10.5 0.0.0.0

N/w

200.100.100.0 0.0.0.255

Subnet

200.100.100.32 0.0.0.15

Applying ACL on interface


46

Router#conf ter
Router(config)#interface <type> <no>
Router(config-if)#ip access-group <ACL no.> <in|out>
Router(config-if)#exit

Internet

Router

Router(config)#access-list 25 permit 192.168.10.32 0.0.0.31


Router(config)#access-list 25 permit 192.168.10.64 0.0.0.3
Router(config)#access-list 25 permit 192.168.10.68
Router(config)#access-list 25 permit 192.168.10.69
Router(config)#access-list 25 permit 192.168.10.70
Router(config)#interface serial 0
Router(config-if)#ip access-group 25 out

IP Standard ACL (Named)


In Numbered ACL editing feature is not available that is we are not able to
delete single rule from the ACL. In Named ACL editing feature is
available.
Router#config ter
Router(config)#ip access-list standard <name>
47

Router(config-std-nacl)#<deny|permit> <source>
Router(config-std-nacl)#exit
Router#conf ter
Router(config)#ip access-list standard abc
Router(config-std-nacl)#deny 172.16.0.16
Router(config-std-nacl)#deny 172.16.0.17
Router(config-std-nacl)#deny 172.16.0.18
Router(config-std-nacl)#permit any
Router(config-std-nacl)#exit

To modify the ACL


Router#conf ter
Router(config)#ip access-list standard abc
Router(config-std-nacl)#no deny 172.16.0.17
Router(config-std-nacl)#exit

IP Extended ACL (Numbered)


Extended ACL are advanced ACL. ACL, which can control traffic flow on
the basis of five different parameters that are: (i) Source address
(ii) Destination address
(iii) Source port
(iv) Destination port
(v) Protocol (layer 3/layer 4)

To display ACL
Router#show access-lists or
Router#show access-list <no.>

To display ACL applied on interface


Router#show ip interface
Router#show ip interface <type> <no>
Router#show ip interface Ethernet 0

9) Network Address Translation

48

NAT is the feature that can be enable in a Router, Firewall or a Pc. With the help of
NAT, we are able to translate network layer addresses that are IP addresses of packets.
With the help of Port Address Translation, we are also able to translate port no.s present
in transport layer header.
There are two reasons due to which we use NAT: (1) Conserve Live IP address-On Internet, there are limited no of IP addresses. If our Pc
wants to communicate on Internet then it should have a Live IP address assigned by our
ISP. So that IP address request will depend on no. of PCs that we want to connect on
Internet. Due to this, there will be a lot of wastage in IP addresses. To reduce wastage, we
can share live IP addresses between multiple PCs with the help of NAT.
(2) NAT enhances the network security by hiding PC & devices behind NAT.
Types of NAT

Static NAT-This NAT is used for servers in which one Live IP is directly mapped
to one Local IP. This NAT will forward on the traffic for the Live IP to the Local
PC in the n/w.

Dynamic NAT-Dynamic NAT is used for clients, which want to access Internet.
The request from multiple client IPs are translated with the Live IP obtained from
the Pool. It is also called Pool Based Dynamic NAT.

Configuring NAT
Router#conf ter
Router(config)#int serial 0
Router(config-if)#ip nat outside
Router(config-if)#int eth 0
Router(config-if)#ip nat inside
Router(config-if)#exit

Router(config)#ip nat inside source static 172.16.0.7 200.1.1.3


Router(config)#ip nat inside source static tcp 172.16.0.5 80 200.1.1.4 80
Router(config)#ip nat inside source static udp 172.16.0.6 53 200.1.1.4 53

Router(config)#access-list 30 deny 172.16.0.5


49

Router(config)#access-list 30 deny 172.16.0.6


Router(config)#access-list 30 deny 172.16.0.7
Router(config)#access-list 30 permit any
Router(config)#ip

nat

pool

abc

200.1.1.8

200.1.1.12

255.255.255.240
Router(config)#ip nat inside source list 30 pool abc overload

NAT + PAT

Command for Basic NAT


Router(config)#ip nat inside source list 30 interface seen
<exiting interface name>

50

netmask

Project Methodology
Network Configuration of LAN with WAN
The project is based on the concepts of networking. It includes configuring different network
devices like Router, Switch, Bridge & connecting it with Hubs & PCs by using different types of
connecting wires by allocating the IP Addresses to all the interfaces after the subneting of
network ID. The beauty of configuring network devices is that it helps users access the network
with few constraints like allowing some to access the website but not allowing them to access the
mail server on the internet on private IP address which are otherwise excluded by internet service
provider (ISP).
We have used Routing between the various centers of a Company in different cities. Inter VLAN
technology is used to make work efficient between 2 different departments in one center.

Fig 3.1 Project Screenshot


DESCRIPTION
51

We have six different centers of an organization. We have purchased a network id and divide
that network id into number of small network ids by using Variable Length Subnet Mask
(VLSM). We have used six Routers & applied various configuration settings on each router.
On Router4 we have configured NAT with translates private range of IPs into public range.
Extended Access Control List has been applied to Router 3 between Laptop 7 and Network of
Router 4 with Laptop 12 and 13. Telnet service has been denied by the network. Switch 3
connected with Router 2 is used to create Inter VLANs between two different departments of
center in a single city.
Configuration
1. Router 0
%SYS-5-CONFIG_I: Configured for ROUTER0
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Patiala
Patiala(config)#line console 0
Patiala(config-line)#password city
Patiala(config-line)#login
Patiala(config-line)#exit
Patiala(config)#line vty 0 4
Patiala(config-line)#password city
Patiala(config-line)#login
Patiala(config-line)#exit
Patiala(config)#enable password city
Patiala(config)#enable secret city
Patiala(config)#int f0/0
Patiala(config-if)#ip address 192.168.2.1 255.255.255.0
Patiala(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Patiala(config-if)#exit
Patiala(config)#int s0/0/0
52

Patiala(config-if)# ip address 192.168.3.1 255.255.255.0


Patiala(config-if)#no sh
Patiala(config-if)#clock rate 64000
Patiala(config-if)#exit
Patiala(config)#int s0/0/1
Patiala(config-if)# ip address 192.168.4.1 255.255.255.0
Patiala(config-if)#no sh
Patiala(config-if)#clock rate 64000
Patiala(config-if)#exit
Patiala(config)#router rip
Patiala(config-router)#network 192.168.2.0
Patiala (config-router)#network 192.168.4.0
Patiala (config-router)#network 192.168.8.0
Patiala (config-router)#network 192.168.10.0
Patiala (config-router)#network 192.168.14.0
Patiala (config-router)#network 192.168.15.0
Patiala (config-router)# exit
Patiala (config)# router ospf 100
Patiala (config-router)#network 192.168.3.0 0.0.0.15 area 0
Patiala (config-router)#network 192.168.2.0 0.0.0.15 area 0
Patiala (config-router)#exit
Patiala(config)#exit
Patiala# write
2. Router 3
%SYS-5-CONFIG_I: Configured for ROUTER0
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Ludhiana
Ludhiana (config)#line console 0

53

Ludhiana (config-line)#password city


Ludhiana (config-line)#login
Ludhiana (config-line)#exit
Ludhiana (config)#line vty 0 4
Ludhiana (config-line)#password city
Ludhiana (config-line)#login
Ludhiana (config-line)#exit
Ludhiana (config)#enable password city
Ludhiana (config)#enable secret city
Ludhiana (config)#int f0/0
Ludhiana (config-if)#ip address 192.168.6.1 255.255.255.0
Ludhiana (config-if)#no sh
Ludhiana (config-if)#exit
Ludhiana (config)#int s0/0/0
Ludhiana (config-if)# ip address 192.168.4.2 255.255.255.0
Ludhiana (config-if)#no sh
Ludhiana (config-if)#clock rate 64000
Ludhiana (config-if)#exit
Ludhiana (config)#int s0/0/1
Ludhiana (config-if)#ip address 192.168.7.2 255.255.255.0
Ludhiana (config-if)#no sh
Ludhiana (config-if)#clock rate 64000
Ludhiana (config-if)#exit
Ludhiana (config)#int s0/1/0
Ludhiana (config-if)# ip address 192.168.8.1 255.255.255.0
Ludhiana (config-if)#no sh
Ludhiana (config-if)#clock rate 64000
Ludhiana (config-if)#exit
Ludhiana (config)#int s0/1/1
Ludhiana (config-if)# ip address 192.168.9.1 255.255.255.0
Ludhiana (config-if)#no sh
54

Ludhiana (config-if)#clock rate 64000


Ludhiana (config-if)#exit
Ludhiana (config)# router eigrp 10
Ludhiana (config-router)# network 192.168.4.0
Ludhiana (config-router)# network 192.168.6.0
Ludhiana (config-router)#exit
Ludhiana (config)#router rip
Ludhiana (config)# network 192.168.2.0
Ludhiana (config-router)# network 192.168.4.0
Ludhiana (config-router)# network 192.168.6.0
Ludhiana (config-router)# network 192.168.7.0
Ludhiana (config-router)# network 192.168.8.0
Ludhiana (config-router)# network 192.168.9.0
Ludhiana (config-router)# network 192.168.10.0
Ludhiana (config-router)# network 192.168.11.0
Ludhiana (config-router)# network 192.168.14.0
Ludhiana (config-router)# network 192.168.15.0
Ludhiana (config-router)#exit
Ludhiana (config)#ip access-list extended city
Ludhiana (config)#deny tcp 192.168.6.4 0.0.0.1 192.168.10.1 255.255.255.0 eq 23
Ludhiana (config)# permit ip any any
Ludhiana (config)#int f0/0
Ludhiana (config-if)# ip access-group city in
Ludhiana (config-if)#exit
Ludhiana (config)#exit
Ludhiana#write
3. Router 4
%SYS-5-CONFIG_I: Configured for ROUTER4
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
55

Router(config)#hostname Jalandhar
Jalandhar (config)#line console 0
Jalandhar (config-line)#password city
Jalandhar (config-line)#login
Jalandhar (config-line)#exit
Jalandhar (config)#line vty 0 4
Jalandhar (config-line)#password city
Jalandhar (config-line)#login
Jalandhar (config-line)#exit
Jalandhar (config)#enable password city
Jalandhar (config)#enable secret city
Jalandhar (config)#int f0/0
Jalandhar (config-if)# ip address 192.168.10.1 255.255.255.0
Jalandhar (config-if)#no sh
Jalandhar (config-if)#exit
Jalandhar (config)#int f0/1
Jalandhar (config-if)#ip address 192.168.12.1 255.255.255.0
Jalandhar (config-if)#no sh
Jalandhar (config-if)#exit
Jalandhar (config)#int s0/0/0
Jalandhar (config-if)#ip address 202.20.20.1 255.255.255.0
Jalandhar (config-if)#no sh
Jalandhar (config-if)#clock rate 64000
Jalandhar (config-if)#exit
Jalandhar (config)#int s0/1/1
Jalandhar (config-if)#ip address 192.168.8.2 255.255.255.0
Jalandhar (config-if)#no sh
Jalandhar (config-if)# clock rate 64000
Jalandhar (config-if)#exit
Jalandhar (config)#router rip
Jalandhar (config-router)# network 192.168.2.0
56

Jalandhar (config-router)#network 192.168.3.0


Jalandhar (config-router)#network 192.168.4.0
Jalandhar (config-router)#network 192.168.5.0
Jalandhar (config-router)#network 192.168.6.0
Jalandhar (config-router)#network 192.168.7.0
Jalandhar (config-router)#network 192.168.8.0
Jalandhar (config-router)#network 192.168.9.0
Jalandhar (config-router)#network 192.168.10.0
Jalandhar (config-router)#network 192.168.12.0
Jalandhar (config-router)#network 192.168.13.0
Jalandhar (config-router)#network 192.168.14.0
Jalandhar (config-router)#network 192.168.15.0
Jalandhar (config-router)#network 202.20.20.0
Jalandhar (config-router)#exit
Jalandhar (config)#int f0/1
Jalandhar (config-if)#ip nat inside
Jalandhar (config-if)#exit
Jalandhar (config)#int s0/0/0
Jalandhar (config-if)#ip nat outside
Jalandhar (config)#exit
Jalandhar (config)#ip access-list standard 10
Jalandhar (config)#permit 192.168.12.0 0.0.0.15
Jalandhar (config)# ip nat pool city 202.20.20.3 202.20.20.10 netmask 255.255.255.0
Jalandhar (config)# ip nat inside source list 10 pool city
Jalandhar (config)#exit
Jalandhar#write

57

Result and Conclusion


Result
Networking is the concept of sharing resources and services. A network of computers is a
group of interconnected systems sharing resources and interacting using a shared
communications link. The shared resource can be data, a printer, a fax modem, or a service
such as a database or an email system.
The two main reasons for using computer networking are to provide services and to reduce
equipment costs. Networks enable computers to share their resources by offering services to
other computers and users on a network. The following are specific reasons for networking
PCs:
v.

Sharing files

vi.

Sharing printers and other devices

vii.

Enabling centralized administration and security of the resources within the system.

viii.

Supporting network applications such as electronic mail and database services.


Microsoft Certified Systems Engineer program began with Windows NT 3.1 and is today one
of the most widely known Microsoft certification programs. It is available for the Platforms
viz., Windows NT 4.0, Windows 2000 Server and Windows Server 2003. Microsoft has, in
effect, discontinued the MCSE certifications for future versions of Windows, replacing the
single Platform MCSE award with a plethora of other more narrowly focused certifications.
Each platform MCSE award required passing a different set of examinations. MCSE qualified
individuals will have the ability to provide business solutions by appropriate design and
implementation of the requisite infrastructure. MCSE Certification Program is useful for
Technical Support & Systems Engineers, Technical Consultants, Network and Systems
Analysts and also for regular Software Engineers / Software Professionals.

Project Review
Project is implemented in software called Cisco Packet Tracer. Packet Tracer is a medium
fidelity, network-capable, simulation-based learning environment for networking novices to
design, configure, and troubleshoot computer networks at a CCNA-level of complexity.
Packet Tracer is an integrated simulation, visualization, collaboration, and assessment
58

environment. Packet Tracer supports student and instructor creation of simulations,


visualizations, and animations of networking phenomena. Like any simulation, Packet Tracer
relies on a simplified model of networking devices and protocols. Real computer networks,
experienced both in-person/hands-on and remotely, remain the benchmark for understanding
network behavior and developing networking skills.

Conclusion
With help of Packet Tracer we have designed a networking model graphically and virtually.
In practical formulation the design can be easily implemented without any errors and with
complete accuracy. Packet Tracer was created to help address the Digital Divide in
networking education, where many students and teachers lack access to equipment,
bandwidth, and interactive modes of learning networking.
The project is simulated, visualized, collaborated, and assessed for networking. Packet Tracer
allows students to construct their own model or virtual networks, obtain access to important
graphical representations of those networks, animate those networks by adding their own data
packets, ask questions about those networks, and finally annotate and save their creations. It
includes protocols like FTP, SMTP, POP3, PPPoE, VoIP, and BGP. CCNA-related protocols
and technologies include improved models of HTTP, DNS, DHCP, TCP, and IP.

References
59

http://www.firewall.cx
Kurose James F and Keith W. Ross : Computer Networking: A Top-Down Approach
Featuring the Internet, Pearson Education 2005.

Andrew S. Tanenbaum, Computer Networks, Fourth Edition, Pearson Education 2006.


William Stallings, Computer Networking with Internet Protocols and Technology,
Pearson Education 2004.

Important publications in computer networks


Network Communication Architecture and Protocols: OSI Network Architecture 7
Layers Model

http://en.wikipedia.org/wiki/Computer_network
http://en.wikipedia.org/wiki/Networking_hardware

60