Sie sind auf Seite 1von 20

PRINCIPALES COMANDOS USADOS EN CCNA2

CAPITULO 1. Introduccin al enrutamiento y envo de


paquete
BORRAR CONFIGURACIN DE INICIO
En modo privilegiado
#erase startup-config
#reload
ASEGURAR EL ROUTER CON CLAVES Y CONFIGURACION BSICA
Router>enable
Router#conf term
R1(config)#hostname R1
R1(config)#enable password cisco
R1(config)#enable secret class
R1(config)#no enable password
----- elimina password
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#banner motd #Acceso restringido#
Cifrar todas las contraseas desde este momento
R1(config)#service password-encryption
Desactivar la bsqueda de DNS
R1(config)#no ip domain-lookup
Configurar puertos
#conf term
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
1

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state
to up
R1(config-if)#
R1(config-if)#description R1 LAN
R1(config-if)#
Interfaces seriales
R1(config-if)#interface serial 0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#description Link to R2
R1(config-if)#no shutdown
R1(config-if)#

Salvar configuracion en ejecucin a la NVRAM


#Copy running-config startup-config
#write
// equivale a copiar el running en el startup-config
#Copy run tftp
//copia en un servidor tftp
#Copy startup-config flash:startup-config.bak // respaldar en la flash

Verificar configuracin
#Show running-config
#Show startup-config
#Show ip int brief
// estado resumido de los puertos
#show ip interface
#Show int
//descripcion detallada de todos los puertos
#Show int fa 0/1
// descripcion de la interfaz
#Show version
#show ip route
// muestra tabla de enrutamiento
#ping
#traceroute

CAPITULO 2. Enrutamiento esttico


Activar depuracin ip
R1#debug ip routing
Desactiva la depuracin en ambos routers mediante no debug ip routing
2

o simplemente undebug all.


R1#no debug ip routing
R1#undebug all
Configurar una ruta esttica con direccin de siguiente salto:
Router(config)# ip route network-address subnet-mask ip-address
R3(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2
Configurar una ruta esttica con puerto o interfaz de salida:
R3(config)#ip route 172.16.1.0 255.255.255.0 Serial 2/0
Configurar una ruta esttica por defecto.
Configura el router R1 con una ruta por defecto con una direccin de siguiente salto.
R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2
Aparece como:
Gateway of last resort is 172.16.2.2 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 172.16.2.2


Sincronizar la aparicin de avisos configurando en lneas de consola y de
terminal virtual.
R1r#conf term
R1(config)#line console 0
R1(config-line)#logging synchronous
R1(config-line)#line vty 0 4
R1(config-line)#logging synchronous
Tiempo de espera de conexin para detectar al usuario
R1(config)#line console 0
R1(config-line)#exec-timeout 0 0
R1(config-line)#line vty 0 4
R1(config-line)#exec-timeout 0 0
Configurar una ruta esttica de resumen.
Al observar las tres redes en el nivel binario, se puede establecer un lmite en
comn en el bit 22 desde
la izquierda. (Mscara 255.255.252.0)
Para las redes cercanas:
172.16.1.0
10101100.00010000.00000001.00000000
172.16.2.0
10101100.00010000.00000010.00000000
172.16.3.0
10101100.00010000.00000011.00000000
La red que deber utilizarse en la ruta de resumen es 172.16.0.0/22.
R3(config)#ip route 172.16.0.0 255.255.252.0 192.168.1.2
Eliminar rutas esttica

R3(config)#no ip route 172.16.1.0 255.255.255.0 192.168.1.2


R3(config)#no ip route 172.16.2.0 255.255.255.0 Serial0/0/0

CAPITULO 3. Protocolos de enrutamiento por vector de distancia


CAPITULO 4. Introduccin a los protocolos de enrutamiento dinmico y
Protocolos de enrutamiento por vector de distancia
Teoria sobre protocolos de enrutamiento dinamico y protocolos de enrutamiento de
vector de distancia.
Repaso de divisin de subredes y configuraciones bsicas.

CAPITULO 5. RIP versin 1


Configurar el protocolo RIP.
Habilitar un enrutamiento dinmico.
Ingrese router ? en el indicador de configuracin global para visualizar una lista
de los protocolos de enrutamiento disponibles en el router.
Para habilitar RIP, ingrese el comando router rip en el modo de configuracin
global.
R1(config)#router rip
R1(config-router)#
Ingrese direcciones de red con clase.
Para cada red conectada directamente se habilida RIP, para que se publiquen
actualizaciones.
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
Visualizar la informacin acerca de los procesos de enrutamiento.
R1#show ip protocols
R1#debug ip rip
R1#undebug all

// desactiva todas las depuraciones

Eliminar configuraciones RIP


R1(config)#no router rip
Deshabilitar el envo de actualizaciones RIPv1 a la interfaz.
R2(config-router)#passive-interface fastethernet 0/0
4

Enviar informacin de la ruta esttica por defecto a R1.


Se utiliza para configurar R2 para que incluya la ruta esttica por defecto en sus
actualizaciones RIP.
R2(config)#ip route 0.0.0.0 0.0.0.0 s 0/0/1
R2(config)#router rip
R2(config-router)#default-information originate

CAPITULO 6. VLSM y CIDR


Repaso sobre creacin de subredes de tamao exacto.

CAPITULO 7. RIP versin 2


Ejemplo de configuracin de una ruta de superred esttica con una interfaz nula
R2(config)#ip route 192.168.0.0 255.255.0.0 Null0
Redistribucin de rutas estticas en las actualizaciones RIP
R2(config)#router rip
R2(config-router)#redistribute static
Habilitar RIPv2
R1(config)#router rip
R1(config-router)#version 2
Verificar si esta activado RIP y la version 2 con:
R1#show ip protocols
Deshabilitar resumen automatico en RIPv1 y RIPv2
Router(config)#router rip
Router(config-router)#no auto-summary
Borrar para que se reconstruyan tablas de ruteo
#clear ip route *
Usar #show ip route y #debug ip rip par aver la informacin de las actualizaciones y
ver si se enva las superredes (rutas sumarizadas).
Si no son necesarias las rutas resumidas, deshabilite la sumarizacin
automtica

CAPITULO 8. La tabla de enrutamiento: Un estudio


detallado
El comportamiento de enrutamiento, especificados por los comandos
ip classless
no ip classless
Por default esta activado y se recomienda mantener un comportamiento ip classless
para hacer que se busque en las rutas por default y de superred, si no hubo
coincidencias en las rutas secundarias.

CAPITULO 9. EIGRP
Mtricas usadas por EIGRP:
- Ancho de banda (usado por defecto)
- Retraso (usado por defecto)
- Confiabilidad
- Carga
El encabezado incluye:
Campo de cdigo de operacin:
actualizacin (1)
consulta (3)
respuesta (4)
saludo (5)
y Nmero de sistema autnomo = ID para identificar al proceso EIGRP.
Parametros de EIGRP, inlcuidos en los mensajes:
TLV = Tipo / Longitud / Valor
K1: ancho de banda (default en 1)
K2: carga
K3: retraso (default en 1)
K4: confiabilidad
K5: confiabilidad
Y tiempo de espera = tiempo mximo para esperar el siguiente saludo.

Usa PDM - mdulos independientes del protocolo, cada modulo enruta protocolos
diferentes: IP, IPX y AppleTalk
Eigrp e igrp redistribuyen automticamente sus rutas entre sistemas autnomos con el
mismo nmero de proceso. Pueden aprender de rutas del otro protocolo, en router de
frontera.
EIGRP Interno rutas aprendidas por eigrp, mtrica 90
EIGRP Externo rutas aprendidas de igrp, mtrica 170
Usa RTP protocolo de transmisin confiable, para transmitir mensajes de EIGRP,
puede ser confiable o no confiable, puede usar Unicast o Multicast.
LOS 5 TIPOS DE PAQUETES EIGRP
SALUDO - Para detectar vecinos y formar adyacencias.
ACTUALIZACION difunde informacin de enrutamiento
RECONOCIMIENTO para reconocer la recepcin de paquetes
CONSULTA y RESPUESTA DUAL (algoritmo de EIGRP) los usa para la bsqueda de
redes. Consulta -> usa multicast y unicast, Respuesta-> unicast.
Caractersticas:
Protocolo de saludo
intervalo entre envo de paquetes de saludo (t1, ethernet) = 5 seg.
- En redes de acceso multiple sin broadcast (frame relay): mensajes unicast cada 60
seg.
Tiempo de HOLD : tiempo mximo para declarar fuera de servicio a un vecino es el
triple del intervalo de saludo. (15 o 180 seg.)
Actualizaciones limitadas: solo cuando hay cambio de estado de ruta, y slo a los
dispositivos afectados.
Actualizaciones parciales: no se enva la tabla de enrutamiento completa.
Minimizand el uso del ancho de banda.

ALGORITMO DUAL
ALGORITMO DE ACTUALIZACION DIFUSA
Evita los bucles de enrutamiento.
Convergencia rpida, mantiene una lista de redes de respaldo sin bucles.
AD distancia administrativa confiabilidad de la ruta de origen.
Rutas eigrp sumarizadas = 5
7

Rutas internas = 90
Rutas externas = 170
Configuracin bsica EIGRP
Router(config)#router eigrp 1
Router(config-router)#network 172.16.0.0
Router(config-router)#network 192.168.3.8 0.0.0.3
Permite el uso de mscara wildcard para seleccionar subred especfica.
El comando para ver la tabla vecina y comprobar que EIGRP ha establecido
adyacencias con los vecinos es:
#show ip eigrp neighbors
Para visualizar la informacin mtrica de EIGRP para la interfaz Serial0/0/0 del router
R1. Observe los valores que se muestran para ancho de banda, demora, confiabilidad
y carga.
R1#show interface serial0/0/0
Cambiar el ancho de banda y retardo de una interfaz:
Router R1:
R1(config)#interface serial0/0/0
R1(config-if)#bandwidth 64
R1(config-if)#delay 10 (se dividio entre 10 los microsegundos)
Verificar con R1#show interface serial0/0/0
Regresar a valor por default: R1#no bandwidth
Un sucesor es la ruta de menor costo hacia la red de destino. Se muestra despus de
la palabra via en la tabla de enrutamiento. equivale como a la dir ip de siguiente salto
o router de siguiente salto
La distancia factible (FD) es la mtrica que se calcula como la ms baja para llegar
al destino
Un sucesor factible es un vecino que tiene una ruta de respaldo viable hacia la
misma red que el sucesor.
Para ser un sucesor factible, el Router debe satisfacer la condicin de factibilidad.
La condicin de factibilidad (FC) se cumple cuando la distancia notificada (RD)
de un vecino hacia una red es menor que la distancia factible del router local hacia la
misma red de destino.
8

Calculo de mtricas:
Ancho de banda:
Retardo:
Mtrica eigrp = (10000000 / BW menor + suma de Retardos / 10 ) * 256
Ver informacin de la mquina de estado del algoritmo DUAL.
#debug eigrp fsm
#debug eigrp packets
Ver la informacin de topologa EIGRP
R2#show ip eigrp topology
Detallada
R2#show ip eigrp topology 192.168.1.0
Todas las rutas hacia un destino
R2#show ip eigrp topology all-links
Ver tabla de adyacencias o vecinos
R2#show ip eigrp neighbors
Desactivar sumarizacion automtica
R3(config)#router eigrp 1
R3(config-router)#no auto-summary
Agregar interfaces loopback
R3(config)#interface loopback1
R3(config-if)#ip address 192.168.2.1 255.255.255.0
Sumarizacion manual EIGRP
R3(config)#interface serial0/0/0
R3(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
Cambiar valores de metrica
(config-router)#metric weights tos k1 k2 k3 k4 k5
(config-router)#metric weights 1 0 1 0 0
Uso de ancho de banda para eigrp en una interfaz
#int s 0/0/0
#bandwidth 64
#ip bandwidth-percent eigrp 1 50
// se usar el 50% del ancho de banda.
#ip hello-interval eigrp 1 60 // cambio de intervalos de mensajes de saludo y hold
#ip hold-time eigrp 1 180
9

CAPITULO 11. OSPF


Tipos de paquetes OSPF
Saludo multicast, intervalo de saludo cada 30 seg. En segmentos NBMA (redes de
acceso multiple sin broadcast), 10 seg, en seriales.
Intervalo muerto tiempo para considerar al vecino inactivo (4 veces tiempo de saludo
)
Descripcion de base de datos DBD
Solicitud de estado de enlace LSR
Actualizacion de estado de enlace LSU
Contienen notificaciones de estado de enlace (LSAs) - vecinos y costos de rutas
Acuse de recibo LSAck
Router DR - router designado. Enva acgtualizacion OSPF a todos los routers.
Router BDR de respaldo por si falla DR.
Algoritmo OSPF
Construyen una base de datos con las actualizaciones LSAs recibidas de los otros
routers.
Se usa el algoritmo SPF de Dijkstra. Crea un rbol SPF. Este rbol se usa para
completar la tabla de enrutamiento.
Distancia administrativa = 110.
Tiene funciones de autenticacin y cifrado, se configuran en las interfaces.
OSPF es classless. Admite VLSM y CIDR.
COMANDOS ospf
R1(config)#router ospf id del procesos
R1(config)#router ospf 1
Comando network: require mascara wildcard y nmero de rea.
La ID del rea: La ID del rea se refiere al rea OSPF. El rea OSPF es un grupo de
routers que comparten informacin sobre el estado de enlace
R1(config-router)#network 172.16.1.16 0.0.0.15 area 0
R1(config-router)#network 192.168.10.4 0.0.0.3 area 0
#passive-interface fa 0/1
ID del Router
Puede ser:
1. Direccin IP configurada con # router-id (mayor prioridad)
2. Si no, entonces usa direccin IP mas alta de cualquier interfaz loopback
10

3. Si no, entonces usa la direccin IP ms alta de cualquier interfaz fsica activa.


Verificar con:
#show ip protocolos
#show ip ospf
#show ip ospf interface
#show ip ospf neighbor
Monitorear el proceso de eleccion
RouterB#debug ip ospf adj
Configuracin de ID de router
1. Usando loopback, se recomienda porque es ms estable su funcionamiento.
#interface loopback 0
#ip address 10.1.1.1 255.255.255.255
2. Con el comando router-id
( )#router ospf 1
(config-router)#router-id 11.2.2.2
Quitar la direccin IP
#clear ip 1 (numero de proceso OSPF)
Verificar con #show ip ospf
Falta de adyacencias se ven si: ID del router vecino se muestra o no se muestra un
estado full.
Si no hay adyacencias: no hay intercambio de informacin, rbol SPF y tablas
inexactas.
En la tabla de enrutamiento:
Se vern rutas con una O, pero OSPF no realiza resumen automtico de rutas en
limites de redes principales.
Por default es la mtrica de OSPF = COSTO

(basado en el ancho de banda)

Se calcula con el valor de referencia 108 / ancho de banda.


Ancho de banda de referencia 100 Mpbs
Cambiar con
#auto-costo reference-bandwidth
Cambiar costo del enlace:
1. Cambiando el ancho de banda:
(config-if)#bandwidth 64 (se calcula como 108/64000=1562)
2.Cambiando el costo directamente:
(config-if)#ip ospf cost 1562 (directamente se registra)
Creacion de ruta de resumen
R3(config)#router ospf 1
R3(config-router)#summary-address 10.10.0.0 255.255.0.0
11

OSPF en redes de acceso mltiple.


Problemas:
Puede haber multiples adyacencias.
Inundacin de LSAs. Por cada LSA debe haber una confirmacin. Trfico.
Solucin: router designado (DR) y de respaldo (BDR). Proceso de eleccin en base a
la prioridad y dir IP.
Los routers envan sus LSA al router DR y BDR a travs de sus interfaces.
El router DR reenva las LSAs a todos los otros routers.
Elecciones.
En punto a punto no hay.
En redes de acceso mltiples es como sigue:
1. Router DR = router con prioridad de interfaz ms alta.
2. BDR = router con segunda prioridad ms alta.
3. Si las prioridades son iguales, se usa la direccin IP del router ms alta para
desempate.
Manipular el proceso: iniciar el router DR, luego el BDR y luego el resto.
O apagar la interfaz y luego encenderlas en el orden deseado para elegir el DR y BDR.
Modificar la prioridad:
(config-if)#ip ospf priority 20 (entre 0 y 255)
0 = el router no se puede convertir en DR o BDR.
1 = default.
Ver con:
#show ip ospf interface fa 0/0
Otras configuraciones
Redistribucin de rutas:
Por ejemplo la ruta esttica por defecto:
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 1
R1(config-router)#default-information originate
Ajustes OSPF
R1(config-router)#auto-cost reference-bandwidth 10000
(debe hacerse en todas las interfaces y routers)
Modificacin manual de los intervalos de saludo y los intervalos muertos:
12

Router(config-if)#ip ospf hello-interval 5


Router(config-if)#ip ospf dead-interval 20
(deben ser los mismos entre vecinos)

MODO EXEC USUARIO


Comando
connect {direccin_ip|
nombre}
disconnect conexin
enable
logout
ping {direccin_ip|nombre}
resume conexin
show cdp
show cdp entry [*|
nombre_dispositivo] [protocol|
version]}
show cdp interfaces [tipo
nmero]
show cdp neighbors [tipo
nmero] [detail]
show clock
show history
show hosts
show ip interface brief
show ip rip database

show ip route [direccin |


protocolo]

Descripcin
Permite conectarse remotamente a un host
Desconecta una sesin telnet establecida desde el
router
Ingresa al modo EXEC Privilegiado
Sale del modo EXEC
Enva una peticin de eco para diagnosticar la
conectividad bsica de red
Resume una sesin telnet interrumpida con la
secuencia CTRL+SHIFT+6 y X
Muestra el intervalo entre publicaciones CDP, tiempo
de validez y versin de la publicacin
Muestra informacin acerca de un dispositivo vecino
registrado en una tabla CDP
Muestra informacin acerca de las interfaces en las
que CDP est habilitado
Muestra los resultados del proceso de descubrimiento
de CDP
Muestra la hora y fecha del router
Muestra el historial de comandos ingresados
Muestra una lista en cach de los nombres de host y
direcciones
Muestra un breve resumen de la informacin y del
estado de una direccin IP
Muestra el contenido de la base de datos privada de
RIP
Muestra el contenido de la tabla de enrutamiento IP.
El parmetro direccin permite acotar la informacin
que se desea visualizar, exclusivamente a la direccin
ingresada. El parmetro protocolo permite indicar la
fuente de aprendizaje de las rutas que se desean
visualizar, como por ejemplo rip, igrp, static y
connected
13

show sessions
show version
telnet {direccin_ip|nombre}
terminal editing
terminal history size
numero_lneas
terminal no editing
traceroute direccin_ip

Muestra las conexiones Telnet establecidas en


router
Muestra informacin sobre el Cisco IOS y
plataforma
Permite conectarse remotamente a un host
Reactiva las funciones de edicin avanzada
Establece el tamao del buffer del historial
comandos
Deshabilita las funciones de edicin avanzada
Muestra la ruta tomada por los paquetes hacia
destino

el
la

de

un

MODO EXEC PRIVILEGIADO


Comando
clear cdp counters
clear cdp table
clear counters
configure memory
configure terminal
copy flash tftp
copy running-config startupconfig
copy running-config tftp
copy tftp flash
copy tftp runnig-config
debug
debug
debug
debug

cdp
cdp
cdp
cdp

adjacency
events
ip
packets

debug ip igrp events


debug ip igrp transactions
debug ip rip
debug ip rip [events]

Descripcin
Restaura los contadores de trfico CDP a cero
Elimina la tabla CDP de informacin de los vecinos
Despeja los contadores de las interfaces
Carga informacin de configuracin de la NVRAM
Configura la terminal manualmente desde la terminal
de consola
Copia la imagen del sistema desde la memoria Flash a
un servidor TFTP
Guarda la configuracin activa en la NVRAM
Almacena la configuracin activa en un servidor TFTP
Descarga una nueva imagen desde un servidor TFTP
en la memoria Flash
Carga la informacin de configuracin desde un
servidor TFTP
Muestra informacin recibida de vecinos CDP
Muestra informacin sobre eventos CDP
Muestra informacin CDP especfica de IP
Muestra informacin relacionada a los paquetes CDP
Muestra todos los eventos IGRP que se estn
enviando y recibiendo en el router.
Muestra las actualizaciones IGRP que se estn
enviando y recibiendo en el router
Muestra informacin sobre las actualizaciones de
enrutamiento RIP mientras el router las enva y recibe
Muestra las actualizaciones de enrutamiento RIP a
medida que se las enva y recibe
14

disable
erase flash
erase startup-config
no debug all
reload
setup
show access-lists [Nro_ACL|
Nom-bre_ACL]
show arp
show cdp traffic
show controllers serial
[nmero]
show debugging
show flash
show interfaces [tipo nmero]
show ip interface [tipo
nmero]
show ip protocols [summary]
show memory
show processes
show protocols
show running-config
show sessions
show stacks
show startup-config
terminal monitor
undebug all

Sale del modo EXEC Privilegiado hacia el modo EXEC


Usuario
Borra el contenido de la memoria Flash
Borra el contenido de la NVRAM
Desactiva todas las depuraciones activadas en el
dispositivo
Reinicia el router
Entra a la facilidad de Dilogo de configuracin inicial
Muestra el contenido de todas las ACL en el router.
Para ver una lista especfica, agregue el nombre o
nmero de ACL como opcin a este comando
Muestra la asignacin de direcciones IP a MAC a
Interfaz del router
Muestra los contadores CDP, incluyendo el nmero de
paquetes enviados y recibidos, y los errores de
checksum
Muestra informacin importante como que tipo de
cable se encuentra conectado
Muestra informacin acerca de los tipos de
depuraciones que estn habilitados
Muestra la disposicin y contenido de la memoria
Flash
Muestra estadsticas para la/las interfaces indicadas
Muestra los parmetros de estado y globales
asociados con una interfaz
Muestra los parmetros y estado actual del proceso
de protocolo de enrutamiento activo
Muestra estadsticas acerca de la memoria del router,
incluyendo estadsticas de memoria disponible
Muestra informacin acerca de los procesos activos
Muestra los protocolos de capa 3 configurados
Muestra la configuracin actual en la RAM
Muestra las conexiones Telnet establecidas en el
router
Controla el uso de la pila de procesos y rutinas de
interrupcin y muestra la causa del ltimo rearranque
del sistema
Muestra la configuracin que se ha guardado, que es
el contenido de la NVRAM
Si se utiliza una sesin por telnet para examinar el
router, entonces, permite redirigir el resultado y los
mensajes del sistema hacia a terminal remota
Desactiva todas las depuraciones activadas en el
dispositivo
15

MODO DE CONFIGURACIN GLOBAL


Comando

Descripcin
Crea o agrega una sentencia de condicin a la ACL
que permitir o denegar los paquetes que llegan
access-list Nro_ACL {permit|
desde un Origen. Este ltimo parmetro puede ser
deny} Origen
una direccin IP ms una mscara wildcard, la palabra
host ms una direccin IP o el wildcard any
Crea o agrega una sentencia de condicin a la ACL
que permitir o denegar los paquetes que lleguen
desde un Origen y vayan hacia un Destino. Proto
identifica el protocolo a verificar. Origen y Destino
access-list Nro_ACL {permit|
pueden ser una direccin IP ms una mscara
deny} Proto Origen Destino
wildcard, la palabra host ms una direccin IP o el
[Operador Nro_puerto]
wildcard any. Operador puede ser lt (menor que), gt
[established][echo |echo-reply] (mayor que), eq (igual a) o neq (distinto a).
Nro_puerto indica el puerto TCP o UDP. El parmetro
established permite el paso de trfico cuando hay una
sesin establecida. En el caso del protocolo ICMP se
puede utilizar echo o echo-reply.
Banner motd #mensaje del
Configura un cartel con un mensaje del da. Ej: banner
da#
motd #Bienvenido#
boot system flash [nombre_im- Especifica que el router cargue el IOS desde la Flash
agen_IOS]
Ej: boot system flash c2500-IOS
boot system rom
Especifica que el router cargue el IOS desde la ROM
Especifica que el router cargue el IOS desde un
boot system tftp nombre_imaservidor TFTP.
gen_IOS dir_IP_server_tftp
Ej: boot system tftp c2500-IOS 24.232.150.1
cdp run
Habilita CDP globalmente en el router
clock set hh:mm:ss mes da
Modificar la fecha y hora del router. Ej: clock set
ao
12:31:00 July 12 2004
config-register
Cambia los valores del registro de configuracin.
valor_registro_configuracin
Ej: config-register 0x2142
Establece una contrasea local para controlar el
enable password contrasea
acceso a los diversos niveles de privilegio. Ej: enable
password class
Especifica una capa de seguridad adicional mediante
enable secret contrasea
el comando enable password. Ej: enable secret class
hostname nombre
Modifica el nombre del router. Ej: hostname Lab_A
Configura un tipo de interfaz y entra al modo de
interface tipo nmero
configuracin de interfaz.
Ej: interface ethernet 0
ip access-list {16tandard|
Permite crear una ACL nombrada. Se debe indicar el
extended} Nombre
tipo. Este comando ingresa al router al submodo de
configuracin que puede reconocerse por el prompt
16

Router(config-ext-nacl)#
Permite que el router no tome en cuenta los lmites
con definicin de clases de las redes en su tabla de
ip classless
enrutamiento y simplemente transmita hacia la ruta
por defecto
ip default-network
Establece una ruta por defecto. Ej: ip default-network
direccin_red
210.32.45.0
Habilita la conversin de nombre a direccin en el
ip domain-lookup
router
Crea una entrada de nombre a direccin esttica en el
ip host nombre_host dir_ip1 .
archivo de configuracin del router. Ej: ip host Lab_A
Dir_ip8
192.168.5.1 210.110.11.1
Permite que el router acte como servidor Web http
ip http server
limitado
Especifica las direcciones de hasta seis servidores de
ip name-server dir_ip1 .
nombres para su uso para la resolucin de nombres y
Dirip6
direcciones.
Ip route direccin_red mscara
Establece rutas estticas.
dir_ip_salto
Ej: ip route 210.42.3.0 255.255.255.0 211.1.2.1
[distancia_administrativa]
Identifica una lnea especfica para la configuracin e
line tipo nmero
inicia el modo de reunin de comandos de
configuracin. Ej: line console 0 line vty 0 4
router
Inicia un proceso de enrutamiento definiendo en
protocolo_de_enrutamiento
primer lugar un protocolo de enrutamiento IP. Ej:
[nro_AS]
router rip router igrp 120
service password-encryption
Habilita la funcin de cifrado de la contrasea

SUBMODO DE CONFIGURACIN DE INTERFAZ


Comando
bandwidth Kbps
cdp enable
cdp holdtime segundos
cdp timer segundos
clock rate velocidad
description descripcin

Descripcin
Establece un valor de ancho de banda para una
interfaz. Ej: bandwidth 64
Habilita Cisco Discovery Protocol en una interfaz
Especifica el tiempo de espera antes de ser enviada la
siguiente actualizacin CDP
Especifica la frecuencia con que son envadas
actualizaciones CDP
Configura la velocidad de reloj para las conexiones de
hardware en interfaces seriales, como mdulos de
interfaz de red y procesadores de interfaz a una
velocidad de bits aceptable. Ej: clock rate 56000
Agrega una descripcin a la interfaz.
Ej: description Conectada a Internet
17

ip access-group Nro_ACL [in|


out]
ip address direccin_ip
mascara_red
no ip route-cache
no ip split-horizon
no shutdown
shutdown

Asigna la ACL indicada a la interfaz, ya sea para que


verifique los paquetes entrantes (in) o los salientes
(out)
Asigna una direccin y una mscara de subred e inicia
el procesamiento IP en una interfaz. Ej: ip address
192.168.52.1 255.255.255.0
Para deshabilitar el balanceo de carga por destino,
que est habilitado por defecto
Deshabilita el horizonte dividido en la interfaz, que
por defecto se encuentra habilitado. Para volver
habilitarlo utilice el comando ip split-horizon
Reinicia una interfaz desactivada
Inhabilita una interfaz

SUBMODO DE CONFIGURACIN DE LINEA


Comando
access-class Nro_ACL in
login
password contrasea

Descripcin
En las lneas VTY, asigna una lista de control de
acceso a las conexiones establecidas via Telnet
Habilita la verificacin de contrasea en el momento
de la conexin.
Asigna la contrasea a ser solicitada en el momento
de la conexin

SUBMODO DE CONFIGURACIN DEL PROTOCOLO DE


ENRUTAMIENTO
Comando

Descripcin
Permite modificar el mximo de rutas sobre las que
maximum-paths valor
balancear la carga
Permite modificar los valores de las constantes
utilizadas para el clculo de las mtricas de las rutas
metric weights tos k1 k2 k3 k4
en el protocolo de enrutamiento IGRP. Los valores por
k5
defecto son: tos (tipo de servicio)= 0; k1= 1; k2= 0;
k3= 1; k4= 0 y k5= 0
Como RIP es un protocolo de tipo broadcast, el
administrador de la red podra tener que configurarlo
para que intercambie informacin de enrutamiento en
neighbor direccin_ip
redes no broadcast, como en el caso de las redes
Frame Relay. En este tipo de redes, RIP necesita ser
informado de otros routers RIP vecinos
network direccin_red
Asigna una direccin de red a la cual el router se
18

no timers basic
passive-interface tipo nmero

redistribute static

timers basic Actualizacin


Invlida Espera Purga
[Suspensin]

variance valor

encuentra directamente conectado, lo que hara que


se envi y reciba publicaciones de enrutamiento a
travs de esa interfaz, adems de que dicha red sea
publicada a los routers vecinos.
Ej: network 210.45.2.0
Regresa los temporizadores a los valores por defecto
El router no enviar informacin de enrutamiento por
la interfaz indicada.
Ej: passive-interface serial 0
Si se asigna una ruta esttica a una interfaz que no
est definida en el proceso RIP o IGRP, mediante el
comando network, no ser publicada la ruta a menos
que se especifique este comando
Indica la frecuencia con la que RIP o IGRP envan
actualizaciones y los intervalos de los temporizadores.
Actualizacin: intervalo en segundos a la que se
envan las actualizaciones (RIP: 30 seg; IGRP: 90 seg).
Invlida: Intervalo de tiempo en segundos despus del
cual una ruta se declara no vlida. Sin embargo, la
ruta todava se utiliza para el envo de paquetes (RIP:
180 seg; IGRP: 270 seg).
Espera: Intervalo en segundos durante el cual se
suprime la informacin de enrutamiento que se
refiere a las mejores rutas (RIP: 180 seg; IGRP: 280
seg).
Purga: Intervalo de tiempo en segundos que debe
transcurrir antes de que la ruta se elimine de la tabla
de enrutamiento (RIP: 240 seg; IGRP: 630 seg).
Suspensin: Intervalo en milisegundos en que se
posponen las actualizaciones de enrutamiento de
cuando se produce una actualizacin flash. Slo IGRP
El valor de variacin determina si IGRP aceptar rutas
de costo desigual. Slo aceptar rutas iguales a la
mejor mtrica local para el destino multiplicado por el
Valor de variacin. El valor puede variar de 1 (por
defecto) a 128

COMANDOS DE EDICIN y OTROS


Teclas / Comando
Ctrl+A
Esc+B
Ctrl+B (o Flecha Izquierda)

Descripcin
Permite desplazarse al principio de la lnea de
comandos
Permite desplazarse una palabra hacia atrs
Permite desplazarse un carcter hacia atrs
19

Ctrl+E
Ctrl+F (o Flecha Derecha)
Ctrl+P (o Flecha Arriba)
Ctrl+N (o Flecha Abajo)
<Tab> (tecla Tabulador)
Ctrl+Z (o end)
Ctrl+C
Ctrl+Shift+6
exit

Permite desplazarse hasta el final de la lnea de


comandos
Permite desplazarse un carcter hacia delante
Muestra el ltimo comando ingresado
Muestra el comando ms reciente
Completa el comando ingresado parcialmente
Estando en cualquier modo de configuracin regresa
al modo EXEC Privilegiado
Cancela la ejecucin del Dialogo de configuracin
inicial o Setup
Permite interrumpir intentos de ping, traceroute y
traducciones de nombres
Estando en el modo de configuracin global o
cualquiera de sus submodos regresa al modo anterior.
Estando en los modos EXEC Usuario o EXEC
Privilegiado, cierra la sesin

20