Sie sind auf Seite 1von 20

CCNA VOICE LAB NUMBER 1

REQUIRED :
CONFIGURE THE ROUTER AS CME AND OPERATE 2 IP PHONE AS FOLLOW:
IP PHONE 1
-SHOULD HAVE TWO EXTENSIONS (1000 , 2000)
-ANY ONE CALL 1000 NEVER GET BUSSY SIGNALING
IP PHONE 2
-SHOULD HAVE EXTINSIONS (1003)
-if it is on call a busy signaling should be sent to the caller

SOLUTION:
1- prepare the lab
I will use the following tools :you can easily find them on the internet
1.
2.
3.
4.
5.
6.
7.
8.

GNS3-1.1-all-in-one .exe
VirtualBox-4.3.18-96516-Win.exe
c3745-ipvoicek9-mz.124-9.T.bin
Tftpd64-4.50-setup.exe
cme-full-4.3.0.0.tar
7z920.exe
windows XP CDs
Cisco ip communicator v8.6.1.0.exe

1- configuring the VirtualBox


after installing the Virtual Box do the following
create two VMs with windows XP 32bit
as shown

after that you will find the two interfaces was created as following

configure the network interface as host only for both VMs

2- configuring GNS3
- now install GNS3 and configure it as

follow considering that you browse the directory or the folder contain the IOS .

linking GNS 3 with the Virtual Box


from GNS3

creating the topology

now configure the clouds to connect via virtual box interface to the VMs as follow
right click on the cloud and chose configure

Now it time to configure the router


first of all you should increase the router flash because we will extract the CME file which contain the
configuration and the firmware of all the ephones in the flash

!CONFIGURE THE ROUTER TO WORK AS DHCP SERVER


ip dhcp pool LabVoice
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
option 150 ip 192.168.1.1
now from the vms make sure they received the ip address from the router
or from the the router do show ip dhcp bind and it will show you the token ips
now i will make one vm as tftp server to extract the CME FILE to the router flash
so i configured shared Folder as shown to put the tftp serve program and the cme-full.4.3.0.0.tar

and this is the files required

now i will

at this point we did not configure any voice commands


now lets start by extracing the CME file to the router flash
from the VM which will be TFTP sever after installing the Tftpd32-4.50-setup.exe

now from the router do the following command


R1#archive tar /xtract tftp://192.168.1.2/cme-full.4.3.0.0.tar flash:
after the extract is done

lets voip
telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.1.1 port 2000
max-conferences 8 gain -6
!

!CREATE DN 1 WITH NUMBER 1000 AND MAKE IT DUAL LINE


ephone-dn 1 dual-line
number 1000

! CREATE DN 2 WITH NUMBER 2000 AND MAKE IT DUAL LINE


ephone-dn 2 dual-line
number 2000

! CREATE DN 3 WITH NUMBER 1003


ephone-dn 3
number 1003

!REGISTER EPHONE 1 TO THE MAC ADD OF THE PHYSICAL IP PHONE 1 (YOU CAN FIND THE
MAC ON !THE BACK OF THE IP PHONE OR USE THE COMMAND SHOW EPHONE AND COPY
PAST THE MAC)
ephone 1
mac-address 0800.27AC.A780

!NOW ASSIGN THE DN1 (1000) TO BUTTON 1 ON THE EPHONE 1


!AND ASSIGN THE DN2 (2000) TO BUTTON 2 ON THE EPHONE 1
button 1:1 2:2

! REGISTER EPHONE 2 TO THE MAC ADD OF THE PHYSICAL IP PHONE 2


ephone 2
mac-address 0800.27E7.0EA8

!NOW ASSIGN THE DN3 (1003) TO BUTTON 1 ON THE EPHONE2


button 1:3
at this point you made voip network connection and you can make call from VM 1 to VM 2

this is show run from the router


R1#sh run
Building configuration...
Current configuration : 1433 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip dhcp use vrf connected

!CONFIGURE THE ROUTER TO WORK AS DHCP SERVER


ip dhcp pool LabVoice

network 192.168.1.0 255.255.255.0


default-router 192.168.1.1
dns-server 8.8.8.8
option 150 ip 192.168.1.1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
ip ssh version 1
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!DEFINE THE MAX NUMBER OF EPHONES AND DNs AND THE INTERFACE AND THE PORT THAT WILL
!CONNECT TO THE EPHONES
telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.1.1 port 2000
max-conferences 8 gain -6
!

!CREATE DN 1 WITH NUMBER 1000 AND MAKE IT DUAL LINE


ephone-dn 1 dual-line
number 1000

! CREATE DN 2 WITH NUMBER 2000 AND MAKE IT DUAL LINE


ephone-dn 2 dual-line
number 2000

! CREATE DN 3 WITH NUMBER 1003


ephone-dn 3
number 1003

!REGISTER EPHONE 1 TO THE MAC ADD OF THE PHYSICAL IP PHONE 1 (YOU CAN FIND THE
MAC ON !THE BACK OF THE IP PHONE OR USE THE COMMAND SHOW EPHONE AND COPY
PAST THE MAC)
ephone 1
mac-address 0800.27AC.A780

!NOW ASSIGN THE DN1 (1000) TO BUTTON 1 ON THE EPHONE 1


!AND ASSIGN THE DN2 (2000) TO BUTTON 2 ON THE EPHONE 1
button 1:1 2:2

! REGISTER EPHONE 2 TO THE MAC ADD OF THE PHYSICAL IP PHONE 2


ephone 2
mac-address 0800.27E7.0EA8

!NOW ASSIGN THE DN3 (1003) TO BUTTON 1 ON THE EPHONE2


button 1:3
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R1#