Sie sind auf Seite 1von 7

COMANDO

PORTUGOL

C#

Varivel tipo

i: inteiro

sbyte i;

inteiro

short i;
int i;
long i;

byte i;
ushort i;
uint i;
ulong i;
Varivel tipo

d: real

real

float d;
double d;
decimal d:

Varivel tipo

b: logico

bool b;

s: caractere

char s;

lgico
Varivel tipo
texto
Varivel tipo

string s;
v: vetor[linha1..linhaN] detipo

tipo[] v = new tipo[linhas];

Varivel tipo

m: vetor[linha1..linhaN,coluna1..colunaN]

tipo[,] m = new tipo[linhas, colunas];

matriz

de tipo

Exemplos de

vetor

3 // int

literais

3L // long

(valores) do

3U // unsigned int

tipo inteiro

3UL // unsigned long

Exemplos de

3.14

3.14F // float

literais

3.14 // double

(valores) do

3.14M // decimal

tipo real
Exemplos de

FALSO

false

literais

VERDADEIRO

true

(valores) do

COMANDO

PORTUGOL

C#

"texto entre aspas"

'C' // char

tipo lgico
Exemplos de
literais

"texto entre aspas" // string

(valores) do
tipo texto
Ler valor tipo

leia(i)

inteiro

i = sbyte.Parse(Console.ReadLine());
i = short.Parse(Console.ReadLine());
i = int.Parse(Console.ReadLine());
i = long.Parse(Console.ReadLine());

i = byte.Parse(Console.ReadLine());
i = ushort.Parse(Console.ReadLine());
i = uint.Parse(Console.ReadLine());
i = ulong.Parse(Console.ReadLine());
Ler valor tipo

leia(d)

real

d = float.Parse(Console.ReadLine());
d = double.Parse(Console.ReadLine());
d = decimal.Parse(Console.ReadLine());

Ler valor tipo

leia(b)

b = bool.Parse(Console.ReadLine());

leia(s)

s = char.Parse(Console.ReadLine());

lgico
Ler valor tipo
texto

s = Console.ReadLine();

Escrever

escreva(...)

Console.Write(...);

Escrever,

escreval(...)

Console.WriteLine(...);

escreva(..., a, ..., b, ...)

Console.Write("...{0}...{1}...", a, b, );

pulando linha
Escrever com
parmetros

Para saber mais opes de formatao, consulte


a documentao do C#.

Escrever com

escreval(..., a, ..., b, ...)

Console.WriteLine("...{0}...{1}...", a, b, );

parmetros,

Para saber mais opes de formatao, consulte

pulando linha

a documentao do C#.

Limpar tela

limpatela

Console.Clear();

Operao de

a <- b

a = b;

COMANDO

PORTUGOL

C#

a+b

a+b

a-b

a-b

a*b

a*b

a/b

a/b

a\b

a/b

atribuio
(recebe)
Operao de
adio
Operao de
subtrao
Operao de
multiplicao
Operao de
diviso
Operao de
diviso inteira

(sendo a e b inteiros)

Operao de

a%b

resto da

a mod b

a%b

diviso
Operao de

a^b

Math.Pow(a, b)

RaizQ(a)

Math.Sqrt(a)

Operao de

"texto" + "texto"

"texto" + "texto"

concatena

"texto" + a

"texto" + a

a + "texto"

a + "texto"

Operao de

v[ndice da linha]

v[ndice da linha]

potenciao
Operao de
raiz quadrada

acesso a um

(ndice comea em 0 e termina em tamanho - 1)

valor do vetor
Operao de

m[ndice da linha, ndice da coluna]

acesso a um

m[ndice da linha, ndice da coluna]


(ndices comeam em 0 e terminam em tamanho - 1)

valor da
matriz
Operao de
acesso ao

(no tem operador especfico)

v.Length

COMANDO

PORTUGOL

C#

(no tem operador especfico)

m.Length

(no tem operador especfico)

m.Rank

(no tem operador especfico)

m.GetLength(ndice da dimenso)

tamanho do
vetor
Operao de
acesso ao
tamanho da
matriz
Operao de
acesso
quantidade
de
dimenses
da matriz
Operao de
acesso ao

(ndices comeam em 0 e terminam em tamanho - 1)

tamanho das
dimenses
da matriz
Operao

a<b

a<b

a <= b

a <= b

a>b

a>b

a >= b

a >= b

a=b

a == b

a <> b

a != b

aeb

a && b

menor
Operao
menor ou
igual
Operao
maior
Operao
maior ou
igual
Operao
igual
Operao
diferente
Operao e

COMANDO

PORTUGOL

C#

Operao ou

a ou b

a || b

Operao ou-

a xou b

(no tem operador especfico)

nao a

!a

(no tem operador especfico)

a&b

(no tem operador especfico)

a|b

(no tem operador especfico)

a^b

(no tem operador especfico)

~a

Operao de

(no tem operador especfico,

a++

incremento

mas pode ser feito com a <- a + 1)

++a

Operao de

(no tem operador especfico,

a--

decremento

mas pode ser feito com a <- a - 1)

--a

Operao

(no tem operador especfico)

a op= b

exclusivo
Operao de
negao
Operao bita-bit e
Operao bita-bit ou
Operao bita-bit ouexclusivo
Operao bita-bit de
negao

com

( o mesmo que a = a op b)

atribuio
Comando seento

Comando seento-seno

Comando se-

se condio entao

if (condio) {

...

...

fimse

se condio entao

if (condio) {

...

...

senao

} else {

...

...

fimse

se condio1 entao

if (condio1) {

COMANDO

PORTUGOL

C#

ento-seno

...

...

encadeados

senao

} else {

se condio2 entao

if (condio2) {

...

...

senao

} else {

...

...

fimse

Comando se-

fimse

se condio1 entao

if (condio1) {

ento-seno

...

encadeados

senao

(verso

...
} else if (condio2) {

se condio2 entao

melhorada do

...

...

C#)

senao

} else {

...

...

fimse

Comando

fimse

escolha varivel

switch (varivel) {

caso valor1

case valor1:

escolha-caso

...

...
break;

caso valor2, valor3

case valor2:
case valor3:

...

...
break;

outrocaso

default:

...

...
break;

Comando

fimescolha

enquanto condio faca

while (condio) {

enquanto-

...

...

faa

fimenquanto

Comando

para varivel de valor1 atevalorN passo P fac

for (varivel = valor1; varivel <= valorN;varivel += P) {

para

...
...

fimpara

COMANDO

PORTUGOL

C#

Comando

repita

(no tem comando especfico)

repita-at

...

(termina com

ate condio

condio
verdadeira)
Comando

(no tem comando especfico)

do {

faa-

...

enquanto

} while (condio);

(termina com
condio
falsa)
Comando de

interrompa

break;

(no tem comando especfico)

continue;

Criar

procedimentonome(parmetro: tipo; ...)

static void nome(tipo parmetro, ...) {

procedimento

var

interrupo
Comando de
prxima
iterao

...
inicio
...

Criar funo

...

fimprocedimento

funcao nome(parmetro:tipo; ...): tipo

static tipo nome(tipo parmetro, ...) {

var
...
inicio
...

...

retorne valor

Chamar

return valor;

fimfuncao

nome(valor, ...)

nome(valor, ...);

a <- nome(valor, ...)

a = nome(valor, ...);

procedimento
Chamar
funo