Sie sind auf Seite 1von 4

5/14/2015

FacingissueinClusterconfigurationRedHatCustomerPortal

C USTO ME R PO RTAL

3 For more information on the VENOM QEMU (CVE-2015-3456) security vulnerability please
refer to this Knowledge Article (https://access.redhat.com/articles/1444903).

3 Support Cases will be unavailable at times on May 17 for scheduled maintenance. More
details (https://access.redhat.com/announcements/1448893).

Products & Services

Knowledgebase

Solutions

Facing issue in Cluster conguration

Facing issue in Cluster


configuration

( Updated June 11 2012 at 4:24 PM

0 Issue
https://access.redhat.com/solutions/139733

1/4

5/14/2015

FacingissueinClusterconfigurationRedHatCustomerPortal

Facing some issue by setting up RH6.2 with cluster


software. The problem are to get the cluster.conf
validated to be able to use cman_tool to distribute the
le to the other cluster nodes.
Getting the below error:
#cman_toolversionr
tempfile:31:elementfailoverdomains:RelaxNGvalidityerror:Elementclusterhasextracontent:failoverdomains
Configurationfailstovalidate

Cluster Conguration looks like below:


#cat/etc/cluster/cluster.conf
<?xmlversion="1.0"?>
<clusterconfig_version="21"name="MyCluster">
<clusternodes>
<clusternodename="node1.example.com"nodeid="1"votes="1">
<fence>
<methodname="fence">
<devicename="fencenode1"/>
</method>
</fence>
</clusternode>
<clusternodename="node2.example.com"nodeid="2"votes="1">
<fence>
<methodname="fence">
<devicename="fencenode2"/>
</method>
</fence>
</clusternode>
<clusternodename="node3.example.com"nodeid="3"votes="1">
<fence>
<methodname="fence">
<devicename="fencenode3"/>
https://access.redhat.com/solutions/139733

2/4

5/14/2015

FacingissueinClusterconfigurationRedHatCustomerPortal

</method>
</fence>
</clusternode>
</clusternodes>
<fencedevices>
<fencedeviceagent="fence_ipmilan"ipaddr="xx.xx.xx.xx"lanplus="on"login="cluster"name="fencenode1"passwd="yyyyy"
<fencedeviceagent="fence_ipmilan"ipaddr="xx.xx.xx.xx"lanplus="on"login="cluster"name="fencenode2"passwd="yyyyy"
<fencedeviceagent="fence_ipmilan"ipaddr="xx.xx.xx.xx"lanplus="on"login="cluster"name="fencenode3"passwd="yyyyy"
</fencedevices>
<failoverdomains/>
<resources/>
<vmautostart="0"exclusive="0"migrate="live"name="l1010s"path="/etc/libvirt/qemu"recovery="restart"/>
<vmautostart="0"exclusive="0"migrate="live"name="l1011s"path="/etc/libvirt/qemu"recovery="restart"/>
<cmantransport="udpu"/>
</cluster>

, Resolution
<failoverdomains> tag should be within <rm></rm>

tags but there is no <rm> tag in the cluster.conf and also


as there is nothing in their <failoverdomains> it is
good to remove it out and check.
Note: If your doing any changes on the cluster.conf, we
recommend you to take the backup rst.

Product(s)

https://access.redhat.com/solutions/139733

3/4

5/14/2015

FacingissueinClusterconfigurationRedHatCustomerPortal

Red Hat Enterprise Linux (https://access.redhat.com/search/#/?q=product:


("Red+Hat+Enterprise+Linux"))

Comments
Add new comment

Formatting Help

SUBMIT COMMENT

Privacy Policy (http://www.redhat.com/en/about/privacy-policy)


Customer Portal Terms of Use (https://access.redhat.com/help/terms/)
All Policies and Guidelines (http://www.redhat.com/en/about/all-policies-guidelines)
Copyright 2015 Red Hat, Inc.

https://access.redhat.com/solutions/139733

4/4