Sie sind auf Seite 1von 5

EIGRP Solutions

EIGRP Split Horizon

interface Serial0/0
no ip split-horizon eigrp 100

EIGRP MD5 Authentication


key chain MD5_KEYS
key 1
key-string CISCO
!
interface Serial0/0
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 MD5_KEYS

EIGRP Key Chain Rotation


R1, R2, R4:
key chain KEY_ROTATION
key 10
key-string CISCO10
accept-lifetime 00:00:00 Jan 1 1993
00:15:00 Jan 1 2030
send-lifetime 00:00:00 Jan 1 1993 00:05:00
Jan 1 2030
key 20
key-string CISCO20
accept-lifetime 00:00:00 Jan 1 2030 infinite
send-lifetime 00:00:00 Jan 1 2030 infinite
!
interface Serial0/0.1 point-to-point
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100
KEY_ROTATION

EIGRP Unicast Updates


router eigrp 100
neighbor 155.1.58.8 FastEthernet0/0

R5:
key chain KEY_ROTATION
key 10
key-string CISCO10
accept-lifetime 00:00:00 Jan 1 1993
00:15:00 Jan 1 2030
send-lifetime 00:00:00 Jan 1 1993
00:05:00 Jan 1 2030
key 20
key-string CISCO20
accept-lifetime 00:00:00 Jan 1 2030 infinite
send-lifetime 00:00:00 Jan 1 2030 infinite
!
interface Serial0/0 point-to-point
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100
KEY_ROTATION

EIGRP Summarization
interface Serial0/1
ip summary-address eigrp 100 30.0.0.0
255.252.0.0 5

EIGRP Default Network


router eigrp 100
redistribute eigrp 10
!
ip default-network 200.0.0.0
default network

<< advertises the network 200.0.0.0/24 as the

EIGRP Summarization with Default Routing

interface Serial0/1
ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5 << only advertises a default route
out this interface

EIGRP Summarization with Leak Map


interface Serial0/1
ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5 leak-map LEAK_LOOPBACK0
!

ip prefix-list LOOPBACK0 seq 5 permit 150.1.4.0/24


!
route-map LEAK_LOOPBACK0 permit 10
match ip address prefix-list LOOPBACK0

EIGRP Floating Summarization


R5:interface FastEthernet0/0
ip summary-address eigrp 100 150.1.4.0 255.255.254.0 5
!
ip route 150.1.4.0 255.255.254.0 155.1.0.4
Note: By default, a route will be installed to null0. R5 manually installs a route to R4
so SW2 will have reachability to R4.

EIGRP Poisoned Floating Summarization


interface FastEthernet0/0
ip summary-address eigrp 100 150.1.4.0 255.255.254.0 255 << route to Null0 is
not installed

EIGRP Metric Weights


router eigrp 100
metric weights 0 0 0 1 0 0
calculation

<< only delay is used in the composite metric

EIGRP Traffic Engineering with Metric


interface Vlan67
delay 100000

EIGRP Unequal Cost Load Balancing

router eigrp 100


variance 128

Feasibility Condition - If the Advertised Distance of an alternate route is lower than


the Feasible Distance of the Successor, the route is a loop free path and can be
considered for load balancing. In other words if R1s metric to reach SW3 is lower than

R6s metric to reach SW3, R6 can assume that R1 is closer to SW3, and is a loop free
path.
interface FastEthernet0/0.67
no ip route-cache
ip load-sharing per-packet

interface FastEthernet0/0.146
no ip route-cache
ip load-sharing per-packet

EIGRP Convergence Timers


interface FastEthernet0/0
ip hello-interval eigrp 100 1
ip hold-time eigrp 100 3
!
router eigrp 100
timers active-time 1

<< Hellos are sent every 1 second


<< holdtime set to 3seconds

NOTE: Unlike OSPF, EIGRP hello intervals do not need to match in order to form
adjacency. Instead, the neighbor sending the hello packet tells the adjacent router
what its hold time is for that particular hello. Routes are considered Stuck In Active if
a query response has not been heard within one minute.

EIGRP Stub Routing (Router does not receive EIGRP query messages)
router eigrp 100
eigrp stub connected

<< will only advertise its connected routes

EIGRP Stub Routing with Leak Map


R5#ip prefix-list SW2_LOOPBACK seq 5 permit 150.1.8.0/24
!
route-map STUB_LEAK_MAP deny 10
match ip address prefix-list SW2_LOOPBACK
!
route-map STUB_LEAK_MAP permit 20
!
router eigrp 100
eigrp stub connected leak-map STUB_LEAK_MAP
NOTE: R5 is configured to leak all dynamically learned routes except SW2s Loopback

EIGRP Filtering with Passive Interface (EIGRP hello packets are not sent)
router eigrp 100
passive-interface default
no passive-interface Vlan67
no passive-interface FastEthernet0/3
NOTE: The passive-interface command in EIGRP, like in RIPv2, stops the sending of
updates out an interface. Unlike RIPv2 however, passive-interface in EIGRP will stop
the forming of an adjacency.

EIGRP Filtering with Prefix-Lists


router eigrp 100
distribute-list prefix STOP_RIP_SUBNETS out Serial0/1
!
ip prefix-list STOP_RIP_SUBNETS seq 5 deny 30.0.0.0/14 ge 16 le 16
ip prefix-list STOP_RIP_SUBNETS seq 10 deny 31.0.0.0/14 ge 16 le 16
ip prefix-list STOP_RIP_SUBNETS seq 15 permit 0.0.0.0/0 le 32

EIGRP Filtering with Standard Access-Lists


router eigrp 10

distribute-list 1 in Serial0/0
!
access-list 1 permit 0.0.0.0 255.255.254.255
routes
3rd Octet host: 00000000 = 0
3rd Octet Mask: 1111111X = 254

<< only permits even 3rd octet

(1st bit is fixed 0)

EIGRP Filtering with Extended Access-Lists (deny routes from specific


sources)
access-list 100 deny ip host 155.1.0.2 host 150.1.7.0
source R2
access-list 100 deny ip host 155.1.0.1 host 150.1.4.0
source R1
access-list 100 deny ip host 155.1.0.3 host 150.1.1.0
source R3
access-list 100 permit ip any any
!
router eigrp 100
distribute-list 100 in Serial0/0

<< Deny R7 loopback from


<< Deny R4 loopback from
<< Deny R1 loopback from

EIGRP Filtering with Offset Lists (modify the metric on a per route /
interface basis)
router eigrp 100
offset-list 1 in 2147483647 FastEthernet0/3
!
access-list 1 permit 150.1.3.0

EIGRP Filtering with Administrative Distance (distance <AD> <source


address> <ACL>
access-list 4 permit 150.1.4.0
!
router eigrp 100
distance 255 0.0.0.0 255.255.255.255 4

EIGRP Filtering with Route Maps


router eigrp 100
distribute-list route-map FILTER_ON_METRIC_RANGE in
!
route-map FILTER_ON_METRIC_RANGE deny 10
match metric 625000 +- 125000 / match tag 4
!
route-map FILTER_ON_METRIC_RANGE permit 20

EIGRP Bandwidth Pacing (EIGRP cannot use more than a specified BW


percentage)
R2#interface Serial0/1
bandwidth 1544
ip bandwidth-percent eigrp 100
10

R3#interface Serial1/3
bandwidth 1544
ip bandwidth-percent eigrp 100
10

EIGRP Default Metric


router eigrp 100
default-metric 100000 10 255 1 1500 << default metric for redistributed routes

EIGRP Neighbor Logging


router eigrp 100
no eigrp log-neighbor-changes
events.
eigrp log-neighbor-warnings 20
every 20s.

<< does not log EIGRP neighbor adjacency


<< EIGRP warning logs will be generated

EIGRP Router-ID
router eigrp 100
eigrp router-id 150.1.2.2
NOTE: EIGRP uses the router-id field in external routes as loop prevention. If an
update is received back in with a router-id in this field matching the local router-id,
the update is dropped.

EIGRP Maximum Hops


router eigrp 100
metric maximum-hops 10
considered invalid

<< routes with a hop count greater than 10 are