You are on page 1of 3

SWITCH EXAM QUESTIONs

MY QUESTIONS
1. What is VTP?. Explain its operation and various modes
2. What is DTP?. Explain its operation.
3. Explain how Private VLAN works. A diagram may help your explanation
4. What is a VLAN? Discuss the benefits. Describe best practices for VLAN desig
n?
5. What does the following command do?
switch(config-if)# switch port host
6.What is the purpose of Trunking in a Cisco switch environment? What are the b
enefits. What are the protocols used.
7. Explain the content of the following show command
Switch# show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 2
Number of aggregators: 2
Group
Port-channel Protocol
Ports
------+-------------+-----------+------------------------------------------2
Po2(SU)
LACP
g0/49(P) g0/50(P) g0/51(P) g0/52(P
)
7
Po7(SU)
LACP
g0/47(P) g0/48(P)
9
Po9(SU)
PAgP
g0/8(P) g0/9(P)
8. Explain the concept of Etherchannel. A diagram might help your explanation
9. What does the following command do?
Switch(config)# port-channel load-balance src-dst-ip
10.Explain the following terms as used in Spanning Tree Protocol.
Root Bridge
Root Port
Designated Port
Non-Designated Port
Also draw a diagram showing how the above terms are interrelated.
11. What is the default spanning tree mode for Cisco Catalyst switches and expla
in its operation?
12. What is the purpose of Spanning Tree port fast? How would you configure it o
n interface fast ethernet 6.
13. Spanning Tree has number of enhancements, explain the following terms

BPDU
BPDU
Root
UDLD
Loop

Filtering
Guard
Guard
(Uni directional Link Detection)
Guard

*14. Cisco Multilayer switch supports routed ports and switch virtual interfaces
.
What is a routed port and how to you configure it?
What is a switched virtual interface (SVI) and how to do you configure it?
*15. Explain the concept of Router-on-a-Stick. A diagram may help your explanati
on.
16. What does the following code achieve?
Switch(config)# interface vlan10
Switch(config-if)# ip address 10.1.10.1 255.255.255.0
Switch(config-if)# ip helper-address 10.1.100.1
17. Explain the concepts of Control Plane and Data Plane
18. Cisco switches have 3 switching methods, there are Process switching, Fast S
witching and CEF.
Give a brief explanation of each term.
19. What is the difference between the Forwarding Information Table (FIB) and th
e Routing Table.
20. Network-level resiliency relies on monitoring with NTP,SNMP, Syslog and IP S
LA.
Give a brief description of each protocol.
21. Describe the HSRP protocol and how it works. A diagram would help your expla
nation.
22. What is HRSP interface tracking
23. Explain the purpose the the folllowing code.
RouterA(config)# interface vlan 10
RouterA(config-if)# ip address 10.1.1.2 255.255.255.0
RouterA(config-if)# standby 10 ip 10.1.1.1
RouterA(config-if)# standby 10 priority 110
RouterA(config-if)# standby 10 preempt
*24. What does the GLBP acronym stand for. Give a brief description of its operat
ion.
25. Describe the operation of Ciscos SLB
26. Describe the MAC address Fooling attack method. What is the mitigation to thi
s attack?
27. Describe the DHCP Starvation and DHCP Spoofing. What is the mitigation to this
attack?
28. Describe the Address Resolution Protocol (ARP) Spoofing. What is the mitigatio
n to this attack?

29. What will the following code achieve?


switch(config)# access-list 100 permit ip 10.1.9.0 0.0.0.255 any
switch(config)# mac access-list extended BACKUP_SERVER
switch(config-ext-mac)# permit any host 0000.1111.4444
switch(config)# vlan access-map XYZ 10
switch(config-map)# match ip address 100
switch(config-map)# action drop
switch(config-map)# vlan access-map XYZ 20
switch(config-map)# match mac address BACKUP_SERVER
switch(config-map)# action drop
switch(config-map)# vlan access-map XYZ 30
switch(config-map)# action forward
switch(config)# vlan filter XYZ vlan-list 10,20
30. What does the following code achieve?
Switch(config)# aaa new-model
Switch(config)# aaa authentication login TEST tacacs+
Switch(config)# tacacs-server host 192.168.100.100
Switch(config)# line vty 0 4
Switch(config-line)# login authentication TEST
*31. Describe the SPAN feature of a Cisco Catalyst switch? A diagram might help
your explanation
32. What is the purpose of the following COS, IP Precedence and DSCP?
33. Give a brief description of the Multicast protocol.