Sie sind auf Seite 1von 3

59457 - Inter-VLAN routing using Cisco and Stratix 8000 switches

1 de 3

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/59457

59457 - Inter-VLAN routing using Cisco and Stratix 8000 switches


Access Level: Everyone
Date Created: 03/11/2009 11:25 AM
Last Updated: 03/30/2015 03:54 PM

How do I Configure Inter-VLAN routing using Cisco and Stratix 8000 switches?
Stratix 8000 and Cisco switches allow networks to be segmented using Virtual LANs (VLANs).
Inter VLAN Routing is a mechanism that allows a device to communicate with devices on different VLANs. A typical scenario in which this would be needed is where there are
automation devices (such as controllers), each on one VLAN, working together with a visualization or SCADA system which needs to communicate with each controller.
In order to achieve this configuration, you require a layer 3 device with routing capabilities. A typical example is a Cisco 3750 switch.
No specific software is required other than a tool for communicating with the Cisco 3750 using Command Line Interface (such as PuTTY). Knowledge of configuration using
Command Line Interface would be of benefit.
This article describes the steps needed to setup the following network configuration.

This architecture shows:


Three controllers, all connected to a Stratix 8000 switch.
Three I/O devices, all connected to a second Stratix 8000 switch.
The Stratix 8000 switches, together with a Cisco 3750 layer 3 switch, form a ring.
In order to setup this configuration, you need to follow these steps.
1. Design the IP addressing scheme for your network.
Best practice for networks using VLANs is to ensure that the subnet on which a device is located corresponds to its VLAN.
2. In this example, we will work with IP addresses in the 172.16.x.y range, with subnet mask 255.255.255.0.
x will correspond to the VLAN number
y will indicate a device on that VLAN
The table below shows the respective IP addresses:
VLAN

Point I/O

Controller

10

172.16.10.5/24

172.16.10.6/24

172.16.10.1

20

172.16.20.5/24

172.16.20.6/24

172.16.20.1

30

172.16.30.5/24

172.16.30.6/24

172.16.30.1

40

FactoryTalk View Server

172.16.40.10/24

Default Gateway

172.16.40.1

Here we have four subnets, and on each subnet, we have defined a default gateway.
Connect your devices to your network
3. Set the following for each of the devices on the network:

24/06/2015 11:03

59457 - Inter-VLAN routing using Cisco and Stratix 8000 switches

2 de 3

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/59457

IP address
Subnet mask
Default gateway.
Note that setting the Default Gateway is essential as otherwise the configuration will not work.

4. Ensure that the Stratix 8000 switches have been configured using Express Setup.
5. Connect to the Stratix 8000 switches using Device Manager and create all four of the VLANs in each switch (Configure->VLANs). Click on Create and enter the VLAN
number and name.
6. Apply Switch smartports to the uplink ports (the links between the switches).
7. Apply the Automation Device smartport to the ports connected to the controllers and I/O devices. Click on Customize and set the access VLAN to the correct VLAN for
that device.
8. Apply switch smartports to the Cisco 3750 (simplest using Cisco Network Assistant) or Device Manager, or connect using command line interface and set the ports to
switchport mode trunk.
9. Configure VLAN interfaces on the Cisco 3750. You can achieve this by entering commands in global configuration mode, such as:
interface VLAN 10
IP address 172.16.10.1 255.255.255.0
10. Repeat for each of the default gateways required in your application. Here, the four default gateways specified in the example are needed.
11. Create the VLANs in the Cisco 3750. You can achieve this by entering the following commands in global configuration mode:
vlan 10
name VLAN10
12. For ease of debugging, ensure that the VLAN name you specify here matches that which you used when setting up the VLANs in the Stratix 8000 switches.
13. To the correct VLAN, add the port to which your FactoryTalk View server is connected. Then enter interface configuration mode and enter the following command:
switchport access vlan 40
14. Configure routing in the 3750. You have various options, but one mechanism would be to use a dynamic routing protocol such as EIGRP. An example configuration,
entered in global configuration mode is:
router eigrp zz [Where zz is the number used to identify the routing process]
network 172.16.10.0 0.0.0.255
network 172.16.20.0 0.0.0.255
network 172.16.30.0 0.0.0.255
network 172.16.40.0.0.0.0.255
15. The network command will identify the subnets between which routing is required. Here it will allow the FactoryTalk View server to access all of the controllers and point
I/O devices.
Confirm that IP routing is working correctly by entering the command Show IP rout in privileged EXEC mode. All of the networks you configured should be listed.
Test your configuration by pinging the following:
Controllers from the FactoryTalk View server.
Automation devices from the Cisco 3750.
Configure RSLinx on your FactoryTalk View server to communicate with the Controllers (and if required, the I/O devices).
You will have to use the Ethernet (AB_ETH) driver instead of the EtherNet/IP driver (AB_ETHIP) as the presence of the router means that the EtherNet/IP driver
cannot browse the network.
Similarly, you will have to configure RSLinx Enterprise in FactoryTalk View to communicate with the controllers the same way.
No additional configuration is required for the ring topology to operate. However, best practice is to define a root bridge for a spanning-tree process.
In the example described above, the most appropriate device to be the root bridge is the Cisco 3750.
The mechanism for setting this will depend on the spanning tree algorithm running in the switches.
By default, Stratix 8000 switches run a process known as mst.
In this case, the command for setting the Cisco 3750 as the root bridge is:
spanning-tree mst <instance-id> root primary [Instance-id is typically 0]
Also keep in mind there is no difference between using copper media and fiber media when implementing this configuration.

Reference
For information on how to configure inter-VLAN routing using the Stratix 8300 Device Manager, see AID 65566 - Inter-VLAN routing using Stratix 8300 and Stratix 8000
switches.

24/06/2015 11:03

59457 - Inter-VLAN routing using Cisco and Stratix 8000 switches

3 de 3

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/59457

Comments (0)
This answer has no comments
Post a Comment

Product Tree for This Answer (expand/collapse)

This page is best viewed in Internet Explorer 10, Firefox 31, Chrome 37, Safari 6 or newer.

24/06/2015 11:03