Sie sind auf Seite 1von 115

mVPN Deployment Models

BRKIPM-2011

Luc De Ghein
Technical Leader Services

Agenda
Introduction
mVPN Rosen GRE Recap

Building Blocks
Signalling in the core
PIM
mLDP
P2MP TE
Assigning flows to LSPs
Customer Signalling

Deployment Models (Profiles)

mVPN GRE
In-band signaling
mVPN mLDP
Partitioned MDT
mVPN over P2MP TE
Ingress Replication

LSM Conclusion
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

Before We Start
P- is Provider
C- is Customer
E.g. C-(S,G) is an S,G of a customer, so likely in a VRF

Only IPv4 mentioned


All applies equally to IPv6
Similar configuration, other address family

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

Introduction

mVPN Rosen GRE - Recap


PIM on the edge
Unicast routing in overlay across MPLS
Mcast signalling in overlay
Mcast through core GRE encap

PIM join

IPv4 MDT

For Default MDT Group


Configured on PE per VRF

PIM join
PIM join
CE

Leaf PE

PIM join

PIM join

PIM join
CE

Leaf PE

PIM

CE

Leaf PE

Leaf PE

CE

Leaf PE

PIM

CE

PIM

BiDir
SSM
Sparse modeCisco Public
2014 Cisco and/or its affiliates. All rights reserved.

Default-MDT created in core using PIM


BRKIPM-2011

mVPN Rosen GRE - Recap


PIM on the edge
Unicast routing in overlay across MPLS
Mcast signalling in overlay
Mcast through core GRE encap

PIM hello/join

BGP vpnv4/6

ON Default MDT Group


1 Default MDT per VPN

PIM join

PIM hello
PIM hello

CE

Leaf PE
CE

PIM hello

Leaf PE

CE

Leaf PE

PIM hello
CE

Leaf PE

Leaf PE

CE

Source

PIM join

Per VRF: Default MDT

vpnv4 or vpnv6 needed to have unicast plane

PIM hellos and other PIM signalling

Default-MDT emulates a virtual LAN


BRKIPM-2011

Unicast plane needed to make RPF succeed

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

mVPN Rosen GRE - Recap


PIM on the edge
Unicast routing in overlay across MPLS
Mcast signalling in overlay
Mcast through core GRE encap

mcast data

forward data
Leaf PE
CE

Leaf PE

drop data
Leaf PE

CE

CE

Leaf PE

Leaf PE

CE

CE

Source

Mcast traffic on Default MDT is received by all PEs attached to that VPN
Even if that PE has no receiver in VRF for the (*,G) or (S,G)
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

mVPN Rosen GRE - Recap


PIM on the edge
Unicast routing in overlay across MPLS
Mcast signalling in overlay
Mcast through core GRE encap

mcast data

I have no receivers:
I ignore

I have receiver:
I join

Leaf PE
CE

Leaf PE

traffic rate
exceeds threshold
CE

I have receiver:
I join
CE

Leaf PE

Leaf PE

Leaf PE

Data MDT
Join TLV

BRKIPM-2011

CE

2014 Cisco and/or its affiliates. All rights reserved.

CE

Source

PIM message
carries C-(S,G) & P-group

Cisco Public

mVPN Rosen GRE - Recap


PIM on the edge
Unicast routing in overlay across MPLS
Mcast signalling in overlay
Mcast through core GRE encap

PIM join
For Data MDT Group
Configured on PE per VRF
Range of groups

PIM join

PIM Data-MDT Join TLV

Leaf PE
CE

mcast data

CE

Leaf PE

C-(S,G)
P-Group

Leaf PE

CE

PIM join
CE

Leaf PE

Leaf PE

CE

Source

For high rate sources, data-MDT created


Removes traffic from default-MDT to offload PEs that did not join stream
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

10

Why Label Switched Multicast ?


Past
1 solution
mVPN based on GRE (Rosen-GRE)

Now and Future


NG mVPN
LSM (Label Switched Multicast) in core

Shared control plane with unicast


Less protocols to manage in the core
Shared forwarding plane with unicast
Only MPLS as encapsulation
FRR

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

11

LSM Solution Space


Service

C-Multicast Signaling (PE-PE)

Core Tree Signaling

Encapsulation/Forwarding

BRKIPM-2011

IPv4

IPv6

IPv4

IPv6

Native

Native

mVPN

mVPN

PIM

PIM

IP/GRE

2014 Cisco and/or its affiliates. All rights reserved.

BGP

MLDP

P2MP TE

LSM

Cisco Public

VPLS

None

IR

Unicast MPLS

12

Building Blocks

Signalling in the Core

Protocols for Building Multicast LSPs


Multipoint LDP (mLDP)
Extensions to LDP
Support both P2MP and MP2MP LSP
RFC 6388

RSVP-TE P2MP
Extensions to unicast RSVP-TE
RFC 4875

Unicast MPLS + Ingress Replication (IR)


Use unicast
No additional signalling in core
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

15

New LSP Types


Point to Multipoint

Multipoint to Multipoint

IP/MPLS

IP/MPLS

PM2P LSP

MP2MP LSP

Replication of traffic in core


Allows only the root of the P2MP LSP to inject
packets into the tree

Replication of traffic in core

Signaled with MLDP

Bidirectional
All the leafs of the LSP can inject and receive
packets from the LSP

Path based on IP routing

Signaled with RSVP-TE


Constraint-based / explicit routing

Signaled with multicast LDP (mLDP)

Admission control

Path based on IP routing

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

16

New LSP Types


Point Point to Multipoint

PPMP is an emulated MP2MP LSP


Control plane is MP2MP, data plane is
P2MP

IP/MPLS

Does not work with PIM bidir

P2P LSP
P2MP LSP

Allows PIM to be run over P2MP LSPs,


as with RSVP-TE that does not support
MP2MP
Core routers dont support MP2MP (dual
vendor issues)

Combination of P2P and P2MP


P2P from leaf to the root
P2MP from root to the leafs
Signaled with mLDP or RSVP-TE
P2P to root used for control packets
P2MP used for data & control
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

17

PIM

PIM Signalling in the Core


IP Multicast routing in the core
PIM in the core
Used by Rosen GRE model

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

19

mLDP

MLDP Overview
LSPs are build from the leaf to the root
Supports P2MP and MP2MP LSPs
mLDP with MP2MP provides great scalability advantages for any to any topologies
any to any communication applications:
mVPN supporting Bidirectional PIM
mVPN Rosen model default MDT
If a provider does not want tree state per ingress PE source

Supports Fast Reroute (FRR) via RSVP TE unicast backup path


No periodic signaling, reliable using TCP
Control plane is P2MP or MP2MP
Data plane is P2MP
Scalable due to receiver driven tree building
Supports MP2MP
Does not support traffic engineering
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

21

Tree Types
Official Tree Names
Multi-directional Inclusive PMSI

Selective PMSI

Multidirectional Selective PMSI

MI-PMSI
(default-MDT)

S-PMSI
(data-MDT)

MS-PMSI
(Partitioned-MDT)

S-PMSI

MI-PMSI

MS-PMSI

PE

PE
P

PE

PE

Like E-LAN

PE

PE

PE

PE

PE

Combination ELAN and NBMA

Like NBMA

Full mesh P2MP or


one MP2MP
Good when sources
are in every site

PE

PE

PE

PE

A single MP2MP

A single P2MP

Good when sources


in few sites

PMSI = Provider Multicast Service Interface


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

22

mLDP FEC and Opaque Values


Multicast FEC is advertised by mLDP
Root node address and opaque value identify the P2MP or MP2MP tree
Root node address is
learned dynamically (BGP next hop address), for P2MP trees
configured, for MP2MP trees
Opaque value is used to carry multicast stream information, like
(S,G) : in-band signalling
LSP identifier : Default/Data MDT

The opaque value has meaning to root and leaves


Root and leaves are edge devices
Opaque value is mapped to PIM state on the edge devices
Opaque value is completely transparent to intermediate nodes (P routers)

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

23

LSP Types and Forwarding


P2MP tree
P#show mpls forwarding-table
Local
Outgoing
Prefix
Label
Label
or Tunnel Id
20

23
18

Bytes Label
Switched

[ipv4 10.100.1.6 232.1.1.1]


0
[ipv4 10.100.1.6 232.1.1.1]
0

packet replication and forwarding


Outgoing
interface

Next Hop
23
20

\
Et1/0

10.1.1.1

Et3/0

10.1.3.3

\
18

MP2MP tree
P#show mpls forwarding-table
Local
Outgoing
Prefix
Label
Label
or Tunnel Id
19

20

23

BRKIPM-2011

Bytes Label
Switched

21

[mdt 1000:2000 0]

19

[mdt 1000:2000

24

[mdt 1000:2000

21

[mdt 1000:2000

24

[mdt 1000:2000

19

[mdt 1000:2000

2006 Cisco Systems, Inc. All rights reserved.

\
33516
0]
\
912
0]
\
1932
0]
\
1932
0]
\
33940
0]
\
912
Cisco Confidential

Outgoing
interface

21

Next Hop
19

Et2/0

10.1.2.2

Et1/0

10.1.1.1

Et3/0

10.1.3.3

Et2/0

10.1.2.2

Et3/0

10.1.3.3

Et1/0

10.1.1.1

23

}
}

20
24

19

MP2MP LSP is combination


of P2MP LSPs
24

P2MP TE

RSVP-TE Overview
LSPs are build from the head-end to the tail-end
Supports only P2MP LSPs

Supports traffic engineering


Bandwidth reservation
Explicit routing
Fast ReRoute

Signaling is periodic
P2P technology at control plane
Inherits P2P scaling limitations

P2MP at the data plane


Packet replication in the core
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

26

RSVP-TE P2MP
Signalling
BGP Auto Discovery leaf updates
or static configuration

Receiver
Leaf

CE

Receiver
Leaf
Source

Ingress
Router
(Root)

Resv

CE

Path

Receiver
Leaf

CE

The Leafs sends a BGP Auto Discovery message to notify the ingress PE

The ingress sends RSVP-TE Path messages to the leaves


The leaves respond with RSVP-TE Resv messages
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

27

Comparisons Core Protocols


PIM

mLDP

Mature protocol

New enhancement to existing protocol

No need for new code on core routers

Need newer code, but base mLDP code (for P


routers) has been around for years now

Soft state (periodic refresh)

Hard state (no periodic updates)

GRE encap

MPLS label switching

Customer state present in core with Data MDT

Customer state present in core with Data MDT

Customer state in core with in-band signalling

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

28

Comparisons Core Protocols


mLDP

P2MP TE

New enhancement to existing protocol

New enhancement to existing protocol

Need newer code, but base mLDP code (for P


routers) has been around for years now

Need newer code

Hard state (no periodic updates)

Soft state (periodic refresh)

Dynamic tree building

Static P2MP trees


Dynamic tree building is coming

FRR possible (P2P TE tunnel)

FRR possible

No BW reservation

BW reservation

Setup driven by tail ends

Setup driven by head ends

P2MP and MP2MP trees

P2MP trees only

Suitable for all mcast applications


Best for many-to-many

Mostly suitable for video delivery


Best for few-to-many

Inter-as and CsC (GRE + all mLDP profiles)

No CsC

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

29

Customer Signalling

Protocols for Assigning Flows to LSPs


Static
PIM
RFC 6513

BGP Customer Multicast (C-Mcast)


RFC 6514
Also describes Auto-Discovery

mLDP In-band signaling


RFC 6826

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

31

Flow Mapping
Overview
PIM

BGP

PIM

Source
S1,S2

PIM

PE

PE

MPLS cloud

PIM

Receiver

Source
S1,S2

PIM

PE

PIM in Overlay

static map

MPLS cloud

PE

PIM

Receiver

Source
S1,S2

PIM

PE

Static
BRKIPM-2011

Receiver

mLDP PIM PIM mLDP


translation
translation

static map

PIM

PE

PE

BGP in Overlay

PIM

Source
S1,S2

MPLS cloud

MPLS cloud

PE

Receiver

Inband
2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

32

Flow Mapping
Static
Today mostly applicable to RSVP-TE P2MP
Static configuration of multicast flows per LSP
Allows aggregation of multiple flows in a single LSP

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

33

Flow Mapping
PIM
Dynamically assigning flows to an LSP by running PIM over the LSP

Works over MP2MP and PPMP LSP types


Mostly applicable (but not limited) to mVPN - Rosen
No changes to PIM in order to support this

Allows aggregation of multiple flows in a single LSP

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

34

Flow Mapping
Auto Discovery

Auto Discovery (AD)


The process of discovering all the PEs with members in a given mVPN

Used to establish the MDT in the SP core


Can also be used to discover set of PEs interested in a given C-group (to
enable S-PMSI creation)
S-PMSI = Data MDT

Used to advertise address of originating PE and tunnel attribute information


(i.e. which kind of tunnel)

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

35

Flow Mapping
Auto Discovery Without BGP

Rosen GRE needs Default MDT


Rosen GRE did not need BGP AD
Core is PIM
ASM or BiDir
RP is configured/learned: the PEs learn of each other through the RP

SSM
AF IPv4 MDT under BGP is needed to learn the PEs

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

36

BGP IPv4/IPv6 MVPN Address Family


Specified in RFC 4271, using BGP Multiprotocol Extensions [RFC4760] with an AFI of 1 or
2 and an SAFI of MCAST-VPN
Used for advertisement of AD routes
Used for advertisement of C-mcast routes (*,G) and (S,G)
Two new extended communities (used by vpnv4/6 prefixes, so SAFI 128):
VRF route import (replacing connector attribute, i.e. storing route originator IP address/used to import
mcast routes, similart to RT for unicast routes)
Source AS (advertise AS information: used for inter-AS mVPN)

New BGP attributes


PMSI Tunnel Attribute (PTA) (contains information about advertised tunnel)
PPMP label attribute (upstream generated label used by the downstream clients to send unicast
messages towards the source)

The NLRI field in the MP_REACH_NLRI/MP_UNREACH_NLRI attribute contains the


MCAST-VPN NLRI

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

37

Flow Mapping
BGP Auto Discovery + C-Signalling
Inside the BGP update
PMSI Tunnel Attribute (PTA)
Flags (1
octet)

0-6 Reserved
7 L Leaf information required

Tunnel type
(1 octet)

0 No tunnel information present


1 RSVP-TE P2MP LSP
2 mLDP P2MP LSP
3 PIM-SSM Tree
4 PIM-SM Tree
5 PIM-Bidir Tree
6 Ingress Replication
7 mLDP MP2MP LSP

MPLS label (3
octects)

mcast vpn NLRI

Route type (1 octet)

AD type

C type

Length in octets of the Route Type specific field of


MCAST-VPN NLRI

Length (1 octet)

One or more of the following:

MPLS label
RD (8 octets)

1 RSVP-TE P2MP LSP - <Extended Tunnel ID, Reserved, Tunnel ID, P2MP ID>
2 mLDP P2MP LSP - <P2MP FEC Element>
3 PIM-SSM Tree - <P- Root Node Address, P-Multicast Group>
Tunnel
Identifier
(variable)

1 Intra-AS I-PMSI A-D route


2 Inter-AS I-PMSI A-D route
3 S-PMSI A-D route
4 Leaf A-D route
5 Source Active A-D route
6 Shared Tree Join route
7 Source Tree Join route

Route type specific


(variable length)

MCAST source length (1 octet)


MCAST source (variable)

4 PIM-SM Tree - <Sender Address, P-Multicast Group>

MCAST group length (1 octet)

5 PIM-Bidir Tree - <Sender Address, P-Multicast Group>

MCAST group (variable)

6 Ingress replication - <unicast tunnel endpoint IP address of the local PE that is to be


this PEs receiving endpoint address for the tunnel>

Originating routers IP address

7 mLDP MP2MP LSP - <MP2MP FEC Element>


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

38

Flow Mapping BGP Route Types


Route
Type

Name

AD or C-mcast

Usage

Intra-AS I-PMSI A-D route

AD

AD Advertise
type
member PE

Inter-AS I-PMSI A-D route

AD

Same as type 1, but for inter-AS


C type

S-PMSI A-D route

AD

Advertised by Source PE to signal Data MDT

Leaf A-D route

AD

Advertised by Receiver-PE as a response to type 3 route with leaf


info required flag set

Source Active A-D route

AD

Advertised by Source PE with active source to facilitate SPT


switchover

Shared Tree Join route

C-mcast

Advertise (*,G) by Receiver PE

Source Tree Join route

C-mcast

Advertise (S,G) by Receiver PE

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

39

Flow Mapping
BGP Customer-Multicast
BGP Customer Multicast (C-Mcast) signalling on overlay
Tail-end driven updates is not a natural fit to BGP
BGP is good in one-2-many, not many-2-one

In mVPN context, PIM is still the PE-CE protocol


Easy for SSM

Complex to understand/troubleshoot for ASM

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

40

Flow Mapping
New SAFIs to Support BGP Customer Signalling
SAFI 2 in VRF and SAFI 129 across the core
Allows for different mcast vs unicast topologies across MPLS
SAFI 129 = VPN mcast SAFI
A PE can select an upstream mcast hop which is different than the unicast next hop (RPF is not the
unicast route)
e.g.
router bgp 1
address-family
address-family
address-family
address-family

vpnv4
vpnv6
vpnv4
vpnv6

unicast
unicast
multicast
multicast

multicast IPv6 2/2

mullticast vpnv6 2/129

multicast IPv6 2/2

multicast IPv4 1/2

mullticast vpnv4 1/129

multicast IPv4 1/2

unicast ipv6 2/1

unicast vpnv6 2/128

unicast ipv6 2/1

unicast ipv4 1/1

unicast vpnv4 1/128

unicast ipv4 1/1

and
address-family
address-family
address-family
address-family

ipv4
ipv6
ipv4
ipv6

BRKIPM-2011

unicast vrf vrf1


unicast vrf vrf1
multicast vrf vrf1
multicast vrf vrf1

MPLS cloud
Source
S1,S2

CE

2014 Cisco and/or its affiliates. All rights reserved.

PE

PE

Cisco Public

CE

Receiver

41

Flow mapping
In-Band signaling
Only works with mLDP
Multicast flow information encoded in the mLDP FEC

Each customer mcast flow creates state on the core routers


IPv4 and IPv6 multicast in global or VPN context
Typical for SSM or PIM Sparse mode sources

IPTV walled-garden deployment


draft-ietf-mpls-mldp-in-band-signaling

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

42

Flow Mapping
Good to Know
Rosen (GRE or mLDP) uses Default and Data MDT
Default MDT (always on) can carry anything
All (*,G) must be on it
Some (S,G), low rate

Data MDT (on demand)


Can only carry (S,G)

Partitioned MDT
Shared
MDT carries (*,G) and (S,G) for which no Data MDT is triggered
Besides one shared MDT, multiple Data MDTs can be used

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

43

Comparisons Customer Signalling Protocols


PIM

BGP

Older protocol, proven, well known

New enhancement to existing protocol

No changes needed

New procedures (troubleshooting!)


complex for PIM SM

Soft state (periodic refresh)

Hard state (no periodic updates)

Info driven to specific PE router

Info driven to all PE routers

PIM adjacencies to all PE routers

BGP adjacencies to all PE routers


but likely only to RRs

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

44

Configuration BGP-AD & C-mcast Signalling


IOS

IOS-XR

vrf definition one

router pim

rd 1:3

vrf one

route-target export 1:1


route-target import 1:1

Switch to BGP as C-mcast


signalling protocol

address-family ipv4
rpf topology route-policy rpf-for-one
mdt c-multicast-routing pim

address-family ipv4

Specify PIM or BGP

mdt overlay use-bgp

migration route-policy pim-to-BPG


announce-pim-join-tlv

mdt auto-discovery mldp pim-tlv-announce


exit-address-family

Specify to use PIM Data


MDT Join TLV in dual
PIM/mLDP network
BGP AD

BRKIPM-2011

multicast-routing
address-family ipv4
bgp auto-discovery mldp | pim | ir | p2mp-te

BGP AD

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

45

BGP Signalling
I-PMSI (type 1)

Build Default MDT

config
driven

I-PMSI (type 1)

MPLS cloud
Source

CE

PE

PE

Share Tree Join (type 6)

Relay PIM Join

PIM
driven

PIM (*,G) Join

CE

RP-PE

PE

Source Tree Join (type 7)

PIM
driven
CE

PE

Data MDT
threshold crossed

data
driven

Receiver

PIM (S,G) Join

PE

CE

PE

CE

Receiver

S-PMSI (type 3)

MPLS cloud
Source

BRKIPM-2011

CE

MPLS cloud
Source

Build Data MDT

Receiver

MPLS cloud
RP

Relay PIM Join

CE

CE

2014 Cisco and/or its affiliates. All rights reserved.

PE

Cisco Public

Receiver

46

BGP Signalling
type 3 with LeafInfo-required

Type 3 with Leaf-InfoRequired Flag

BGP
driven

MPLS cloud
Source

SPT Switchover

data
driven

type 4

CE

PE

PE

CE

Receiver

RP PE

SPT threshold
crossed

PIM (*,G) Join


Source Active A-D route (type 5)
Receiver
Source

CE

Source
PE

This is iBGP signalling


All BGP speakers get the BGP mvpn updates
Only targetted PEs store it
e.g. Type 6 is only stored by RP-PE
e.g. Type 5 is stored by all PEs
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

MPLS cloud

Cisco Public

Receiver
PE

CE

47

BGP Signalling - Routes


DRP/0/3/CPU1:meltdown-drp#show bgp ipv4 mvpn vrf one

Route Distinguisher: 1:2 (default for vrf one


*>i[1][10.1.100.1]/40 10.1.100.1

100

0 i

Intra-AS I-PMSI AD Route

100

0 i

Partitioned MDT

*>i[3][0][0.0.0.0][0][0.0.0.0][10.1.100.1]/120
10.1.100.1

*>i[4][3][1:2][32][10.2.2.9][32][225.1.1.1][10.1.100.2][10.1.100.5]/224

10.1.100.5

100

*>i[4][3][1:2][32][10.2.100.9][32][225.1.1.1][10.1.100.2][10.1.100.1]/224
10.1.100.1

100

0 i

100

0 i

100

0 i

100

0 i

*>i[5][32][10.2.2.9][32][225.1.1.1]/88
10.1.100.2

*>i[6][1:5][1][32][10.2.100.12][32][225.1.1.1]/184
10.1.100.1

*>i[7][1:2][1][32][10.2.2.9][32][232.1.1.1]/184
10.1.100.1

Data MDT advertised by Source PE

0 i

Leaf AD Route

Source Active Route

(*,G) Join Route

(S,G) Join Route

R-PE or Source-PE
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

48

BGP C-Signalling
On Rosen models with C-PIM signalling, data traffic needs to be monitored
On Default/Data tree to detect duplicate forwarders over MDT and trigger the assert process
On Default MDT to perform SPT switchover (switchover from (*,G) to (S,G))

On Rosen models with C-BGP signalling


There is only one forwarder on MDT
There are no asserts
The BGP Type 5 routes are used for SPT switchover on PEs

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

49

Type 4 Leaf AD Routes

Not required at this time


Can be enabled
Only used for display purposes and to track type 3 S-PMSI (Data MDT) routes
If the Source PE sets the Leaf-Info-required flag on type 3 routes, the Receiver PE
responds with a type 4 route
IOS-XR
multicast-routing

vrf one

address-family ipv4
bgp auto-discovery ir | mldp | p2mp-te | pim
leaf-info-required

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

50

Migration PIM to BGP for C-mcast Signalling


router pim
vrf one
address-family ipv4
rpf topology route-policy rpf-for-one
mdt c-multicast-routing pim
migration route-policy pim-to-BGP

Migration route policy for C-mcast signalling

!
interface GigabitEthernet0/1/0/0
enable

route-policy pim-to-BGP
if destination in (10.1.100.2/32) then
set c-multicast-routing bgp
endif

If source-PE is 10.1.100.2 then use BGP


else use PIM for C-mcast signalling

pass
end-policy

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

51

Migrating Core Tree


Core tree selection can be based on C-S, C-G, Source PE
route-policy rpf-for-one
if destination in (225.1.1.0/24) then

If C-Group is 10.2.2.10 then use Rosen GRE

set core-tree pim-default


endif
if source in (10.2.2.10) then

If C-Source is 10.2.2.10 then use Partitioned mLDP

set core-tree mldp-partitioned-p2mp


endif
if next-hop in (10.1.100.9) then

If Source-PE is 10.1.100.9 then use mLDP Inband

set core-tree mldp-inband

endif
if next-hop in (10.1.100.11/32) then

If Source-PE is 10.1.100.11 then use Rosen mLDP

set core-tree mldp-default


endif
end-policy
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

52

Flow Mapping
Summary
Static
Mostly applicable to RSVP-TE

PIM
Well known, used since the introduction of mVPN over GRE in 2000

BGP A-D
Useful where head-end assigns the flows to the LSP

BGP C-mcast
Alternative to PIM in mVPN context
Might be required in dual vendor networks

mLDP In-band signalling


Method to stitch a PIM tree to a mLDP LSP without any additional signaling
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

53

Deployment Models

NG-mVPN - Deployment Models


In-band signaling
Global context
VPN context (mVPN)

Rosen Model mVPN


GRE based
mLDP based

Partitioned MDT mVPN over mLDP

P2MP TE
Global context
VRF Static over P2MP TE
mVPN Rosen over P2MP TE

Ingress Replication
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

55

Configuration
All unicast must be up and running
IPv4 MDT is needed for Rosen GRE model
Enable multicast-routing/PIM on the edge
Global or VRF interface to CE

Enable mLDP/P2MP TE on core


IOS
mLDP enabled by default, if MPLS is enabled

IOS-XR
mpls ldp
mldp

Specify the mVPN model

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

56

Configuration IOS-XR
multicast-routing
vrf one
address-family ipv4
mdt mldp in-band-signaling ipv4

Specify the mVPN model

mdt partitioned mldp ipv4 p2mp (bidir)


mdt partitioned mldp ipv4 mp2mp (bidir)

mdt partitioned ingress-replication


mdt mldp in-band-signaling ipv4
mdt default mldp ipv4 <root>

MP2MP core-tree with IPv4 Root address

mdt default mldp p2mp (partitioned)(bidir)

P2MP core-tree

mdt default ingress-replication

mdt default <ipv4-group>


mdt default (ipv4) <ipv4-group> partitioned
mdt data <ipv4-group/length>
mdt data <max nr of data groups> (threshold)
mdt static p2mp-te tunnel-te <0-65535>
mdt static tunnel-mte <0-65535>
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

57

Configuration IOS-XR
router pim
vrf one
address-family ipv4
rpf topology route-policy rpf-for-one
interface GigabitEthernet0/0/0/9

Specify RPF to core-tree

RP/0/RP1/CPU0:MeltDown(config-rpl)#set core-tree ?
ingress-replication-default
Ingress Replication Default MDT core
ingress-replication-partitioned Ingress Replication Partitioned MDT core
mldp-default
MLDP Default MDT core
mldp-inband
MLDP Inband core
mldp-partitioned-mp2mp
MLDP Partitioned MP2MP MDT core
mldp-partitioned-p2mp
MLDP Partitioned P2MP MDT core
p2mp-te-default
P2MP TE Default MDT core
pim-default
PIM Default MDT core

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

58

Rosen GRE

Rosen mVPN over GRE Default MDT


Default MDT
PIM join

PIM join

Leaf PE
CE

Leaf PE

Leaf PE

CE

CE

Leaf PE

Leaf PE

CE

CE

Default-MDT created in core using single IPv4 mcast group


PIM used for Customer route signalling over default-MDT
Default-MDT emulates a virtual LAN
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

60

Rosen mVPN over GRE Data MDT


PIM Data-MDT Join TLV
C-(S,G)
P-group

traffic rate
exceeds threshold
Data-MDT

Leaf PE
Source

CE

Leaf PE

Leaf PE

CE

CE

Leaf PE

Leaf PE

CE

CE

For high rate sources data-MDT created using P2MP LSPs


Removes traffic from default-MDT to offload PEs that did not join stream
Creation of data-MDT is signalled dynamically using MDT Join messages or BGP A-D routes
Only PEs with receivers join Data MDT
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

61

Configuration - IOS
vrf definition one
rd 1:3
route-target export 1:1
route-target import 1:1
!

address-family ipv4
mdt default 232.100.1.1
mdt data 232.100.100.0 0.0.0.255

ip multicast-routing
ip multicast-routing vrf one

Default and Data IPv4 groups for this VRF in


global context

Multicast-routing globally enabled (PIM on the


interfaces)

router bgp 1
!
address-family vpnv4
neighbor 10.1.100.7 activate
neighbor 10.1.100.7 send-community extended
!
address-family ipv4 mdt
neighbor 10.1.100.7 activate

BRKIPM-2011

AF IPv4 MDT needed to auto-discover PEs

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

62

Configuration IOS-XR
route-policy rpf-for-one
set core-tree pim-default

specify core-tree type

multicast-routing
address-family ipv4
interface Loopback0
enable

router bgp 1
!

address-family vpnv4 unicast


!
address-family ipv4 mdt
!

AF IPv4 MDT needed to


auto-discover PEs

mdt source Loopback0


interface all enable

vrf one
neighbor 10.1.100.5

address-family vpnv4 unicast

Multicast-routing enabled
in global context

address-family ipv4

mdt source Loopback0

mdt data 232.100.100.0/24

address-family ipv4 mdt

mdt default ipv4 232.100.1.1

Default and Data IPv4 groups for


this VRF in global context

router pim
address-family ipv4
rpf topology route-policy rpf-for-one
interface GigabitEthernet0/0/4/0

specify route-policy to
select RPF topology

enable
!

PIM enabled on global interfaces


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

63

In-band Signaling VPN Context

in-band signalling
model also exists in
global context

In-band Signaling VPN Context


PIM (S1,G)
PIM (S2,G)

RD

RD

CE

R-PE
CE

Source
S1,S2

PIM (S1,G)
PIM (S2,G)

P2MP LSP FEC {RD,S1,G}


P2MP LSP FEC {RD,S2,G}
P2MP LSP FEC {RD,S1,G}

Root-PE
PIM (S1,G)

PIM (S1,G)

RD

RD

CE

CE
Source
S1

Receiver

Root-PE

MPLS cloud

RD

R-PE
PIM (S1,G)

Receiver

CE

Receiver

PIM (S,G) VPN tree is mapped to a mLDP P2MP LSP


Root PE is learned via BGP Next-Hop of the VPNv4 Source address route

R-PE may use SSM Mapping if Receiver is not SSM aware


RD of the source VRF is included in the mLDP FEC to allow overlapping (S,G)
addresses
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

65

In-band Signaling VPN Context


Multicast flow information encoded in the mLDP FEC
Not well suited for generic mVPN support
Scalability concern
State in VRF creates state in core (on P routers)

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

66

Configuration - IOS
vrf definition one
rd 1:3
route-target export 1:1
route-target import 1:1
!
address-family ipv4
!
address-family ipv6

ip multicast-routing
ip multicast-routing vrf one
ip multicast vrf one mpls mldp

enables mLDP inband signalling for the VRF

interface Loopback0
ip address 10.1.100.3 255.255.255.255
ip pim sparse-mode

mpls mldp logging notifications

ip pim mpls source Loopback0


ip pim vrf one mpls source Loopback0

BRKIPM-2011

specifies source interface for multicast RPF


2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

67

Configuration IOS-XR
vrf one

multicast-routing

address-family ipv4 unicast

address-family ipv4

import route-target

interface Loopback0

1:1

enable

export route-target

mdt source Loopback0

1:1

vrf one

address-family ipv6 unicast


!

interface GigabitEthernet0/0/0/9
vrf one
ipv4 address 10.2.1.1 255.255.255.0

address-family ipv4

interface used to set


MDT source address
enables mLDP inband
signalling for the VRF

mdt source Loopback0


mdt mldp in-band-signaling ipv4
interface all enable
!
router igmp
vrf one

route-policy rpf-for-one
set core-tree mldp-inband

specify core-tree type

interface GigabitEthernet0/0/0/9
!
router pim

mpls ldp

vrf one

enables mLDP

mldp
logging notifications
!
interface GigabitEthernet0/0/4/0
BRKIPM-2011

address-family ipv4
rpf topology route-policy rpf-for-one

specify route-policy to
select RPF topology
2014 Cisco and/or its affiliates. All rights reserved.

interface GigabitEthernet0/0/0/9

Cisco Public

68

Rosen Model mVPN over mLDP

Rosen mVPN over mLDP Default MDT


Default MDT
PIM join

PIM join

Leaf PE
CE

Leaf PE

Leaf PE

CE

CE

Leaf PE

Leaf PE

CE

CE

Default-MDT created in core using single MP2MP LSP


By configuration
Any core router is specified as root

PIM or BGP used for Customer route signalling over default-MDT

Default-MDT emulates a virtual LAN


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

70

Rosen mVPN over mLDP Data MDT


PIM Data-MDT Join TLV
C-(S,G)
FEC Element
traffic rate
exceeds threshold

FEC element
root

Data-MDT

vpn-id
Leaf PE
Source

CE

PMSI ID

Leaf PE

Leaf PE

CE

CE

Leaf PE

Leaf PE

CE

CE

For high rate sources data-MDT created using P2MP LSPs


Removes traffic from default-MDT to offload PEs that did not join stream

Creation of data-MDT is signalled dynamically using MDT Join messages or BGP A-D
routes
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

71

Rosen mVPN over mLDP


Known from Rosen GRE
same principles/architecture
Default MDT = one MP2MP LSP (opaque type MDT), created as soon as the root is configured
on the leaf(s)
Data MDT is P2MP LSP (opaque type MDT), signalled by PIM by ingress PE upon reaching
threshold rate

No need to configure IPv4 multicast in core


Avoiding cumbersome design/management of IPv4 groups for Default MDT or IPv4
group ranges for Data MDTs per customer VRF/PE
PIM or BGP signalling in overlay

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

72

Configuration - IOS
vrf definition one
rd 1:3
vpn id 1:1

vpn id needs to be configured

route-target export 1:1


route-target import 1:1
!
address-family ipv4
mdt default mpls mldp 10.1.100.7
mdt data mpls mldp 100

root address of mp2mp tree


data MDTs

ip multicast-routing vrf one

interface Loopback0
ip address 10.1.100.3 255.255.255.255
ip pim sparse-mode
!
ip pim mpls source Loopback0
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

73

Configuration IOS-XR
vrf one

multicast-routing

vpn id needs to be configured

vpn id 1:1

address-family ipv4 unicast

mdt source Loopback0

import route-target
1:1

vrf one

!
export route-target
1:1

interface used to set MDT


source address

address-family ipv4
mdt source Loopback0
mdt default mldp ipv4 10.1.100.7

root address of mp2mp tree

mdt data 100

address-family ipv6 unicast

interface all enable

data MDTs

route-policy rpf-for-one
set core-tree mldp-default

router pim

specify core-tree type

vrf one

specify route-policy to
select RPF topology

mpls ldp

address-family ipv4
rpf topology route-policy rpf-for-one

enables mLDP

mldp

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

interface GigabitEthernet0/0/0/9

Cisco Public

enable

74

Rosen mVPN over mLDP BGP AD


No need for BGP AD to autodiscover the PEs
Root is known by configuration

BGP AD signaling can be used instead of PIM Join TLV signaling


When Data MDT threshold is crossed
AF IPv4 mvpn is used to advertise (C-S, C-G) to S-PMSI tunnel binding
IOS

IOS-XR

vrf definition one

multicast-routing

address-family ipv4

vrf one

mdt auto-discovery mldp pim-tlv-announce

address-family ipv4

mdt default mpls mldp 10.1.100.7

bgp auto-discovery mldp

mdt data mpls mldp 100


router bgp 1
router bgp 1

address-family ipv4 mvpn

address-family ipv4 mvpn

vrf one

neighbor 10.1.100.7 activate

address-family ipv4 mvpn

neighbor 10.1.100.7 send-community extended


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

75

Rosen mVPN over mLDP - Data MDT BGP AD


BGP IPv4 mvpn update
PMSI type

FEC Element
FEC type
adress family
Root
vpn-id
traffic rate
exceeds threshold

PMSI ID
Data-MDT
Leaf PE

Source

CE

Leaf PE

Leaf PE

CE

CE

Leaf PE
Leaf PE

BRKIPM-2011

CE

CE

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

76

Rosen Co-Existence/Migration
Rosen GRE and Rosen mLDP can co-exist, even in one VRF
GRE is preferred if both are present

Migration is possible from Rosen GRE to Rosen mLDP


Steps
1. Enable mLDP in core
2. Migrate per PE, per VRF at a time

Preference command to prefer mLDP over GRE

3. Remove Rosen GRE when all VRFs/PEs are in Rosen mLDP


mGRE

mdt preference mldp


mLDP
Receiver
(S1, G)
PE3

Source
(S1,G)

CE

CE
Source
(S2,G)
BRKIPM-2011

PE1

mdt preference mldp

Receiver
(S1, G)
(S2, G)

PE2

2014 Cisco and/or its affiliates. All rights reserved.

CE

PE4

CE
Cisco Public

77

Rosen Co-Existence/Migration
IOS

IOS-XR

vrf definition one

route-policy rpf-for-one

RPF topology mLDP used

rd 1:3

set core-tree mldp-default

vpn id 1:1
route-target export 1:1

multicast-routing

route-target import 1:1

vrf one

address-family ipv4

address-family ipv4
mdt preference mldp

mdt source Loopback0

Prefer mldp over GRE

mdt default mpls mldp 10.1.100.7


mdt data mpls mldp 100
mdt default 232.100.1.1
mdt data 232.100.100.0 0.0.0.255

BRKIPM-2011

mdt data 232.100.100.0/24


mdt default ipv4 232.100.1.1

Both Rosen mLDP and Rosen


GRE configured (and
signalled)

2014 Cisco and/or its affiliates. All rights reserved.

mdt default mldp ipv4 10.1.100.7


mdt data 100
interface all enable

Cisco Public

78

Rosen mVPN over mLDP


Summary
Default-MDT created using MP2MP LSP

Functionality as you know, but instead of GRE, MPLS encapsulation and


mLDP replaces PIM/multicast in core
MP2MP is more scalable than PIM SM/SSM since no per PE state created in
provider core
BGP A-D support for Data-MDTs

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

79

Rosen Model mVPN over mLDP Full Mesh


P2MP

Rosen mVPN over mLDP Default MDT is Full Mesh


P2MP
Default MDT

Leaf PE
CE

Leaf PE

Leaf PE

CE

CE

Leaf PE

Leaf PE

CE

CE

Default-MDT created in core using full mesh of P2MP LSPs


Each PE is root of one P2MP mLDP LSP
BGP AD must be enabled!
Might be used when interoperating

P2MP might be easier understood than MP2MP


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

81

Configuration IOS-XR
router bgp 1

multicast-routing

address-family vpnv4 unicast


address-family ipv4 mvpn

mdt source Loopback0

AF ipv4 mvpn is needed

vrf one

address-family ipv4
neighbor 10.1.100.5

mdt source Loopback0

address-family vpnv4 unicast


address-family ipv4 mvpn
!

mdt default mldp p2mp

Default MDT is full mesh of


P2MP mLDP LSPs

mdt data 100


interface all enable

vrf one

rd 1:1

bgp auto-discovery mldp

BGP AD is needed

address-family ipv4 unicast

router pim

redistribute connected
!
address-family ipv4 mvpn

vrf one

specify route-policy to
select RPF topology

address-family ipv4
rpf topology route-policy rpf-for-one

!
route-policy rpf-for-one
set core-tree mldp-default
BRKIPM-2011

interface GigabitEthernet0/0/0/9

specify core-tree type


2014 Cisco and/or its affiliates. All rights reserved.

enable

Cisco Public

82

Partitioned MDT mVPN over mLDP

Partitioned MDT mVPN over mLDP


Introduction
Dynamic version of Rosen model

Key difference
MDT built only when customer traffic needs to be transported across core

Address issues in Rosen model


Optimizes deployments where customer sources are mostly co-located in few sites
Supports Anycast sources
With Rosen -> Default MDT-> Asserts

Default MDT is MP2MP or P2MP


Data MDT is always P2MP
Reduces the number of PIM neighbors
PIM neighborship is unidirectional: ingress PE sees egress PEs as PIM neighbors

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

84

Partitioned MDT mVPN over mLDP


Auto Discovery of Candidate PEs
BGP MVPN SAFI
[*,*] PE1
mLDP ID X

Receiver
(S1, G)
PE 3

Source
(S1,G)

CE

PE 1

BGP MVPN SAFI


[*,*] PE2
mLDP ID Y

CE

Source
(S2,G)

CE

BGP RR

PE 4

PE 2
PE 5

CE

CE

Receiver
(S2, G)

Receiver
(S1, G)
(S2, G)

Initially there is no (default) MDT


Candidate PEs advertise their LSP identifier as [*,*] wildcard S-PMSI via BGP AD, we
call this the MS-PMSI
In this example PE1 and PE2 are candidates

Note, using BGP AD MVPN SAFI is optional, Cisco also supports it without
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

85

Partitioned MDT mVPN over mLDP


Setting up the MDT
MP2MP or P2MP LSP
PIM join
(S1,G)

Receiver
(S1, G)

Multicast packet

BGP MVPN SAFI


Source
(S1,G)

CE

PE1

PE3

CE

[*,*] PE1, mLDP X


[*,*] PE2, mLDP Y
CE

PE4

Source
(S2,G)

CE

Receiver
(S2, G)

Receiver
(S1, G)
(S2, G)

PE2
PE5

CE

PE3 determines that S1 is reachable via PE1 by doing a RIB lookup


PE3 joins the [*,*] mLDP LSP as advertised by BGP AD for PE1
When the mLDP LSP is ready, PE3 sends PIM join. Tree is either MP2MP or P2MP

PE5 joins same (S1,G) it follows same procedures as PE3


PE4 does not see P-MDT traffic and signalling for (S1,G)
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

86

Partitioned MDT mVPN over mLDP


Setting up the MDT
MP2MP or P2MP LSP

PIM join
(S2,G)

Multicast packet

Receiver
(S1, G)
BGP MVPN SAFI
Source
(S1,G)

CE

PE1

PE3

PE4

CE
Source
(S2,G)

CE

[*,*] PE1, mLDP X


[*,*] PE2, mLDP Y

PE2
PE5

Receiver
(S2, G)

CE

Receiver
(S1, G)
(S2, G)

CE

PE4 determines that S2 is reachable via PE2 by doing a RIB lookup


PE4 joins the [*,*] mLDP LSP as advertised by BGP AD for PE2
When the mLDP LSP is ready, PE4 sends PIM join. Tree is either MP2MP or P2MP
PE2 joins (S2,G) in customer site and forwards packet down LSP
PE5
now joins (S2,G) and
follows same procedures as PE4
BRKIPM-2011
2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

87

Partitioned MDT mVPN over mLDP


BGP MVPN SAFI

PPMP Usage
Unicast LSP
Label

PPMP
Label

[*,*] PE1
mLDP ID X
PPMP Label

PIM Join

PPMP LSP

PIM join
(S1,G)

Multicast packet

turnaround

Receiver
(S1, G)

Unicast LSP
PE3

Source
(S1,G)

CE

PE1

BGP MVPN SAFI


[*,*] PE1, mLDP X
[*,*] PE2, mLDP Y

Source
(S2,G)

CE

CE

PE2

PE4

PE5

CE

CE

Receiver
(S2, G)

Receiver
(S1, G)
(S2, G)

PPMP is needed when P2MP is used and PIM as overlay signalling protocol
Root advertises BGP MVPN prefix with PPMP label
Leafs use the PPMP label to encapsulate PIM Joins/Prunes to root, which turns around the packet and sends it out
mcast on the P2MP tree to all egress PEs
A P2P LSP is not set up explicitly, its an existing P2P LSP that is used to reach the root

Why does the PIM Join/Prune need to be received by all egress PE routers?
Because of the way PIM Sparse mode works (e.g. PIM router needs to see Joins/Prunes from other PIM routers)
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

88

Control Tree
C-PIM is SM or BiDir
How do the PE & C-routers learn RP?

RP
BSR

MP2MP or P2MP LSP


Receiver
(S1, G)
PE3
Source
(S1,G)

CE

CE

CE

PE1

PE4

Source
(S2,G)

mapping
agent

PE2
PE5

CE

CE

Receiver
(S2, G)

Receiver
(S1, G)
(S2, G)

P2MP Control Tree

Additional P2MP tree


Only for RP discovery trafic (AutoRP and BSR)

Not needed for any other model than the partitioned model
BGP-AD must be enabled
When an egress PE receives this AD route, it will join the P2MP tree
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

89

Configuration - IOS
vrf definition one
rd 1:3
vpn id 1:1
route-target export 1:1
route-target import 1:1
!
address-family ipv4
mdt partitioned mldp p2mp
mdt data mpls mldp 100

Partitioned P2MP
data MDTs

exit-address-family

router bgp 1
address-family ipv4 mvpn
neighbor 10.1.100.7 activate
neighbor 10.1.100.7 send-community extended

ip multicast-routing vrf one


BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

90

Configuration IOS-XR
vrf one

multicast-routing

vpn id 1:1

address-family ipv4 unicast

mdt source Loopback0

import route-target
1:1

vrf one

export route-target

address-family ipv4

1:1

mdt source Loopback0


mdt partitioned mldp ipv4 p2mp

specify partitioned MDT


route-policy rpf-for-one

set core-tree mldp-partitioned-p2mp

mpls ldp

mdt data 100

interface all enable

data MDTs
specify core-tree type (mp2mp or p2mp)

router pim

mldp

router bgp 1

vrf one
address-family ipv4

specify route-policy to select RPF topology

rpf topology route-policy rpf-for-one

address-family ipv4 mvpn

interface GigabitEthernet0/0/0/9

neighbor 10.1.100.7
address-familyBRKIPM-2011
ipv4 mvpn

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

enable

91

Partitioned MDT mVPN over mLDP


Summary
Only PIM join sent towards root
Only root (ingress PE) is seen as PIM adjacency - unidirectionally
Core tree is either MP2MP or P2MP
If PIM bidir needs to be supported, MP2MP is required

BGP A-D used to signal core tree [*,*]


BGP A-D used/needed to signal data-MDT
BGP is needed because Partitioned MDT does not lead to full mesh of PIM across core tree (Default MDT)

PIM or BGP as overlay signalling protocol


No core state if no customer traffic
Optimised when sources are co-located in few sites
Smaller PIM broadcast domain than Rosen mLDP
Fewer unnecessary PIM Join/Prune messages
No asserts (only one root per P-MDT)
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

92

VRF Static over P2MP TE

static over P2MP TE


model also exists in
global context

VRF Static over P2MP TE


BGP Update (S,G)
Route type 3 S-PMSI A-D route

P2MP TE LSP
Tunnel type 1 - RSVP-TE P2MP LSP
BGP Update (S,G)

includes RD

S-PMSI update is used to map


C-(S,G) in VRF to tailend of
P2MP TE tunnel (MPLS label
is incoming label)

PIM join
(S1,G)

multicast packet

Receiver
(S1, G)
CE

PE3
CE
Source
(S1,G)

PE1
PIM join
(S1,G)

PE5

CE

Receiver
(S1, G)
(S2, G)

Static mapping of C-(S,G) onto MTE tunnels, on PE headend


Egress PEs (leaves of P2MP TE tunnel) is statically configured destination list
There is no C-mcast signalling in overlay
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

94

Configuration IOS-XR Headend


interface tunnel-mte1

Tunnel type is MTE

ipv4 unnumbered Loopback0


destination 10.1.100.1
path-option 1 dynamic

Path-option can be explicit or dynamic

destination 10.1.100.3
path-option 1 dynamic

Destination list is static


Destination learning (dynamic egress PE set) through BGP AD
is future

!
destination 10.1.100.5
path-option 1 dynamic
!

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

95

Configuration IOS-XR Headend


vrf one

multicast-routing

vpn id 1:1

vrf one
address-family ipv4 unicast

address-family ipv4
import route-target

specify core-tree protocol rsvp-te

mdt source Loopback0

1:1

core-tree-protocol rsvp-te
export route-target

mdt static p2mp-te tunnel-mte1

Bind P2MP TE tunnel to VRF

1:1

interface all enable

router pim
vrf one
address-family ipv4

BGP AD needed
for P2MP TE

bgp auto-discovery p2mp-te

router igmp

rpf topology route-policy rpf-for-one

vrf default

interface tunnel-mte1
enable

specify route-policy to select RPF topology

interface GigabitEthernet0/1/0/0

vrf one

enable

interface tunnel-mte1
static-group 232.1.1.1 10.2.2.9

route-policy rpf-for-one
set core-tree p2mp-te-default

BRKIPM-2011

C-(S,G) mapping to P2MP TE tunnel


2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

96

Configuration IOS-XR Tailend


vrf one

multicast-routing

vpn id 1:1

address-family ipv4

address-family ipv4 unicast

interface Loopback0

import route-target

enable

1:1

mdt source Loopback0

export route-target

1:1

vrf one
address-family ipv4

specify core-tree protocol rsvp-te


router pim

mdt source Loopback0

vrf one

core-tree-protocol rsvp-te

address-family ipv4
rpf topology route-policy rpf-for-one

interface all enable

BGP AD needed
for P2MP TE

bgp auto-discovery p2mp-te

interface GigabitEthernet0/0/0/9
enable

specify route-policy to select RPF topology

route-policy rpf-for-one
set core-tree p2mp-te-default
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

97

mVPN Rosen over P2MP TE

mVPN Rosen over P2MP TE


Full mesh of P2MP TE LSPs

Receiver
(S1, G)
PE3
CE
Source
(S1,G)

CE

PE1

PE5

CE

Receiver
(S1, G)
(S2, G)

Default MDT is full mesh of Static P2MP TE tunnels - Data MDT is future
BGP AD is required
No type 3 BGP route is needed
PIM or BGP C-signalling in overlay
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

99

Configuration IOS-XR Headend


vrf one

multicast-routing

vpn id 1:1

vrf one

address-family ipv4 unicast

address-family ipv4

import route-target

specify core-tree protocol rsvp-te

mdt source Loopback0

1:1
export route-target
1:1

router pim

core-tree-protocol rsvp-te

Bind Default P2MP TE tunnel to


VRF

mdt default p2mp-te static tunnel-mte1


interface all enable

BGP AD needed
for P2MP TE

bgp auto-discovery p2mp-te

vrf one

router igmp

address-family ipv4

vrf default

rpf topology route-policy rpf-for-one

interface GigabitEthernet0/1/0/0

vrf one

enable

specify route-policy to select RPF topology

interface tunnel-mte1
static-group 232.1.1.1 10.2.2.9

route-policy rpf-for-one
set core-tree p2mp-te-default
BRKIPM-2011

C-(S,G) mapping to P2MP TE tunnel


2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

100

Configuration IOS-XR Tailend


vrf one

multicast-routing

vpn id 1:1

address-family ipv4

address-family ipv4 unicast

interface Loopback0

import route-target

enable

1:1

mdt source Loopback0

export route-target

1:1

vrf one
address-family ipv4

specify core-tree protocol rsvp-te


router pim

mdt source Loopback0

vrf one
address-family ipv4

core-tree-protocol rsvp-te

Bind Default P2MP TE


tunnel to VRF

mdt default p2mp-te static tunnel-mte1

rpf topology route-policy rpf-for-one


interface GigabitEthernet0/0/0/9
enable

interface all enable

BGP AD needed for


P2MP TE
specify route-policy to select RPF topology

bgp auto-discovery p2mp-te

route-policy rpf-for-one
set core-tree p2mp-te-default
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

101

Ingress Replication (IR)

Ingress Replication (IR)


BGP Update (S1,G)

Example of BGP
signalling for
Partitioned MDT

Route type 4 (Leaf AD)) (*, *) S-PMSI


Tunnel type 1 Ingress Replication
mVPN label

used by the egress PE to identify


the multicast IR data packet and
associate with one VRF

multicast packet
PIM join
(S1,G)
Receiver
(S1, G)
CE

Existing unicast LSPs are used (LDP or TE)

PE1

mVPN
Label

Unicast LSP
Label

CE

PE3

unicast LSPs

BGP AD is needed

PE5

CE

Receiver
(S1, G)
(S2, G)

Default-MDT (Rosen-like) and Partitioned MDT is supported (both with Data-MDT)


PPMP LSP is needed for Partitioned IR for egress PE sending PIM Join to ingress PE
PIM and BGP signalling in overlay is supported
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

103

Configuration IOS-XR
vrf one

multicast-routing

vpn id 1:1

address-family ipv4 unicast

mdt source Loopback0

import route-target

core-tree-protocol rsvp-te

1:1

static-rpf 10.2.2.9 32 mpls 10.1.100.2

interface all enable

export route-target

1:1

vrf one

specify MDT type


router pim

address-family ipv4

mdt source Loopback0

vrf one

BGP AD for IR

address-family ipv4
rpf topology route-policy rpf-for-one
mdt c-multicast-routing bgp

mdt partitioned ingress-replication


interface all enable

specify core-tree type

bgp auto-discovery ir

specify route-policy to select RPF topology

route-policy rpf-for-one

interface GigabitEthernet0/0/0/9
enable

BRKIPM-2011

set core-tree ingress-replication-partitioned

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

104

Ingress Replication (IR)


Summary

Using a P2MP LSP is not efficient


Replication on the ingress PE
Can be used for interop issues
Transport mcast across MPLS on a part/segment of the network
Can be done if amount of mcast traffic is really low

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

105

Comparison Deployment Models


Rosen GRE

Rosen mLDP

PIM/mcast in core needed

mLDP in core

Encapsulation in core is mGRE

Encapsulation in core is MPLS

Huge number of deployments

Deployments ramping up

C-PIM in overlay, but BGP is possible

C-PIM in overlay, but BGP is possible

Control traffic over Default MDT

Control traffic over Default MDT

Data MDT is signalled by PIM (or BGP) in


overlay

Data MDT is signalled by PIM (or BGP) in


overlay

Data MDT is P2MP mcast IP tree

Data MDT is P2MP FEC

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

106

Comparison Deployment Models


VRF mLDP In-band Signalling

mLDP Partitioned MDT

mLDP in core

mLDP in core

Encapsulation in core is MPLS

Encapsulation in core is MPLS

C-(S,G) state is present on P routers (in


mLDP)

C-(S,G) state is not present on P routers


There is one P-MDT per ingress PE per VRF

No overlay signalling

Overlay signalling

Control traffic over control tree


Data MDT (new P2MP FEC) can only be
signalled by BGP
PIM hellos are one way only

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

107

Inter-AS & CsC


Inter-AS
GRE: Option C
mLDP: Option B & C
P2MP TE: Options B & C

CsC
Recursive FEC needed

make sure ASBRs have VPNv4/v6 and IPv4/v6 MVPN routes


in case no VRF is configured

IOS
router bgp 1
address-family ipv4 mvpn
no bgp default route-target filter

IOS-XR
router bgp 1
address-family ipv4 mvpn
retain route-target all|route-policy

IOS-XR
multicast-routing

IOS-XR

vrf one
address-family ipv4
bgp auto-discovery mldp
inter-as

removes the no-export community


BRKIPM-2011

mpls ldp

needed for:

seamless MPLS

Inter-AS Option B

BGP-free core

2014 Cisco and/or its affiliates. All rights reserved.

mldp
recusive-fec

Cisco Public

108

LSM Conclusion

Multicast over MPLS Profiles


P2MP TE

PIM
GRE encap

MPLS encap

Static Global P2MP TE


(static (S,G))

Rosen GRE

Rosen GRE with


BGP-AD

mLDP

mLDP

mLDP

Inband Signalling

Rosen mLDP

Partitioned MDT

Global Inband
mLDP
VRF Inband
mLDP

VRF Static over P2MP


TE with BGP-AD
(static (S,G))
Rosen Static over P2MP
TE with BGP-AD

10

18

core tree

global

Rosen mLDP
MP2MP

Partitioned MDT
MP2MP

Rosen mLDP
MP2MP with BGPAD

Partitioned MDT
MP2MP with BGPAD

Rosen mLDP P2MP


with BGP-AD

17

Partitioned MDT
P2MP with BGPAD

Rosen mLDP
MP2MP with BGPAD and BGP cmcast signalling

13

Rosen mLDP P2MP


with BGP-AD and
BGP c-mcast
signalling

12

VRF

BGP AD

*no Data MDT


Rosen GRE with
BGP-AD and
BGP c-mcast
signalling

11

Rosen Static over P2MP


TE with BGP-AD and
BGP c-mcast signalling
*no Data MDT

*static = static destination


list in the core

BRKIPM-2011

16

2014 Cisco and/or its affiliates. All rights reserved.

Partitioned MDT
MP2MP with BGP-AD
and BGP c-mcast
signalling
Partitioned MDT P2MP
with BGP-AD and BGP
c-mcast signalling

Cisco Public

15

BGP C-mcast
signalling
14

110

Multicast over MPLS Profiles bis


IR

IR

P2MP

Rosen IR

Partitioned IR

Rosen P2MP TE

P2MP

core tree

Partitioned
P2MP-TE
global

VRF

BGP AD

Rosen IR with BGP-AD


and PIM c-mcast
signalling

Rosen IR with BGP cmcast signalling

19

Partitioned IR with
BGP-AD and PIM cmcast signalling

21

Partitioned IR BGP cmcast signalling

BRKIPM-2011

23

Rosen P2MP with BGPAD and PIM c-mcast


signalling

25

Rosen P2MP-TE with


BGP c-mcast signalling

2014 Cisco and/or its affiliates. All rights reserved.

20

Partitioned P2MP-TE
with BGP-AD and PIM
c-mcast signalling

22

Partitioned P2MP-TE
BGP c-mcast signalling

Cisco Public

24

BGP C-mcast
signalling
26

111

Conclusion
LSM provides unified unicast/multicast forwarding
mLDP and RSVP are both useful tree building protocols for transporting multicast over
MPLS
It depends on the application and the scalability/feature requirements which protocol is
preferred
Aggregation is useful to limit the number of LSPs that are created
Too much aggregation causes flooding

There are different options to assign multicast flows to LSPs, Static, PIM, BGP, and mLDP
in-band signaling
For general purpose mVPN we recommend mLDP for tree building and PIM for assigning
flows to the LSP
With NG mVPN, you can choose any model (per VPN/customer) !
Even per-source/per-group/next-hop with flexible route-policy (RPL)
BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

112

Questions?

Complete Your Online Session Evaluation


Complete your online session
evaluation
Complete four session evaluations
and the overall conference evaluation
to receive your Cisco Live T-shirt

BRKIPM-2011

2014 Cisco and/or its affiliates. All rights reserved.

Cisco Public

114