Sie sind auf Seite 1von 44

mkvg -y vgname -s 32 pvname

mkvg -y vgname -n -s 32 pvname


mkvg -y vgname -V majornumber -s 32
pvname
lsvg
lsvg -o
lsvg vgname
extendvg vgname pvname
reducevg vgname pvname
reducevg -d -f vgname pvname
varyonvg vgname
varyoffvg vgname
exportvg vgname
importvg -y vgname pvname
importvg -y vgname -n pvname
mirrorvg vgname pvname
unmirrorvg vgname pvname
mirrorvg -c 2 vgname pvname1 pvname2
unmirrorvg -c 2 vgname pvname1 pvname2
splitvg -y newvgname -c 1 vgname
joinvg vgname
chvg -Qn vgname
chvg -Qy vgname
chvg -hy vgname
chvg -hn vgname
chvg -sy vgname
chvg -sn vgname
chvg -ay vgname
chvg -an vgname
readvgda pvname
reorgvg vgname
reorgvg vgname lvname
chvg -t 2 vgname
chvg -g vgname

used to create a Vg with PP size 32MB


used to create a VG& keep the VG in varied off state
here we can define explicitely major number by using this command
list available VG's
lists only active VG's
used to display VG attributes
used to extend the PV to a volume group
used remove the Pv from a volume group
used to remove the PV's from volume group with force
used to make VG active
used to make VG inactive
removes definition of a volume group,the PV and its contents will
remain as it is,in VG
command used to import the VG,
-n option will keep the vg in varied off state
used to mirror the VG in to particular PV,mirrorvg will disable the
quorum
un mirror vg will remove the mirrored vg.and enable the quorum
used to mirror the Vg into 2 PV's
un mirror vg will remove the mirrored vg copies.and enable the
quorum
used to create a snapshot of the mirrored vg
used to join the VG fom snapshot
used to make quorum disable
used to make quorum enable
used to make VG hot spare flag : yes
used to make VG hot spare flag : NO
AUTO SYNC : YES
AUTO SYNC : NO
AUTO ON : YES
AUTO ON : NO
used to get VGDA details from PV
command used to re organize the allocation policies
used to re organize allocation policies of a LV
used to change the T-fator ,by default VG t factor is 1 ie max PPs per
VG : 1016 PP *32 PV
to use the effective space which is allocated to LUN

mklv -y lvname -t jfs/jfs2 vgname 5 pvname


mklv -y lvname -t jfs2 -a ie vgname 5 pvname
mklv -y lvname -t jfs2 -C 2 -S 1M vgname 4 pv1
pv2
mklv -y lvname -t jfs2 -C 2 -S 1M -c 2 vgname 4
pv1 pv2 pv3 pv4
mklvcopy lvname 2 pvname
extendlv lvname 5 pvname
rmlvcopy lvname 1 pvname
rmlv lvname
rmlv -f lvname
chlv -sy lvname
chlv -sn lvname
chlv -x 1024 lvname
splitlv -y newlvname oldlvname copies(2 to 3)
pv1 pv2
chlv -n newlv oldlv

cplv -y newlvname -v vgname lvname


chlv -L "newLVname" oldlvname
migratelp lvname/LP no/mirrorcopy no
/pvname/ppno
getlvcb -AT lvname
logform -V jfs2 /dev/lvname
chpv -c hdisk0

lv creation with 5 LP's


LV creation with 5 LP's & intra policy inner edge
creation of stripped LV
example of RAID 0 + 1 concept (st
creation of mirror LV
used to increase the 5 LP's in LV
remove the LV copy ,after execution of this command,1 copy will
remain in the system
used to remove LV
used to remove LV with force
EACH LP COPY ON A SEPARATE PV: YES (by default this is NO,can
keep same mirror copy on same PV: Y/N)
used to change the attribute " EACH LP COPY ON A SEPARATE
PV:YES /NO )
used to increase the LP's in a LV,by defauly only 512 LP's are
there in LV
used to split the mirrored LV
used to change the LV name
mount point and log device will not be copied ,have to make
explicitely in /etc/filesystems,can copy LV across VG's
used to change the LV LABEL name
used to migrate the lp no from LV and place tht into another PV in
particular PP no.
used to get information ie time created,and modified details of a
LV
logform command used to format the log device
clears the boot record of the physical volume ( BLV will be cleared
from hdisk0)

lspv
lspv pvname
migratepv sourcepv destinationpv
migratepv -l lvname sourcepv
destinationpv
chpv -vr pvname
chpv -va pvname
chpv -ay pvname
chpv -an pvname
chpv -hn pvname
chpv -hy pvname
lsvg -l `lsvg -o`
lsvg -p `lsvg -o`

lists the pv's and corresponding VG's


lists the PV attributes
migrate the contents of sourcepv to destination pv
migrapte the lv of sourcepv to destinationpv
PV STATE : remove (if PV state is remove,cant interact with tht PV)
PV STATE: active (should be active to interact with the PV)
ALLOCATABLE: YES (by default this is yes,if its NO,cant create any new
LV 's on this PV)
ALLOCATABLE :NO
HOT SPARE:NO (by default this is NO,if this is set to YES,cant use tht
PV,ie only for extra PV)
HOT SPARE :NO
used to list the total LV's in the active vg's
used to list the total pvs in all the active vg's

crfs -v jfs2 -d /dev/lvname -m /mntpnt


crfs -v jfs2 -d /dev/lvname -A yes /mntpnt
crfs -v jfs2 -d /dev/lvname -a log=INLINE or
dedicated -A yes -m /mntpnt
chfs -m /newmntpnt /oldmntpnt
chfs -a size=+128M /mntpnt
chfs -a size=-128M /mntpnt
chfs -a log=dedicated /mntpnt
chfs-A yes /mntpnt
rmfs /mntpnt
mount -V jfs2 -0 log=/dev/hd8 /dev/lvname
/mntpnt

cmd for creation o file system


cmd for creation of file system with auto mount flag : yes
used to create file system with dedicated log device with auto
mount : YES
used to change the mount point
used to increase the file system size
used tp decrease the file system size
used to assign the dedicated log device to mount point
used to assign Auto mount : yes
rmfs command will remove mount point as well as
corresponding LV
this command will mount the file system with different mount
point

mkps -an -s no of lps vgname pvname


chps -ay pagingname
chps -an pagingname
swapon /dev/pagingname
swapoff /dev/pagingname
chps -s 3 pagingname
chps -d 3 pagingname
lsps -a ,lsps -s
rmps pagingname

/etc/swapspaces

used to make the pagingspace name


used to change the attribute AUTO flag,if AUTO flag set to Yes
means,after reboot,PS will be active
if AUTO flag set to NO means,after reboot,PS will be in active
used to change the paging space to active
used to change the pagings space in active
used to increase the pagingspace by 3 PP's
used to decrease the paging space by 3 PP's
-a flag list's all paging spaces,-s flag gives the summary size of active
paging spaces
rmps command will remove the paging space name
This file lists all the paging spaces that are automatically put into
service on each system restart(the 'swapon -a' command executed
from /etc/rc swaps on every deivce listed here).
This file is modified by the chps, mkps and rmps commands and
referenced by the lsps and swapon commands.

lsdev -Cc disk


rmdev -l hdisk1
mkdev -l hdisk1
rmdev -dl hdisk1
lvlstmajor
lvgenmajor rootvg
cfgmgr
cfgmgr -v
lsdev -Cc if
lsdev -Pc predifined Database class
ifconfig -a
ifconfig en0
ifconfig en0 up
ifconfig en0 down
ifconfig -a -d
ifconfig en0 detach
ifconfig en0 192.168.1.227 alias
ifconfig eno delete
ifconfig eno 192.168.1.227 delete
chdev -l en0 -a netaddr=192.168.1.228 -a
state=up
chdev -l en0 -a "netaddr=192.168.1.228
state=up"
chdev -l hdisk2 -a pv=yes
chdev -l hdisk2 -a pv=clear
chdev -l ent0 -a media_speed=10_Full_Duplex
-P
lsattr -El en0
lsattr -El ent0
lsdev -Cc if
arp -a
lsdev -P/C -H
entstat -d ent0|more
/etc/resolv.conf
/etc/netsvc.com
chdev -l inet0 -a gateway=192.168.1.1
traceroute yahoo.com

ping -c 5 ndtv.com
mknode devicename (b-block type/c- char
type) 17(majornumber) 70(minor number)

NOTES:
1. A single interface can have more than one
IP address
2. Configure more than one IP address on a
single interface is calles alias

PCI (pheripheral computer interface)


there are 3 types of PCI's

SCSI can be of above 3 PCI types


Physical locator code starts with "U"
Each part is having FRU(Field replacement
unit) number

# lsconf (# prtconf)
location code format for PCI devices
SCSI Adapter can connect maximum 15
devices(SCSI is having the capability to
address max 15 devices)
SCSI ID's will range from 0-16
SCSI ID '7' will not be used,its reserved for the
SCSI device
Each SCSI device will represent 1 device
the entire HARD DISK we will call it as one LUN
(logical unit number)
if we devide the Harddisk into multiple
partitions,each partition is called as LUN
location code format for scsi devices

command to list the disk related devices from customized data


base
command used to keep the hdisk1 in defined state
command used to bring the device from defined state to usable
state
command used to delete the hdisk1
used to list the free major number's
used to list the major number of rootvg
used to scan for new hardware changes
used to scan for new hardware changes in verbose mode
used to list the interfaces
to lists the predefined device drivers
used to list all the interfaces
used to list the interface present details
used to bring the interface up
used to bring the interface down
command used to list the interfaces which are in down state
used to detach the interface
used to create alias to the original IP
it will delete all IP's of interface,once reboot the machine,it will
assign the default IP from ODM
it will delete the specified IP.
used to assign the IP for the interface
another way to use the above command
used to assign the PVID to the object
used to clear the pvid of the object
used
used
used
used

to
to
to
to

change the media speed attribute in the ODM, flag P


change in ODM
list the attributes of interface
list the attributes of adapter

used to list the interface devices from the Customized database


command to list the IP to MAC address
used to list the all the classes from Predefined or customized with
Header
will list the complete statistics of an adapter
this file contains the IP Address to Name resolution
contains LOCAL,BIND(Berkely international network domain)
used to assign the Gatewat IP address
command to trace the root path to server

here it will ping only 5 times

PCI (cost is less)


PCIX (PCI Extended) (cost is higher than PCI)
PCIE (PCI Express) (cost is high)
SCSI (small computer system interface)

FRU P/N 89ps300


both commands are same,these are used to list the entire
machine configuration
AB-CD-EF-GH

AB-CD-EF-G,H(SCSI ID,LUN No)

fsck /mntpnt (fsck -y /mntpnt)


fsck -n /mntpnt
fuser
fuser
fuser
fuser

-u /mntpnt
-k /mntpnt
-uk /mntpnt
-uckx /mntpnt

/var/spool/cron/crontabs
/var/adm/cron/log
crontab -e,crontab -l ,crontab -r
at -f filename or path -t
CCYYMMDDhhmm.ss
atq
at noon,at midnight

this command will check and repair the file system


this will only check the file system & it will not repair,this is called,fsck in
reporting mode
it will display the user who is using the given file system
it will kill the user's who is using this file system
it will kill the user's and display the killed users
used to kill the kernel extension jobs
crontab path
crontab log file
min hour (day of the month) (month) (day of the week) command
used to run the job at particular time by using 'at' command
used to list the at jobs

NFS (Network File system) NFS


Portno:2049
NFS Server

NFS client

rpcinfo
startsrc -g portmap
startsrc -g nfs
stopsrc -g portmap
stopsrc -g nfs
stopsrc -g portmap
lssrc -g nfs
lssrc -s biod
lssrc -a
/etc/exports
showmount -e
share
showmount -e aix27
exportfs
exportfs -a
export -I /mntpnt
export -u /mntpnt
mount servername or IP:/exportname
/local mount point
mount aix27:/myfs1 /myfs2
crfs -v nfs -d /remote-fs -A yes -a
nodename=aix27 -a options=hard,rw
-m /local
options=hard,rw
options=soft,rw
hard (Cntrl + c will not work),have to
define explicitely options=hard,rw,intr

soft

check=Yes
check=No
/usr (check=false)

mount
2 types of NFS mapping
direct mapping

indirect mapping

nfsd
rpc.mountd
rpc.lockd
rpc.statd
biod (Binary input output daemon (Imp to access data from NFS server)
rpc.statd
rpc.lockd
Reports the status of Remote Procedure Call
used to activate portmap on the NFS server or client
used to activate the nfs services on the NFS server or client
used to in activate ie(in operative) NFS
on the
NFS server
orNFS
client
Portmap
services
on the
server or
client
used to list the NFS services
used to list the subsystem resources
used
the resource
controllers
this istoa list
file all
where
we can keep
mount points,in order to make the
machine as NFS server
To configure a share in NFS server put mount point in /etc/exports
this will show the contents of /etc/exports file
this will show the contents of /etc/exprots file
used to show the contents of specified machine
Exportfs
unexportsand
directories
to NFS
clients.mounts to /etc/exports
To
refreshand
/etc/exports
add newly
configured
file
used to export the file systems
temporary Export ,after reboot this exported mount point will not exist
used to unexport mount points from NFS clients (temporary)

command
usedwill
to mount
file system
frominthe
NFS client
this
command
not create
any stanza
/etc/filesystems
in the NFS
client

this command
is used to are
create
a default
stanza inoptions
the /etc/filesystems
hard
and no interrupt
the
for the NFS client
to
NFS
Server
we can explicitely defince soft option to link betweek NFS client and NFS
server
When the NFS server is not available,and we are trying to access from
the NFS client,it will hang in the middle till NFS server come up to
available state this is called hard mount
When the NFS server is not available,and we are trying to access from
the NFS client,it will not hang in the middle till NFS server come up to
available state this is called soft mount

if check is Yes means,at the time of reboot ,fsck -y will applies to mount
point
if check is no means,at the time of reboot,fsck -n will not applies to
mount point
fsck -y command usually we will run when the file system is in the
unmount state
But at the time of reboot this /usr directory will be automatically
mounted,so its not recommended to apply fsck when f.s is mounted
by using only mount command we can see the nodename and options of
NFS along with other f.s details
create a file system in server A and keep the file system in /etc/exports
in server B ,create 2 file's ie /etc/map( /prasad
and /etc/auto_master (/- /etc/map)
then run the # automount -v

server A:/mntpnt )

tht means with out creating prasad directory,we can specify as per above
and mount the Server A mount point
when login into user ,have to mount automatically (home/username)

ODM (Object data manager)


is a database of system and device configuration information integrated into IBM's AIX operating syste
ODM consists of following
network configuration
LVM configuration
physical devices & logical devices information
installed s/w info
predefined data base consists of device driver s/w
customized data base consists of device's
menus, screens and commands that SMIT uses
create
delete
modify
display
ODM directories
/usr/lib/objrepos
/usr/share/lib/objrepos
/etc/objrepos
to create a class
vi prasad.cre
class student {
char name[10];
char class[20];
short rno[5];
}

to create object
vi prasad1
student:
name="prasad"
calss="mca"
rno=24

device configuration information integrated into IBM's AIX operating system.

evices information

ts of device driver s/w


sts of device's
nds that SMIT uses
ODM class
odmcreate
odmdrop
odmshow

ODM Object
odmadd
odmdelete
odmchange
odmget

this file consists of customized objects

aix27:root:/:# cat prasad.cre


class student {
char name[10];
char class[20];
short rno;
}
aix27:root:/:# odmcreate /prasad.cre
student
aix27:root:/:# cat prasad1
student:
name="prasad"
class="mca"
rno=24
aix27:root:/:# odmadd /prasad1
odmshow student
aix27:root:/:# odmshow student
class student {
char name[10];
char class[20];

/* offset: 0xc ( 12) */


/* offset: 0x16 ( 22) */

short rno;
};

/* offset: 0x2a ( 42) */

/*
descriptors: 3
structure size:
0x2c (44) bytes
data offset: 0x20003014
population:
1 objects (1 active, 0 deleted)
*/
aix27:root:/:# odmget -q rno=24 student
student:
name = "prasad"
class = "mca"
rno = 24
aix27:root:/:# odmchange -o student -q rno=24 /prasad2
aix27:root:/:# odmget student
student:
name = "prasad"
class = "mca"
rno = 30
aix27:root:/:#
aix27:root:/:# odmget student
student:
name = "prasad"
class = "mca"
rno = 30
add second object to the class from /prasad2
aix27:root:/:# odmadd /prasad2
aix27:root:/:# odmget student
student:
name = "prasad"
class = "mca"
rno = 30
student:
name = "prasad"
class = "mca"
rno = 30

how to delete object


aix27:root:/:# odmget student
student:
name = "prasad"
class = "mca"
rno = 24
student:
name = "prasad"
class = "mba"
rno = 30
aix27:root:/:# odmdelete -o student -q class=mba
0518-307 odmdelete: 1 objects deleted.
aix27:root:/:# odmget student
student:
name = "prasad"
class = "mca"
rno = 24

passwordless authentication is used to define the user to login to remote machine with out issuing an

assume tht server A is having root user and this root user of server A wnt to login into the SERVER B w
password

to carry out this scenario,in SERVER B (/etc/hosts.equiv) file we need to define (root user of SERVER A)
follows
SERVER B
/etc/hosts.equiv (file contais a list of trusted hosts)it is used by the rsh,rlogin and rcp commands
SERVER A root
or
SERVER A
or
username
we need to define the user as above to carry out the password less authentication
we can also define as trusted user by login into the normal user
vi rhosts
host1

name of a host considered trusted by the local system individual user on the trusted host tht can login
password,if no users are specified then all users on the trusted host can login with out a password

/etc/inetd.conf (inetd - internet daemon)

inetd listens on designated ports used by internet services such as FTP, POP3, and telnet. When a TCP
packet arrives with a particular destination port number, inetd launches the appropriate server progra
the connection. For services that are not expected to run with high loads, this method uses memory m
since the specific servers run only when needed. Furthermore, no network code is required in the appl
daemons, as inetd hooks the sockets directly to stdin, stdout and stderr of the spawned process. For p
have frequent traffic, such as HTTP and POP3, a dedicated server that intercepts the traffic directly ma
preferable.

The file /etc/services is used to map port numbers and protocols to service names, and the file /etc/inet
map service names to server names. For example, if a TCP request comes in on port 23, /etc/services s
telnet
23/tcp
The corresponding line in the /etc/inetd.conf file is
telnet

stream

tcp6

nowait

servicename sockettype protocol

root

wait/nowait

/usr/sbin/telnetd

user

server prg

telnetd -a

arguments

This tells inetd to launch the program /usr/sbin/telnetd with the command line arguments telnetd -a. ine
automatically hooks the socket to stdin, stdout, and stderr of the server program.
/etc/services
ftp portnumber 21
telnet portnumber 23
rlogin
ssh
rsh
by using following command we can start or stop inetd.conf
# startsrc inetd
#stopsrc inetd
#refresh -s inetd
#netstat -an (comd used to see port listening or not)

RUN LEVELS
run levels are ranging from 0 to 9
and h

and a,b,c

these run levels are stored in the file called


/etc/inittab(intialization table) file
every 60 seconds this /etc/inittab file will be
refreshed automatically and if any new entry
are to be processed ,it will process
the stanzas line contains 1024 characters in
the /etc/inittab file
the stanza format is as follows:
runlevel : id : action(wait/once,respawn)
: command
once
wait

respawn
boot
the command to find out the system run level
is
who -r
cat /etc/.init.state
the default run level for the system is 2

to change the run level's the command are


telinit 0 to 9
telinit a,b,c,d and h ( when we run this run
level's by using telinit a or init a,the system will
not change the run levels,but it will run the
programs at this run levels)
if we wont give any run level id ,at evry run
level execution by default this no id run level
will be executed
for 0 and 1 run level
init 0

init 1

init 2

telinit q
telinit m

run the program once(dont wait for the 1st program till its
completion) and goto next program
wait till the program get executed and execute the next
program
assume in one run level 2 pgrms called prgm1 and prgm2 are
running,the prgm1 is infinite loop,when we run this run
level,the prgm1 will be run continuously and prgm2 is normal
pgm used to display 5 numbers,due to any reasons the prgm1
is killed means,it will be stated automatically
only at the time of boot this run level will be executed

aix27:root:/:# init 0
INIT: New run level: 0 (ENTER)
aix27:root:/:#
aix27:root:/:# init 1
INIT: New run level: 1 (ENTER)

aix27:root:/:#
aix27:root:/:# init 2
INIT: New run level: 2 (ENTER)
aix27:root:/:#

used to tell the /etc/inittab file to check for the new entries and
run those new entries(traverse once and run those new entries)
used to bring the system into maintanance mode ie single user
mode

CORE file
errpt

/usr/lib/errdemon
/usr/lib/errdemon
/usr/lib/errstop
errclear 0
errprt -a

errpt - i /tmp/errpt_backup
errpt -d H
errpt -d S
errclear -d H 0
errpt -c > /dev/console
errpt -a -c > /dev/console
errpt -j identifier
errlogger "test msg to be record"

errpt -d S -T TEMP
errpt -s MMDDhhmmYY -e MMDDhhmmYY

aix27:root:/:# /usr/lib/errdemon -l
Error Log Attributes
-------------------------------------------Log File
/var/adm/ras/errlog
Log Size
73728 bytes
Memory Buffer Size
32768 bytes
Duplicate Removal
false
Duplicate Interval
10000 milliseconds
Duplicate Error Maximum 1000
by using the following command we can
change the above errdemon attributes

/usr/lib/errdemon - I /tmp/messages
/usr/lib/errdemon -s 2097152
/usr/lib/errdemon -B 2097152
/usr/lib/errdemon -d
/usr/lib/errdemon -D
/usr/lib/errdemon -t 20000
/usr/lib/errdemon -m 2000

NOTE:
When /var/adm/ras/errlog gets
corrupted ,the work around is to remove
the file and start and stop te error
demon,doing this will recreate the
errorlog file,do not nullify errorlog file.

cat > /var/adm/ras/errlog

When ever any program failed ,tht failed information will be kept in this
file
is a command used to get the error related information from
/var/adm/ras/errlog

this errdemon is used to track the errors,when ever any error occurs this
will put all those errors in the /var/adm/ras/errlog
used to start the error demon
used to stop the error demon
used to clear all recorded errors in the /var/adm/ras/errlog
used to see the detailed report of errlog
if errlog type file is stored in some other location,by using this command
we can explore those contents
used to diplay only H/W errors
used to display only S/W errors
this will clear only H/W related errors
errlog wil be redirected to console
detailed errorlog report will be redirected to console
used to display the errors by identifier wise
by using errlogger command we can record our own error messages to
the errlog
used to display the (d for class) software type and (T for type) and TEMP
type error messages
used to display the errors from and to date

command used to display the errdemon attributes

command used to change the log file location


used to change the log size
used to change the memory buffer size
used to change the duplicate removal attribute to false
used to change the duplicate removal attribute to true
used to change the Duplicate interval
used to change the Duplicate error maximum

this is not recommended to nullify the errlog file.its better to remove the
full file,and start/stop the errdemon to recreate the errlog file.

dump
the contents of real memory will be copied
into logical volume ie paging space
at the time of reboot the /dev/hd6 contents
will be moved to /var/adm/ras/vmcore.0 file
the default system dump device is /dev/hd6
if there is no enough space in /dev/hd6
means,the dump will not occur
to find out how much size is required for
both /dev/hd6 and /var/adm/ras directory the
following command is used
sysdumpdev -e
the default sysdumpdev attributes can be get
by using the following command
aix27:root:/:# sysdumpdev -l
primary
/dev/hd6
secondary
/dev/sysdumpnull
copy directory
/var/adm/ras
forced copy flag
FALSE
always allow dump FALSE
dump compression
ON
the above attributes can be changed by using
following commands
sysdumpdev -Pp /dev/aix27dumpdev
sysdumpdev -Pps/dev/aix27dumpdev
sysdumpdev -p /dev/aix27dumpdev
sysdumpdev -s /dev/aix27dumpdev
sysdumpdev -d /tmp/dumpdir
dump compression (ON /OFF)
sysdumpdev -c
sysdumpdev -C
sysdumpdev -K
ctrl + alt + 1
ctrl + alt + 2

alog -t console -o
/dev/hd6 ---> /var/adm/ras

capturing the memory contents is called as dump

to estimate the dump size

to change the primary device permanently


to change the secondary device permanently
to change the primary device temporarily
to change the secondary device temporarily
to change the default copy directory

Off
ON
to take the system dump manually
primary dump device
secondary dump device

to know the messages tht are happned at the time of boot


copycore command is used to carry out the moving operation at the
time of boot

Backup's
rootvg
# mksysb -ie /dev/rmt0
# mksysb -i /backup/rootvg.bkup

/image.data
# mkszfile
# lsmksysb -lf /dev/rmt0
l - list vg information only ,f - device or file)
# lsmksysb -f /mksysb/sep_042011
# lsmksysb -lf /mksysb/sep_042011
# lsmksysb -Lf /mksysb/sep_042011

user defined VG's


# savevg -f /dev/rmt0 aixvg
# restvg -f /dev/rmt0 pvname
# savevg -f /backup/aixvg.bkup aixvg (aixvg is lying in
the hdisk3)
/backup is the filesystem created in bixvg ie hdisk4
# restvg -f /backup/aixvg.bkup pvname
reducevg -d -f aixvg hdisk3
restvg -f /backup/aixvg.bkup hdisk3
restvg -f /backup/aixvg.bkup -P 64 hdisk3
restvg -f /dev/rmt0 -P 64 hdisk3
The procedure to change PP size for rootvg is different
as shown below
edit the /image.data file and change PP_size = 32 to
64 ..)

backup Command

backup -I -v -q -f /dev/rmt0

cat /tmp/file | backup -ivqf /dev/rmt0


find /etc -print | backup -ivqf /dev/rmt0
restrore command
restore -xvqf /dev/rmt0
restore -Tvqf /dev/rmt0

find / -name passwd -print


find / -xdev -name hosts .equiv -print
find / -xdev -name hosts -print
find . -perm 0600 -print
touch -t 201109030600.10 [[[CC]YY]MMDDhhmm[.SS]]
/myfs1
tar command(tape archive)tar command cant span
multiple volumes
tar -cvf /dev/rmt0 /myfs1
tar -cvf /backup/myfs1.tar /myfs1
tar -tvf /dev/rmt0
tar -tvf /backup/myfs1.tar
tar -xvf /backup/myfs1.tar /tmp/backup
tar -xvf (filename or device) ("files or
directories to restore")

command used to perform the rootvg backup into tape


command used to perform the rootvg backup into
filesystem
I - backup will be created as image file
e - exclude files (vi /etc/exclude.rootvg)
^./etc/ (have to keep like this format in the exclude file)
contains info about data related to root VG
command used to create image.data file for rootvg
lists vg information

lists entire files and directories from the rootvg backup


lists the vg information only
lists the file sets info

command used to perform the aixvg backup into tape


command used to perform the backup restore into new pv
from tape
command used to perform the aixvg backup into filesystem
command used to perform the backup restore into new pv
from file system
reduce the backed up vg
restore the above reduced vg from the bixvg (/backup)
this will restore the vg with different PP size
restore the vg with different PP size

Backs up files and file systems.


backup command overwrites previous content on tape if
exists

I - take input from standard in


v-verbose
q-quite
f-device
input will be taken from cat and piped to the backup
command
input will be taken from find command and piped to backup
command
Extracts files from archives created with the backup
command.
restore files from tape
to show only the content of tape which was taken by using
backup command

to find a file or directory with its absolute path


find the file only in the particular device ie hd4
find the file only in the particular device ie hd4 else it will
display all the paths where tht name consists
find the files for permission 0600 and list with its absolute
path

used to change the time stamp of the file

to archive the data to tape


c -create ,v - verbose, f -device
show the contents of tar ball file
show the contents of tar ball file

Das könnte Ihnen auch gefallen