You are on page 1of 23

EJERCICIOS PRACTICOS

Ejercicio 1: Imprimir el tercer elemento del array


En pseint
Proceso tercer elemento
dimension A(9);
x<- 0
para i<-1 hasta 9 hacer
leer A(i);
finpara
ingrese la matriz de (3,3)
escribir 'el tercer elemento del array es: ',A(3)
FinProceso

DFD

Ejercicio 2: Imprimir todos los numeros del array en una linea,


separados por un coma (,).
En PSeint:
Proceso SinTitulo

dimension A(9);
ingrese la matriz de (1,9)

x<- 0
para i<-1 hasta 9 hacer
leer A(i);
finpara

escribir 'los elementos son es';


escribir
A(1),',',A(2),',',A(3),',',A(4),',',A(5),',',A(6),',',A(7),,,A(8),,
,A(9);
FinProceso

DFD

Ejercicio 3: Imprimir los elementos de numeros al revs: del


ltimo al primero.

En PSeint: Proceso SinTitulo

dimension A(9);
para i<-1 hasta 9 hacer
leer A(i);

finpara
escribir 'ingrese la matriz (1,9)';
Escribir los elementos son es
escribir
A(9),',',A(8),',',A(7),',',A(6),',',A(5),',',A(4),',',A(3),',',A(2),'
,',A(1);
FinProceso

DFD

Ejercicio 4: Imprimir solamente el mayor nmero dentro del


array.
En PSeint: Proceso SinTitulo
dimension A(9);
para i<-1 hasta 9 hacer
leer A(i);
finpara

mayor<-0
para i<-1 hasta 9 hacer
si A(i)>= mayor entonces
mayor<-A(i)
finsi
finpara
escribir 'el mayor de los numeros dentro del array es :',mayor;

FinProceso

DFD

Ejercicio 5: Contar cuantos elementos del array tienen un valor


superior a 20
En PSeint:
contador<-0
para i<-1 hasta 9 hacer
si A(i)>=20 entonces
contador<-contador+1
finsi
finpara
escribir 'los numeros dentro del array mayores a 20
son:',contador;

En DFD:

Ejercicio 6: Imprimir todos los elementos del array nmeros


superiores a 0.
En PSeint:

Proceso SinTitulo
dimension A(9);
para i<-1 hasta 9 hacer
leer A(i);
finpara
escribir 'los numeros dentro del array mayores a 0 son:';
para i<-1 hasta 9 hacer
si A(i)>=0 entonces
escribir A(i);
finsi
finpara

FinProceso

En DFD:

Ejercicio

7:

Dado

un

segundo

array

otrosNumeros

[10,15,20,25,30] , imprimir solamente los elementos del array


numeros

con

valor

superior

al

mximo

otrosNumeros
En PSeint:
Proceso SinTitulo
dimension B(5);
escribir "ingrese la matriz de B(1,5)";
para i<-1 hasta 5 hacer
leer B(i);

valor

del

array

finpara
escribir "el numero maximo en el array B(1,5) es:","30";
dimension A(9);
escribir "ingrese la matriz de A(1,9)";
para j<-1 hasta 9 hacer
escribir "este numero es mayor al maximo numero del
array B(1,5)";
leer A(j);
finpara
FinProceso

En DFD :

Ejercicio 8: Imprimir la suma de todos los valores de numeros


En PSeint:
Proceso SinTitulo
dimension A[9];
sum<- 0
escribir 'ingrese la matriz de A[1,9]'
para i<- 1 hasta 1 con paso 1 hacer
para i<- 1 hasta 9 con paso 1 hacer
leer A(i);
sum<-A(i)+sum
cont<-cont+1

finpara
finpara
escribir 'la suma de los elementos son:',sum;
FinProceso

En DFD :

Ejercicio 9: crear el array numerosAlReves y ponerle los mismos


elementos que tiene el array numeros, pero con el orden inverso
En PSeint:
Proceso SinTitulo
escribir 'array numero 1 :'
dimension A(9);
para i<-1 hasta 9 hacer
leer A(i);
finpara
dimension D(9);
escribir '---------';
para h<-1 hasta 9 hacer
D(h)<-A(10-h);
finpara
escribir 'los # del array de D';
para i<-1 hasta 9 hacer
escribir D(i);
finpara

FinProceso

DFD

Ejercicio 10: crear dos array unidimensionales y realizar las 4


operaciones bsicas de ambos.
En PSeint:
Proceso SinTitulo
dimension B(3);
escribir "ingrese la primera matriz :";
para i<-1 hasta 3 hacer

leer B(i);
finpara
dimension A(3);
escribir "ingrese la segunda matriz:";
para j<-1 hasta 3 hacer
leer A(j);
finpara
escribir "la matriz C(i,j) resultante es"
escribir "la suma de la dos matrices es :"
s1=A[0]+B[0];
s2=A[1]+B[1];
s3=A[2]+B[2];
escribir "la multiplicacion de la dos matrices es :"
m1=A[0]*B[0]+A[0]*B[1]+A[0]*B[2];
m2=A[1]*B[0]+A[1]*B[1]+A[1]*B[2];
m3=A[2]*B[0]+A[2]*B[1]+A[2]*B[2];
escribir "la resta de la dos matrices es :"
r1=A[0]-B[0];
r2=A[1]-B[1];

r3=A[2]-B[2];
FinProceso

En
DFD:

Ejercicio 11: crear dos array bidimensionales y realizar las 4


operaciones bsicas de ambos.
EN PSEINT:
Proceso SinTitulo
dimension A[2,2];
dimension B[2,2];
escribir 'ingrese la matriz de A(2,2)';
escribir 'ingrese la matriz de B(2,2)';
para i<- 1 hasta 2 hacer
para j<- 1 hasta 2 hacer
leer A[i,j];
finpara
finpara
para k<- 1 hasta 2 hacer
para L<- 1 hasta 2 hacer
leer B[K,L];
finpara
finpara
w<-A(1,1)+B(1,1)

x<-A(1,2)+B(1,2)
Y<-A(2,1)+B(2,1)
Z<-A(2,2)+B(2,2)
escribir 'la suma de las matrices de A(2,2)+B(2,2) es';
escribir w,',',x,',',y,',',z;

M<-A(1,1)-B(1,1)
N<-A(1,2)-B(1,2)
O<-A(2,1)-B(2,1)
P<-A(2,2)-B(2,2)
escribir 'la diferencia de las matrices de A(2,2)-B(2,2) es';
escribir M,',',N,',',O,',',P;

R<-A(1,1)*B(1,1)+A(1,2)*B(2,1)
S<-A(1,1)*B(1,1)+A(1,2)*B(2,2)
T<-A(2,1)*B(1,1)+A(2,2)*B(2,1)
U<-A(2,1)*B(1,2)+A(2,2)*B(2,2)
escribir 'la multiplicacion
es';

de las matrices de A(2,2)*B(2,2)

escribir R,',',S,',',T,',',U;
FinProceso

En DFD: