Sie sind auf Seite 1von 2

Routage intervlan l'aide de sousinterfaces :

ip route 0.0.0.0 0.0.0.0 loopback 1


______________________________________________
__________
R1(config)#interface fastEthernet 1/0.2
sh ip ospf neighbor
sh ip ospf int s 0/0/0
R1(config-subif)#encapsulation dot1Q 2
if)#ip ospf cost ........
if)#bandwidth
R1(config-subif)#ip address 192.168.2.1
ip ospf priority .....
255.255.255.0
debug ip ospf events
default information-originate
R1(config-subif)#no shut
______________________________________________
__________
R1(config-subif)#exit
spanning-tree vlan 1 root primary
spanning-tree vlan 1 root secondary
R1(config)#interface fastEthernet 1/0.3
no spanning-tree vlan num
______________________________________________
R1(config-subif)#encapsulation dot1Q 3
__________
vlan num
R1(config-subif)#ip address 192.168.3.1
name nom
255.255.255.0
int f0/0
switchport access vlan num
R1(config-subif)#no shut
switch port mode trunk
______________________________________________
R1(config-subif)#end
__________
********************************************** vtp domain nom dom
mode s c t
*****
vtp password mot pass
vtp version 1 2
router rip
______________________________________________
network ........................
__________
ip route 0.0.0.0 0.0.0.0 INTERFACE
int range f0/1,F0/2,F0/3
default-information orginate
spanning-tree port-fast
debug ip rip
______________________________________________
no debug ip rip
__________
________________________________
vlan 1
router eigrp 1
int vlan 1
network ..................
ip address ...............................
debug eigrp fsm
ip default-gateway .........................
no auto-summary
______________________________________________
redistribute static
__________
sh ip eigrp nieghbors
sh vlan id "num"
sh ip eigrp topology
sh vlan name "nom"
sh ip eigrp topology all-links
sh vlan brief
sh ip protocols
sh vlan summary
sh ip route
sh spanning-tree
sh startup-config
sh vtp status
metric weights tos k1 k2 k3 k4 k5
sh int s 0/0/0
--------------------------------------------------------------sh int brief
sh ip rip database
______________________________________________
*Standard:
NAT
ip nat inside sourcs static "l'adress interne
adress externe
in s 0/0/0
ip nat inside
int s 0/1/0
ip nat outside
______________________________________________
__________
PAP
int s 0/0
ip adress ...
ppp encapsulation pap
ppp pap sent-username R1 passowrd ..
______________________________________________
__________
router ospf 1
network add masque genirique area 0
sh ip ospf nieghbor
sh ip ospf int S0/0/0
______________________________________________
__
int loopback 1
ip address ..............................
redestribute static

# access-list N {permit | deny} {adresse}


{mask gnrique}
# access-list N {permit | deny} any any
# interface "nom d'interface"
# ip access-group N {in | out}

*Etendue:
# access-list N {permit | deny} {protocole}
{@source} {mask gnrique}
{@destination} {mask gnrique} eq {port}
# access-list N {permit | deny} {protocole}
any any
# interface "nom d'interface"
# ip access-group N {in | out}
*Nomme Standard:

# ip access-list standard {Nom}


# {permit | deny} {adresse} {mask
gnrique}
# {permit | deny} {protocole} any any
# interface "nom d'interface"
# ip access-group N {in | out}
*Nomme tendue:
# ip access-list extended {Nom}
# {permit | deny} {protocole} {@source}
{mask gnrique} {@destination} {mask
gnrique} eq {port}
# {permit | deny} {protocole} any any
# interface "nom d'interface"
# ip access-group N {in | out}
Les N des ports avec leur protocoles:
TFTP (69) ==> Udp
==> Udp
DNS (53) ==> Tcp
==> Tcp

SNMP (161)

IMAP (143)

SSH (22) ==> Tcp


==> Tcp

Telnet (23)

POP3 (110) ==> Tcp


Tcp

HTTP (80) ==>

HTTPS (443) ==> Tcp


==> Tcp

SMTP (25)

FTP (21 pour le contrle et 20 pour les


donnes) ==> Tcp
--------------------------------------------------------------------

Dmarrage des serveurs sous linux (


Fedora ) :
DHCP => service dhcpd start
DNS => service named start
FTP => service vsftpd start
TELNET => service xinetd start
SSH => service sshd start
OPENVPN => service openvpn start
Configuration @mac statiques
SW (config)#mac-addresstablestatic(@mac de hote)
vlan{nom vlan} interface fast
Ethernet {n}
Configuration de la securit des
ports
SW (config)#interface fastethernet
0/2
SW (config-if)#switchport portsecurity
une authentification unidirectionnelle.
Lab_A (config-if)# encapsulation ppp
Lab_A (config-if)# ppp authentication pap callin

Lab_A (config-if)# ppp pap sent-username Lab_A


password password_pap
Lab_B (config)# username Lab_A password
password_pap
Lab_B (config-if)# encapsulation ppp
Lab_B (config-if)# ppp authentication pap
Pour une authentification bidirectionnelle, il suffit
de procder comme suit
Lab_A (config)# username Lab_B password
password_pap
Lab_A (config-if)# encapsulation ppp
Lab_A (config-if)# ppp authentication pap
Lab_A (config-if)# ppp pap sent-username Lab_A
password password_pap
Lab_B (config)# username Lab_A password
password_pap
Lab_B (config-if)# encapsulation ppp
Lab_B (config-if)# ppp authentication pap
Lab_B (config-if)# ppp pap sent-username Lab_B
password password_pap
CHAP
Lab_A (config)# username Lab_B password
password_chap
Lab_A (config-if)# encapsulation ppp
Lab_A (config-if)# ppp authentication chap
Lab_B (config)# username Lab_A password
password_chap
Lab_B (config-if)# encapsulation ppp
Lab_B (config-if)# ppp authentication chap
TELNET :
router1> telnet 160.10.1.2
router1# disconnect 1
TFTP :
router4# copy running-config tftp
router4# copy tftp startup-config
TRACE ROUTE:
router1#traceroute 192.168.2.2
router1(config)#defaukt-route 192.168.0.254

dynamique
router1(config)# ip nat pool {nom pool}{@
debut}{@fin}netmask {msk}
router1(config)# ip nat pool pool1 169.10.1.50
169.10.1.100 netmask 255.255.255.0
router1(config)# ip nat inside source list

{nacl} pool {nom pool}


router1(config)# access-list {nacl}
permit{source}{msk generique}
R (config)# interface Ethernet 0
R (config-if)# ip address 160.10.1.1
255.255.255.0
R (config-if)# ip nat inside
R (config-if)# interface serial 0
R (config-if)# ip nat outside

LUNIX
ftp

# chkconfig vsftpd on
# vi /etc/vsftpd/vsftp.conf
# service vsftpd restart

PAT
R (config)# access-list 1 permit 160.10.1.0
0.0.0.255
R (config)# ip nat inside source list 1 interface
serial0 overload
R (config)# ip nat pool {nom pool}{@ debut}
{@fin}netmask {msk}
R (config)# interface Ethernet 0
R (config-if)# ip address 160.10.1.1
255.255.255.0
R (config-if)# ip nat inside
R (config-if)# interface serial 0
R (config-if)# ip nat outside
R (config-if)# exit
#show ip nat translations

#show ip nat statistics


route par defaut:

# vi /etc/vsftpd/ftpusers
# ftp localhost

telnet
# rpm -ivh (chemin de
paquets)
# rpm -qa | grep xinetd
# rpm -qa | grep telnet

# vi /etc/xinetd.d/telnet
# chkconfig xinetd on

router1(config-router)#defaultinformation-originate
configuration des compteurs ospf
router(config-if)#ip OSPF hellointerval 30s
router(config-if)#ip OSPF deadinterval 30s

# telnet 192.168.0.3

INTERFACE LOOPBACK

#rpm -qa | grep xinetd

router1(config)#interface loopback n
router1(config-if)#ip add {@}
{mask}
router(config-if)#bandwitch n
router(config-if)#ip OSPF priority N
router(config-if)#ip OSPF cost N

rsh
# rpm -ivh (chemin de
paquets)

# rpm -qa | grep rsh


# vi /etc/xinetd.d/rsh
# vi /etc/xinetd.d/rlogin
# chkconfig xinetd on
#rsh 192.168.0.3

Das könnte Ihnen auch gefallen