You are on page 1of 10

Cisco CLI - Configurar Interfaces

Tabela de contedo
[esconder]

1 Configurao da porta COM para Acesso ao Console


2 Comandos Bsicos
o

2.1 Acesso ao Terminal

2.2 Limpeza das Configuraes Atuais


3 Configurao das Interfaces
3.1 Exemplos de configurao

4 Configurao de Rotas
o

4.1 Rotas Estticas

4.2 Rotas Dinmicas

4.2.1 RIP

4.2.2 OSPF

4.2.3 BGP
5 VLAN
5.1 Switch

5.1.1 Criar a VLAN

5.1.2 Definir VLAN da porta

5.1.3 Configurar Porta Trunk


5.2 Roteador

5.2.1 Configurar sub interface

5.2.2 Bloquear acesso entre VLANs

6 NAT

6.1 NAT por porta

6.2 Nat para um Range

6.3 Throbleshooting

6.3.1 Tabela Nat

6.3.2 Rastrear Pacotes


6.4 Nat esttico

7 Referncia

Configurao da porta COM para Acesso ao Console


Bits per sec

9600

Data bits

Parity

none

Stop bits

Flow control

none

No Windows o programa a ser utilizado o hyperterminal

No Linux cutecomcom interface grafica ou minicom via terminal com root.


As root:

minicom -s
Select "Serial Port Setup"
Press "A" to change serial device settings
COM1 = /dev/ttyS0
COM2 = /dev/ttyS1
Change Bps settings to 9600 8N1 (option "E" on menu)
Press Enter to return to config screen.

Select "Save setup as," when prompted give is a name such as "console"
or "COM1", whatever floats your boat, then press Enter.
Exit from Minicom.
To use the connection you just configured,just type:
minicom -o console
minicom -o COM1

Comandos Bsicos
- Voltar 1 nvel: exit
- Voltar para o primeiro nvel: Ctrl+Z

Acesso ao Terminal
Logo que o roteador ligado a tela que ele exibe apenas para consulta de informaes, um
acesso limitado, para que possam ser executados comandos de configurao do terminal
necessario entrar com o usurio administrativo, para isso execute o comando enable:

Router> en
Aps esse comando ser executado o caracter que fica em frente ao nome do roteador vai mudar
de > para #:

Router#
Nesse nivel de acesso possivel apenas visualizar as configuraes e estatisticas do sistema,
abaixo seguem alguns comandos:
Para vizualizar as configuraes atuais:

Router# show running-config


Para visualizar informaes das interfaces:

Router# show interfaces


Para visualizar as rotas existentes:

Router# show ip route


Para entra no nvel de configurao do roteador digite o comando:

Router# Router# configure terminal


Nesse nvel possvel fazer todas as configuraes clogais do roteador, como configurar as
interfaces, rotas, nome do roteador, vlans e etc.
para configurar o nome do roteador utilise o comando hostname:

Router(config)# hostname Roteador01


Para salvar a configurao atual, volte para o nvel inicial (utilize o atalho Ctrl+Z):

Roteador01# copy running-config startup-config

Limpeza das Configuraes Atuais


Para limpar as atuais configuraes do roteador, execute:

write erase

Configurao das Interfaces


Para configurar uma interface entre no modo de configurao, digite o comando interface seguido
do nome da interface e numero da interface, conforme o exemplo abaixo:

Router(config)# interface serial 0/0/0


A interface por padro, inicia desligada, para ativa-la utilize o comando no shutdown:

Router(config)# no shutdown

Exemplos de configurao
Configurao de uma interface serial desde o incio:

Router> enable
Router# configure terminal
Router(config)# interface serial 0/0/0

Router(config-if)# ip address 172.16.0.1 255.255.255.0


Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router# show interface serial
Configurao de uma interface serial que esteja com o cabo DCE (Controla a velocidade do link)
desde o incio:

Router> enable
Router# configure terminal
Router(config)# interface serial 0/0/0
Router(config-if)# ip address 172.16.0.1 255.255.255.0
Router(config-if)# clock rate 56000
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router# show interface serial

Exemplo de configurao de uma interface Fast Ethernet desde o incio:

Router> enable
Router# configure terminal
Router(config)# interface fastEthernet 0/0
Router(config-if)# ip address 192.168.0.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router# show interface fastEthernet

Configurao de Rotas
Rotas Estticas
Exemplo de configurao de uma rota esttica:

Router(config)# ip route 172.16.10.0 255.255.255.0 172.16.20.2


Router(config)# ip route 172.16.30.0 255.255.255.0 172.16.20.2
Exemplo de configurao de uma rota padro:

Router(config)# ip route 0.0.0.0 0.0.0.0 172.16.20.2

Rotas Dinmicas
RIP
Para habilitar o protocolo de configurao dinmica de rotas RIP, utilize os comandos abaixo:

Router2(config)# router rip


Router2(config-rip)# network 172.16.10.0
Router2(config-rip)# network 192.168.1.0

Desabilitar replicao de rotas em uma determinada interface:

Router(config-if)# passive-interface fastEthernet 0/0

OSPF
Para habilitar a configurao do OSPF necessrio definir o processo, isso por que pode existir
mais de uma configurao com OSPF em um mesmo roteador.

Router2(config)# router ospf 1


Router2(config)# network 172.16.10.0 0.0.0.255 area 0
Router2(config)# network 192.168.1.0 0.0.0.255 area 0

BGP
http://www.packettracernetwork.com/advanced-network-features/bgp.html
http://www.cisco.com/cisco/web/support/BR/8/85/85732_bgp-toc.html
http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/5242-bgp-ospfredis.html#redistribute

VLAN

Switch
Criar a VLAN
switch(config)# vlan <id>
switch(config-vlan)# name <nome>

Definir VLAN da porta


switch(config)#interface fastEthernet 0/23
switch(config-if)#switchport access vlan <id_vlan>

Configurar Porta Trunk


switch(config)# int fa0/15
switch(config-if)# switchport mode trunk
Limitando a porta trunk a determinadas portas

switch(config-if)# switchport trunk allowed vlan 1,71-75

Roteador
Configurar sub interface
router(config)# int fa0/0.1
router(config-if)# encapsulation dot1q 1 native
router(config-if)# ip address 192.168.1.1 255.255.255.0

Bloquear acesso entre VLANs


Primeiro cria as regras de controle, supondo que essa lista seja para bloquear subredes protegidas:

router(config)# access-list 1 deny 172.16.20.0 0.0.0.255


router(config)# access-list 1 deny 172.16.30.0 0.0.0.255
router(config)# access-list 1 permit any
Depois adiciona as regras a interface:

router(config)# interface fastEthernet 0/0.1


router(config-subif)# ip access-group 1 in
router(config-subif)# ip access-group 1 out

NAT
NAT por porta
Definir a porta a qual vai realizar o NAT.

ip nat inside source list 1 interface fastEthernet 1/0


overload
Nesta configurao a opo overload define que os endereos de sada vo utilizar
sempre o mesmo endereo como origem.

Criar a lista com o controle das redes com permisso para realizar o Nat, no caso
est liberado para todas origens.

access-list 1 permit any


Na interface por onde vai entrar o trfego (Interface da LAN), execute o
comando ip nat inside.

Router(config)# interface fastEthernet 0/0


Router(config-if)# ip nat inside

Na interface por onde vai sair o trfego (Interface da WAN), execute o comando ip
nat outside.

Router(config)# interface fastEthernet 0/1


Router(config-if)# ip nat outside

Nat para um Range


interface ethernet 0
ip address 10.10.10.1 255.255.255.0
ip nat inside
!--- Defines Ethernet 0 with an IP address and as a NAT
inside interface.

interface ethernet 1
ip address 10.10.20.1 255.255.255.0
ip nat inside
!--- Defines Ethernet 1 with an IP address and as a NAT
inside interface.

interface serial 0
ip address 172.16.10.64 255.255.255.0
ip nat outside
!--- Defines serial 0 with an IP address and as a NAT
outside interface.

ip nat pool no-overload 172.16.10.1 172.16.10.63 prefix 24


!--- Defines a NAT pool named no-overload with a range of
addresses
!--- 172.16.10.1 - 172.16.10.63.

ip nat inside source list 7 pool no-overload


!--- Indicates that any packets received on the inside
interface that
!--- are permitted by access-list 7 has
!--- the source address translated to an address out of
the
!--- NAT pool "no-overload".
access-list 7 permit 10.10.10.0 0.0.0.31
access-list 7 permit 10.10.20.0 0.0.0.31
!--- Access-list 7 permits packets with source addresses
ranging from
!--- 10.10.10.0 through 10.10.10.31 and 10.10.20.0 through
10.10.20.31.

Throbleshooting
Tabela Nat

show ip nat translations

Rastrear Pacotes
debug ip packet
debug ip nat
Exemplo de sada.

IP: tableid=0, s=192.168.32.130 (FastEthernet0/0.101),


d=55.5.0.193 (FastEthernet1/0), routed via RIB
IP: s=192.168.32.130 (FastEthernet0/0.101), d=55.5.0.193
(FastEthernet1/0), g=55.5.0.193, len 28, forward
NAT: s=192.168.32.130->20.0.0.2, d=55.5.0.193 [28]
NAT*: s=55.5.0.193, d=20.0.0.2->192.168.32.130 [211]
IP: tableid=0, s=55.5.0.193 (FastEthernet1/0),
d=192.168.32.130 (FastEthernet0/0.101), routed via RIB
IP: s=55.5.0.193 (FastEthernet1/0), d=192.168.32.130
(FastEthernet0/0.101), g=192.168.32.130, len 28, forward

Nat esttico
ip nat inside source static tcp <IP_Interno> 80
<IP_Externo>

Referncia