You are on page 1of 75

Facultad de Ingeniera de Sistemas, Cmputo y

Telecomunicaciones
Sistema a Distancia

TELEMTICA II
RUBN CUEVA ZIGA

2011

Telemtica II - Unidad I

Rubn Cueva Ziga

NDICE
PRIMERA UNIDAD
Leccin 1
1. Protocolo IPv6
1.1
Introduccin
1.2
Definicin
1.3
Caractersticas
1.4
Formato del datagramas IPv6
1.5
Cabecera Fija de IPv6
1.6
Direccionamiento IPv6

4
4
4
4
4
6
7

Leccin 2
2. Internet2
2.1
Introduccin
2.2
Definicin
2.3
Caractersticas

10
10
10
10

3. Redes de siguiente generacin (NGN)


3.1
Introduccin
3.2
Concepto
3.3
Caractersticas
3.4
Arquitectura

11
11
11
11
11

SEGUNDA UNIDAD
Leccin 3
4. GNS3 - Graphical Network Simulator
4.1
Introduccin
4.2
Dynamips

13
13
13

4.3

Qemu

13

4.4

VPC

14

4.5

BES

14

5. Instalacin de GNS3
5.1
Configurar y optimizar GNS3
5.2
Conexiones en GNS3
5.3
Integrar PCs virtuales con VPC:
5.4
Integracin de VPC + GNS3
5.5
Comandos Bsicos

14
14
21
23
25
26

TERCERA UNIDAD
Leccin 4
6. Routing
6.1
Definicin
6.2
Tipos de enrutamiento

27
27
27

Sistema a Distancia

Telemtica II - Unidad I

6.2.1
6.2.2
6.2.3

Rubn Cueva Ziga

Enrutamiento Esttico
Enrutamiento Dinmico
Enrutamiento Predeterminado

27
27
27

7. Protocolos de enrutamiento dinmico


7.1
Introduccin
7.2
Evolucin
7.3
Papel del protocolo de enrutamiento dinmico
7.4
Propsito
7.5
Funcionamiento
7.6
Clasificacin de Protocolos de Enrutamiento Dinmico
7.6.1 IGP y EGP
7.6.2 Por vector de distancia y por estado del enlace
7.6.2.1 Protocolos de enrutamiento por vector de distancia
7.6.2.2 Protocolos de enrutamiento por estado del enlace
7.6.3 Con clase y sin clase
7.6.3.1 Protocolos de enrutamiento con clase
7.6.3.2 Protocolo de enrutamiento sin clase

29
30
30
31
32
32
33
34
34
34
35

CUARTA UNIDAD
Leccin 9
8. RIPv1
8.1
Introduccin
8.2
Caractersticas
8.3
Formato de mensaje RIP
8.3.1 Cabecera RIP
8.3.2 Entrada de ruta
8.4
Funcionamiento
8.4.1 Proceso de solicitud/respuesta RIP
8.4.2 Clases de direcciones IP y Enrutamiento con clase
8.4.3 Distancia Administrativa

36
36
37
37
37
38
38
38
39
40

Leccin 6
9. RIPv2
9.1
Introduccin
9.2
Funcionamiento
9.3
Comparacin de los formatos de mensajes de RIPv1 y RIPv2
Leccin 7
10. Protocolo EIGRP
10.1 Introduccin
10.2 IGRP
10.3 Caracterstica
10.4 Formato de mensaje EIGRP

28
28

41
41
42

44
44
44
45
45

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Leccin 8
11. Protocolo OSPF
11.1 Introduccin
11.2 Encapsulacin de mensajes OSPF
11.3 Tipos de paquetes OSPF
11.4 Mtricas

48
48
48
49
49

QUINTA UNIDAD
Leccin 9
12. Configuracin de Protocolos de Enrutamiento
12.1 Configuracin de Rutas Estticas
12.2 Configuracin de RIPv1
12.3 Configuracin de RIPv2
12.4 Configuracin de EIGRP
12.5 Configuracin de OSPF

52
52
57
62
67
72

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

PRIMERA UNIDAD
Leccin 1
1. Protocolo IPv6
1.1

Introduccin
Uno de los motivos por el que surge, en el seno del IETF (Internet Engineering
Task Force), se ve asociado a la creacin de un nuevo protocolo, que en su
primer momento tomo el nombre de IPNG (Internet Protocol Next Generation o
Siguiente Generacin del Protocolo Internet"), esto se desarrolla a la falta de
direcciones IP.
IPV4 tiene un espacio de direcciones de 32 bits, es decir 232 que equivale a
4.294.967.296 redes, que para unos aos atrs era suficiente, pero IPV6 nos
ofrece
un
espacio
de
2128
que
equivale
a
340.282.366.920.938.463.463.374.607.431.768.211.456 redes. Sin embargo
IPV4, al principio de los aos 70, no predijeron el xito de este protocolo en tan
poco tiempo.

1.2

Definicin
IPV6 (Internet Protocol Versin 6) es un reciente desarrollo del protocolo de
Internet, que se encargara de resolver eficientemente las limitaciones nativas de
IPV4.

1.3

Caractersticas
-

1.4

IPv6 retiene varias de las caractersticas que hicieron IPv4 exitoso. Por
ejemplo IPv6 tambin es no orientado a la conexin.
Tamao del direccionamiento: fue extendido a 128 bits.
Formato del encabezado: ms grande, pero con menos campos.
Encabezados de extensin: en lugar de opciones, el encabezado base puede
preceder cero o ms encabezados de extensin seguidos por los datos.
Soporte de audio y video: IPv6 incluye mecanismos para ofrecer el tipo de
servicio requerido por este tipo de trfico.
El protocolo es extensible: Es posible definir nuevos encabezados y con ello
agregar o probar nuevas caractersticas.

Formato del datagrama IPv6




Comparacin entre IPv4 e IPv6

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Figura 1: Comparacin entre IPv4 e IPv6

Estructura de IPv6
La unidad de datos de protocolo de IPv6 es conocida como paquete o
datagrama.

Las cabeceras de extensin IPV6 son similares a las opciones IPv4


-

Nuevas opciones que incluyen servicios adicionales


Evitan que los datagramas compartan campos que no utilizan
Los Routers hacen caso omiso de opciones no dirigidas a ellos

La cabecera fija y las de extensin opcional incluyen el campo cabecera


siguiente que identifica el tipo de cabecera de extensin que viene a
continuacin o el identificador del protocolo de nivel superior.
Existen 6 tipos de cabeceras de extensin.




Cabecera de opciones salto a salto: Informacin especial para los routers


en cada salto.
Cabecera de encaminamiento: Ruta a seguir total o parcial.
Cabecera de fragmentacin: Informacin de fragmentacin y
reensamblaje.

Sistema a Distancia

Telemtica II - Unidad I




1.5

Rubn Cueva Ziga

Cabecera de autenticacin: Verificacin de la autenticidad del emisor


(RFC-1827
1827 y RFC-1825).
RFC
Cabecera de encapsulado de seguridad de la carga til: Informacin
sobre los tipos de mecanismos de seguridad utilizados para garantizar los
servicios de confidencialidad e integridad del contenido cifrado en el campo
datos del datagrama
datagra (RFC-18827 RFC-1825)
Cabecera de opciones para el destino: Informacin opcional que debe ser
procesada por el destino final del datagrama.

Cabecera Fija de IPv6

Figura 2: Cabecera Fija de IPv6

Versin: Campo de 4 bits, contiene el numero de versin del protocolo


Internet (IP), para IPv6 es 6.

Prioridad: Es un campo de 4 bits. Se usa para distinguir entre paquetes a


cuyos orgenes se les puede controlar el flujo y aquellos a los que no. Los
valores 0 a 7 son para transmisiones capaces
capaces de reducir su velocidad en caso
de un congestionamiento. Se muestran los siguientes valores de prioridad.
0
1
2
3
4
5
6
7

Trfico sin caracterizar.


Trfico como las News de la red.
Datos de transferencia sin atender como email.
Reservado.
Volumen de transferencia atendido como FTP.
Reservado.
Trfico interactivo como telnet.
Trfico
fico de control de internet como SNMP.

Los valores que van desde 8 hasta 15 se usan para trfico


tr fico de tiempo real
cuya tasa de envo es constante aun si se estn perdiendo todos los paquetes
mandados un ejemplo de este tipo de trfico son los videos o audios.
mandados:
audio

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Dentro de cada grupo, los paquetes de nmero ms bajo son menos


importantes que los paquetes de nmero alto.

1.6

Etiqueta de flujo: Campo de 24 bits. Es un campo an experimental. Se


usar en un principio para permitir a un origen y a un destino establecer una
pseudoconexin con unas determinadas propiedades de requisitos. Un
ejemplo sera el de video en tiempo real.

Longitud de la carga til: Campo de 16 bits. Define la longitud del


paquete que sigue a la cabecera (que inicialmente ocupa 40 bytes). El
nombre del campo se cambi de longitud total en el IPv4 porque el
significado cambi ligeramente: los 40 bytes de la cabecera ya no se
cuentan como parte de la longitud. Si su valor es cero, indica que el tamao
de la carga vendr especificado como Carga Jumbo, en una opcin salto a
salto.

Cabecera siguiente: Campo de 8 bits. Identifica el tipo de cabeceras que


sigue inmediatamente despus de la primera cabecera (si es que hubiera
ms). Por ejemplo, puede ser una cabecera TCP, de encaminamiento, o de
fragmentacin y sus combinaciones.

Limite de saltos: campo de 8 bits. Este campo se usa para evitar que los
paquetes vivan eternamente. En la prctica es igual que el campo de IPv4
TTL (Time To Live: Tiempo de vida). Se decrementa de uno en uno en
cada nodo que procesa el paquete. Si el lmite es cero, el paquete se
descarta.

Direccin de origen: Campo de 182 bits, que contiene la direccin origen.

Direccin de destino: Campo de 128 bits, que contiene la direccin


destino.

Direccionamiento IPv6
Las direcciones son de 128 bits e identifican interfaces individuales o conjuntos
de interfaces. Al igual que en IPV4 en los nodos se asignan a interfaces.
Se clasifican en tres tipos:


Unicast: Identifican a una sola interfaz. Un paquete enviado a una direccin


unicast es entregado solo a la interfaz identificada con dicha direccin.

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Figura 3: Unicast

Anycast. Identifica a un conjunto de interfaces. Un paquete enviado a una


direccin anycast, ser entregado a alguna de las interfaces identificadas
con la direccin del conjunto al cual pertenece esa direccin anycast.

Figura 4: Anycast

Multicast: identifican un grupo de interfaces. Cuando un paquete es


enviado a una direccin multicast es entregado a todos las interfaces del
grupo identificadas con esa direccin.

Figura 5: Multicast

En el IPv6 no existe direcciones broadcast. Su funcionalidad ha sido mejorada


por las direcciones multicast.

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Leccin 2
2. Internet2
2.1

Introduccin
Internet2 es un esfuerzo de colaboracin para desarrollar tecnologa y
aplicaciones avanzadas en Internet considerados vitales para las misiones de
investigacin y educacin de las instituciones de educacin superiores.
Naci en 1996 donde se definieron los objetivos de un nuevo proyecto:
Internet2. Esto surge debido a dos problemas que se detectan como los ms
importantes en la red actual: El primero es la rapidez de respuesta y el segundo
es el agotamiento de las direcciones del protocolo TCP/IP sobre el que se
construy Internet.
Fue desarrollada por el consorcio UCAID (University Corporation for
Advanced Internet Development Corporacin Universitaria para el Desarrollo
Avanzado de Internet), con el propsito de hacer posible las aplicaciones de la
telemedicina, bibliotecas digitales y laboratorios virtuales, que requieran de
altas conexiones de banda ancha en tiempo real.

2.2

Definicin
Internet2 es una red de cmputo con capacidades avanzadas separada de la
Internet comercial actual. Su origen se basa en el espritu de colaboracin entre
las universidades, adems de ayudar en la formacin de personal capacitado en
el uso y manejo de redes avanzadas de cmputo.
Los desarrollos a nivel internacional de Internet2 son: telemedicina, bibliotecas
digitales, laboratorios virtuales, manipulacin a distancia y visualizacin de
modelos 3D, todas estas aplicaciones no son posibles de desarrollar con la
tecnologa de internet de hoy.

2.3

Caractersticas
-

Maneja un gran ancho de banda, el cual tiene la finalidad de apoyar la


transmisin de grandes cantidades de informacin a alta velocidad,
alcanzando rangos de gigabits por segundo segn la demanda.
Mejor servicio de video, con esta caracterstica se busca mantener un nivel
adecuado del retardo de la informacin, siendo importante sobre todo para
sistemas de control de dispositivos a distancia que requieran garanta y
precisin en el envo de datos.
Trabaja con una tecnologa conocida como multicasting, mediante el cual se
enva, en una sola transmisin, paquetes de informacin dirigidos a varios
usuarios simultneamente, evitando con ello trafico innecesario en la red
por tener que enviar los mismos paquetes de informacin a varios usuarios
que los solicitan.
Retardo reducido y uniforme

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Mayor seguridad, privacidad y confiabilidad.

3. Redes de siguiente generacin (NGN)


3.1

Introduccin
Las redes de cobre han sido la base de las telecomunicaciones en los ltimos
100 aos. Ahora, estamos asistiendo a una revolucin tecnolgica en este sector,
con la sustitucin de dichas redes por las redes de siguiente generacin (Next
Generation Networks, NGN) basadas en fibra ptica. Reemplazar el cobre por
fibra ptica permitir mejorar drsticamente las prestaciones de las redes
actuales, alcanzando velocidades de acceso de ms de 100 mbps. Las NGN van
a cambiar completamente el sector de las telecomunicaciones y podran tener un
efecto muy importante sobre la economa en su conjunto.

3.2

Concepto
Segn la unin Internacional de telecomunicaciones (UIT-T) se define a NGNs
como: Una red basada en paquetes que permite prestar servicios de
telecomunicacin y en la que se pueden utilizar multiples tecnologas de
transporte de banda ancha propiciadas por la QoS (Quality of service), y en la
que las funciones relacionadas con los servicios son independientes de las
tecnologas subyacentes relacionadas con el transporte.
Permite a los usuarios el acceso sin trabas a redes y a proveedores de servicios
y/o servicios de su eleccin. Se soporta movilidad generalizada que permitir la
prestacin coherente y ubicua de servicios a los usuarios.

3.3

Caractersticas
- Red multiservicio capaz de manejar voz, datos y video.
- Red con las capas de aplicaciones, control y transporte formalmente
separadas,
- Red con interfaces abiertas entre el transporte, el control y las aplicaciones.
- Red que usa la conmutacin de paquetes para transportar todo tipo de
informacin.
- Red con calidad de servicio garantizada para distintos tipos de trfico.
- Red que permite la ubicuidad de los servicios.
- Red que permite el acceso irrestricto por parte de los usuarios a cualquier
proveedor de servicios.

3.4

Arquitectura
En cuanto a la tecnologa aplicada a las NGN, esta se basa en una arquitectura,
donde los servicios ya no estn integrados verticalmente. Esta plataforma es
conocida como IMS (Internacional Multimedia system), la cual permite la
convergencia de servicios de texto, datos, video y multimedia.

10

Sistema a Distancia

Telemtica II - Unidad I

Rubn Cueva Ziga

Figura 6: Arquitectura de NGN

11

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

SEGUNDA UNIDAD
Leccin 3

1. GNS3 - Graphical Network Simulator


1.1

Introduccin

GNS3 (Graphical Network Simulator), es un simulador grafico de redes que le


permitir disear fcilmente topologas de una manera profesional. GNS3 nos
permite probar y experimentar las funciones del Cisco IOS, verificar
configuraciones rpidamente que sern implementadas en routers reales, es por
eso que esta herramienta es tan til, porque permite trabajar con la IOS a todo
su potencial, como si estuviera en un router fsico y no tener el problema de que
algn comando sea rechazado.

Esta herramienta le va a permitir al estudiante familiarizarse con dispositivos


Cisco, siendo Cisco el lder mundial en tecnologas de redes.
Gns3 se ejecuta en Windows, Linux y Mac OS X.

Nota: para nuestros laboratorios usamos la ltima versin del GNS3 7.3 esta
versin es del 2011, se recomienda siempre descargar la ltima versin les dejo
el link de la pgina oficial.
Link: http://www.gns3.net/
Se van a la pestaa download, y descargan la ltima versin.

1.2

Dynamips
Para permitir esta simulacin de las IOS, GNS3 est basado en Dynamips, que
nos permite poder emular routers Cisco podramos decir que es el motor; emula
las plataformas 1700, 2600, 3600, 3700 y 7200, y ejecuta imgenes de IOS
estndar.

1.3

Qemu
Es una mquina de cdigo abierto y genrico emulador y virtualizador (archivo
imagen basado en Linux deban), esta herramienta nos va permitir emular PC en
nuestras topologa.

12

Sistema a Distancia

Telemtica II - Unidad II

1.4

Rubn Cueva Ziga

VPC
Esta herramienta nos va a permitir tener PC para nuestras pruebas.

1.5

BES
Software libre que nos permite controlar los proceso de nuestra CPU (para
maquinas que no tengan procesadores de ltima generacin como: core 2 dos,
core i3, corte i5 o core i7), esta herramienta nos va ser muy til a la hora que
nuestro procesador llegue al 100%.
Descargue siempre la ltima versin.

Link: http://mion.faireal.net/BES/

2. Instalacin de GNS3
Antes de empezar con nuestra instalacin debemos tener el siguiente software:
2.1

Instalador GNS3
IOS de cisco versin 2691
Imagen Qemu
VPCs
Bes
Configurar y optimizar GNS3

Figura 7: Pantalla de inicio de GNS3

13

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Despus de terminar la instalacin nos aparece la siguiente ventana en la que


nos dice en el tem 1 que configuremos el Dynamips y en el tem 2 que
carguemos una IOS (recuerde que sin una IOS cargada el programa no
funciona), en nuestro caso no vamos a utilizar el wizard para la configuracin
as que cerramos la ventana que est encima.

Figura 8: Pantalla de presentacin del GNS3

Nos debe quedar solo esta ventana activa.

Figura 9: Men Edit de la barra de herramientas de GNS3

14

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Vamos a verificar que el Dynamips est funcionando, para eso nos vamos a
edit>Prerences.

Figura 10: Configuracin del Dynamips

Elegimos la opcin Dynamips y le damos clic al botn Test.

Figura 11: Dynamips

15

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Tienes que salir el siguiente mensaje Dynamips successfully started, este


mensaje nos quiere decir que el Dynamips de inici correctamente, en el caso
no salga el mensaje, cierre el GNS3 y vuelva a intentarlo.
Recuerde que si el Dynamips no se inicializa exitosamente no va a poder emular
las Cisco IOS.

Aplicamos y aceptamos.

Figura 12: Menu Edit

Figura 13: Ventana para cargar Imagen IOS

Ahora vamos a cargar nuestra Cisco IOS. No vamos a Edit>IOS Image and
hypervisors.

16

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Clic para buscar


ubicacin de nuestra
IOS.

Figura 14: Buscar y seleccionar una imagen IOS

Nos aparece este ventana, es aqu donde vamos a gestionar nuestras Cisco IOS,
como puede ver no hay ninguna imagen. Llego la hora de cargar nuestra
imagen.

Figura 15: seleccionar la Imagen IOS

17

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Elegimos nuestra imagen en caso vamos a usar la Cisco IOS c2691adventerprisek9_sna-mz.124-13b.bin. Clic en abrir.

Nombre completo
de la IOS
Plataforma
Modelo del
router
Cantidad de
memoria usada por
el router
Figura 16: Cargar imagen IOS

En esta ventana tenemos toda la especificacin de nuestra IOS cargada.

Figura 17: Muestra de IOS cargada

18

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Damos Save para que nuestra IOS se guarde. Como nos podemos dar cuenta, ya
apareci la IOS en el recuadro donde antes estaba vaco, entonces de esta forma
podemos seguir agregando ms IOS y elegir con la que vamos a trabajar, le
damos al botn Close para cerrar.

NOTA:
Si no cargamos una IOS no podremos utilizar los routers. Ojo, que tenemos
que elegir el router que corresponda a la misma versin de la IOS, sino nos va a
aparecer un mensaje de error. Veamos unas imgenes sobre esto.
Para agregar un router a nuestra topologa, seleccionamos
arrastramos.

uno y

lo

En nuestro caso la IOS que hemos cargado es la c2691-adventerprisek9_snamz.124-13b.bin, si nos damos cuenta es un c2691 entonces es para el router
c2691, y yo eleg el router c3600 para la cual no hay una IOS cargada.

19

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Figura 18: Router

Router cargado correctamente.


Hasta este punto el alumno tiene que estar en la capacidad de instalar y
configurar adecuadamente el software en cuestin.

2.2

Conexiones en GNS3

Poner 3 routers c2691 en nuestra escena, como esta en el ejemplo.

20

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Vamos a poner 2 tarjetas de seriales a nuestros routers.

Le damos dos clic sobre R1 y nos muestra esta venta vamos a R1>Slots, en la
seccin WIC y elegimos wic-2t. OK.
Lo mismo hacemos para R2 y R3
Conectar los routers:

En nuestros casos siempre vamos a seleccionar Manual. Damos clic sobre el R1


y elegimos la conexin serial (s0/0).

21

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Y lo conectamos a la s0/0 de R2. Y de la misma manera R1 con R3

Habilitamos este botn para ver las etiquetas de las interfaces.

22

Sistema a Distancia

Telemtica II - Unidad II

2.3

Rubn Cueva Ziga

Integrar PCs virtuales con VPC

Vamos a usar esta herramienta muy til para probar nuestro estado de
conexin utilizando el famoso y conocido Internet Control Message Protocol
(ICMP), el famoso ping.
Ejecutamos vpcs.exe.

Tenemos esta ventana del vpcs, esta herramienta nos permite usar 9 pc virtuales.
Nota:
Para pasar de una pc a otra debemos elegir un nmero del 1 al 9, observemos el
siguiente ejemplo:

De pc 1 a pc 9, esto nos va a servir cuando pongamos ips, ya que debemos


estar en la pc que vamos a configurar.

23

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Comando show para visualizar todas las pc.

Como configurar IP con vpcs:


En este ejemplo deseo configurar las IP para las pc1 192.168.1.10 /24
VPCS [1]> ip 192.168.1.10 192.168.1.1
IP asignada
al host

Gateway

24
Mascara
en bits

VPCS [1]> show

2.4

Integracin de VPC + GNS3


Para la integracin correcta de vpcs con GNS3, tenemos que tener en cuenta dos
parmetros muy importantes, en la venta de vpcs tenemos LPORT (20000) y
RPORT (30000). Abrimos la ventana de configuracin de la pc y nos mostrara
una venta como en el ejemplo, la configuracin de los nmeros sern puestos a
la inversa:
RPORT=Local port
Remote host=127.0.0.1 (direccin de loopback)
LPORT=Remote port

24

Sistema a Distancia

Telemtica II - Unidad II

Rubn Cueva Ziga

Una vez terminada la configuracin procedemos a conectar nuestra pc en la


topologa, quedando como en la imagen.
Nota:
Se explicar como ms detalles estos primeros captulos sobre configuracin de
GNS3 en un video tutorial (cd) q se adjunta en este libro.

2.5

Comandos Bsicos

Comando
Enable
Configure terminal
Hostname <nombre>
Line console <.>
Logging synchronous

Descripcin
Permite pasar del modo consola al modo EXEC privilegiado.
Permite pasar al modo configuracin global.
Permite cambiar el nombre del router.
Permite ingresar a la lnea de consola.
Para evitar que los mensajes del IOS interrumpa los comandos ingresados
en la CLI.
Password <..>
Permite configurar una contrasea.
Line vty <..>
Permite ingresar al modo de configuracin virtual.
Login
Para permitir logeo.
Enable secret <>
Configurar una clave encriptada.
No ip domain-lookup
Para que no haga resolucin dns.
Service
password- Permite encriptar contraseas ingresadas.
encription
Copy running-config Permite copiar la configuracin en la nvram del router.
startup-config

25

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

TERCERA UNIDAD
Leccin 4
1. Routing
1.1

Definicin
El enrutamiento o encaminamiento es la funcin que desarrollan los routers y
que tiene por objetivo buscar un camino entre todos los posibles en una red de
paquetes donde existe una gran conectividad.
Antes de entrar al tema de enrutamiento es importante indicar la diferencia entre
los protocolos enrutados y los protocolos de enrutamiento. Los protocolos
enrutados como IP o IPX necesitan de un direccionamiento de otro equipo para
tener conexiones remotas, mientras que los protocolos de enrutamiento se
encargan de elegir la mejor ruta la ruta ms ptima para que los equipos
alcancen su destino.

1.2

Tipos de enrutamiento
1.2.1

Enrutamiento Esttico
- Las rutas son agregadas de manera manual.
- No hay consumo de ancho de banda.
- Las rutas de las tablas de enrutamiento no se adaptan a los cambios en
la topologa.
- Se requiere tiempo para el mantenimiento de tablas de enrutamiento.

1.2.2

Enrutamiento Dinmico
- Las rutas se aprenden de manera automtica.
- Si hay consumo de ancho de banda porque intercambian tablas de
enrutamiento.
- Las rutas varan de acuerdo a la topologa.
- No requieren mantenimiento de tablas de enrutamiento.

1.2.3

Enrutamiento Predeterminado
- Es una ruta esttica que se refiere a una conexin de salida o Gateway
de ltimo recurso.
- El trfico hacia destinos desconocidos por el router se enva a dicha
conexin de salida.
- Es la forma ms fcil de enrutamiento para un dominio conectado a un
nico punto de salida. Esta ruta se indica como la red de destino
0.0.0.0/0.0.0.0

26

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

2. Protocolos de enrutamiento dinmico


2.1

Introduccin
Los protocolos de enrutamiento dinmico juegan un importante papel en las
redes actuales. Las siguientes secciones describen varios beneficios importantes
que los protocolos de enrutamiento dinmico proporcionan. En muchas redes,
los protocolos de enrutamiento dinmico se utilizan normalmente con rutas
estticas.

2.2

Evolucin
Los protocolos de enrutamiento dinmico se llevan utilizando en las redes desde
principios de los 80s. La primera versin de RIP data de 1982, pero algunos de
los algoritmos bsicos del protocolo se utilizaron en la ARPANET, por los aos
1969.
A medida que las redes evolucionan y ganan en complejidad, van emergiendo
protocolos de enrutamiento nuevos.

Figura 19: Evolucin de los protocolos de enrutamiento

En la figura 19 se observa una lnea de tiempo de los protocolos de


enrutamiento IP, con una grafica que ayuda a clasificar los distintos protocolos.
Uno de los primeros protocolos de enrutamiento fue RIP, que evoluciono en una
versin ms moderna: RIPv2. Sin embargo, la versin ms moderna de RIP
todava no escala a implementaciones de redes ms grandes. Para tener en

27

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

cuenta las necesidades de las redes ms grandes, se desarrollaron dos protocolos


de enrutamiento avanzados: OSPF e IS-IS (Sistema Intermedio a Sistema
Intermedio, Intermediate System to Intermediate System). Cisco desarrollo
IGRP (protocolo de enrutamiento de Gateway interior, Interior Gateway
Routing protocol) y EIGRP (IGRP mejorado). EIGRP tambin escala en
implementaciones de redes grandes.
Adicionalmente, haba la necesidad de interconectar diferentes interworks y
proporcionar un enrutamiento entre ellas. Ahora se utiliza BGP (protocolo de
Gateway fronterizo, Border Gateway Protocol) entre los proveedores de
servicios de Internet (ISP), as como entre los ISP y sus clientes privados ms
grandes, para intercambiar informacin de enrutamiento.
Con el surgimiento de tantos dispositivos de consumo que utilizan IP, el espacio
de direccionamiento IPV4 est llegando a su lmite y empieza a agotarse. Para
soportar la comunicacin en IPV6, se han desarrollado versiones ms modernas
de los protocolos de enrutamiento IP.
2.3

Papel del protocolo de enrutamiento dinmico


Qu son exactamente los protocolos de enrutamiento dinmico? Los protocolos
de enrutamiento se utilizan para facilitar el intercambio de informacin de
enrutamiento entre los routers. Los protocolos de enrutamiento permiten a los
routers aprender dinmicamente informacin sobre redes remotas y aadir
automticamente esa informacin a sus tablas de enrutamiento propias.
Los protocolos de enrutamiento determinan la mejor ruta a cada red, que
despus se aade a la tabla de enrutamiento. Uno de los principales beneficios
de utilizar un protocolo de enrutamiento dinmico es que los routers
intercambian la informacin de enrutamiento cada vez que se produce un
cambio en la topologa. Este intercambio permite a los routers aprender
dinmicamente sobre las redes nuevas y tambin encontrar rutas alternativas en
caso de que falle el enlace a una red actual.
Comparados con el enrutamiento esttico, los protocolos de enrutamiento
requieren menos sobrecarga administrativa. Sin embargo, el gasto de usar
protocolos de enrutamiento dinmico esta en dedicar parte de los recursos del
router para el funcionamiento del protocolo, incluyendo tiempo de CPU y ancho
de banda de enlace de red. A pesar de los beneficios del enrutamiento dinmico,
el enrutamiento esttico sigue teniendo su ligar. En ocasiones es ms apropiado
el enrutamiento esttico, y otras veces la mejor eleccin es el enrutamiento
dinmico. La mayora de las veces, encontrara una combinacin de los dos tipos
de enrutamiento en cualquier red que tenga un nivel de complejidad moderado.

28

Sistema a Distancia

Telemtica II - Unidad III

2.4

Rubn Cueva Ziga

Propsito
Un protocolo de enrutamiento es un conjunto de procesos, algoritmos y
mensajes que se utilizan para intercambiar informacin de enrutamiento y
rellenar la tabla de enrutamiento con la eleccin de las mejores rutas del
protocolo de enrutamiento. El propsito de un protocolo de enrutamiento es:
-

Descubrir redes remotas


Mantener informacin de enrutamiento actualizada
Elegir la mejor ruta de las redes de destino
Tener la posibilidad de encontrar una nueva mejor ruta si la ruta actual ya
no est disponible.

Los componentes de un protocolo de enrutamiento son los siguientes:

2.5

Estructuras de Datos. Algunos protocolos de enrutamiento utilizan tablas


o bases de datos para sus operaciones. Esta informacin se mantiene en la
RAM.

Algoritmo. Un algoritmo es una lista finita de los pasos que se siguen para
acometer una tarea. Los protocolos de enrutamiento utilizan algoritmos para
procesar la informacin de enrutamiento y para determinar la mejor ruta.

Mensaje de protocolo de enrutamiento. Los protocolos de enrutamiento


utilizan varios tipos de mensajes para descubrir los routers vecinos,
intercambiar informacin de enrutamiento y realizar otras tareas
encaminadas a aprender y mantener informacin precisa sobre la red.

Funcionamiento
Todos los protocolos de enrutamiento tienen el mismo propsito: aprender sobre
redes remotas y adaptarse rpidamente siempre que se produce un cambio en la
topologa. El mtodo que un protocolo de enrutamiento utiliza para acometer
esto depende del algoritmo que utiliza y de las caractersticas operacionales de
ese protocolo. Las operaciones de un protocolo de enrutamiento dinmico
varan en funcin del tipo de protocolo de enrutamiento y de las operaciones
especficas de RIP, EIGRP y OSPF. En general, las operaciones de un protocolo
de enrutamiento dinmico se pueden describir de este modo: (ver figura 20)
-

El router enva y recibe mensajes de enrutamiento en sus interfaces.


El router comparte mensajes de enrutamiento e informacin de
enrutamiento con otros routers que estn utilizando el mismo protocolo de
enrutamiento.
Los routers intercambian informacin de enrutamiento para aprender sobre
redes remotas.
Cuando un router detecta un cambio en la topologa, el protocolo de
enrutamiento puede publicar ese cambio a otros routers.

29

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

Figura 20: Funcionamiento

2.6

Clasificacin de Protocolos de Enrutamiento Dinmico


Los protocolos de enrutamiento se pueden clasificar en diferentes grupos de
acuerdo con sus caractersticas.

Figura 21: Clasificacin del protocolo de enrutamiento dinmico

30

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

Las secciones que siguen explican estos esquemas de clasificacin ms en


detalle.
Los protocolos de enrutamiento que ms se utilizan son los siguientes:
RIP. Protocolo de enrutamiento interior por vector distancia.
IGRP. Protocolo de enrutamiento interior por vector de distancia desarrollado
por Cisco (desaprobado en Cisco IOS versin 12.2 y posteriores).
OSPF. Protocolo de enrutamiento interior por estado de enlace.
IS-IS. Protocolo de enrutamiento interior por estado de enlace.
EIGRP. Es el protocolo de enrutamiento interior por vector de distancia
avanzado desarrollado por Cisco.
BGP. Protocolo de enrutamiento exterior por vector de ruta.

2.6.1

IGP y EGP
Un sistema autnomo (AS, Autonomous System. En otro tiempo conocido
como dominio de enrutamiento) es una coleccin de routers bajo una
administracin comn. Ejemplos tpicos son la red interna de una empresa y
la red de un ISP. Como internet est basada en el concepto de sistema
autnomo, se necesitan dos tipos de protocolos de enrutamiento: Protocolo
de enrutamiento interior y exterior. Estos protocolos son los siguientes:


Protocolos de Gateway interior (IGP).


Se utilizan para el
enrutamiento intra-sistema autnomo, es decir, para el enrutamiento
dentro de un sistema autnomo.

Protocolos de Gateway exterior (EGP).


enrutamiento entre sistemas autnomos.

se utilizan para el

Los protocolos de enrutamiento (y, ms concretamente, el algoritmo que


este protocolo de enrutamiento utiliza) usan una mtrica para determinar la
mejor ruta a una red. La mtrica utilizada por el protocolo de enrutamiento
RIP es el conteo de saltos, que se el numero de routers que un paquete debe
atravesar para llegar a otra red. OSPF utiliza el ancho de banda para
determinar la ruta ms corta.
Por el contrario, los EGP estn diseados para ser utilizados entre diferentes
sistemas autnomos que estn bajo el control de administraciones
diferentes.
BGP es el nico EGP actualmente viable y es el protocolo de enrutamiento
que se utiliza en internet. BGP es un protocolo por vector de ruta que puede
usar muchos atributos diferentes para medir las rutas. Al nivel ISP, a

31

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

menudo hay temas ms importantes que el hecho de elegir la ruta ms


rpida.
BGP se utiliza normalmente entre los ISP y a veces entre una empresa y un
ISP.
2.6.2

Por vector de distancia y por estado del enlace


Los protocolos de Gateway interior (IGP) pueden clasificarse como dos
tipos:

2.6.2.1 Protocolos de enrutamiento por vector de distancia


Vector de distancia significa que las rutas son publicadas o notificadas
como vectores de distancia y direccin. La distancia se define en
trminos de una mtrica como el conteo de saltos o interfaz de salida.
Los protocolos por vector de distancia utilizan normalmente el
algoritmo Bellman-Ford para determinar la mejor ruta.
Algunos protocolos por vector de distancia envan peridicamente
tablas de enrutamiento completas a todos los vecinos conectados. En las
redes ms grandes, estas actualizaciones de enrutamiento pueden ser
enormes, provocando un trfico significativo en los enlaces.
Aunque el algoritmo Bellman-Ford acumula suficiente conocimiento
para mantener una base de datos de redes alcanzables, el algoritmo no
permite que un router conozca la topologa exacta de una internetwork.
El router slo conoce la informacin de enrutamiento recibida de sus
vecinos.
Los protocolos por vector de distancia utilizan routers a modo de
seales indicadoras a lo largo del camino al destino final. La nica
informacin que un router conoce sobre una red remota es la distancia o
mtrica para alcanzar esa red qu ruta o interfaz usar para llegar all.
Los protocolos de enrutamiento por vector de distancia no tienen un
mapa real de la topologa de la red.
Los protocolos por vector de distancia funcionan mejor en situaciones
donde:
-

La red es sencilla y plana y no requiere un diseo jerrquico.


Los administradores no tienen suficiente conocimiento para
configurar y resolver los problemas de los protocolos por estado
del enlace.
Se han implementado tipos especficos de redes, como las redes
huband-spoke.
Los tiempos de convergencia en el peor de los casos en una red no
son un problema.

32

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

2.6.2.2 Protocolos de enrutamiento por estado del enlace


Al contrario que el funcionamiento de un protocolo de enrutamiento por
vector de distancia, un router configurado con un protocolo de
enrutamiento por estado del enlace (link-state) puede crear una vista
completa o topologa de la red obteniendo informacin de todos los
dems routers. Piense en usar un protocolo por estado del enlace como
en tener un mapa completo de la topologa de la red. Las seales a lo
largo del camino, desde el origen hasta el destino, no son necesarias
porque todos los routers de estado del enlace estn utilizando un
mapa idntico de la red. Un router de estado del enlace utiliza la
informacin de estado del enlace para crear un mapa de la topologa y
seleccionar la mejor ruta a todas las redes de destino en esa topologa.
Con algunos protocolos de enrutamiento por vector de distancia. Los
routers envan actualizaciones peridicas de su informacin de
enrutamiento a sus vecinos. Los protocolos por estado del enlace no
utilizan actualizaciones peridicas. Una vez que la red ha convergido,
slo se enva una actualizacin de estado del enlace para crear un mapa
de topologa y seleccionar la mejor ruta a todas las redes de destino en
esa topologa.
Los protocolos por estado del enlace trabajan mejor en las situaciones
donde:
2.6.3

El diseo de la red es jerrquico. Lo que normalmente ocurre en las


redes grandes.
Los administradores tienen un buen conocimiento del protocolo por
estado del enlace implementado.
La rpida convergencia de la red es crucial.

Con clase y sin clase


Todos los protocolos y enrutamientos tambin se pueden clasificar con:

2.6.3.1 Protocolos de enrutamiento con clase


Los protocolos de enrutamiento con clase no envan informacin de
mascara de subred en las actualizaciones de enrutamiento. Los primeros
protocolos de enrutamiento, como RIP. Era en un momento que las
direcciones de red se asignaban basndose en las clases; clase A, B, o
C. Un protocolo de enrutamiento no necesita incluir la mscara de
subred en la actualizacin de enrutamiento porque la mscara de red
puede determinarse basndose en el primer octeto de la direccin de
red.
Todava se pueden utilizar los protocolos de enrutamiento con clases en
algunas redes de nuestros das, pero como no incluyen la mscara de
subred, no pueden utilizarse en todas las situaciones. Los protocolos de

33

Sistema a Distancia

Telemtica II - Unidad III

Rubn Cueva Ziga

enrutamientos con clase no se pueden utilizar cuando una red se ha


dividido en subredes utilizando ms de una mscara de subred. Es decir,
los protocolos de enrutamiento con clase no soportan las mscaras de
subred de longitud variable (VLSM). La figura3.4 muestra un ejemplo
de una red que utiliza la misma mscara de subred en todas sus subredes
para la misma direccin de red principal. En esta situacin, podra
utilizar un protocolo de enrutamiento con o sin clase.

Figura 22: Enrutamiento con Clase

2.6.3.2 Protocolo de enrutamiento sin clase


Los protocolos de enrutamiento sin clase incluyen la mscara de subred
con la direccin de red en las actualizaciones de de enrutamiento. Las
redes actuales ya no se asignan basndose en clases, y la mscara de
subred no puede determinarse por el valor del primer octeto. Los
protocolos de enrutamiento sin clase son necesarios en la mayora de las
redes actuales debido a que soportan VLSM.

Figura 23: Enrutamiento sin Clase

34

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

CUARTA UNIDAD
Leccin 5

1. RIPv1
1.1

Introduccin
Los protocolos de enrutamiento han evolucionado durante aos para satisfacer
las demandas crecientes de las redes complejas. El primer protocolo que se
utiliz fue el protocolo de informacin de enrutamiento (RIP, Routing
Information Protocol). RIP todava goza de cierta popularidad debido a su
simplicidad y su amplio soporte.
En la figura 24 observamos un grfico de los protocolos de enrutamiento IP ms
comunes.

Figura 24: Protocolo de enrutamiento RIPv1

Es importante conocer RIP para los estudios de Networking por dos


razones:
-

RIP todava se sigue utilizando. Podra encontrarse con una implementacin


de red suficientemente grande como para necesitar un protocolo de
enrutamiento, pero suficientemente sencilla como para utilizar RIP
eficazmente.
La familiaridad con muchos de los conceptos fundamentales de RIP le
ayudar a comparar RIP con otros protocolos. Si comprende el
funcionamiento de RIP y conoce su implementacin le resultar ms fcil
aprender otros protocolos de enrutamiento.

35

Sistema a Distancia

Telemtica II - Unidad IV

1.2

Rubn Cueva Ziga

Caractersticas
RIPv1 es un protocolo de enrutamiento y, al igual que otros protocolos, tiene un
formato con campos que contienen informacin especfica. Por ejemplo, el
protocolo IP tiene campos que contienen informacin como la direccin IP de
origen y la direccin IP de destino. Los protocolos de enrutamiento tambin
tienen campos que contienen informacin. Uno de los campos del protocolo de
enrutamiento RIPv1 es el campo Direccin IP, que contiene una direccin de
red IP. Los routers comparten informacin de enrutamiento utilizando la
informacin contenida de estos campos. El anlisis de algunos de estos campos
le ayudara a desentraar algunos de los misterios de este protocolo y su
funcionamiento.
Las caractersticas clave de RIP son las siguientes:
- RIP es un protocolo de enrutamiento por vector de distancia.
- RIP utiliza la cuenta de saltos como nica mtrica para seleccionar una ruta.
- Las rutas publicadas o notificadas con cuentas de saltos superiores a 15 son
consideradas inalcanzables.
- Los mensajes de respuesta (actualizaciones de la tabla de enrutamiento) se
difunden cada 30 segundos.

1.3

Formato de mensaje RIP


1.3.1 Cabecera RIP

Figura 25: Cabecera RIP

36

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Se especifican tres campos en la porcin de cabecera de 4 bytes y se resaltan en la


figura 25. El campo comando especifica el tipo de mensaje; el campo versin se
establece a 1 para RIP Versin 1. El tercer campo aparece etiquetado como Debe
ser cero; estos campos proporcionan espacio para una futura ampliacin del
protocolo.
1.3.2

Entrada de ruta
La porcin de entrada de ruta del mensaje incluye tres campos con
contenido:
-

Identificador de familia de direcciones (se establece a 2 para IP a menos


que un router est solicitando una tabla de enrutamiento completa, en
cuyo caso el campo se establece a 0).
Direccin IP
Mtrica

Esta porcin de entrada de ruta representa una ruta de destino con su


mtrica asociada. Una actualizacin RIP puede contener hasta 25 entradas
de ruta. El tamao mximo del datagrama es de 512 bytes, sin incluir las
cabeceras IP o UDP.
Por qu hay tantos campos establecidos a cero?, RIP se desarroll antes
que IP y se utiliz para otros protocolos de red (como XNS). BSD tambin
tena su influencia. Inicialmente, se aadi espacio extra con la intencin de
soportar en el futuro espacios de direcciones ms grandes. RIPv2 ya ha
utilizado la mayora de estos campos vacos.
1.4

Funcionamiento
1.4.1 Proceso de solicitud/respuesta RIP
RIP utiliza dos tipos de mensaje que se especifica en el campo Comando.
Mensaje de solicitud y mensaje de respuesta.

37

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

La figura 26 muestra el proceso de solicitud/respuesta de RIPv1.

Figura 26: Protocolo RIPv1

Cada interfaz configurada con RIP enva un mensaje de solicitud al inicio,


pidiendo que todos los vecinos RIP enven sus tablas de enrutamiento
completas. Los vecinos con RIP habilitado envan de regreso un mensaje de
respuesta. Cuando el router demandante recibe las respuestas, evala cada
una de las entradas de ruta. Si una entrada de ruta es nueva, el router
receptor instala la ruta en la tabla de enrutamiento. Si la ruta ya existe en la
tabla, la entrada existente es sustituida si la entrada nueva tiene una cuenta
de saltos mejor. El router de inicio enva entonces una actualizacin activa,
que contiene su propia tabla de enrutamiento, por todas las interfaces que
tienen RIP habilitado, para poder informar a todos los vecinos RIP de
cualquier ruta nueva.
1.4.2

Clases de direcciones IP y Enrutamiento con clase


Es posible que recuerde de estudios anteriores que las direcciones IP que se
asignan a los host se dividan inicialmente en tres clases: clase A, clase B u
clase C. como se muestra en la figura 27, a cada clase se le asignaba una
mscara de subred predeterminada. Es importante conocer la mscara de
subred predeterminada de cada clase para entender el funcionamiento de
RIP.
RIP es un protocolo de enrutamiento con clase. Como habr podido
imaginar de la explicacin anterior sobre el formato del mensaje, RIPv1 no
enva informacin sobre la mscara de subred en la actualizacin. Por tanto,
un router utiliza la mscara de subred configurada en una interfaz local, o

38

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

aplica la mscara de subred predeterminada basndose en la clase de


direccin.
Debido a esta limitacin, las redes RIPv1 no pueden ser discontinuas, ni
pueden implementar VLSM.

Figura 27: Clases de direcciones IP

1.4.3

Distancia Administrativa
La distancia administrativa (AD segn la expresin en ingles, o DA) es la
fiabilidad (o preferencia) del origen de la ruta. RIP tiene una distancia
administrativa predeterminada de 120. En comparacin con otros
protocolos de Gateway interior, RIP es el protocolo de enrutamiento menos
preferible. Los protocolos IS-IS, OSPF, IGRP y EIGRP tienen valores de
DA predeterminados ms pequeos.
Recuerde que puede comprobar la distancia administrativa con los
comandos show ip route o show ip protocols.

39

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Leccin 6

2. RIPv2
2.1

Introduccin
RIP Versin 2 (RIPv2) est definido en la RFC 1723. RIPv2 es el primer
protocolo de enrutamiento sin clase.
clase. Aunque RIPv2 es un protocolo de
enrutamiento adecuado para algunos entornos, ha perdido popularidad en
comparacin con otros protocolos de enrutamiento como EIGRP, OSPF e IS-IS
IS
que ofrecen ms caractersticas y son ms escalables.

Figura 28: Protocolo RIPv2

Sin embargo, todava se utilizan las dos versiones de RIP en algunas


situaciones. Aunque RIP carece de las capacidades de muchos de los protocolos
posteriores, su total simplicidad y su extenso uso en mltiples sistemas
operativos lo han convertido en un candidato ideal para las redes ms pequeas
y homogneas donde es necesario un soporte multifabricante, especialmente en
entornos UNIX.
Aun cuando no se plantee utilizar RIPv2, es ideal para explicar las diferencias
entre un protocolo
protocolo de enrutamiento con clase (RIPv1) y un protocolo de
enrutamiento sin clase (RIPv2). Esta leccin se centra en estas diferencias, en
lugar de hacerlo en los detalles de implementacin de RIPv2. La principal
limitacin de RIPv1 es que se trata de un protocolo
protocolo de enrutamiento con clase.
Como sabe, los protocolos de enrutamiento con clase no incluyen la mscara de
subred con direccin de red en las actualizaciones de enrutamiento. Esto puede
provocar problemas con las subredes discontinuas o con las redes que
qu hacen uso
de VLSM. Como RIPv2 es un protocolo de enrutamiento sin clase, las mascaras
de subred se incluyen en las actualizaciones de enrutamiento haciendo que
RIPv2 sea ms compatible con los entornos de enrutamiento modernos.

40

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

RIPv2 es realmente una mejora de las caractersticas y extensiones de RIPv1 en


lugar de ser un protocolo completamente nuevo, algunas de sus caractersticas
son las siguientes.
- En las actualizaciones de enrutamiento se incluyen las direcciones de
siguiente salto.
- Uso de direcciones de multicast al enviar actualizaciones.
- Opcin de autenticacin disponible.
Al igual que RIPv1, RIPv2 es un protocolo de enrutamiento por vector de
distancia. Las dos versiones de RIP comparten las siguientes caractersticas y
limitaciones.
-

2.2

Uso de hold-down y otros temporizadores para intentar evitar los bucles


de enrutamiento.
Uso del horizonte dividido y del horizonte dividido con
envenenamiento a la inversa como ayuda para evitar los bucles de
enrutamiento.
Uso de actualizaciones activas (triggered updates) cuando hay un
cambio en la topologa para una convergencia ms rpida.
Conteo mximo de 15 saltos, de modo que una cuenta de 16 saltos
significa una red inalcanzable.

Funcionamiento
La configuracin de RIPv2 es parecida a la de RIPv1, con la adicin de un solo
comando RIP, versin 2. Aunque RIPv2 utiliza los mismos comandos bsicos
de configuracin que RIPv1, los resultados de usar RIPv2 son diferentes, ya que
permite utilizar en la red tanto CIDR como VLSM.

2.3

Comparacin de los formatos de mensajes de RIPv1 y RIPv2


RIPv2 se define en RFC 1723. Al igual que la versin 1, RIPv2 se encapsula en
un segmento UDP mediante el puerto 520 y puede transportar hasta 25 rutas. Si
bien RIPv2 tiene el mismo formato de mensaje bsico que RIPv1, se agregan
dos extensiones importantes.
La primera extensin en el formato de mensaje de RIPv2 es el campo de
mscara de subred que permite que una mscara de 32 bits se incluya en
entrada de ruta de RIP. Como resultado, el router receptor ya no depende de
mscara de subred de la interfaz entrante ni de la mscara con clase
determinar la mscara de subred para una ruta.

la
la
la
al

La segunda extensin importante para el formato de mensaje de RIPv2 es la


adicin de la direccin de siguiente salto. La direccin del siguiente salto se usa
para identificar una direccin de siguiente salto mejor que la direccin del
router emisor, si es que existe. Si el campo se establece todo en ceros (0.0.0.0),
la direccin del router emisor es la mejor direccin del siguiente salto. La

41

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

informacin detallada sobre cmo se usa la direccin del siguiente salto se


encuentra ms all del alcance de este curso. Sin embargo, puede encontrar un
ejemplo en RFC 1722 o en Routing TCP/IP Volume 1 de Jeff Doyle.
Doyl

Figura 29: Formato de mensaje de RIPv1 y


RIPv2

42

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Leccin 7
3. Protocolo EIGRP
3.1

Introduccin
EIGRP se describe como un protocolo de enrutamiento por vector de distancia
mejorado, sigue siendo un protocolo de enrutamiento por vector de distancia.
Esto puede llegar a ser en ocasiones fuente de confusin. Para apreciar las
mejoras de EIGRP y eliminar la confusin, primero tiene que revisar a su
predecesor IGRP.

3.2

IGRP
Cisco desarrollo el IGRPpropietario en 1985, en respuesta a algunas de las
limitaciones de RIPv1, incluyendo el uso de la mtrica de cuenta de saltos y de
tamao de red mximo establecido en 15 saltos.
En lugar de la cuenta de saltos, IGRP y EIGRP utilizan una mtrica compuesta
por el ancho de banda, el retraso, la fiabilidad y la carga. Por defecto, los dos
protocolos de enrutamiento utilizan solo el ancho de banda y el retraso.
Sin embargo, como IGRP es un protocolo de enrutamiento con clase que utiliza
el algoritmo Bellman-Ford y las actualizaciones peridicas, su utilidad est
limitada en muchas de las redes actuales.
Por consiguiente, Cisco mejor IGRP como un algoritmo nuevo, DUAL, y otras
caractersticas. Los comandos tanto para IGRP como para EIGRP son
parecidos, y en muchos casos idnticos. Gracias a ello es fcil migrar de IGRP a
EIGRP. Cisco suspendi IGRP empezando con las versiones 12.2(13)T y
12.2(R1s4)S del software Cisco IOS.
Vamos a examinar algunas de las diferencias entre un protocolo de
enrutamiento por vector de distancia tradicional como RIP e IGRP, y el
protocolo de enrutamiento por vector de distancia mejorando, EIGRP.

Protocolos de enrutamiento por vector de


distancia tradicionales
Utilizan el algoritmo Bellman-Ford o FordFulkerson.
Envejecen las entradas de enrutamiento y
utilizan actualizaciones peridicas.
Solo hace un seguimiento de las mejores
rutas; la mejor ruta a una red de destino.

Protocolo de enrutamiento por vector de


distancia mejorado: EIGRP
Utiliza DUAL.

No envejece las entradas de enrutamiento ni


utiliza actualizaciones peridicas.
Mantiene una tabla de topologa separada de
la tabla de enrutamiento, que incluye la mejor
ruta y cualesquiera rutas de respaldo libres de
bucles.
Cuando una ruta deja de estar disponible, el Cuando una ruta deja de estar disponible,
router debe esperar por una actualizacin de DUAL utiliza una ruta de respaldo si existe
enrutamiento.
una en la tabla topolgica.
Convergencia ms lenta debido a los Convergencia ms rpida debido a la ausencia
temporizadores hold-down.
de temporizadores hold-down y un sistema de
clculos de rutas coordinados.

43

Sistema a Distancia

Telemtica II - Unidad IV

3.3

Rubn Cueva Ziga

Caracterstica
El protocolo de enrutamiento de Gateway interior mejorado (EIGRP, Enhanced
Interior Gateway Routing Protocol) es un protocolo de enrutamiento por vector
de distancia y sin clase, que se lanz en 1992 con la versin 9.21 del software
Cisco IOS. Como su nombre sugiere, EIGRP es un protocolo de enrutamiento
de Gateway interior (IGRP) de Cisco. Los dos son protocolos propietarios de
Cisco y operan en los routers Cisco.
El propsito principal en el desarrollo de EIGRP por parte de Cisco fue crear
una versin sin clase de IGRP. EIGRP incluye varias caractersticas que
normalmente no se encuentran en otros protocolos de enrutamiento por vector
de distancia como el protocolo de informacin de enrutamiento por vector de
distancia como el protocolo de informacin de enrutamiento (RIPv1 y RIPv2) e
IGRP.
Estas caractersticas son las siguientes:
- Protocolo de transporte fiable.
- Actualizaciones limitadas.
- Algoritmo de actualizacin por difusin.
- Establecimiento de adyacencias.
- Tablas de vecinos y de topologa.
Aunque EIGRP podra actuar como un protocolo de enrutamiento por estado del
enlace, sigue siendo un protocolo de enrutamiento por vector distancia.

3.4

Formato de mensaje EIGRP


La porcin de datos de un mensaje EIGRP esta encapsulada en un paquete. Este
campo de datos se denomina Tipo/Longitud/Valor, o TLV. Como se muestra en
la figura 30, los tipos de TLV relativos a este curso son Parmetros EIGRP,
Rutas internas IP, y Rutas externas IP.
La cabecera de paquete EIGRP se incluye con cada paquete EIGRP,
independientemente de su tipo. La cabecera de paquete EIGRP y el TLV se
encapsulan despus en un paquete IP. En la cabecera de paquete IP, el campo de
protocolo se establece a 88 para indicar EIGRP, y la direccin de destino se
establece a la direccin de multicast 224.0.0.10. Si el paquete EIGRP se
encapsula en una trama Ethernet, la direccin MAC de destino tambin es una
direccin de multicast.
Todo mensaje EIGRP incluye la cabecera, que se muestra en la figura.

44

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Figura 30: Formato de mensaje de EIGRP

Los campos importantes para nuestra explicacin son los campos Opcode y
Nmero de sistemas autnomo. Opcode especifica el tipo de paquete EIGRP
como uno de los siguientes:
- Actualizacin
- Consulta
- Respuesta
- Saludo
Los campos importantes para nuestra explicacin son los siguientes:


Los campos de mtrica (Retraso y ancho de banda): El retraso se


calcula como la suma de los retrasos desde el origen hasta el destino,
en unidades de 10 microsegundos. El ancho de banda es el ancho de
banda ms bajo configurado de cualquier interfaz a lo largo de la ruta.

El campo de la mscara de subred (Longitud de prefijo): La


mscara de subred se especifica como la longitud de prefijo o el nmero
de bits de red en la mscara de subred. Por ejemplo, la longitud de
prefijo para la mscara de subred 255.255.255.0 es 24 porque 24 es el
nmero de bits de red.

El campo destino: este campo almacena la direccin de la red de


destino. Aunque es esta figura solo se muestra 24 bits, este campo varia
en base al valor de la porcin de red de la direccin de red de 32 bits.
Por ejemplo, la porcin de red de 10.1.0.0/16 es 10.1. por tanto, el
campo Destino almacena los 16 primeros bits. Como la longitud
mnima de este campo es de 24 bits, el resto del campo de rellena con

45

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

ceros. Si una direccin de red es ms larga que 24 bits (por ejemplo,


192.168.1.32/27), el campo destino se extiende otros 32 bits (para hacer
un total de 56 bits), rellenndose con ceros los bits que no se utilizan.

46

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Leccin 8
4. Protocolo OSPF
4.1

Introduccin
Open Shortest Path First (OSPF) es un protocolo de enrutamiento de estado del
enlace, desarrollado como reemplazo del protocolo de enrutamiento vector
distancia RIP. RIP constituy un protocolo de enrutamiento aceptable en los
comienzos del networking y de Internet; sin embargo, su dependencia en el
conteo de saltos como la nica medida para elegir el mejor camino rpidamente
se volvi inaceptable en redes mayores que necesitan una solucin de
enrutamiento ms slida. OSPF es un protocolo de enrutamiento sin clase que
utiliza el concepto de reas para realizar la escalabilidad. RFC 2328 define la
mtrica OSPF como un valor arbitrario llamado costo. El IOS de Cisco utiliza el
ancho de banda como la mtrica de costo de OSPF.
Las principales ventajas de OSPF frente a RIP son su rpida convergencia y
escalabilidad en implementaciones de redes mucho mayores.

4.2

Encapsulacin de mensajes OSPF


La porcin de datos de un mensaje OSPF se encapsula en un paquete. Este
campo de datos puede incluir uno de cinco tipos de paquetes OSPF.
El encabezado del paquete OSPF se incluye con cada paquete OSPF,
independientemente de su tipo. El encabezado del paquete OSPF y los datos
especficos segn el tipo de paquete especfico se encapsulan luego en un
paquete IP.

47

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Figura 31: Encapsulamiento de OSPF

4.3

Tipos de paquetes OSPF


La figura 32 muestra los cinco tipos diferentes de LSP de OSPF. Cada paquete
cumple una funcin especfica en el proceso de enrutamiento de OSPF:

Figura 32: Paquetes OSPF

4.4

Saludo: los paquetes de saludo se utilizan para establecer y mantener la


adyacencia con otros routers OSPF. El protocolo de saludo se analiza en
detalle en el prximo tema.

DBD: el paquete de Descriptores de bases de datos (DBD) incluye una lista


abreviada de la base de datos de estado de enlace del router emisor y es
utilizado por los routers receptores para realizar una comparacin con la
base de datos de estado del enlace.

LSR: los routers receptores pueden entonces solicitar ms informacin


acerca de una entrada en la DBD enviando una Solicitud de estado del
enlace (LSR).

LSU: los paquetes de Actualizacin de estado de enlace (LSU) se utilizan


para responder las LSR y para anunciar nueva informacin. Las LSU
contienen siete tipos diferentes de Notificaciones de estado de enlace
(LSA). Las LSU y LSA se analizarn brevemente en un tema posterior.

LSAck: cuando se recibe una LSU, el router enva un Acuse de recibo de


estado de enlace (LSAck) para confirmar la recepcin de LSU.

mtricas
La mtrica del OSPF se denomina costo. En RFC 2328: "Un costo se asocia con
el resultado de cada interfaz de router. Dicho costo est configurado por el

48

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

administrador del sistema. Cuanto ms bajo sea el costo, ms probabilidad hay


de que la interfaz sea utilizada para enviar trfico de datos."
Observe que RFC 2328 no especifica los valores que deben utilizarse para
determinar el costo.
El IOS de Cisco utiliza los anchos de banda acumulados de las interfaces de
salida desde el router hasta la red de destino como el valor del costo. En cada
router, el costo de una interfaz se calcula en 10 a la octava potencia dividido por
el ancho de banda en bps. Esto se conoce como ancho de banda de referencia.
La divisin de 10 a la octava potencia por el ancho de banda de la interfaz se
realiza para que las interfaces con mayores valores de ancho de banda tengan un
costo calculado inferior. Recuerde, en las mtricas de enrutamiento, la ruta de
inferior coste es la ruta preferida (por ejemplo, con RIP, 3 saltos es mejor que
10 saltos). La figura muestra los costes predeterminados de OSPF para varios
tipos de interfaces.
Ancho de banda de referencia
El ancho de banda de referencia predeterminado es de 10 a la octava potencia,
100 000 000 bps o 100 Mbps. Esto da como resultado interfaces con un ancho
de banda de 100 Mbps y ms con el mismo costo de OSPF de 1. El ancho de
banda de referencia puede modificarse para adaptarse a redes con enlaces ms
rpidos que 100 000 000 bps (100 Mbps) con el comando auto-cost referencebandwidth de OSPF. Cuando este comando es necesario, se recomienda su
utilizacin en todos los routers para que la mtrica de enrutamiento de OSPF se
mantenga uniforme.

Costes acumulados de OSPF


El coste de una ruta OSPF es el valor acumulado desde un router hasta la red de
destino. Por ejemplo, en la figura, la tabla de enrutamiento en R1 muestra un
costo de 65 para alcanzar la red 10.10.10.0/24 en R2. Debido a que
10.10.10.0/24 est conectada a la interfaz FastEthernet, R2 asigna el valor de 1
como costo para 10.10.10.0/24. R1 luego agrega el valor del costo adicional de
64 para enviar datos a travs del enlace T1 predeterminado entre R1 y R2.

49

Sistema a Distancia

Telemtica II - Unidad IV

Rubn Cueva Ziga

Ancho de banda predeterminado en interfaces seriales


Recuerde que en el Captulo 9, "EIGRP", se indic que el comando show
interface se puede utilizar para ver el valor del ancho de banda utilizado para
una interfaz. En los routers de Cisco, el valor del ancho de banda
predeterminado de varias interfaces seriales es T1 (1 544 Mbps). Sin embargo,
algunas interfaces seriales pueden tener el valor predeterminado de 128 kbps.
Por lo tanto, nunca suponga que OSPF utiliza un valor de ancho de banda
particular. Siempre verifique el valor predeterminado con el comando show
interface.
Recuerde que este valor de ancho de banda no afecta realmente la velocidad del
enlace; lo utilizan ciertos protocolos de enrutamiento para calcular la mtrica de
enrutamiento. Muy probablemente, en las interfaces seriales la velocidad real
del enlace es diferente del ancho de banda predeterminado. Es importante que el
valor de ancho de banda refleje la velocidad real del enlace para que la tabla de
enrutamiento tenga informacin precisa del mejor camino. Por ejemplo, el
usuario puede estar pagando a su proveedor de servicios nicamente por una
conexin T1 fraccional, un cuarto de la conexin T1 completa (384 kbps). Sin
embargo, a los fines del protocolo de enrutamiento, IOS supone el valor de
ancho de banda de T1 a pesar de que la interfaz en realidad slo enva y recibe
un cuarto de una conexin T1 completa (384 kbps)

50

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

QUINTA UNIDAD
Leccin 5

1. Configuracin de Protocolos de Enrutamiento


1.1

Configuracin de Rutas Estticas

Tabla de direccionamiento
Dispositivo
R1
R2

R3
PC1
PC2
PC3

Interfaz
F0/0
S0/0
F0/0
S0/1
S0/0
F0/0
S0/1
NIC
NIC
NIC

Direccin IP
192.168.1.1
10.10.10.1
192.168.2.1
10.10.10.2
11.11.11.1
192.168.3.1
11.11.11.2
192.168.1.10
192.168.2.10
192.168.3.10

Mascara
de Gateway
por
subred
defecto
255.255.255.0
No aplicable
255.255.255.252
No aplicable
255.255.255.0
No aplicable
255.255.255.252
No aplicable
255.255.255.252
No aplicable
255.255.255.0
No aplicable
255.255.255.252
No aplicable
255.255.255.0
192.168.1.1
255.255.255.0
192.168.2.1
255.255.255.0
192.168.3.1

Paso 1: Configuracin bsica en los routers


En R1:
Router >enable
Router #configure terminal
Router(config)#hostname R1
R1(config)#line console 0

51

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

R1(config-line)#logging synchronous
R1(config-line)#password uigv
R1(conf-line)#login
R1(conf-line)#line vty 0 5
R1(conf-line)#password uigv
R1(conf-line)#login
R1(conf-line)#exit
R1(conf)#no ip domain-lookup
R1(conf)#enable secret telematica
R1(conf)#service password-encription
R1(conf)#end
R1#copy running-config startup-config
Repetir los pasos de configuracin en los routers R2 y R3
Paso 2: Configurar interfaces del router.
En R1:
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0
R1(config-if)#ipaddress 10.10.10.1 255.255.255.252
R1(config-if)#no shutdown
R1(config)#end
En R2:
R2#configure terminal
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config)#interface fastEthernt 0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface serial 0/0
R2(config-if)#ip address 11.11.11.1 255.255.255.252
R2(config-if)#no shutdown
R3(config-if)#end

En R3:
R3#configure terminal
R3(config)#interface serial 0/1

52

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

R3(config-if)#ip address 11.11.11.2 255.255.255.252


R3(config)#no shutdown
R3(config)#end
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-f)#no shutdown
R3(config-if)#end
Paso 3: Configurar rutas estticas
Antes de empezar con nuestra configuracin debemos tener en cuenta ciertos parmetros:
1.- Para ingresar una ruta esttica debemos estar en el modo de configuracin global.
2.- la sintaxis para ingresar una ruta esttica es:
ip route <red destino><mascara de red destino><interface de salida>

Ejemplo: ip route 192.168.1.0 255.255.255.0 s0/0


En nuestra topologa tenemos un total de 5 redes. Esto quiere decir que para que nuestra
topologa converja debe haber 5 rutas presente en las tablas de enrutamiento de R1, R2 y R3.
En R1:
R1#configure terminal
R1(config)#ip route 192.168.2.0 255.255.255.0 serial 0/0
R1(config)#ip route 11.11.11.0 255.255.255.252 serial 0/0
R1(config)#ip route 192.168.3.0 255.255.255.0 serial 0/0
En R2:
R2#configure terminal
R2(config)#ip route 192.168.1.0 255.255.255.0 serial 0/1
R2(config)#ip route 192.168.3.0 255.255.255.0 serial 0/0
En R3:
R3#configure terminal
R3(config)#ip route 192.168.2.0 255.255.255.0 serial 0/1
R3(config)#ip route 10.10.10.0 255.255.255.252 serial 0/1
R3(config)#ip route 192.168.1.0 255.255.255.0 serial 0/1

53

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento de R1
R1#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set

C
S
C
S
S

10.0.0.0/30 is subnetted, 1 subnets


10.10.10.0 is directly connected, Serial0/0
11.0.0.0/30 is subnetted, 1 subnets
11.11.11.0 is directly connected, Serial0/0
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
192.168.3.0/24 is directly connected, Serial0/0

Tabla de enrutamiento de R2
R2#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set

C
C
S
C
S

10.0.0.0/30 is subnetted, 1 subnets


10.10.10.0 is directly connected, Serial0/1
11.0.0.0/30 is subnetted, 1 subnets
11.11.11.0 is directly connected, Serial0/0
192.168.1.0/24 is directly connected, Serial0/1
192.168.2.0/24 is directly connected, FastEthernet0/0
192.168.3.0/24 is directly connected, Serial0/0

Tabla de enrutamiento de R3
R3#show ip route
<Esta seccin ha sido omitida>

Gateway of last resort is not set

S
C
S
S
C

10.0.0.0/30 is subnetted, 1 subnets


10.10.10.0 is directly connected, Serial0/1
11.0.0.0/30 is subnetted, 1 subnets
11.11.11.0 is directly connected, Serial0/1
192.168.1.0/24 is directly connected, Serial0/1
192.168.2.0/24 is directly connected, Serial0/1
192.168.3.0/24 is directly connected, FastEthernet0/0

54

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Breve explicacin de la tabla de enrutamiento:


Podemos reconocer el origen de una entrada en nuestra tabla de enrutamiento por medio de los
siguientes parmetros:

Cuando veamos la letra S al lado izquierdo de una direccin de red, nos est dando a
notar que la direccin fue ingresada de forma manual. Si revisamos las configuraciones
en los pasos anteriores podemos ver que el ingreso se hizo con el comando IP ROUTE.

La letra C, nos quiere decir que es una conexin directa.

10.10.10.0, nos hace referencia que hemos ingresado esta direccin de red.

is directly connected, Serial0/1, conectado fsicamente al router en la interface


Serial0/1.

55

Sistema a Distancia

Telemtica II - Unidad V

1.2

Rubn Cueva Ziga

Configuracin de RIPv1

Tabla de direccionamiento
Dispositivo

Interfaz

Direccin IP

R1

F0/0
S0/0
F0/0
S0/1
S0/0
F0/0
S0/1
NIC
NIC
NIC

192.168.1.1
192.168.2.1
192.168.3.1
192.168.4.1
192.168.2.2
192.168.5.1
192.168.4.2
192.168.1.10
192.168.2.10
192.168.3.10

R2

R3
PC1
PC2
PC3

Mascara
de
subred
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0

Gateway
por
defecto
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
192.168.1.1
192.168.2.1
192.168.3.1

Paso 1: configuracin bsica en R1, R2 y R3


En R1:
Router >enable
Router #configure terminal
Router(config)#hostname R1
R1(config)#line console 0
R1(config-line)#logging synchronous
R1(config-line)#password uigv
R1(conf-line)#login

56

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

R1(conf-line)#line vty 0 5
R1(conf-line)#password uigv
R1(conf-line)#login
R1(conf-line)#exit
R1(conf)#no ip domain-lookup
R1(conf)#enable secret telematica
R1(conf)#service password-encription
R1(conf)#end
R1#copy running-config startup-config
Repetir los pasos de configuracin en los routers R2 y R3

Paso 2: Configurar interfaces del router.


En R1:
R1>enable
R1#configure terminal
R1(conf)#interface f0/0
R1(conf-if)#ip address 192.168.1.1 255.255.255.0
R1(conf-if)#no shutdown
R1(conf)#int s0/0
R1(conf-if)#ip address 192.168.2.1 255.255.255.0
R1(conf-if)#no shutdown
R1(conf-if)#end
R1#copy running-config startup-config

En R2:
R2>enable
R2#conf t
R2(conf)#int s0/0
R2(conf-if)#ip address 192.168.2.2 255.255.255.0
R2(conf-if)#no shutdown
R2(conf-if)#int f0/0
R2(conf-if)#ip address 192.168.3.1 255.255.255.0
R2(conf-if)#int s0/1
R2(conf-if)#ip address 192.168.4.1 255.255.255.0
R2(conf-if)#end
R2#copy running-config startup-config
En R3:
R3>enable
R3#configure terminal
R3 (config)#int f0/0

57

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

R3 (conf-if)#ip address 192.168.5.1 255.255.255.0


R3 (conf-if)#no shutdown
R3 (conf-if)#int s0/1
R3 (conf-if)#ip address 192.168.4.2 255.255.255.0
R3 (conf-if)#no shutdown
R3 (conf-if)#end
R3#copy running-config startup-config
Paso 3 : Enrutamiento con Ripv1
En R1:
R1>enable
R1#conf igure terminal
R1(conf)#router rip
R1(conf-router)#network 192.168.1.0
R1(conf-router)#network 192.168.2.0
R1(conf-router)# passive-interface FastEthernet0/0
R1(conf-router)#end
R1#copy running-config startup-config

En R2:
R2>enable
R2#conf igure terminal
R2(conf)#router rip
R2(conf-router)#network 192.168.2.0
R2(conf-router)#network 192.168.3.0
R2(conf-router)#network 192.168.4.0
R2(conf-router)# passive-interface FastEthernet0/0
R2(conf-router)#end
R2#copy running-config startup-config

En R3:
R3>enable
R3#conf igure terminal
R3(conf)#router rip
R3(conf-router)#network 192.168.4.0
R3(conf-router)#network 192.168.5.0
R3(conf-router)# passive-interface FastEthernet0/0
R3(conf-router)#end
R3#copy running-config startup-config

58

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento de R1
R1#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
R
R
C
C
R

192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:25, Serial0/0


192.168.5.0/24 [120/1] via 192.168.2.2, 00:00:25, Serial0/0
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:25, Serial0/0

Tabla de enrutamiento de R2
R2#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
C
R
R
C
C

192.168.4.0/24 is directly connected, Serial0/1


192.168.5.0/24 [120/1] via 192.168.4.2, 00:00:10, Serial0/1
192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:02, Serial0/0
192.168.2.0/24 is directly connected, Serial0/0
192.168.3.0/24 is directly connected, FastEthernet0/0

Tabla de enrutamiento de R3
R3#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
C
C
R
R
R

192.168.4.0/24 is directly connected, Serial0/1


192.168.5.0/24 is directly connected, FastEthernet0/0
192.168.1.0/24 [120/1] via 192.168.4.1, 00:00:04, Serial0/1
192.168.2.0/24 [120/1] via 192.168.4.1, 00:00:04, Serial0/1
192.168.3.0/24 [120/1] via 192.168.4.1, 00:00:04, Serial0/1

59

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

La letra R que se muestra a la izquierda de las direcciones de red nos hace referencia que la
direccin se la aprendido por medio de RIP.
12.3

Configuracin de RIPv2

Tabla de direccionamiento
Dispositivo

Interfaz

Direccin IP

R1

F0/0
S0/0
F0/0
S0/1
S0/0
F0/0
S0/1
NIC
NIC
NIC

192.168.1.1
10.10.10.1
192.168.3.1
11.11.11.1
10.10.10.2
192.168.5.1
11.11.11.2
192.168.1.10
192.168.2.10
192.168.3.10

R2

R3
PC1
PC2
PC3

60

Mascara
de
subred
255.255.255.0
255.255.255.252
255.255.255.0
255.255.255.252
255.255.255.0
255.255.255.0
255.255.255.252
255.255.255.0
255.255.255.0
255.255.255.0

Gateway
por
defecto
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
192.168.1.1
192.168.2.1
192.168.3.1

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Paso 1: configuracin bsica en R1, R2 y R3


En R1:
Router >enable
Router #configure terminal
Router(config)#hostname R1
R1(config)#line console 0
R1(config-line)#logging synchronous
R1(config-line)#password uigv
R1(conf-line)#login
R1(conf-line)#line vty 0 5
R1(conf-line)#password uigv
R1(conf-line)#login
R1(conf-line)#exit
R1(conf)#no ip domain-lookup
R1(conf)#enable secret telematica
R1(conf)#service password-encription
R1(conf)#end
R1#copy running-config startup-config
Repetir los pasos de configuracin en los routers R2 y R3
Paso 2: Configurar interfaces del router.
En R1:
R1>enable
R1#configure terminal
R1(conf)#interface f0/0
R1(conf-if)#ip address 192.168.1.1 255.255.255.0
R1(conf-if)#no shutdown
R1(conf)#int s0/0
R1(conf-if)#ip address 10.10.10.1 255.255.255.252
R1(conf-if)#no shutdown
R1(conf-if)#end
R1#copy running-config startup-config

En R2:
R2>enable
R2#conf t
R2(conf)#int s0/0
R2(conf-if)#ip address 10.10.10.2 255.255.255.252
R2(conf-if)#no shutdown

61

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

R2(conf-if)#int f0/0
R2(conf-if)#ip address 192.168.10.1 255.255.255.0
R2(conf-if)#int s0/1
R2(conf-if)#ip address 11.11.11.1 255.255.255.252
R2(conf-if)#end
R2#copy running-config startup-config
En R3:
R3>enable
R3#configure terminal
R3 (config)#int f0/0
R3 (conf-if)#ip address 172.16.1.1 255.255.255.0
R3 (conf-if)#no shutdown
R3 (conf-if)#int s0/1
R3 (conf-if)#ip address 11.11.11.2 255.255.255.252
R3 (conf-if)#no shutdown
R3 (conf-if)#end
R3#copy running-config startup-config
Paso 3 : Enrutamiento con Ripv2
En R1:
R1>enable
R1#conf igure terminal
R1(conf)#router rip
R1(conf-router)#version 2
R1(conf-router)#network 192.168.1.0
R1(conf-router)#network 10.10.10.0
R1(conf-router)# no auto-summary
R1(conf-router)# passive-interface FastEthernet0/0
R1(conf-router)#end
R1#copy running-config startup-config
En R2:
R2>enable
R2#conf igure terminal
R2(conf)#router rip
R2(conf-router)#version 2
R2(conf-router)#network 192.168.10.0
R2(conf-router)#network 10.10.10.0
R2(conf-router)#network 11.11.11.0
R2(conf-router)# no auto-summary
R2(conf-router)# passive-interface FastEthernet0/0
R2(conf-router)#end
R2#copy running-config startup-config

62

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

En R3:
R3>enable
R3#conf igure terminal
R3(conf)#router rip
R3(conf-router)#version 2
R3(conf-router)#network 11.11.11.0
R3(conf-router)#network 172.16.1.0
R3(conf-router)# no auto-summary
R3(conf-router)# passive-interface FastEthernet0/0
R3(conf-router)#end
R3#copy running-config startup-config

Tabla de enrutamiento de R1
R1#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
R 192.168.10.0/24 [120/1] via 10.10.10.2, 00:00:16, Serial0/0
R 172.16.0.0/16 [120/1] via 10.10.10.2, 00:00:16, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C
10.10.10.0 is directly connected, Serial0/0
R 11.0.0.0/8 [120/1] via 10.10.10.2, 00:00:16, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0

Tabla de enrutamiento de R2
R2#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, FastEthernet0/0
R 172.16.0.0/16 [120/1] via 11.11.11.2, 00:00:07, Serial0/1
10.0.0.0/30 is subnetted, 1 subnets
C
10.10.10.0 is directly connected, Serial0/0
11.0.0.0/30 is subnetted, 1 subnets
C
11.11.11.0 is directly connected, Serial0/1
R 192.168.1.0/24 [120/1] via 10.10.10.1, 00:00:06, Serial0/0

63

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento R3
R3#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
R 192.168.10.0/24 [120/1] via 11.11.11.1, 00:00:20, Serial0/1
172.16.0.0/24 is subnetted, 1 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
R 10.0.0.0/8 [120/1] via 11.11.11.1, 00:00:20, Serial0/1
11.0.0.0/30 is subnetted, 1 subnets
C
11.11.11.0 is directly connected, Serial0/1
R 192.168.1.0/24 [120/1] via 11.11.11.1, 00:00:20, Serial0/1

12.4 Configuracin de EIGRP

64

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de direccionamiento
Dispositivo

Interfaz

Direccin IP

R1

F0/0
F0/1
F1/0
S0/0
S0/1
F0/0
F0/1
F1/0
S0/1
S0/0
S0/0
S0/1
S0/2
S0/0
F0/0
NIC
NIC
NIC
NIC
NIC
NIC
NIC

192.168.1.1
192.168.1.129
192.168.1.193
10.10.10.1
10.0.0.9
172.16.0.1
172.16.1.1
172.16.1.129
10.0.0.6
10.0.0.10
10.0.0.2
10.0.0.5
200.165.210.1
200.165.210.2
200.165.30.1
192.168.1.126
192.168.1.190
192.168.1.222
172.16.0.254
172.16.1.126
172.16.1.190
200.165.30.2

R2

PRINCIPAL

ISP
PC1
PC2
PC3
PC4
PC5
PC6
SERVER

Mascara
de
subred
255.255.255.128
255.255.255.192
255.255.255.224
255.255.255.252
255.255.255.252
255.255.255.0
255.255.255.128
255.255.255.192
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.128
255.255.255.192
255.255.255.224
255.255.255.0
255.255.255.128
255.255.255.192
255.255.255.252

Gateway
por
defecto
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
192.168.1.1
192.168.1.129
192.168.1.193
172.16.0.1
172.16.1.1
172.16.1.129
200.165.30.1

Paso 1: Hacer el VLSM correspondiente:


Paso 2: Configuracin bsica en R1, R2 y R3
En R1:
Router >enable
Router #configure terminal
Router(config)#hostname R1
R1(config)#line console 0
R1(config-line)#logging synchronous
R1(config-line)#password uigv
R1(conf-line)#login
R1(conf-line)#line vty 0 5
R1(conf-line)#password uigv
R1(conf-line)#login
R1(conf-line)#exit
R1(conf)#no ip domain-lookup
R1(conf)#enable secret telematica
R1(conf)#service password-encription
R1(conf)#end
R1#copy running-config startup-config
Repetir los pasos de configuracin en los routers R2 y R3

65

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Paso3: Configurar interfaces de los routers R1, R2, PRINCIPAL, ISP; en las PC y el SEVER.
Paso 4: Configurar enrutamiento con EIGRP, usaremos como id 1

En R1:
R1>enable
R1#configure terminal
R1(conf)#router eigrp 1
R1(conf-router)#network 10.0.0.0 0.0.0.3
R1(conf-router)#network 10.0.0.8 0.0.0.3
R1(conf-router)#network 192.168.1.0
R1(conf-router)# no auto-summary
R1(conf-router)# passive-interface FastEthernet0/0
R1(conf-router)# passive-interface FastEthernet0/1
R1(conf-router)# passive-interface FastEthernet1/0
R1(conf-router)#end
R1#copy running-config startup-config
En R2
R2>enable
R2#configure terminal
R2(conf)#router eigrp 1
R2(conf-router)#network 10.0.0.4 0.0.0.3
R2(conf-router)#network 10.0.0.8 0.0.0.3
R2(conf-router)#network 172.16.0.0
R2(conf-router)# no auto-summary
R2(conf-router)# passive-interface FastEthernet0/0
R2(conf-router)# passive-interface FastEthernet0/1
R2(conf-router)# passive-interface FastEthernet1/0
R2(conf-router)#end
R2#copy running-config startup-config
En PRINCIPAL
PRINCIPAL >enable
PRINCIPAL #configure terminal
PRINCIPAL (conf)#router eigrp 1
PRINCIPAL (conf-router)#network 10.0.0.0 0.0.0.3
PRINCIPAL (conf-router)#network 10.0.0.4 0.0.0.3
PRINCIPAL (conf-router)# no auto-summary
PRINCIPAL (conf-router)# passive-interface Serial0/2
PRINCIPAL (conf-router)#end
PRINCIPAL #copy running-config startup-config

66

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Paso 5: Configuracin de ruta predeterminada en PRINCIPAL:


Cuando el destino al que se pretende llegar son mltiples redes o no se conocen se puede crear
rutas
estticas
por
default
como
lo
muestra
la
siguiente
sintaxis:
Router (config)#ip route 0.0.0.0 0.0.0.0 <interfaz de salida>
PRINCIPAL (conf)#ip route 0.0.0.0 0.0.0.0 serial0/2
Para propagar la ruta predeterminada a los dems routers lo hacemos por medio del protocolo
eigrp:
PRINCIPAL(config)#router eigrp 1
PRINCIPAL(config-router)#redistribute static
Paso 6: Configuracin de rutas estticas en ISP:
En el ISP no configuramos ningn protocolo por ser nuestro proveedor de servicio. Entonces
como alcanzamos las redes remotas; vamos a configurar dos rutas estticas, que sern las IPs
principales de cada red.
PRINCIPAL(config)# ip route 172.16.0.0 255.255.254.0 Serial0/0
PRINCIPAL(config)# ip route 192.168.1.0 255.255.255.0 Serial0/0
PRINCIPAL(config)# ip route 10.0.0.0 255.255.255.248 Serial0/0

Tabla de enrutamiento de R1
R1#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is 10.0.0.2 to network 0.0.0.0
172.16.0.0/23 is subnetted, 1 subnets
D
172.16.0.0 [90/2172416] via 10.0.0.10, 01:38:17, Serial0/1
10.0.0.0/30 is subnetted, 3 subnets
C
10.0.0.8 is directly connected, Serial0/1
C
10.0.0.0 is directly connected, Serial0/0
D
10.0.0.4 [90/2681856] via 10.0.0.10, 01:38:17, Serial0/1
[90/2681856] via 10.0.0.2, 01:38:17, Serial0/0
192.168.1.0/24 is variably subnetted, 4 subnets, 4 masks
C
192.168.1.0/25 is directly connected, FastEthernet0/0
D
192.168.1.0/24 is a summary, 01:38:20, Null0
C
192.168.1.192/27 is directly connected, FastEthernet1/0
C
192.168.1.128/26 is directly connected, FastEthernet0/1
D*EX 0.0.0.0/0 [170/2681856] via 10.0.0.2, 01:30:05, Serial0/0

67

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento de R2
R2#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is 10.0.0.5 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 4 subnets, 4 masks
C
172.16.1.128/26 is directly connected, FastEthernet1/0
C
172.16.0.0/24 is directly connected, FastEthernet0/0
D
172.16.0.0/23 is a summary, 02:40:38, Null0
C
172.16.1.0/25 is directly connected, FastEthernet0/1
10.0.0.0/30 is subnetted, 3 subnets
C
10.0.0.8 is directly connected, Serial0/0
D
10.0.0.0 [90/2681856] via 10.0.0.9, 02:40:36, Serial0/0
[90/2681856] via 10.0.0.5, 02:40:36, Serial0/1
C
10.0.0.4 is directly connected, Serial0/1
D 192.168.1.0/24 [90/2172416] via 10.0.0.9, 02:40:36, Serial0/0
D*EX 0.0.0.0/0 [170/2681856] via 10.0.0.5, 02:32:24, Serial0/1

Tabla de enrutamiento de PRINCIPAL

PRINCIPAL#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
172.16.0.0/23 is subnetted, 1 subnets
D
172.16.0.0 [90/2172416] via 10.0.0.6, 02:54:11, Serial0/1
10.0.0.0/30 is subnetted, 3 subnets
D
10.0.0.8 [90/2681856] via 10.0.0.6, 02:54:11, Serial0/1
[90/2681856] via 10.0.0.1, 02:54:11, Serial0/0
C
10.0.0.0 is directly connected, Serial0/0
C
10.0.0.4 is directly connected, Serial0/1
200.165.210.0/30 is subnetted, 1 subnets
C
200.165.210.0 is directly connected, Serial0/2
D 192.168.1.0/24 [90/2172416] via 10.0.0.1, 02:54:11, Serial0/0
S* 0.0.0.0/0 is directly connected, Serial0/2

68

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento de ISP


ISP#show ip route
<Esta seccin ha sido omitida>
Gateway of last resort is not set
172.16.0.0/23 is subnetted, 1 subnets
172.16.0.0 is directly connected, Serial0/0
200.165.210.0/30 is subnetted, 1 subnets
C
200.165.210.0 is directly connected, Serial0/0
200.165.30.0/30 is subnetted, 1 subnets
C
200.165.30.0 is directly connected, FastEthernet0/0
S 192.168.1.0/24 is directly connected, Serial0/0
S

12.5

Configuracin de OSPF

69

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de direccionamiento
Dispositivo

Interfaz

Direccin IP

R1

F0/0
F0/1
F1/0
S0/0
S0/1
F0/0
F0/1
F1/0
S0/0
S0/1
S0/0
S0/1
S0/2
S0/0
F0/0
NIC
NIC
NIC
NIC
NIC
NIC
NIC

192.168.1.1
192.168.1.129
192.168.1.193
10.10.10.1
10.0.0.9
172.16.0.1
172.16.1.1
172.16.1.129
10.0.0.6
10.0.0.10
10.0.0.2
10.0.0.5
200.165.210.1
200.165.210.2
200.165.30.1
192.168.1.126
192.168.1.190
192.168.1.222
172.16.0.254
172.16.1.126
172.16.1.190
200.165.30.2

R2

PRINCIPAL

ISP
PC1
PC2
PC3
PC4
PC5
PC6
SERVER

Mascara
de
subred
255.255.255.128
255.255.255.192
255.255.255.224
255.255.255.252
255.255.255.252
255.255.255.0
255.255.255.128
255.255.255.192
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.128
255.255.255.192
255.255.255.224
255.255.255.0
255.255.255.128
255.255.255.192
255.255.255.252

Gateway
por
defecto
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
No aplicable
192.168.1.1
192.168.1.129
192.168.1.193
172.16.0.1
172.16.1.1
172.16.1.129
200.165.30.1

Paso 1: Configurar direccionamiento y configuraciones bsicas en R1, R2, PRINCIPAL, ISP y


configurar las pc con el direccionamiento correspondiente, as como se ha hecho en el ejercicio
anterior.
Paso 2: Configurar enrutamiento con OSPF, usaremos como id 1
En R1:
R1#configure terminal
R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.0.0.3 area 0
R1(config-router)# network 10.0.0.8 0.0.0.3 area 0
R1(config-router)#network 192.168.1.0 0.0.0.127 area 0
R1(config-router)#network 192.168.1.128 0.0.0.63 area 0
R1(config-router)#network 192.168.1.192 0.0.0.31 area 0
R1(config-router)#passive-interface f0/0
R1(config-router)#passive-interface f0/1
R1(config-router)#passive-interface f1/0
R1(config-router)#end
R1#copy running-config startup-config
En R2:
R2#configure terminal

70

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

R2(config)#router ospf 1
R2(config-router)#network 10.0.0.4 0.0.0.3 area 0
R2(config-router)#network 10.0.0.8 0.0.0.3 area 0
R2(config-router)# 172.16.0.0 0.0.0.255 area 0
R2(config-router)# 172.16.1.0 0.0.0.127 area 0
R2(config-router)# 172.16.1.128 0.0.0.63 area 0
R2(config-router)#passive-interface f0/0
R2(config-router)#passive-interface f0/1
R2(config-router)#passive-interface f1/0
R2(config-router)#end
R2#copy running-config startup-config
En PRINCIPAL:
PRINCIPAL#configure terminal
PRINCIPAL(config)#router ospf 1
PRINCIPAL(config-router)#network 10.0.0.0 0.0.0.3 area 0
PRINCIPAL(config-router)#network 10.0.0.4 0.0.0.3 area 0
PRINCIPAL(config-router)#passive-interface s0/2
PRINCIPAL(config-router)#end
PRINCIPAL#copy runnin-config startup-config
Paso 3: Configuracin de ruta predeterminada en PRINCIPAL
Cuando el destino al que se pretende llegar son mltiples redes o no se conocen se puede crear
rutas
estticas
por
default
como
lo
muestra
la
siguiente
sintaxis:
Router (config)#ip route 0.0.0.0 0.0.0.0 <interfaz de salida>
PRINCIPAL (conf)#ip route 0.0.0.0 0.0.0.0 serial0/2
Para propagar la ruta predeterminada a los dems routers lo hacemos por medio del protocolo
eigrp:
PRINCIPAL(config)#router ospf 1
PRINCIPAL(config-router)# default-information originate
Paso 4: Configuracin de rutas estticas en ISP
En el ISP no configuramos ningn protocolo por ser nuestro proveedor de servicio. Entonces
como alcanzamos las redes remotas; vamos a configurar dos rutas estticas, que sern las IPs
principales de cada red.
PRINCIPAL(config)# ip route 172.16.0.0 255.255.254.0 Serial0/0
PRINCIPAL(config)# ip route 192.168.1.0 255.255.255.0 Serial0/0
PRINCIPAL(config)# ip route 10.0.0.0 255.255.255.248 Serial0/0
Paso 5: Configuracin del ancho de banda
El cambio del ancho de banda solo se configura en el enlace serial, y se debe configurar los dos
extremos con el mismo ancho de banda como veremos a continuacin:

71

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

De R1 a PRINCIPAL:
R1#configure terminal
R1(config)#interface serial 0/0
R1(config-if)# bandwidth 64
De PRINCIPAL a R1:
PRINCIPAL#configure terminal
PRINCIPAL(config)#interface serial 0/0
PRINCIPAL(config-if)# bandwidth 64
De R1 a R2:
R1#configure terminal
R1(config)#interface serial 0/1
R1(config-if)# bandwidth 256
De R2 a R1:
R2#configure terminal
R2(config)#interface serial 0/1
R2(config-if)# bandwidth 256
De R2 a PRINCIPAL:
R2#configure terminal
R2(config)#interface serial 0/0
R2(config-if)# bandwidth 128
De PRINCIPAL a R2:
R2#configure terminal
R2(config)#interface serial 0/1
R2(config-if)# bandwidth 128
Tabla de enrutamiento de R1
R1#show ip route
<omitido>
Gateway of last resort is 10.0.0.10 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
O
172.16.1.128/26 [110/391] via 10.0.0.10, 00:22:29, Serial0/1
O
172.16.0.0/24 [110/400] via 10.0.0.10, 00:22:29, Serial0/1
O
172.16.1.0/25 [110/400] via 10.0.0.10, 00:22:29, Serial0/1
10.0.0.0/30 is subnetted, 3 subnets
C
10.0.0.8 is directly connected, Serial0/1
C
10.0.0.0 is directly connected, Serial0/0
O
10.0.0.4 [110/1171] via 10.0.0.10, 00:22:29, Serial0/1
192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks
C
192.168.1.0/25 is directly connected, FastEthernet0/0
C
192.168.1.192/27 is directly connected, FastEthernet1/0
C
192.168.1.128/26 is directly connected, FastEthernet0/1
O*E2 0.0.0.0/0 [110/1] via 10.0.0.10, 00:22:29, Serial0/1
72

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento de PRINCIPAL


PRINCIPAL#show ip route
<omitido>
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
200.165.100.0/30 is subnetted, 1 subnets
C
200.165.100.0 is directly connected, Serial0/2
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
O
172.16.1.128/26 [110/782] via 10.0.0.6, 00:29:41, Serial0/1
O
172.16.0.0/24 [110/791] via 10.0.0.6, 00:29:41, Serial0/1
O
172.16.1.0/25 [110/791] via 10.0.0.6, 00:29:41, Serial0/1
10.0.0.0/30 is subnetted, 3 subnets
O
10.0.0.8 [110/1171] via 10.0.0.6, 00:29:41, Serial0/1
C
10.0.0.0 is directly connected, Serial0/0
C
10.0.0.4 is directly connected, Serial0/1
192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks
O
192.168.1.0/25 [110/1181] via 10.0.0.6, 00:29:41, Serial0/1
O
192.168.1.192/27 [110/1172] via 10.0.0.6, 00:29:41, Serial0/1
O
192.168.1.128/26 [110/1181] via 10.0.0.6, 00:29:42, Serial0/1
S* 0.0.0.0/0 is directly connected, Serial0/2

Tabla de enrutamiento de R2
R2#show ip route
<omitido>
Gateway of last resort is 10.0.0.5 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C
172.16.1.128/26 is directly connected, FastEthernet1/0
C
172.16.0.0/24 is directly connected, FastEthernet0/0
C
172.16.1.0/25 is directly connected, FastEthernet0/1
10.0.0.0/30 is subnetted, 3 subnets
C
10.0.0.8 is directly connected, Serial0/1
O
10.0.0.0 [110/1952] via 10.0.0.9, 00:35:24, Serial0/1
C
10.0.0.4 is directly connected, Serial0/0
192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks
O
192.168.1.0/25 [110/400] via 10.0.0.9, 00:35:25, Serial0/1
O
192.168.1.192/27 [110/391] via 10.0.0.9, 00:35:25, Serial0/1
O
192.168.1.128/26 [110/400] via 10.0.0.9, 00:35:25, Serial0/1
O*E2 0.0.0.0/0 [110/1] via 10.0.0.5, 00:35:25, Serial0/0

73

Sistema a Distancia

Telemtica II - Unidad V

Rubn Cueva Ziga

Tabla de enrutamiento de ISP


ISP#show ip route
<omitido>
Gateway of last resort is not set

C
C
S
S
S

200.165.200.0/30 is subnetted, 1 subnets


200.165.200.0 is directly connected, FastEthernet0/0
200.165.100.0/30 is subnetted, 1 subnets
200.165.100.0 is directly connected, Serial0/0
172.16.0.0/22 is subnetted, 1 subnets
172.16.0.0 is directly connected, Serial0/0
10.0.0.0/29 is subnetted, 1 subnets
10.0.0.0 is directly connected, Serial0/0
192.168.1.0/24 is directly connected, Serial0/0

74

Sistema a Distancia