Sie sind auf Seite 1von 9

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

IPv6 Over MPLS


We can implement ipv6 over mpls in two different ways: 6PE or 6VPE
6PE (without vrf or VPNv4 af)
The Cisco implementation of IPv6 provider edge router over MPLS is called 6PE, and it enables IPv6 sites
to communicate with each other over an MPLS IPv4 core network using MPLS label switched paths
(LSPs).
6VPE (with vrf)
This is Cisco implementation of IPv6 provider edge router over MPLS VPN is called 6VPE , and it enables
IPv6 vrf sites to communicate with each other over an MPLS VPN IPv4 core network
In both solutions P routers doesnt need to run IPV6
6PE Lab

Frist Lest Create assign IPv4/IPv6 address


P1
int f0/0
ip add 10.1.1.1 255.255.255.0
no sh
int f0/1
ip add 10.2.2.1 255.255.255.0
no sh
int loop0
ip add 1.1.1.1 255.255.255.255

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

PE1
ipv6 uni
int f0/0
ip add 10.1.1.100 255.255.255.0
no sh
int s1/1
ip add 100.100.100.100 255.255.255.0
ipv6 add 2001:100:100:100::100/64
ipv6 add fe80::1 link-local
no sh
int loop 0
ip add 11.11.11.11 255.255.255.255
PE2
ipv6 uni
int f0/1
ip add 10.2.2.2 255.255.255.0
no sh
int s1/1
ip add 200.200.200.200 255.255.255.0
ipv6 add 2001:200:200:200::200/64
ipv6 add fe80::3 link-local
no sh
int loop 0
ip add 22.22.22.22 255.255.255.255
CE-1-A
ipv6 uni
int s1/1
ipv6 add 2001:100:100:100::11A/64
ipv6 add fe80::11 link-local
no sh
int loop 0
ipv6 add 2001:bad:bad:dad::1/128
CE-1-B
ipv6 uni
int s1/1
ipv6 add 2001:200:200:200::21B/64
ipv6 add fe80::33 link-local
no sh
int loop 0
ipv6 add 2001:bad:bad:cad::1/128

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

Second Lets Have IGP between P1,PE1,PE2 , I will use OSPFv2


P1
router ospf 100
int f0/0
ip ospf 100 area 0
int f0/1
ip ospf 100 area 0
int loop 0
ip ospf 100 area 0
PE1
router ospf 100
int f0/0
ip ospf 100 area 0
int loop 0
ip ospf 100 area 0
PE2
router ospf 100
int f0/1
ip ospf 100 area 0
int loop 0
ip ospf 100 area 0
Third lets create mpls connectivity between PE1 & PE2
PE1
router bgp 123
no bgp def ipv4
nei 22.22.22.22 remote-as 123
nei 22.22.22.22 update loop0
add ipv6
nei 22.22.22.22 act
PE2
router bgp 123
no bgp def ipv4
nei 11.11.11.11 remote-as 123
nei 11.11.11.11 update loop0
add ipv6
nei 11.11.11.11 act
P1
mpls label prot ldp
mpls label range 500 599
mpls ldp router-id loop0 f
int f0/0
mpls ip
int f0/1
mpls ip

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

PE1
mpls label prot ldp
mpls label range 100 199
mpls ldp router-id loop0 f
int f0/0
mpls ip
PE2
mpls label prot ldp
mpls label range 200 299
mpls ldp router-id loop0 f
int f0/1
mpls ip
Fourth lets create connection between CE-1-A & CE-1-B through MPLS
PE1
router bgp 123
add ipv6
network 2001:100:100:100::/64
nei 22.22.22.22 send-label < to let bgpv4 send label for ipv6
PE2
router bgp 123
add ipv6
network 2001:200:200:200::/64
nei 11.11.11.11 send-label
NOW we configure CE1 CE2 using BGP with PE1 PE2( we can use static route or IGP instead)
CE-1-A
router bgp 1
bgp router-id 9.9.9.9
no bgp def ipv4
nei 2001:100:100:100::100 remote-as 123
add ipv6
network 2001:bad:bad:dad::1/128
nei 2001:100:100:100::100 act
PE1
router bgp 123
no bgp def ipv4
nei 2001:100:100:100::11A remote-as 1
add ipv6
nei 2001:100:100:100::11A act

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

CE-1-B
router bgp 2
bgp router-id 99.99.99.99
no bgp def ipv4
nei 2001:200:200:200::200 remote-as 123
add ipv6
network 2001:bad:bad:cad::1/128
nei 2001:200:200:200::200 act
PE2
router bgp 123
no bgp def ipv4
nei 2001:200:200:200::21B remote-as 2
add ipv6
nei 2001:200:200:200::21B act
CE-1-A#sh bgp ipv6 un
BGP table version is 5, local router ID is 9.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network
Next Hop
Metric LocPrf Weight Path
r> 2001:100:100:100::/64
2001:100:100:100::100
0
0 123 i
*> 2001:200:200:200::/64
2001:100:100:100::100
0 123 i
*> 2001:BAD:BAD:CAD::1/128
2001:100:100:100::100
0 123 2 i
*> 2001:BAD:BAD:DAD::1/128
::
0
32768 i
CE-1-A#
CE-1-A#ping 2001:BAD:BAD:CAD::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:BAD:BAD:CAD::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 308/392/588 ms

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

6VPE Lab
Same Topology we used in 6PE
Following steps are the same as 6PE:
Frist Lets assigns IPv4/IPv6 address
Second Lets Have IGP between P1,PE1,PE2 , I will use OSPFv2
Third lets create mpls connectivity between PE1 & PE2
Fourth lets create connection between CE-1-A & CE-1-B through MPLS using vrf for ipv6
I will make Both CE in same AS# so we will need later to add as-override
Then we configure CE1 CE2 using BGP with PE1 PE2
PE1
vrf definition cbtme
rd 1:1
add ipv6
route-target both
add ipv4
route-target both
int s1/1
vrf forwarding cbtme
ip add 100.100.100.100 255.255.255.0
ipv6 add 2001:100:100:100::100/64
ipv6 add fe80::1 link-local
PE2
vrf definition cbtme
rd 1:2
add ipv6
route-target both
add ipv4
route-target both
int s1/1
vrf forwarding cbtme
ip add 200.200.200.200 255.255.255.0
ipv6 add 2001:200:200:200::200/64
ipv6 add fe80::3 link-local
CE-1-A
router bgp 1
bgp router-id 9.9.9.9
no bgp def ipv4
nei 2001:100:100:100::100 remote-as 123
add ipv6
network 2001:bad:bad:dad::1/128
nei 2001:100:100:100::100 act

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

PE1
router bgp 123
no bgp def ipv4
add ipv6 vrf cbtme
nei 2001:100:100:100::11A remote-as 1
nei 2001:100:100:100::11A as-override
CE-1-B
router bgp 1
bgp router-id 99.99.99.99
no bgp def ipv4
nei 2001:200:200:200::200 remote-as 123
add ipv6
network 2001:bad:bad:cad::1/128
nei 2001:200:200:200::200 act
PE2
router bgp 123
no bgp def ipv4
add ipv6 vrf cbtme
nei 2001:200:200:200::21B remote-as 1
nei 2001:200:200:200::21B as-override
CE-1-A#sh bgp ipv6 un
BGP table version is 5, local router ID is 9.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network
Next Hop
Metric LocPrf Weight Path
r> 2001:100:100:100::/64
2001:100:100:100::100
0
0 123 i
*> 2001:200:200:200::/64
2001:100:100:100::100
0 123 i
*> 2001:BAD:BAD:CAD::1/128
2001:100:100:100::100
0 123 2 i
*> 2001:BAD:BAD:DAD::1/128
::
0
32768 i
CE-1-A#ping 2001:BAD:BAD:CAD::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:BAD:BAD:CAD::1, timeout is 2 seconds:
!!!!!
7

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

6PE Notes :
Cisco 6PEThe 2 Magic Commands
Essentially, one new command is added to advertise the "IPv6+label" capability and to start 6PE
operations.
In address-family IPv6 configuration mode, specify that "IPv6+label" capability is advertised to a
neighbor:
router(config-router-af)#neighbor <ip-address> send-label
An additional command is added in global configuration mode, to specify the interface to take source
address from, for self-generated packets:
router(config)#mpls ipv6 source-interface <interface>
6VPE Notes:
Notice in PE1 & PE2 we did not used ip vrf command , instead we use vrf definition :
vrf definition cbtme
rd 1:1
add ipv6
route-target both
add ipv4
route-target both
careful here if you have ipv4 vrf with its own route-targets , you will need to add in address-family ipv4
under vrf definition , you can not use ip vrf and vrf definition on the same time.
Also notice under interface we did not used ip vrf forwarding but we used instead vrf forwarding
int s1/1
vrf forwarding cbtme

Resources :
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/configuration/15-2mt/ipv6-15-2mt-book/ip6over-mpls.html
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/configuration/15-2mt/ipv6-15-2mt-book/ip6ov-mpls-6vpe.html

Good Luck
CCSI: Yasser Auda
https://www.facebook.com/YasserRamzyAuda
https://learningnetwork.cisco.com/people/yasser.r.a?view=documents
https://www.youtube.com/user/yasserramzyauda

CCIEv5 IPv6 Over MPLS (6PE/6VPE)

By CCSI: Yasser Auda

Das könnte Ihnen auch gefallen