Sie sind auf Seite 1von 20

Operating System

Aix Basic commands to work with SAP


Hi Guys,
I hope this basic AIX commands will help you work with sap.

ls -l -> listing directory & files


chmod -> Changing the directory or file permission(rwx)
chown -> changing the directory or file ownership
mkdir -> create directory
rmdir -> remove directory
touch -> create file
rm -> remove file
Note: use man page for more details about each command {man }
***************************************
ps -> Managing the process ( ps -ef | grep -i )
kill -> terminate the process (kill -9 )
******************************************************
To Display if the hardware is 32bit or 64bit
bootinfo -y
To see if you're running with a 32 bit or 64 bit kernel,
bootinfo -k
To identify the memory size:
lsattr -El sys0 -a realmem
To Display number of processor on system:
lscfg | grep proc
Displays the system name, nodename, version, machine ID.
uname -a
version, release, and maintenance level of AIX is running on my system
oselvel -r
To get ipaddress of my machine
ifconfig -a
*****************************************
Working with services:

lssrc -a
refresh
startsrc
stopsrc
*****************************************
Basic Logical volume command:
lsvg --> list volume group
lsvg --> Detail report of particule VG
lsvg -l --> list logical volume(lv) for particular vg
lslv --> Detail report of lv
lsvg -p --> Display the hardisk included in particular vg
lspv --> List all the physical disk
chfs -a size=+1G --> increase the file system

Cluster Basic :

Determine the cluster name and networks


/usr/es/sbin/cluster/utilities/cltopinfo
Cluster Service status
/usr/es/sbin/cluster/utilities/clshowsrv -v
/usr/es/sbin/cluster/utilities/cldump

To identify the volume group which comes under cluster


1.) smitty hacmp
2.) logical volume managment
3.) shared vg
4.) list shared vg
***********************************************************************

"
&! '
!

###$%
&(

&
'

"
*!
!

"

"
+

!
'

&

&
,

,
"

/
"
1

1
,
4* 3 8

"

"
2345 )4
* 62
, ", " &

1
"7

" 6&

,
,

,
,

"

"

&
$
"
5
"
5
"
" ,
"
:; ) "
:< ) "
9
"
5
5$>?@=#%
$

&

9 $55 )
, ,
"

$55
5
"

$55
=5
,

>?>

>

$
>+

8*4BC D
,
-

"

9 $55

"

9
5

9
4
4

5
5
,

$E@&?=&=>&$
$E=&#5&#5&$
,

>==&>==&>==&5
"
/

C-3

"
"
"
$E@&#5&FE&5 $E@&#5&E5&@

&

5 "

&
9

"

9$G
&
)

&

8&H&)&
!
!
!

!
*!

I
J

, , !
!
8H)
8H)

)
DJK)
3D)L)
1
1

,
"

KC

&

@&!

, & 1
, 5

?&!

< 0*
M

&, ,
M
K C *)4C *

'
',

M
N
N

G
N,

N,

,
,

5G
5 G.

,.G
&

G
G

< 0*

,
,
*)4C *

5 G,

!
!
!
! ,

,.G

5G

, 5G
< 0*

&

M"
"
,
"

O
5

"
"

&
M"

"

&

5 ,
*)4C *

5 G,

O4
O !
O !

CKL 82 - )D*44*)
9,
, 5 9
9
9,
CKL 82 4 K*)
9,
9

" 9?#"
, 5 " 9?#"

9
9,

0
+ ,!!!, ,, ,
I
)
:3
4

"
,, I

&

"

"

"

&
"
;

&
-*0 *)

!!!
'

"
;

&

"
"
"

4
, " $5>@
1
,

7
>?

&

K
K

"
"

5
*<
*<

9
9F5

"

"

5
"
-

) )
K

3
-

/
"

"

&

5J
5

K
K

3
3

4 K* - 0*)
5&!
9
9
9

!9 P P
59
@9
59
>9
59
$9
8 )
" 8 )

5 "
@
9 $5>@/ F
$5>@
"
59

8
"

*7
)
6 1 9=$>
9
" "

"

$9

=$> "

"
88C4 "

<

&

K 84 QJ*J*)
!
O
O
O
O
O

A K-*)49G O
,
R7 "8
R7 "8 K
R7 "8
)
7 "
! 7 "8
7 "8

G)

O
"

&
O

7 "
O
7 "

7 "

&

O J
"
O "

KO
O
KO
O

"

"

O
O

O
O

R7 "8
O

7 "

O
)

"

"
"

H * )L)4*3)
K

K0I

K0
9

&
&
"

&

"
"
3
K0I
0

"
2

L*)
8C
0I
&

K0

K0/ "

02I

C
H
0
02/ "
0/
0
C
4
KK 1
@

02
"
02- / 0

!
!
8
+
"
"
"
O

"

"

C-3&

K0 "

& 0
,C&

K0 -

02-

&
K0
*!
!
!

02&
S

02
02& *!

&
0
-

&
&
&

"
4

Q ,
0

"

02
, Q

"

55

&
&

0I

0
8

KKI

KKI
!

!
, !
9
9

KKI

9 KK
9

9
9

"

&

"

S
7
TH)
,
,
H)I

KKI
&
0

8
TH)

O
3
3
,

5,

7
B
, ,

/
! &
7

1 9

B
&
,

&B
! &

1 9

&
O

&
&
-

&

/
K

"
O

B
"

"

"

&

3
>

KKI

K0 8

&
>

?
&4

3J)4 "

S
$

>
1

&

3
&8

"

CC4 C2
"
"
"
"
"

0C J3*

&

0
"
"

"
)
"
"
"

"

"
"

,
,

"

,
,

(
)

&

"

&
C-3

"

&

)L)4*3 -J3K
&
*
)
)

"
&

"

&
&
K)

+
G

GM

K 2 82 )K

8
8
8

@3 "
@3 "
4
@3 "

&

"

"

"
,

"

) <*-J 82
"

&5

&

+8
G"

* K)I

& K)
8

&

"

!G "

"
, " , &"
, #& L
" &

&

"
"
"
"
"
,
,
,

,
,
,

U 4

"
C

"

*
,
,
,
,
,
,
P>

"
"
H
H

&
&

"/ $?+5=/
U

"
"

&
"
"

&
&

"
U
V

V)

&

7 "

-V

,
,
,

*
'

7 "
7 "8
7 "8
,
, &
H
,
, &
H
,
, 7 " -

,
,
,

7 "

&
&
&
&

)* J 4L
"
)
"
B
"

@
@
@

! !
MMM MMM MMM
MMM
C
)

,
@ )J - P > )2 - P $ )04
P >
P $ !
P >
P $ !
P >
P $ !
!
! ! !
! ! !

2
C
! ! 9 )J -

! 9 )2 -

9 )04

,
,
"
%
% "9
%
9

5>> 9
!
!
'
&!

!
%== 9

&!

"

"

J)* )
-

"

I
-

&
-

"

"

&
-

"
"

"

"

"
"

"
9
&
-

"

"

*3C4* J)* )

H)
K)
)
HK-

, ,
, ,
&
, ,
& O
, ,
, ,
&
, ,
& O
, ,
, ,
&
, ,
& O
, ,
, ,
&
, ,
& O

8 44
))
>)
"
"

&
&
$

"
$

"

"

" G
G
" G
G
"
" G $+>+

"
!

"

$
+,

," ,

"
,

&
$G

C-3
OG
OG

9 $G
$G
OG
9 $G

OG
N $&
*

,
,
,

, ",
, ",
, ",
-

- M
2
M
2
9 $G ' $&
C-3

$
$
$
*!

C-3
!
&

"

&

&

&

&
&

&
-

&

<9<

)9)

C9
&

09J

&
&

C22 82

7
8

"
"
"&

&

+4

"
&4
G

>?5

5&

&

K* HC 3 8 * 3C8 4C 82
&
5 = >5
-

"
"
"

&
&
"

&
,

&

5 = >5
&
&
-C) - )D*44*)

-,
-,
-,
H

, 5 @$&4 4 @$& ! 2
@$&4 4
, 5 - * 4C L, @$&4 4 @$& !
"
5
, 5
!
B
-

)*8-3
"

"

O-

&

O
OK

8CB

<3
"

A<C)4

A8H)-

................................................................................................................
..
COMMAND

PARAMETER

DESCRIPTION

bootlist

-m normal <dev1>
<dev2>

Alters the list of boot devices (or the ordering of


these devices in the list available to the system)

bosboot

-a-ad /dev/rnt<x>
-b <loc of bootimage>

Create a boot image on the default boot


device Create a boot image at location and send to
tape

cfgmgr

Configures devices by running the programs in


/etc/methods directory.

chcons

Redirects the system console to device or file,


effective next startup

chdev

-l <device>
-a<params>

Changes a device's characteristics.

chdisp

Changes the display used by the low-function


terminal (LFT subsystem.

chfont

Changes the default font selected at boot time.

chfs

-a size=+<blocks>
/<FS>

Changes attributes of a file system. This one will


increase the Filesystem .

chgroup

Users=x,y,z <grp
name>

Changes attributes for groups.

chlv

-n <nlvname>
<olvname>

Rename logical volume from olvname to nlvname

chps

-s<no. pps> <ps


name>

chpv

chque

Changes the characteristics of a physical volume in


a volume group.
-q<q name> -ahost =
x

Changes the queue name.

chssys

Changes a subsystem definition in the subsystem


object class.

chtcb

Changes or queries the trusted computing base


attribute of a file.

chtz.

Changes the system time zone information

chuser

rlogin=true
<username>

Changes attributes for the specified user.

chvfs

Changes entries in the /etc/vfs file.

chvg

Sets the characteristics of a volume group.

crfs

-v <fstype> (jfs)-d
<lvname>
-m <mount point>
-Ayes

Create a Filesystem on a pre-defined logical


volume( which will automount at boot!)

crfs

-v <fstype> (jfs)-g
<vgname>
-a size=<no blocks>
-m <mount point>
-Ayes

Create a Filesystem and its logical volume (uses


default lvname)

crvfs

Creates entries in the /etc/vfs file.

exportvg

None

Export a volume group

grpck

-n ALL

Verifies the correctness of a group definition.

hvirprt
importvg

Changes attributes of a paging space.

Changes the attribute values of a virtual printer.


-y <vgname><hdisk
x>

Import a Volume Group onto hdisk x

lpstat

List print queues

lsallq

Lists the names of all configured queues.

lsallqdev

Lists all configured printer and plotter queue device


names within a specified queue.

lsattr

-El <devname>

lscfg

lsdev

List all configured devices


-v

List in detail

-l scsi*

List all scsi IO devices

-Cc tape

List configured tape devices

-Cc disk

List configured disks on devices

-C -s scsi -H

List all defined scsi devices

lsdisp

Lists the displays currently available on the system.

lsfont

Lists the fonts available for use by the display.

lsfs

-l

lsfs

"

List detailed configuration for a device

List all filesystems in /etc/filesystems quering the


LVM descriptor area and superblocks
Displays the characteristics of file systems.

lsgroup

ALL

Displays the attributes of groups.(checks NIS


aswell!)

lsitab

-a

Lists the records in the /etc/inittab file.

lskbd

Lists the keyboard maps currently available to the


low-function terminal (LFT subsystem.

lslicense

Displays the number of fixed licenses and the


status of floating licensing.

lslpp

-l

List all installed software

lslv

<lvname>

List configuration details of a given Logical Volume

-l <lvname>

List further configuration details of a given disk

lsprtsv

-ch

Shows print service information stored in the


database.

lsps

-a

List pagaing space

lspv

None

List configured disks

<hdisk>

List configuration details of a given disk

-l <hdisk>

List Logical Volumes/Filesystems on a given disk

lsque

Displays the queue stanza name.

lsquedev

Displays the device stanza name.

lssrc

-a

List all subsystems

lsuser

Displays attributes of user accounts.

lsvfs

Lists entries in the /etc/vfs file.

lsvg

None

List configured Volume groups

<vgname>

List configuration details of a given Volume group

-l <vgname>

List Logical Volumes/Filesystems on a given


Volume Group

mkcatdefs

Preprocesses a message source file.

mkdev

Adds a device to the system.

mkfont

Adds the font code associated with a display to the


system.

mkfontdir

Creates a fonts.dir file from a directory of font files.

mkgroup

Creates a new group.

mkitab

Makes records in the /etc/inittab file.

mklv

Create a Logical Volume

mklv

Creates a logical volume.

mklvcopy

Adds copies to a logical volume.

mknamsv

Configures TCP/IP-based name service on a host


for a client.

mknotify

Adds a notify method definition to the notify object


class.

mkprtsv

Configures TCP/IP-based print service on a host.

mkps

Add an additional paging space to the system.

mkque

Adds a printer queue to the system.

mkquedev

Adds a printer queue device to the system.

mkserver

Adds a subserver definition to the subserver object


class.

mkssys

Adds a subsystem definition to the subsystem


object class.

mksysb.

Backs up mounted file systems in the rootvg


volume group for subsequent reinstallation

mkszfile.

Records size of mounted file systems in the rootvg


volume group for reinstallation

mktcpip

Sets the required values for starting TCP/IP on a


host.

mkuser

Creates a new user account.

mkuser.sys

Customizes a new user account.

Mkvg

-y <lvname>
<vgname>
<no of pps>

-y <vgname> -s
<ppsize>
<hdisk x>

Create a Volume Group on hdisk x

mkvg

Creates a volume group.

mkvirprt

Makes a virtual printer.

odmadd

Adds objects to created object classes.

odmchange

Changes the contents of a selected object in the


specified object class.

odmcreate

Produces the .c (source and .h (include files


necessary for ODM application development and
creates empty objectclasses.

odmdelete

Deletes selected objects from a specified object


class.

odmdrop

Removes an object class.

odmget

Retrieves objects from the specified object classes


and places them into an odmadd input file.

odmshow

Displays an object class definition on the screen.

pwdck

Verifies the correctness of local authentication


information.

redefinevg

Redefines the set of physical volumes of the given


volume group in the device configuration database.

reducevg

Removes physical volumes from a volume group.


When all physical volumes are removed from the
volume group, the volume group is deleted.

reorgvg

Reorganizes the physical partition allocation for a


volume group.

restbase

Restores customized information from the boot


image.

rmdel

Removes a delta from a Source Code Control


System (SCCS file.

rmdev

Removes a device from the system.

rmf

Removes folders and the messages they contain.

rmfs

Removes a file system.

rmgroup

Removes a group.

rmitab

Removes records in the /etc/inittab file.

rmlv

Removes logical volumes from a volume group.

rmlvcopy

Removes copies from a logical volume.

rmm

Removes messages.

rmnamsv

Unconfigures TCP/IP-based name service on a


host.

rmnotify

Removes a notify method definition from the notify


object class.

rmprtsv

Unconfigures a print service on a client or server


machine.

rmps

Removes a paging space from the system.

rmque

Removes a printer queue from the system.

rmquedev

Removes a printer or plotter queue device from the


system.

rmserver

Removes a subserver definition from the subserver


object class.

rmssys

Removes a subsystem definition from the


subsystem object class.

rmuser

Removes a user account.

rmvfs

Removes entries in the /etc/vfs file.

rmvirprt

Removes a virtual printer.

runcat

Pipes the output data from the mkcatdefs command


to the gencat command.

savebase

Saves base customized device data in the ODM


onto the boot device.

startsrc

-s <subsystem>

Start a subsystem

stopsrc

-s <subsystem>

Stop a subsystem

syncvg

Synchronizes logical volume copies that are not


current.

usrck

Verifies the correctness of a user definition.

varyoffvg

<vgname>

varyoffvg
varyonvg
varyonvg

Takes a Volume Group offline


Deactivates a volume group.

<vgname>

Puts a Volume Group online


Activates a volume group.

Das könnte Ihnen auch gefallen