Sie sind auf Seite 1von 51

RIP Version 1 (RIPv1)

To configure RIP routing turn on the protocol with the router rip command and tell it which
networks to advertise.

RIP routing example

RouterA Configuration

RIP has an administrative distance of 120. Static routes have an administrative distance of 1 by
default and since we currently have static routes configured the routing tables wont be
propagated with RIP information. So the first thing we need to do is delete the static routes off
each router.

This is done with the no ip route command

RouterA(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2


RouterA(config)#no ip route 192.168.40.0 255.255.255.0 192.168.20.2
RouterA(config)#no ip route 192.168.50.0 255.255.255.0 192.168.20.2

Once the static routes are deleted we can add RIP1 using the router rip command and the
network command. In our router configuration we have to type every directly connected network
that RIP will advertise leaving out networks 30, 40 and 50 because its RIP’s job to find them and
populate the routing table.

RouterA(config)#router rip
RouterA(config-router)#network 192.168.10.0
RouterA(config-router)#network 192.168.20.0
RouterA(config-router)# ^Z
RouterA
That’s it just a few commands easier than static routes! But remember the extra cpu and
bandwidth you will consume.

RIP, RIPv2, and IGRP use classful addresses when they configure the network address because
of this all subnet masks must be the same on all devices in the network classful routing.

To clarify this say your using a class B network address of 172.16.0.0/24 with subnets
172.16.10.0, 172.16.20.0, and 172.16.30.0, In this case you would type in only the classful
network address of 172.16.0.0 and let RIP, RIPv2 and IGRP find the subnets for the routing table.

RIPv1 uses only classful routing which means that all devices in the network must use the same
subnet mask. This is because RIPv1 doesn’t send updates with subnet mask information. RIPv2
provides prefix routing and does send subnet mask info with the route updates. This is called
classless routing.

Configuring RIP
To configure RIP routing

enable
config t
Router(config)#router rip
now add all directly connected networks using a classful address
ie if network 10.1.1.0 is directly connected the command would be network 10.0.0.0

Router(config-router)#network 10.0.0.0
Router(config-router)# ˆZ
Router#
The Routing Information Protocol (RIP) is an old but commonly used IGP created for use in small,
networks. It is a classical distance-vector routing protocol.

The metric that RIP uses to rate the value of different routes is the hop count. The hop count is
the number of routers that can be traversed in a route. A directly connected network has a metric
of zero, an unreachable network has a metric of 16. This small range of metrics makes RIP
unsuitable as a routing protocol for large networks. If the router has a default network path, RIP
advertises a route that links the router to the pseudonetwork 0.0.0.0. The network 0.0.0.0 does
not exist; RIP treats 0.0.0.0 as a network to implement the default routing feature.

To configure RIP, perform the following tasks, starting in global configuration mode:

RouterB Configuration

To configure RIP on RouterB we need to remove the two static routes once there are no routes in
the routing table with a better administrative distance than 120, we can add RIP. RouterB has 3
directly connected networks and we want RIP to advertise them all.

RouterB#config t
RouterB(config)#no ip route 192.168.10.0 255.255.255.0 192.168.20.1
RouterB(config)#no ip route 192.168.50.0 255.255.255.0 192.168.40.2
RouterB(config)#router rip
RouterB(config-router)#network 192.168.20.0
RouterB(config-router)#network 192.168.30.0
RouterB(config-router)#network 192.168.40.0
RouterB(config-router)# ˆZ
RouterB#

RouterC Configuration

We’ve already removed the static routes on RouterC as we placed a default route on it. So we
need to remove the default route from RouterC. Once it’s gone we can turn on RIP routing for the
two directly connected routes.

RouterC#config t
RouterC(config)#no ip route 0.0.0.0 0.0.0.0 192.168.40.1
RouterC(config)#router rip
RouterC(config-router)#network 192.168.40.0
RouterC(config-router)#network 192.168.50.0
RouterC(config-router)# ˆZ
RouterC#
It’s important to remember directly connected routes have an administrative distance of 0, static
routes have an administrative distance of 1 and RIP has an administrative distance of 120.

Verifying the RIP Routing Tables

show ip route, do show route


This output shows RouterA’s routing table.

RouterA#show ip route
Codes: C – connected etc…

R 192.168.50.0 [120/2] via 192.168.20.2 00:00:23 serial0/0


R 192.168.40.0 [120/1] via 192.168.20.2 00:00:23 serial0/0
R 192.168.30.0 [120/1] via 192.168.20.2 00:00:23 serial0/0
C 192.168.20.0 is directly connected, serial0/0
C 192.168.10.0 is directly connected, FastEthernet0/0
RouterA#

R means networks were added dynamically using RIP. The [120/1] is the administrative distance
of the route (120) and the number of hops to the remote network.

The do command

Starting with IOS v12.3, Cisco added a command that allows us to run configuration stats from
within configuration mode (previously they were run in privileged mode)

If you had run tried a show run on a pre-12.3 router from global config we would have got an error

Router(config)#show run
^
% Invalid input detected at ‘^’ marker

But now we can use do show ip route

RouterB#show ip route
Codes: C – connected etc…

R 192.168.50.0 [120/2] via 172.16.40.2 00:00:11 serial0/1


C 192.168.40.0 is directly connected, serial0/1
C 192.168.30.0 is directly connected, FastEthernet0/0
C 192.168.20.0 is directly connected, serial0/0
R 192.168.10.0 [120/1] via 172.16.20.1, 00:00:21, serial0/0
RouterB#

RouterC#show ip route
Codes: C – connected etc…
Gateway of last resort is not set

C 192.168.50.0 is directly connected, FastEthernet0/0


C 192.168.40.0 is directly connected, serial0/0
R 192.168.30.0 [120/1] via 192.168.40.1, 00:00:04, serial0/0
R 192.168.20.0 [120/1] via 192.168.40.1, 00:00:26, serial0/0
R 192.168.10.0 [120/1] via 192.168.40.1, 00:00:21, serial0/0
RouterC#

Another show ip route example


The Problem with RIP!

So RIP has worked really well in our little internetwork its not an enterprise solution because it
has a maximum hop count of only 15 (16 is deemed unreachable) and it performs full routing
table updates every 30 seconds which would wreak havoc in a larger network!

If the routing table had showed [120/15] this means the administrative distance is 120 but the hop
count is 15 remember each time a router receives an update from another router it increments the
hop count by one for each route.

R 192.168.10.0 [120/15] via 192.168.40.1, 00:00:21, serial0/0

So [120/15] is really bad because the next router that receives the table from the router will just
discard the route to the network 192.168.10.0 because the next count would be 16 which is
invalid.

Configuring RIP using the SDM

From routing Edit

Select RIP the network number and tick the interfaces you don’t want RIP to be broadcast out of.
These are called passive interfaces
RIP Example

Configure Router A, use the network ID of 192.168.164.0/28. The s0/0 interface of Router A will
use the last available IP address in the 8th subnet and fa0/0 will use the last available IP address
in the 2nd subnet. Do not consider the zero subnet valid.
Answer

/28 = 255.255.255.240 mask


256 – 240 = 16 block size in the 4th octet
Since we have a block size of 16 our subnets are: (not starting at subnet zero)
16, 32, 48, 64, 80, 96,112,128,144 etc…
The 8th subnet for the s0/0 interface is subnet 128
Valid host range is 129 – 142, 143 is the broadcast address
The 2nd subnet fa0/0 = subnet 32
Valid hosts 33 – 46, 47 as broadcast

Configuration on Router A will be

RouterA(config)#interface s0/0
RouterA(config-if)#ip address 192.168.164.142 255.255.255.240
RouterA(config-if)#no shutdown
RouterA(config-if)#interface fa0/0
RouterA(config-if)#ip address 192.168.164.46 255.255.255.240
RouterA(config-if)#no shutdown
RouterA(config-if)#router rip
RouterA(config-router)#network 192.168.164.0
RouterA(config-router)#^Z
RouterA#

Here we added 2 subnets to the Router A router using a singe classful network statement under
RIP.

RIP Timers

Route update timer Sets the interval (30s) between periodic routing updates in which the router
sends a complete copy of its routing table out to all neighbors.

Route invalid timer The length of time that must elapse (180s) before a router determines that
the route is invalid when this happens the router will send out updates to all its neighbors letting
them know the route is invalid.

Holddown timer This sets the amount of time during which routing information is suppressed.
Routes will enter into the holddown state when an update packet is received that indicated the
route is reachable. This continues either until an update packet is received with a better metric or
until the holddown timer expires for RIP the default is 180s.

Route flush timer Sets the time between a route becoming invalid and its removal from the
routing table (240s)

Holding down RIP Propergations

You probably don’t want your RIP network advertised everywhere on your LAN/WAN no point in
advertising over the internet. You can stop unwanted RIP updates from propagating across your
LAN/WAN a few ways. The easiest is the passive-interface command. This command
prevents RIP update broadcasts from being sent out an interface, but the same interface
can still receive RIP updates.
RouterA#config t
RouterA(config)#router rip
RouterA(config-router)#network 192.168.10.0
RouterA(config-router)#passive-interface serial 0/0

This command stops RIP updates from being propagated out serial interface 0/0, but serial
interface 0/0 can still receive RIP updates.

Question

If the passive interface command is enabled on the fa0/0 interface of Router E, which statements
are true? (Choose two.)

A. Router E will send all routing updates via interface fa0/0.


B. Router E will ignore all routing updates learned via interface fa0/0.
C. Router E will use routing updates learned via interface fa0/0.
D. Router E will not send routing updates via interface fa0/0.

Answer C, D

Router E will use routing updates learned via interface fa0/0.


Router E will not send routing updates via interface fa0/0.

Question
A technician is configuring a router named RouterLon.
Why does she use passive-interface command?

A. Allows a routing protocol to forward updates out an interface that is missing its IP address.
B. Allows a router to send routing updates on an interface but not receive updates via that
interface.
C. Allows an interface to remain up without receiving keepalives.
D. Allows interfaces to share IP addresses.
E. Allows a router to receive routing updates on an interface but not send updates via that
interface.

Answer E
Explanation
The passive-interface command is used to control the advertisement of routing information. The
command enables the suppression of routing updates over some interfaces while allowing
updates to be exchanged normally over other interfaces.

With most routing protocols, the passive-interface command restricts outgoing advertisements
only. However, when used with Enhanced Interior Gateway Routing Protocol (EIGRP), the effect
is slightly different. The use of the passive-interface command in EIGRP suppresses the
exchange of hello packets between two routers, resulting in the loss of their neighbor relationship.
This stops not only routing updates from being advertised, but it also suppresses incoming
routing updates.

Question
You are concerned about security on your network. You have a router that is connected to the
Internet and do not want your RIP updates being sent out this interface that is connected to the
Internet. Which command will prevent these updates from going out the interface without using
access-lists?

A. Passive routes
B. Default interface
C. Passive interface
D. Route update filtering

Answer C

Explanation
The passive interface command will prevent the sending of RIP updates.

Incorrect Answers
A. Passive routes as used with IGRP and not RIP.
B. Default/static routes will not prevent RIP updates.
D. Filtering is most often achieved on a router with an access list.

Question
You are using a distance-vector routing protocol at your branch office in Idaho. Because you are
using RIP, what can you use to prevent routing loops? (Choose two.)

A. Link-state advertisements (LSAs)


B. Spanning-Tree Protocol
C. A shortest path first tree
D. Split-horizon
E. Hold-down timers

Answers D and E

Split-horizon ensures that updates are not sent back through the interface on which they arrived;
this helps prevent loops.
Hold-down timers prevent incorrect updates from propagating throughout the network.
A is incorrect, as LSAs are used by link-state protocols to announce changes in the network. B is
incorrect, as Spanning-Tree Protocol is used in switched environments, not routing protocols.
C is incorrect because the SPF tree is used to help decide the best path to the destination.

Question
Which of the following can reset a hold-down timer? (Choose three.)
A. When the hold-down timer expires.
B. When infinity is finally defined as some maximum number.
C. When the router exchanges update summaries at area borders.
D. When the router detect faulty LSPs propagating through the internetwork.
E. When another update is received indicating a new route with a better metric.
F. When another update is received indicating the original route to the network has been
restored.
G. When the router receives a processing task proportional to the number of links in the
internetwork.

Answer A, E, F

Explanation
Holddown timers work as follows

When a router receives an update from a neighbor indicating that a previously accessible network
is now in accessible, the router marks the route as inaccessible and starts the holddown timer.
If an update arrives from the neighboring router with a better metric than originally recorded for
the network, the router marks the network as accessible and removes the holddown timer.
If at any time before the holddown timer expires an update is received from a different
neighboring router with a poorer metric, the update is ignored. Ignoring an update with a poorer
metric when the holddown is in effect allows more time for the knowledge to change to propagate
through the network.
During the holddown period, routes appear in the routing table as possible down. Routers remain
in holddown until one of the following events occurs: the holddown expires; another update is
received indicating a new route with a better metric; and a flush timer, which is the time a route
would be held before being removed, removes the route from the routing table.

Incorrect answers
B, C, D and G. None of these situations will remove a holddown timer.

Another RIP example

Configure a simple network with two routers to run RIP. Our network consists of three subnets, 10.0.10.0/24,
10.0.20.0/24, and 10.0.30.0/24, as shown. Our goal is to ultimately have Router A learn about network
10.0.30.0 from Router B, and Router B learn about network 10.0.10.0 from Router A using RIP.

If you’re trying to configure a router to use RIP to exchange routing table information, an important step is to
remove any static routes. If you have a static route defined on Router A that provides information on how to
get to network 10.0.30.0, any information that Router A receives about network 10.0.30.0 via RIP will be
ignored. A static route has an administrative distance of 1, while RIP’s administrative distance is 120. When
a route with a higher administrative distance is received, it is ignored.
The command to turn on RIP routing is simple – from global configuration mode, simply issue the command
router rip, as shown below.

RouterA(config)#router rip

Notice how the prompt changes, the router rip command makes this router capable of sending and receiving
RIP updates. However we have to tell it which network(s) to advertise. In this case, the network we want to
advertise is 10.0.0.0. You don’t need to specify either the subnet mask or specific subnet addresses –
because RIP is classful it will automatically assume that you meant all networks starting with 10. In order to
make RIP announce all of the 10.0.0.0 subnets, enter the network 10.0.0.0 command.

RouterA(config-router)#network 10.0.0.0

That’s literally all it takes to set up RIP. Of course, we’ll also need RIP configured on Router B, which
involves following the same steps.

RouterB(config)#router rip
RouterB(config-router)#network 10.0.0.0

In order to confirm that RIP is properly exchanging information between our routers, let’s take a look at the
routing tables on Router A.

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 3 subnets
C 10.0.10.0 is directly connected, Ethernet0
R 10.0.30.0 [120/1] via 10.0.20.2, 00:00:22, Serial0
C 10.0.20.0 is directly connected, Serial0

Notice in the routing table above that Router A learned about network 10.0.30.0 from RIP, as designated by
the R at the beginning of the entry. The administrative distance is 120, and the number of hops to reach the
network is 1, as designated by the entry [120/1].

Finally, the next-hop address is 10.0.20.2, which is accessible via interface Serial0.
An easy way to test whether RIP is working on both routers is a simple ping. If Router A can successfully
ping IP address 10.0.30.1, it means that Router B also has a route (learned from RIP) back to network
10.0.10.0.

RouterA#ping 10.0.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/38/48 ms

Remember that many routing protocols are also able to load-balance across multiple paths. RIP can load
balance traffic across up to 6 paths, as long as the hop counts to the network in question are equal.
Configuring RIP on a Subinterface

Router2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#interface Ethernet0
Router2(config-if)#ip address 192.168.30.1 255.255.255.0
Router2(config-if)#interface Serial0.1
Router2(config-subif)#ip address 172.25.2.2 255.255.255.0
Router2(config-subif)#exit
Router2(config-router)#router rip
Router2(config-router)#network 172.25.0.0
Router2(config-router)#network 192.168.30.0
Router2(config-router)#end
Router2#

The Serial0.1 interface in this example has an IP address of 172.25.2.2. So, if you want this
interface to take part in RIP route distribution, you just need to include a network statement that
includes its address.

Router2(config)#router rip
Router2(config-router)#network 172.25.0.0

If you have other interfaces that are also part of 172.25.0.0/16 on this router, they will take part in
RIP as well. It's important to note that RIP network statements work with classful network
addresses. Since 172.25.0.0 is a Class B network, the statement network 172.25.0.0 tells the
router to include all interfaces in this range. Note, however, that the other address on this router,
192.168.30.1, is part of the Class C network 192.168.30.0/24, which is why we need the second
network command. If your router has several addresses that belong to different network classes
(for example, 192.168.x.0/24), you have to specify them all separately.

Router2(config)#router rip
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.2.0
Router2(config-router)#network 192.168.3.0
RIP Version 2 (RIPv2

config t
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 10.0.0.0

Just add version 2

RIPv2 unlike RIPv1 is a classless routing protocol (even though it is configured as classful, like
RIPv1 which means that it sends subnet mask information along with the route updates. By
sending subnet mask info with updates, RIPv2 can support Variable Length Subnet Masks
(VLSMs) as well as the summarisation of network boundaries.
In addition RIPv2 can support discontiguous networking.

RouterC(config)#router rip
RouterC(config-router)#version 2
RouterC(config-router)#network 192.168.40.0
RouterC(config-router)#network 192.168.50.0

That’s it just add the command version 2

If two neighboring routers are sending and receiving different versions of RIP, routes will not be
properly exchanged. By default, RIP routers are sending version 1 updates and accepting
version 1 and 2 updates.

Question
Both routers are configured using RIP v1. Both routers are sending updates about the directly
connected routes. R1 can successfully ping the serial interface of R2. The routing table on R1
does not contain any dynamically learned routes from R2, and the routing table on R2 shows no
dynamically learned routes from R1. What is the problem?
A. Subnetting is not supported by RIP v1.

B. One of the routers needs a clock rate on the serial interface.

C. CIDR is not supported by RIP v1.

D. VLSM is not supported by RIP v1.

Answer D

VLSM is not supported by RIP v1.

RIP's default behavior is to send version 1 updates only, but to accept both versions 1 and 2.

This is a strange little default, but you better know this! See show ip protocols

R2#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 6 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Redistributing: rip
Default version control: send version 1, receive any version

RIP version 2 default behavior is to autosummarize routes advertised across classful boundaries.
To disable this behavior, run the no auto-summary command under the RIP process.

To hardcode RIP to send and receive only version 1 or version 2, run the appropriate version
command under the RIP process.

RIP version 2 supports variable-length subnet masking (VLSM), but you still enter the classful
network number under the RIP process.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 172.10.0.0

To see the routes being advertised in RIP updates and the metrics of these routes,
run debug ip rip.

To see these updates immediately after turning the debug on, run clear ip route * to clear
the routing table of its dynamic routes.

R1#debug ip rip
RIP protocol debugging is on
R1#clear ip route *
01:16:54: RIP: sending v1 update to 255.255.255.255 via Loopback1
(1.1.1.1)
01:16:54: network 2.0.0.0, metric 2
01:16:54: network 3.0.0.0, metric 2
01:16:54: network 172.16.0.0, metric 1
01:16:54: network 10.0.0.0, metric 2
01:16:54: RIP: sending v1 update to 255.255.255.255 via Serial0
(172.16.123.1)
01:16:54: subnet 172.16.123.0, metric 1
01:16:54: network 1.0.0.0, metric 1
01:16:54: network 2.0.0.0, metric 2
01:16:54: network 3.0.0.0, metric 2
01:16:54: network 10.0.0.0, metric 2

If you want to see only a certain protocol route from the entire routing table, run the
show ip route followed by the protocol or route type (static, for example).

R1#show ip route rip


R 2.0.0.0/8 [120/1] via 172.16.123.2, 00:00:26, Serial0
R 3.0.0.0/8 [120/1] via 172.16.13.2, 00:00:09, Serial1
[120/1] via 172.16.123.3, 00:00:09, Serial0
R 10.0.0.0/8 [120/1] via 172.16.13.2, 00:00:09, Serial1
[120/1] via 172.16.123.3, 00:00:09, Serial0
[120/1] via 172.16.123.2, 00:00:26, Serial0

Don't forget to turn your debugs off when you're done! To turn all debugs off at once, run
undebug all. To turn off individual debugs, run the command no debug followed by the type
of debug you want to turn off - no debug ip rip, for example.

R1#undebug all
All possible debugging has been turned off

Remember how to verify RIP routing. The show ip route command provides the routing table.
R= RIP found route. The debug ip rip command shows rip updates being sent and received on
the router.

Another example
Note RIPv2 is classless and works in VLSM and discontiguous networks
Multicasting

To reduce unnecessary load on hosts that are not listening to RIPv2 messages, an IP multicast
address is used for periodic broadcast messages. The IP multicast address is 224.0.0.9.
Troubleshooting RIP

Show ip protocols
provides information about the interfaces on which RIP is configured, the sources of routing
information, and the timer values.
Notice that this router is receiving updates from address 10.1.1.2

The show ip protocols shows we are running RIP for networks 10.0.0.0, 172.16.0.0
Which means a our configuration would be

Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 172.16.0.0

Also ethernet and serial2 are participating in the RIP network and the neighbor router is 10.1.1.2

Lets also look at the show ip interface brief

From this command we can see that only serial0/0 is in the 10.0.0.0 network.
This means that the router will only send and receive routing updates with the 10.0.0.0 network
and will not advertise the 192.168.0.0 network out any interface.

show ip route
Displays the ip routing table. A summary of the route information for specific ip addresses,
network masks or protocols.

Question
What can be determined from the line of "show ip route" output shown below
R 10.10.10.8 [120/2] via 10.10.10.6, 00:00:25, Serial0/1 (choose two)

A. The ip address 10.10.10.8 is configured on S0/1

B. The 10.10.10.8 network is 2 hops away from this router

C. The next routing update can be expected in 35 seconds

D. This route is using the default administrative distance

E. The ip address 10.10.10.6 is configured on S0/1

Answer B, D

Explanation
R 10.10.10.8 [120/2] via 10.10.10.6, 00:00:25, Serial0/1

B is correct because that is a RIP metric, hop count, it is two hops away. [120/2]
D is correct. 120 is the default AD for RIP. [120/2]

This is a RIP update about network 10.10.10.8, with the default RIP AD, and is two hops away.
The route is coming on interface s0/1 from a neighbor router with the network address of
10.10.10.6 the next hop.

00:00:25 Specifies the last time the route was updated (in hours:minutes:seconds).

E is incorrect the 10.10.10.6 is next hop and serial0/1 is the local interface used to transmit data
to the destination network 10.10.10.8. Data destined for 10.10.10.8 will be placed in the output
queue on serial 0/1 the interface through which the destination network can be reached.

debug ip rip, terminal monitor monitor the RIP traffic on your network
The debug ip rip command sends information about routing updates as they are sent and
received by the router to the console session. If you are telnetted into the router, use the
terminal monitor command to be able to receive the output from the debug commands.
RIP is sending v1 packet to 255.255.255.255 a broadcast out interface serial0/0/01 via 10.1.5.2
this is where RIP v2 would only send a multicast 224.0.0.9
RouterB#debug ip rip
RIP protocol debugging is on RouterB#
07:12:56 RIP received v1 update from 192.168.40.2 on Serial0/1 07:12:56
192.168.50.0 in 1 hops
07:12:56 RIP received v1 update from 192.168.20.1 on Serial0/0
07:12:56 192.168.10.0 in 1 hops

Note that RIP version 1 is received on RouterB serial0/0 and serial0/1 interfaces this is from
RouterA and RouterC. Note split horizon rules stop RouterA and RouterC from advertising back
routes that they learned from RouterB
This means that only network 192.168.50.0 is being advertised from RouterC and 192.168.10.0 is
being advertised to RouterB from RouterA.

Split horizon exists for a very good reason - routing loop prevention. The rule of split horizon
states that a router cannot send an advertisement for a route out the same interface that it came
in on. With split horizon activated, a router omits sending routes back to the router it learned them
from This help in avoiding a process of mutual deception where two routers tell each other that
they can reach destination x via each other.

Split horizon is on by default on all interfaces running RIP, IGRP, and EIGRP.

Split horizon with poisoned reverse a router behaves in the same way as plain split horizon, but
instead of not sending information back it sends a route update with a metric of 16 (unreachable)
to the router it got the route from.

07:12:58 RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0


(192.168.30.1)
07:12:58 subnet 192.168.50.0, metric 1
07:12:58 subnet 192.168.40.0, metric 1
07:12:58 subnet 192.168.20.0, metric 1
07:12:58 subnet 192.168.10.0, metric 1
07:12:58 RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0
(192.168.20.2)
07:12:58 subnet 192.168.50.0, metric 1
07:12:58 subnet 192.168.40.0, metric 1
07:12:58 subnet 192.168.30.0, metric 1
07:12:58 RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0
(192.168.40.1)
07:12:58 subnet 192.168.30.0, metric 1
07:12:58 subnet 192.168.20.0, metric 1
07:12:58 subnet 192.168.10.0, metric 1

Here split-horizon rules allow only networks 192.168.30.0, 40 and 50 to be advertised to RouterA.
RouterB will not advertise the 192.168.10.0 network back to RouterA, nor 192.168.50.0 back to
RouterC.

If the metric of a route shows 16, this is a route poison, and the route advertising is unreachable.

In order to gain more information about the actual contents of the RIP traffic moving between
systems, use the debug ip rip command. This particular command is like a toggle switch –
debugging information that shows the contents of RIP updates sent and received will continue to
appear on-screen until you turn it off with the no debug ip rip command.

RouterA#debug ip rip
RIP protocol debugging is on
22:48:34: RIP: received v1 update from 10.0.20.2 on Serial0
22:48:34: 10.0.30.0 in 1 hops
22:48:38: RIP: sending v1 update to 255.255.255.255 via Ethernet0
(10.0.10.1)
22:48:38: subnet 10.0.20.0, metric 1
22:48:38: RIP: sending v1 update to 255.255.255.255 via Serial0
(10.0.20.1)
22:48:38: subnet 10.0.20.0, metric 1
RouterA#no debug ip rip

Note that the debug ip rip command shows the RIP updates both sent and received on a
particular interface, along with associated subnet and metric information. Remember than a
metric of 16 suggests an unreachable network in RIP.

To close down the debugger

RouterB#undebug all

All possible debugging has been turned off


RouterB#

To turn off debugging we can use the undebug all or no debug all or un all command

Question
Your senior network administrator wants you to monitor the RIP traffic on your network in real
time. Which of the following commands would you issue?

A. Show ip route
B. Show processes
C. Debug ip rip
D. Show ip rip

Answer C

Monitoring in real time requires the use of a debug command. Show commands merely grab a
snapshot in time, whereas debug commands are in real time.
A is incorrect, as it is a show command.
B is incorrect, as it is merely another show command.
D is also incorrect, as it uses a show command.
Here from the updates information is sent out about 10.0.0.0, 192.168.1.0 and 172.16.0.0

Both the 10.0.0.0 and 172.16.0.0 network are advertised with a metric of 1 which means their
directly connected. 192.168.168.0 is unreachable.

Question
RouterC does not appear to be receiving RIP updates from RouterB, which command can you
enter on RouterC to see if it is receiving these RIP updates?

A. Show ip protocols.
B. Show ip route rip.
C. Debug ip rip.
D. Debug ip updates.
E. Debug ip transactions.

Answer C

Explanation
The debug debug ip rip command displays information on RIP routing transactions. It would
enable us to see if the RIP updates are received.
Incorrect Answers
A. The show ip protocol command is used to see if a router is delivering bad routing information.
B. This is not a valid command. RIP is not a parameter of show ip route command.
D and E are not valid debug commands.

Although you don’t need to know how to do this for the exam, it’s always nice to know how to
change the default timers used by a protocol. The command to do so is timers basic, and is
issued from the routing protocol configuration level. One important note here – if you do decide to
change the timers on one router, you should also change the timers on every router. Otherwise,
you’ll be dealing with one very unpredictable network potentially susceptible to routing loops.

RouterA(config)#router rip
RouterA(config-router)#timers basic ?
<0-4294967295> Interval between updates
RouterA(config-router)#timers basic 30 ?
<1-4294967295> Invalid
RouterA(config-router)#timers basic 30 180 ?
<0-4294967295> Holddown
RouterA(config-router)#timers basic 30 180 180 ?
<1-4294967295> Flush
RouterA(config-router)#timers basic 30 180 180 240

I used the help function to walk through the timers basic command step by step to show you the order of the
entries – update, invalid, holddown, and flush. Ultimately, the same command can be used to set IGRP
timers.

Question
You company has decided to use RIP version 1 as the routing on a Cisco router. What is the
command to enable rip as the routing protocol on the company’s router?

A. SET RIP
B. SET ROUTER RIP
C. RIP
D. ROUTER RIP

Answer D

Explanation
The key characteristics of RIP include: it is a distance vector protocol, hop count is the metric
used for path selection, it maximum allowable hop count is 15, it broadcasts it entire routing table
every 30 seconds by default and it can be load balanced as many as six equal cost paths (4
paths are the default). To configure RIP not only does the router rip command need to be
inputted but also it must be followed by the network command. The network command must be
issued for each directly connected network.

Question
Your company has decided to use IP RIP version 1 as the routing protocol. Which of the
following are the commands you can use to configure IP RIP version 1 on your router?

A. Router RIP
network 172.16.1.0
network 10.1.0.1

B. Router RIP
network 172.16.0.0
network 10.0.0.0

C. Router RIP
network 172.16.1.0 172.16.1.1
network 10.1.0.0 10.1.1.1

D. Router RIP
network 172.16.1.0 265.255.255.0
Network 10.1.0.0 255.255.0.0

Answer B

Explanation
To enable RIP version 1 not only does the router rip command need to be used but also it must
be followed by the network command. The network command must be issued for each directly
connected network. The network command must be followed by a valid network address.

Incorrect Answers

A. Is this series of commands the network 10.1.0.1 is not a valid command.


C. If 4 networks are directly connected they must have their own network command.
D. There is no need to include a subnet mask with a network command.

Question
You have been hired as a consultant to troubleshoot the company's network. You issue the
debug ip rip command to troubleshooting the rip network. You notice your Ethernet interface
10.1.0.0 shuts down. Which update message is seen in your routers debug ip rip output
regarding that network?

A. Subnet 10.1.0.0, metric 0

B. Subnet 10.1.0.0, metric 1

C. Subnet 10.1.0.0, metric 15

D. Subnet 10.1.0.0, metric 16

Answer D

Explanation
RIP (Routing Information Protocol) is a distance vector protocol. RIP uses hope counts as metric.
The designers of RIP believed that the protocol was unlikely to be practical for networks with a
diameter larger than 15. The maximum hop count is therefore set to 15. In RIP when a network in
not reachable then its metric is changed to 16.
Incorrect Answers
A. A metric of 0 denotes a directly connected route and indicates that the interface is up.
B. This metric indicates that the interface is up and that the destination is reached with a hop
count of 1.
C. This metric indicates that the interface is up and that the destination is reached with a hop
count of 15.

Question
RouterC does not appear to be receiving RIP updates from RouterB, which command can you
enter on RouterC to see if it is receiving these RIP updates?

A. Show ip protocols.

B. Show ip route rip.

C. Debug ip rip.

D. Debug ip updates.

E. Debug ip transactions.
Answer C

Explanation
The debug debug ip rip command displays information on RIP routing transactions. It would
enable us to see if the RIP updates are received.
Incorrect Answers:
A. The show ip protocol command is used to see if a router is delivering bad routing information.
B. This is not a valid command. RIP is not a parameter of show ip route command.
D and E. These are not valid debug commands.

Question
You need to install RIP as the routing protocol of your network. Which of the following shows the
correct prompt and command to install RIP as the routing protocol? (Choose one)

A. Router# rip.
B. Router rip.
C. Router (Config)# rip.
D. Router (Config)# router rip.

Answer D

Explanation
In order to configure RIP as the routing protocol you need to ensure that you are in the route
configuration mode and that you use the command router rip.
A. This is both the wrong mode and command.
B. This is both the wrong mode and command.
C. This is the proper mode but the wrong command.

Question
You would like to configure IP RIP on your Cisco Router. Which of the following steps below are
required to install IP RIP? (Choose two)

A. Specify the routing protocol.

B. Configure static Rip routes.

C. Specify directly connected subnets.

D. Specify directly connected networks.

Answer A, D

Explanation
In enable a router with RIP it takes two basic steps: select the routing protocol and identify the
networks that the router is directly connected to. These steps are achieved with the commands
router rip and network.

Incorrect Answers
B. There is no such thing as a static RIP route.
C. With RIP you specify the directly connected networks, not the directly subnets.
Question
You need to install RIP on your router. Which command enables directly connected network
131.107.10.0 to be used by RIP?

A. Router(Config)# rip 131.107.10.0

B. Router(Config-router)# rip 131.107.10.0

C. Router(Config-router)# network 131.107.10.0

D. Router(Config-router)# network 131.107.0.0

Answer D

Explanation
The network command allows the routing process to identify the interfaces will participate in the
sending and receiving of messages.
Incorrect Answers
A and B. These are not valid commands. In addition, A is in the wrong mode.
C. This is the wrong network number. The 131.107.10.0 is a Class B subnet, using a default
mask of 255.255.0.0.

Question
The RIP network shown in the exhibit has been fully operational for two days. Each routing table
is complete.

Which networks will be included in the next routing update from the Testking1 router to the
Testking3 router?

A. A,B,C,D,E,F

B. A,C

C. A,B,C,D

D. B,D

E. D,E,F
F. A,B,C

Answer F

Explanation
Testking3 gets routing update from Testking1 with the following information
Network A, metric 1
Network B, metric 1
Network C, metric 2

Incorrect Answers
A. Not A because of split horizon. It is never useful to send information about a route back in the
direction from which the original update came.
B. Not B because it is missing one routing update information (Network B).
C, D, E: Not C, D & E because you don't get a routing update for your directly connected network
(Network D).

Question
A technician is configuring a route
Why does she use passive-interface command?

A. Allows a routing protocol to forward updates out an interface that is missing its IP address.
B. Allows a router to send routing updates on an interface but not receive updates via that
interface.
C. Allows an interface to remain up without receiving keepalives.
D. Allows interfaces to share IP addresses.
E. Allows a router to receive routing updates on an interface but not send updates via that
interface.

Answer E

Explanation
The passive-interface command is used to control the advertisement of routing information. The
command enables the suppression of routing updates over some interfaces while allowing
updates to be exchanged normally over other interfaces.

With most routing protocols, the passive-interface command restricts outgoing advertisements
only. However, when used with Enhanced Interior Gateway Routing Protocol (EIGRP), the effect
is slightly different. This document demonstrates that use of the passive-interface command in
EIGRP suppresses the exchange of hello packets between two routers, resulting in the loss of
their neighbor relationship. This stops not only routing updates from being advertised, but it also
suppresses incoming routing updates. This document also discusses the configuration required in
order to allow the suppression of outgoing routing updates, while allowing incoming routing
updates to be learnt normally from the neighbor.

Question
RtrA#debug ip rip
Rip protocol debugging is on
RtrA#
1d05h: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0
(172.16.1.1)
1d05h: RIP: build update entries
1d05h: network 10.0.0.0 metric 1
1d05h: network 192.168.1.0 metric 2
1d05h: RIP: sending v1 update to 255.255.255.255 via Serial0/0
(10.0.8.1)
1d05h: RIP: build update entries
1d05h: network 172.16.0.0 metric 1
RtrA#
1d05h: RIP: received v1 update from 10.0.15.2 on Serial0/0
1d05h: 192.168.1.0 in 1 hops
1d05h: 192.168.0 in 16 hops (inaccessible)

Which of the following are true regarding the command output shown in the display?
(Choose two)

A. There are at least two routers participating in the RIP process.


B. A ping to 192.168.168.2 will be successful.
C. A ping to 10.0.15.2 will be successful.
D. RtrA has three interfaces participating in the RIP process.

Answer A, C

Question
RouterTK#show ip route
Codes: C-connected, s-static, I –IGRP, R –RIP, M –mobile, B –BGP, D –
EIGRP, EX – EIGRP external, O – OSPF, IA –OSPF inter area, EI –OSPF
external type 1, E2 –OSPF external type 2, E –EGP, i –IS-IS, L1 –IS-IS
level-1, L2 –IS-IS level-2, * -candidate default, U – per-user static
route

Gateway of last resort is not set

R 202.30.8.0 /24[120/1] via 202.30.2.2, 00:00:16, Serial 0


C 202.30.9.0 /24 is directly connected, Serial 1
R 202.30.10.0 /24 is possibly down, routing via 202.30.9.1, Serial 1
R 202.30.11.0 /24 is possibly down, routing via 202.30.9.1, Serial 1
C 202.30.1.0 /24 is directly connected, Ethernet 0
C 202.30.2.0 /24 is directly connected, Serial 0
R 202.30.3.0 /24 [120/1] via 202.30.2.2, 00:00:17, Serial 0
R 202.30.4.0 /24 [120/15/ via 202.30.2.2, 00:00:17, Serial 0
R 202.30.5.0 /24 [120/15] via 202.30.2.2, 00:00:17, Serial 0
R 192.158.6.0 /24 [120/15] via 202.30.2.2, 00:00:17, Serial 0
R 202.30.7.0 /24 [120/1] via 202.30.2.2, 00:00:17, Serial 0

You are troubleshooting a router with default settings. You are concerned about the 202.30.10.0
and 202.30.11.0 routes. In particular you are interested how long they will be kept in the routing
table. What would be the maximum time these routes would be kept in the routing table?

A. 30 seconds
B. 60 seconds
C. 240 seconds
D. 360 seconds
E. 630 seconds

Answer C

Explanation: The Rs on the 202.30.10.0 and 202.30.11.0 lines (see below) indicates that the
routes were learned from the RIP protocol.
R 202.30.10.0 /24 is possibly down, routing via 202.30.9.1, Serial 1
R 202.30.11.0 /24 is possibly down, routing via 202.30.9.1, Serial 1

The hold down timer for RIP is 180 sec. The flush timer for RIP is 240 sec.

Question
RouterTK#show ip route
Codes: C-connected, s-static, l –IGRP, R –RIP, M –mobile, B –BGP, D –
EIGRP, EX – EIGRP external, O – OSPF, IA –OSPF inter area, EI –OSPF
external type 1, E2 –OSPF external type 2, E –EGP, i –IS-IS, L1 –IS-IS
level-1, L2 –IS-IS level-2, * -candidate default, U – per-user static
route

Gateway of last resort is not set

R 202.30.8.0 /24[120/1] via 202.30.2.2, 00:00:10, Serial 0


C 202.30.9.0 /24 is directly connected, Serial 1
R 202.30.10.0 /24 [120/7] via 202.30.9.1, 00:00:02, Serial 1
R 202.30.11.0 /24 [120/7] via 202.30.9.1, 00:00:03, Serial 1
C 202.30.1.0 /24 is directly connected, Ethernet 0
C 202.30.2.0 /24 is directly connected, Serial 0
R 202.30.3.0 /24 [120/1] via 202.30.2.2, 00:00:10, Serial 0
R 202.30.4.0 /24 [120/15/ via 202.30.2.2, 00:00:10, Serial 0
R 202.30.5.0 /24 [120/15] via 202.30.2.2, 00:00:10, Serial 0
R 202.30.6.0 /24 [120/15] via 202.30.2.2, 00:00:10, Serial 0
R 202.30.7.0 /24 [120/1] via 202.30.2.2, 00:00:10, Serial 0

You examine the routing table of your router


This routing table will be send to neighbouring routers via broadcasts. Some routes might be
discarded and not entered in to the routing tables of the neighbouring RIP routers. Which of the
following routes would be discarded in this way?

A. R 202.30.8.0/24 [120/1] via 202.30.2.2, 00:00:10, Serial0


B. R 202.30.11.0/24 [120/7] via 202.30.9.1, 00:00:03, Serial1
C. C 202.30.1.0/24 is directly connected, Ethernet0
D. R 202.30.5.0/24 [120/15] via 202.30.2.2, 00:00:10, Serial0

Answer D

RIP has the maximum hop count of 15. This route already has a hop count of 15 and adding one
would make it unreachable (see below). This route will be discarded.
R 202.30.5.0/24 [120/15] via 202.30.2.2, 00:00:10, Serial0

Question
Look at the configuration below and identify the true statement
R3#conf t

Enter configuration commands one per line end with cntl/z


R3(config)#router rip
R3(config-router)#network 172.12.0.0

A. A subnet mask must follow 172.12.0.0


B. The RIP version number must follow 172.12.0.0
C. A wildcard mask must follow 172.12.0.0
D. Nothing should follow 172.12.0.0
Answer D

Explanation
A. RIPv1 does not understand VLSM while RIPv2 does however it doesn’t matter which
version of RIP you run the subnet mask does not go here
B. Only RIPv1 has been configured
C. RIP doesn’t use wildcard masks

Question
Your company has decided to use IP RIP version 1 as the routing protocol. Which of the following
are the commands you can use to configure IP RIP version 1 on your router?

A. Router RIP
network 172.16.1.0
network 10.1.0.1
B. Router RIP
network 172.16.0.0
network 10.0.0.0
C. Router RIP
network 172.16.1.0 172.16.1.1
network 10.1.0.0 10.1.1.1
D. Router RIP
network 172.16.1.0 265.255.255.0
Network 10.1.0.0 255.255.0.0

Answer B

Question
You have been hired as to troubleshoot the company’s network. You issue the debug ip rip
command to troubleshoot the rip network. You notice your Ethernet interface 10.1.0.0 shuts
down. Which update message is seen in your routers debug ip rip output regarding that network?

A. Subnet 10.1.0.0, metric 0


B. Subnet 10.1.0.0, metric 1
C. Subnet 10.1.0.0, metric 15
D. Subnet 10.1.0.0, metric 16

Answer D

Question
You are using RIP as your routing protocol. Your WAN service provider asks you to use the
passive-interface command for the serial interface that is attached to the service provider. What
does this command accomplish?

A. It puts the interface in shutdown.


B. It tells a router to send routing updates out the interface but not to listen to any routing
updates.
C. It allows an interface to remain up despite the fact that the service provider does not provide
keepalives.
D. It tells a router to receive routing updates on an interface but not to send updates via that
interface.
Answer D

The passive-interface command is used to control the advertisement of routing information. The
command enables the suppression of routing updates over some interfaces while allowing
updates to be exchanged normally over other interfaces.
A is incorrect, as the actual command to turn off the interface is shutdown.
B is incorrect, as this answer is the opposite of what the command does.
C is incorrect, as keepalives keep up an Ethernet interface but do nothing for a serial interface.

Question
You are suggesting that your company uses IP RIP as its routing protocol. Your boss would like
you to list some facts about IP RIP before he approves your request. Which of the following
statements about IP RIP are true? (Choose two.)

A. It limits hop counts to 31.


B. It is a link-state routing protocol.
C. It uses autonomous system numbers.
D. It is capable of load sharing over multiple paths.
E. It uses bandwidth as the metric for path selection.
F. It broadcasts updates every 30 seconds by defaults

Answer D, F

Explanation
Key characteristics of RIP,
it is a distance vector protocol
hop count is used as the metric for path selection
maximum allowable hop count is 15
broadcast routing updates every 30 seconds
RIP can be load balanced over as many as 6 equal cost paths
RIP 1 requires a major classful network number to advertise
RIP 2 use VLSMs.

Incorrect answers
A. RIP's maximum allowable hop count is 15.
B. RIP is a distance vector protocol.
C. It uses network numbers/VLSMs.
E. Hop count is used as the metric for path selection.

Question
Your company has decided to use RIP version 1 as the routing on a Cisco router. What is the
command to enable rip as the routing protocol on the company’s router?

A. SET RIP
B. SET ROUTER RIP
C. RIP
D. ROUTER RIP

Answer D
Explanation
The key characteristics of RIP include: it is a distance vector protocol, hop count is the metric
used for path selection, it maximum allowable hop count is 15, it broadcasts it entire routing table
every 30 seconds by default and it can be load balanced as many as six equal cost paths (4
paths are the default). To configure RIP not only does the router rip command need to be
inputted but also it must be followed by the network command. The network command must be
issued for each directly connected network.

Question
Your company has decided to use IP RIP version 1 as the routing protocol. Which of the
following are the commands you can use to configure IP RIP version 1 on your router?

A. Router RIP
network 172.16.1.0
network 10.1.0.1

B. Router RIP
network 172.16.0.0
network 10.0.0.0

C. Router RIP
network 172.16.1.0 172.16.1.1
network 10.1.0.0 10.1.1.1

D. Router RIP
network 172.16.1.0 265.255.255.0
Network 10.1.0.0 255.255.0.0

Answer B

Explanation
To enable RIP version 1 not only does the router rip command need to be used but also it must
be followed by the network command. The network command must be issued for each directly
connected network. The network command must be followed by a valid network address.
Incorrect Answers:

A. Is this series of commands the network 10.1.0.1 is not a valid command.

C. If 4 networks are directly connected they must have their own network command.
D. There is no need to include a subnet mask with a network command.

Question
You are configuring the Ike router on the network shown in the figure below. You would like to
use the RIP routing protocol to propagate all the networks to the three routers shown. What
configuration would you apply to Ike to have it participate in this objective?
A. Ike(config)#router rip
Ike(config-router)#network 172.16.0.0
Ike(config-router)#network 192.168.45.0

B. Ike(config)#router rip
Ike(config-router)#network 172.16.30.0
Ike(config-router)#network 192.168.35.0
Ike(config-router)#network 192.168.45.0
Ike(config-router)#network 192.168.55.0

C. Ike(config)#router rip
Ike(config-router)#network 172.16.0.0
Ike(config-router)#network 192.168.35.0
Ike(config-router)#network 192.168.45.0
Ike(config-router)#network 192.168.55.0

D. Ike(config)#router rip
Ike(config-router)#network 172.16.0.0
Ike(config-router)#network 192.168.0.0

Answer A

RIP is considered a classful protocol. From a configuration standpoint, this means that networks
must be entered into the configuration using their default classes (Class A, B, or C). Because
172.16.0.0 is a class B network, it must be entered as if it had a class B subnet mask rather than
the subnet mask shown in the figure. In addition, you enter directly connected interfaces only into
a routing process. This concept applies to any routing protocol. In the case of Ike, it is connected
only to the 172.16.0.0 and 192.168.45.0 networks.

B and C are incorrect because they enter all the networks rather than the networks that are
directly connected to Ike.
D is incorrect because it enters the 192.168.0.0 network in a class B style when this is a class C
address.

Question
You need to install RIP on your router. Which command enables directly connected network
131.107.10.0 to be used by RIP?

A. Router(Config)# rip 131.107.10.0


B. Router(Config-router)# rip 131.107.10.0
C. Router(Config-router)# network 131.107.10.0
D. Router(Config-router)# network 131.107.0.0

Answer D

Explanation
The network command allows the routing process to identify the interfaces will participate in the
sending and receiving of messages.

Incorrect Answers
A and B. These are not valid commands. In addition, A is in the wrong mode.
C. This is the wrong network number. The 131.107.10.0 is a Class B subnet, using a default
mask of 255.255.0.0.

Question

Routers B and C are configured for RIPv2 and have complete connectivity. Router A is added to
the network. What is the most appropriate Router A configuration for full connectivity?

A. RouterA(config)# router rip


RouterA(config)# network 10.0.0.0
RouterA(config)# network 172.16.0.0
RouterA(config)# network 192.168.1.0

B. RouterA(config)# router rip


RouterA(config)# network 10.0.0.0

C. RouterA(config)# router rip


RouterA(config)# network 10.0.0.0
RouterA(config)# network 172.16.0.0

D. RouterA(config)# router rip


RouterA(config)# network 10.0.0.0
RouterA(config)# network 192.168.1.0

Answer C
RouterA(config)# router rip
RouterA(config)# network 10.0.0.0
RouterA(config)# network 172.16.0.0

Explanation: When configuring RIP you configure only the directly connected networks that are to
be advertised via the RIP routing process are to be configured.
Incorrect Answers
A. This choice implies that when configuring rip on a router every possible network in the entire
system should be configured. This is not the case.
B. Router 1 requires the 172.16.0.0 network to be configured, not the 192.168.1.0 network.
D. If the 172.16.0.0 network is omitted, then the other routers in the network will not be able to
reach the LAN users of RouterA via RIP.

Question
The Ethernet 0 interface of a router was configured with address 10.64.0.1 255.224.0.0 while the
Ethernet 1 interface was configured with address 10.96.0.1/11. Which commands could be used
to configure RIP version 1 on this router to advertise both networks to neighboring routers?
(Choose two.)

A. Router(config)# router rip


Router(config-router)# network 10.0.0.0 255.224.0.0

B. Router(config)# router rip


Router(config-router)# network 10.0.0.0

C. Router(config)# router rip


Router(config-router)# network 10.64.0.0
Router(config-router)# network 10.96.0.0

D. Router(config)# router rip


Router(config-router)# network 10.64.0.1 255.224.0.0
Router(config-router)# network 10.96.0.1 255.224.0.0

Answer B, C

Explanation: Both options B and C correctly include both of the networks in the routing process,
making them correct. With RIP, the subnet mask is not specified as the networks involved are
assumed to be classful.

Incorrect Answers
A, D. Both of these options incorrectly show a subnet mask used in the network commands under
the routing process. This is not an option with RIP.

Question

In this network, you must configure router CK1 to provide connectivity to router CK2. The entire
network must utilize the 192.1.1.0/24 network. If RIP is being used as the routing protocol, which
3 sets of commands will need to be completed on CK1? (Choose 3).

A. CK1(config)# interface ethernet 0


CK1(config-if)# ip address 192.1.1.129 255.255.255.192
CK1(config-if)# no shutdown
B. CK1(config)# interface ethernet 0
CK1(config-if)# ip address 192.1.1.97 255.255.255.192
CK1(config-if)# no shutdown

C. CK1(config)# interface serial 0


CK1(config-if)# ip address 192.1.1.4 255.255.255.252
CK1(config-if)# clock rate 56000

D. CK1(config)# interface serial 0


CK1(config-if)# ip address 192.1.1.6 255.255.255.252
CK1(config-if)# no shutdown

E. CK1(config)# router rip


CK1(config-router)# network 192.1.1.4
CK1(config-router)# network 192.1.1.128

F. CK1(config)# router rip


CK1(config-router)# version 2
CK1(config-router)# network 192.1.1.0

Answer A, D, F

Explanation
A is correct, a valid host is configured on E0 interface of the router 192.1.1.129/26.
D is correct because each WAN link uses the /30 or 255.255.255.252 mask revealing 2 valid host
addresses. Serial 0 is configured with the address 192.1.1.6/30, which comes from the subnet
192.1.1.4/30. Valid hosts in this subnet are 192.1.1.5/30 and 192.1.1.6/30
F is correct because we RIP version 2 will be required in this case as VLSM information needs to
be carried throughout the network, and VLSM is not supported on RIP version 1.

Incorrect Answers
B. The IP address in use here will conflict with the LAN network configured on CK2.
192.1.1.65/26, 11000000 = 192, bs = 64
0, 64, 128, 192

65 is in the 64 subnet so CK2 hosts 65 – 127

C. the 192.168.1.4/30 address is a network address, not a host address.

192.1.1.5/30, 11111100 = 252


bs = 4
subnets 0, 4, 8

Question
Which command or set of commands will stop the RIP routing process?

A. RouterB(config)# router rip


RouterB(config-router)# shutdown
B. RouterB(config)# router rip
RouterB(config-router)# network no 192.168.2.0

C. RouterB(config)# no router rip

D. RouterB(config)# router no rip

Answer C

RouterB(config)# no router rip

Question
When does a distance vector routing protocol set a hold-down timer on a route?

A. when the metric value of the route decreases


B. when the route is marked as inaccessible
C. when the metric value for the route improves
D. when a regular update is received from a neighboring router

Answer B

when the route is marked as inaccessible

Question
Which of the following functions are performed by a router as routing information travels through
the network? (Choose two.)

A. advertise supported applications


B. identify new destinations
C. calculate packet speed
D. verify network scalability
E. identify invalid networks

Answer B, E

identify new destinations and identify invalid networks

Question
What do distance vector algorithms require each router in the network to send?

A. a partial routing table to each router in the LAN


B. a partial routing table to each router in the WAN
C. the entire routing table to each neighboring router
D. the entire routing table to each router in the autonomous system

Answer C

the entire routing table to each neighboring router


Question

The administrator of the network depicted in the graphic would like to decrease the network's
convergence time. How can this be accomplished?

A. disable split horizon on the routers


B. increase the update interval on the routers
C. change the RIP holddown timer to 96 seconds
D. change the RIP holddown timer to 226 seconds

Answer C

change the RIP holddown timer to 96s

Explanation
Holddown timer: This sets the amount of time during which routing information is suppressed.
Routes will enter into the holddown state when an update packet is received that indicated the
route is reachable. This continues either until an update packet is received with a better metric or
until the holddown timer expires for RIP the default is 180s.

Question
Which statements describe load balancing when RIP is configured as the routing protocol?
(Choose two.)

A. A router is allowed to take advantage of multiple best paths to a given destination.


B. RIP uses the round robin approach in load balancing.
C. RIP load balancing selects a single path to forward all data to the destination even though
equal parallel paths exist.
D. RIP load balancing is based on bandwidth first and then the hop count.
E. Only one path to a destination can be statically assigned or dynamically calculated.

Answer A, B

Question
Which of the following would be the correct command sequence to enable RIP on Router B for all
connected networks?

A. RouterB# router rip


RouterB(router)# network 210.36.7.0
RouterB(router)# network 220.17.29.0
RouterB(router)# network 211.168.74.0

B. RouterB(config)# router rip


RouterB(config-router)# network 198.16.4.0
RouterB(config-router)# network 211.168.74.0
RouterB(config-router)# network 199.84.32.0

C. RouterB(config)# configure router rip


RouterB(config-router)# network 210.36.7.0
RouterB(config-router)# network 199.84.32.0
RouterB(config-router)# network 211.168.74.0

D. RouterB(config)# router rip


RouterB(config-router)# network 198.16.4.0
RouterB(config-router)# network 210.36.7.0
RouterB(config-router)# network 211.168.74.0

E. RouterB(config)# router rip


RouterB(config-router)# network 198.16.4.0
RouterB(config-router)# network 210.36.7.0
RouterB(config-router)# network 220.17.29.0

Answer E

RouterB(config)# router rip


RouterB(config-router)# network 198.16.4.0
RouterB(config-router)# network 210.36.7.0
RouterB(config-router)# network 220.17.29.0

Question
RouterTK#show ip route
Codes: C-connected,s-static,I-IGRP,R-RIP,M-Mobile,B-BGP
..........D-EIGRP,EIGRP external, O-OSPF,IA-OSPF inter area,
..........EI-OSPF external type 1,E2-OSPF external type 2, E-EGP,
..........i-IS-IS,L1-IS-IS level-1,L2-IS-IS level-2,*-candidate default,
..........U-per-user static route
Gateway of last resort is not set
R 192.168.8.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0
C 192.168.9.0/24 is directly connected, Serial 1
R 192.168.10.0/24 [120/7] via 192.168.9.1, 00:00:02, Serial1
R 192.168.11.0/24 [120/7] via 192.168.9.1, 00:00:03, Serial1
C 192.168.1.0/24 is directly connected, Ethernet0
C 192.168.2.0/24 is directly connected, Serial0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0
R 192.168.4.0/24 [120/15] via 192.168.2.2, 00:00:10, Serial0
R 192.168.5.0/24 [120/15] via 192.168.2.2, 00:00:10, Serial0
R 192.168.6.0/24 [120/15] via 192.168.2.2, 00:00:10, Serial0
R 192.168.7.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0
Based on the output of the show ip route command which route will not be entered into a
neighbour RIP router?

A. R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0

B. R 192.168.11.0/24 [120/7] via 192.168.9.1, 00:00:03, Serial1

C. C 192.168.1.0/24 is directly connected, Ethernet0

D. R 192.168.5.0/24 [120/15] via 192.168.2.2, 00:00:10, Serial0

Answer D

Explanation
This route has the worst metric of those listed and as such will not be shared with the neighbour.
RIP has the maximum hop count of 15. This route already has a hop count of 15 and adding one
would make it unreachable.

Incorrect Answers
A. This has the best metric thus it will be shared.
B. This route has a better metric therefore it will be shared.
C. This is a directly connected network thus it will be shared.

Question
Which of the following commands are required to turn on RIP routing on your network?
(Choose two.)

A. R4(config)#router rip

B. R4(config)#router rip 100

C. R4(config-router)#network 192.168.0.0

D. R4(config-router)#network all

Answers A and C

You must turn on the routing protocol with the router rip command from Global Configuration
mode. You must then specify interfaces to advertise; the network command accomplishes this. B
is incorrect, as you do not need to specify an autonomous system for RIP, as you would IGRP. D
is incorrect, as it is not a valid network command.

Question
A router learns two routes to a remote network, one route via OSPF and one route via RIPv2. The
network administrator wants the router to install the route learned via RIPv2 into its routing table.
What should the network administrator configure to ensure that the router will use the route
learned via RIPv2?
A. Nothing. The router will automatically use routes learned via RIP over routes learned via
OSPF.

B. The network administrator should configure the routers along the OSPF path with lower priority
numbers.
C. The network administrator should configure the router interface on the OSPF path to be a
passive interface.
D. The network administrator should configure an administrative distance for RIP that is lower
than the administrative distance of OSPF.
E. If two paths exist to a remote network, the only way to force the router to prefer one path over
the other is to configure the preferred path as a static route.

Answer D

Explanation: When multiple routing protocols are configured for the same networks, the router will
use the path with the lowest Administrative Distance (AD). By default, OSPF has and AD of 110
and RIP has an AD of 120. In order to ensure that the router prefers the route learned via RIP
over OSPF, the AD of the RIP route must be reduced to a value less than 120.

Question
You are running RIP version 2 in your enterprise network. You are interested in creating a
summary route and advertising this route out the Serial 2 interface of one of your routers. The
summary address is 10.10.0.0 255.255.0.0. What is the correct command to use to configure this
summary address?

A. Manual address summarization is not possible with RIP.

B. Router(config-router)#ip summary-address 10.10.0.0 255.255.0.0

C. Router(config-if)#ip summary-address 10.10.0.0 255.255.0.0

D. Router(config-if)#ip summary-address rip 10.10.0.0 255.255.0.0

Answer D

Router(config-if)#ip summary-address rip 10.10.0.0 255.255.0.0

Question
Which IP address would be appropriate for the S0/0 interface of the LCAG router shown in the
diagram below?

A. 172.16.0.25 /27
B. 192.168.17.125 /27
C. 10.16.7.13 /27
D. 192.168.17.17 /27
E. 10.16.7.129 /27
F. 172.18.7.49 /27

Answer D

Explanation: Since RIPv1 is being used, we need to ensure that the subnet mask is /27 like the
other internal networks as RIPv1 does not support VLSM. We will also need to use something in
the 192.168.17.X network since all the other networks are 192.168.17.X. This leaves only choices
B and D viable at this point.

Since we can see from this that the 192.168.17.125 IP address lies within the 192.168.17.96/27
network, we can not use this network as it is already being used by the network attached to Fa
0/1 of the MAFLD router. This leaves choice D as the only correct option. This can be verified by
the fact that the 192.168.17.0-31 IP addresses are not being used anywhere else within the
enterprise.

Question

Three networks have 50 hosts each and one network has 10 hosts. The multi-vendor routers are
connected by serial links that use separate subnets. One Class C address is to be used for all
networks and serial links and they do not wish to replace any of their existing routers Which is the
most appropriate protocol?

A. TCP/IP
B. RIP v1
C. RIP v2
D. IGRP
E. EIGRP
G. All are acceptable

Answer C
One class C address range for all networks therefore VLSM is needed rules out RIP v1 and IGRP
also multiple vendors used so only OSPF or RIPv2 viable choices OSPF not an option.
D. E are Cisco proprietary.

RIP SIM

Description Acme Inc. is a multinational company, whose headquarters are located in Istanbul.
The company demands end-to-end connectivity between headquarters and the two branch
offices, Berlin and Paris.

Tasks on Istanbul
1. Erase initial router configuration
2. Configure Hostname; enable, vty and console passwords. All passwords will be set to ‘cisco’
3. a. Configure interfaces by assigning them the appropriate IP Addresses given in the topology
b. Check whether the serial interfaces are DCE or DTE. Set clock rate if required.
4. a. Configure RIP to provide end-to-end connectivity
b. Check end-to-end connectivity
5. Save your configurations into router’s NVRAM

Solution for Step 1

Router#
Router#erase start
Erasing the nvram filesystem will remove all files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#reload

System configuration has been modified. Save? [yes/no]: n


Proceed with reload? [confirm]
01:12:03: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
Copyright (c) 1986-1995 by cisco Systems

Solution for Step 2

Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ISTANBUL
ISTANBUL(config)#enable secret cisco
ISTANBUL(config)#line vty 0 4
ISTANBUL(config-line)#password cisco
ISTANBUL(config-line)#line console 0
ISTANBUL(config-line)#login
ISTANBUL(config-line)#password Cisco
ISTANBUL(config-line)#end

Solution for Step 3

ISTANBUL(config)#int serial 0
ISTANBUL(config-if)#ip address 192.168.1.1 255.255.255.0
ISTANBUL(config-if)#no shut
00:32:24: %LINK-3-UPDOWN: Interface Serial0, changed state to down
ISTANBUL(config-if)#int serial 1
ISTANBUL(config-if)#ip address 176.16.1.1 255.255.255.0
ISTANBUL(config-if)#no shut

ISTANBUL(config-if)#int ethernet 0
ISTANBUL(config-if)#ip address 202.1.1.1 255.255.255.0
ISTANBUL(config-if)#no shut

ISTANBUL#sh controllers serial 0


HD unit 0, idb = 0x9F514, driver structure at 0xA31C0
buffer size 1524 HD unit 0, V.35 DCE cable
cpb = 0x21, eda = 0x4940, cda = 0x4800
RX ring with 16 entries at 0x214800
00 bd_ptr=0x4800 pak=0x106648 ds=0x21EC68 status=80 pak_size=0
!Output Omitted for simplicity

ISTANBUL#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ISTANBUL(config)#int serial 0
ISTANBUL(config-if)#clock rate 64000
ISTANBUL(config-if)#end
%SYS-5-CONFIG_I: Configured from console by console
ISTANBUL#sh controllers s 0
HD unit 0, idb = 0x9F514, driver structure at 0xA31C0
buffer size 1524 HD unit 0, V.35 DCE cable, clockrate 64000
cpb = 0x21, eda = 0x4940, cda = 0x4800
RX ring with 16 entries at 0x214800
00 bd_ptr=0x4800 pak=0x106648 ds=0x21EC68 status=80 pak_size=0
!Output Omitted for simplicity

Note Do not set clock rate on DTE interfaces.

Solution for Step 4

ISTANBUL(config)#router rip
ISTANBUL(config-router)#network 192.168.1.0
ISTANBUL(config-router)#network 202.1.1.0
ISTANBUL(config-router)#network 172.16.0.0 !!!

!!! Important Note for the CCNA Exam It’s a common mistake to write this command
as

ISTANBUL(config-router)#network 172.16.1.0

Your router will accept this command and indicate no error message. Furthermore, you won’t
encounter any problems in connectivity. However look at the output of show run

!
router rip
network 172.16.0.0
network 192.168.1.0
network 202.1.1.0
!

172.16 is a B class IP address and the network command is classless, so the last two octets will
be neglected.

Although this may cause not much trouble in the real world, it will definitely reduce your score in
the CCNA exam.

Solution for Step 5

BERLIN#copy running-config startup-config


Destination filename [startup-config]?
Building configuration...
[OK]

Das könnte Ihnen auch gefallen