Sie sind auf Seite 1von 3

/ip firewall mangle

add action=mark-connection chain=prerouting disabled=no in-interface=ether1-gate


way new-connection-mark=all-inconn passthrough=yes comment="CONEXION ENTRANTE"
add action=mark-packet chain=prerouting connection-mark=all-inconn disabled=no n
ew-packet-mark=all-inpkt passthrough=yes comment="SUBIDA"
add action=mark-connection chain=forward disabled=no out-interface=bridge-local
new-connection-mark=all-outconn passthrough=yes comment="CONEXION DE SALIDA"
add action=mark-packet chain=forward connection-mark=all-outconn disabled=no new
-packet-mark=all-outpkt passthrough=yes comment="DESCARGA"
/ip firewall layer7-protocol
add comment="DESCARGA" name=high regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|0[0-9]
[1-9]|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
add comment="DESCARGA" name=document regexp="^.*get.+\\.(pdf|doc|docx|xlsx|xls|r
tf|ppt|ppt).*\$"
add comment="VIDEO" name=youtube regexp="^.*get.+\\.(c.youtube.com|cdn.dailymoti
on.com|metacafe.com|mccont.com).*\$"
add comment="VIDEO" name=streaming regexp="videoplayback|video"
/ip firewall mangle
add action=mark-packet chain=forward layer7-protocol=high new-packet-mark=dpkt p
acket-mark=all-outpkt passthrough=no comment="DESCARGA DE CLIENTE"
add action=mark-packet chain=forward layer7-protocol=document new-packet-mark=dp
kt packet-mark=all-outpkt passthrough=no comment=""
/ip firewall mangle
add action=mark-packet chain=forward layer7-protocol=youtube new-packet-mark=spk
t packet-mark=all-outpkt passthrough=no comment="CLIENTE VIDEO"
add action=mark-packet chain=forward layer7-protocol=streaming new-packet-mark=s
pkt packet-mark=all-outpkt passthrough=no comment=""
/ip firewall mangle
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-140
30,18901-18909 comment="CLIENTES JUEGOS ONLINE"
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,
15002,7341,7451
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466
,36567,8822
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,
9015
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=udp dst-port=27005,27015
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000
add action=mark-packet chain=forward packet-mark=all-outpkt new-packet-mark=gpkt
passthrough=yes protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000
-13080
/ip firewall mangle
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443
passthrough=no new-packet-mark=bpkt packet-mark=all-outpkt protocol=tcp comment=
"NAVEGADOR"
/ip firewall layer7-protocol

add comment="BIT TORENT" name=bittorrent regexp="^(\13bittorrent protocol|azver1


\$|get /scrape\\\\?info_hash=)|d1:ad2:id20:|8 7P\\)[RP]"
add comment="TORRENT WEBSITES" name=torrentsites regexp="^.*(get|GET).+(torrent|
thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz|vert
or|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bit
soup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$"
/ip firewall mangle
add action=mark-packet chain=forward layer7-protocol=bittorrent new-packet-mark=
tpkt packet-mark=all-outpkt passthrough=no comment="TORRENTS"
add action=mark-packet chain=forward layer7-protocol=torrentsites new-packet-mar
k=tpkt packet-mark=all-outpkt passthrough=no comment="WEB TORRENTS"
add action=mark-packet chain=forward p2p=all-p2p new-packet-mark=tpkt packet-mar
k=all-outpkt passthrough=no comment="TODOS P2P"
add action=mark-packet chain=forward dst-port=58561,58045,14948,58008,58816,5909
7 new-packet-mark=tpkt packet-mark=all-outpkt passthrough=no protocol=tcp commen
t="PUERTOS DEL TORRENT"
/queue type
add name=pcq_upstream kind=pcq pcq-rate=256k pcq-classifier=src-address
add name=pcq_downstream kind=pcq pcq-rate=512k pcq-classifier=dst-address
add name=pcq_game kind=pcq pcq-rate=256k pcq-classifier=dst-address
add name=pcq_browsing kind=pcq pcq-rate=256k pcq-classifier=dst-address
add name=pcq_download kind=pcq pcq-rate=256k pcq-classifier=dst-address
add name=pcq_undefined kind=pcq pcq-rate=180k pcq-classifier=dst-address
add name=pcq_extensions kind=pcq pcq-rate=180k pcq-classifier=dst-address
add name=pcq_video kind=pcq pcq-rate=200k pcq-classifier=dst-address
add name=pcq_p2ptorrent kind=pcq pcq-rate=150k pcq-classifier=dst-address
/queue tree
add name=a.Upstream parent=global queue=pcq_upstream packet-mark=all-inpkt prior
ity=8 max-limit=2M
add name=b.Downstream parent=global queue=pcq_downstream packet-mark=all-outpkt
priority=8 max-limit=2M
add name=1.Games parent=b.Downstream queue=pcq_game packet-mark=gpkt priority=1
limit-at=125k max-limit=512k
add name=2.Browsing parent=b.Downstream queue=pcq_browsing packet-mark=bpkt prio
rity=2 limit-at=125k max-limit=512k
add name=3.Download parent=b.Downstream queue=pcq_download packet-mark=all-outpk
t priority=3 limit-at=125k max-limit=512k
add name=3.1.Undefined parent=3.Download queue=pcq_undefined packet-mark=all-out
pkt priority=4 limit-at=75k max-limit=320k
add name=3.2.Extensions parent=3.Download queue=pcq_extensions packet-mark=dpkt
priority=5 limit-at=75k max-limit=320k
add name=3.3.Video parent=3.Download queue=pcq_video packet-mark=spkt priority=6
limit-at=75k max-limit=320k
add name=3.4.P2P&Torrent parent=3.Download queue=pcq_p2ptorrent packet-mark=tpkt
priority=7 limit-at=75k max-limit=320k
/ip firewall mangle
add chain=prerouting protocol=icmp action=mark-connection new-connection-mark=IC
MP_CONNECTION passthrough=yes comment="ICMP_CONNECTION" disabled=no
/ip firewall mangle
add chain=prerouting protocol=icmp connection-mark=ICMP_CONNECTION action=mark-p
acket new-packet-mark=ICMP_PACKET passthrough=no comment="ICMP_PACKET" disabled=
no
/queue tree
add name="==PING_CONDITION==" parent=global packet-mark=ICMP_PACKET limit-at=0 q
ueue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0
s

/queue type
add kind=pcq name=pcq-up pcq-classifier=src-address pcq-limit=50 pcq-rate=0 pcqtotal-limit=2000
add kind=pcq name=pcq-down pcq-classifier=dst-address pcq-limit=50 pcq-rate=0 pc
q-total-limit=2000
/queue simple
:for i from=1 to=253 do={add name=("Usuarios $i") target=("192.168.79.$i") max-l
imit=128K/512k limit-at=128k/512k total-queue=default queue=pcq-up/pcq-down}

Das könnte Ihnen auch gefallen