Sie sind auf Seite 1von 10

HUAWEI SWITCH S5700 - HOW TO

HUAWEI SWITCH S5700 HOW TO

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO
General infos and application environment
VLAN Mapping is a function that maps the
customer VLAN ID to the carrier VLAN ID
by replacing VLAN tags of data frames.
VLAN mapping implements VLAN
aggregation (users in different vlan can
communicate) and allows service data to
be transmitted according to carriers'
network plans, saving carrier vlan
resources.
The S5700 supports the following VLAN
mapping features:
- Single-tag VLAN mapping based on
the interface and VLAN
- Double-tag VLAN mapping based on
the interface and VLAN.
We will explain single-tag vlan mappinq
through the simple network scenario
shown in the picture.
We will configure VLAN mapping on
SwitchA and SwitchB, so Client PCs in
VLAN 10 will be able to communicate
with Client PCs in VLAN 20, through
carriers VLAN 100.
Configuring single-tag vlan mapping
HUAWEI SWITCH S5700 - HOW TO
Configuring vlans on the switches
1. Create vlans on the switches
<SwitchA> system-view Enter the configuration view
[SwitchA] vlan batch 10 100
Create vlans 10 and 100
<SwitchB> system-view

[SwitchB] vlan batch 20 100

<SwitchC> system-view

[SwitchC] vlan batch 100

<SwitchD> system-view

[SwitchD] vlan batch 100

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO
Adding interfaces to vlans (1)
2. Add interfaces to vlans
[SwitchA] interface gigabitethernet 0/0/1 Enter the interface view
[SwitchA-GigabitEthernet0/0/1] port link-type access Configure the port type
[SwitchA-GigabitEthernet0/0/1] port default vlan 10
[SwitchA-GigabitEthernet0/0/1] quit Configure the default vlan
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type access
[SwitchA-GigabitEthernet0/0/2] port default vlan 10
[SwitchA-GigabitEthernet0/0/2] quit
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] port link-type trunk
[SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet0/0/3] quit

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO
Adding interfaces to vlans (2)
[SwitchB] interface gigabitethernet 0/0/1
[SwitchB-GigabitEthernet0/0/1] port link-type access
[SwitchB-GigabitEthernet0/0/1] port default vlan 20
[SwitchB-GigabitEthernet0/0/1] quit
[SwitchB] interface gigabitethernet 0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type access
[SwitchB-GigabitEthernet0/0/2] port default vlan 20
[SwitchB-GigabitEthernet0/0/2] quit
[SwitchB] interface gigabitethernet 0/0/3
[SwitchB-GigabitEthernet0/0/3] port link-type trunk
[SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 20
[SwitchB-GigabitEthernet0/0/3] quit

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO
Adding interfaces to vlans (3)
[SwitchC] interface gigabitethernet 0/0/1
[SwitchC-GigabitEthernet0/0/1] port link-type trunk
[SwitchC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
[SwitchC-GigabitEthernet0/0/1] quit

[SwitchD] interface gigabitethernet 0/0/1


[SwitchD-GigabitEthernet0/0/1] port link-type trunk
[SwitchD-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
[SwitchD-GigabitEthernet0/0/1] quit

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO
Configuring single-tag vlan mapping on
the switches
Enter the interface view
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] qinq vlan-traslation enable Enable vlan mapping

[SwitchA-GigabitEthernet0/0/3] port vlan-mapping vlan 100 map-vlan 10 Define vlan mapping

[SwitchA-GigabitEthernet0/0/3] quit

[SwitchB] interface gigabitethernet 0/0/3


[SwitchB-GigabitEthernet0/0/3] qinq vlan-traslation enable
[SwitchB-GigabitEthernet0/0/3] port vlan-mapping vlan 100 map-vlan 20
[SwitchB-GigabitEthernet0/0/3] quit

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO
Checking the configuration
3. Check the configuration (ping from Client1 to Client4)
Client1> ping 192.168.100.5

Ping 192.168.100.5: 32 data bytes, Press Ctrl_C to break


From 192.168.100.5: bytes=32 seq=1 ttl=128 time=78 ms
From 192.168.100.5: bytes=32 seq=2 ttl=128 time=93 ms
From 192.168.100.5: bytes=32 seq=3 ttl=128 time=109 ms
From 192.168.100.5: bytes=32 seq=4 ttl=128 time=78 ms
From 192.168.100.5: bytes=32 seq=5 ttl=128 time=94 ms

--- 192.168.100.5 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 78/90/109 ms

Client1>

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO

More needs?

See hints on www.ipmax.it


Or email us your questions to info_ipmax@ipmax.it

Configuring single-tag vlan mapping


HUAWEI SWITCH S5700 - HOW TO

IPMAX is a Huawei Partner in Italy.


IPMAX is the ideal partner for companies seeking quality in products and services.
IPMAX guarantees method and professionalism to support its customers in selecting
technologies with the best quality / price ratio, in the design, installation,
commissioning and operation.

IPMAX srl
Via Ponchielli, 4
20063 Cernusco sul Naviglio (MI) Italy
+39 02 9290 9171

Configuring single-tag vlan mapping