Sie sind auf Seite 1von 12

----PE1-------------

hostname PE1

ip vrf cliente_A
rd 123:12
route-target export 123:12
route-target import 123:12
!
ip vrf cliente_B
rd 321:21
route-target export 321:21
route-target import 321:21
!

interface Loopback0
ip address 12.12.12.12 255.255.255.255
!
interface FastEthernet0/0
ip address 192.170.0.1 255.255.255.252
no shutdown
exit
!
interface FastEthernet3/0
ip vrf forwarding cliente_A
ip address 192.170.1.1 255.255.255.252
no shutdown
exit
!
interface FastEthernet1/0
ip vrf forwarding cliente_B
ip address 192.170.2.1 255.255.255.252
no shutdown
exit

!
router ospf 1
router-id 12.12.12.12
log-adjacency-changes
network 12.12.12.0 0.0.0.0 area 0
network 192.170.0.0 0.0.0.3 area 0
!
router bgp 7412
no synchronization
bgp router-id 12.12.12.12
bgp log-neighbor-changes
neighbor 14.14.14.14 remote-as 7412
neighbor 14.14.14.14 update-source Loopback0
neighbor 15.15.15.15 remote-as 7412
neighbor 15.15.15.15 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 14.14.14.14 activate
neighbor 14.14.14.14 send-community both
neighbor 14.14.14.14 next-hop-self
neighbor 15.15.15.15 activate
neighbor 15.15.15.15 send-community both
neighbor 15.15.15.15 next-hop-self
exit-address-family
address-family ipv4 vrf cliente_A
neighbor 172.16.1.1 remote-as 123
neighbor 172.16.1.1 activate
no auto-summary
no synchronization
exit-address-family

address-family ipv4 vrf cliente_B


neighbor 172.16.2.1 remote-as 123
neighbor 172.16.2.1 activate
no auto-summary
no synchronization
exit-address-family

----P-------------
hostname P
!
interface Loopback0
ip address 13.13.13.13 255.255.255.255
!
interface FastEthernet0/0
ip address 192.170.0.2 255.255.255.252
no shutdown
exit
!
interface FastEthernet1/0
ip address 192.170.2.1 255.255.255.252
no shutdown
exit

interface FastEthernet3/0
ip address 192.170.1.1 255.255.255.252
no shutdown
exit
!
router ospf 1
router-id 13.13.13.13
log-adjacency-changes
network 13.13.13.0 0.0.0.0 area 0
network 192.170.0.0 0.0.0.3 area 0
network 192.170.1.0 0.0.0.3 area 0
network 192.170.2.0 0.0.0.3 area 0

------PE2----------------

hostname PE2

ip vrf cliente_A
rd 123:12
route-target export 123:12
route-target import 123:12
!
ip vrf cliente_B
rd 321:21
route-target export 321:21
route-target import 321:21
!
interface Loopback0
ip address 14.14.14.14 255.255.255.255
!
interface FastEthernet3/0
ip address 192.170.1.2 255.255.255.252
no shutdown
exit
!
interface FastEthernet1/0
ip vrf forwarding cliente_B
ip address 200.2.112.1 255.255.255.252
no shutdown
exit
!
interface FastEthernet0/0
ip vrf forwarding cliente_A
ip address 200.1.122.1 255.255.255.252
no shutdown
exit
!
router ospf 1
router-id 14.14.14.14
log-adjacency-changes
network 14.14.14.0 0.0.0.0 area 0
network 192.170.1.0 0.0.0.3 area 0
!
router bgp 7412
no synchronization
bgp router-id 14.14.14.14
bgp log-neighbor-changes
neighbor 12.12.12.12 remote-as 7412
neighbor 2.2.2.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 12.12.12.12 activate
neighbor 12.12.12.12 send-community both
neighbor 12.12.12.12 next-hop-self
exit-address-family
!
address-family ipv4 vrf cliente_B
neighbor 200.2.112.2 remote-as 112
neighbor 200.2.112.2 activate
no auto-summary
no synchronization
network 200.2.112.0 mask 255.255.255.252
exit-address-family
!
address-family ipv4 vrf cliente_A
neighbor 200.1.112.2 remote-as 112
neighbor 200.1.112.2 activate
no auto-summary
no synchronization
exit-address-family

----PE3-----------

hostname PE3
ip vrf cliente_A
rd 123:12
route-target export 123:12
route-target import 123:12
!
ip vrf cliente_B
rd 321:21
route-target export 321:21
route-target import 321:21
!
interface Loopback0
ip address 15.15.15.15 255.255.255.255
!
interface FastEthernet1/0
ip address 192.170.2.2 255.255.255.252
no shutdown
exit
!
interface FastEthernet0/0
ip vrf forwarding cliente_A
ip address 200.3.112.1 255.255.255.252
no shutdown
exit
!
interface FastEthernet2/0
ip vrf forwarding cliente_B
ip address 200.4.112.1 255.255.255.252
no shutdown
exit
!
router ospf 1
router-id 15.15.15.15
log-adjacency-changes
network 15.15.15.0 0.0.0.0 area 0
network 192.170.2.0 0.0.0.3 area 0
!
router bgp 7412
no synchronization
bgp router-id 15.15.15.15
bgp log-neighbor-changes
neighbor 12.12.12.12 remote-as 7412
neighbor 12.12.12.12 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 12.12.12.12 activate
neighbor 12.12.12.12 send-community both
neighbor 12.12.12.12 next-hop-self
exit-address-family
!
address-family ipv4 vrf cliente_B
neighbor 200.4.112.2 remote-as 212
neighbor 200.4.112.2 activate
neighbor 200.4.112.2 as-override
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf cliente_A
neighbor 200.3.112.2 remote-as 112
neighbor 200.3.112.2 activate
neighbor 200.3.112.2 as-override
no auto-summary
no synchronization
exit-address-family

------CPE1---------------

hostname CPE1

VLAN DATABASE
exit

interface FastEthernet0/0
ip address 20.1.112.2 255.255.255.252
ip nat outside
no shutdown
exit

interface Port-channel1
switchport mode trunk
!
interface FastEthernet1/0
switchport mode trunk
channel-group 1 mode on

interface FastEthernet1/1
switchport mode trunk
channel-group 1 mode on

interface Vlan10
description VLAN_10
ip address 192.168.112.2 255.255.255.0
ip nat inside
standby 1 ip 192.168.112.1
standby 1 priority 120
standby 1 preempt
!
router bgp 112
bgp router-id 16.16.16.16
bgp log-neighbor-changes
neighbor 200.1.112.1 remote-as 7412
!
address-family ipv4
neighbor 200.1.112.1 activate
no auto-summary
no synchronization
network 192.168.112.0 mask 255.255.255.0
network 200.1.112.0 mask 255.255.255.252
exit-address-family
!
ip route 0.0.0.0 0.0.0.0 200.1.112.1
!
ip nat inside source list 1 interface FastEthernet1/0 overload
!
access-list 1 permit 192.168.112.0 0.0.0.255
------CPE2---------------
VLAN DATABASE
vlan 10 name AA
exit

interface FastEthernet1/0
switchport mode trunk
channel-group 1 mode on

!
interface FastEthernet1/1
switchport mode trunk
channel-group 1 mode on

!
interface FastEthernet0/0
ip address 200.3.112.2 255.255.255.252
ip nat outside
no shutdown
exit
!
interface Vlan10
ip address 192.168.112.3 255.255.255.0
ip nat inside
ip virtual-reassembly
standby 1 ip 192.168.112.1
standby 1 preempt
!
router bgp 112
bgp router-id 17.17.17.17
bgp log-neighbor-changes
neighbor 200.3.112.1 remote-as 7412
!
address-family ipv4
neighbor 200.3.112.1 activate
no auto-summary
no synchronization
network 192.168.112.0 mask 255.255.255.0
network 200.3.112.0 mask 255.255.255.252
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 200.3.112.1
!
ip nat inside source list 1 interface FastEthernet1/0 overload
!
access-list 1 permit 192.168.112.0 0.0.0.255

----CPE_1--------------------

hostname CPE_1
!
interface Loopback0
ip address 8.8.8.7 255.255.255.255
!
interface Port-channel1
switchport mode trunk
!
interface FastEthernet0/0
ip address 200.2.8.2 255.255.255.252
ip nat outside
ip virtual-reassembly
no shutdown
exit
!
interface FastEthernet1/0
switchport mode trunk
channel-group 1 mode on
no shutdown
exit
!
interface FastEthernet1/1
switchport mode trunk
channel-group 1 mode on
no shutdown
exit
!
interface Vlan10
ip address 192.168.18.2 255.255.255.0
ip nat inside
ip virtual-reassembly
vrrp 1 ip 192.168.18.1
vrrp 1 priority 120
!
router bgp 28
bgp log-neighbor-changes
neighbor 200.2.8.1 remote-as 748
!
address-family ipv4
neighbor 200.2.8.1 activate
no auto-summary
no synchronization
network 192.168.18.0
network 200.2.8.0 mask 255.255.255.252
exit-address-family
!
!
ip nat inside source list 10 interface FastEthernet0/0 overload
!
access-list 10 permit 192.168.18.0 0.0.0.255

----CPE_2--------------------

hostname CPE_2
!
interface Loopback0
ip address 8.8.8.9 255.255.255.255
!
interface Port-channel1
switchport mode trunk
!
interface FastEthernet0/0
ip address 200.4.8.2 255.255.255.252
ip nat outside
ip virtual-reassembly
no shutdown
exit
!
interface FastEthernet1/0
switchport mode trunk
channel-group 1 mode on
no shutdown
exit
!
interface FastEthernet1/1
switchport mode trunk
channel-group 1 mode on
no shutdown
exit
!
interface Vlan10
ip address 192.168.18.2 255.255.255.0
ip nat inside
ip virtual-reassembly
vrrp 1 ip 192.168.18.1
!
router bgp 28
bgp log-neighbor-changes
neighbor 200.4.8.1 remote-as 748
!
address-family ipv4
neighbor 200.4.8.1 activate
no auto-summary
no synchronization
network 192.168.18.0
exit-address-family
!
!
ip nat inside source list 10 interface FastEthernet0/0 overload
!
access-list 10 permit 192.168.18.0 0.0.0.255
!

----SW3--------------------

hostname SW3

no spanning-tree vlan 1
no spanning-tree vlan 10
!
!
ip tcp synwait-time 5
!
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/2
switchport mode trunk
channel-group 2 mode on
!
!
interface FastEthernet0/4
switchport access vlan 10

----SW2--------------------

hostname SW2
!
no spanning-tree vlan 1
no spanning-tree vlan 10
!
!
ip tcp synwait-time 5
!
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/2
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet0/3
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet0/4
switchport access vlan 10
!

----SW4--------------------

hostname SW4

no spanning-tree vlan 1
no spanning-tree vlan 10
!
!
ip tcp synwait-time 5
!
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/2
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet0/3
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet0/4
switchport access vlan 10

----SW5--------------------

hostname SW5

no spanning-tree vlan 1
no spanning-tree vlan 10
!
!
ip tcp synwait-time 5
!
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/2
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet0/3
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet0/4
switchport access vlan 10

::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:::::::::PROFE::::::::::::::::::::::::::::::::::::::::::

router cliente A

interface Loopback0
ip address 200.75.0.10 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
no shutdown
exit
!
router bgp 123
bgp router-id 200.75.0.10
bgp log-neighbor-changes
neighbor 172.16.2.112 remote-as 7412
!
address-family ipv4
neighbor 172.16.2.112 activate
neighbor 172.16.2.112 default-originate
no auto-summary
no synchronization
network 200.75.0.0
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 Loopback0

-------------cliente B.................

router cliente B

interface Loopback0
ip address 200.75.0.10 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
no shutdown
exit
!
router bgp 123
bgp router-id 200.75.0.10
bgp log-neighbor-changes
neighbor 172.16.2.112 remote-as 7412
!
address-family ipv4
neighbor 172.16.2.112 activate
neighbor 172.16.2.112 default-originate
no auto-summary
no synchronization
network 200.75.0.0
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 Loopback0

Das könnte Ihnen auch gefallen