You are on page 1of 5

(http://www.sap.

com/)

Products Industries
(https://www.sap.com/products.html) Industries (https://www.sap.com/industries.html)

Support (https://www.sap.com/support.html)

Training (https://www.sap.com/training-certi cation.html)

Community (https://www.sap.com/community.html)
Developer Developer (https://www.sap.com/developer.html)

Partner About
(https://www.sap.com/partner.html) About (https://www.sap.com/corporate/en.html)

 

(/users/login.html)
Home (https://www.sap.com) / Community (https://www.sap.com/community.html) / Questions & Answers (/index.html) + Actions



0 HANA Express Edition only VM, not able
to reach from local host
Dec 10, 2016 at 06:32 AM 1k

Hi,
I have hxe.ova imported, up and running in vmware player locally, with the
network set to bridged and IP properly obtained. I have also turned off the
firewall at SuSE level just to ensure smooth development, for starters. (/users/37108/satishkandi.
Now, I am able to reach the IP of the guest VM from the host operating
Satish Kandi
system (Windows 8.1) and vice versa.
(/users/37108/satishkandi.html)
However, the eclipse setup is not able to reach the HDB.
HDB info command on the server shows all servers to be up and running.
Please advise as to how I can get the connection working.

SAP HANA (/tags/73554900100700000996)

9 Comments 
* Please Login or Register (/users/login.html) to Answer, Follow or Comment.

5 Answers Sort by: Votes

Satish Kandi (/users/37108/satishkandi.html) Answered Dec 10, 2016 at 07:45 AM

(/users/37108/satishkandi.html)
 Hello,
0
My local host has IP 192.168.1.102 and guest VM is running at 192.168.1.103.

I have followed the steps listed in that link till setting up of /etc/hosts files at both guest and host
operating systems and ping works fine.
I have also installed a 64 bit SAP HANA client locally (since my OS is 64 bit). The ODBC administrator
window lists the HDBODBC and allows configuration till the connect part. The exception on connect
from HDB ODBC is
"SQLSTATE: 08S01
NATIVE ERROR: -10709
MESSAGE TEXT: [SAP AG][LIBODBCHDB.DLL][HDBODBC]
Communication link failure;-10709 Connected failed (RTE:[89006]
System call 'connect failed, rc=10061:No connection could be made because the target machine
actively refused it (hxehost.localdomain.com (http://hxehost.localdomain.com):30015))"
The error I am getting from Eclipse is "The system could not be reached. The logon data could not be
used."
Based on above messages, I have turned off the firewall at both machines. Thus, at least the ping
works both ways.
Any pointers?

Share

Satish Kandi (/users/37108/satishkandi.html) Answered Dec 11, 2016 at 06:46 AM

(/users/37108/satishkandi.html)
 Any pointers would be appreciated.
0
Share

Vidya Mandapudy (/users/1312/vidyamandapudy.html) Answered Dec 14, 2016 at 11:36 PM

(/users/1312/vidyamandapudy.html)
 Hi Satish,
0
From the HDB information you have provided, it looks like you are using HANA 1.0 SPS12.

Were you able to successfully execute HDB sql?
hdbsql -i 00 -d SystemDB -u SYSTEM -p HXEHana1
Were you using the same instance number 00 to connect using eclipse or 90? Please make sure to use
00 as described in the documentation for SPS12. Revert back incase of any further issues.
Thanks,
Vidya Mandapudy

Share

Denys van Kempen (/users/7158/denyskempen.html) Answered Dec 15, 2016 at 03:27 PM

(/users/7158/denyskempen.html)
 Hi Satish,
0
FYI: there is a full playlist on the HANA Academy about the express edition, which covers most of the

issues you might encounter.
https://www.youtube.com/playlist?list=PLkzo92owKnVy6nOZMFZIZxcvBCoRdshsR
(https://www.youtube.com/playlist?list=PLkzo92owKnVy6nOZMFZIZxcvBCoRdshsR)
If you cannot connect with Eclipse running on your host to express running on the guest (VM), it could
be that a firewall is blocking the port access. Are you using a Windows PC with the Firewall on by any
chance? Try stopping the Firewall service and see if you can connect. If so, you have to configure the
Firewall to allow for port traffic from VMware.

Share

1 Comments 

Denys van Kempen (/users/7158/denyskempen.html) Answered Jun 19, 2017 at 02:13 PM

(/users/7158/denyskempen.html)
 Hi,
0
Just downloaded the HXE vm (hxe.ova). Imported into VMware. Changed the passwords as instructed

and queried the IP using /sbin/ipconfig.
Also downloaded Eclipse Neon from eclipse.org (http://eclipse.org), installed studio from
tools.hana.ondemand.com/neon (http://tools.hana.ondemand.com/neon).
Added the system database using the IP and instance number 90.
Proceeded to add the tenant database HXE, received an error.
SQL> select * from m_databases
Output informed me that HXE was not started.
SQL> alter system start database HXE;
Proceeded adding tenant HXE to studio.

 screen-shot-2017-06-19-at-154819.png (/storage/attachments/41356-screen-shot-2017-
06-19-at-154819.png) (706.6 kB)
 screen-shot-2017-06-19-at-155018.png (/storage/attachments/41357-screen-shot-2017-
Share & Follow
06-19-at-155018.png) (176.0 kB)
(https://www.facebook.com/sapcommunity) (https://twitter.com/SAPCommunity)
Share
(https://www.youtube.com/c/SAPCommunities) (https://www.linkedin.com/company/sap)
(https://plus.google.com/+SAPCommunities) (https://instagram.com/sap/) (http://www.slideshare.net/SAP)

Privacy (http://go.sap.com/about/legal/privacy.html) Terms of Use (http://go.sap.com/corporate/en/legal/terms-of-use.html) Legal


Disclosure (http://go.sap.com/about/legal/impressum.html) Copyright (http://go.sap.com/about/legal/copyright.html) Trademark
(http://go.sap.com/about/legal/trademark.html) Sitemap (http://www.sap.com/sitemap/index.html) Newsletter
(https://go.sap.com/registration/newsletter.html)