Sie sind auf Seite 1von 4

WWW.DEVM ASTER.

CLUB
CURSO: LÓGICA DE PROGRAMAÇÃO COM VISUALG
PROFESSOR: HÉLIO ANDRADE

LISTA 01 – Estruturas Sequenciais

1) Faça um algoritmo que receba as duas notas de um aluno e calcule a sua média.

algoritmo "lista01-questao01"
var
nota1, nota2, media : real
inicio
escreva("Digite a primeira nota: ")
leia(nota1)
escreva("Digite a segunda nota: ")
leia(nota2)

media <- (nota1 + nota2) / 2

escreva("A média é: ", media:5:2)


fimalgoritmo

2) A imobiliária Imóbilis vende apenas terrenos retangulares. Faça um algoritmo para ler as
dimensões de um terreno e depois exibir a área do terreno. Sabe-se que: Área de um
retângulo = largura x comprimento.

algoritmo "lista01-questao02"
var
area, largura, comprimento : real
inicio
escreva("Digite a largura (em metros): ")
leia(largura)
escreva("Digite o comprimento (em metros): ")
leia(comprimento)

area <- largura * comprimento

escreva("A área do terreno é: ", area:10:2, " m²")


fimalgoritmo

Prof. Hélio Andrade www.devmaster.club


3) Faça um programa que calcule e apresente o valor do volume de uma lata de óleo,
2
utilizando a fórmula VOLUME = 3,14159 * RAIO * ALTURA.

algoritmo "lista01-questao03"
var
volume, raio, altura : real
inicio
escreva("Digite o valor do RAIO da lata: ")
leia(raio)
escreva("Digite o valor da ALTURA da lata: ")
leia(altura)

volume <- 3.14159 * raio^2 * altura

escreva("O volume da lata é ", volume:8:4, " m³")


fimalgoritmo

4) Faça um algoritmo que leia os valores de COMPRIMENTO, LARGURA e ALTURA e


apresente o valor do volume de uma caixa retangular. Utilize para o cálculo a fórmula
VOLUME = COMPRIMENTO * LARGURA * ALTURA.

algoritmo "lista1-questao4"
var
volume, comprimento, largura, altura : real
inicio
escreva("Digite o COMPRIMENTO em metros: ")
leia(comprimento)
escreva("Digite a LARGURA em metros: ")
leia(largura)
escreva("Digite a ALTURA em metros: ")
leia(altura)

volume <- comprimento * largura * altura

escreva("O volume é igual a ", volume:10:2, " m³")


fimalgoritmo

5) Escreva um algoritmo para ler o nome e a idade de uma pessoa, e exibir quantos dias de
vida ela possui. Considere sempre anos completos, e que um ano possui 365 dias. Ex.:
Uma pessoa com 19 anos possui 6935 dias de vida.

algoritmo "lista01-questao05"
var
idade, dias : real
inicio
escreva("Quantos anos você tem? ")
leia(idade)

dias <- idade * 365

escreva("Você já viveu ", dias, " dias!")


fimalgoritmo

Prof. Hélio Andrade www.devmaster.club


6) Escreva um algoritmo para ler o salário mensal atual de um funcionário e o percentual de
reajuste. Calcular e escrever o valor do novo salário.

algoritmo "lista01-questao06"
var
salario_atual, salario_novo, reajuste : real
inicio
escreva("Digite o salário atual: R$ ")
leia(salario_atual)
escreva("Digite o percentual de aumento (em %): ")
leia(reajuste)

salario_novo <- salario_atual + (reajuste/100) * salario_atual

escreva("O novo salário é: R$ ", salario_novo:10:2)


fimalgoritmo

7) A empresa Hipotheticus paga R$ 50,00 por hora normal trabalhada, e R$ 25,00 por hora
extra. Faça um algoritmo para calcular e imprimir o salário bruto e o salário líquido de um
determinado funcionário. Considere que o salário líquido é igual ao salário bruto
descontando-se 10% de impostos.

algoritmo "lista01-questao07"
var
horas_normais, horas_extras, salario_liquido, salario_bruto :
real
inicio
escreva("Quantas horas foram trabalhadas? ")
leia(horas_normais)
escreva("Quantas horas-extras foram feitas? ")
leia(horas_extras)

salario_bruto <- horas_normais * 50 + horas_extras * 25


salario_liquido <- 0.90 * salario_bruto

escreval("Salário Bruto: R$ ", salario_bruto:10:2)


escreval("Salário Líquido: R$ ", salario_liquido:10:2)
fimalgoritmo

Prof. Hélio Andrade www.devmaster.club


8) O lucro de uma empresa é dado por LUCRO = 10x – 5000, onde x é a quantidade de
produtos vendidos num determinado mês. Elabore um algoritmo que calcule o lucro mensal
dessa empresa.

algoritmo "Calcular Lucro"


var
qtde_produtos : real
lucro : real
inicio
escreva("Digite a quantidade de produtos vendidos: ")
leia(qtde_produtos)

lucro <- 10 * qtde_produtos - 5000

escreval("Resultado --> R$ ", lucro:12:2)


fimalgoritmo

9) O restaurante a quilo Bem-Bão cobra R$ 35,00 por cada quilo de refeição. Escreva um
algoritmo que leia o peso do prato montado pelo cliente (em Kg) e imprima o valor a pagar.
Assuma que a balança já desconte o peso do prato.

algoritmo "lista01-questao09"
var
peso_refeicao, valor_pagar : real
inicio
escreva("Qual щ o peso da refeiчуo (em Kg)? ")
leia(peso_refeicao)

valor_pagar <- peso_refeicao * 35

escreva("O valor a pagar щ: R$ ", valor_pagar:10:2)


fimalgoritmo

10) Escreva um algoritmo para ler o número total de eleitores de um município, o número de
votos brancos, nulos e válidos. Calcular e escrever o percentual que cada um representa
em relação ao total de eleitores.

algoritmo "questao10"
var
eleitores, brancos, nulos, validos: inteiro
inicio
escreva("NÚMERO DE ELEITORES ....: ")
leia(eleitores)
escreva("VOTOS BRANCOS ..........: ")
leia(brancos)
escreva("VOTOS NULOS ............: ")
leia(nulos)

validos <- eleitores - brancos - nulos

limpatela
escreval("TOTAL DE ELEITORES ....: ", eleitores:5)
escreval("VOTOS VÁLIDOS .........: ", 100*validos/eleitores:5:2, "%")
escreval("VOTOS BRANCOS .........: ", 100*brancos/eleitores:5:2, "%")
escreval("VOTOS NULOS ...........: ", 100*nulos/eleitores:5:2, "%")
fimalgoritmo

Prof. Hélio Andrade www.devmaster.club