Sie sind auf Seite 1von 24

Lab 4

Configuring Expanded Switched


Networks

CCNA Lab Guide L4-1


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Objectives
 Configure VTP
 Create VLANs
 Configure trunking
 Configure inter-VLAN routing
 Verify correct operation of inter-VLAN routing
 Examine STP
 Configure RSTP

Lab Diagram

Fa0/0 192.168.xx.2/24

S1/0 192.168.x.102/27 DCE

PxR2
S1/1 192.168.x.202/27
Student PC
Core Router
PxSW 192.168.x.200/27
VLAN 1 192.168.xx.10/24
Fa0/2
Frame Relay
Fa0/1

Fa0/11 Fa0/12 Core Switch


10.1.1.7

S1/1 192.168.x.201/27

PxR1

S1/0 192.168.x.101/27 DTE

To Core Switch Fa0/0 192.168.xx.1/24

TFTP Server
10.1.1.1

L4-2 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Cisco IOS Commands Used In This Lab


Command Description
copy running-config startup-config Saves the running config to NVRAM.
encapsulation type vlan Configures trunking on a router interface.
ip address address mask Assigns interface IP address and subnet
mask.
name name Assigns a name to a VLAN.
network network Specifies which interfaces run RIP.
no shutdown Administratively enables an interface.
router rip Configures an IP RIP routing process.
show interface status Displays status of switch interfaces.
show interfaces [type number] Displays info about an interface.
show ip interface [brief] Displays info about the active IP interfaces.
show ip route Displays the IP routing table.
show running-config Displays the running configuration.
show spanning tree [vlan vlan] Displays spanning tree information.
show version Displays IOS version and hardware
information.
show vlan Displays VLAN information.
show vtp status Displays VTP status.
shutdown Administratively disables an interface.
spanning-tree mode mode Selects the STP mode.
spanning-tree vlan vlan root primary Makes switch the root for a VLAN.
switchport access vlan vlan Sets VLAN assignment of an interface.
switchport mode mode Sets trunking mode of an interface.
vlan vlan Creates a VLAN.
vtp domain name Sets the VTP domain name.
vtp mode mode Sets the VTP mode.

CCNA Lab Guide L4-3


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Procedure
In this lab, you’ll create a new VLAN, assign a switch port to it, configure trunking
between the switch and a router, and test inter-VLAN routing. Following that, you’ll
examine STP, and then implement RSTP.

Note This lab requires that the previous lab was completed correctly. If you have any
doubts, reset to this lab.

Disable Router WAN Connections


1. On both routers, isolate your pod from the WAN core by disabling the Serial 1/0 and
Serial 1/1 interfaces:
PxRy#configure terminal
PxRy(config)#interface serial 1/0
PxRy(config-if)#shutdown
PxRy(config-if)#interface serial 1/1
PxRy(config-if)#shutdown
PxRy(config-if)#end

2. On both routers, verify that the FastEthernet 0/0 interface is “up/up”, and that the Serial
1/0 and Serial 1/1 interfaces are “administratively down”:
PxRy#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.xx.y YES manual up up
BRI0/0 unassigned YES unset administratively down down
BRI0/0:1 unassigned YES unset administratively down down
BRI0/0:2 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 192.168.x.10y YES manual administratively down down
Serial1/1 192.168.x.20y YES manual administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
PxRy#

Enable Switch LAN Connections


3. On your switch, enable the LAN connections to the core by enabling the FastEthernet
0/11 and FastEthernet 0/12:
PxSW#configure terminal
PxSW(config)#interface range fastethernet 0/11 – 12
PxSW(config-if-range)#no shutdown
PxSW(config-if-range)#end

L4-4 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

4. On your switch, verify that the switch’s FastEthernet 0/1, 2, 11 and 12 interfaces are
“connected”:
PxSW#show interfaces status

Port Name Status Vlan Duplex Speed Type


Fa0/1 To PxR1 connected 1 full 100 10/100BaseTX
Fa0/2 To PxR2 connected 1 full 100 10/100BaseTX
Fa0/3 notconnect 1 auto auto 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 notconnect 1 auto auto 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX
Fa0/7 notconnect 1 auto auto 10/100BaseTX
Fa0/8 notconnect 1 auto auto 10/100BaseTX
Fa0/9 notconnect 1 auto auto 10/100BaseTX
Fa0/10 disabled 1 auto auto 10/100BaseTX
Fa0/11 To core switch connected 1 a-full a-100 10/100BaseTX
Fa0/12 To core switch connected 1 a-full a-100 10/100BaseTX
(output omitted)
PxSW#

Note Do not pass this point until you have verified that the router and switch
interfaces are correctly configured

All For One, and One Subnet for All


5. The next thing to do is to create one big broadcast domain (subnet) containing your
switch and both routers. Change R1’s FastEthernet 0/0 address to 10.1.1.1x1/24:
PxR1#configure terminal
PxR1(config)#interface fastethernet 0/0
PxR1(config-if)#ip address 10.1.1.1x1 255.255.255.0
PxR1(config-if)#end

6. Change R2’s FastEthernet 0/0 address to 10.1.1.1x2/24:


PxR2#configure terminal
PxR2(config)#interface fastethernet 0/0
PxR2(config-if)#ip address 10.1.1.1x2 255.255.255.0
PxR2(config-if)#end

7. Change the switch’s VLAN 1 address to 10.1.1.1x3/24:


PxSW#configure terminal
PxSW(config)#interface vlan 1
PxSW(config-if)#ip address 10.1.1.1x3 255.255.255.0
PxSW(config-if)#end

CCNA Lab Guide L4-5


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Verify Connectivity
8. Verify connectivity by pinging between the R1, R2, and the switch to the target
addresses. Indicate success or failure in the table. Once the ARP caches are loaded, all
pings should be successful (if you don’t get a success rate of 100%, try it again):
PxRy#ping 10.1.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5)
PxRy#

R1 R2 Switch TFTP
10.1.1.1x1 10.1.1.1x2 10.1.1.1x3 10.1.1.1
VLAN 1 VLAN 1 VLAN 1 VLAN 1
R1
R2
Switch

Note Do not pass this point until you are pinging between all sources and targets with
100 percent success.

Configure VTP and VLANs


9. View the switch’s VLAN database:
PxSW#show vlan

VLAN Name Status Ports


---- --------------------- ------ --------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
(output omitted)
PxSW#

L4-6 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

At this point only VLAN 1 should exist (ignore the reserved FDDI and Token Ring
VLANs of 1002-1005), and all twenty-four interfaces should be in VLAN 1.
10. Configure your switch as a member of VTP domain “Podx”, where “x” is your pod
number (the VTP domain name is case sensitive). To prevent other pods from modifying
your VLAN database, place your switch into transparent mode:
PxSW#configure terminal
PxSW(config)#vtp domain Podx
PxSW(config)#vtp mode transparent
PxSW(config)#end

11. View the VTP status:


PxSW#show vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 128
Number of existing VLANs : 5
VTP Operating Mode : Transparent
VTP Domain Name : Podx
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest: 0x8E 0x8F 0x04 0xE8 0xA3 0x4B 0xB9 0x32
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
PxSW#

Your switch should belong to VTP domain “Podx”, and the operating mode should be
“transparent”. Note that while in transparent mode, the “Configuration Revision” is hard-
wired to zero.
12. You will now break the network into two parts. VLAN 1 will contain the core and the
switch management address, and VLAN 2 will contain the two routers. VLAN 1 exists by
default, so create VLAN 2 on the switch:
PxSW#configure terminal
PxSW(config)#vlan 2

13. Change the name of VLAN 2 to “Testx”, where “x” is your pod number:
PxSW(config-vlan)#name Testx

14. Place the switch’s FastEthernet 0/1 and 2 interfaces into VLAN 2, and leave config
mode:
PxSW(config-vlan)#interface range fastethernet 0/1 - 2
PxSW(config-if-range)#switchport access vlan 2
PxSW(config-if-range)#end
CCNA Lab Guide L4-7
© Global Knowledge Training LLC
Configuring Expanded Switched Networks

15. View the VLAN database:


PxSW#show vlan

VLAN Name Status Ports


---- -------------------- ------ --------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
2 Testx active Fa0/1, Fa0/2
(output omitted)
PxSW#

You should see that FastEthernet 0/1 and 0/2 are now in VLAN 2, and all other interfaces
are still in VLAN 1.
16. View the switch’s FastEthernet 0/1 VLAN-related information:
PxSW#show interface fastethernet0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 2 (Test4)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
PxSW#

Note that the “show interface switchport” command gives an excellent summary of the
interfaces’ VLAN-related information.
L4-8 CCNA Lab Guide
© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Verify Connectivity
17. Test connectivity by attempting to ping per the chart below. Not all pings should be
successful:
PxRy#ping 10.1.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
PxRy#

R1 R2 Switch TFTP
10.1.1.1x1 10.1.1.1x2 10.1.1.1x3 10.1.1.1
VLAN 2 VLAN 2 VLAN 1 VLAN 1
R1
R2
Switch

Why weren’t all of the pings successful?

18. Change R1’s FastEthernet 0/0 address back to the old value of 192.168.xx.1/24:
PxR1#configure terminal
PxR1(config)#interface fastethernet 0/0
PxR1(config-if)#ip address 192.168.xx.1 255.255.255.0
PxR1(config-if)#end

19. Ping from R1 to R2:


PxR1#ping 10.1.1.1x2

The ping should not be successful. Although the routers’ FastEthernet 0/0 interfaces are
both on VLAN 2, they cannot reach each other, because they are in different Layer-3
broadcast domains (subnets) that are not connected by a router.

CCNA Lab Guide L4-9


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Configure Trunking and Inter-VLAN Routing


20. Configure trunking on the switch’s FastEthernet 0/2:
PxSW#configure terminal
PxSW(config)#interface fastethernet 0/2
PxSW(config-if)#switchport mode trunk
PxSW(config-if)#end

21. Configure R2’s FastEthernet 0/0 as a trunk port by creating a subinterface for VLAN 2.
Use subinterface of 2, and specify IEEE 802.1q encapsulation (tagging):
PxR2#configure terminal
PxR2(config)#interface fastethernet 0/0.2
PxR2(config-subif)#encapsulation dot1q 2

22. Assign R2’s FastEthernet 0/0.2 subinterface an IP address of 192.168.xx.2/24:


PxR2(config-subif)#ip address 192.168.xx.2 255.255.255.0

23. Enable RIP on R2’s FastEthernet 0/0 native VLAN by adding a network statement for
the 10.0.0.0 network (it already has a network statement for 192.168.xx.0):
PxR2(config-subif)#router rip
PxR2(config-router)#network 10.0.0.0
PxR2(config-router)#end

24. View R2’s routing table. R2 should have connected routes for 10.1.1.0/24 (on
FastEthernet 0/0) and 192.168.xx.0/24 (on the FastEthernet 0/0.2 subinterface):
PxR2#show ip route
(output omitted)
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
C 192.168.xx.0/24 is directly connected, FastEthernet0/0.2
(output omitted)
PxR2#

Note that R2 has multiple directly-connected routes associated with an interface, one on
the FastEthernet 0/0 main interface, and another on the FastEthernet 0/0.2 subinterface.
This configuration is sometimes referred to as a “router on a stick” (like a lollipop).

L4-10 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

25. View R1’s routing table. R1 should have a connected route for 192.168.xx.0/24, and a
RIP route via R2 (192.168.xx.2) to 10.1.1.0/24, both via the FastEthernet 0/0 interface:
PxR1#show ip route
(output omitted)
C 192.168.xx.0/24 is directly connected, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 10.1.1.0/24 [120/1] via 192.168.xx.2 00:00:24, FastEthernet0/0
(output omitted)
PxR1#

26. Change the switch’s default gateway to R2’s FastEthernet 0/0 (the VLAN 1 interface)
address (10.1.1.1x2):
PxSW#configure terminal
PxSW(config)#ip default-gateway 10.1.1.1x2
PxSW(config)#end

27. View the switch’s FastEthernet 0/2 trunking information:


PxSW#show interface fastethernet 0/2 trunk

Port Mode Encapsulation Status Native vlan


Fa0/2 on 802.1q trunking 1

Port Vlans allowed on trunk


Fa0/2 1-4094

Port Vlans allowed and active in management domain


Fa0/2 1-2

Port Vlans in spanning tree forwarding state and not pruned


Fa0/2 1-2
PxSW#

The trunking mode should be “on”, encap of “802.1q”, and status “trunking”.

CCNA Lab Guide L4-11


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Verify Connectivity
28. Give RIP a few minutes to converge, and test connectivity. All pings should be
successful:
PxR1#ping 10.1.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
28/29/32 ms
PxR1#

R1 R2 Switch TFTP
192.168.xx.1 10.1.1.1x2 10.1.1.1x3 10.1.1.1
VLAN 2 Trunked VLAN 1 VLAN 1
R1
R2
Switch

Note Do not pass this point until you have verified that full connectivity has been
restored.

Examine Spanning Tree Protocol


29. Display the switch’s running config:
PxSW#show running-config
Building configuration...
(output omitted)
!
vtp domain Podx
vtp mode transparent
!
spanning-tree mode pvst
(output omitted)

Note that the running config says that the STP mode is “pvst” (Per-VLAN Spanning
Tree), which means standard STP (IEEE 802.1d) on a per-VLAN basis (every VLAN has
its own tree, each with its own root).

L4-12 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

30. Your switch is connected to the core switch by two parallel links, which constitutes a
bridging loop. To prevent adverse looping effects, STP automatically blocks one of the
interfaces for user data. Check the spanning tree status for VLAN 1:
PxSW#show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 8193
Address 0012.00c3.5940
Cost 19
Port 11 (FastEthernet0/11)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)


Address 0012.002d.a640
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type


------------- ---- --- --------- -------- ---------------------
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/11 Root FWD 19 128.11 P2p
Fa0/12 Altn BLK 19 128.12 P2p
(output omitted)
Looking at the output for VLAN 1 (the command shows info for all VLANs, VLAN 2’s
is shown below), you can see that the Root ID and Bridge ID’s address fields are
different, indicating that your switch is not the root for VLAN 1 (the root should
currently be the core switch). You can see the current settings for the various timers. You
can also see that FastEthernet 0/2 and 11 are forwarding (FWD), and FastEthernet 0/12 is
blocked (BLK). That’s because FastEthernet 0/2 is the designated port for the segment
connecting the switch to R2, and FastEthernet 0/11 is the switch’s root port. The
FastEthernet 0/12 link runs parallel to the link from FastEthernet 0/11, and was blocked
to prevent looping. Why did FastEthernet 0/11 win the battle? Because the path costs are
equal (both are 19), the port identifiers are not. What about FastEthernet 0/1? That port
doesn’t show up in the VLAN 1 section, because it’s on VLAN 2.
31. Now, look at the spanning tree status for VLAN 2 (continued from above) and note who
the root bridge is.
PxSW#show spanning-tree vlan 2

VLAN0002
Spanning tree enabled protocol ieee
Root ID Priority 32770
Address 0012.002d.a640
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

CCNA Lab Guide L4-13


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Bridge ID Priority 32770 (priority 32768 sys-id-ext 2)


Address 0012.002d.a640
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type


------------- ---- --- --------- -------- ---------------------
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
PxSW#

Now look at the VLAN 2 section, you should see that FastEthernet 0/1 is listed (it’s the
designated port for the segment between the switch and R1), as well as FastEthernet 0/2.
Why does FastEthernet 0/2 appear for both VLANs? Because it’s a trunk!

Measure STP Convergence Time


32. In order to measure the STP convergence time, start a string of pings from R1 to the
TFTP server. To do this, use the extended ping feature of IOS. Just type “ping”, without
specifying a destination (you must be in privileged mode). The router will respond by
asking for additional information. Answer the questions as follows (the “Repeat count” of
a million is not a typo, you want a good long string of pings, and pings are cheap!):
PxR1#ping
Protocol [ip]:<Enter>
Target IP address: 10.1.1.1
Repeat count [5]: 1000000
Datagram size [100]: <Enter>
Timeout in seconds [2]: <Enter>
Extended commands [n]: <Enter>
Sweep range of sizes [n]: <Enter>
Type escape sequence to abort.
Sending 1000000, 100-byte ICMP Echos to 10.1.1.1, timeout is 2
seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! (this goes on and on …)

33. Leave the pings from R1 running, and shut down the switch’s FastEthernet 0/11
interface:
PxSW#configure terminal
PxSW(config)#interface fastethernet 0/11
PxSW(config-if)#shutdown

L4-14 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

34. After the switch’s FastEthernet 0/11 goes down, look at R1’s console display. You
should see an interruption of the stream of pings (it should shift from !’s to dots, and then
back to !’s). Count the number of dots (missed pings):
Number of missed pings:

Since the default ping timeout is 2 seconds, double the number of missed pings to get the
STP convergence time in seconds.
STP convergence time: ____________________________seconds
Based on previous experience with STP on these switches, the expected convergence
time is around 30 seconds.
35. With the pings from R1 still running, bring the switch’s FastEthernet 0/11 interface back
up, leave config mode, and again examine the output on R1:
PxSW(config-if)#no shutdown
PxSW(config-if)#end

36. What happened to R1’s pings after the switch’s FastEthernet 0/0 came back up? Count
the number of dots (missed pings):
Number of missed pings:

Since Cisco’s implementation of ping uses a two-second timeout, double the number of
missed pings to get the STP convergence time in seconds.
STP convergence time: ____________________________seconds
Interestingly, gaining additional connectivity (by bringing a preferred interface on line)
can result in a temporary connectivity loss! For this reason, some people consider STP to
be a “broken” protocol, and avoid it when possible.
37. Stop the pings from R1 using the <CTRL><SHIFT><6> break sequence:
PxR1#<CTRL><SHIFT><6>

Configure RSTP
38. Configure your switch for Rapid Spanning Tree Protocol (IEEE 802.1w):
PxSW#configure terminal
PxSW(config)#spanning-tree mode rapid-pvst

CCNA Lab Guide L4-15


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

39. First, configure it on the switch’s FastEthernet 0/1, which leads to R1:
PxSW(config)#interface fastethernet 0/1
PxSW(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a
single host. Connecting hubs, concentrators, switches, bridges,
etc... to this interface when portfast is enabled, can cause
temporary bridging loops.
Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only


have effect when the interface is in a non-trunking mode.

40. Next, configure portfast on the switch’s FastEthernet 0/2, which leads to R2. Since this
interface is trunking, specify the “trunk” option, and then leave config mode:
PxSW(config-if)#interface fastethernet 0/2
PxSW(config-if)#spanning-tree portfast trunk
%Warning: portfast should only be enabled on ports connected to a
single host. Connecting hubs, concentrators, switches, bridges,
etc... to this interface when portfast is enabled, can cause
temporary bridging loops.
Use with CAUTION
PxSW(config-if)#end

41. Examine the STP configuration on your switch:


PxSW#show spanning-tree
The display should say “Spanning tree enabled protocol rstp”, indicating that your switch
is running RSTP (IEEE 802.1w).
42. Display the switch’s running config:
PxSW#show running-config

Building configuration...
(output omitted)
!
spanning-tree mode rapid-pvst
(output omitted)

L4-16 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Measure RSTP Convergence Time


43. To measure the RSTP convergence time, start another million pings running from R1 to
the TFTP server (10.1.1.1):
PxR1#ping
Protocol [ip]:<Enter>
Target IP address: 10.1.1.1
Repeat count [5]: 1000000
Datagram size [100]: <Enter>
Timeout in seconds [2]: <Enter>
Extended commands [n]: <Enter>
Sweep range of sizes [n]: <Enter>
Type escape sequence to abort.
Sending 1000000, 100-byte ICMP Echos to 10.1.1.1, timeout is 2
seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! (this goes on and on …)

44. Leave the pings from R1 running, and shut down the switch’s FastEthernet 0/11
interface:
PxSW#configure terminal
PxSW(config)#interface fastethernet 0/11
PxSW(config-if)#shutdown

45. After the switch’s FastEthernet 0/11 goes down, you might see an interruption on the
stream of pings (shift from !’s to dots, and back to !’s). Count the number of missed
pings.
Number of missed pings:

Since the default ping timeout is 2 seconds, double the number of missed pings to get the
RSTP convergence time in seconds.
RSTP convergence time: ____________________________seconds
How does this compare with the previous result?

46. With the pings from R1 still running, bring the switch’s FastEthernet 0/11 interface back
up:
PxSW(config-if)#no shutdown

CCNA Lab Guide L4-17


© Global Knowledge Training LLC
Configuring Expanded Switched Networks
47. What happened to R1’s pings after the switch’s FastEthernet 0/0 came back up? Count
the number of dots (missed pings).
Number of missed pings:

Double the number of missed pings to get the RSTP convergence time in seconds.
RSTP convergence time: ____________________________seconds
How does this compare to the time for regular STP?

What is your opinion of RSTP versus STP?

48. Stop the pings from R1 using the <CTRL><SHIFT><6> break sequence:
PxR1#<CTRL><SHIFT><6>

Configure Primary Root Switch


49. Make your switch the primary root for VLAN 2, and leave config mode:
PxSW#configure terminal
PxSW(config)#spanning-tree vlan 2 root primary
PxSW(config)#end

50. Examine the STP configuration on your switch for VLAN 2 and compare it to the
information you obtained from Step 31. Did the root bridge change?
PxSW#show spanning-tree vlan 2

VLAN0002
Spanning tree enabled protocol rstp
Root ID Priority 24578
Address 0012.002d.a640
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24578 (priority 24576 sys-id-ext 2)


Address 0012.002d.a640
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type


------------- ---- --- --------- -------- ---------------------
Fa0/1 Desg FWD 19 128.1 Edge P2p
Fa0/2 Desg FWD 19 128.2 Edge P2p
L4-18 CCNA Lab Guide
© Global Knowledge Training LLC
Configuring Expanded Switched Networks

PxSW#

Note that your switch is the root for VLAN 2 (and it says so), with a priority of well
below the default of 32,768.

Save the Configurations


51. Save the running configuration to NVRAM on all devices under your control. When it
asks you to confirm the destination (startup-config), press <Enter>:
hostname#copy running-config startup-config

STOP! You have completed this lab, you may choose to explore the information that
you entered in more detail before moving on to another lab. Good job!

CCNA Lab Guide L4-19


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Review Questions
1. Which command configures trunking on a switch interface?

2. Which commands configure trunking on a router interface?

3. Which command creates a new VLAN?

4. Which command assigns a name to a VLAN?

5. Which command shows the VLAN database?

6. Which commands show to which VLAN an interface is assigned?

7. Which command displays trunking status of a switch interface?

8. Which command shows the IP address of a subinterface?

9. What are the two options for trunking encapsulation/tagging?

10. What is the default VTP operational mode?

L4-20 CCNA Lab Guide


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

Sample Configurations
hostname PxSW
!
vtp domain Podx
vtp mode transparent
!
spanning-tree mode rapid-pvst
!
spanning-tree vlan 2 priority 24576
!
vlan 2
name Testx
!
interface FastEthernet0/1
description To PxR1
switchport access vlan 2
switchport mode access
speed 100
duplex full
spanning-tree portfast
!
interface FastEthernet0/2
description To PxR2
switchport access vlan 2
switchport mode trunk
speed 100
duplex full
spanning-tree portfast trunk
!
interface FastEthernet0/11
description To core switch
switchport mode access
!
interface FastEthernet0/12
description To core switch
switchport mode access
!
interface Vlan1
ip address 10.1.1.1x3 255.255.255.0
no ip route-cache
!
ip default-gateway 10.1.1.1x2
!
end

hostname PxR1
!
interface FastEthernet0/0
CCNA Lab Guide L4-21
© Global Knowledge Training LLC
Configuring Expanded Switched Networks
description To PxSW
ip address 192.168.xx.1 255.255.255.0
speed 100
full-duplex
!
interface Serial1/0
description To PxR2
bandwidth 128
ip address 192.168.x.101 255.255.255.224
shutdown
no fair-queue
!
interface Serial1/1
description To core router
bandwidth 128
ip address 192.168.x.201 255.255.255.224
encapsulation frame-relay
shutdown
!
router rip
version 2
network 192.168.x.0
network 192.168.xx.0
no auto-summary
!
end

hostname PxR2
!
interface FastEthernet0/0
description To PxSW
ip address 10.1.1.1x2 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.xx.2 255.255.255.0
no snmp trap link-status
!
interface Serial1/0
description To PxR1
bandwidth 128
ip address 192.168.x.102 255.255.255.224
shutdown
no fair-queue
clock rate 128000
no dce-terminal-timing-enable
!
interface Serial1/1
L4-22 CCNA Lab Guide
© Global Knowledge Training LLC
Configuring Expanded Switched Networks

description To core router


bandwidth 128
ip address 192.168.x.202 255.255.255.224
encapsulation frame-relay
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.x.0
network 192.168.xx.0
no auto-summary
!
end

CCNA Lab Guide L4-23


© Global Knowledge Training LLC
Configuring Expanded Switched Networks

L4-24 CCNA Lab Guide


© Global Knowledge Training LLC

Das könnte Ihnen auch gefallen