Sie sind auf Seite 1von 23

CCNP ROUTE

BGP Aggregate Address ............................................................................................................. 2


BGP ORF ..................................................................................................................................... 4
BGP Conditional Advertisement ................................................................................................8
Preparación N3 ........................................................................................................................12

1
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

BGP Aggregate Address

Setup: Configure el direccionamiento mostrado. Utilice topología R2.unl.


 Configure eBGP entre los routers R1 y R2 correspondientes a los sistemas autónomos AS100 y AS200. Las
sesiones BGP se deben establecer utilizando las interfaces loopback0. No utilice eBGP multihop.

R1
interface loopback0
ip address 1.1.1.1 255.255.255.0

ip route 2.2.2.0 255.255.255.0 10.1.12.2

R2
interface loopback0
ip address 2.2.2.2 255.255.255.0

ip route 1.1.1.0 255.255.255.0 10.1.12.1

R1#ping 2.2.2.2 source 1.1.1.1


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/25/32 ms

R1
router bgp 100
bgp router-id 1.1.1.1
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 disable-connected-check
neighbor 2.2.2.2 update-source Loopback0

address-family ipv4
neighbor 2.2.2.2 activate
exit-address-family

R2
router bgp 200
bgp router-id 2.2.2.2
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 disable-connected-check
neighbor 1.1.1.1 update-source Loopback0

2
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

address-family ipv4
neighbor 1.1.1.1 activate
exit-address-family

 En R1 cree las subredes 100.1.0.0/24 a 100.1.7.0/24. Redistribuyalas dentro de BGP. Utilcie el route-map
RED-CON.

R1
interface Loopback100
ip address 100.1.1.1 255.255.255.0 secondary
ip address 100.1.2.1 255.255.255.0 secondary
ip address 100.1.3.1 255.255.255.0 secondary
ip address 100.1.4.1 255.255.255.0 secondary
ip address 100.1.5.1 255.255.255.0 secondary
ip address 100.1.6.1 255.255.255.0 secondary
ip address 100.1.7.1 255.255.255.0 secondary
ip address 100.1.0.1 255.255.255.0

route-map RED-CON permit 10


match interface Loopback100

router bgp 100


address-family ipv4
redistribute connected route-map RED-CON

R2#show ip bgp
BGP table version is 9, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*> 100.1.0.0/24 1.1.1.1 0 0 100 ?
*> 100.1.1.0/24 1.1.1.1 0 0 100 ?
*> 100.1.2.0/24 1.1.1.1 0 0 100 ?
*> 100.1.3.0/24 1.1.1.1 0 0 100 ?
*> 100.1.4.0/24 1.1.1.1 0 0 100 ?
*> 100.1.5.0/24 1.1.1.1 0 0 100 ?
*> 100.1.6.0/24 1.1.1.1 0 0 100 ?
*> 100.1.7.0/24 1.1.1.1 0 0 100 ?

R1
router bgp 100
address-family ipv4
aggregate-address 100.1.0.0 255.255.248.0 summary-only

3
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

R2#show ip bgp
BGP table version is 18, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 100.1.0.0/21 1.1.1.1 0 0 100 i

R1#show ip bgp regexp ^$


BGP table version is 21, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
s> 100.1.0.0/24 0.0.0.0 0 32768 ?
*> 100.1.0.0/21 0.0.0.0 32768 i
s> 100.1.1.0/24 0.0.0.0 0 32768 ?
s> 100.1.2.0/24 0.0.0.0 0 32768 ?
s> 100.1.3.0/24 0.0.0.0 0 32768 ?
s> 100.1.4.0/24 0.0.0.0 0 32768 ?
s> 100.1.5.0/24 0.0.0.0 0 32768 ?
s> 100.1.6.0/24 0.0.0.0 0 32768 ?
s> 100.1.7.0/24 0.0.0.0 0 32768 ?

BGP ORF
 En R2 cree y publique los prefijos 200.1.1.0/24, 201.1.1.0/24 y 202.1.1.0/24.
 R1 debe indicar a R2 que solo necesita el prefijo 202.1.1.0/24.

El problema con esta configuración es que las actualizaciones viajan, se reciben, el router determina si existe algún
filtro y las bloquea. Esto implica gasto de BW, recursos del router (memoria, CPU).
Una forma efectiva es utilizar recursos de red es con ORF.

R2
interface Loopback200
ip address 200.1.1.2 255.255.255.0

interface Loopback201
ip address 201.1.1.2 255.255.255.0

interface Loopback202
ip address 202.1.1.2 255.255.255.0

router bgp 200


address-family ipv4
network 200.1.1.0
network 201.1.1.0

4
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

network 202.1.1.0

R2#show ip bgp regexp ^$


BGP table version is 21, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 200.1.1.0 0.0.0.0 0 32768 i
*> 201.1.1.0 0.0.0.0 0 32768 i
*> 202.1.1.0 0.0.0.0 0 32768 i

R1#show ip bgp regexp ^200$


BGP table version is 21, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 200.1.1.0 2.2.2.2 0 0 200 i
*> 201.1.1.0 2.2.2.2 0 0 200 i
*> 202.1.1.0 2.2.2.2 0 0 200 i

R1
router bgp 100
address-family ipv4
neighbor 2.2.2.2 capability orf prefix-list send

R2
router bgp 200
address-family ipv4
neighbor 1.1.1.1 capability orf prefix-list receive

R1#debug ip bgp updates


BGP updates debugging is on for address family: IPv4 Unicast

R1
ip prefix-list SOLO-202 permit 202.1.1.0/24

router bgp 100


address-family ipv4
neighbor 2.2.2.2 prefix-list SOLO-202 in

R1#clear ip bgp 2.2.2.2 in prefix-filter

R1#
*Jun 6 11:36:03.023: BGP: nbr_topo global 2.2.2.2 IPv4 Unicast:base (0x6AD46428:1) rcvd Refresh Start-of-RIB
*Jun 6 11:36:03.023: BGP: nbr_topo global 2.2.2.2 IPv4 Unicast:base (0x6AD46428:1) refresh_epoch is 5

5
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

*Jun 6 11:36:03.059: BGP(0): 2.2.2.2 rcvd UPDATE w/ attr: nexthop 2.2.2.2, origin i, metric 0, merged path 20
0, AS_PATH
*Jun 6 11:36:03.063: BGP(0): 2.2.2.2 rcvd 202.1.1.0/24...duplicate ignored
*Jun 6 11:36:03.063: BGP(0): 2.2.2.2 rcv UPDATE about 200.1.1.0/24 -- withdrawn
*Jun 6 11:36:03.067: BGP(0): 2.2.2.2 rcv UPDATE about 201.1.1.0/24 -- withdrawn
*Jun 6 11:36:03.067: BGP: nbr_topo global 2.2.2.2 IPv4 Unicast:base (0x6AD46428:1) rcvd Refresh End-of-RIB

R1#show ip bgp neighbors 2.2.2.2 received-routes


% Inbound soft reconfiguration not enabled on 2.2.2.2

R1
router bgp 100
address-family ipv4
neighbor 2.2.2.2 soft-reconfiguration inbound

R1#show ip bgp neighbors 2.2.2.2 received-routes


BGP table version is 35, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 202.1.1.0 2.2.2.2 0 0 200 i

Total number of prefixes 1

R2#show ip bgp neighbors 1.1.1.1 advertised-routes


BGP table version is 25, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*> 202.1.1.0 0.0.0.0 0 32768 i
Total number of prefixes 1

6
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

 No borre configuraciones anteriores.


 Realice este laboratorio para IPv6 utilizando la siguiente topología y esquema de direccionamiento:

7
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

BGP Conditional Advertisement

Setup: Cree el direccionamiento mostrado. Utilice topología 3R.unl.


 Configure eBGP entre AS100-AS200, y AS100-AS300.
 En R1 cree y publique dentro de BGP el prefijo 172.16.1.0/24.
 En R3 cree y publique dentro de BGP el prefijo 172.16.3.0/24.
 Configure una característica de BGP de manera que si R1 recibe la red 172.16.3.0/24 desde R3 tengamos la
siguiente salida en R2:
R2#show ip bgp
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 172.16.3.0/24 10.1.12.1 0 100 300 i
 En caso que R1 no reciba la red 172.16.3.0/24 desde R3 (AS300) en R2 tengamos la siguiente salida:
R2#show ip bgp
BGP table version is 6, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.0/24 10.1.12.1 0 0 100 i

8
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

R1
router bgp 100
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 10.1.12.2 remote-as 200
neighbor 10.1.13.3 remote-as 300

R2
router bgp 200
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 10.1.12.1 remote-as 100

R3
router bgp 300
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 10.1.13.1 remote-as 100

R1#show ip bgp summary


BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


10.1.12.2 4 200 4 4 1 0 0 00:01:27 0
10.1.13.3 4 300 4 2 1 0 0 00:00:12 0

R3
interface Loopback172
ip address 172.16.3.3 255.255.255.0

router bgp 300


network 172.16.3.0 mask 255.255.255.0

R1
interface Loopback172
ip address 172.16.1.1 255.255.255.0

router bgp 100


network 172.16.1.0 mask 255.255.255.0

route-map COMM permit 10


set community 100:300 Commented [NMT1]: Le agrega la comunidad 100:300 a los
prefijos que vengan desde R3.

router bgp 100


neighbor 10.1.13.3 route-map COMM in

R1#show ip bgp 172.16.3.0


BGP routing table entry for 172.16.3.0/24, version 4
Paths: (1 available, best #1, table default)
Advertised to update-groups:
1
Refresh Epoch 2

9
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

300
10.1.13.3 from 10.1.13.3 (3.3.3.3)
Origin IGP, metric 0, localpref 100, valid, external, best
Community: 100:300
rx pathid: 0, tx pathid: 0x0

R2#show ip bgp
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 172.16.1.0/24 10.1.12.1 0 0 100 i
*> 172.16.3.0/24 10.1.12.1 0 100 300 i

R2#show ip bgp 172.16.3.0 Commented [NMT2]: Sin comunidad porque no hemos


BGP routing table entry for 172.16.3.0/24, version 2 utilizado send-community.

Paths: (1 available, best #1, table default)


Not advertised to any peer
Refresh Epoch 3
100 300
10.1.12.1 from 10.1.12.1 (1.1.1.1)
Origin IGP, localpref 100, valid, external, best
rx pathid: 0, tx pathid: 0x0

R1
ip community-list 10 permit 100:300

ip prefix-list AS300-TRACK seq 5 permit 172.16.3.0/24

ip prefix-list PFX-LOCAL seq 5 permit 172.16.1.0/24

route-map AS200-OUT permit 10


match ip address prefix-list PFX-LOCAL

route-map AS300-IN permit 10


match ip address prefix-list AS300-TRACK
match community 10

router bgp 100


neighbor 10.1.12.2 advertise-map AS200-OUT non-exist-map AS300-IN Commented [NMT3]: Publique el prefijo 172.16.1.0 (de R1)
siempre que el prefijo 172.16.3.0/24 (de R3) no sea alcanzable.

R2#show ip bgp
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

10
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

Network Next Hop Metric LocPrf Weight Path


*> 172.16.3.0/24 10.1.12.1 0 100 300 i

R1(config)#router bgp 100


R1(config-router)#neighbor 10.1.13.3 shutdown

R2#show ip bgp
BGP table version is 6, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.0/24 10.1.12.1 0 0 100 i

11
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

Preparación N3

Setup: Cree el direccionamiento mostrado. Utilice la topología LAB BGP 3.unl.


 Forme adyacencia EIGRP 1 entre R1 y R2 publicando dentro de EIGRP las interfaces loopback0 de cada
router. Compruebe que solo se publiquen las redes indicadas.

R1
router eigrp 1
network 1.1.1.0 0.0.0.255
network 10.1.12.0 0.0.0.255

R2
router eigrp 1
network 2.2.2.0 0.0.0.255
network 10.1.12.0 0.0.0.255

R2#sh ip eigrp neighbors


EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.12.1 Et0/0 12 00:00:03 17 102 0 3

R1#ping 2.2.2.2 source 1.1.1.1


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

12
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

 Configure iBGP AS1 entre R1 y R2 tomando como dirección de origen la interface loopback0.

R1
router bgp 1
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0

R2
router bgp 1
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0

R2#show ip bgp summary


BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


1.1.1.1 4 1 5 5 1 0 0 00:01:47 0

 En R2 redistribuya las redes 200.1.X.0/24 dentro de BGP. Compruebe que solo se redistribuyan los prefijos
indicados.

R2
route-map CON-200 permit 10
match interface Loopback200

router bgp 1
redistribute connected route-map CON-200

R1#show ip bgp
BGP table version is 9, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*>i 200.1.0.0 2.2.2.2 0 100 0 ?
*>i 200.1.1.0 2.2.2.2 0 100 0 ?
*>i 200.1.2.0 2.2.2.2 0 100 0 ?
*>i 200.1.3.0 2.2.2.2 0 100 0 ?
*>i 200.1.4.0 2.2.2.2 0 100 0 ?
*>i 200.1.5.0 2.2.2.2 0 100 0 ?
*>i 200.1.6.0 2.2.2.2 0 100 0 ?
13
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

*>i 200.1.7.0 2.2.2.2 0 100 0?

 Forme sesiones eBGP entre R1-R3, R2-R3, R2-R4, y R4-R3.

R1
router bgp 1
neighbor 10.1.13.3 remote-as 3

R3
router bgp 3
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 10.1.13.1 remote-as 1
neighbor 10.1.23.2 remote-as 1
neighbor 10.1.34.4 remote-as 4

R2
router bgp 1
neighbor 10.1.23.3 remote-as 3
neighbor 10.1.24.4 remote-as 4

R4
router bgp 4
bgp router-id 4.4.4.4
neighbor 10.1.24.2 remote-as 1
neighbor 10.1.34.3 remote-as 3

R2#show ip bgp summary


BGP router identifier 2.2.2.2, local AS number 1
BGP table version is 9, main routing table version 9
8 network entries using 1184 bytes of memory
8 path entries using 512 bytes of memory
1/1 BGP path/bestpath attribute entries using 136 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1832 total bytes of memory
BGP activity 8/0 prefixes, 8/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


1.1.1.1 4 1 28 29 9 0 0 00:22:34 0
10.1.23.3 4 3 6 6 9 0 0 00:01:21 0
10.1.24.4 4 4 2 6 9 0 0 00:00:33 0

R3#show ip bgp summary


BGP router identifier 3.3.3.3, local AS number 3
BGP table version is 9, main routing table version 9
8 network entries using 1184 bytes of memory
16 path entries using 1024 bytes of memory
2/1 BGP path/bestpath attribute entries using 272 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2504 total bytes of memory
14
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

BGP activity 8/0 prefixes, 16/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


10.1.13.1 4 1 13 12 9 0 0 00:07:45 8
10.1.23.2 4 1 6 7 9 0 0 00:01:33 8
10.1.34.4 4 4 2 6 9 0 0 00:00:32 0

 R2 debe sumarizar los prefijos 200.1.X.0/24 y solo enviar la sumarización a sus vecinos.

R2
router bgp 1
aggregate-address 200.1.0.0 255.255.248.0 summary-only

R1#show ip bgp
BGP table version is 37, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*>i 200.1.0.0/21 2.2.2.2 0 100 0i

 R3 debe acceder al prefijo sumarizado utilizando en la tarea anterior utilizando como próximo salto a AS4
(10.1.34.4). R1 debe enviar a R3 una métrica de 100, R2 debe enviar una métrica de 2000 a R3, y R4 debe
enviar una métrica de 1. Al final de esta tarea R3 debe tener como mejor camino al prefijo sumarizado a
través de R4.

R3#show ip bgp
BGP table version is 40, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


* 200.1.0.0/21 10.1.13.1 01i
* 10.1.34.4 041i
*> 10.1.23.2 0 01i

R1
route-map MED permit 10
set metric 100

router bgp 1
neighbor 10.1.13.3 route-map MED out

15
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

R2
route-map MED permit 10
set metric 2000

router bgp 1
neighbor 10.1.23.3 route-map MED out

R4
route-map MED permit 10
set metric 1

router bgp 4
neighbor 10.1.34.3 route-map MED out

R3#show ip bgp
BGP table version is 41, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 200.1.0.0/21 10.1.13.1 100 01i
* 10.1.34.4 1 041i
* 10.1.23.2 2000 01i

R3
router bgp 3
bgp always-compare-med
bgp bestpath as-path ignore

R3#clear ip bgp *

R3#show ip bgp
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 200.1.0.0/21 10.1.34.4 1 041i
* 10.1.23.2 2000 01i
* 10.1.13.1 100 01i

16
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

 Autentifique la session iBGP entre R1 y R2 utilizando password class.

R1
router bgp 1
neighbor 2.2.2.2 password class

R2
router bgp 1
neighbor 1.1.1.1 password class

 Realice el mismo laboratorio anterior para la AFI IPv6 utilizando el siguiente direccionamiento:

17
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

BGP Route-Reflector
R2----------------------------R1----------------------------R3
10.1.12.0/24 10.1.13.0/24
<-----------------------------AS1----------------------------->
 Cree el direccionamiento mostrado.
 Configure EIGRP 1 en todos los routers del dominio BGP. Publique además las interfaces loopback0s.
 Compruebe que tenga conectividad end to end.

R1
interface Loopback0
ip address 1.1.1.1 255.255.255.0

router eigrp 1
network 1.0.0.0
network 10.0.0.0

R2
interface Loopback0
ip address 2.2.2.2 255.255.255.0

router eigrp 1
network 2.0.0.0
network 10.0.0.0

R3
interface Loopback0
ip address 3.3.3.3 255.255.255.0

router eigrp 1
network 3.0.0.0
network 10.0.0.0

R1#sh ip eigrp neighbors


EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.13.3 Fa0/1 13 00:19:34 66 396 0 3
0 10.1.12.2 Fa0/0 14 00:20:05 30 180 0 4

R3#sh ip route eigrp


Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/156160] via 10.1.13.1, 00:19:46, FastEthernet0/1
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/158720] via 10.1.13.1, 00:19:46, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.12.0/24 [90/30720] via 10.1.13.1, 00:19:46, FastEthernet0/1

18
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

 Configure iBGP entre R1-R2, y R1-R3 estableciendo las sesiones en base a la loopback0 de cada router.

R1
router bgp 1
bgp router-id 1.1.1.1
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 update-source Loopback0

R2
router bgp 1
bgp router-id 2.2.2.2
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0

R3
router bgp 1
bgp router-id 3.3.3.3
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0

R1#sh bgp summary


BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1 4 3 1 0 0 00:00:59 0
3.3.3.3 4 1 2 2 1 0 0 00:00:09 0

 Cree y publique en BGP los siguientes prefijos:


R1- 11.1.1.1/24
R3- 33.3.3.3/24
R2- 22.2.2.2/24

R1
interface Loopback1
ip address 11.1.1.1 255.255.255.0

router bgp 1
network 11.1.1.0 mask 255.255.255.0

R2
interface Loopback1
ip address 22.2.2.2 255.255.255.0

router bgp 1
network 22.2.2.0 mask 255.255.255.0

19
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

R3
interface Loopback1
ip address 33.3.3.3 255.255.255.0

router bgp 1
network 33.3.3.0 mask 255.255.255.0

R3#show ip bgp
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*>i 11.1.1.0/24 1.1.1.1 0 100 0 i
*> 33.3.3.0/24 0.0.0.0 0 32768 i

R2#show ip bgp
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*>i 11.1.1.0/24 1.1.1.1 0 100 0 i
*> 22.2.2.0/24 0.0.0.0 0 32768 i

Como Podemos observar en la salida anterior, R2 y R3 no han instalado todos los prefijos publicados por la regla de
la sincronización.
 Verificamos la tabla de enrutamiento para BGP.

R2#sh ip route bgp


Gateway of last resort is not set
11.0.0.0/24 is subnetted, 1 subnets
B 11.1.1.0 [200/0] via 1.1.1.1, 00:00:23

R3#sh ip route bgp


Gateway of last resort is not set
11.0.0.0/24 is subnetted, 1 subnets
B 11.1.1.0 [200/0] via 1.1.1.1, 00:00:47

20
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

 Configure router reflector en el servidor.


 Verifique la tabla BGP y de enrutamiento.

Para que los peers iBGP intercambien rutas entre ellos, debe existir malla completa, o utilizar Route Reflectors.
Veneficios de route reflectors:
Reducen el numero de sesiones BGP.
No se necesita malla completa.
El RR refleja todas las rutas lo que implica que el RR debe conocer la tabla con todas las redes.

R1
router bgp 1
neighbor 2.2.2.2 route-reflector-client
neighbor 3.3.3.3 route-reflector-client

R2#show ip bgp
BGP table version is 20, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*>i 11.1.1.0/24 1.1.1.1 0 100 0 i
*> 22.2.2.0/24 0.0.0.0 0 32768 i
*>i 33.3.3.0/24 3.3.3.3 0 100 0 i

R3#show ip bgp
BGP table version is 18, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*>i 11.1.1.0/24 1.1.1.1 0 100 0 i
*>i 22.2.2.0/24 2.2.2.2 0 100 0 i
*> 33.3.3.0/24 0.0.0.0 0 32768 i

R1#show ip bgp 33.3.3.0


BGP routing table entry for 33.3.3.0/24, version 16
Paths: (1 available, best #1, table default)
Advertised to update-groups:
4
Refresh Epoch 1
Local, (Received from a RR-client)
3.3.3.3 (metric 156160) from 3.3.3.3 (3.3.3.3)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx pathid: 0, tx pathid: 0x0

21
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

R1#show ip bgp 22.2.2.0


BGP routing table entry for 22.2.2.0/24, version 18
Paths: (1 available, best #1, table default)
Advertised to update-groups:
4
Refresh Epoch 1
Local, (Received from a RR-client)
2.2.2.2 (metric 156160) from 2.2.2.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx pathid: 0, tx pathid: 0x0

 Para oprtimizar la red BGP, reconfigure el RR utilizando peer group.

R1(config)#router bgp 1
R1(config-router)#no neighbor 3.3.3.3 route-reflector-client
R1(config-router)#no neighbor 2.2.2.2 route-reflector-client

R1
router bgp 1
bgp router-id 1.1.1.1
network 11.1.1.0 mask 255.255.255.0
neighbor AS1 peer-group
neighbor AS1 remote-as 1
neighbor AS1 update-source Loopback0
neighbor AS1 route-reflector-client
no neighbor 2.2.2.2
no neighbor 3.3.3.3
neighbor 2.2.2.2 peer-group AS1
neighbor 3.3.3.3 peer-group AS1

R1#show ip bgp 22.2.2.0


BGP routing table entry for 22.2.2.0/24, version 26
Paths: (1 available, best #1, table default)
Advertised to update-groups:
6
Refresh Epoch 1
Local, (Received from a RR-client)
2.2.2.2 (metric 156160) from 2.2.2.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx pathid: 0, tx pathid: 0x0

R1#show ip bgp 33.3.3.0


BGP routing table entry for 33.3.3.0/24, version 25
Paths: (1 available, best #1, table default)
Advertised to update-groups:
6
Refresh Epoch 1
Local, (Received from a RR-client)
3.3.3.3 (metric 156160) from 3.3.3.3 (3.3.3.3)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx pathid: 0, tx pathid: 0x0

22
TLDR © 2018 Nicolás Montero Torrealba
CCNP ROUTE

23
TLDR © 2018 Nicolás Montero Torrealba

Das könnte Ihnen auch gefallen