Sie sind auf Seite 1von 49

INTRODUCCIÓN

INTRODUCCIÓN
CARACTERÍSTICAS
main() {
//variables locales
//secuencia de sentencias
}
f1() {
//variables locales
//secuencia de sentencias
}
f2() {
//variables locales
//secuencia de sentencias
}
.
:
fN() {
//variables locales
//secuencia de sentencias
}
PSEUDOCÓDIGO
programa progEjemplo
/* inicialmente no usaremos variables globales */
[variables globales]
/* declaración de funciones */
función cuadrado( variable )
entero i_var
i_var <- variable * variable
devolver i_var
fin función
/* programa principal */
inicio
entero valor
leer valor
entero resultado
resultado <- cuadrado ( valor )
escribir "el cuadrado de " + valor + " es : " + resultado
fin
CÓDIGO EN C
#include <iostream>
using namespace std;
/* declaración de funciones */
int cuadrado( int variable ) {
int i_var;
i_var = variable * variable;
return i_var;
}
/* programa principal */

main() {
int valor;
cin >> valor;
int resultado;
resultado = cuadrado( valor );
cout << "el cuadrado de " << valor << " es : " << resultado;
}
COMENTARIOS

/* comentario */

instrucción /* comentario */
TIPOS DE DATOS EN
PSEUDOCÓDIGO
Tipo
caracter
entero
flotante
TIPOS DE DATOS EN C
Tipo Tamaño de bits Rango
char 8 0 a 225
int 16 -32768 a 32767
float 32 3.4e-38 a 3.4e38
double 64 1.7e-308 a 1.7e-308
void 0 sin valor
MODIFICADORES EN C
Modificador Significado
signed con signo
unsigned sin signo
long largo
short corto
CONSTANTES EN C
Tipo de dato Ejemplo de constante
char 'a', '\n', '9'
int 1, 123, 21000, -234
long int 35000, -35
float 123.23, 4,34e-3
double 123.23, 12312333, -0.9876324
ASIGNACIÓN
PSEUDOCÓDIGO:
var1 <- var2
var1 <- cons1
var1 <- expr1
LENGUAJE C
var1 = var2;
var1 = cons1;
var1 = expr1;
OPERADORES ARITMÉTICOS
OPERADOR SIGNIFICADO
+ Suma
- Resta
* Multiplicación
/ División
% Módulo (residuo de una división)
OPERADORES LÓGICOS
OPERADOR SIGNIFICADO
& Y (a nivel de bits)
&& Y (a nivel de condición)
| O (a nivel de bits)
|| O (a nivel de condición)
~ No (a nivel de bits)
! No (a nivel de condición)
^ O exclusivo (XOR, a nivel de bits)
OPERADORES RELACIONALES
OPERADOR SIGNIFICADO
< Menor
> Mayor
<= Menor o igual
>= Mayor o igual
= Igual
!= Distinto
JERARQUÍA DE OPERADORES
JERARQUÍA OPERADOR
mayor ( ) [ ] -> .
! ~ ++ -- - (tipo) * & sizeof
*/%
+-
<< >>
< <= > >=
== !=
&
^
|
&&
||
?
menor = += -= *= /=
ENTRADA
PSEUDOCÓDIGO:
leer var1
leer var1, var2
LENGUAJE C
cin >> var1;
cin >> var1 >> var2;
SALIDA
PSEUDOCÓDIGO:
escribir var1
escribir var1 + “cad”
LENGUAJE C
cout << var1;
cout << var1 << “cad”;
CONDICIONAL SIMPLE
PSEUDOCÓDIGO:
si (condición)
entonces hacer
...
fin si LENGUAJE C
if (condición) {
...
}
CONDICIONAL SIMPLE
PSEUDOCÓDIGO:
si (condición)
entonces hacer
... LENGUAJE C
sino hacer if (condición) {
... ...
fin si } else {
...
}
CONDICIONAL MÚLTIPLE
LENGUAJE C:
switch (var) {
case cons1:
...
break;
case cons2:
...
break;
...
default:
...
}
BUCLE MIENTRAS
PSEUDOCÓDIGO:
mientras
(condición) hacer
...
fin mientras LENGUAJE C
while(condición) {
...
}
BUCLE REPETIR - MIENTRAS
PSEUDOCÓDIGO:
repetir
...
mientras (condición) LENGUAJE C
do {
...
} while (condición);
BUCLE PARA
PSEUDOCÓDIGO:
para i<-1 hasta n
hacer
...
fin para LENGUAJE C
for (i=1; i<=n; i++) {
...
}
ESTRUCTURA BÁSICA
PSEUDOCÓDIGO:
funcion nombre (parámetros)
...
fin funcion

LENGUAJE C:
tipo_dato_retorna nombre (parámetros) {
...
}
ARREGLO UNIDIMENSIONAL
PSEUDOCÓDIGO:
tipo nombre_de_variable[tamaño]

LENGUAJE C:
tipo nombre_de_variable[tamaño];
EJEMPLO ARREGLO
UNIDIMENSIONAL
int v[5];
1
v[0] = 1;

v[1] = 2; 1 2

v[2] = 3; 1 2 3

v[3] = 4; 1 2 3 4

v[4] = 5; 1 2 3 4
ARREGLO BIDIMENSIONAL
PSEUDOCÓDIGO:
tipo nombre_de_variable[tamaño1][tamaño2]

LENGUAJE C:
tipo nombre_de_variable[tamaño1][tamaño2];
EJEMPLO ARREGLO
BIDIMENSIONAL
int v[2][2];
1
v[0][0] = 1;
1 2
v[0][1] = 2;
1 2
v[1][0] = 3; 3

1 2
v[1][1] = 4; 3 4
CODEBLOCKS
INSTALACIÓN EN UBUNTU (LINUX)