Sie sind auf Seite 1von 3

FACULTAD DE INGENIERIA DE SISTEMAS, CÓMPUTO y TELECOMUNICACIONES

2016 – II

ASIGNATURA: ALGORÍTMICA TUR/SEC: 1 A CICLO: III


PROFESORA: Mg. EVELYN AYALA Ñ. DURACION: 50 minutos Práctica No 01

APELLIDOS Y NOMBRES: ___________________________________________

INSTRUCCIONES

1. No se permite el uso de otros recursos. 4. La práctica es personal.


2. Escribir en forma clara. 5. Los celulares deben estar apagados.
3. Las respuestas serán con lapicero o lápiz. 6. Prohibido el préstamo de cualquier material.

I. DECLARAR LAS EXPRESIONES ALGORÍTMICAS DE ACUERDO A LOS SIGUIENTES


ENUNCIADOS: (2 ptos. c/u)
a. x2 + bx + c = (x^2) + (b*x) + c

3−√5𝑧+1
b. = (3 – raiz(5*z + 1)) / 3
3
x+3z 4𝑦−1
c. + = (x + 3*z)/4 + (4*y – 1)/5
4 5

II. IDENTIFICAR ESTRUCTURA Y PLASMAR EL PSEUDOCÓDIGO


a) Los precios de las entradas al Estadio, es como sigue: (08 ptos.)

Ubicación / Encuentros Perú - Chile Perú - Paraguay


Occidente S/. 450 S/. 400
Oriente S/. 380 S/. 320
Popular S/. 160 S/. 100
El coste es por unidad.

Además, considerando el monto de la compra se aplica un descuento:

Monto Descuento (%)


0 – 800 0
801 - 1500 3
1500 - más 8

Considerando el número de entradas a comprar, deberá mostrar como salida: el monto total a
pagar.

Inicio
real: pf, coste, desc;
entero: entradas, ubicacion;
caracter: encuentro;
Escribir (“Ingrese el encuentro: <C>Perú-Chile, <P>Perú-Paraguay”);
Leer (encuentro);
Escribir (“Ingrese la ubicación: <1>Oriente, <2>Occidente o <3>Popular”);
Leer (ubicación);
Escribir (“Ingrese el número de entradas”);
Leer (entradas);
En caso sea (encuentro) hacer
“C”: En caso sea (ubicación) hacer
1: coste = entradas*450;
2: coste = entradas*380;
3: coste = entradas*160:
Sino
Escribir(“Ubicación no encontrada”);
Fin_caso
“P”: En caso sea (ubicación) hacer
1: coste = entradas*400
2: coste = entradas*320
3: coste = entradas*100
Sino
Escribir(“Ubicación no encontrada”);
Fin_caso
Sino
Escribir(“Encuentro no considerado”);
Fin_caso

Si (coste >= 0) and (coste <= 800) entonces


desc = 0;
Sino
Si (coste>=801) and (coste<=1500) entonces
desc = coste * 0.03;
Sino
Si (coste>=1501) entonces
desc = coste * 0.08;
Fin_si
Fin_si
Fin_si
pf = coste – desc;
Escribir(“El monto total a pagar es: ”, pf)
Fin
Observación:
- Cuando hay cruce de datos, se sugiere realizarlo con EN CASO SEA (ANIDADO).
- Cuando utilizamos EN CASO SEA, debemos tener en cuenta que la variable a analizar sea
caracter o entero.
- Se debe respetar las estructuras de las sentencias.
- Cuando aplicamos 3% de algo, se multiplica por 0.03
b) Escriba un algoritmo en pseudocódigo donde ingrese un número N y deberá calcular la siguiente
serie: (06 ptos.)

(1¹)+(2²)+(3³)+......+(N^N)

Inicio
entero: sum =, i, n;
Escribir (“Ingrese un número”);
Leer (n);
sum = 0;
Desde i = 1 hasta i <= n con incremento 1 hacer
sum = sum + i ^ i ;
Fin_desde
Escribir(“La suma total de la serie es: ”, sum);
Fin
Observaciones:
- Se debe tener en cuenta que en este ejercicio utilizamos contador ( i ) y acumulador
(suma).
- El contador va a ir aumentando dependiendo del incremento que le hayamos dado, en
este caso de 1 en 1.
- El acumulador va a acumular lo que le asignemos, en este caso i ^ i .