You are on page 1of 6

Introduccion a los Algoritmos

Estructuras de Datos
Se necesita calcular la cantidad de cerámica necesaria para cubrir el piso de un departamento
(CantCer). Para resolver esto, es necesario dividir y calcular el problema por partes. Primero es
necesario calcular la superficie del departamento (SupDep) cuya forma es cuadrada, al igual que
la cerámica (SupCer)

Para el siguiente ejercicio aplicare el siguiente algoritmo en pseudocodigo en donde podre


obtener tnto los metros cuadrados de la superfice como la cantidad de ceramicas que se
necesitaran.

Algoritmo ceramicas_cantidad
supdep <- 1
Repetir
Escribir 'ingrese la longitud de metros del piso del departamento representado en
numeros:'
Leer supdep
Si supdep>0 Entonces
su <- supdep*supdep
Escribir 'ingrese el la longitud de centimetros de la ceramica del departamento
representado en numeros:'
Leer cantdep
Si cantdep>0 Entonces
ac <- (cantdep*cantdep)
cc <- (su/ac)*1000
Escribir 'el resultado es:'
Escribir 'el area de la superficie del departamento:',su,' metros cuadrado'
Escribir 'la cantidad de ceramica que ocupa es:',cc,'unidad'
Escribir ''
Escribir 'desea continuar SI es si presionar cero=0 o salir= 1?'
Leer supdep
SiNo
Escribir 'valor no aceptado!!'
FinSi
SiNo
Escribir 'valor no aceptado!!'
FinSi
Hasta Que sup=1
FinAlgoritmo
1) ¿Qué clasificación de algoritmo se usó? Justifique su respuesta.

Podriamos decir que se cuantitativo y compuacional, ya que el primer tipo de algoritmo

nos permite dar solucion a los problemas de tipo numerico. Debemos mencinar que este

tipo de agoritmo consta de tres partes:

ENTRADA, PROCESO Y SALIDA.

*Entrada: se podria decir que son quellos datos necesarios para ejecutar el algoritmo

*Proceso: secuencia de datos para ejecutar el algoritmo

*Salida: Son aquellos datos que se obtienen despues que se ejcuta el algoritmo.
Y el computacional nos permite utilizar un computador para que ejecute ciertas actividades
que nos ayudaran agilizar el tiempo de solucion de un problema

2) ¿Cuál es la complejidad del algoritmo utilizado? Justifique su respuesta.

Este es de tipo lineal, no necesita un análisis tan matemático para el desarrollo de esta.

Es decir solo es necesario definir áreas y conversiones de longitud (centímetros- metros)

3) ¿Es aplicable el Método Voraz en este caso? Justifique su respuesta

Se podría decir que este tipo de método es aplicable ya que hay condicionantes que se

requieren para llegar a una respuesta que no es necesariamente compleja.


Bibliografía

Iacc semana 1