Sie sind auf Seite 1von 29

c

ALGORITMOS

ALUMNOS:

ALCANTARA FLORES
----------------
RUIZ CORDOVA
OBANDO CHAVEZ
IDROGO ROJAS

1. A un trabajador le pagan segun sus horas y una tarifa de pago por


horas. si la cantidad de horas trabajadas es mayor a 40 horas. la
tarifa se incrementa en un 50% para las horas extras. calcular el
salario del trabajador dadas las horas trabajadas y la tarifa.

variables: horas_trabajadas,tarifa,horas_extras,salario,tarifa_e
inicio
leer: horas_trabajadas,tarifa
si: horas_trabajadas <= 40 entonces
salario <-- horas_trabajadas * tarifa
si_no
tarifa_extra <-- tarifa + 0.50 * tarifa
horas_extras <-- horas_trabajadas - 40
salario <-- horas_extras * tarifa_extra + 40 *
tarifa
fin_si
imprimir: salario.
fin

2. A un trabajador le descuentan de su sueldo el 10% si su sueldo es


menor o igual a 1000. por encima de 1000 y hasta 2000 el 5% del
adicional, y por encima de 2000 el 3% del adicional. calcular el
descuento y sueldo neto que recibe el trabajador dado su sueldo.

variables: sueldo,sueldo_neto,descuento
inicio
leer: sueldo
si: sueldo <= 1000 entonces
descuento <-- sueldo * 0.1
si_no
si: sueldo <= 2000 entonces
descuento <-- (sueldo - 1000) * 0.05 + 1000 * 0.1
si_no
descuento <-- (sueldo - 2000) * 0.03 + 1000 * 0.1
fin_si
imprimir: descuento.
fin

3. Dado un monto calcular el descuento considerando que por encima de


100 el descuento es el 10% y por debajo de 100 el descuento es el
2%.
variables: monto,descuento
inicio
leer: monto
si: monto > 100 entonces
descuento <-- monto * 10 / 100
si_no
descuento <-- monto * 2 / 100
fin_si
imprimir: monto, descuento
fin

4. Dado un tiempo en segundos, calcular los segundos restantes que le


correspondan para convertirse exactamente en minutos.

variables: tiempo_seg,minutos,segundos
inicio
leer: tiempo_seg
si minutos <-- tiempo_seg div 60 entonces
segundos <-- tiempo_seg mod 60
fin_si
imprimir: minutos,segundos.
fin

5. Dado un tiempo en minutos, calcular los dias, horas y minutos que


le corresponden.

variables: tiempo,dias,horas,minutos
inicio
leer: tiempo
si: dias <-- tiempo div 1440
x <-- tiempo mod 1440
horas <-- x div 60
minutos <-- x mod 60
imprimir: dias,minutos,horas
fin_si
fin

6. Calcular mediante un algoritmo repetitivo la suma de los N primeros


números naturales.

Inicio
Leer : N
X<--1
S<--0
Mientras x<=N hacer
S<--s+1
X<--x+1
Fin _ mientras
Imprimir: s
Fin

7. Modificar el ejercicio 1 para obtener la suma de los salarios de todos


los trabajadores.
Inicio
Leer: N
X<--1
S<--0
Mientras x<=N hacer
Leer:h, t
S<--h*t
Imprimir s
S<--s+s
X<--x+1
Fin _ mientras
Imprimir: s
Fin

8. Dada las horas trabajadas de una persona la tarifa de pago.


Calcular su salario e imprimirla.

Inicio
leer: h, t
S<--h * t
Imprimir: s
fin

(Para dos personas)

inicio
leer: h, t
S<--h * t
Imprimir s
Leer: h, t
S<--h * t
Imprimir: s
Fin

9. Dado N notas de un estudiante calcular:

a) Cuantas notas tiene desaprobados.


b) Cuantos aprobados.
c) El promedio de notas.
d) El promedio de notas aprobadas y desaprobadas.

Inicio
Leer: N
X<--1
Cd<--0
NA <-0
acum_desap <-0
acum_ap <- 0
acum <- 0
Mientras x<=N hacer
Leer: not
Si: not < 10.5 entonces
CD<--cd+1
acum_desap <- acum_desap + not
Sino
NA <- NA + 1
acum_ap <- acum_ap + not
fin _ si
acum <- acum + not
x<--x+1
Fin _ mientras
prom_ap <- acum_ap /NA
prom_desap <- acum_desap/CD
prom <- acum / N
Imprimir: prom, prom_ap, prom_desap, NA, CD
Fin

10. Dado un numero determinar la suma de sus dígitos.

Inicio
Leer: n
S<--0
Mientras n<>0 hacer
R<--n mod 10
S<--s + r
N<--n div 10
Fin _ mientras
Imprimir: s
Fin

11.Se trata de escribir el algoritmo que permita emitir la factura


correspondiente a una compra de un articulo determinado, del que
se adquieren una o varias unidades. El IVA es del 15% y si el precio
bruto ( precio venta mas IVA) es mayor de 50.00 pesetas se debe
realizar un descuento del 5%.

Variables: precio, numeros de articulos(Nart), precio venta(Pv),


descuento(d)
Inicio
Leer precio, Nart
Pv= Precio * Nart
IVA= Pv * 0.15
Pb= Pv + IVA
Si Pb >= 50 entonces
d= (Pb * 5)/100
Sino
d= 0
Finsi
Pl= Pb - d
Escribir Pv, IVA, Pb,d, Pl
Fin

12. Realizar un algoritmo que permita pedir


50 números naturales y determine e imprima cuantos son
pares, impares, positivos y negativos.

variables:par(p), impares(im), positivos(pos), negativos(n)


Inicio
p= 2
in= 0
pos.= 0
n= 0
Para x= 1 hasta 50
Leer n
Si n mod 2= 0 entonces
p= p + 1
Sino
in= in + 1
Finsi
Si n > 0 entonces
Pos= pos + 1
Sino
n= n + 1
Finsi
Fin_para
Escribir p, in, pos, n
Fin

13. Desarrollar un algoritmo para calcular e


imprimir el factorial de un número.

variables: factorial(f). numero(n)


Inicio
f= 1
Para x= 1 hasta n
f = f * x
Fin_para
Escribir f
Fin

14. Calcular la media de 100 números e imprimir su resultado.

variables: suma(s), media


Inicio
s= 0
x= 1
Mientras x<= 100 hacer
Leer n
s = s + n
x = x + 1
Finmientras
media = s /100
Escribir media
Fin

15. Calcular y visualizar la suma y el producto de los


números pares comprendidos entre 20 y 400 ambos inclusive.

variables: suma(s), producto(p)


Inicio
s = 0
p = 1
x = 20
Mientras x<= 400 hacer
s = s +1
p = p *x
x = x +1
Finmientras
Escribir s, p
Fin
16.-Hacer un programa que al ingresar un número
de Amstrong nos escriba si es o no es un número de
amstrong, y si no es que indique que vuelva a intentar.

Variables número, número original, digito

INICIO
LEER NÚMERO
Numeró original
Suma 0
Mientras NUMERO <> 0 hacer
dijito <- digito mod 10
Suma <- suma + dijito ^ 3
Numero <- numero mod 10
Si suma = Número _ original Entonces
Escribir "es un numero de amstrong"
Sino
Escribir "no es un numero de amstrong, intente otra vez"
Finsi
Fin

17.-Hacer un programa que registre el nº de créditos de un alumno.


*El número máximo de crédito es 25
*Imprimir número de crédito y total de crédito.

Variables crédito, numero_de_crédito


Inicio
total_de_crédito <- 0
Leer crédito
Si total_de_crédito + crédito < = 25 entonces
Total_de_crédito <- total_de_crédito + crédito
Numero_de_crédito <- número_de_cedito + 1
Fin si
Imprimir Numero_de_crédito, crédito
Fin

18.-Hacer un programa para escribir la primera vocal leída del teclado.


*Se supone que se leen, uno a uno, carácter desde el teclado

Variables vocal
Carácter J
Inicio
sw = 1
Mientras sw = 1 hacer
Leer J
si (J= "a") o (J = "e") o (J = "i") o (J = "o") o (J ="u")
Escribir "LA PRIMERA VOCAL INGRESADA FUE",J
sw <- 0
fin_si
Fin_mientras
Fin
19.-Hacer un programa que no determine un numero
tiene o no parte fraccionaria.

Variables parte_fracciomaria
Real n
Inicio
Escribir "ingresa numero"
Leer n
Si n = trunc(n) entonces // trunc es una funcion
// que elimina los decimales de
un numero

Escribir "numero no tiene parte fraccionaria"


Sino
Escribir" numero con parte fraccionaria"
fin si
Fin

PRESENTACIÓN DE INFORME 01

INTEGRANTES:
JUAN MANUEL NAMUCHE GONZALES.(SUPERVISOR)
MARICELY GUEVARA SÁNCHEZ (HE CORREGIDO MUCHO)
JOSE CELIZ LOPEZ.(no presento)
JOSE ROMERO FLORES.(MAL PRESENTADO- NO SIRVE)

*************************************************************************
******************************************
ATENCION SUPERVISOR:
PRESTE MAS ATENCION A LO QUE LE PRESENTAN
*************************************************************************
******************************************

JUAN NAMUCHE
(ESTRUCTURAS REPETITIVAS)

1) Hacer un programa que permita escoger en un conjunto de numeros


naturales:
· Cuales son menores que 15.
· Cuales son mayores de 50.
· Cuales estan comprendidos entre 25 y 50.

*el programa termina con el ingreso de un numero negativo y el numero de


iteraciones debe ser 100.

Inicio
Leer n
desde I ? 1 hasta 100 hacer
Si n < 15 entonces
Escribir n
Sino
Si n > 50 entonces
Escribir n
Sino
Si n > 25 y n < 50 entonces
Escribir n
Fin_si
Fin_si
Fin_si
Fin_desde

n ? n + 1
si n < 0 entonces
Escribir ³error de datos procesados´
Fin_si
Fin.

2) El ing. De sistemas del banco de credito necesita conocer de una


lista de 2500 cuentas cual es la que posee mayor y menor cantidad de
dinero (d)

Inicio
Leer n
Max ? n
Min ? n
Desde i ? 1 hasta 2500 hacer
Leer n
Si n > max entonces
Max ? n
Sin_no
Si n < min entonces
Min ? n
Fin_si
Fin_si
Fin_desde
Escrbir ³MÁXIMO´ Max
³MINIMO´ Min
fin

3) En una empresa: se debe visualizar en una lista FICHA donde se


encuentra nombre categoría, edad y sueldo ademas el programa debe
visualizar un mensaje ³existen trabajadores mayores de 65 años en un
numero de ...´ y el numero de trabajadores mayores de 65 años.

Inicio
SW <- 0
mientras SW = 0 hacer
Leer FICHA (NOMBRE CATEGORÍA, EDAD, SUELDO)
Escribir FICHA
Si EDAD > 65 Entonces
S <- S + 1
SW <- 1
Fin_si
Fin_mientras
Si SW = 1 Entonces
Escribir ³existen trabajadores...´
Escribir S
Fin_si
Fin

4) hacer un programa que permita calcular y mostrar el jornal


mensual de acuerdo con las siguientes especificación:

· los trabajadores tienen dos turnos (nocturno y diurno)


· la tarifa de las horas diurnas es de 10 soles.
· La tarifa de las nocturnas es de 50 soles.
· Ningun trabajador recibe nada por feriados.
· El trabajador sera despedido si sus horas_trabajadas son
menores que 15. (mensual)

Inicio
Leer Horas_trabajadas, dia, turno
Mientras dia <> ³domingo´ hacer
Si turno = ³diurno´ entonces
Jornal<-? 10 * Horas trabajadas
Sino
Jornal <- ? 50 * Horas_trabajadas
Fin_si
Fin_mientras
Si horas_trabajadas < 15 entonces
Escribir ³Trabajador en observación´
Sino
Escribir ³el jornal mensual es:´ jornal
Fin_si
Fin

5.Determinar cuantos trabajadores recibirán un salario mayor o igual a


500.
conocida la tarifa y las horas trabajadas

Variable: tarifa, horas, salaros,N,C,i


Inicio
Leer tarifa,N
C = 1
i = 0
mientras C<=N hacer
Leer horas
salario = tarifa*horas
si salario>=500 entonces
i = i+1
fin_si
fin_mientras
Imprimir i
Fin

MARICELY GUEVARA SANCHEZ


(ESTRUCTURAS REPETITIVAS)
*ING.ENRIQUE BARRUETO ESTOS EJERCICIOS DE LA ALUMNA SON ESTRUCTURAS
REPETITIVAS,PERO ESTAN PROGRAMADOS EN OTRO LENGUAJE.

1). Clasificar a 50 personas segun la edad y el sexo al final deberá


visualizar la cantidad de personas
masculinas mayores de edad, la cantidad de personas femeninas
menores de edad, cantidad de
personas mayores y menores. ademas debera indicar el porcentaje
que representa las personas
mayores y menores de edad.

variables:
Nom(50), 5x(50):Texto
Ed(50),MMa, FMe,May,Men,C

Inicio
MMa=0
Fme=0
May=0
Men=0
para c=1 hasta c = 50 hacer
leer Ed(c),Sx(c)
si Ed(c)>=18 entonces
May=May+1
sino
Men=Men+1
fin_si
si sx(c)="M"entonces
Si Ed(c)>=18 entonces
MMa=MMa+1
fin_si
sino
si Ed(c)<18entonces
FMe=FMe+1
fin_si
fin_si
Fin Para
PMa=may*100/50
PMe=Men*100/50
mostrar MMa,FMe,May,Men,PMa,PMe
fin

2). Autogenerar el codigo del alumno tomando como datos los dos primeros
caracteres del apellido paterno el segundo y tercer caracterde apellido
materno los dos ultimos caracteres de los nombres mas el numero que le
corresponde en la lista. Ademas se deberá pedir dos notas para calcular
su promedio del curso de matematica. se sabe que en el aula son 36
alumnos y ademas deberá mostrar al final la cantidad de alumnos
desaprobados.
variables
Nom(36),pat(369,Mat(36),Cod(36):Texto
N1(36),N2(36),Prom(36),A,D,C:Numerico

Inicio
A=0
D=0
paraC=1 hasta 36
leer Nom(c), Pat(c),Mat(c),N1(c),N2(c)

cod(c)=Left(pat(c),2)+Mid(Mat(c),2.2)+Rig(Nom(c),2)+STR(c)
Prom(c)=(N1(c))+N2(c))/2
escribir cod(c), prom(c)
si prom(c)>=10.5 Then
A=A+1
si no
D=D+1
fin_si
fin_para
escribir A,D
Fin

3). utilizando arraysbidimensional se pide realizar lo sgte:


Ingresar somo datos nombre del trabajador, categoria y cantidad
de horas, segun estos datos se debe
calcular el sueldo segun la sgt tabla de criterios

categoria Costo hora


1 8.5
2 9.7
3 10.5
4 11.5

la cantidad de trabajadores es de 30 y al final se pide mostrar


lo sgte.
Los nombres de los trabajadores con sus respectivos sueldos,
ordenados por el sueldo en forma descendente.
la cantidad de trabajadores por categorias y el total de los
sueldos de dicho trabajador.

variables
Aux, Trab(30,4):Variant
I,Ts,C1,C2,C3,C4;Fil,VH:Numerico
Ordenar=Logico
Inicio
C1=0
C2=0
C3=0
C4=0
TS=0
para fil = 01 hasta 30
Ingresar trab(Fil,1), trab(Fil,2), trab(Fil,3)
Seleccione Caso segun trab(Fil,2)
Caso trab(Fil,2)= 1
VH=8.5
C1=C1+1
caso trab(Fil,2)=2
VH=9.7
C1=C2+1
caso trab(Fil,2)=3
VH =10.5
C3=C3+1
caso trab(Fil,2)=4
VH = C4=C4+1
Fin_Seleccione
trab(Fil,4)=Vh*Trab(Fil,3)
Ts=Ts+Trab(Fil,4)
Fin_para

Ordenar=True
mientras ordenar=True hacer
Ordenar=False
Para Fil=1 Hasta29
Si Trab(Fil,4)<Trab(Fil+1,4) Entonces
Aux=Trab(Fil,1)
Trab(Fil,1)=Trab(Fil+1,1)
Trab(Fil+1,1)=Aux
Aux=Trab(Fil,2)
Trab(Fil,2)=Trab(Fil+1,2)
Trab(Fil+1,2)=Aux
Ordenar=True
Fin-si
Fin_Para
Fin mientras
Para Fil=1 hasta 30
Mostrar C1;C2,C3,C4,Ts
Fin_para
Fin

4).clasificar una lista de numeros indicando al final la cantidad de


numeros pares y la cantidad de numeros impares
el dato a ingresar es un numero y se debe en proceso repetir mientras el
numero in gresado sea diferente a cero
variables
NP, N1,NUm : numericos
Inicio
Np= 0
N1=0
leer Num
mientras Num <>0 hacer
si (NUM MOD 2) = 0 entonces
NP= NP+1
sino
NI= NI+1
Fin_si
Ingresar Num
Fin_Hacer
mostrar NP, NI
Fin
c

TRABAJO DE ALGORITMOS

SUPERVISOR: CRISTHIAN QUEZADA ASENJO


INTEGRANTES:
MANUEL LUCERO GIL (10)
KATHERINE EMPERATRIZ PEREZ POPUCHE(10)
PAOLA SANDOVAL AHUMADA(10)

TOTAL DE EJERCICIOS RESUELTOS: 30

DESARROLLO

Hacer un programa que registre 20 numeros en un array de una dimension y


muestre posteriormente los elementos que ocupan posiciones impares

INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| fin_mientras
|
| x=1
| mientras x<=20 Hacer
| | escribe a[x]
| | x=x+2
| fin_mientras
|
FIN

Hacer un programa que registre 20 numeros en un array de una dimension y


muestre posteriormente los elementos que ocupan posiciones pares y de
inversa

INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| fin_mientras
|
| x=20
| mientras x>=2 Hacer
| | escribe a[x]
| | x=x-2
| fin_mientras
|
FIN

Hacer un programa que registre 20 numeros en un array de una dimension y


muestre posteriormente los elementos que contienen numeros multiplos de 3
INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| fin_mientras
|
| x=1
| mientras x<20 Hacer
| | Si a[x]mod3 =0 entonces
| | | escribe a[x]
| | Fin_si
| | x=x+1
| fin_mientras
|
FIN

Hacer un programa que registre 20 numeros en un array de una dimension y


muestre posteriormente los elementos que contienen numeros multiplos de 5
y en forma inversa

INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| |
fin_mientras
|
| x=20
| mientras x>=1 Hacer
| | Si a[x]mod5 =0 entonces
| | escribe a[x]
| | Fin_si
| | x=x-1
| fin_mientras
|
FIN

Se necesita elaborar un programa donde se registren 20 notas de alumnos,


calificadas de 0 a 20, teniendo en cuenta que se mostraran solo los
aprobados, si no sladra una frase "desaprobado"

INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| fin_mientras
|
| x=1
| mientras x>=13 Hacer
| | escribe a[x]
| | Si x<=13 entonces
| | escribe "Desaprobado"
| | Fin_si
| | x=x+1
| | Mostrar aprobados
| fin_mientras
|
FIN
Hacer un programa que registre 20 numeros enn una array de 1 dimension y
luego muestre en la pantalla los numeros ingresados en orden inverso y
los que ocupen posicion pares

INICIO
|
| Dimensionar a[100]
| x=1
| mientras x<=20 hacer
| |
| | leer a[x]
| | x=x+1
| |
| fin_mientras
|
| x=20
| mientras x>=1 Hacer
| |
| | escribe a[x]
| | x=x-1
| |
| fin_mientras
|
| x=1
| mientras x<10 hacer
| |
| | Si a[x]mod2=0 entonces
| | | escribe a[x]
| | |
| | Fin_si
| | x=x+1
| |
| fin_mientras
|
FIN

"SAGA FALABELLA" se encuentra de aniversario y ha programado una serie de


ofertas con la finalidad de brindar facilidades a sus clientes y al a vez
de incrementar sus ventas. Estas ofertas se basan especificamente en un
procentaje de descuento sobre eol total de compra el cual varia de
acuerdo al monto
* Por un monto mayor o igual a $500 se hara un descuento del 30%

* Por un monto menor de $500 pero mayor o igual a 200 se hara un


descuento del 20%

* Por un monto menor de $200 pero mayor o igual a 100 se hara un


descuento del 10%

* Considere 100 personas

INICIO
|
| x=x+1
| Leer Consumo
|
| Si consumo >=500 entonces
| |
| | descuento = Consumo*30/100
| |
| Sino
| | Si consumo >=200 entonces
| | |
| | | descuento = Consumo*20/100
| | |
| | Sino
| | | Si consumo >=100 entonces
| | | |
| | | | descuento = Consumo*10/100
| | | |
| | | Sino
| | | | Descuento=0
| | | |
| | | Fin_si
| | |
| | Fin_si
| |
| Fin_si
|
| Totalpagar= Consumo-Descuento
| Imprimir Totalpagar
|
| Si x<>100 entonces
| | x=x+1
| |
| Fin_si
|
FIN

Dado la tarifa de pago por horas de un trabajador, y sus horas trabajadas


calcular cuantos trabajadores reciben un salario mayor o igual a S/.500 y
calcular ademas el promedio de los salarios de todos los trabajores

INICIO
|
| Leer N
| Leer Tarifa
| i=0
| C=0
| Suma=0
| mientras i<=N Hacer
| | Leer horas
| | salario= tarifa * horas
| | Escribir salario
| | Si salario >=500 entonces:
| | c=c+1
| | Fin_si
| | Suma= suma + salario
| | i=i+1
| fin_mientras
| P=suma/N
| Escribir: P,C
|
FIN

Dado N notas, calcular el promedio de las notras aprobadas y el promedio


de las notas desaprobadas

INICIO
|
| Leer N
| i=1
| Suma1 =0
| Suma2 =0
| C=0
| S=0
| mientras i<= N Hacer
| |
| | Leer Nota
| | Si Nota>=13 entonces:
| | | Suma1= Suma1+Nota
| | | C=C+1
| | |
| | Sino
| | |
| | | Suma2= Suma2+Nota
| | | S=S+1
| | |
| | Fin_si
| |
| | i=i+1
| |
| |
| fin_mientras
|
| Pa=Suma1/C
| Pd=Suma2/S
|
| Escribir: Pa, Pd
|
FIN
Dado N, calcular los numeros: 2,4,6,8,....,2N

INICIO
|
| Leer N
| i=1
| mientras i<=2*N Hacer:
| | Si i mod2 =0 entonces:
| | | escribir i
| | Fin_si
| |
| | i=i+1
| |
| fin_mientras
|
FIN

Dado N, escribir el producto desde 1 hasta N

INICIO
|
| Leer N
| i=1
| mult=1
|
| mientras i<=N Hacer:
| mult= mult*i
| i=i+1
|
| fin_mientras
|
FIN

Dadas 3 longitudes, es decir mediante un mensaje si forman un triangulo:


equilatero, isosceles o escaleno, o no forman triangulo (cada lado tiene
que ser menos que la suma de los otros dos)

INICIO
|
| Leer a,b,c
| Si a<b+c and b<a+c and c<a+b entonces
| |
| | Si a=b and b=c entonces:
| | | escribe: "El triangulo es equilatero"
| | |
| | Sino
| | | Si a<>b and a<>c and b<>c entonces
| | | | escribe: "El triangulo es escaleno"
| | | |
| | | Sino
| | | | escribe: "El triangulo es isosceles"
| | | |
| | | Fin_si
| | |
| | Fin_si
| |
| Sino
| | escribe: "No forman triangulo"
| |
| Fin_si
|
|
FIN

Una tienda se dedica a la venta de computadoras, cuenta con 10


vendedores. Cada uno de ellos tiene un sueldo mensual pero ademas de su
sueldo ganan una comision por venta

* Si el monto de venta es mayor de 1000 la comsion sera del 15%

* Si el monto de venta es mayor o igual a 500 y menor de 1000 la


comision es del 5%

* Si el monto de la venta es menor que 500 no tiene comision

INICIO
|
| x=x+1
| Leer "Sueldo", "Venta"
|
| Si venta>=1000 entonces
| | Sueldo = Venta * 15/100
| |
| Sino
| |
| | Si venta>=500 entonces
| | Sueldo = Venta * 5/100
| |
| | Sino
| | Comision=0
| |
| | Fin_si
| |
| Fin_si
|
| Sueldototal
| Si x<>10 entonces
| | x=x+1
| |
| Fin_si
|
FIN

Katthy organiza una fiesta en la cual una computadora controla el ingreso


mediante 5 claves. Si se ingresa al menos una clave incorrecta esta
imprimira "TE EQUIVOCASTE DE FIESTA" y no permitira el ingreso. Si las 5
claves son correctas imprimira "BIENVENIDO A LA FIESTA"

Las Claves son:


1: "TIENES"
2: "QUE SER"
3: "INVITADO"
4: "PARA"
5: "INGRESAR"

INICIO
|
| Leer Claves: C1,C2,C3,C4,C5
|
| Si C1<>"TIENE" entonces:
| | escribir "Te Equivocaste de Fiesta"
| |
| Sino
| | escribir "Ingrese la Clave2"
| |
| | Si C2<>"QUE_SER" entonces:
| | | escribir "Te Equivocaste de Fiesta"
| | |
| | Sino
| | | escribir "Ingrese la Clave3"
| | |
| | | Si C3<>"INVITADO" entonces:
| | | | escribir "Te Equivocaste de Fiesta"
| | | |
| | | Sino
| | | | escribir "Ingrese la Clave4"
| | | |
| | | | Si C4<>"PARA" entonces:
| | | | | escribir "Te Equivocaste de Fiesta"
| | | | |
| | | | Sino
| | | | | escribir "Ingrese la Clave5"
| | | | |
| | | | | Si C5<>"INGRESAR" entonces:
| | | | | | escribir "Te Equivocaste de Fiesta"
| | | | | |
| | | | | Sino
| | | | | | escribir "Bienvenido a la Fiesta"
| | | | | |
| | | | | Fin_si
| | | | |
| | | | Fin_si
| | | |
| | | Fin_si
| | |
| | Fin_si
| |
| Fin_si
|
FIN

Hacer un programa que clasifique 400 personas segun el deporte que


prcatica los deportes son: Ajedrez, Atletismo, Basket, Futbol, Gimnasia,
Karate, Natacion, Tiro, Voley

INICIO
| x=x+1
| Leer "Deporte"
|
| Si deporte= "AJ" entonces
| | AJ=AJ+1
| |
| Sino
| | Si deporte= "AT" entonces
| | | AT=AT+1
| | |
| | Sino
| | | Si deporte= "B" entonces
| | | | B=B+1
| | | |
| | | Sino
| | | | Si deporte= "F" entonces
| | | | | F=F+1
| | | | |
| | | | Sino
| | | | | Si deporte= "G" entonces
| | | | | | G=G+1
| | | | | |
| | | | | Sino
| | | | | | Si deporte= "K" entonces
| | | | | | | K=K+1
| | | | | | Sino
| | | | | | | Si deporte= "N" entonces
| | | | | | | | N=N+1
| | | | | | | |
| | | | | | | Sino
| | | | | | | | Si deporte= "T" entonces
| | | | | | | | | T=T+1
| | | | | | | | |
| | | | | | | | Sino
| | | | | | | | | Si deporte= "V" entonces
| | | | | | | | | | V=V+1
| | | | | | | | | |
| | | | | | | | | Sino
| | | | | | | | | | Imprimir "Error"
| | | | | | | | | |
| | | | | | | | | Fin_si
| | | | | | | | |
| | | | | | | | Fin_si
| | | | | | | |
| | | | | | | Fin_si
| | | | | | |
| | | | | | Fin_si
| | | | | |
| | | | | Fin_si
| | | | |
| | | | Fin_si
| | | |
| | | Fin_si
| | |
| | Fin_si
| |
| Fin_si
|
| Si x<>400 entonces
| | x=x+1
| |
| Sino
| | Imprimir AJ,AT,B,F,G,K,N,T,V
| |
| Fin_si
FIN

Hacer un programa que registre 10 números en un Array de un 1D y que


muestre posteriormente los elementos que contiene N°s Impares.

Inicio
Dimensionar a (100)
x=1
mientras x <=10 hacer
leer a (x)

fin_mientras
x=1

mientras x<=10 hacer

si a (x)mod2 = 1 entonces
escribir (x)
fin_si
x=x + 1

fin_mientras
Fin

Diseñar un formulario que permita ingresar dos notas malas y determine su


promedio, debe mostrar un comentario si este está aprobado o desaprobado.

Inicio

Leer (N1)
Leer (N2)

P=(N1 + N2) / 2
Escribir ("el promedio es :", P)

Si P>= 11 y P<=20 entonces


Escribir ("Aprobado")

Sino

Escribir ("Desaprobado")

Fin_si

Fin

Diseñar un programa que permita controlar la venta de pasajes a los


clientes según la categoría y el destino.
INICIO
| Leer (cliente)
| Leer (CAT)
|
| Si CAT= "económico" , entonces
| | Escribir ("ingrese destino")
| |
| | Si DES = "Tumbes", entonces
| | | Escribir ("No hay pasajes")
| | |
| | Sino
| | | Si DES ="Piura", entonces
| | | | P1 = 12
| | | | Escribir (P1)
| | | |
| | | Sino
| | | | Si DES ="Talara", entonces
| | | | | P2 = 18
| | | | | Escribir (P2)
| | | | |
| | | | Sino
| | | | | Si DES = "Lima" , entonces
| | | | | | Escribir ("No hay pasajes")
| | | | | Fin_si
| | | | Fin_si
| | | Fin_si
| | Fin_si
| |
| Sino
| | Si CAT =Imperial, entonces
| | | Escribir ("Ingrese destino")
| | |
| | | Si DES = Tumbes, entonces
| | | P3=80
| | | Escribir ("P3")
| | |
| | | Sino
| | | | Si DES =Piura, entonces
| | | | | P4= 20
| | | | | Escribir (P4)
| | | | |
| | | | Sino
| | | | | Si DES =Talara, entonces
| | | | | | P5=30
| | | | | | Escribir (P5)
| | | | | |
| | | | | Sino
| | | | | | Si DES = Lima , entonces
| | | | | | | Escribir ("No hay pasajes")
| | | | | | |
| | | | | | Fin_si
| | | | | Fin_si
| | | | Fin_si
| | | Fin_si
| | |
| | Sino
| | | Si CAT = Bus cama , entonces
| | | | Escribir ("Ingrese destino")
| | | |
| | | | Si DES = Tumbes, entonces
| | | | P6=100
| | | | Escribir ("P6")
| | | |
| | | | Sino
| | | | | Si DES =Piura, entonces
| | | | | | Escribir ("No hay pasaje")
| | | | | |
| | | | | Sino
| | | | | | Si DES =Talara, entonces
| | | | | | | Escribir ("No hay pasaje")
| | | | | | |
| | | | | | Sino
| | | | | | | Si DES = Lima, entonces
| | | | | | | P7=170
| | | | | | | Escribir(P7)
| | | | | | Fin_si
| | | | | Fin_si
| | | | Fin_si
| | | Fin_si
| | Fin_si
| |
|Fin_si
|
FIN

La compañia Barner posee una caja con $3.71 con la cual empieza todos los
dias diariamente se registran egresos.
calcular los egresos de la compañia y mostrar cuanto queda en caja.
(el programa termina cuando se ingresa un egreso imaginario de -1)

INICIO

Caja=371
Egreso=0

mientras egreso <> -1 Hacer:


Caja= Caja - Egreso
Leer Egreso

Fin_mientras

Escribir Caja

FIN

Dado Ny X CALCULAR:

X2/2 + X4/4 + X6/6 + .... + Xn/N

INICIO

Leer N, X
i=2
Suma=0

mientras i <= 2N Hacer


suma= suma +(x^i)/i
i=i+2

fin_mientras

Escribir suma

FIN

Calcular la suma de los n primeros numeros enteros desde el numero 8

S=8+9+10+11+...+N

INICIO

Leer n
suma=0

desde i=8 hasta n hacer:


suma=suma+1

fin_desde

Escribir suma

FIN

Calcular la media de un conjunto de notas de alumnos. Se le ha dado un


valor de -30 que detecte el fin del programa

INICIO

Total=0
n=0
Leer nota

mientras nota<>-30 Hacer:


total=total+nota
n=n+1
Leer nota

fin_mientras

media=total/n

escribir media

FIN

Calcular todos los pagos hechos de un restaurant que lea 130 consumos y
que si el consumo ingresado excede los $130 el descuento sera del 15%
INICIO

x=1

mientras x<130 Hacer


Leer consumo
Si consumo > 130 entonces:
descuento=consumo * 0.15

Sino
descuento=0

Fin_si

pago=consumo-descuento

escribir pago
x=x+1

fin_mientras
FIN

Hace un programa que calcule la longitud de la circunferencia, el are del


circulo y el volumen de la esfera para un radio ingresado por el teclado

INICIO

Leer "R"

PI=3.1416

LC=2*PI*R

A=PI*R^2

V=4/3*PI*R^3

Imprimir "LC","A","V"
FIN

Hacer un programa que calcule el valor de la hipotenusa de un triangulo


rectangulo, ingresando por el teclado sus catetos (Teorema de Pitagoras)

INICIO

Leer A,B

H=(A^2+B^2)^0.5

Imprimir "Hipotenusa"

FIN
Hacer un programa que permita calcular el area de un triangulo cualquiera
donde los valores de los lados son ingresados por el teclado

INICIO

Leer A,B,C

S=(A+B+C)/2
AT= (S*(S-A)*S*(S-B)*S*(S-C))^0.5

IMPRIMIR AT

FIN

Hacer un prpgrama que calcule las raices de una ecuacion cuadratica cuya
forma canonica es:
Ax+By+C=0

Solo se calculara raices reales. si el discriminante en menor de 0,


imprimir error y volver a ingresar datos.
Los coeficientes A,B,C seran ingresados por la pantalla

INICIO

Leer A,B,C

D=B^2-4*A*C
Si D<0 entonces:
IMPRIMIR "ERROR"

Fin_si

X=(-B+D^5)/(2*A)
Y=(-B+D^5)/(2*A)

IMPRIMIR X,Y

FIN

Hacer un programa en el que ingresados dos numeros por la pantalla se


debe calcular la suma, diferencia,producto y division. el proceso debe
finalizar al ingresar el primer numero igual a cero

INICIO

Leer A

Si A=0 entonces
escribe "Fin del programa"

Sino

Leer B

S=A+B
R=A-B
M=A*B
D=A/B

IMPRIMIR S,R,M,D
Fin_si
FIN

Hacer un programa que imprima el cubo y la raiz cuadrada de un numero


ingresado por la pantalla; el programa debe estar confeccionado de tal
manera que el proceso a efectuarse sea repetitivo.
Debe terminar cuando al pedir el numero se ingrese el valor 0

INICIO

Leer N

Si N=0 entonces:
escribe "Fin del programa"

Sino
C=N^3
R=N^0.5

IMPRIMIR C,R

Fin_si
FIN

Hacer un programa que al ingresar 2 numeros por la pantalla y que se


calcule la suma, resta, multiplicacion y division. El proceso debe
terminar cuandon se hallan realizado 10 procesos (Hacer uso de
contadores)

INICIO

X=X+1
Leer A,B

S=A+B
R=A-B
M=A*B
D=A/B

IMPRIMIR ,S,R,M,D

Si x=10 entonces:
escribe "Fin del programa"

Sino
X=X+1

Fin_si

FIN
c