Sie sind auf Seite 1von 3

Techniques des Réseaux Informatiques

Correction- Configuration d’un routeur


Questions de cours :

1) • RAM : C’est la mémoire de travail principal du routeur. Elle contient entre autres le système
d'exploitation une fois chargé, le fichier de configuration active, la ou les tables de routage, ainsi
que les mémoires tampon utilisées par les interfaces et la pile utilisée par les processus logiciels.
Sa taille varie en fonction du modèle de routeur (64 ou 96 Mo sur un 2620XM). Le contenu de cette
mémoire est perdu lors de la mise hors tension ou du redémarrage.
• NVRAM (Non-Volatile RAM) : Cette mémoire est non volatile, c'est-à-dire que son contenu n'est pas
effacé lorsque l'alimentation est coupée. Sa très petite capacité de stockage (32 Ko sur un 2620XM)
ne lui permet pas de stocker autre chose que le registre de configuration et le fichier de
configuration de sauvegarde.
• Flash : Mémoire morte effaçable et reprogrammable (EEPROM). Son contenu est conservé lors de
la mise hors tension et du redémarrage. Elle contient l'image du système d'exploitation Cisco IOS
(32 Mo sur un 2620XM). Elle est l’équivalente du disque dur d’un PC.
• ROM : Elle contient le bootstrap ainsi que la séquence d'amorçage du routeur. Celle-ci est donc
uniquement utilisée au démarrage du routeur. Cette mémoire est l’équivalent du BIOS d’un PC.
2) Il faut attribuer au routeur deux mots de passe, l’un par telnet (line vty 0 4) et l’autre par la mode
privilégié (enable password), puis passe au client et accéder le routeur par telnet.
3) 1. Connecter un terminal ou un PC avec un logiciel d'émulation terminal au port console du
routeur.
2. Entrer la commande show version et noter les valeurs de la configuration en cours.
C'est habituellement 0x2102 ou 0x102.
Notez si la configuration est paramétrée pour permettre l'interruption.
La valeur enregistrée dans la configuration d'usine est 0x102. A savoir que le troisième digit
depuis la gauche de la valeur est 1, ce qui désactive l'interruption. Si le Troisième digit n'est pas 1 ,
l'interruption est permise.
3. Eteindre le routeur et le rallumer.
4. Presser la touche d'interruption sur le terminal dans les soixante premières secondes. Le
Rommon> prompt s'affiche sans nom de routeur. Si ce n'est pas le cas , le terminal n'envoit pas le
bon signal d'interruption.
5. Entrer o/r0x42 pour démarrer depuis la mémoire Flash ou o/r0x41 pour démarrer depuis le
boot de la ROM.
Si vous avez une mémoire Flash intacte, 0x42 est le meilleur choix. Utiliser 0x41 seulement si la
mémoire Flash est effacée ou pas installée. Si vous utilisez 0x41, vous ne pourrez seulement voir ou
effacer la configuration sans pouvoir changer le mot de passe.
6. Au Rommon> prompt, entrer la commande d'initialisation pour initialiser le routeur.
Ca entraine le redémarrage du routeur mais ignore la configuration sauvegardée et utilise l'image
dans la mémoire Flash à la place.
Les demandes de configuration du système apparaissent.
7. Entrer No réponse aux messages de configuration du système jusqu'au message suivant : Press
RETURN to get started!
8. Appuyez sur la touche Entrée.
Le Router>Prompt apparrait.
9. Entrer la commande enable.
Le Router# prompt apparrait.
10. Choisir une des options ci-dessous :
1. Pour voir le mot de passe, s'il n est pas encrypté, tapper more nvram:startup-config
2. Pour changer le mot de passe (s'il est encrypté par exemple), entrer les commandes suivantes:
memory

-z

KHALID KATKOUT Page 1


Techniques des Réseaux Informatiques

11. Entrer la commande configure terminal.


12. Entrer la commande config-register et la valeur notée à l'étape 2.
13. Presser Ctrl+Z pour quitter le mode configuration.
14. Entrer la commande Reload au mode privilégié puis la commande write memory pour
sauvegarder la configuration.
4) Le protocole RIP opère au niveau de la couche 3. Avec RIP des messages d'états sont émis
régulièrement par chaque routeur sur chaque lien (environ toutes les 30 secondes). Les messages
ne sont échangés qu'entre routeurs dits voisins qui partagent un réseau commun ou sont reliés par
une liaison directe.
5) EGP est un protocole permettant le routage entre différents systèmes autonomes de routage.
6) L’emplacement idéal d’une ACL étendue est l’emplacement d’origine.

Exercice 1 :

Exercice 2 :

1)
Paramètre Commande
Nom d’hôte : R2 Router(config)#hostname R2
Interface Fa0/0 (@IP, description « link R2(config)#interface FastEthernet0/0
to LAN3 » et activation R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#description link to LAN1
R2(config-if)#no shutdown
Bannière : « accès strictement interdit » R2(config)#banner motd # accs strictement interdit #
Mot de passe mode privilégié « pa$$V2 » R2(config)#enable password pa$$V2
Mot de passe des ligne VTY « pa$$vty2 » R2(config-line)#line vty 0 4
R2(config-line)#password pa$$vty2
R2(config-line)#login
Désactiver CDP globalement au routeur R2(config)#no cdp run
Date et heure avec valeurs actuelles R2#clock set 10:27:23 21 fevr 2013
Loopback : 200.200.20.20/32 R2(config)# interface loopback 1
R2(config-if)# ip addresse 200.200.20.20 255.255.255.252

2)
@ réseau de Masque de sous Interface de sortie Passerelle (@IP Métrique (nombre
destination réseau du prochain saut des sauts
192.168.0.0 255.255.255.0 192.168.2.2 192.168.0.1 2
192.168.1.0 255.255.255.0 192.168.2.2 192.168.1.1 2
192.168.2.0 255.255.255.0 - - 1
192.168.3.0 255.255.255.0 - - 1

3) R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.2


4) R2(config)# router rip
R2(config-router)# version 2
R2((config-router)# network 192.168.2.0
KHALID KATKOUT Page 2
Techniques des Réseaux Informatiques

R2((config-router)# network 192.168.3.0


5) R2(config-router)# no passive-interface fastEthernet Fa0/0
6) R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2
R2(config)#Router rip
R2(config-router)#ver 2
R2(config-router)#default-information originate
R2(config-router)#redistribute static
7) R2#copy running-config tftp: 192.168.3.4 255.255.255.0
8) R1(config)#access-list 101 permit tcp host 192.168.0.10 eq telnet 192.168.2.1 0.0.0.255 established
R1(config)#access list 101 deny any any
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip access-group 101 in
9) R2(config)#access-list 102 deny tcp host 192.168.3.4 eq tftp 192.168.0.0 0.0.0.255 established
R2(config)#access-list 102 deny tcp host 192.168.3.4 eq tftp 192.168.1.0 0.0.0.255 established
R2(config)#interface serial 0/0
R1(config-if)#ip access-group 102 in
10) R2(config)#access-list 103 permit tcp192.168.0.0 0.0.0.255 eq 110 192.168.1.0 0.0.0.255 establishe
R2(config)#access-list 103 permit tcp192.168.0.0 0.0.0.255 eq 80 192.168.1.0 0.0.0.255
established
R2(config)#access-list 103 deny tcp192.168.3.0 0.0.0.255 eq 110 192.168.1.0 0.0.0.255 established
R2(config)#access-list 103 deny tcp192.168.3.0 0.0.0.255 eq 80 192.168.1.0 0.0.0.255 established
R2(config)#access list 103 permit any any
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip access-group103 in

KHALID KATKOUT Page 3