Sie sind auf Seite 1von 74

EXPT NO: 1

DATE: 4/7/2019

LAN CONFIGURATION
AIM:
To configure IP address to PC and router using Packet Tracer.

PROCEDURE:
Step 1: Create a simple topology like the one given below (using default subnet).

Step 2: We can do this either graphically or using CLI commands. To do this graphically, first we go to
PC0 and type in the following;

• In Gateway : 10.0.0.1
• In FastEthernet0 : 10.0.0.2 with default subnet (255.0.0.0).
Step 3: In PC1 we type in

• In Gateway : 20.0.0.2
• In FastEthernet0 : 20.0.0.1 with default subnet (255.0.0.0).
Step 4: In Router0 we first go to Config and then to GigabitEthernet0/0 and type in the IP address as
10.0.0.1. Then we go to GigabitEthernet0/1 and type in IP address as 20.0.0.2. We leave both having
default subnets (255.0.0.0).

Step 5: To check if connectivity has been made, click on PC0, go to Desktop and select Command
Prompt. There type in the ping command to receive a response. If a response is not received,
them there is a connectivity problem.

CLI COMMANDS
The connections can also be made using CLI Commands.

They are as follows

Router>enable

Router# config t

Router(config)# interface GigabitEthernet0/0

Router(config-if)# ip address 10.0.0.1 255.0.0.0

Router(config-if)# no shutdown

Router(config-if)# exit

Router(config)#interface GigabitEthernet0/1

Router(config-if)# ip address 20.0.0.2 255.0.0.0

Router(config-if)# no shutdown
OUTPUT:
The ping command to show connectivity is as follows:

RESULT:

Thus configuration of IP address to PC and router in Packet Tracer using default subnet and
VLSM is done successfully.

RUBRICS:
EXPT NO : 1 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO: 2
DATE: 18/7/2019

ROUTER CONFIGURATION USING CLI


AIM:
To configure basic router and apply VLSM using Packet Tracer.

PROCEDURE:
Step 1: Drag and drop the Router0 onto the workspace.
Step 2: Double click on the router chosen.

Step 3: Enter the CLI mode

Step 4: To configure the router, type hostname routername. To enable password type in the CLI
command line, and enable secret class.

Step 5: Then type in the password. For this example both the password for console line and the
password for virtual terminal line is going to be cisco. We first type line con 0 and then type password
cisco. Then we should type in login for password prompting.

Step 6: For the virtual terminal line we must first enter the virtual terminal lines by typing line vty 04.
Then we type in password cisco and then type in login to enable password requirement.

Step 7: Later we type reload to restart the router and this shows that we have both configured the
router and created a password.

CLI COMMANDS
Router>enable

Router#config t

Router(config)#hostname router1

Router(config)#enable secret class

Router(config)#line con 0

Router(config-line)#password cisco

Router(config-line)#login

Router(config-line)#exit

Router(config)#line vty 04

Router(config-line)#password cisco

Router(config-line)#login

Router(config-line)#exit
Router(config)#exit

Router#reload
OUTPUT:
The screenshots show the various CLI Commands and the final password verification.

The first time the password is prompted the wrong password is given.

This is why the password is prompted for the second time. This time the right one is given, thus starting
the router.

RESULT:
Hence router configuration is successfully executed.

RUBRICS:
EXPT NO: 2 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO : 3
DATE:1/8/2019

STATIC ROUTING
AIM:
To configure static routing using packet tracer.

PROCEDURE:
Step 1: Set up the two routers and PCs.

Step 2: Giving the network a subnet of 224, we can set the IPs of the PCs to 192.168.8.34 and
192.168.8.96.

Step 3: The routers are given the IPaddresses as 192.168.8.33 and 192.168.8.97.
Step 4: The two routers are connected to each other using DCE cable in the network 192.168.8.64
(one router has serial address of 192.168.8.65 and the other has serial address of 192.168.8.66).
Step 5: To configure static routing graphically, go to Router0 -> Routing -> Static.

Step 6: There fill in the following:

• Network Address : 192.168.8.96


• Mask Address : 255.255.255.224
• Next Hop : 192.168.8.66
Step 7: Repeat the previous step but with Router1

• Network Address : 192.168.8.32


• Mask Address : 255.255.255.224
• Next Hop : 192.168.8.65

Step 8: Check whether connection is made by using the ping command in the Command Prompt in
Desktop of Router0.
CLI COMMANDS
***(In Router0)***

Router>enable

Router#config t

Router(config)#ip route 192.168.8.96 255.255.255.224 192.168.8.66

Router(config)#exit
***(In Router1)***

Router>enable

Router#config t

Router(config)#ip route 192.168.8.32 255.255.255.224 192.168.8.65

Router(config)#exit
OUTPUT:
The ping command in the command prompt is as follows:

RESULT:
Hence static routing is configured using packet tracer.

RUBRICS:
EXPT NO: 3 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO : 4
DATE : 08/8/2019

ROUTER INFORMATION PROTOCOL (VERSION 1)


AIM:
To make connections using RIP v1.

PROCEDURE:
Step 1: Set up the routers and PCs.

Step 2: We give the IP addresses for the PCs as 192.168.1.2 and 192.168.2.2.

Step 3: For the routers we give IP addresses as 192.168.1.3 and 192.168.2.3 (all with default subnet
mask).

Step 4: The two routers are connected by serial DCE cable and given the IP addresses as 10.0.0.2
and 10.0.0.3.
Step 5: For RIP routing got to RIP in the Router0 menu and type in all the necessary addresses. In
this case we add 192.168.2.0, and 10.0.0.0.
Step 6: We repeat the previous step with Router1, adding networks 192.168.1.0, 192.168.2.0,
and 10.0.0.0.

Step 7: Check whether the connections are proper by using the ping command in the Command Prompt
in the Desktop Router0.
CLI COMMANDS
**(In Router0)**

Router>enable

Router#config t

Router(config)#router rip

Router(config-router)#network 192.168.2.0

Router(config-router)#network 10.0.0.0
**(In Router1)**

Router>enable

Router#config t

Router(config)#router rip

Router(config-router)#network 192.168.1.0

Router(config-router)#network 10.0.0.0

Router(config-router)#exit

Router(config)#exit
OUTPUT:
The ping command shows that the connections are proper.

RESULT:
Hence RIPv1 routing has been successfully verified and implemented.

RUBRICS:
EXPT NO: 4 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO: 5
DATE: 26/8/2019

ROUTER INFORMTION PROTOCOL( VERSION 2)

AIM:

To configure Router Information Protocol Version 2 using Cisco Packet Tracer and
subnetting.

PROCEDURE:
1. Set up the routers and PCs.
2. Giving the IP of PCs as 172.30.1.10, 10.1.0.10, and 172.30.100.10 and routers
as 172.30.1.1, 10.1.0.1 and 172.30.100.1

3. The Serial PC connection that is given are 209.165.200.230,


209.165.200.229, 209.165.200.233 and 209.165.200.234.
4. Check whether each PC connected to the other using ‘ping’ command.

5. In CLI, for each router type the router rip version #2.

CLI COMMANDS:

ROUTER 1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#
Router#
%SYS-5-CONFIG_I: Configured from console by console
ROUTER 2
Router(config)#interface Serial0/1/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0 Router(config-if)#ip
address 209.14.200.229 255.255.255.0 Router(config-if)#

ROUTER 3

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/1/1
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#
OUTPUT:
The connection can be established and checked by using the ping command.

RESULT:

Hence RIP version 2 configuration and subnetting has been performed successfully.

RUBRICS:

EXPT NO: 5 DESIGN(3) PROCEDURE OUTPUT(4) FACULTY


(3) SIGNATURE
EXPT NO: 6
DATE: 10/8/2019

EIGRP(Enhanced Interior Gateway Routing Protocol)


BANDWIDTH AND ADJACENCY
AIM:
To configure EIGRP routing using Cisco Packet Tracer and Subnetting.

PROCEDURE:
Step 1: Set up the Routers, PC and Switch as shown below.

Step 2: Assign Gateway and IP Address for all PC’s and Routers.

• For PC0 ,Assign Gateway:192.168.10.3 and IP Address:192.168.10.1


• For PC1 ,Assign Gateway:192.168.10.3 and IP Address:192.168.10.2

• For PC2 ,Assign Gateway:192.168.30.3 and IP Address:192.168.30.1


• For PC3 ,Assign Gateway:192.168.30.3 and IP Address:192.168.30.2
• For Router0, Assign Gigabit Ethernet 0/0:192.168.10.3 and Serial S0/1/0:192.168.20.1

• For Router1, Assign Gigabit Ethernet 0/0:192.168.30.3 and Serial S0/1/0:192.168.20.2

Step 3: Click on Router0 and switch to CLI Mode and type the following commands to assign
network address.
Router(config)# router eigrp 10

Router(config-router)# router 192.168.20.0 255.255.255.0

Router(config-router)# router 192.168.10.0 255.255.255.0

Step 4: Now click on Router1 and switch to CLI Mode and type the following commands to assign
network address.

Router(config) # router eigrp 10

Router(config-router)# router 192.168.30.0 255.255.255.0

Router(config-router)# router 192.168.20.0 255.255.255.0


Step 5: Ping in Command Prompt From PC1 using the command ping 192.168.30.0

Step 6: Now use the following commands in Router0

CLI COMMANDS

Router(config-if)# exit

Router(config)#exit

Router# show ip eigrp interfaces

Router# show ip eigrp neighbors

Router# show ip eigrp topology

Router# show interface Se0/1/0

Router# configure terminal

Router(config)# interface Se0/1/0

Router(config-if)# bandwidth 64
Router(config-if)# exit

Router(config)#exit

Router# show interface Se0/1/0

Router# debug ip packets


OUTPUT:
We can check the connection by using Ping command from PC1

RESULT:
Hence the connections are made and is configured using EIGRP.

RUBRICS:
EXPT NO: 6 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO: 7
DATE: 5/9/2019

EIGRP AUTHENTICATION AND TIMERS


AIM:
To perform EIGRP Authentication and Timers using Cisco Packet Tracer.
PROCEDURE:
Step 1: Set up the Routers, PC and Switch as shown below.s
Step 2: Assign Gateway and IP Address for PC’s and Routers.

• For PC0 ,Assign Gateway:192.168.10.3 and IP Address:192.168.10.1

• For PC1 ,Assign Gateway:192.168.10.3 and IP Address:192.168.10.2


• For PC2 ,Assign Gateway:192.168.30.3 and IP Address:192.168.30.1

• For PC3 ,Assign Gateway:192.168.30.3 and IP Address:192.168.30.2


• For Router0, Assign Gigabit Ethernet 0/0:192.168.10.3 and Serial S0/1/0:192.168.20.1

• For Router1, Assign Gigabit Ethernet 0/0:192.168.30.3 and Serial S0/1/0:192.168.20.2


Step 3: Click on Router0 and switch to CLI Mode and type the following commands to assign
network address.

Router(config) # router eigrp 10

Router(config-router)# network 192.168.20.0 255.255.255.0

Router(config-router)# network 192.168.10.0 255.255.255.0


Step 4: Now click on Router1 and switch to CLI Mode and type the following commands to assign
network address.

Router(config)# router eigrp 10

Router(config-router)# network 192.168.30.0 255.255.255.0

Router(config-router)# network 192.168.20.0 255.255.255.0

Step 5: Ping in Command Prompt From PC1 using the command ping 192.168.30.0.
Step 6: After implementing EIGRP Routing and verifying if the connection is successfully established,
type in the following CLI Commands to perform EIGRP Authentication and timers.

CLI COMMANDS:

Router#config t

Router(config)#keychain mykey

Router(config keychain)#key 1

Router(config-keychain-key)#key_string CISCO

Router(config-keychain-key)#exit

Router(config-keychain)#exit

Router(config)#interface Se0/1/0

Router(config-if)#ip authentication mode eigrp 10 mds

Router(config-if)#ip authentication keychain eigrp 10 mykey


Step 7: To set up timers, type in the following CLI Commands.

Router#show ip eigrp neighbors

Router#configure terminal

Router#ip hello_interval eigrp 10 2


OUTPUT:
We can check the connection by using Ping command from PC1

RESULT:
Hence the connection is made and we have performed EIGRP Authentication and timers.

RUBRICS:
EXPT NO: 7 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO: 8
DATE: 12/9/2019

SINGLE AREA OSPF


AIM:
To demonstrate Single area OSPF Using Cisco Packet Tracer

PROCEDURE:
Step 1: Set up the topology as shown
Step 2: Assign IP Address and Gateways for all Routers and PCs.
Step 3: Click on Router0 and type the following commands in CLI

Router(config)# router ospf 10

Router(config-router)# network 10.0.0.0 0.255.255.255 area 0

Router(config-router)# network 192.168.0.0 0.0.0.3 area 0

Router(config-router)# network 192.168.1.0 0.0.0.3 area 0

Router(config-router)# network 192.168.2.0 0.0.0.3 area 0

Router(config-router)# exit
Click on Router2 and type the following commands in
CLI Router(config)# router ospf 10

Router(config-router)# network 10.0.0.0 0.255.255.255 area 0

Router(config-router)# network 192.168.0.0 0.0.0.3 area 0

Router(config-router)# network 192.168.1.0 0.0.0.3 area 0

Router(config-router)# network 192.168.2.0 0.0.0.3 area 0

Router(config-router)# exit
Click on Router1 and type the following commands in CLI
Router(config)# router ospf 20 Router(config-router)#
network 192.168.0.4 0.0.0.3 area 0 Router(config-router)#
network 192.168.0.8 0.0.0.3 area 0 Router(config-router)#
exit
Click on Router4 and type the following commands in
CLI Router(config)# router ospf 60

Router(config-router)# network 20.0.0.0 0.255.255.255 area 0

Router(config-router)# network 192.168.0.8 0.0.0.3 area 0

Router(config-router)# network 192.168.2.8 0.0.0.3 area 0

Router(config-router)# network 192.168.1.4 0.0.0.3 area 0

Router(config-router)# exit
Click on Router5 and type the following commands in CLI
Router(config)# router ospf 30 Router(config-router)#
network 192.168.2.0 0.0.0.3 area 0 Router(config-router)#
network 192.168.2.4 0.0.0.3 area 0 Router(config-router)#
exit
Click on Router6 and type the following commands in CLI
Router(config)# router ospf 40 Router(config-router)#
network 192.168.2.8 0.0.0.3 area 0 Router(config-router)#
network 192.168.2.4 0.0.0.3 area 0 Router(config-router)#
exit

Step 4: Use the following additional commands in


CLI Router(config)# do show ip route Router(config)#
do show ip ospf Router(config)# do show ip ospf
neighbor
OUTPUT:
The connection has been successfully established.

RESULT:
Hence single area OSPF has been demonstrated.

RUBRICS:
EXPT NO: 8 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
EXPT NO: 9
DATE: 21/9/2019

MULTI AREA OSPF


AIM:
To perform Multi-Area OSPF using Cisco packet tracer.
PROCEDURE:
Step 1: Set up the network as shown
Step 2: Assign Gateway and IP Address to all Routers and PCs
Step 3: Type in the following CLI Commands for Router0, Router1, Router2 and Router3.

CLI COMMANDS:

1. For Router0

Router>enable Router#config

t Router(config)#router ospf

Router(config-router)#network 192.168.1.0 0.0.0.255 area 1


Router(config-router)#network 10.0.0.0 0.255.255.255 area 1
Router(config-router)#exit
2. For Router1

Router>enable Router#config

t Router(config)#router ospf

Router(config-router)#network 10.0.0.0 0.255.255.255 area 1


Router(config-router)#network 20.0.0.0 0.255.255.255 area 0
Router(config-router)#exit
3. For Router2

Router>enable Router#config

t Router(config)#router ospf

Router(config-router)#network 30.0.0.0 0.255.255.255 area 2


Router(config-router)#network 20.0.0.0 0.255.255.255 area 0
Router(config-router)#exit
4. For Router3

Router>enable Router#config

t Router(config)#router ospf

Router(config-router)#network 30.0.0.0 0.255.255.255 area 2


Router(config-router)#network 192.168.2.0 0.0.0.255 area 2
Router(config-router)#exit
OUTPUT:
The connection is checked by pinging using the ping command

RESULT:
Hence the Multi-area OSPF have been demonstrated.

RUBRICS:
EXPT NO: 9 DESIGN(3) PROCEDURE(3) OUTPUT(4) FACULTY
SIGNATURE
MARKS
///////////////////////

Das könnte Ihnen auch gefallen