Sie sind auf Seite 1von 84

SRM IST

Department of Computer Science and Engineering

III Year/V Sem B.Tech


Regulation : 2015
Sub. Code & Sub. Title : 15IT303J - Computer Networks Lab

LAB MANUAL

PURPOSE This course provides a foundation to understand computer networks using


Layered architectures. It also helps students to understand the various network
models, addressing concept, routing protocols and design aspects of computer
networks. .
INSTRUCTIONAL OBJECTIVES STUDENT OUTCOMES
At the end of the course, student will be able to
1. Understand the evolution of computer networks using the
b
layered network architecture.
2. Design computer networks using sub netting and routing c
Concepts in Packet Tracer
3. Understand and implement the various routing protocols such as
RIP, OSPF, and EIGRP using Packet Tracer. m

Contact C-D-
Sl. No. Description of Experiments IOs Reference
Hours I-O
1. IP Addressing and sub netting (VLSM) 2 D,I 1-4 1,2
LAN Configuration using straight
2. 2 D,I 3 2
through and cross over cables
3. Basic Router Configuration ( Creating 2 I 1 2
Passwords, Configuring Interfaces)
4. Static and Default Routing 4 I 1 2
5. RIPv1 4 I 2 1,2
6. RIPv2 2 I 2 1,2
EIGRP Configuration, Bandwidth, and
7. 4 I 2 2
Adjacencies
8. EIGRP Authentication and Timers 2 I 2 2
9. Single-Area OSPF Link Costs and 2 I 2 1,2
Interface
10. Multi-Area OSPF with Stub Areas and 2 I 2 2
Authentication
Redistribution Between EIGRP and
11. 2 I 2 2
OSPF
12. Model Examination 2
Total Contact Hours 30

1
SRM IST
Department of Computer Science and Engineering

Sub. Code / Sub. Title: 15IT303J / Computer Networks Lab

Course Outcomes:
Course Outcome 1: The students will be able to design and communicate between any network node using Packet Tracer.

Course Outcome 2: The students will be able to implement the CIDR and VLSM.

Course Outcome 3: The students will be able to implement and compare the various routing algorithms.

Course Outcome 4: he students will be able to design and simulate any kind of network using packet tracer

Assessment Method – Practical Component (Weightage 50%)


IN Assessment Experiments Record MCQ/ Model Total
semester tool Viva voce Examination
Weightage 40 5 5 10 60
End semester examination Weightage 40

2
SRM IST
Department of Computer Science and Engineering

Exercise No 1. Introduction to Packet Tracer

1.What is Packet Tracer?

Packet Tracer is a protocol simulator developed by Dennis Frezzo and his team at Cisco
Systems. Packet Tracer (PT) is a powerful and dynamic tool that displays the various
protocols used in networking, in either Real Time or Simulation mode. This includes
layer 2 protocols such as Ethernet and PPP, layer 3 protocols such as IP, ICMP, and ARP,
and layer 4 protocols such as TCP and UDP. Routing protocols can also be traced.

Purpose: The purpose of this lab is to become familiar with the Packet Tracer
interface. Learn how to use existing topologies and build your own.

Requisite knowledge: This lab assumes some understanding of the Ethernet


protocol. At this point we have not discussed other protocols, but will use Packet
Tracer in later labs to discuss those as well.
Version: This lab is based on Packet Tracer 4.0 Beta, Test1. Introduction to the

Packet Tracer Interface using a Hub Topology Step 1: Start Packet Tracer and

Entering Simulation Mode

3
SRM IST
Department of Computer Science and Engineering

Step 2: Choosing Devices and Connections

We will begin building our network topology by selecting devices and the media in
which to connect them.
Several types of devices and network connections can be used. For this lab we will
keep it simple by using End Devices, Switches, Hubs, and Connections.

Single click on each group of devices and connections to display the various choices.

Step 3: Building the Topology – Adding Hosts Single click

on the End Devices.

4
SRM IST
Department of Computer Science and Engineering

Move the cursor into topology area. You will notice it turns into a plus “+” sign.
Single click in the topology area and it copies the device.

5
SRM IST
Department of Computer Science and Engineering

Step 4: Building the Topology – Connecting the Hosts to Hubs and Switches

Adding a Hub
Select a hub, by clicking once on Hubs and once on a Generic hub.

Perform the following steps to connect PC0 to Hub0:


1. Click once on PC0
2. Choose FastEthernet
3. Drag the cursor to Hub0
4. Click once on Hub0 and choose Port 0

6
SRM IST
Department of Computer Science and Engineering

5. Notice the green link lights on both the PC0 Ethernet NIC and the Hub0 Port 0
showing that the link is active.

Adding a Switch
Select a switch, by clicking once on Switches and once on a 2950-24 switch.

Add the switch by moving the plus sign “+” below PC2 and PC3 and click once.

7
SRM IST
Department of Computer Science and Engineering

Connect PC2 to Hub0 by first choosing Connections.

Click once on the Copper Straight-through cable.

8
SRM IST
Department of Computer Science and Engineering

Perform the following steps to connect PC2 to Switch0:


1. Click once on PC2
2. Choose FastEthernet
3. Drag the cursor to Switch0
4. Click once on Switch0 and choose FastEthernet0/1
5. Notice the green link lights on PC2 Ethernet NIC and amber light Switch0
FastEthernet0/1 port. The switch port is temporarily not forwarding frames, while it goes
through the stages for the Spanning Tree Protocol (STP) process.
6. After a about 30 seconds the amber light will change to green indicating that the
port has entered the forwarding stage. Frames can now forwarded out the switch
port.

9
SRM IST
Department of Computer Science and Engineering

Step 5: Configuring IP Addresses and Subnet Masks on the Hosts

Before we can communicate between the hosts we need to configure IP


Addresses and Subnet Masks on the devices.

Click once on PC0.

Choose the Config tab. It is here that you can change the name of PC0. It is also here
where you would enter a Gateway IP Address, also known as the default gateway. We
will discuss this later, but this would be the IP address of the local router. If you want,
you can enter the IP Address 172.16.1.1, although it will not be used in this lab.

Click on FastEthernet. Although we have not yet discussed IP Addresses, add the IP
Address to 172.16.1.10. Click once in the Subnet Mask field to

10
SRM IST
Department of Computer Science and Engineering

enter the default Subnet Mask. You can leave this at 255.255.0.0. We will discuss
this later.

Also, notice this is where you can change the Bandwidth (speed) and Duplex of the
Ethernet NIC (Network Interface Card). The default is Auto (autonegotiation), which
means the NIC will negotiate with the hub or switch. The bandwidth and/or duplex can
be manually set by removing the check from the Auto box and choosing the specific
option.
Bandwidth - Auto
If the host is connected to a hub or switch port which can do 100 Mbps, then the
Ethernet NIC on the host will choose 100 Mbps (Fast Ethernet). Otherwise, if the hub or
switch port can only do 10 Mbps, then the Ethernet NIC on the host will choose 10
Mbps (Ethernet).
Duplex - Auto

Hub: If the host is connected to a hub, then the Ethernet NIC on the host will choose
Half Duplex.

Switch: If the host is connected to a switch, and the switch port is configured as Full
Duplex (or Autonegotiation), then the Ethernet NIC on the host will choose Full Duplex.
If the switch port is configured as Half Duplex, then the

11
SRM IST
Department of Computer Science and Engineering

Ethernet NIC on the host will choose Half Duplex. (Full Duplex is a much more
efficient option.)
The information is automatically saved when entered.

Repeat these steps for the other hosts. Use the information below for IP
Addresses and Subnet Masks.
Host IP Address Subnet Mask
PC0 172.16.1.10 255.255.0.0
PC1 172.16.1.11 255.255.0.0
PC2 172.16.1.12 255.255.0.0
PC3 172.16.1.13 255.255.0.0

Verify the information


To verify the information that you entered, move the Select tool (arrow) over each host.

Deleting a Device or Link


To delete a device or link, choose the Delete tool and click on the item you wish to
delete.

12
SRM IST
Department of Computer Science and Engineering

Step 6: Connecting Hub0 to Switch0

To connect like-devices, like a Hub and a Switch, we will use a Cross-over cable.
Click once the Cross-over Cable from the Connections options.

Move the Connections cursor to Switch0.

13
SRM IST
Department of Computer Science and Engineering

Click once on Switch0 and choose FastEthernet0/4 (actual port does not matter).

The link light for switch port FastEthernet0/4 will begin as amber and eventually change
to green as the Spanning Tree Protocol transitions the port to forwarding.

14
SRM IST
Department of Computer Science and Engineering

15
SRM IST
Department of Computer Science and Engineering

Exercise 2. Types of Network Topology

TOPOLOGIES MADE IN PACKET TRACER USING HUB OR SWITCH

1. BUS TOPOLOGY
A bus topology is a network setup in which each computer and network device are
connected to a single cable or backbone.
Steps to make a bus topology:-
1. Drag the end user devices or workstations onto the workspace.
2. Connect the workstations together as shown in the figure.
3. After each device has been connected to each other using switches/hubs, the IP
address of each workstation is entered. The subnet mask is automatically set by the
Cisco packet tracer.
4. After this, the following topology can be implemented in two ways:-
a. REALTIME
The command prompt of the source workstation is opened. Command to ping
the destination workstation is entered. We will see the replies received from the
destination and the amount of bytes received as well as the amount of time
required.
b. SIMULATION
In this mode, the message icon is dragged onto the source device and then on
the destination device. On clicking Auto Capture/Play, we see that the message
is being delivered to the destination with the broadcasting of the message until it
reaches the desired workstation.
5. TOOLS:

Cables: While configuring bus topology, two different grades of Co-axial cables were used.
The two grades were RG-58 (Radio Grade 58) and RG-8 (Radio Grade 8). RG-58 is also referred
to as Thicknet or sometimes as 10Base5. RG-58 was used as the trunk or backbone cable in bus
topology. On the other hand RG-8 was referred to as Thinnet or sometimes as 10Base2 and was
used as branch cables that used to connect the PCs with the backbone cable.

Connectors: T-Connecters were used to join the branch cables with the trunk and
were T in shapes.

Terminators: Terminators were the 50 ohms resistors that were connected to each end of the
trunk. These resistors were grounded in order to ground and neutralize all garbage data of the
trunk cable that was generated because of the collisions that used to occur in a bus topology.

16
SRM IST
Department of Computer Science and Engineering

Bayonet Neill–Concelman or BNCs: These connectors were used to connect the branch cables
with the PCs. The branch cables were crimped with the BNC connectors and then the
connectors were connected to the available ports in the NICs (LAN cards) that were installed in
the PCs.

Features of Bus Topology

1. It transmits data only in one direction.


2. Every device is connected to a single cable

Advantages of Bus Topology

1. It is cost effective.
2. Cable required is least compared to other network topology.
3. Used in small networks.
4. It is easy to understand.
5. Easy to expand joining two cables together.

Disadvantages of Bus Topology

1. Cables fails then whole network fails.


2. If network traffic is heavy or nodes are more the performance of the network decreases.
3. Cable has a limited length.
4. It is slower than the ring topology.

2. RING Topology

17
SRM IST
Department of Computer Science and Engineering

A ring network is a network topology in which each node connects to exactly two other nodes,
forming a single continuous pathway for signals through each node - a ring. Data travels from
node to node, with each node along the way handling every packet.
Rings can be unidirectional, with all traffic travelling either clockwise or anticlockwise around
the ring, or bidirectional Because a unidirectional ring topology provides only one pathway
between any two nodes, unidirectional ring networks may be disrupted by the failure of a single
link.[1] A node failure or cable break might isolate every node attached to the ring.

Steps to make a ring topology:-


i. Drag the end user devices or workstations onto the workspace.
ii. Connect the workstations together as shown in the figure. Connect each switch to
the next switch and every end user device to its respective switch.
iii. After each device has been connected to each other using switches/hubs, the IP
address of each workstation is entered. The subnet mask is automatically set by the
Cisco packet tracer.
iv. After this, the following topology can be implemented in two ways:-
a. REALTIME
The command prompt of the source workstation is opened. Command to ping
the destination workstation is entered. We will see the replies received from the
destination and the amount of bytes received as well as the amount of time
required.
b. SIMULATION
In this mode, the message icon is dragged onto the source device and then on
the destination device. On clicking Auto Capture/Play, we see that the message
is being delivered to the destination with the broadcasting of the message until it
reaches the desired workstation.

TOOLS:

END USER DEVICE: An end user device is a personal computer (desktop or laptop),
consumer device (e.g., personal digital assistant (PDA), smart phone), or removable
storage media (e.g., USB flash drive, memory card, external hard drive, writeable CD or
DVD) that can store information.
SWITCH: A network switch (also called switching hub, bridging hub, officially MAC
bridge) is a computer networking device that connects devices together on a computer
network by using packet switching to receive, process, and forward data to the
destination device.

18
SRM IST
Department of Computer Science and Engineering

COPPER STRAIGHT CABLE: Straight-through cable is a type of twisted pair copper


wire cable for local area network (LAN) use for which the RJ-45 connectors at each end
have the same pinout (i.e., arrangement of conductors). ... Straight-through cable is also
commonly referred to as patch cable.

COPPER CROSS CABLE: Crossover cable is a cable that is used to interconnect


computers by “crossing over”(reversing)their respective pin contacts.

Features of Ring Topology

1. A number of repeaters are used for Ring topology with large number of nodes, because
if someone wants to send some data to the last node in the ring topology with 100
nodes, then the data will have to pass through 99 nodes to reach the 100th node. Hence
to prevent data loss repeaters are used in the network.
2. The transmission is unidirectional, but it can be made bidirectional by having 2
connections between each Network Node, it is called Dual Ring Topology.
3. In Dual Ring Topology, two ring networks are formed, and data flow is in opposite
direction in them. Also, if one ring fails, the second ring can act as a backup, to keep the
network up.

19
SRM IST
Department of Computer Science and Engineering

4. Data is transferred in a sequential manner that is bit by bit. Data transmitted, has to
pass through each node of the network, till the destination node.

Advantages of Ring Topology

1. Transmitting network is not affected by high traffic or by adding more nodes, as only the
nodes having tokens can transmit data.
2. Cheap to install and expand

Disadvantages of Ring Topology

1. Troubleshooting is difficult in ring topology.


2. Adding or deleting the computers disturbs the network activity.
3. Failure of one computer disturbs the whole network.

3. STAR TOPOLOGY
A star topology is a topology for a Local Area Network (LAN) in which all nodes are
individually connected to a central connection point, like a hub or a switch. A star takes
more cable than e.g. a bus, but the benefit is that if a cable fails, only one node will be
brought down.
Steps to make a star topology:-
v. Drag the end user devices or workstations onto the workspace.
vi. Connect the workstations together as shown in the figure.
vii. After each device has been connected to each other using switches/hubs, the IP
address of each workstation is entered. The subnet mask is automatically set by the
Cisco packet tracer.
viii. After this, the following topology can be implemented in two ways:-
c. REALTIME
The command prompt of the source workstation is opened. Command to ping
the destination workstation is entered. We will see the replies received from the
destination and the amount of bytes received as well as the amount of time
required.
d. SIMULATION
In this mode, the message icon is dragged onto the source device and then on
the destination device. On clicking Auto Capture/Play, we see that the message
is being delivered to the destination with the broadcasting of the message until it
reaches the desired workstation.

TOOLS:

20
SRM IST
Department of Computer Science and Engineering

END USER DEVICE: : An end user device is a personal computer (desktop or


laptop), consumer device (e.g., personal digital assistant (PDA), smart phone), or
removable storage media (e.g., USB flash drive, memory card, external hard
drive, writeable CD or DVD) that can store information.

SWITCH: : A network switch (also called switching hub, bridging hub, officially
MAC bridge) is a computer networking device that connects devices together on
a computer network by using packet switching to receive, process, and forward
data to the destination device.

COPPER STRAIGHT CABLE: Straight-through cable is a type of twisted pair copper


wire cable for local area network (LAN) use for which the RJ-45 connectors at
each end have the same pinout (i.e., arrangement of conductors). ... Straight-
through cable is also commonly referred to as patch cable.

Features of Star Topology

21
SRM IST
Department of Computer Science and Engineering

1. Every node has its own dedicated connection to the hub.


2. Hub acts as a repeater for data flow.
3. Can be used with twisted pair, Optical Fibre or coaxial cable.

Advantages of Star Topology

1. Fast performance with few nodes and low network traffic.


2. Hub can be upgraded easily.
3. Easy to troubleshoot.
4. Easy to setup and modify.
5. Only that node is affected which has failed, rest of the nodes can work smoothly.

Disadvantages of Star Topology

1. Cost of installation is high.


2. Expensive to use.
3. If the hub fails then the whole network is stopped because all the nodes depend on the
hub.
4. Performance is based on the hub that is it depends on its capacity

4. EXTENDED STAR TOPOLOGY


Extended star topology is a connection of all individual star topologies using an
additional networking device.
Steps to make an extended star topology:-
i. Drag the end user devices or workstations onto the workspace.
ii. Connect the workstations together as shown in the figure.
iii. After each device has been connected to each other using switches/hubs, the IP address
of each workstation is entered. The subnet mask is automatically set by the Cisco
packet tracer.
iv. After this, the following topology can be implemented in two ways:-
a. REALTIME
The command prompt of the source workstation is opened. Command to ping
the destination workstation is entered. We will see the replies received from the
destination and the amount of bytes received as well as the amount of time
required.

22
SRM IST
Department of Computer Science and Engineering

b. SIMULATION
In this mode, the message icon is dragged onto the source device and then on the
destination device. On clicking Auto Capture/Play, we see that the message is being
delivered to the destination with the broadcasting of the message until it reaches the
desired workstation.

TOOLS:
END USER DEVICE: An end user device is a personal computer (desktop or
laptop), consumer device (e.g., personal digital assistant (PDA), smart phone), or
removable storage media (e.g., USB flash drive, memory card, external hard
drive, writeable CD or DVD) that can store information.

SWITCH: :A network switch (also called switching hub, bridging hub, officially MAC
bridge) is a computer networking device that connects devices together on a computer
network by using packet switching to receive, process, and forward data to the
destination device.

COPPER CROSS CABLE: Crossover cable is a cable that is used to interconnect two
computers by "crossing over" (reversing) their respective pin contacts.

COPPER STRAIGHT CABLES: Straight-through cable is a type of twisted pair copper wire
cable for local area network (LAN) use for which the RJ-45 connectors at each end have
the same pinout (i.e., arrangement of conductors). ... Straight-through cable is also
commonly referred to as patch cable.

23
SRM IST
Department of Computer Science and Engineering

5. MESH TOPOLOGY
A network setup where each computer and network device is interconnected with one
another, allowing for most transmissions to be distributed, even if one of the
connections go down. It is a topology commonly used for wireless networks.
Steps to make a mesh topology:-
i. Drag the end user devices or workstations onto the workspace.

ii. Connect the workstations together as shown in the figure.


iii. After each device has been connected to each other using switches/hubs, the IP address
of each workstation is entered. The subnet mask is automatically set by the Cisco
packet tracer.
iv. After this, the following topology can be implemented in two ways:-
a. REALTIME
The command prompt of the source workstation is opened. Command to ping
the destination workstation is entered. We will see the replies received from the
destination and the amount of bytes received as well as the amount of time
required.
b. SIMULATION
In this mode, the message icon is dragged onto the source device and then on
the destination device. On clicking Auto Capture/Play, we see that the message
is being delivered to the destination with the broadcasting of the message until it
reaches the desired workstation.

TOOLS:

24
SRM IST
Department of Computer Science and Engineering

END USER DEVICE: : An end user device is a personal computer (desktop or laptop), consumer
device (e.g., personal digital assistant (PDA), smart phone), or removable storage media (e.g.,
USB flash drive, memory card, external hard drive, writeable CD or DVD) that can store
information.

SWITCH: : A network switch (also called switching hub, bridging hub, officially MAC bridge) is a
computer networking device that connects devices together on a computer network by using
packet switching to receive, process, and forward data to the destination device.
COPPER CROSS CABLE: Crossover cable is a cable that is used to interconnect two computers by
"crossing over" (reversing) their respective pin contacts.

COPPER STRAIGHT CABLES: Straight-through cable is a type of twisted pair copper wire cable
for local area network (LAN) use for which the RJ-45 connectors at each end have the same
pinout (i.e., arrangement of conductors). ... Straight-through cable is also commonly referred to
as patch cable.

Features of Mesh Topology

1. Fully connected.
2. Robust.
3. Not flexible.

25
SRM IST
Department of Computer Science and Engineering

Advantages of Mesh Topology

1. Each connection can carry its own data load.


2. It is robust.
3. Fault is diagnosed easily.
4. Provides security and privacy.

Disadvantages of Mesh Topology

1. Installation and configuration is difficult.


2. Cabling cost is more.
3. Bulk wiring is required.

6. HYBRID TOPOLOGY
A hybrid topology is a type of network topology that uses two or more other network
topologies, including bus topology, mesh topology, ring topology, star topology, and
tree topology.
Steps to make an extended star topology:-
i. Drag the end user devices or workstations onto the workspace.
ii. Connect the workstations together as shown in the figure.
iii. After each device has been connected to each other using switches/hubs, the IP address
of each workstation is entered. The subnet mask is automatically set by the Cisco
packet tracer.
iv. After this, the following topology can be implemented in two ways:-
a. REALTIME
The command prompt of the source workstation is opened. Command to ping
the destination workstation is entered. We will see the replies received from the
destination and the amount of bytes received as well as the amount of time
required.
b. SIMULATION
In this mode, the message icon is dragged onto the source device and then on
the destination device. On clicking Auto Capture/Play, we see that the message
is being delivered to the destination with the broadcasting of the message until it
reaches the desired workstation.

26
SRM IST
Department of Computer Science and Engineering

TOOLS:

END USER DEVICES: An end user device is a personal computer (desktop or laptop), consumer
device (e.g., personal digital assistant (PDA), smart phone), or removable storage media (e.g.,
USB flash drive, memory card, external hard drive, writeable CD or DVD) that can store
information.

HUBS: An Ethernet hub, active hub, network hub, repeater hub, multiport repeater, or simply
hub is a network hardware device for connecting multiple Ethernet devices .

SWITCHES: A network switch (also called switching hub, bridging hub, officially MAC bridge) is a
computer networking device that connects devices together on a computer network by using
packet switching to receive, process, and forward data to the destination device.

COPPER CROSS CABLE: Crossover cable is a cable that is used to interconnect two computers by
"crossing over" (reversing) their respective pin contacts.

COPPER STRAIGHT CABLES: Straight-through cable is a type of twisted pair copper wire cable
for local area network (LAN) use for which the RJ-45 connectors at each end have the same
pinout (i.e., arrangement of conductors). ... Straight-through cable is also commonly referred to
as patch cable.

27
SRM IST
Department of Computer Science and Engineering

Features of Hybrid Topology

1. It is a combination of two or topologies


2. Inherits the advantages and disadvantages of the topologies included

Advantages of Hybrid Topology

1. Reliable as Error detecting and trouble shooting is easy.


2. Effective.
3. Scalable as size can be increased easily.
4. Flexible.

Disadvantages of Hybrid Topology

1. Complex in design.
2. Costly.

28
SRM IST
Department of Computer Science and Engineering

Exercise 3. Subnetting

Packet Tracer – Subnetting Scenario 1

Addressing Table

29
SRM IST
Department of Computer Science and Engineering

Objectives

Part 1: Design an IP Addressing Scheme

Part 2: Assign IP Addresses to Network Devices and Verify Connectivity

Scenario

In this activity, you are given the network address of 192.168.100.0/24 to subnet and provide
the IP addressing for the network shown in the topology. Each LAN in the network requires
enough space for, at least, 25 addresses for end devices, the switch and the router. The
connection between R1 to R2 will require an IP address for each end of the link.

Part 1: Design an IP Addressing Scheme


Step 1: Subnet the 192.168.100.0/24 network into the appropriate number of subnets.

a. Based on the topology, how many subnets are needed? 5

b. How many bits must be borrowed to support the number of subnets in the topology table? 3
bits

c. How many subnets does this create? 2^3 = 8 subnets (support subnet zero)

d. How many usable hosts does this create per subnet? 2^5 – 2 = 30 hosts

Note: If your answer is less than the 25 hosts required, then you borrowed too many bits.

e. Calculate the binary value for the first five subnets. The first subnet is already shown.

Net 0: 192 . 168 . 100 . 0 0 0 0 0 0 0 0

Net 1: 192 . 168 . 100 . => 192.168.100.00100000

Net 2: 192 . 168 . 100 . => 192.168.100.01000000

Net 3: 192 . 168 . 100 . => 192.168.100.01100000

Net 4: 192 . 168 . 100 . => 192.168.100.10000000

f. Calculate the binary and decimal value of the new subnet mask.

11111111.11111111.11111111. _ =>
11111111.11111111.11111111.11100000
255 . 255 . 255 . => 255 . 255 . 255 .224

30
SRM IST
Department of Computer Science and Engineering

g. Fill in the Subnet Table, listing the decimal value of all available subnets, the first and last
usable host address, and the broadcast address. Repeat until all addresses are listed.

Note: You may not need to use all rows.

Subnet Table

Step 2: Assign the subnets to the network shown in the topology.

a. Assign Subnet 0 to the LAN connected to the GigabitEthernet 0/0 interface of R1: –
192.168.100.0 /27

b. Assign Subnet 1 to the LAN connected to the GigabitEthernet 0/1 interface of R1: –
192.168.100.32 /27

c. Assign Subnet 2 to the LAN connected to the GigabitEthernet 0/0 interface of R2: –
192.168.100.64 /27

d. Assign Subnet 3 to the LAN connected to the GigabitEthernet 0/1 interface of R2: –
192.168.100.96 /27

e. Assign Subnet 4 to the WAN link between R1 to R2: – 192.168.100.128 /27

31
SRM IST
Department of Computer Science and Engineering

Step 3: Document the addressing scheme.

Fill in the Addressing Table using the following guidelines:

a. Assign the first usable IP addresses to R1 for the two LAN links and the WAN link.

b. Assign the first usable IP addresses to R2 for the LANs links. Assign the last usable IP address
for the WAN link.

c. Assign the second usable IP addresses to the switches.

d. Assign the last usable IP addresses to the hosts.

Part 2: Assign IP Addresses to Network Devices and Verify Connectivity

Most of the IP addressing is already configured on this network. Implement the following steps
to complete the addressing configuration.

Step 1: Configure IP addressing on R1 LAN interfaces.


Step 2: Configure IP addressing on S3, including the default gateway.
Step 3: Configure IP addressing on PC4, including the default gateway.

Instructions

R1(config)#interface gigabitEthernet 0/0


R1(config-if)#ip address 192.168.100.1 255.255.255.224
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface gigabitEthernet 0/1


R1(config-if)#ip address 192.168.100.33 255.255.255.224
R1(config-if)#no shutdown

S3#configure terminal
S3(config)#interface vlan 1
S3(config-if)#ip address 192.168.100.66 255.255.255.224
S3(config-if)#no shutdown
S3(config-if)#exit
S3(config)#ip default-gateway 192.168.100.65

32
SRM IST
Department of Computer Science and Engineering

Step 4: Verify connectivity.

You can only verify connectivity from R1, S3, and PC4. However, you should be able to ping
every IP address listed in the Addressing Table.

Suggested Scoring Rubric

33
SRM IST
Department of Computer Science and Engineering

Exercise 4. Variable Length Subnet Mask

Difference

VLSM:
The recursion is performed on the address space previously assigned to an
organization and is invisible to the global Internet.

CIDR:
CIDR permits the recursive allocation of an address blocked by an Internet
Registry to a high-level ISP, to a mid level to a lower level ISP and finally to a
private organization’s network.
The issues to be considered while
designing a network

1. How many total subnets does the organization need today?

2. How many total subnets will the organization need in the future?

3. How many hosts are there on the organization’s largest subnet today?

4. How many hosts will there be on the organization’s largest subnet in the
future?

34
SRM IST
Department of Computer Science and Engineering

35
SRM IST
Department of Computer Science and Engineering

Solution to Problem 1:

To support 26 hosts on a subnet, a minimum of 5 bits is needed in the host portion of


the address. 5 bits result in 30 possible host addresses (2^5-2). The other 3 bits in the
last octet can be added to the default 24-bit Class C mask. Thus, a 27-bit mask can be
used to create the following subnets:-

Subnet # Subnet Address

0 192.168.15.0 /27 Sub-subnet 0 192.168.15.0 /30


1 192.168.15.32 /27 Sub-subnet 1 192.168.15.4 /30
2 192.168.15.64 /27 Sub-subnet 2 192.168.15.8 /30
3 192.168.15.96 /27 Sub-subnet 3 192.168.15.12 /30
4 192.168.15.128 /27 Sub-subnet 4 192.168.15.16 /30
Sub-subnet 5 192.168.15.20 /30
5 192.168.15.160 /27 Sub-subnet 6 192.168.15.24 /30
6 192.168.15.192 /27

To maximize the address space, the 192.168.150.0 /27 subnet is further subnetted
using a 30-bit mask. This creates subnets that can be used on point-to-point links with
minimal waste, because each subnet contains only 2 possible host addresses.

36
SRM IST
Department of Computer Science and Engineering

37
SRM IST
Department of Computer Science and Engineering

38
SRM IST
Department of Computer Science and Engineering

Solution to Problem 2:

The network address given is 192.168.15.0. Since this is the only network address
available it cannot be supernetted. Also the problem we are now facing is that one
subnet requires 60 hosts and we require at least 4 subnets. Therefore at least 3 bits are
needed for 4 subnets (2^3-2=6). We are therefore left with 5 bits which would give us a
maximum of 30 hosts (2^5-2).
We solve this problem by supernetting 2 subnets. A 27-bit mask can be used to create
the following subnets:-

Subnet # Subnet Address

0 192.168.15.0 /27
1 192.168.15.32 /27

2 192.168.15.64 /27 Sub-subnet 0 192.168.15.0 /30

3 192.168.15.96 /27 Sub-subnet 1 192.168.15.4 /30

4 192.168.15.128 /27 Sub-subnet 2 192.168.15.8 /30

5 192.168.15.160 /27 Sub-subnet 3 192.168.15.12 /30

6 192.168.15.192 /27 Sub-subnet 4 192.168.15.16 /30

Sub-subnet 5 192.168.15.20 /30


Sub-subnet 6 192.168.15.24 /30

The 2 subnets viz. subnet #2 and #3 can be supernetted using a 26-bit mask thus giving
a subnet 192.168.15.64 /26 which provides 62 (2^6-2) hosts on this subnet.

39
SRM IST
Department of Computer Science and Engineering

To maximize the address space, the 192.168.15.0 /27 subnet is further subnetted
using a 30-bit mask. This creates subnets that can be used on point-to-point links with
minimal waste, because each subnet contains only 2 possible host addresses.

40
SRM IST
Department of Computer Science and Engineering

41
SRM University
Department of Computer Science and Engineering

Exercise 5. Configuring Static and Default Routes

Overview

It is important to know how to configure static routes on a router. Many networks


are small enough that all of the routing can be handled by a few static routes and a
default route out of the network. If you want to know a router’s routes you need to
look at its routing table. The routing table will show you connected routes, static
routes, if there is a default route, and it will also show you if there are any
dynamically learned routes too. In this section we will look at connected routes,
static routes and default routes.

Connected Routes

Connected routes are routes to networks directly connected to the router. To


establish connected routes all you have to do is bring up your router’s interfaces.
This means configuring the router’s interfaces with IP addresses and subnet masks
and making sure they are not in an administratively shutdown state.

To configure a Fast Ethernet interface from global configuration mode:

R1(config)#interface fastethernet 0/0


R1(config-if)#ip address <your ip address> <your subnet mask>
R1(config-if)#description <your description>
R1(config-if)#no shutdown

To configure a serial interface from global configuration mode. You can first check
to see if your interface is the DCE and will need a clock rate:

R1#show controllers serial 0/0

Checking the “show controllers” command results to see If the interface is the DCE,
you can see from the output below, that the interface is in fact the DCE, and that
the clock rate needs to be set.

42
SRM University
Department of Computer Science and Engineering

R1(config)#interface serial 0/0


R1(config-if)#ip address <your ip address> <your subnet mask>
R1(config-if)#clock rate 64000 (only if the interface is the DCE)
R1(config-if)#description <your description>
R1(config-if)#no shutdown

Now that the interfaces have been brought up you can see the connected routes by
looking at the routing table by issuing a “show ip route” command and looking for
the lines that start with “c”:

Static Routes

In the picture below, R1 has three connected networks in its routing table but it
does not know about the 192.168.2.0 network and therefore cannot route traffic to
it. To solve that problem a static route to the 192.168.2.0 network can be
configured.

43
SRM University
Department of Computer Science and Engineering

There are two ways of configuring a static route. The first uses the next hop router’s
IP address on the connected network:

R1(config)#ip route <destination network> <subnet mask> <next hop router


address>

The second uses the router’s own exit interface. This way is faster for the router
because it doesn’t have to first look up the exit interface from the connected
network:

R1(config)#ip route <destination network> <subnet mask> <local router exit


interface>

both types of static route commands are listed below:

44
SRM University
Department of Computer Science and Engineering

After the static route has been configured you should be able to verify the static
route in the router’s routing table be issuing a #show ip route command and looking
for the “s” entry in the routing table. The image below shows the router’s routing
table after a static route was configured and the “show ip route” command was
executed. Notice the highlighted static route which starts with an “s” in the routing
table:
R1(config)#ip route 192.168.2.0 255.255.255.0 fa1/0
R1#show ip route

Default Routes

In the diagram below R1 needs a default route or gateway of last resort configured
so that it can route traffic to unknown networks across the internet. If R1 does not
have a default route, traffic to all unknown networks will be dropped, and surfing

45
SRM University
Department of Computer Science and Engineering

the Web will not be possible. To configure a default route you must configure a
static route to the 0.0.0.0 network and 0.0.0.0 subnet mask to the next hop router
or exit interface which has a path out of the network (see below). The commands to
create a default route or gateway of last resort are:

R1(config)#ip route 0.0.0.0 0.0.0.0 <next hop router IP address>


or
R1(config)#ip route 0.0.0.0 0.0.0.0 <exit interface>

Once you have configured a default route it will show up in the routing table as an
“s” with an asterisk “*” next to it signifying it as a default route. You can also see
from the highlighted areas in the routing table output below that the default route
is also acknowledged as the “Gateway of last resort is 0.0.0.0 to network 0.0.0.0”
(see below):

46
SRM University
Department of Computer Science and Engineering

Exercise 6. Router configuration

Aim: Configure a Network topology using packet tracer software.

Apparatus (Software): Packet tracer Software

Procedure: To implement this practical following network topology is required


to be configured using the commands learned in previous practical.

After configuring the given network a packet should be ping from any one
machine to another.

47
SRM University
Department of Computer Science and Engineering

Router0 Configuration Command.........

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.0.254 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up %LINEPROTO-5-


UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0 Router(config-
if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console Router#wr
Building configuration...
[OK]
Router#show running-config Building
configuration...

Current configuration : 542 bytes


!
version 12.2

48
SRM University
Department of Computer Science and Engineering

no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.0 duplex auto
speed auto
!
interface FastEthernet1/0 no ip address
duplex auto speed auto
shutdown
!
interface Serial2/0
ip address 192.168.1.1 255.255.255.0
!interface Serial3/0 no ip address shutdown
!
interface FastEthernet4/0 no ip address
shutdown
!
interface FastEthernet5/0 no ip address
shutdown
!
ip classless
!
!
!
!
!
line con 0 line vty 0 4 login
!
!
end

Router#

49
SRM University
Department of Computer Science and Engineering

Router1 Configuration Command.......

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable
Router# Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial2/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0 Router(config-if)#no
shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to up Router(config-if)#exit


Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console Router#config t

Enter configuration commands, one per line. End with CNTL/Z.


Router(config)#
Router(config)#interface Serial2/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.2.254 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up %LINEPROTO-5-


UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by
console Router#wr
Building configuration...
[OK]
Router#
Router#show running-
config Building
configuration...

50
SRM University
Department of Computer Science and Engineering

Current configuration : 542 bytes


!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
ip address 192.168.2.254
255.255.255.0 duplex auto
speed auto
!
interface
FastEthernet1/0 no ip
address
duplex
auto
speed
auto
shutdown
!
interface Serial2/0
ip address 192.168.1.2 255.255.255.0
!

51
SRM University
Department of Computer Science and Engineering

interface Serial3/0 no ip address


shutdown
!
interface FastEthernet4/0 no ip address
shutdown
!
interface FastEthernet5/0 no ip address
shutdown
!
ip classless
!
!
!
!
!
line con 0 line vty 0 4 login
!
!
end

Router#

IP ROUTE Command.....
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.2.2
Router(config)#exit
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP
external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U -
per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.2.0/24 is directly connected, FastEthernet0/0 C 192.168.1.2/24 is


directly connected, Serial2/0
S 192.168.2.0/24 [1/0] via 192.168.1.2 Router#

52
SRM University
Department of Computer Science and Engineering

IP ROUTE Command.....

Router>enable Router#show ip route


Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP
external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF
NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U -
per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

S 192.168.0.0/24 [1/0] via 192.168.1.1


C 192.168.0.0/24 is directly connected, FastEthernet0/0 C 192.168.1.1/24 is
directly connected, Serial2/0 Router#

53
SRM University
Department of Computer Science and Engineering

Lab 5 : Basic RIP V1 Configuration

Topology Diagram

Learning Objectives
Upon completion of this lab, you will be able to:

 □ Cable a network according to the Topology Diagram. 


 □ Erase the startup configuration and reload a router to the default state. 
 □ Perform basic configuration tasks on a router. 
 □ Configure and activate interfaces. 
 □ Configure RIP routing on all routers. 
□ Verify RIP routing using show and debug commands. 

 □ Reconfigure the network to make it contiguous. 
□ Observe automatic summarization at boundary router. 
□ Gather information about RIP processing using the debug ip rip command.
  Configure a static default route. 
  Propagate default routes to RIP neighbors. 
 Document the RIP configuration. 

Scenarios
□  Scenario A: Running RIPv1 on Classful Networks 
□  Scenario B: Running RIPv1 with Subnets and Between Classful Networks 
.

54
SRM University
Department of Computer Science and Engineering

Scenario A: Running RIPv1 on Classful Networks

Topology Diagram

Addressing Table

Device

Fa0/0 192.168.1.1 255.255.255.0 N/A


R1
S0/0/0 192.168.2.1 255.255.255.0 N/A
Fa0/0 192.168.3.1 255.255.255.0 N/A
R2 S0/0/0 192.168.2.2 255.255.255.0 N/A
S0/0/1 192.168.4.2 255.255.255.0 N/A
Fa0/0 192.168.5.1 255.255.255.0 N/A
R3
S0/0/1 192.168.4.1 255.255.255.0 N/A
PC1 NIC 192.168.1.10 255.255.255.0 192.168.1.1
PC2 NIC 192.168.3.10 255.255.255.0 192.168.3.1
PC3 NIC 192.168.5.10 255.255.255.0 192.168.5.1

Task 1: Prepare the Network.


Step 1: Cable a network that is similar to the one in the Topology Diagram.
You can use any current router in your lab as long as it has the required interfaces shown in the
topology.
Note: If you use 1700, 2500, or 2600 routers, the router outputs and interface descriptions will
appear different.

55
SRM University
Department of Computer Science and Engineering

Step 2: Clear any existing configurations on the routers.

Task 2: Perform Basic Router Configurations.


Perform basic configuration of the R1, R2, and R3 routers according to the following guidelines:
• Configure the router hostname.
• Disable DNS lookup.
• Configure an EXEC mode password.
• Configure a message-of-the-day banner.
• Configure a password for console connections.
• Configure a password for VTY connections.

Task 3: Configure and Activate Serial and Ethernet Addresses.


Step 1: Configure interfaces on R1, R2, and R3.
Configure the interfaces on the R1, R2, and R3 routers with the IP addresses from the table
under the Topology Diagram.

Step 2: Verify IP addressing and interfaces.


Use the show ip interface brief command to verify that the IP addressing is correct and
that the interfaces are active.
When you have finished, be sure to save the running configuration to the NVRAM of the router.

Step 3: Configure Ethernet interfaces of PC1, PC2, and PC3.


Configure the Ethernet interfaces of PC1, PC2, and PC3 with the IP addresses and default
gateways from the table under the Topology Diagram.

Step 4: Test the PC configuration by pinging the default gateway from the PC.

Task 4: Configure RIP.


Step 1: Enable dynamic routing.
To enable a dynamic routing protocol, enter global configuration mode and use the router
command.
Enter router ? at the global configuration prompt to a see a list of available routing protocols on
your router.
To enable RIP, enter the command router rip in global configuration mode.

R1(config)#router rip
R1(config-router)#

Step 2: Enter classful network addresses.

56
SRM University
Department of Computer Science and Engineering

Once you are in routing configuration mode, enter the classful network address for each
directly connected network, using the network command.

R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#

The network command:

□ Enables RIP on all interfaces that belong to this network. These interfaces will now both
□ send and receive RIP updates. 
□ Advertises this network in RIP routing updates sent to other routers every 30 seconds. 

When you are finished with the RIP configuration, return to privileged EXEC mode and save the
current configuration to NVRAM.

R1(config-router)#end
%SYS-5-CONFIG_I: Configured from console by
console R1#copy run start

Step 3: Configure RIP on the R2 router using the router rip and network commands.

R2(config)#router rip R2(config-


router)#network 192.168.2.0
R2(config-router)#network
192.168.3.0 R2(config-
router)#network 192.168.4.0
R2(config-router)#end
%SYS-5-CONFIG_I: Configured from console by
console R2#copy run start

When you are finished with the RIP configuration, return to privileged EXEC mode and save the
current configuration to NVRAM.

Step 4: Configure RIP on the R3 router using the router rip and network commands.

R3(config)#router rip
R3(config-router)#network
192.168.4.0 R3(config-
router)#network 192.168.5.0
R3(config-router)#end
%SYS-5-CONFIG_I: Configured from console by
console R3# copy run start

When you are finished with the RIP configuration, return to privileged EXEC mode and save the
current configuration to NVRAM.

Task 5: Verify RIP Routing.

57
SRM University
Department of Computer Science and Engineering

Step 1: Use the show ip route command to verify that each router has all of the networks
in the topology entered in the routing table.
Routes learned through RIP are coded with an R in the routing table. If the tables are not
converged as shown here, troubleshoot your configuration. Did you verify that the configured
interfaces are active? Did you configure RIP correctly? Return to Task 3 and Task 4 to review the
steps necessary to achieve convergence.

R1#show iproute
Codes: C -connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR P -
periodic downloaded static route

Gateway oflast resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet0/0


C 192.168.2.0/24 is directly connected, Serial0/0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:04, Serial0/0/0
R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:04, Serial0/0/0
R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:04, Serial0/0/0
R1#

R2#show ip route

<Output omitted>

R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:22,


Serial0/0/0 C 192.168.2.0/24 is directly connected,
Serial0/0/0
C 192.168.3.0/24 is directly connected,
FastEthernet0/0 C 192.168.4.0/24 is directly
connected, Serial0/0/1
R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:23, Serial0/0/1
R2#

R3#show ip route

<Output omitted>

R 192.168.1.0/24 [120/2] via 192.168.4.2, 00:00:18, Serial0/0/1


R 192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:18, Serial0/0/1
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:18,
Serial0/0/1 C 192.168.4.0/24 is directly connected,
Serial0/0/1
C 192.168.5.0/24 is directly connected,
FastEthernet0/0 R3#

58
SRM University
Department of Computer Science and Engineering

Step 2: Use the show ip protocols command to view information about the routing
processes.
The show ip protocols command can be used to view information about the routing
processes that are occurring on the router. This output can be used to verify most RIP
parameters to confirm that:

□  RIP routing is configured 


□  The correct interfaces send and receive RIP updates 
□  The router advertises the correct networks 
• RIP neighbors are sending updates

R1#show ip protocols
Routing Protocol is " rip"
Sending updates every 30 seconds, next due in 16 seconds
Invalid after 180 seconds, hold down 180, flushed after
240 Outgoing update filter list for all interfaces is not
set Incoming update filter list for all interfaces is not
set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 2 1
Serial0/0/0 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
192.168.2.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.2.2 120
Distance: (default is 120)
R1#

R1 is indeed configured with RIP. R1 is sending and receiving RIP updates on FastEthernet0/0
and Serial0/0/0. R1 is advertising networks 192.168.1.0 and 192.168.2.0. R1 has one routing
information source. R2 is sending R1 updates.

Step 3: Use the debug ip rip command to view the RIP messages being sent and received.
Rip updates are sent every 30 seconds so you may have to wait for debug information to be
displayed.

R1#debug ip rip
R1#RIP: received v1 update from 192.168.2.2 on
Serial0/0/0 192.168.3.0 in 1 hops
192.168.4.0 in 1
hops 192.168.5.0
in 2 hops
RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0
(192.168.1.1) RIP: build update entries

59
SRM University
Department of Computer Science and Engineering

network 192.168.2.0
metric 1 network
192.168.3.0 metric 2
network 192.168.4.0
metric 2 network
192.168.5.0 metric 3
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0
(192.168.2.1) RIP: build update entries
network 192.168.1.0 metric 1

The debug output shows that R1 receives an update from R2. Notice how this update includes all
the networks that R1 does not already have in its routing table. Because the FastEthernet0/0
interface belongs to the 192.168.1.0 network configured under RIP, R1 builds an update to send out
that interface. The update includes all networks known to R1 except the network of the interface.
Finally, R1 builds an update to send to R2. Because of split horizon, R1 only includes the
192.168.1.0 network in the update.

Step 4: Discontinue the debug output with the undebug all command.

R1#undebug all
All possible debugging has been turned off

60
SRM University
Department of Computer Science and Engineering

Lab 6: RIPv2 Basic Configuration Lab

Topology Diagram

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway

Fa0/0 172.30.1.1 255.255.255.0 N/A


R1 Fa0/1 172.30.2.1 255.255.255.0 N/A
S0/0/0 209.165.200.230 255.255.255.252 N/A
Fa0/0 10.1.0.1 255.255.0.0 N/A
R2 S0/0/0 209.165.200.229 255.255.255.252 N/A
S0/0/1 209.165.200.233 255.255.255.252 N/A
Fa0/0 172.30.100.1 255.255.255.0 N/A
S0/0/1 209.165.200.234 255.255.255.252 N/A
R3 Lo0 172.30.110.1 255.255.255.0 N/A
Lo1 172.30.200.17 255.255.255.240 N/A
Lo2 172.30.200.33 255.255.255.240 N/A
PC1 NIC 172.30.1.10 255.255.255.0 172.30.2.1
PC2 NIC 172.30.2.10 255.255.255.0 172.30.1.1
PC3 NIC 10.1.0.10 255.255.0.0 10.1.0.1
PC4 NIC 172.30.100.10 255.255.255.0 172.30.100.1

61
SRM University
Department of Computer Science and Engineering

Step 1: Configure the routers


On the routers, enter global configuration mode and configure the hostname as shown on the chart.
Then configure the console, virtual terminal lines password (both “cisco”) and privileged EXEC
password (“class”):

Step 2: Add the logging synchronous command to the console and virtual terminal lines
This command is very helpful in both lab and production environments and uses the following syntax:

Router(config-line)#logging synchronous

Step 3: Disable DNS lookup


Router(config)#no ip domain-lookup

Step 4: Configure the interfaces on R1, R2, and R3


Configure the interfaces on the R1, R2, and R3 routers with the IP addresses from the table
under the Topology Diagram.

Step 5: Verify IP addressing and interfaces


Use the show ip interface brief command to verify that the IP addressing is correct and
that the interfaces are active.

Step 6: Configure Ethernet interfaces of PC1, PC2, and PC3


Configure the Ethernet interfaces of PC1, PC2, and PC3 with the IP addresses and default
gateways from the table under the Topology Diagram.

Step 7: Test the PC configuration by pinging the default gateway from the PC

Task: Configure RIP Version 2.

Use the version 2 command to enable RIP version 2 on each of the routers.

R2(config)#router rip
R2(config-router)#version 2

R1(config)#router rip
R1(config-router)#version 2

R3(config)#router rip
R3(config-router)#version 2

62
SRM University
Department of Computer Science and Engineering

Lab 7 EIGRP Configuration, Bandwidth, and Adjacencies

Learning Objectives
• Configure EIGRP on an interface
• Configure the bandwidth command to limit EIGRP bandwidth
• Verify EIGRP adjacencies
• Verify EIGRP routing information exchange
• Utilize debugging commands for troubleshooting EIGRP
• Challenge: Test convergence for EIGRP when a topology change occurs

Topology Diagram

Scenario

You are responsible for configuring the new network to connect your
company’s Engineering, Marketing, and Accounting departments, represented
by the loopback interfaces on each of the three routers. The physical devices
have just been installed and are connected by Fast Ethernet and serial

63
SRM University
Department of Computer Science and Engineering

cables. Your task is to configure EIGRP to enable full connectivity between


all departments.
Step 1: Addressing

Using the addressing scheme in the diagram, apply IP addresses to the


Fast Ethernet interfaces on R1, R2, and R3. Then create Loopback1 on R1,
Loopback2 on R2, and Loopback3 on R3 and address them according to
the diagram.
R1#configure terminal
R1(config)# interface Loopback1
R1(config-if)# description Engineering Department
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# exit
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 10.1.100.1 255.255.255.0

R2#configure terminal
R2(config)# interface Loopback2
R2(config-if)# description Marketing Department
R2(config-if)# ip address 10.1.2.1 255.255.255.0
R2(config-if)# exit
R2(config)# interface FastEthernet0/0
R2(config-if)# ip address 10.1.100.2 255.255.255.0

R3#configure terminal
R3(config)# interface Loopback3
R3(config-if)# description Accounting Department
R3(config-if)# ip address 10.1.3.1 255.255.255.0
R3(config-if)# exit
R3(config)# interface FastEthernet0/0
R3(config-if)# ip address 10.1.100.3 255.255.255.0

Leave the switch in its default (blank) configuration. By default, all switch
ports are in VLAN1 and are not administratively down.
For now, also leave the serial interfaces in their default configuration. You
will configure the serial link between R1 and R2 in Step 4.
Verify that the line protocol of each interface is up and that you can successfully
ping across each link. You should see similar output on each router:
R1#sh ip interface brief
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 10.1.100.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down
down
Serial0/0/0 unassigned YES manual up up
Serial0/0/1 unassigned YES unset administratively down
down
Loopback1 10.1.1.1 YES manual up up

64
SRM University
Department of Computer Science and Engineering

Step 2: Configuring EIGRP Across VLAN1

After you have implemented your addressing scheme, create an EIGRP


autonomous system (AS) on R1 using the following commands in global
configuration mode:
R1(config)# router eigrp 1
R1(config-router)# network 10.0.0.0

Using network statements with major networks causes EIGRP to begin sending EIGRP
Hello packets out all interfaces in that network (that is, subnets of the major network
10.0.0.0/8). In this case, EIGRP should start sending Hello packets out of its Fast Ethernet
and loopback interfaces. To check if this is occurring, use the debug eigrp packets in
privileged-exec mode.
R1#debug eigrp packets
*Sep 25 21:27:09.547: EIGRP: Sending HELLO on Loopback1
*Sep 25 21:27:09.547: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Sep 25 21:27:09.547: EIGRP: Received HELLO on Loopback1 nbr 10.1.1.1
*Sep25 21:27:09.547: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
*Sep25 21:27:09.547: EIGRP: Packetfrom ourselves ignored
*Sep25 21:27:10.203: EIGRP: Sending HELLO on FastEthernet0/0
*Sep25 21:27:10.203: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#undebug all

These Hello packets are unanswered by the other routers, because EIGRP is not yet
running on R2 or R3. R1 ignores the Hello packets from itself on Loopback1. Use the
undebug all command to stop the debug output.
Which interfaces are involved in EIGRP’s routing process on this router? Use show ip
eigrp interfaces to show which interfaces are participating in EIGRP. You should see
output similar to the following:
R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending


Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 0 0/0 0 0/1 0 0
Lo1 0 0/0 0 0/1 0 0

You are interested in seeing the adjacency initiate on R1 and R2, so you issue debug
eigrp packets on R1 and R2 to monitor the adjacency taking place in real time while you
configure R2.
Now, in global configuration mode on R2, issue the same set of commands you issued on
R1 to create EIGRP AS 1 and advertise the 10.0.0.0/8 network. You should see debug
output similar to the following:
R2#debug eigrp packets

65
SRM University
Department of Computer Science and Engineering

EIGRP Packets debugging is on


(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY

Configure EIGRP on R3 using the same commands.

R3(config)# router eigrp 1


R3(config-router)# network 10.0.0.0

Step 3: Verifying the EIGRP Configuration

When R3 is configured, issue show ip eigrp neighbors on each router. If you have
configured each router successfully, there are two adjacencies on each router.
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.100.3 Fa0/0 1000:00:17 1 200 0 7
0 10.1.100.2 Fa0/0 1100:02:01 5 200 0 6
!
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.100.3 Fa0/0 1300:00:56 1 200 0 7
0 10.1.100.1 Fa0/0 1200:02:40 1 200 0 47
!
R3#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.100.2 Fa0/0 1100:01:21 819 4914 0 6
0 10.1.100.1 Fa0/0 1100:01:21 2 200 0 47

Now check whether the EIGRP routes are being exchanged between the routers
using show ip eigrp topology:
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply


Status, s - sia Status
P 10.1.3.0/24, 1 successors, FD is 156160
via 10.1.100.3 (156160/128256), FastEthernet0/0 P
10.1.2.0/24, 1 successors, FD is 156160
via 10.1.100.2 (156160/128256), FastEthernet0/0 P
10.1.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 10.1.100.0/24, 1 successors, FD is 28160 via
Connected, FastEthernet0/0

You should see all the networks currently advertised by EIGRP on every router.

66
SRM University
Department of Computer Science and Engineering

We will explore the output of this command in the next lab. For now, verify that each of the
loopback networks exist in the EIGRP topology table. Because EIGRP is the only routing
protocol running and currently has routes to these networks, issuing show ip route eigrp
displays the best route to the destination network.

R1#show ip route eigrp


10.0.0.0/24 is subnetted, 4 subnets
D 10.1.3.0 [90/156160] via 10.1.100.3, 00:00:53, FastEthernet0/0
D 10.1.2.0 [90/156160] via 10.1.100.2, 00:00:53, FastEthernet0/0

To check whether you have full connectivity, ping the remote loopbacks from each
router. If you have successfully pinged all the remote loopbacks, congratulations!
You have configured EIGRP to route between these three remote networks.
Step 4: Configuring EIGRP on the Serial Interfaces

Your serial interfaces are still be in their default configuration. Address the
interface according to the diagram, and set the clock rate to 64 kbps.
R1(config)# interface serial 0/0/0
R1(config-if)# ip address 10.1.200.1 255.255.255.0
R1(config-if)# clock rate 64000
R1(config-if)# no shut
!
R2(config)# interface serial 0/0/0
R2(config-if)# ip address 10.1.200.2 255.255.255.0
R2(config-if)# no shut

Notice that even though you have clocked the interface at 64 kbps, issuing show
interface serial 0/0/0 reveals that the interface still is a full T1 bandwidth of 1544
kbps.
R1#show interfaces serial 0/0/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.200.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, reliability
255/255, txload 1/255, rxload 1/255
...

By default, EIGRP uses up to 50 percent of the bandwidth that your interface reports
to the Cisco IOS software. Suppose there was a significant routing instability in some
other part of our EIGRP AS. If EIGRP were to use 50 percent of 1544 kbps for its own
routing information traffic, EIGRP traffic would fully saturate our measly 64 kbps serial
link!
Also, recall that EIGRP makes bandwidth computations using a composite metric in
which one of the variables is the bandwidth of the interface. For EIGRP to make an
accurate computation, it needs correct information about the bandwidth of your serial
link. Therefore, you need to manually configure the bandwidth variable to 64 kbps.

67
SRM University
Department of Computer Science and Engineering

Apply the bandwidth 64 command to the R1 and R2 serial interfaces as follows:


R1:
!
interface Serial0/0/0
bandwidth 64
!

R2:
!
interface Serial0/0/0 bandwidth
64
!

Verify that your bandwidth configuration is reflected in the show interface serial
0/0/0 output:
R1#show interfaces serial 0/0/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.200.1/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, reliability 255/255,
txload 1/255, rxload 1/255
...
R2#show interfaces serial 0/0/0 Serial0/0/0 is up,
line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.200.2/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, reliability 255/255,
txload 1/255, rxload 1/255
...

Now, issue the show ip eigrp neighbors command, which displays the following
neighbor relationship between R1 and R2:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface HoldUptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
2 10.1.200.2 Se0/0/0 1000:03:03 24 200 0 53
1 10.1.100.2 Fa0/0 1409:22:42 269 1614 0 54
0 10.1.100.3 Fa0/0 1109:22:42 212 1272 0 59

Step 5: Configuring Network Statement Wildcard Masks

On R3, create Loopback11 with IP address 192.168.100.1/30, and Loopback15 with IP


address 192.168.100.5/30.
R3(config)# interface Loopback11
R3(config-if)# ip address 192.168.100.1 255.255.255.252
R3(config-if)# exit
R3(config)# interface Loopback15
R3(config-if)# ip address 192.168.100.5 255.255.255.252
R3(config-if)# exit

68
SRM University
Department of Computer Science and Engineering

How can you add the 192.168.100.0/30 network to EIGRP without involving the
192.168.100.4/30 network as well?

In Step 2, we looked at how network statements select networks for routing using major
network boundaries. EIGRP also provides a way to select networks using wildcard masks.
In a wildcard mask, bits that may vary are denoted by 1s in the binary bit values. If we
wanted to route both Loopback11 and Loopback15 with EIGRP, we could use a wildcard
mask that includes both of their network addresses, such as network 192.168.100.0
0.0.0.7 or network

192.168.100.0 0.0.0.255. However, in this scenario, we only want to select


Loopback11’s IP network.

On R3, issue the following commands:


R3(config)# router eigrp 1
R3(config-router)# network 192.168.100.0 0.0.0.3

Did this solution work? Check it with the show ip eigrp interfaces command.
Notice that Loopback11 is involved in EIGRP, and Loopback15 is not.
R3#show ip eigrp interfaces
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending


Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 2 0/0 5 0/1 50 0
Lo3 0 0/0 0 0/1 0 0
Lo11 0 0/0 0 0/1 0 0

Which of these two IP networks can you see in the routing table on R1 after
EIGRP converges with the new network? Look at the output of show ip route eigrp on
R1.
R1#show ip route eigrp
10.0.0.0/24 is subnetted, 5 subnets
D 10.1.3.0 [90/156160] via 10.1.100.3, 00:05:59, FastEthernet0/0 D 10.1.2.0
[90/156160] via 10.1.100.2, 00:12:16, FastEthernet0/0
D 192.168.100.0/24 [90/156160] via 10.1.100.3, 00:03:05, FastEthernet0/0

Notice that the subnet mask for the 192.168.100.0 network advertised by R3 is 24 bits.
This will be examined in much further depth in the next lab. Do you remember the
command to allow R3 to advertise the proper subnet mask to its adjacent routers? If so,
record it below:

Challenge: Topology Change

You have been reading up about the advantages of different routing protocols in your
spare time. You noticed statements claiming that EIGRP converges significantly faster
69
SRM University
Department of Computer Science and Engineering

than other routing protocols in a topology where there are multiple paths to the destination
network. You are interested in testing this before you bring the network that you are
designing online.
Verify that all the neighbor relationships are active and that the routing tables of each
router have the original three loopback interfaces of the other routers as described in the
initial diagram. Make sure you issue the debug ip eigrp 1 command on all routers. You
are not going to want to miss this!
You have observed the following output:
R2#show ip route eigrp
10.0.0.0/24 is subnetted, 5 subnets

D 10.1.3.0 [90/156160] via 10.1.100.3, 00:05:22, FastEthernet0/0


D 10.1.1.0 [90/156160] via 10.1.100.1, 00:05:22, FastEthernet0/0
!
R3#sh ip route eigrp
/24 is subnetted, 5 subnets
D 10.1.2.0 [90/156160] via 10.1.100.2, 09:25:37, FastEthernet0/0
D 10.1.1.0 [90/156160] via 10.1.100.1, 09:25:37, FastEthernet0/0
D 10.1.200.0 [90/40514560] via 10.1.100.2, 00:03:01, FastEthernet0/0

! [90/40514560] via 10.1.100.1, 00:03:01, FastEthernet0/0

R3#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
1 10.1.100.1 4 msec * 0 msec R3#

R3 is using R1 as the next hop to get to destination network 10.1.1.0/24 per


R3’s routing table. However, R3 could potentially get to R1 through R2 via the serial link if
the Fast Ethernet port on R1 was shut down.
From R3, issue a ping with a high repeat count to destination address 10.1.1.1:
ping 10.1.1.1 repeat 100000

You should see multiple exclamation points flooding the console output from R3. On R1,
shut down the FastEthernet0/0 interface:
R3(config)# interface FastEthernet0/0
R3(config-if# shutdown

From R3’s perspective, how many packets were dropped? Which of the EIGRP timers causes
this delay in the route recalculation?
Use the traceroute tool to find the new route from R3 to R1:
R3#traceroute 10.1.1.1

70
SRM University
Department of Computer Science and Engineering

Type escape sequence to abort.


Tracing the route to 10.1.1.1

1 10.1.100.2 0 msec 4 msec 0 msec


2 10.1.200.1 12 msec * 12 msec

71
SRM University
Department of Computer Science and Engineering

Lab 8: EIGRP Authentication and Timers


Topology

Objectives
• Review a basic configuration of EIGRP.
• Configure and verify EIGRP authentication parameters.
• Configure EIGRP hello interval and hold time.
• Verify the hello interval and hold time.

Background
As a network engineer, you have weighed the benefits of routing protocols and deployed EIGRP in your
corporation’s network. Recently, a new Chief Information Officer replaced the previous CIO and outlined a
new network policy detailing more robust security measures. The CIO has also drawn up specifications to
allow more frequent checking between neighboring routers so that fewer packets are lost in transit during
times of instability. In this lab, you implement the CIO’s specifications on the network.
Note: This lab uses Cisco 1841 routers with Cisco IOS Release 12.4(24)T1 and the advanced IP services
image c1841-advipservicesk9-mz.124-24.T1.bin. The switch is a Cisco WS-C2960-24TT-L with the Cisco IOS
image c2960-lanbasek9-mz.122-46.SE.bin. You can use other routers (such as a 2801 or 2811) and Cisco
IOS Software versions if they have comparable capabilities and features. Depending on the router or switch

72
SRM University
Department of Computer Science and Engineering

model and Cisco IOS Software version, the commands available and output produced might vary from what is
shown in this lab.

Required Resources
8. 3 routers (Cisco 1841 with Cisco IOS Release 12.4(24)T1 Advanced IP Services or comparable)
9. 1 switch (Cisco 2960 with the Cisco IOS Release 12.2(46)SE C2960-LANBASEK9-M image or comparable)
10. Serial and Ethernet cables

Step 1: Configure the hostname and interface addresses.


Using the addressing scheme in the diagram, apply IP addresses to the loopback, serial, and Fast Ethernet
interfaces on R1, R2, and R3. Set the serial interface bandwidth on each router with the interface-level
bandwidth bandwidth command. Specify the bandwidth as 64 kb/s on each serial interface. Specify the clock
rate on the DCE end of each serial link using the clock rate 64000 command.
Note: If you have WIC-2A/S serial interfaces, the maximum clock rate is 128 kb/s. If you have WIC-2T serial
interfaces, the maximum clock rate is much higher (2.048 Mb/s or higher depending on hardware), which is
more representative of a modern network WAN link. However, this lab uses 64 kb/s and 128 kb/s settings.
You can copy and paste the following configurations into your routers to begin.
Note: Depending on the router model, the interfaces might be numbered differently than those listed and
might require you to alter the interface designation accordingly.
Router R1
hostname R1
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no shutdown
!
interface Serial0/0/0
ip address 172.16.12.1 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
!
interface Serial0/0/1
ip address 172.16.13.1 255.255.255.248
bandwidth 64
no shutdown
!
end

Router R2
hostname R2
!

73
SRM University
Department of Computer Science and Engineering

interface Loopback2
ip address 192.168.2.2 255.255.255.0
!
interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0


no shutdown
!
interface Serial0/0/0
ip address 172.16.12.2 255.255.255.248
bandwidth 64
no shutdown
!
interface Serial0/0/1
ip address 172.16.23.2 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
!
end

Router R3
hostname R3
!
interface Loopback3
ip address 192.168.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.3 255.255.255.0
no shutdown
!
interface Serial0/0/0
ip address 172.16.13.3 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
!
interface Serial0/0/1
ip address 172.16.23.3 255.255.255.248
bandwidth 64
no shutdown
!
end

Step 2: Configure basic EIGRP.


• Configure EIGRP AS 1 as in the previous EIGRP labs. Run EIGRP on all connections in the lab, and
leave auto-summarization on. Advertise networks 10.0.0.0/8, 172.16.0.0/16, 192.168.1.0/24,
192.168.2.0/24, and 192.168.3.0/24 from their respective routers.
• Use the show ip eigrp neighbors command to check which routers have EIGRP adjacencies.
R1# show ip eigrp neighbors

74
SRM University
Department of Computer Science and Engineering

IP-EIGRP neighbors for process 1


H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 10.1.1.2 Fa0/0 11 00:00:54 4 200 0 36
2 10.1.1.3 Fa0/0 11 00:00:54 13 200 0 39
1 172.16.12.2 Se0/0/0 14 00:14:18 27 2280 0 32
0 172.16.13.3 Se0/0/1 13 00:14:23 25 2280 0 37
R2# show ip eigrp neighbors
IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq


(sec) (ms) Cnt Num
3 10.1.1.1 Fa0/0 10 00:02:05 1020 5000 0 35
2 10.1.1.3 Fa0/0 14 00:02:05 11 200 0 39
1 172.16.12.1 Se0/0/0 14 00:15:25 106 2280 0 32
0 172.16.23.3 Se0/0/1 13 00:16:59 1 2280 0 38
R3# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 10.1.1.1 Fa0/0 12 00:03:18 816 4896 0 34
2 10.1.1.2 Fa0/0 11 00:03:18 822 4932 0 35
1 172.16.13.1 Se0/0/0 14 00:16:47 22 2280 0 31
0 172.16.23.2 Se0/0/1 14 00:18:12 4 2280 0 33
Did you receive the output that you expected?

• Run the following Tcl script on all routers to verify full connectivity.
R1# tclsh

foreach address {
10.1.1.1
172.16.12.1
172.16.13.1
192.168.1.1
10.1.1.2
172.16.12.2
172.16.23.2
192.168.2.2
10.1.1.3
172.16.13.3
172.16.23.3
192.168.3.3
} { ping $address }

You should get ICMP echo replies for every address pinged.

75
SRM University
Department of Computer Science and Engineering

Step 3: Configure authentication keys.


Before you configure a link to authenticate the EIGRP adjacencies, you must configure the keys that are used
for the authentication. EIGRP uses Cisco IOS generic router key chains as storage locations for keys. These
key chains classify keys into groups, enabling keys to be easily changed periodically without bringing down
adjacencies.
• Use the key chain name command in global configuration mode to create a chain of keys with the label
EIGRP-KEYS.
R1# conf t
R1(config)# key chain EIGRP-KEYS
R1(config-keychain)# key 1 R1(config-
keychain-key)# key-string cisco
R2# conf t
R2(config)# key chain EIGRP-KEYS

R2(config-keychain)# key 1
R2(config-keychain-key)# key-string cisco

R3# conf t
R3(config)# key chain EIGRP-KEYS
R3(config-keychain)# key 1
R3(config-keychain-key)# key-string cisco

C Issue the show key chain command. You should have the same output on every router.
R1# show key chain
Key-chain EIGRP-KEYS: key 1
-- text "cisco"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
You can set a time span for sending a key to other routers and during which a key is accepted from other
routers. Although lifetime values are not explored in the route labs, you should keep it in mind for
production networks when you are rolling from one set of authentication strings to another. For now, you
simply want to authenticate the EIGRP adjacencies for security reasons.

Step 4: Configure EIGRP link authentication.


When configuring EIGRP link authentication, you must first associate the key chain with a particular EIGRP
process (or autonomous system) running on the interface using the ip authentication key-chain eigrp
as_number key key_chain_label command. Then you activate the MD5 authentication for that EIGRP
process using the ip authentication mode eigrp as_number md5 command.
R Apply the following commands on all active EIGRP interfaces.
R1# conf t
R1(config)# interface serial 0/0/0
R1(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R1(config-if)# ip authentication mode eigrp 1 md5 R1(config-
if)# interface serial 0/0/1
R1(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R1(config-if)# ip authentication mode eigrp 1 md5 R1(config-

76
SRM University
Department of Computer Science and Engineering

if)# interface fastethernet 0/0


R1(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R1(config-if)# ip authentication mode eigrp 1 md5
R2# conf t
R2(config)# interface serial 0/0/0
R2(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R2(config-if)# ip authentication mode eigrp 1 md5 R2(config-
if)# interface serial 0/0/1
R2(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R2(config-if)# ip authentication mode eigrp 1 md5 R2(config-
if)# interface fastethernet 0/0
R2(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R2(config-if)# ip authentication mode eigrp 1 md5
R3# conf t
R3(config)# interface serial 0/0/0
R3(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R3(config-if)# ip authentication mode eigrp 1 md5 R3(config-
if)# interface serial 0/0/1
R3(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R3(config-if)# ip authentication mode eigrp 1 md5

R3(config-if)# interface fastethernet 0/0


R3(config-if)# ip authentication key-chain eigrp 1 EIGRP-
KEYS R3(config-if)# ip authentication mode eigrp 1 md5
Each EIGRP adjacency should flap (go down and come back up) when you implement MD5
authentication on one side of the link before the other side has been configured. In a production network,
flapping causes some instability during a configuration, so make sure you implement MD5 outside of peak
usage times.
R Check the configuration with the show ip eigrp interfaces detail command.
R1# show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing TimeMulticast Pending


Interface Peers Un/Reliable SRTT Un/ReliableFlow Timer Routes
Fa0/0 2 0/0 3 0/1 50 0
Hello interval is 5sec
Next xmit serial <none>
Un/reliable mcasts: 0/14 Un/reliable ucasts: 26/21
Mcast exceptions: 3CR packets: 3 ACKs suppressed: 3
Retransmissions sent: 1 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use multicast
Se0/0/0 1 0/0 4 0/12 50 0
Hello interval is 5sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 10/28
Mcast exceptions: 0CR packets: 0 ACKs suppressed: 5
Retransmissions sent: 0 Out-of-sequence rcvd: 0

77
SRM University
Department of Computer Science and Engineering

Authentication mode is md5, key-chain is "EIGRP-KEYS"


Use unicast
Se0/0/1 1 0/0 1 0/12 50 0
Hello interval is 5sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 10/22
Mcast exceptions: 0CR packets: 0 ACKs suppressed: 8
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Lo1 0 0/0 0 0/1 0 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 0/0
Mcast exceptions: 0CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is not set
Use multicast
R2# show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/ReliableSRTT Un/Reliable Flow Timer Routes
Fa0/0 2 0/0 4 0/10 50 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/7 Un/reliable ucasts: 34/15
Mcast exceptions: 0CR packets: 0 ACKs suppressed: 7

78
SRM UNIVERSITY
Faculty of Computer Science and Engineering

Retransmissions sent: 1Out-of-sequence rcvd: 0


Authentication mode is md5, key-chain is "EIGRP-KEYS"
Se0/0/0 1 0/0 1 0/12 50 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0Un/reliable ucasts: 19/17
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 7
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Se0/0/1 1 0/0 3 0/12 50 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0Un/reliable ucasts: 11/9
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 4
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Lo2 0 0/0 0 0/1 0 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 0/0
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is not set
Use multicast
R3# show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1
Xmit QueueMean Pacing TimeMulticast Pending
Interface Peers Un/Reliable SRTT Un/ReliableFlow Timer Routes
Fa0/0 2 0/0 4 0/1 50 0
Hello intervalis 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/3Un/reliable ucasts: 6/7
Mcast exceptions: 1 CR packets: 1 ACKs suppressed: 0
Retransmissions sent: 2Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use multicast
Se0/0/0 1 0/0 482 10/380 2732 0
Hello intervalis 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 3/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Se0/0/1 1 0/0 109 10/380 904 0
Hello intervalis 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 4/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Lo3 0 0/0 0 0/1 0 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 0/0

Mcast exceptions: 0 CR packets: 0 ACKs

79
SRM UNIVERSITY
Faculty of Computer Science and Engineering
suppressed: 0 Retransmissions sent: 0
Out-of-sequence rcvd: 0 Authentication
mode is not set
Use multicast

At this point, the interfaces are authenticating each adjacency with the EIGRP-
KEYS key chain. Make sure that you verify the number of neighbors out each
interface in the above output. Notice that the number of peers is the number of
adjacencies established out that interface.
When EIGRP has a key chain associated with an autonomous system on a given
interface and EIGRP is authenticating its adjacencies, you have successfully
completed the initial work.
R Use the debug eigrp packets command to see the authenticated hellos.
R1# debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP,
PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
R1#
Feb 9 19:10:51.090: EIGRP: Sending HELLO on Serial0/0/1
Feb 9 19:10:51.090: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ
un/rely 0/0
Feb 9 19:10:51.190: EIGRP: received packet with MD5
authentication, key id
1
Feb 9 19:10:51.190: EIGRP: Received HELLO on Serial0/0/1 nbr
172.16.13.3
Feb 9 19:10:51.190: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ
un/rely 0/0 peerQ un/rely 0/0
Feb 9 19:10:51.854: EIGRP: received packet with MD5
authentication, key id
1
Feb 9 19:10:51.854: EIGRP: Received HELLO on FastEthernet0/0
nbr 10.1.1.2
Feb 9 19:10:51.854: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ
un/rely 0/0 peerQ un/rely 0/0
Feb 9 19:10:53.046: EIGRP: received packet with MD5
authentication, key id
1

<output omitted>

d. Issue the undebug all command to stop the debugging output.

Step 5: Manipulate EIGRP timers.


The CIO also ordered you to change the hello and dead intervals on point-to-point
serial interfaces so that dead neighbors are detected in roughly half the time that they
are detected by default.
a. To view the default timers, use the show ip eigrp interfaces detail command.
R1# show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending


Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 2 0/0 4 0/1 50 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/3 Un/reliable ucasts: 6/7
Mcast exceptions: 1 CR packets: 1 ACKs suppressed: 0
Retransmissions sent: 2Out-of-sequence rcvd: 0

80
SRM UNIVERSITY
Faculty of Computer Science and Engineering
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use multicast
Se0/0/0 1 0/0 482 10/380 2732 0
Hello interval is 5 sec

Next xmit serial <none>


Un/reliable mcasts: 0/0 Un/reliable ucasts: 3/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Se0/0/1 1 0/0 109 10/380 904 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 4/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
<output omitted>

The default hello interval for point-to-point serial links is 5 seconds, regardless of
the bandwidth, and 5 seconds for LAN interfaces. The default hold time is three
times the length of the hello interval.
The hello interval determines how often outgoing EIGRP hellos are sent, while the
hold time defines how long other neighbors tolerate the loss of the hello packets You
are more concerned with the hold time than the hello interval, because the hold time
detects a dead neighbor. However, you also want the neighbors to send the same
number of hellos as under normal circumstances before declaring a neighbor dead.
The requirements from the CIO specify that the hold time should be roughly half of
the default, which is 15 seconds, so a new hold time of 7 or 8 seconds would be
appropriate. A shorter hold time allows a dead neighbor to be detected more
quickly. A hello interval of 2 seconds results in detecting new neighbors more
rapidly.
b. Change both the hello interval and the hold time for AS 1 for serial 0/0/0 on R1 and
R2 using the ip hello-interval eigrp 1 2 and ip hold-time eigrp 1 8 commands. If
necessary, use the ? to investigate what each parameter does.
R1# conf t
R1(config)# interface
serial 0/0/0 R1(config-if)#
ip hello-interval eigrp 1 2
R1(config-if)# ip hold-time
eigrp 1 8
R2# conf t
R2(config)# interface
serial 0/0/0 R2(config-if)#
ip hello-interval eigrp 1 2
R2(config-if)# ip hold-time
eigrp 1 8
c. Verify that the hello interval has been successfully changed on routers R1 and
R2 using the show ip eigrp 1 interfaces detail serial 0/0/0 command.
R1# show ip eigrp 1 interfaces detail serial 0/0/0
IP-EIGRP interfaces for process 1

81
SRM UNIVERSITY
Faculty of Computer Science and Engineering
Xmit Queue Mean Pacing TimeMulticast
Pending
Interface Peers Un/Reliable SRTTUn/Reliable Flow Timer Routes
Se0/0/0 1 0/0 482 10/380 2732 0
Hello interval is 2 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 3/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2

Retransmissions sent: 0 Out-of-sequence rcvd: 0


Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast

R2# show ip eigrp 1interfaces detail serial 0/0/0


IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast
Pending
Interface PeersUn/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/0/0 1 0/0 190 10/380 1300 0
Hello interval is 2 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0Un/reliable ucasts: 4/5
Mcast exceptions:0 CR packets: 0ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast

d. Verify that the hold time has been successfully changed with the show ip eigrp
neighbors command.
R1# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 10.1.1.2 Fa0/0 11 01:32:00 7 200 0 19
2 10.1.1.3 Fa0/0 12 01:32:03 1 200 0 18
1 172.16.12.2 Se0/0/0 7 01:32:27 482 2892 0 17
0 172.16.13.3 Se0/0/1 11 01:32:28 109 2280 0 19
R2# show ip eigrp neighbors
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 10.1.1.1 Fa0/0 14 01:30:33 816 4896 0 19
2 10.1.1.3 Fa0/0 12 01:30:33 819 4914 0 21
1 172.16.12.1 Se0/0/0 7 01:30:58 190 2280 0 21
0 172.16.23.3 Se0/0/1 13 01:30:59 80 2280 0 20
e. Configure the same hello interval and hold time on each active serial interface in the
topology.
R1# conf t
R1(config)# interface serial
0/0/1 R1(config-if)# ip
hello-interval eigrp 1 2
R1(config-if)# ip hold-time
eigrp 1 8
R2# conf t
R2(config)# interface serial
0/0/1 R2(config-if)# ip
hello-interval eigrp 1 2
R2(config-if)# ip hold-time

82
SRM UNIVERSITY
Faculty of Computer Science and Engineering
eigrp 1 8
R3# conf t
R3(config)# interface serial
0/0/0 R3(config-if)# ip
hello-interval eigrp 1 2
R3(config-if)# ip hold-time
eigrp 1 8 R3(config-if)#
interface serial 0/0/1
R3(config-if)# ip hello-
interval eigrp 1 2
R3(config-if)# ip hold-time
eigrp 1 8
f. Make sure that all of the EIGRP neighbor relationships remain up during the
configuration process. Use the show ip eigrp neighbors command to verify the hold
time, and the show ip eigrp interfaces detail command to verify the hello interval.

R1# show ip eigrp neighbors


IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 10.1.1.2 Fa0/0 14 01:35:15 7 200 0 19
2 10.1.1.3 Fa0/0 12 01:35:18 1 200 0 18
1 172.16.12.2 Se0/0/0 7 01:35:43 482 2892 0 17
0 172.16.13.3 Se0/0/1 6 01:35:43 109 2280 0 19
R1# show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending


Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 2 0/0 4 0/1 50 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/3 Un/reliable ucasts: 6/7
Mcast exceptions: 1 CR packets: 1 ACKs suppressed: 0
Retransmissions sent: 2Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use multicast
Se0/0/0 1 0/0 482 10/380 2732 0
Hello interval is 2 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 3/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Se0/0/1 1 0/0 109 10/380 904 0
Hello interval is 2 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 4/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 2
Retransmissions sent: 0Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
<output omitted>

g. Run the Tcl script again to make sure you still have full connectivity after making

83
SRM UNIVERSITY
Faculty of Computer Science and Engineering
the changes to the EIGRP default configuration. You should receive all ICMP
echo replies back successful.

84

Das könnte Ihnen auch gefallen