Sie sind auf Seite 1von 2

##### routing untuk pisah jalur antar port-game dan bukan port-game, 2 line isp

## untuk ip address game bisa diambil dari http://pastebin.com/raw/KDAuLHJJ dan


copas di terminal winbox

### copy paste scrip berikut di terminal winbox, scrip ini untuk menambah address
list ip lokal secara global ###
/ip firewall address-list
add address=10.0.0.0/8 comment="lokal-private" list=lokal-private
add address=172.16.0.0/12 comment="lokal-private" list=lokal-private
add address=192.168.0.0/16 comment="lokal-private" list=lokal-private
###################################################################################
##############################

###################################################################################
##############################
#### apabila menggunakan PPPOE mikrotik, berikut scriptnya ####
## misal nama pppoe mikrotik adalah pppoe1 dan pppoe2, maka :
## pengaturan ip route mikrotiknya :
add check-gateway=ping comment=default distance=1 gateway=pppoe1
add check-gateway=ping comment=backup-default distance=2 gateway=pppoe1
add check-gateway=ping comment=jalur1 distance=1 gateway=pppoe1 routing-mark=jalur1
add check-gateway=ping comment=backup-jalur1 distance=2 gateway=pppoe2 routing-
mark=jalur1
add check-gateway=ping comment=jalur2 distance=1 gateway=pppoe2 routing-mark=jalur2
add check-gateway=ping comment=backup-jalur2 distance=2 gateway=pppoe1 routing-
mark=jalur2
## script mangle routing :
add action=mark-routing chain=prerouting comment=game dst-address-list=games dst-
port=!21,22,23,80,81,88,5050,843,443,182,8777,1935,8000-8081 new-routing-
mark=jalur1 passthrough=no protocol=tcp

add action=mark-routing chain=prerouting comment=game dst-address-list=games dst-


port=!21,22,23,80,81,88,5050,843,443,182,8777,1935,8000-8081 new-routing-
mark=jalur1 passthrough=no protocol=udp

add action=mark-routing chain=prerouting comment=bukan-game dst-address-list=!


lokal-private new-routing-mark=jalur2 passthrough=no protocol=!icmp src-address-
list=lokal-private
###################################################################################
##############################

###################################################################################
##############################
#### apabila bukan PPPOE mikrotik, berikut scriptnya ####
## misal :
# modem1 menggunakan ether1 dengan ip modem = 192.168.1.1
# dan modem2 menggunakan ether2 dengan ip modem = 192.168.2.1
## pengaturan ip route mikrotiknya :
add check-gateway=ping comment=default distance=1 gateway=192.168.1.1
add check-gateway=ping comment=backup-default distance=2 gateway=192.168.2.1
add check-gateway=ping comment=jalur1 distance=1 gateway=192.168.1.1 routing-
mark=jalur1
add check-gateway=ping comment=backup-jalur1 distance=2 gateway=192.168.2.1
routing-mark=jalur1
add check-gateway=ping comment=jalur2 distance=1 gateway=192.168.2.1 routing-
mark=jalur2
add check-gateway=ping comment=backup-jalur2 distance=2 gateway=192.168.1.1
routing-mark=jalur2
## script mangle routing :
add action=mark-routing chain=prerouting comment=game dst-address-list=games dst-
port=!21,22,23,80,81,88,5050,843,443,182,8777,1935,8000-8081 new-routing-
mark=jalur1 passthrough=no protocol=tcp

add action=mark-routing chain=prerouting comment=game dst-address-list=games dst-


port=!21,22,23,80,81,88,5050,843,443,182,8777,1935,8000-8081 new-routing-
mark=jalur1 passthrough=no protocol=udp

add action=mark-routing chain=prerouting comment=bukan-game dst-address-list=!


lokal-private new-routing-mark=jalur2 passthrough=no protocol=!icmp src-address-
list=lokal-private
###################################################################################
##############################