Sie sind auf Seite 1von 2

#################################################################################

################### FIREWALL MIKROTIK (work di RB750r2) #########################


###################created by uky, Sunday 31/03/2019 ############################
#################################################################################

#################################################################################
###### LAYER 7 Facebook, Youtube, dan Video Facebook ############################
#################################################################################

/ip firewall layer7-protocol


add name=youtube regexp="r[0-9]+---[a-z]+-+[a-z0-9-]+\\.googlevideo\\.com"
add name=facebook.com regexp="^.+(facebook.com).*\$"
add name=video_fb regexp="video-sin[0-9]+-[0-9]+\\.[a-z]+\\.fbcdn\\.net"

#################################################################################
###### DROP Facebook dan Youtube (masih disable) ################################
#################################################################################

/ip firewall filter


add action=reject chain=forward comment="Youtube UDP" disabled=yes dst-port=\
443 layer7-protocol=youtube protocol=udp reject-with=\
icmp-network-unreachable
add action=reject chain=forward comment="Youtube TCP" disabled=yes dst-port=\
443 layer7-protocol=youtube protocol=tcp reject-with=tcp-reset \
src-address=192.168.5.0/24
add action=drop chain=forward comment="drop facebook " disabled=yes \
layer7-protocol=facebook.com

#################################################################################
###### Mangle Memisahkan Koneksi Lokal dan Internasional ########################
#################################################################################

/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;

[admin@MikroTik] > import nice.rsc

/ip firewall mangle


add action=mark-connection chain=prerouting comment="Mangle Koneksi Lokal" \
new-connection-mark=LOCAL passthrough=yes src-address-list=nice
add action=mark-connection chain=prerouting dst-address-list=nice \
new-connection-mark=LOCAL passthrough=yes
add action=mark-packet chain=prerouting connection-mark=LOCAL \
new-packet-mark=LOCAL passthrough=no
add action=mark-connection chain=prerouting comment=\
"Mangle Koneksi International" new-connection-mark=INT passthrough=yes \
src-address-list=!nice
add action=mark-connection chain=prerouting dst-address-list=!nice \
new-connection-mark=INT passthrough=yes
add action=mark-packet chain=prerouting connection-mark=INT new-packet-mark=\
INT passthrough=no

#################################################################################
###### Mangle Video Facebook ####################################################
#################################################################################

/ip firewall mangle


add action=mark-packet chain=prerouting comment="Mangle FB Video" \
layer7-protocol=!video_fb new-packet-mark=fbvid passthrough=no
#################################################################################
###### Mangle Memisahkan Traffic Download dan Browsing ##########################
#################################################################################

/ip firewall mangle


add action=mark-connection chain=forward comment="Mangle Download & Browsing" \
connection-mark=!traffic_download new-connection-mark=traffic_browsing \
passthrough=yes
add action=mark-connection chain=forward connection-bytes=500000-0 \
connection-mark=traffic_browsing connection-rate=200k-100M \
new-connection-mark=traffic_download protocol=tcp
add action=mark-connection chain=forward connection-bytes=500000-0 \
connection-mark=traffic_browsing connection-rate=200k-100M \
new-connection-mark=traffic_download protocol=udp
add action=mark-packet chain=forward connection-mark=traffic_download \
new-packet-mark=mark_packet_traffic_download passthrough=no
add action=mark-packet chain=forward connection-mark=traffic_browsing \
new-packet-mark=mark_packet_traffic_browsing passthrough=no

#################################################################################
###### queue tree ###############################################################
#################################################################################

/queue tree
add max-limit=3M name=upload parent=global
add disabled=yes limit-at=1M max-limit=3M name=other_upload packet-mark=\
mark_packet_traffic_browsing parent=upload priority=1
add disabled=yes limit-at=128k max-limit=768k name=heavy_upload packet-mark=\
mark_packet_traffic_download parent=upload
add max-limit=6M name=download parent=global
add limit-at=1M max-limit=3M name=other_download packet-mark=\
mark_packet_traffic_browsing parent=download priority=1
add limit-at=128k max-limit=512k name=heavy_download packet-mark=\
mark_packet_traffic_download parent=download
add max-limit=2M name=inter packet-mark=INT parent=global

#################################################################################
###### queue simple #############################################################
#################################################################################

/queue simple
add max-limit=256k/768k name="2 INTER" packet-marks=INT target=""
add disabled=yes max-limit=128k/512k name="1 FB VID" packet-marks=fbvid \
target=""