Sie sind auf Seite 1von 4

C6 CLASE 6: VECTORES

16. INTRODUCCION

6
Vectores  es  parte  esencial  de  algoritmos.  Por  que  permite  la  utilizacion  de  una 
variable con varios valores, a traves de las sub‐divisiones de la misma referencia. 
17. VECTOR
Es  una  estructura  de  datos  que  se  almacena  en  la  memoria  principal,  que  tienen 
elementos homogeneos referenciados a un mismo nombre. 
18. INSTRUCCIÓN

Dimensionar Nombre(tamano)

CLASE
O
Vector Nombre(tamano)

19. CONVENCION
Los  ejercicios  que  indiquen  “que  ya  están  cargados”  significa  que  no  hace  falta 
realizar el algoritmo de carga, para diferenciar en el momento de definir si se esta 
Vector creando  o  ya  esta  cargado  colocaremos  un  subrayado  sobre  la  instrucción  de 
acuerdo a la siguiente tabla: 
Cuando la instrucción dice  Significa 
Significa  que  el  vector  se  esta  creando, 
Vector (K)  no tiene valores dentro del vector. 
Significa que el vector esta cargado con 
Vector (K)  valores dentros. 
 
20. EJERCICIOS RESUELTOS
 

27. Crear un vector k de tamaño 50 y cargarlo


Nº Algoritmo Explicación
1 INICIO
2 Vector K(50)
3 A=0, C=0
4 Mientras C < 50
5 Leer A
6 K(C)= A
7 C=C+1
8 FinMientras
9 FIN

 
Vectores CLASE 6: VECTORES

Se tiene un vector ya cargado de tamaño 30 obtener la sumatoria del  


28. mismo Dado un vector G hacer un algoritmo que permita hallar el menor
Nº Algoritmo Explicación 31. elemento
1 INICIO Nº Algoritmo Explicación
2 Vector P(30)
3 S=0, C=0 1 INICIO
4 Mientras C < 30 2 Vector G(N)
5 S= S+P(C) 3 C=1, ME= G(0)
6 C=C+1 4 Mientras C < N
7 FinMientras 5 Si G(C)< M
8 Imprimir S 6 M=G(C)
9 FIN 7 FinSi
8 C=C+1
  9 FinMientras
10 Imprimir M
Se tiene un vector A de tamaño 10 ya cargado, encontrar la cantidad de 11 FIN
29. elementos que sean múltiplos de 5 y que estén ubicados en posiciones
pares
 
Nº Algoritmo Explicación Cargar un vector A con 100 elementos, a partir del vector A generar un
vector X conteniendo todos los elementos ubicados en las posiciones
1
2
3
INICIO
Vector A(10)
C=2, C5=0
32. pares y por otro lado un vector K conteniendo los elementos ubicados
4 Mientras C < 10 en posiciones impares
5 Si C/2 = ENT(C/2) Nº Algoritmo Explicación
6 Si A(C)/5 = ENT(A(C)/5) 1 INICIO
7 C5= C5+1 2 Vector A(100)
8 FinSi 3 C=1, P=0
9 FinSi 4 Mientras C ≤ 100
10 C=C+1 5 Leer P
11 FinMientras 6 A(C)= P
12 Imprimir C5 7 C=C+1
13 FIN 8 FinMientras
9 Vector X(50)
  10 Vector K(50)
11 C=1, CI=1, CP=1
Se tiene dos vectores A y B cagados de tamaño 6, cree un tercer vector
30. que almacene el menor valor entre posiciones simétricas de A y B
12
13
Mientras C ≤ 100
Si C/2 = ENT(C/2)
Nº Algoritmo Explicación 14 X(CP)= A(C)
15 Sino
1 INICIO 16 K(CI)= A(C)
2 Vector A(6), B(6), Vector X(6) 17 FinSi
3 C=0 18 C=C+1
4 Mientras C <= 6 19 FinMientras
5 Si A(C) < B(C) 20 FIN
6 X(C)= A(C)
7 FinSi  
8 Si B(C) < A(C)
9 X(C)= B(C)
10 FinSi 21. EJERCICIOS PROPUESTOS
11 C=C+1
12 FinMientras 63.Crear un vector D(10) y cargar las posiciones impares (k2) 
13 FIN 64.Cargar un vector de 10 elementos donde las posiciones pares se solicite nro. Y las 
  posiciones impares incremente de 2 en 2 comenzando por el nro. 15 
  65.Se tiene un vector A cargado con 1000 elementos, contar cuantos elementos son 
negativos (k3) . 
66.Se tiene un vector con 1000 elementos, encontrar la cantidad de números pares y 
mayores que 18 (k1). 
Vectores CLASE 6: VECTORES

67.Se tiene un vector de 6 elementos, crear dos vectores, en uno cargue los valores  22. RESPUESTAS DE EJERCICIOS PROPUESTOS


pares y en el otro los valores impares del vector cargado (k6) 

k1 k2 k3
68.Cargar un vector V de tamaño 50 e imprimir los valores pares (k5) 
69.Se  tiene  en  memoria  un  vector  M(1000),  encontrar  el  menor  entre  los  primeros 
INICIO INICIO INICIO
500 y el mayor de los siguientes elementos  Vector X(1000) Vector D(10) Vector A(1000)
70.Se  tiene  un  vector  T(60)  ya  cargado,  crear  otro  vector  que  contenga  todos  los  C=0, PM=0 A=0, C=0 CN=0, C=0
Mientras C < 1000 Mientras C < 50 Mientras C < 1000
valores pares del vector T.  Si A(C)> 18 y A(C)/2 = Si C/2 = ENT(C/2) Si A(C) < 0
ENT(A(C)/2) Leer A CN=CN+1
71.Crear un vector V de dimensión K y cargar solamente las posiciones impares. En las  PM=PM+1 K(C)= A FinSi
posiciones pares contar de 2 en 2 empezando del 15 (k11).  FinSi FinSi C=C+1
C=C+1 C=C+1 FinMientras
72.Teniendo un vector F, hallar la diferencia entre el mayor y el menor elemento.  FinMientras FinMientras Imprimir CN
Imprimir PM FIN FIN
73.Obtener  la  sumatoria  de  todos  los  elementos  ubicados  en  posición  par  de  un  FIN
vector de V de N (k8) 
74.Se tiene un vector A(M), encontrar cuantos elementos son múltiplos de 5, también  k4 k5 k6
imprimir la sumatoria de los mismos (k7)  INICIO NICIO NICIO
75.Dado  un  vector  N(T).  Hacer  un  algoritmo  que  permita  hallar  el  mayor  elemento  Vector M(1000) VECTOR C(50) Vector A(6)
C=1, ME=0, MA=0 A=0, C=0 C=0, CP=0, CIM=0
(k9)  Mientras C < 1000 MIRNTRAS C < 50 Mientras C < 6
Si C ≤ 500 Leer A Si A(C)/2 = ENT(A(C)/2)
Si C = 1 V(C)= A CP=CP+1
ME= M(C) C=C+1 FinSi
FinSi FinMientras Si A(C)/2 <> ENT(A(C)/2)
Si M(C) < ME CON=0 CIM=CIM+1
ME= M(C) Mientras CON < 50 FinSi
FinSi Si V(CON)/2 = C=C+1
FinSi ENT(V(CON)/2) FinMientras
Si C ≤ 500 Imprimir V(CON) Vector B(CP)
Si M(C) > MA FinSi Vector X(CIM)
MA= M(C) CON= CON + 1 X=0, LP=0, LI=0
FinSi FinMientras Mientras X < 6
FinSi FIN Si A(X)/2 = ENT(A(X)/2)
C=C+1 B(LP)= A(X)
FinMientras LP=LP+1
Imprimir MA, ME FinSi
FIN Si A(X)/2 <> ENT(A(X)/2)
X(LI)= A(X)
LI=LI+1
FinSi
X=X+1
FinMientras
FIN
Vectores

K7 K8 K9
INICIO INICIO INICIO
VECTOR A(M) VECTOR V(N) VECTOR N(T)
C=0, CM5=0, SM5=0 C=2, S=0 C=0, M=N(0)
Mientras C < M Mientras C < N Mientras C < T
Si A(C)/5 = ENT(A(C)/5) Si C/2 = ENT(C/2) Si N(C) > M
CM5= CM5 + 1 S= S + V(C) M= T(C)
SM5= SM5 + A(C) FinSi FinSi
FinSi C=C+1 C=C+1
C=C+1 FinMientras FinMientras
FinMientras Imprimir S Imprimir M
Imprimir CM5, SM5 FIN FIN
FIN

K10 K11 K12


INICIO
INICIO
VECTOR C(K)
A=0, C=0, CP=15
MIRNTRAS C < K
Si C/2 <> ENT C/2
Leer A
V(C)= A
FinSi
Si C/2 = ENT(C/2)
V(C)= CP
CP= CP + 2
FinSi
C=C+1
FinMientras
FIN