Sie sind auf Seite 1von 49

Cisco 7600

QoS Architecture

Andy Chien
Consulting System Engineer
Cisco Systems
hchien@cisco.com

© 2005 Cisco Systems, Inc. All rights reserved. 1


QoS Architecture
Scope

• Includes
PFC3- and DFC3-based forwarding, e.g., L2, IP, MPLS
Supervisor Engine 720, -3B, -3BXL
DFC3, DFC3B, DFC3BXL
OSM, Enhanced OSM
FlexWAN, Enhanced FlexWAN, SIP-200, SIP-400
Features available through 12.2(18)SXD
• Excludes
OSM- and FlexWAN-based forwarding, e.g., AToM
Supervisor Engine 2
DFC

© 2005 Cisco Systems, Inc. All rights reserved. 2


QoS Architecture
Terminology

• PFC3 PFC3A, PFC3B, PFC3BXL


• DFC3 DFC3, DFC3B, DFC3BXL
• OSM OSM, Enhanced OSM
• FlexWAN FlexWAN, Enhanced FlexWAN

© 2005 Cisco Systems, Inc. All rights reserved. 3


QoS Architecture
Agenda

• QoS Architecture
• QoS Command Sets
• Class of Service
• Internal Classification

© 2005 Cisco Systems, Inc. All rights reserved. 4


QoS Architecture

© 2005 Cisco Systems, Inc. All rights reserved. 5


Animated
QoS Architecture
Distributed QoS

Forwarding
Tables 16 Gbps Shared Bus
16 16
MSFC3
Classic CEF256 dCEF256 16
Linecard Linecard Linecard
PFC3

Fabric
Arbitration
dCEF720 CEF720
Linecard 8 8 8 Linecard
Net MGMT
NMP 20 20 20 20

Crossbar

Supervisor
Where QoS Lives
© 2005 Cisco Systems, Inc. All rights reserved. 6
QoS Architecture
Application

• Cisco 7600 distributes QoS features across the Supervisor Engine and
the line cards
• Each line card family is designed to provide the QoS features applicable
to its role, e.g., WAN cards have deeper buffers and more features than
LAN cards, while the simpler LAN cards are less expensive
• Knowing the ingress and egress line cards will tell you what QoS
features are available to you.
• Or vice versa, determine the QoS features you need, then select the
appropriate line cards.

© 2005 Cisco Systems, Inc. All rights reserved. 7


QoS Architecture
Distribution of Features

• PFC3 on Sup720
Centralized forwarding for Catalyst, OSM, and FlexWAN line cards
Centralized policing and marking for Catalyst and OSM line cards
No packet buffer or queuing capabilities
• Catalyst LAN ports
Distributed packet buffering, queuing, scheduling
Hardware-based queues
Strict priority, WRR, DWWR, WRED
• OSM WAN ports
Distributed packet buffering, queuing, scheduling
Software-definable queues
Shaping
CBWFQ, LLQ, WRED (Enhanced OSMs)
• FlexWAN, SIP-200, SIP-400 ports
Fully distributed QoS; no dependencies on PFC3-based QoS
Policing, marking
Packet buffering, queuing, scheduling
Software-definable queues
CBWFQ, LLQ, Shaping, WRED, etc.
WFQ (FlexWAN, SIP-200)

© 2005 Cisco Systems, Inc. All rights reserved. 8


QoS Architecture
QoS Model

1 2 3

Catalyst LAN Port Supervisor 720 Catalyst LAN Port

Frame Ingress Egress


QoS QoS

Ingress QoS

Egress QoS
PFC3

PFC3
OSM WAN Port OSM WAN Port

Forwarding
Frame

PFC3
Ingress Egress
QoS QoS

FlexWAN, SIP-200, FlexWAN, SIP-200,


SIP-400 Port SIP-400 Port

Frame Ingress Egress


QoS QoS

© 2005 Cisco Systems, Inc. All rights reserved. 9


Animated
QoS Architecture
Example: QoS Model

1 2 3

Catalyst LAN Port Supervisor 720 Catalyst LAN Port

Frame Ingress Egress


QoS QoS

Ingress QoS

Egress QoS
PFC3

PFC3
OSM WAN Port OSM WAN Port

Forwarding
Frame

PFC3
Ingress Egress
QoS QoS

FlexWAN, SIP-200, FlexWAN, SIP-200,


SIP-400 Port SIP-400 Port

Frame Ingress Egress


QoS QoS

© 2005 Cisco Systems, Inc. All rights reserved. 10


Animated
QoS Architecture
Example: QoS Model

3 2 1

Catalyst LAN Port Supervisor 720 Catalyst LAN Port

Egress Ingress Frame


QoS QoS

Ingress QoS
Egress QoS
PFC3

PFC3
OSM WAN Port OSM WAN Port

Forwarding
PFC3
Egress Ingress Frame
QoS QoS

FlexWAN, SIP-200, FlexWAN, SIP-200,


SIP-400 Port SIP-400 Port

Frame
Egress Ingress
QoS QoS

© 2005 Cisco Systems, Inc. All rights reserved. 11


Animated
QoS Architecture
Example: QoS Model

1 2 3

Catalyst LAN Port Supervisor 720 Catalyst LAN Port

Frame Ingress Egress


QoS QoS

Ingress QoS

Egress QoS
PFC3

PFC3
OSM WAN Port OSM WAN Port

Forwarding
Frame

PFC3
Ingress Egress
QoS QoS

FlexWAN, SIP-200, FlexWAN, SIP-200,


SIP-400 Port SIP-400 Port

Frame Ingress Egress


QoS QoS

© 2005 Cisco Systems, Inc. All rights reserved. 12


Animated
QoS Architecture
Example: QoS Model

3 2 1

Catalyst LAN Port Supervisor 720 Catalyst LAN Port

Egress Ingress Frame


QoS QoS

Ingress QoS
Egress QoS
PFC3

PFC3
OSM WAN Port OSM WAN Port

Forwarding
PFC3
Egress Ingress Frame
QoS QoS

FlexWAN, SIP-200, FlexWAN, SIP-200,


SIP-400 Port SIP-400 Port

Frame
Egress Ingress
QoS QoS

© 2005 Cisco Systems, Inc. All rights reserved. 13


QoS Architecture Very Strong
Advantage
Scaleable QoS

• PFC3
Centralized marking and policing
ASIC implementation
Up to 30 Mpps forwarding rate
No throughput degradation when applying QoS
• Catalyst Line Card
Distributed port QoS
ASIC implementation
Line rate performance
No throughput degradation when applying QoS

© 2005 Cisco Systems, Inc. All rights reserved. 14


QoS Architecture Very Strong
Advantage
Scalable QoS, continued

• Enhanced OSM
Distributed port QoS
PXF implementation
Up to OC-48 throughput rate
In most cases, minimal throughput degradation when applying QoS
• FlexWAN, SIP-200
Distributed IOS – policing, marking, port QoS
Processor-based implementation (one per PA)
Some throughput degradation when applying QoS
• SIP-400
Distributed IOS – policing, marking, port QoS
Network processor-based implementation
In most cases, little or no degradation when applying QoS

© 2005 Cisco Systems, Inc. All rights reserved. 15


QoS Command Sets

© 2005 Cisco Systems, Inc. All rights reserved. 16


QoS Command Sets
MQC vs. MLS QoS

• Modular QoS CLI (MQC)


Standard CLI across all main Cisco IOS-based platforms
PFC3-based policing & marking
OSM WAN, FlexWAN, SIP-200, SIP-400 based QoS
• Multilayer Switching (MLS) CLI
Hardware-specific command syntax
PFC3-based trust, markdown, maps, more
Catalyst LAN card-based QoS

© 2005 Cisco Systems, Inc. All rights reserved. 17


QoS Command Sets
MQC vs. MLS CLI

Modular QoS CLI MLS CLI

PFC3 Policing, Marking QoS mode, Markdown, Maps,


etc.

Catalyst Card-based QoS n/a Queueing, Scheduling

OSM-based QoS Queueing, Scheduling Trust

FlexWAN, SIP-200 and SIP-400 All QoS n/a


based QoS

© 2005 Cisco Systems, Inc. All rights reserved. 18


QoS Command Sets
Modular QoS CLI

class-map
Router(config)# class-map <match-all | match-any> class-map-name
Router(config-cmap)# match <access-group | ip precedence | ip dscp | mpls exp |...>

policy-map
Router(config)# policy-map policy-map-name
Router(config-pmap)# class class-name
Router(config-pmap-c)# <bandwidth | police | shape | random-detect | set | queue-limit
|...>

service-policy
Router(config)# interface interface-name
Router(config-if)# service-policy <input | output> policy-map-name

© 2005 Cisco Systems, Inc. All rights reserved. 19


QoS Command Sets
MLS QoS CLI

mls qos
! Several different global & interface commands
Router(config)# mls qos ...
Router(config-if)# mls qos ...
Router(config-subif)# mls qos ...

rcv-queue
Router(config-if)# rcv-queue <cos-map | queue-limit | random-detect | threshold> ...

wrr-queue
Router(config-if)# wrr-queue <bandwidth | cos-map | queue-limit | random-detect |
threshold> ...

priority-queue
Router(config-if)# priority-queue cos-map ...

© 2005 Cisco Systems, Inc. All rights reserved. 20


Class of Service

© 2005 Cisco Systems, Inc. All rights reserved. 21


Class of Service
Ethernet Tag

0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

48-bit Destination MAC Address

48-bit Source MAC Address

C
3-bit
16-bit Ethertype (0x8100) F 12-bit VLAN ID
Prio I

16-bit Length/Type Data (variable) 802.1q


Tag
Data (variable) Pad (variable)

32-bit FCS

802.1p User Priority


3 bits wide; values 0–7

© 2005 Cisco Systems, Inc. All rights reserved. 22


Class of Service
MPLS Label

0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

20-bit Label EXP S TTL

MPLS EXP
3 bits wide; values 0–7

© 2005 Cisco Systems, Inc. All rights reserved. 23


Class of Service
IP Header

0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
4-bit 4-bit
8-bit TOS 16-bit Total Length
Version Hdr Len
3-bit
16-bit Indentification 13-bit Fragment Offset
Flags

8-bit TTL 8-bit Protocol 16-bit Header Checksum

32-bit Source IP Address

32-bit Destination IP Address

Options (if any)

Data

Type of Service byte


IPP or DSCP

© 2005 Cisco Systems, Inc. All rights reserved. 24


Class of Service
IP TOS Byte

Type of Service format


8 9 10 11 12 13 14 15

3-bit Precedence 4-bit Type of Service 0

IP Precedence
3 bits wide; values 0–7

Differentiated Services format


8 9 10 11 12 13 14 15

6-bit Differentiated Services Control Point 2-bit Unused

DSCP
6 bits wide; values 0–63

© 2005 Cisco Systems, Inc. All rights reserved. 25


Class of Service
Putting It All Together

802.1q EXP 3 bit IPP


3 bits 3 bits 6 bit DSCP

Ethernet MPLS IP IP Ethernet


Header Label Header Payload FCS

802.1p EXP IP Prec DSCP ToS

0 0 0 0 0x00

1 1 1 8 0x20

2 2 2 16 0x40

3 3 3 24 0x60

4 4 4 32 0x80

5 5 5 40 0xA0

6 6 6 48 0xC0

7 7 7 56 0xE0

© 2005 Cisco Systems, Inc. All rights reserved. 26


Internal Classification

© 2005 Cisco Systems, Inc. All rights reserved. 27


Internal Classification
Introduction

• Internal classification is the assignment and handling of


the internal parameters identifying the class of service
for a frame.
• These parameters are the input CoS, the internal dscp
and the output CoS.

© 2005 Cisco Systems, Inc. All rights reserved. 28


Animated
Internal Classification
Big Picture

Line Card PFC3B Line Card

Input
CoS internal Output
dscp CoS

Trust
State QoS Result
Function Function
Frame Packet Packet Result Frame
Header Header Header

IOS Config
Legend
Frame data is in blue text.
Config is in italics.
Internal classification is in

© 2005 Cisco Systems, Inc. All rights reserved. 29


Animated
Internal Classification
Example: L2 Switching

Line Card PFC3B Line Card

Input
CoS internal Output
dscp CoS

trust cos QoS Result


Function Function
802.1p = 1 802.1p = 1
DSCP=46 Packet Packet Result Frame DSCP = 8
Header Header Header

mls qos

mls qos

interface GigabitEthernet7/1 interface GigabitEthernet7/2


description Ingress Interface description Ingress Interface
no ip address no ip address
switchport switchport
switchport trunk encapsulation dot1q switchport trunk encapsulation dot1q
switchport mode trunk switchport mode trunk
mls qos trust cos

© 2005 Cisco Systems, Inc. All rights reserved. 30


Animated
Internal Classification
Example: IP Routing

Line Card PFC3B Line Card

Input
CoS internal Output
dscp CoS

trust dscp QoS Result


Function Function
802.1p = 1 802.1p = 5
DSCP=46 Packet Packet Result Frame DSCP=46
Header Header Header

mls qos

mls qos

interface GE-WAN3/1.31 interface GigabitEthernet4/2.42


description Ingress interface description Egress Interface
encapsulation dot1Q 31 encapsulation dot1Q 42
ip address 192.85.2.1 255.255.255.0 ip address 10.0.3.2 255.255.255.0
mls qos trust dscp

© 2005 Cisco Systems, Inc. All rights reserved. 31


Animated
Internal Classification
Example: MPLS Imposition

Line Card PFC3B Line Card

Input
CoS internal Output
dscp CoS

trust dscp QoS Result


Function Function 802.1p = 5
802.1p = 1
EXP = 5
DSCP=46 Packet Packet Result Frame
Header Header Header DSCP=46

mls qos

mls qos

interface GE-WAN3/1.31 interface GigabitEthernet4/2.42


description Ingress interface description Egress Interface
encapsulation dot1Q 31 encapsulation dot1Q 42
ip address 192.85.2.1 255.255.255.0 ip address 10.0.3.2 255.255.255.0
mls qos trust dscp tag-switching ip

© 2005 Cisco Systems, Inc. All rights reserved. 32


Animated
Internal Classification
Troubleshooting

Line Card PFC3B Line Card

Input
CoS internal Output
dscp CoS

trust ip-prec QoS Result


Function Function 802.1p = 5
802.1p = 1
EXP = 5
DSCP=46 Packet Packet Result Frame
Header Header Header DSCP=46

mls qos

pe2#sh mls qos last


----- Module [5] -----
QoS last packet policing information:
------------------------------------------------------------------
Packet was transmitted
Packet L3 Prot: 0, packet length: 508, dont_plc: No
Input COS: 1, TOS/DSCP: 0xB8/46
Output TOS/DSCP: 0xB8/46[unchanged] Output COS: 5[rewritten]
Output MPLS EXP (if outgoing packet is MPLS): 5
……………………………………………………………………………………………………………………………………………
……………………………………………………tos_i: 0xB8…………………………………………………………

© 2005 Cisco Systems, Inc. All rights reserved. 33


Animated
Internal Classification
Internal dscp Maps

Line Card PFC3B Line Card

Input
CoS internal Output
cos-> dscp dscp CoS
dscp ->cos
Trust ipp->
State dscp
exp-> dscp
Frame Packet dscp Packet ->exp Result Frame
Header Header Header
QoS Result
Function Function

IOS Config
Legend
Frame data is in blue text.
Config is in italics.
Internal classification is in

© 2005 Cisco Systems, Inc. All rights reserved. 34


DFC3

© 2005 Cisco Systems, Inc. All rights reserved. 35


QoS Architecture
QoS Model: Distributed DFC3

1 2 3

Catalyst LAN Port DFC3 Catalyst LAN Port


(CFC)

Forwarding
Ingress

Egress
DFC3
DFC3
Frame Ingress Egress

QoS
QoS

DFC3
QoS QoS

OSM WAN Port

Egress
QoS

FlexWAN, SIP-200,
SIP-400 Port

Egress
QoS

© 2005 Cisco Systems, Inc. All rights reserved. 36


QoS Architecture
QoS Model: Distributed DFC3

3 2 1

Catalyst LAN Port DFC3 Catalyst LAN Port


(CFC)

Egress Ingress Frame


QoS QoS

OSM WAN Port

Ingress Frame

Ingress QoS
Egress QoS

QoS
PFC3

PFC3
Forwarding
PFC3
FlexWAN, SIP-200,
SIP-400 Port

Ingress Frame
QoS

Supervisor 720

© 2005 Cisco Systems, Inc. All rights reserved. 37


MPLS DiffServ Tunneling Modes

© 2005 Cisco Systems, Inc. All rights reserved. 38


MPLS DiffServ Tunneling Modes
Overview

• Short Pipe Mode


• Pipe Mode
• Pipe Mode with Explicit NULL LSP
• Uniform Mode

© 2005 Cisco Systems, Inc. All rights reserved. 39


Short Pipe Mode
Architecture

Customer Customer
Diff-Serv Domain Service Provider Diff-Serv Domain Diff-Serv Domain

IP MPLS IP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

• Allows a customer’s Diff-Serv domain on both edges of the service provider network
• Uses IP ToS-based QoS on the output i/f of PE2

© 2005 Cisco Systems, Inc. All rights reserved. 40


Short Pipe Mode
Architecture

12 EXP 16 EXP
QoS
23 EXP 23 EXP 23 EXP
IPP IPP IPP IPP IPP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

Input QoS Egress QoS


determines based on
EXP IPP

Original Original
IPP is IPP is
Short Pipe preserved preserved
Mode
Behavior

© 2005 Cisco Systems, Inc. All rights reserved. 41


Pipe Mode
Architecture

Customer Customer
Diff-Serv Domain Service Provider Diff-Serv Domain Diff-Serv Domain

IP MPLS IP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

• Extends the service provider’s Diff-Serv Domain to the output i/f of PE2
• Uses EXP-based QoS on the output i/f of PE2 even though the packet is transmitted as
an IP packet
• Allows scalability by eliminating per customer configuration in PE2

© 2005 Cisco Systems, Inc. All rights reserved. 42


Pipe Mode
Architecture

12 EXP 16 EXP
QoS
23 EXP 23 EXP 23 EXP
IPP IPP IPP IPP IPP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

Input QoS Egress QoS


determines based on
EXP EXP

Original Original
IPP is IPP is
preserved preserved
Pipe Mode
Behavior
© 2005 Cisco Systems, Inc. All rights reserved. 43
Pipe Mode with Explicit NULL LSP
Architecture

Customer
Cust. Service Provider Diff-Serv Domain Diff-Serv Domain

IP MPLS IP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

• Extends the service provider’s Diff-Serv Domain to managed CEs


• Assigns EXP in the managed CE1 and passes it to PE1 in an explicit NULL label
• Uses EXP-based QoS on the output i/f of PE2 even though the packets transmitted are
IP packets
• Allows scalability by eliminating per customer configuration on the PEs

© 2005 Cisco Systems, Inc. All rights reserved. 44


Pipe Mode with Explicit NULL LSP
Architecture

QoS 12 EXP 16 EXP


0 EXP 23 EXP 23 EXP 23 EXP
IPP IPP IPP IPP IPP IPP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

Input QoS EXP copied Egress QoS


determines to imposed based on
EXP labels EXP

Original Original
IPP is IPP is
preserved preserved
Pipe Mode
Behavior

© 2005 Cisco Systems, Inc. All rights reserved. 45


Uniform Mode
Architecture

Diff-Serv Domain

IP MPLS IP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

• Maintains a uniform Diff-Serv Domain across the IP and MPLS networks


• When popping a label, propagates EXP to the exposed label (mpls2mpls) or IP packet
(mpls2ip)
• Uses IP ToS-based QoS on the output i/f of PE2

© 2005 Cisco Systems, Inc. All rights reserved. 46


Uniform Mode
Architecture

QoS

12 EXP 16 EXP
23 EXP 23 EXP 23 EXP
IPP IPP IPP IPP IPP

A B C D E F G

CE1 PE1 P1 P2 PE2 CE2

IPP is If IGP … it is Egress QoS


copied EXP is copied to based on
to EXP recolored, BGP EXP propagated
then ... Class of
Service
(EXP->IPP)
Uniform
Mode
Behavior

© 2005 Cisco Systems, Inc. All rights reserved. 47


Q and A

© 2005 Cisco Systems, Inc. All rights reserved. 48


© 2005 Cisco Systems, Inc. All rights reserved. 49